Api.Framework 命名空间

[缺少 "N:Api.Framework" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | ApiClient | Api端功能集合
公共类 | CpsClient | Cps管理端
公共类 | EventClient | 事件管理
公共类 | PluginClient | 插件管理
公共类 | WebClient | web管理
公共类 | WebClientResult | 响应结果
公共类 | WebClientUtil |
枚举
 | 枚举 | 说明
公共枚举 | ApiClientQrImageType | 合成海报模板


ApiClient 类

Api端功能集合
继承层次
SystemObject
Api.FrameworkApiClient

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ApiClient

ApiClient 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ApiClient | 初始化 ApiClient 类的一个新实例
Top
属性
名称 | 说明
Cache | 缓存
CurVersion | 当前版本
Server | Socket服务
Setting | 配置
Top
方法
 | 名称 | 说明
 | CreateTables | 创建表,没有表则创建
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCouponImage | 合成优惠券图
 | GetCouponImage2 | 合成优惠券图(新版)
公共方法 | GetHashCode | (继承自 Object。)
 | GetQRImage | 合成二维码
 | GetServerConfig |
 | GetSession | 获取数据库操作对象
公共方法 | GetType | (继承自 Object。)
 | Initialization | 初始化
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | SelectDbbase | 判断是否已经配置数据库
 | SendAdminEmail(String, String, String, Boolean, Boolean) | 发送邮件
 | SendAdminEmail(String, String, String, String, Boolean, Boolean) | 发送邮件
 | SendAdminMessage | 发送信息
 | SendMessage(temp_send_data) | 发送消息
 | SendMessage(fl_robot_info, String, String, Boolean) | 发送消息
 | SendMessage(fl_robot_info, String, String, String) | 发送消息1
 | SendMessage(String, ChatType, String, String, String) | 发送消息
 | SendNewDingdingMessage | 通知钉钉机器人
 | SendNoticeMessage(String, String) | 发送通知【钉钉/微信群机器人】消息
 | SendNoticeMessage(fl_noticeapi_info, String, Boolean) | 通知机器人发送消息
 | SendWechatPay(Object, String, Double) | 已过时。 商户支付
 | SendWechatPay(Object, String, Double, Boolean) | 发视商户支付
 | SendWechatPay(Object, String, Double, Boolean, Object) | 发送商户支付
 | ShortURL(String) | 缩短网址 - 根据配置的短网址类型
 | ShortURL(String, DwzType) | 缩短网址 - 自定义短网址类型
 | SocketInitialization | 服务端Socket启动
 | StartSocketServer | 启动Socket服务
 | StopSocketServer | 关闭Socket服务
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework 命名空间


ApiClient 构造函数

初始化 ApiClient 类的一个新实例

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ApiClient()
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient 属性

ApiClient 类型公开以下成员。

属性
名称 | 说明
Cache | 缓存
CurVersion | 当前版本
Server | Socket服务
Setting | 配置
Top
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.Cache 属性

A Sandcastle Documented Class Library

ApiClientCache 属性

缓存

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static CacheTool Cache { get; }

属性值

类型：CacheTool
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.CurVersion 属性

ApiClientCurVersion 属性

当前版本

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Version CurVersion { get; }

属性值

类型：Version
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.Server 属性

ApiClientServer 属性

Socket服务

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static AppServer Server { get; }

属性值

类型：AppServer
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.Setting 属性

ApiClientSetting 属性

配置

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Setting Setting { get; set; }

属性值

类型：Setting
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient 方法

ApiClient 类型公开以下成员。

方法
 | 名称 | 说明
 | CreateTables | 创建表,没有表则创建
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCouponImage | 合成优惠券图
 | GetCouponImage2 | 合成优惠券图(新版)
公共方法 | GetHashCode | (继承自 Object。)
 | GetQRImage | 合成二维码
 | GetServerConfig |
 | GetSession | 获取数据库操作对象
公共方法 | GetType | (继承自 Object。)
 | Initialization | 初始化
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | SelectDbbase | 判断是否已经配置数据库
 | SendAdminEmail(String, String, String, Boolean, Boolean) | 发送邮件
 | SendAdminEmail(String, String, String, String, Boolean, Boolean) | 发送邮件
 | SendAdminMessage | 发送信息
 | SendMessage(temp_send_data) | 发送消息
 | SendMessage(fl_robot_info, String, String, Boolean) | 发送消息
 | SendMessage(fl_robot_info, String, String, String) | 发送消息1
 | SendMessage(String, ChatType, String, String, String) | 发送消息
 | SendNewDingdingMessage | 通知钉钉机器人
 | SendNoticeMessage(String, String) | 发送通知【钉钉/微信群机器人】消息
 | SendNoticeMessage(fl_noticeapi_info, String, Boolean) | 通知机器人发送消息
 | SendWechatPay(Object, String, Double) | 已过时。 商户支付
 | SendWechatPay(Object, String, Double, Boolean) | 发视商户支付
 | SendWechatPay(Object, String, Double, Boolean, Object) | 发送商户支付
 | ShortURL(String) | 缩短网址 - 根据配置的短网址类型
 | ShortURL(String, DwzType) | 缩短网址 - 自定义短网址类型
 | SocketInitialization | 服务端Socket启动
 | StartSocketServer | 启动Socket服务
 | StopSocketServer | 关闭Socket服务
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.CreateTables 方法

ApiClientCreateTables 方法

创建表,没有表则创建

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool CreateTables(
    SqlSugarClient session
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.ApiClient.CreateTables(SqlSugar.SqlSugarClient)" 的 <param name="session"/> 文档]

返回值

类型：Boolean
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.GetCouponImage 方法

ApiClientGetCouponImage 方法

合成优惠券图

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetCouponImage(
    string image,
    string shopname,
    string shopimage,
    string couponprice,
    string indate,
    string basePath = ""
)

参数

image
类型：SystemString
优惠券底图
shopname
类型：SystemString
店铺名称
shopimage
类型：SystemString

[缺少 "M:Api.Framework.ApiClient.GetCouponImage(System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="shopimage"/> 文档]

couponprice
类型：SystemString
优惠券金额
indate
类型：SystemString
优惠券有效期区间(2018.02.12 - 2018.03.12)
basePath (Optional)
类型：SystemString
图片保存路径

返回值

类型：String
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.GetCouponImage2 方法

ApiClientGetCouponImage2 方法

合成优惠券图(新版)

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetCouponImage2(
    string image,
    string shopname,
    Image shopimage,
    string title,
    string price,
    string couponprice,
    Image itemimage,
    string indate,
    string sellcount,
    string basePath = ""
)

参数

image
类型：SystemString
优惠券底图
shopname
类型：SystemString
店铺名称
shopimage
类型：System.DrawingImage
店铺头像
title
类型：SystemString
宝贝标题
price
类型：SystemString
宝贝原价
couponprice
类型：SystemString
优惠券金额
itemimage
类型：System.DrawingImage
宝贝图片
indate
类型：SystemString
优惠券有效期区间(2018.02.12 - 2018.03.12)
sellcount
类型：SystemString
月销量
basePath (Optional)
类型：SystemString
图片保存路径

返回值

类型：String
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.GetQRImage 方法

ApiClientGetQRImage 方法

合成二维码

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetQRImage(
    string title,
    string price,
    string cprice,
    string nprice,
    string image,
    string link,
    ApiClientQrImageType type = ApiClientQrImageType.模板B,
    CpsType cps = CpsType.阿里妈妈,
    string content = "",
    string basePath = ""
)

参数

title
类型：SystemString
标题
price
类型：SystemString
价格
cprice
类型：SystemString
券价格
nprice
类型：SystemString
券后价格
image
类型：SystemString
图片地址
link
类型：SystemString
生成二维码的链接
type (Optional)
类型：Api.FrameworkApiClientQrImageType
使用的模板
cps (Optional)
类型：Api.Framework.EnumsCpsType
联盟类型,自动填写内容
content (Optional)
类型：SystemString
底栏内容
basePath (Optional)
类型：SystemString
保存路径

返回值

类型：String
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.GetServerConfig 方法

ApiClientGetServerConfig 方法

[缺少 "M:Api.Framework.ApiClient.GetServerConfig(System.String)" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetServerConfig(
    string key
)

参数

key
类型：SystemString

[缺少 "M:Api.Framework.ApiClient.GetServerConfig(System.String)" 的 <param name="key"/> 文档]

返回值

类型：String
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.GetSession 方法

ApiClientGetSession 方法

获取数据库操作对象

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static SqlSugarClient GetSession(
    ConnectionConfig config = null,
    bool iscache = true
)

参数

config (Optional)
类型：Api.Framework.ToolsConnectionConfig
数据库连接配置,如果是软件的数据库该值不需要传
iscache (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.ApiClient.GetSession(Api.Framework.Tools.ConnectionConfig,System.Boolean)" 的 <param name="iscache"/> 文档]

返回值

类型：SqlSugarClient
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.Initialization 方法

ApiClientInitialization 方法

初始化

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool Initialization()

返回值

类型：Boolean
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.SelectDbbase 方法

ApiClientSelectDbbase 方法

判断是否已经配置数据库

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool SelectDbbase()

返回值

类型：Boolean
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.SendAdminEmail 方法

ApiClientSendAdminEmail 方法

重载列表
名称 | 说明
SendAdminEmail(String, String, String, Boolean, Boolean) | 发送邮件
SendAdminEmail(String, String, String, String, Boolean, Boolean) | 发送邮件
Top
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.SendAdminEmail 方法 (String, String, String, Boolean, Boolean)

ApiClientSendAdminEmail 方法 (String, String, String, Boolean, Boolean)

发送邮件

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SendAdminEmail(
    string toemail,
    string title,
    string content,
    bool tryException = false,
    bool begin = true
)

参数

toemail
类型：SystemString
收件人
title
类型：SystemString
标题
content
类型：SystemString
内容
tryException (Optional)
类型：SystemBoolean
捕获
begin (Optional)
类型：SystemBoolean
异步
参见

引用

ApiClient 类
SendAdminEmail 重载
Api.Framework 命名空间


ApiClient.SendAdminEmail 方法 (String, String, String, String, Boolean, Boolean)

ApiClientSendAdminEmail 方法 (String, String, String, String, Boolean, Boolean)

发送邮件

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SendAdminEmail(
    string toemail,
    string title,
    string content,
    string file,
    bool tryException = false,
    bool begin = true
)

参数

toemail
类型：SystemString
收件人
title
类型：SystemString
标题
content
类型：SystemString
内容
file
类型：SystemString

[缺少 "M:Api.Framework.ApiClient.SendAdminEmail(System.String,System.String,System.String,System.String,System.Boolean,System.Boolean)" 的 <param name="file"/> 文档]

tryException (Optional)
类型：SystemBoolean
捕获
begin (Optional)
类型：SystemBoolean
异步
参见

引用

ApiClient 类
SendAdminEmail 重载
Api.Framework 命名空间


ApiClient.SendAdminMessage 方法

ApiClientSendAdminMessage 方法

发送信息

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SendAdminMessage(
    string message,
    fl_robot_info robot,
    string title = "系统消息"
)

参数

message
类型：SystemString
消息内容
robot
类型：Api.Framework.Modelfl_robot_info
通过哪个机器人发送
title (Optional)
类型：SystemString

[缺少 "M:Api.Framework.ApiClient.SendAdminMessage(System.String,Api.Framework.Model.fl_robot_info,System.String)" 的 <param name="title"/> 文档]

参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.SendMessage 方法

ApiClientSendMessage 方法

重载列表
名称 | 说明
SendMessage(temp_send_data) | 发送消息
SendMessage(fl_robot_info, String, String, Boolean) | 发送消息
SendMessage(fl_robot_info, String, String, String) | 发送消息1
SendMessage(String, ChatType, String, String, String) | 发送消息
Top
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.SendMessage 方法 (temp_send_data[])

ApiClientSendMessage 方法 (temp_send_data)

发送消息

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Task SendMessage(
    params temp_send_data[] data
)

参数

data
类型：Api.Framework.Modeltemp_send_data
temp_send_data对象集合

返回值

类型：Task
参见

引用

ApiClient 类
SendMessage 重载
Api.Framework 命名空间


ApiClient.SendMessage 方法 (fl_robot_info, String, String, Boolean)

ApiClientSendMessage 方法 (fl_robot_info, String, String, Boolean)

发送消息

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Task SendMessage(
    fl_robot_info robot,
    string tousername,
    string message,
    bool isTemp
)

参数

robot
类型：Api.Framework.Modelfl_robot_info
机器人对象
tousername
类型：SystemString
接收者账号
message
类型：SystemString
消息
isTemp
类型：SystemBoolean
机器人为QQ时,临时聊天需要复制为true

返回值

类型：Task
参见

引用

ApiClient 类
SendMessage 重载
Api.Framework 命名空间


ApiClient.SendMessage 方法 (fl_robot_info, String, String, String)

ApiClientSendMessage 方法 (fl_robot_info, String, String, String)

发送消息1

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Task SendMessage(
    fl_robot_info robot,
    string tousername,
    string message,
    string groupid = ""
)

参数

robot
类型：Api.Framework.Modelfl_robot_info
机器人
tousername
类型：SystemString
发送给谁
message
类型：SystemString

[缺少 "M:Api.Framework.ApiClient.SendMessage(Api.Framework.Model.fl_robot_info,System.String,System.String,System.String)" 的 <param name="message"/> 文档]

groupid (Optional)
类型：SystemString

[缺少 "M:Api.Framework.ApiClient.SendMessage(Api.Framework.Model.fl_robot_info,System.String,System.String,System.String)" 的 <param name="groupid"/> 文档]

返回值

类型：Task
参见

引用

ApiClient 类
SendMessage 重载
Api.Framework 命名空间


ApiClient.SendMessage 方法 (String, ChatType, String, String, String)

ApiClientSendMessage 方法 (String, ChatType, String, String, String)

发送消息

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SendMessage(
    string robot_name,
    ChatType robot_type,
    string tousername,
    string message,
    string groupid = ""
)

参数

robot_name
类型：SystemString
机器人账号
robot_type
类型：Api.Framework.SDKChatType
机器人类型
tousername
类型：SystemString
发送给谁
message
类型：SystemString
发送消息内容
groupid (Optional)
类型：SystemString
发送的群号
参见

引用

ApiClient 类
SendMessage 重载
Api.Framework 命名空间


ApiClient.SendNewDingdingMessage 方法

ApiClientSendNewDingdingMessage 方法

通知钉钉机器人

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SendNewDingdingMessage(
    string _message,
    string api = "",
    string secret = ""
)

参数

_message
类型：SystemString
发送消息
api (Optional)
类型：SystemString
通知机器人名称
secret (Optional)
类型：SystemString
secret字符串
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.SendNoticeMessage 方法

ApiClientSendNoticeMessage 方法

重载列表
名称 | 说明
SendNoticeMessage(String, String) | 发送通知【钉钉/微信群机器人】消息
SendNoticeMessage(fl_noticeapi_info, String, Boolean) | 通知机器人发送消息
Top
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.SendNoticeMessage 方法 (String, String)

ApiClientSendNoticeMessage 方法 (String, String)

发送通知【钉钉/微信群机器人】消息

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SendNoticeMessage(
    string message,
    string name = ""
)

参数

message
类型：SystemString
消息内容
name (Optional)
类型：SystemString
名称,为空为系统设置
参见

引用

ApiClient 类
SendNoticeMessage 重载
Api.Framework 命名空间


ApiClient.SendNoticeMessage 方法 (fl_noticeapi_info, String, Boolean)

ApiClientSendNoticeMessage 方法 (fl_noticeapi_info, String, Boolean)

通知机器人发送消息

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SendNoticeMessage(
    fl_noticeapi_info api_entity,
    string message,
    bool is_begin = true
)

参数

api_entity
类型：Api.Framework.Modelfl_noticeapi_info
通知机器人对象
message
类型：SystemString
发送消息
is_begin (Optional)
类型：SystemBoolean
异步发送
参见

引用

ApiClient 类
SendNoticeMessage 重载
Api.Framework 命名空间


ApiClient.SendWechatPay 方法

ApiClientSendWechatPay 方法

重载列表
名称 | 说明
SendWechatPay(Object, String, Double) | 已过时。 商户支付
SendWechatPay(Object, String, Double, Boolean) | 发视商户支付
SendWechatPay(Object, String, Double, Boolean, Object) | 发送商户支付
Top
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.SendWechatPay 方法 (Object, String, Double)

ApiClientSendWechatPay 方法 (Object, String, Double)

注意：此 API 现在已过时。

商户支付

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
[ObsoleteAttribute("改方法已过时")]
public static string SendWechatPay(
    Object remark,
    string describe,
    double money
)

参数

remark
类型：SystemObject

[缺少 "M:Api.Framework.ApiClient.SendWechatPay(System.Object,System.String,System.Double)" 的 <param name="remark"/> 文档]

describe
类型：SystemString

[缺少 "M:Api.Framework.ApiClient.SendWechatPay(System.Object,System.String,System.Double)" 的 <param name="describe"/> 文档]

money
类型：SystemDouble

[缺少 "M:Api.Framework.ApiClient.SendWechatPay(System.Object,System.String,System.Double)" 的 <param name="money"/> 文档]

返回值

类型：String
返回 连接为点击领取 返回 "已转账"为自动转账 返回 空为异常
参见

引用

ApiClient 类
SendWechatPay 重载
Api.Framework 命名空间


ApiClient.SendWechatPay 方法 (Object, String, Double, Boolean)

ApiClientSendWechatPay 方法 (Object, String, Double, Boolean)

发视商户支付

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string SendWechatPay(
    Object remark,
    string describe,
    double money,
    out bool ispaid
)

参数

remark
类型：SystemObject

[缺少 "M:Api.Framework.ApiClient.SendWechatPay(System.Object,System.String,System.Double,System.Boolean@)" 的 <param name="remark"/> 文档]

describe
类型：SystemString

[缺少 "M:Api.Framework.ApiClient.SendWechatPay(System.Object,System.String,System.Double,System.Boolean@)" 的 <param name="describe"/> 文档]

money
类型：SystemDouble

[缺少 "M:Api.Framework.ApiClient.SendWechatPay(System.Object,System.String,System.Double,System.Boolean@)" 的 <param name="money"/> 文档]

ispaid
类型：SystemBoolean

[缺少 "M:Api.Framework.ApiClient.SendWechatPay(System.Object,System.String,System.Double,System.Boolean@)" 的 <param name="ispaid"/> 文档]

返回值

类型：String
参见

引用

ApiClient 类
SendWechatPay 重载
Api.Framework 命名空间


ApiClient.SendWechatPay 方法 (Object, String, Double, Boolean, Object)

ApiClientSendWechatPay 方法 (Object, String, Double, Boolean, Object)

发送商户支付

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string SendWechatPay(
    Object remark,
    string describe,
    double money,
    out bool ispaid,
    out Object appinfo
)

参数

remark
类型：SystemObject
备注
describe
类型：SystemString
描述
money
类型：SystemDouble
金额
ispaid
类型：SystemBoolean
是否直接到账
appinfo
类型：SystemObject
小程序信息,微信可以用户发送小程序;不支持小程序返回null

返回值

类型：String
参见

引用

ApiClient 类
SendWechatPay 重载
Api.Framework 命名空间


ApiClient.ShortURL 方法

ApiClientShortURL 方法

重载列表
名称 | 说明
ShortURL(String) | 缩短网址 - 根据配置的短网址类型
ShortURL(String, DwzType) | 缩短网址 - 自定义短网址类型
Top
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.ShortURL 方法 (String)

ApiClientShortURL 方法 (String)

缩短网址 - 根据配置的短网址类型

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Task<string> ShortURL(
    string url
)

参数

url
类型：SystemString
目标URL

返回值

类型：Task String
参见

引用

ApiClient 类
ShortURL 重载
Api.Framework 命名空间


ApiClient.ShortURL 方法 (String, DwzType)

ApiClientShortURL 方法 (String, DwzType)

缩短网址 - 自定义短网址类型

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Task<string> ShortURL(
    string url,
    DwzType type
)

参数

url
类型：SystemString
目标网址
type
类型：Api.Framework.EnumsDwzType
缩短类型

返回值

类型：Task String
参见

引用

ApiClient 类
ShortURL 重载
Api.Framework 命名空间


ApiClient.SocketInitialization 方法

ApiClientSocketInitialization 方法

服务端Socket启动

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SocketInitialization()
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.StartSocketServer 方法

ApiClientStartSocketServer 方法

启动Socket服务

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool StartSocketServer(
    int port,
    string password
)

参数

port
类型：SystemInt32
端口
password
类型：SystemString
通讯秘钥

返回值

类型：Boolean
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.StopSocketServer 方法

ApiClientStopSocketServer 方法

关闭Socket服务

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void StopSocketServer()
参见

引用

ApiClient 类
Api.Framework 命名空间


ApiClient.QrImageType 枚举

ApiClientQrImageType 枚举

合成海报模板

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum QrImageType
成员
成员名称 | 值 | 说明
模板A | 0 |
模板B | 1 |
模板C | 2 |
参见

引用

Api.Framework 命名空间


CpsClient 类

Cps管理端
继承层次
SystemObject
Api.FrameworkCpsClient

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CpsClient

CpsClient 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CpsClient | 初始化 CpsClient 类的一个新实例
Top
属性
名称 | 说明
Members | 软件登录的cps集合
Top
方法
 | 名称 | 说明
 | CreateAlimamaRequest | 创建一个阿里妈妈API请求
 | CreateDouyinRequest | 创建一个抖音联盟API请求
 | CreateJingdongRequest | 创建一个京东联盟API请求
 | CreatePinduoduoRequest | 创建拼多多API请求
 | CreateWeipinhuiRequest | 创建一个唯品联盟API请求
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | Login | cps登录
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | RefreshCps | 刷新cps缓存
 | SelectTuiguangwei | cps选择推广位
公共方法 | ToString | (继承自 Object。)
 | UpdateOrder | 更新订单
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework 命名空间


CpsClient 构造函数

初始化 CpsClient 类的一个新实例

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CpsClient()
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient 属性

CpsClient 类型公开以下成员。

属性
名称 | 说明
Members | 软件登录的cps集合
Top
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.Members 属性

CpsClientMembers 属性

软件登录的cps集合

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_cps_member> Members { get; }

属性值

类型：List fl_cps_member
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient 方法

CpsClient 类型公开以下成员。

方法
 | 名称 | 说明
 | CreateAlimamaRequest | 创建一个阿里妈妈API请求
 | CreateDouyinRequest | 创建一个抖音联盟API请求
 | CreateJingdongRequest | 创建一个京东联盟API请求
 | CreatePinduoduoRequest | 创建拼多多API请求
 | CreateWeipinhuiRequest | 创建一个唯品联盟API请求
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | Login | cps登录
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | RefreshCps | 刷新cps缓存
 | SelectTuiguangwei | cps选择推广位
公共方法 | ToString | (继承自 Object。)
 | UpdateOrder | 更新订单
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.CreateAlimamaRequest 方法

CpsClientCreateAlimamaRequest 方法

创建一个阿里妈妈API请求

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static AlimamaApi CreateAlimamaRequest(
    fl_cps_member member
)

参数

member
类型：Api.Framework.Modelfl_cps_member
cps对象

返回值

类型：AlimamaApi
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.CreateDouyinRequest 方法

CpsClientCreateDouyinRequest 方法

创建一个抖音联盟API请求

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static DouyinApi CreateDouyinRequest(
    fl_cps_member member
)

参数

member
类型：Api.Framework.Modelfl_cps_member
cps对象

返回值

类型：DouyinApi
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.CreateJingdongRequest 方法

CpsClientCreateJingdongRequest 方法

创建一个京东联盟API请求

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static JingdongApi CreateJingdongRequest(
    fl_cps_member member
)

参数

member
类型：Api.Framework.Modelfl_cps_member
cps对象

返回值

类型：JingdongApi
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.CreatePinduoduoRequest 方法

CpsClientCreatePinduoduoRequest 方法

创建拼多多API请求

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static PinduoduoApi CreatePinduoduoRequest(
    fl_cps_member member
)

参数

member
类型：Api.Framework.Modelfl_cps_member
cps对象

返回值

类型：PinduoduoApi
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.CreateWeipinhuiRequest 方法

CpsClientCreateWeipinhuiRequest 方法

创建一个唯品联盟API请求

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static WeipinhuiApi CreateWeipinhuiRequest(
    fl_cps_member member
)

参数

member
类型：Api.Framework.Modelfl_cps_member
cps对象

返回值

类型：WeipinhuiApi
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.Login 方法

CpsClientLogin 方法

cps登录

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_cps_member Login(
    CpsType type
)

参数

type
类型：Api.Framework.EnumsCpsType
需要登录cps类型

返回值

类型：fl_cps_member
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.RefreshCps 方法

CpsClientRefreshCps 方法

刷新cps缓存

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void RefreshCps()
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.SelectTuiguangwei 方法

CpsClientSelectTuiguangwei 方法

cps选择推广位

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Object SelectTuiguangwei(
    CpsType type,
    bool isalone = true,
    bool isgroup = false,
    bool isactivity = false
)

参数

type
类型：Api.Framework.EnumsCpsType
cps类型
isalone (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.CpsClient.SelectTuiguangwei(Api.Framework.Enums.CpsType,System.Boolean,System.Boolean,System.Boolean)" 的 <param name="isalone"/> 文档]

isgroup (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.CpsClient.SelectTuiguangwei(Api.Framework.Enums.CpsType,System.Boolean,System.Boolean,System.Boolean)" 的 <param name="isgroup"/> 文档]

isactivity (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.CpsClient.SelectTuiguangwei(Api.Framework.Enums.CpsType,System.Boolean,System.Boolean,System.Boolean)" 的 <param name="isactivity"/> 文档]

返回值

类型：Object
参见

引用

CpsClient 类
Api.Framework 命名空间


CpsClient.UpdateOrder 方法

CpsClientUpdateOrder 方法

更新订单

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void UpdateOrder(
    CpsType type,
    DateTime startTime,
    DateTime endTime,
    string order_id
)

参数

type
类型：Api.Framework.EnumsCpsType
cps类型
startTime
类型：SystemDateTime
开始时间
endTime
类型：SystemDateTime
结束时间
order_id
类型：SystemString
订单id
参见

引用

CpsClient 类
Api.Framework 命名空间


EventClient 类

事件管理
继承层次
SystemObject
Api.FrameworkEventClient

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class EventClient

EventClient 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | EventClient | 初始化 EventClient 类的一个新实例
Top
属性
名称 | 说明
StopParsing | 是否传递插件
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | OnEvent(Object, MethodType) | 刷新事件触发
 | OnEvent(Object, Object) | 给插件传递消息
 | OnEvent(Object, String) | 输出日志触发
公共方法 | ToString | (继承自 Object。)
Top
事件
名称 | 说明
LogEvent | 日志事件
MethodEvent | 刷新刷新传递事件(刷新某些数据或者页面数据)
Top
字段
名称 | 说明
ReplaceURL | 替换短网址链接
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework 命名空间


EventClient 构造函数

初始化 EventClient 类的一个新实例

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public EventClient()
参见

引用

EventClient 类
Api.Framework 命名空间


EventClient 属性

EventClient 类型公开以下成员。

属性
名称 | 说明
StopParsing | 是否传递插件
Top
参见

引用

EventClient 类
Api.Framework 命名空间


EventClient.StopParsing 属性

EventClientStopParsing 属性

是否传递插件

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool StopParsing { get; set; }

属性值

类型：Boolean
参见

引用

EventClient 类
Api.Framework 命名空间


EventClient 方法

EventClient 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | OnEvent(Object, MethodType) | 刷新事件触发
 | OnEvent(Object, Object) | 给插件传递消息
 | OnEvent(Object, String) | 输出日志触发
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

EventClient 类
Api.Framework 命名空间


EventClient.OnEvent 方法

EventClientOnEvent 方法

重载列表
名称 | 说明
OnEvent(Object, MethodType) | 刷新事件触发
OnEvent(Object, Object) | 给插件传递消息
OnEvent(Object, String) | 输出日志触发
Top
参见

引用

EventClient 类
Api.Framework 命名空间


EventClient.OnEvent 方法 (Object, MethodType)

EventClientOnEvent 方法 (Object, MethodType)

刷新事件触发

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void OnEvent(
    Object sender,
    MethodType e
)

参数

sender
类型：SystemObject

[缺少 "M:Api.Framework.EventClient.OnEvent(System.Object,Api.Framework.Events.MethodType)" 的 <param name="sender"/> 文档]

e
类型：Api.Framework.EventsMethodType

[缺少 "M:Api.Framework.EventClient.OnEvent(System.Object,Api.Framework.Events.MethodType)" 的 <param name="e"/> 文档]

参见

引用

EventClient 类
OnEvent 重载
Api.Framework 命名空间


EventClient.OnEvent 方法 (Object, Object)

EventClientOnEvent 方法 (Object, Object)

给插件传递消息

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void OnEvent(
    Object _sender,
    Object _e
)

参数

_sender
类型：SystemObject

[缺少 "M:Api.Framework.EventClient.OnEvent(System.Object,System.Object)" 的 <param name="_sender"/> 文档]

_e
类型：SystemObject

[缺少 "M:Api.Framework.EventClient.OnEvent(System.Object,System.Object)" 的 <param name="_e"/> 文档]

参见

引用

EventClient 类
OnEvent 重载
Api.Framework 命名空间


EventClient.OnEvent 方法 (Object, String)

EventClientOnEvent 方法 (Object, String)

输出日志触发

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void OnEvent(
    Object sender,
    string log
)

参数

sender
类型：SystemObject

[缺少 "M:Api.Framework.EventClient.OnEvent(System.Object,System.String)" 的 <param name="sender"/> 文档]

log
类型：SystemString

[缺少 "M:Api.Framework.EventClient.OnEvent(System.Object,System.String)" 的 <param name="log"/> 文档]

参见

引用

EventClient 类
OnEvent 重载
Api.Framework 命名空间


EventClient 事件

EventClient 类型公开以下成员。

事件
名称 | 说明
LogEvent | 日志事件
MethodEvent | 刷新刷新传递事件(刷新某些数据或者页面数据)
Top
参见

引用

EventClient 类
Api.Framework 命名空间


EventClient.LogEvent 事件

EventClientLogEvent 事件

日志事件

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static event EventHandler<LogEvents> LogEvent

值

类型：SystemEventHandler LogEvents
参见

引用

EventClient 类
Api.Framework 命名空间


EventClient.MethodEvent 事件

EventClientMethodEvent 事件

刷新刷新传递事件(刷新某些数据或者页面数据)

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static event EventHandler<MethodType> MethodEvent

值

类型：SystemEventHandler MethodType
参见

引用

EventClient 类
Api.Framework 命名空间


EventClient 字段

EventClient 类型公开以下成员。

字段
名称 | 说明
ReplaceURL | 替换短网址链接
Top
参见

引用

EventClient 类
Api.Framework 命名空间


EventClient.ReplaceURL 字段

EventClientReplaceURL 字段

替换短网址链接

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Func<int, string, string> ReplaceURL

字段值

类型：Func Int32, String, String
参见

引用

EventClient 类
Api.Framework 命名空间


PluginClient 类

插件管理
继承层次
SystemObject
Api.FrameworkPluginClient

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PluginClient

PluginClient 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PluginClient | 初始化 PluginClient 类的一个新实例
Top
属性
名称 | 说明
Plugins | 插件集合
Top
方法
 | 名称 | 说明
 | AddPlugin | 添加插件
 | Delete | 删除插件
公共方法 | Equals | (继承自 Object。)
 | FileConvertPlugin | 将指定文件的转换成插件，并保存
受保护的方法 | Finalize | (继承自 Object。)
 | FindVersion | 获取插件新版本
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | Install | 插件安装
 | LodingPlugin | 加载插件
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | MovePlugin(Int32, Int32) | 调换插件顺序
 | MovePlugin(Plugin, Plugin) |
公共方法 | ToString | (继承自 Object。)
 | UnInstall | 插件卸载
 | UpdatePlugin | 更新插件
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework 命名空间


PluginClient 构造函数

初始化 PluginClient 类的一个新实例

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PluginClient()
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient 属性

PluginClient 类型公开以下成员。

属性
名称 | 说明
Plugins | 插件集合
Top
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.Plugins 属性

PluginClientPlugins 属性

插件集合

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<Plugin> Plugins { get; }

属性值

类型：List Plugin
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient 方法

PluginClient 类型公开以下成员。

方法
 | 名称 | 说明
 | AddPlugin | 添加插件
 | Delete | 删除插件
公共方法 | Equals | (继承自 Object。)
 | FileConvertPlugin | 将指定文件的转换成插件，并保存
受保护的方法 | Finalize | (继承自 Object。)
 | FindVersion | 获取插件新版本
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | Install | 插件安装
 | LodingPlugin | 加载插件
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | MovePlugin(Int32, Int32) | 调换插件顺序
 | MovePlugin(Plugin, Plugin) |
公共方法 | ToString | (继承自 Object。)
 | UnInstall | 插件卸载
 | UpdatePlugin | 更新插件
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.AddPlugin 方法

PluginClientAddPlugin 方法

添加插件

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Plugin AddPlugin(
    string filePath
)

参数

filePath
类型：SystemString
插件路径

返回值

类型：Plugin
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.Delete 方法

PluginClientDelete 方法

删除插件

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Delete(
    Plugin plugin
)

参数

plugin
类型：Api.Framework.SDKPlugin
要删除的插件对象
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.FileConvertPlugin 方法

PluginClientFileConvertPlugin 方法

将指定文件的转换成插件，并保存

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Plugin FileConvertPlugin(
    string filePath
)

参数

filePath
类型：SystemString
文件路径

返回值

类型：Plugin
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.FindVersion 方法

PluginClientFindVersion 方法

获取插件新版本

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<PluginVersion> FindVersion(
    Plugin plugin
)

参数

plugin
类型：Api.Framework.SDKPlugin
需要获取的插件

返回值

类型：List PluginVersion
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.Install 方法

PluginClientInstall 方法

插件安装

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Install(
    Plugin plugin
)

参数

plugin
类型：Api.Framework.SDKPlugin
要安装的插件对象
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.LodingPlugin 方法

PluginClientLodingPlugin 方法

加载插件

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void LodingPlugin(
    bool reload = false
)

参数

reload (Optional)
类型：SystemBoolean
重新加载
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.MovePlugin 方法

PluginClientMovePlugin 方法

重载列表
名称 | 说明
MovePlugin(Int32, Int32) | 调换插件顺序
MovePlugin(Plugin, Plugin) |
Top
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.MovePlugin 方法 (Int32, Int32)

PluginClientMovePlugin 方法 (Int32, Int32)

调换插件顺序

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void MovePlugin(
    int plugin1,
    int plugin2
)

参数

plugin1
类型：SystemInt32
被调换的插件下标
plugin2
类型：SystemInt32
需要调换的插件下标
参见

引用

PluginClient 类
MovePlugin 重载
Api.Framework 命名空间


PluginClient.MovePlugin 方法 (Plugin, Plugin)

PluginClientMovePlugin 方法 (Plugin, Plugin)

[缺少 "M:Api.Framework.PluginClient.MovePlugin(Api.Framework.SDK.Plugin,Api.Framework.SDK.Plugin)" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string MovePlugin(
    Plugin plugin1,
    Plugin plugin2
)

参数

plugin1
类型：Api.Framework.SDKPlugin

[缺少 "M:Api.Framework.PluginClient.MovePlugin(Api.Framework.SDK.Plugin,Api.Framework.SDK.Plugin)" 的 <param name="plugin1"/> 文档]

plugin2
类型：Api.Framework.SDKPlugin

[缺少 "M:Api.Framework.PluginClient.MovePlugin(Api.Framework.SDK.Plugin,Api.Framework.SDK.Plugin)" 的 <param name="plugin2"/> 文档]

返回值

类型：String
参见

引用

PluginClient 类
MovePlugin 重载
Api.Framework 命名空间


PluginClient.UnInstall 方法

PluginClientUnInstall 方法

插件卸载

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void UnInstall(
    Plugin plugin
)

参数

plugin
类型：Api.Framework.SDKPlugin
要卸载的插件对象
参见

引用

PluginClient 类
Api.Framework 命名空间


PluginClient.UpdatePlugin 方法

PluginClientUpdatePlugin 方法

更新插件

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool UpdatePlugin(
    PluginVersion version
)

参数

version
类型：Api.Framework.SDKPluginVersion
版本

返回值

类型：Boolean
参见

引用

PluginClient 类
Api.Framework 命名空间


WebClient 类

web管理
继承层次
SystemObject
Api.FrameworkWebClient

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WebClient

WebClient 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WebClient | 初始化 WebClient 类的一个新实例
Top
属性
名称 | 说明
IsStart |
Top
方法
 | 名称 | 说明
 | Close |
公共方法 | Configuration | 配置管理器
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetFilePath | 查找本地数据，无数据 返回index
公共方法 | GetHashCode | (继承自 Object。)
 | GetNetwork |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | RequestHandler | 挂载静态数据
公共方法 | SetResponse | 设置返回contenttype 并返回数据
 | Start |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework 命名空间


WebClient 构造函数

初始化 WebClient 类的一个新实例

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WebClient()
参见

引用

WebClient 类
Api.Framework 命名空间


WebClient 属性

WebClient 类型公开以下成员。

属性
名称 | 说明
IsStart |
Top
参见

引用

WebClient 类
Api.Framework 命名空间


WebClient.IsStart 属性

WebClientIsStart 属性

[缺少 "P:Api.Framework.WebClient.IsStart" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool IsStart { get; }

属性值

类型：Boolean
参见

引用

WebClient 类
Api.Framework 命名空间


WebClient 方法

WebClient 类型公开以下成员。

方法
 | 名称 | 说明
 | Close |
公共方法 | Configuration | 配置管理器
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetFilePath | 查找本地数据，无数据 返回index
公共方法 | GetHashCode | (继承自 Object。)
 | GetNetwork |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | RequestHandler | 挂载静态数据
公共方法 | SetResponse | 设置返回contenttype 并返回数据
 | Start |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WebClient 类
Api.Framework 命名空间


WebClient.Close 方法

WebClientClose 方法

[缺少 "M:Api.Framework.WebClient.Close" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Close()
参见

引用

WebClient 类
Api.Framework 命名空间


WebClient.Configuration 方法

WebClientConfiguration 方法

配置管理器

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Configuration(
    IAppBuilder app
)

参数

app
类型：IAppBuilder

[缺少 "M:Api.Framework.WebClient.Configuration(Owin.IAppBuilder)" 的 <param name="app"/> 文档]

参见

引用

WebClient 类
Api.Framework 命名空间


WebClient.GetFilePath 方法

WebClientGetFilePath 方法

查找本地数据，无数据 返回index

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetFilePath(
    string relPath
)

参数

relPath
类型：SystemString

[缺少 "M:Api.Framework.WebClient.GetFilePath(System.String)" 的 <param name="relPath"/> 文档]

返回值

类型：String
参见

引用

WebClient 类
Api.Framework 命名空间


WebClient.GetNetwork 方法

WebClientGetNetwork 方法

[缺少 "M:Api.Framework.WebClient.GetNetwork" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<IPAddress> GetNetwork()

返回值

类型：List IPAddress
参见

引用

WebClient 类
Api.Framework 命名空间


WebClient.RequestHandler 方法

WebClientRequestHandler 方法

挂载静态数据

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Task RequestHandler(
    IOwinContext context,
    Func<Task> next
)

参数

context
类型：IOwinContext

[缺少 "M:Api.Framework.WebClient.RequestHandler(Microsoft.Owin.IOwinContext,System.Func{System.Threading.Tasks.Task})" 的 <param name="context"/> 文档]

next
类型：SystemFunc Task

[缺少 "M:Api.Framework.WebClient.RequestHandler(Microsoft.Owin.IOwinContext,System.Func{System.Threading.Tasks.Task})" 的 <param name="next"/> 文档]

返回值

类型：Task
参见

引用

WebClient 类
Api.Framework 命名空间


WebClient.SetResponse 方法

WebClientSetResponse 方法

设置返回contenttype 并返回数据

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Task SetResponse(
    IOwinContext context,
    string path
)

参数

context
类型：IOwinContext

[缺少 "M:Api.Framework.WebClient.SetResponse(Microsoft.Owin.IOwinContext,System.String)" 的 <param name="context"/> 文档]

path
类型：SystemString

[缺少 "M:Api.Framework.WebClient.SetResponse(Microsoft.Owin.IOwinContext,System.String)" 的 <param name="path"/> 文档]

返回值

类型：Task
参见

引用

WebClient 类
Api.Framework 命名空间


WebClient.Start 方法

WebClientStart 方法

[缺少 "M:Api.Framework.WebClient.Start(System.String,System.Int32,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Start(
    string ip,
    int port,
    bool throwExcption = true
)

参数

ip
类型：SystemString

[缺少 "M:Api.Framework.WebClient.Start(System.String,System.Int32,System.Boolean)" 的 <param name="ip"/> 文档]

port
类型：SystemInt32

[缺少 "M:Api.Framework.WebClient.Start(System.String,System.Int32,System.Boolean)" 的 <param name="port"/> 文档]

throwExcption (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.WebClient.Start(System.String,System.Int32,System.Boolean)" 的 <param name="throwExcption"/> 文档]

参见

引用

WebClient 类
Api.Framework 命名空间


WebClient.Result 类

WebClientResult 类

响应结果
继承层次
SystemObject
Api.FrameworkWebClientResult

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Result

WebClientResult 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WebClientResult | 初始化 WebClientResult 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | code |
公共属性 | Code |
公共属性 | data |
公共属性 | Message |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework 命名空间


WebClient.Result 构造函数

WebClientResult 构造函数

初始化 WebClientResult 类的一个新实例

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Result()
参见

引用

WebClientResult 类
Api.Framework 命名空间


Result 属性

WebClientResult 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | code |
公共属性 | Code |
公共属性 | data |
公共属性 | Message |
Top
参见

引用

WebClientResult 类
Api.Framework 命名空间


WebClient.Result.code 属性

WebClientResultcode 属性

[缺少 "P:Api.Framework.WebClient.Result.code" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int code { get; }

属性值

类型：Int32
参见

引用

WebClientResult 类
Api.Framework 命名空间


WebClient.Result.Code 属性

WebClientResultCode 属性

[缺少 "P:Api.Framework.WebClient.Result.Code" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Code { get; set; }

属性值

类型：Int32
参见

引用

WebClientResult 类
Api.Framework 命名空间


WebClient.Result.data 属性

WebClientResultdata 属性

[缺少 "P:Api.Framework.WebClient.Result.data" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object data { get; }

属性值

类型：Object
参见

引用

WebClientResult 类
Api.Framework 命名空间


WebClient.Result.Message 属性

WebClientResultMessage 属性

[缺少 "P:Api.Framework.WebClient.Result.Message" 的 <summary> 文档]

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object Message { get; set; }

属性值

类型：Object
参见

引用

WebClientResult 类
Api.Framework 命名空间


Result 方法

WebClientResult 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WebClientResult 类
Api.Framework 命名空间


WebClient.Util 类

WebClientUtil 类

[缺少 "T:Api.Framework.WebClient.Util" 的 <summary> 文档]

继承层次
SystemObject
Api.FrameworkWebClientUtil

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Util

WebClientUtil 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WebClientUtil | 初始化 WebClientUtil 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetQueryString | 将查询字符串解析转换为名值集合.
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework 命名空间


WebClient.Util 构造函数

WebClientUtil 构造函数

初始化 WebClientUtil 类的一个新实例

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Util()
参见

引用

WebClientUtil 类
Api.Framework 命名空间


Util 方法

WebClientUtil 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetQueryString | 将查询字符串解析转换为名值集合.
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WebClientUtil 类
Api.Framework 命名空间


WebClient.Util.GetQueryString 方法

WebClientUtilGetQueryString 方法

将查询字符串解析转换为名值集合.

命名空间： Api.Framework
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static NameValueCollection GetQueryString(
    string queryString,
    Encoding encoding
)

参数

queryString
类型：SystemString

[缺少 "M:Api.Framework.WebClient.Util.GetQueryString(System.String,System.Text.Encoding)" 的 <param name="queryString"/> 文档]

encoding
类型：System.TextEncoding

[缺少 "M:Api.Framework.WebClient.Util.GetQueryString(System.String,System.Text.Encoding)" 的 <param name="encoding"/> 文档]

返回值

类型：NameValueCollection
参见

引用

WebClientUtil 类
Api.Framework 命名空间


Api.Framework.Config 命名空间

[缺少 "N:Api.Framework.Config" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | LoginUser |
公共类 | OtherConfig | 系统其他配置
公共类 | ServerConfig | 系统接口配置
公共类 | Setting | 配置
公共类 | SystemConfig | 系统基础设置
公共类 | SystemConfignotice_robotname_item |


LoginUser 类

[缺少 "T:Api.Framework.Config.LoginUser" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ConfigLoginUser

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class LoginUser

LoginUser 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | LoginUser | 初始化 LoginUser 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Name |
公共属性 | Pass |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Config 命名空间


LoginUser 构造函数

初始化 LoginUser 类的一个新实例

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public LoginUser()
参见

引用

LoginUser 类
Api.Framework.Config 命名空间


LoginUser 属性

LoginUser 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Name |
公共属性 | Pass |
Top
参见

引用

LoginUser 类
Api.Framework.Config 命名空间


LoginUser.Name 属性

LoginUserName 属性

[缺少 "P:Api.Framework.Config.LoginUser.Name" 的 <summary> 文档]

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Name { get; set; }

属性值

类型：String
参见

引用

LoginUser 类
Api.Framework.Config 命名空间


LoginUser.Pass 属性

LoginUserPass 属性

[缺少 "P:Api.Framework.Config.LoginUser.Pass" 的 <summary> 文档]

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Pass { get; set; }

属性值

类型：String
参见

引用

LoginUser 类
Api.Framework.Config 命名空间


LoginUser 方法

LoginUser 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

LoginUser 类
Api.Framework.Config 命名空间


OtherConfig 类

系统其他配置
继承层次
SystemObject
Api.Framework.ConfigOtherConfig

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class OtherConfig

OtherConfig 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | OtherConfig | 初始化 OtherConfig 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Plugins | 插件顺序
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Config 命名空间


OtherConfig 构造函数

初始化 OtherConfig 类的一个新实例

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OtherConfig()
参见

引用

OtherConfig 类
Api.Framework.Config 命名空间


OtherConfig 属性

OtherConfig 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Plugins | 插件顺序
Top
参见

引用

OtherConfig 类
Api.Framework.Config 命名空间


OtherConfig.Plugins 属性

OtherConfigPlugins 属性

插件顺序

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> Plugins { get; set; }

属性值

类型：List String
参见

引用

OtherConfig 类
Api.Framework.Config 命名空间


OtherConfig 方法

OtherConfig 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

OtherConfig 类
Api.Framework.Config 命名空间


ServerConfig 类

系统接口配置
继承层次
SystemObject
Api.Framework.ConfigServerConfig

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ServerConfig

ServerConfig 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ServerConfig | 初始化 ServerConfig 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Domain | 域名
公共属性 | Host | 服务器IP
公共属性 | IsOpen | Web服务器是否开启
公共属性 | Port | 端口号
公共属性 | SocketIsOpen | Socket服务器是否打开
公共属性 | SocketPassword | 通信秘钥
公共属性 | SocketPort | Socket端口
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Config 命名空间


ServerConfig 构造函数

初始化 ServerConfig 类的一个新实例

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ServerConfig()
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


ServerConfig 属性

ServerConfig 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Domain | 域名
公共属性 | Host | 服务器IP
公共属性 | IsOpen | Web服务器是否开启
公共属性 | Port | 端口号
公共属性 | SocketIsOpen | Socket服务器是否打开
公共属性 | SocketPassword | 通信秘钥
公共属性 | SocketPort | Socket端口
Top
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


ServerConfig.Domain 属性

ServerConfigDomain 属性

域名

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Domain { get; set; }

属性值

类型：String
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


ServerConfig.Host 属性

ServerConfigHost 属性

服务器IP

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Host { get; set; }

属性值

类型：String
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


ServerConfig.IsOpen 属性

ServerConfigIsOpen 属性

Web服务器是否开启

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsOpen { get; set; }

属性值

类型：Boolean
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


ServerConfig.Port 属性

ServerConfigPort 属性

端口号

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Port { get; set; }

属性值

类型：Int32
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


ServerConfig.SocketIsOpen 属性

ServerConfigSocketIsOpen 属性

Socket服务器是否打开

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool SocketIsOpen { get; set; }

属性值

类型：Boolean
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


ServerConfig.SocketPassword 属性

ServerConfigSocketPassword 属性

通信秘钥

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SocketPassword { get; set; }

属性值

类型：String
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


ServerConfig.SocketPort 属性

ServerConfigSocketPort 属性

Socket端口

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int SocketPort { get; set; }

属性值

类型：Int32
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


ServerConfig 方法

ServerConfig 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ServerConfig 类
Api.Framework.Config 命名空间


Setting 类

配置
继承层次
SystemObject
Api.Framework.ConfigSetting

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Setting

Setting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Setting | 初始化 Setting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DbConfig | 数据库配置
公共属性 | OtherConfig | 系统其他配置
公共属性 | Plugins | 获取插件顺序
公共属性 | ServerConfig | 系统接口配置
公共属性 | SystemConfig | 系统基础配置
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Iniconfig | 初始化配置
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Save | 保存配置
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Config 命名空间


Setting 构造函数

初始化 Setting 类的一个新实例

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Setting()
参见

引用

Setting 类
Api.Framework.Config 命名空间


Setting 属性

Setting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DbConfig | 数据库配置
公共属性 | OtherConfig | 系统其他配置
公共属性 | Plugins | 获取插件顺序
公共属性 | ServerConfig | 系统接口配置
公共属性 | SystemConfig | 系统基础配置
Top
参见

引用

Setting 类
Api.Framework.Config 命名空间


Setting.DbConfig 属性

SettingDbConfig 属性

数据库配置

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ConnectionConfig DbConfig { get; set; }

属性值

类型：ConnectionConfig
参见

引用

Setting 类
Api.Framework.Config 命名空间


Setting.OtherConfig 属性

SettingOtherConfig 属性

系统其他配置

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OtherConfig OtherConfig { get; set; }

属性值

类型：OtherConfig
参见

引用

Setting 类
Api.Framework.Config 命名空间


Setting.Plugins 属性

SettingPlugins 属性

获取插件顺序

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> Plugins { get; }

属性值

类型：List String
参见

引用

Setting 类
Api.Framework.Config 命名空间


Setting.ServerConfig 属性

SettingServerConfig 属性

系统接口配置

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ServerConfig ServerConfig { get; set; }

属性值

类型：ServerConfig
参见

引用

Setting 类
Api.Framework.Config 命名空间


Setting.SystemConfig 属性

SettingSystemConfig 属性

系统基础配置

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SystemConfig SystemConfig { get; set; }

属性值

类型：SystemConfig
参见

引用

Setting 类
Api.Framework.Config 命名空间


Setting 方法

Setting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Iniconfig | 初始化配置
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Save | 保存配置
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Setting 类
Api.Framework.Config 命名空间


Setting.Iniconfig 方法

SettingIniconfig 方法

初始化配置

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Iniconfig()
参见

引用

Setting 类
Api.Framework.Config 命名空间


Setting.Save 方法

SettingSave 方法

保存配置

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Save()
参见

引用

Setting 类
Api.Framework.Config 命名空间


SystemConfig 类

系统基础设置
继承层次
SystemObject
Api.Framework.ConfigSystemConfig

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SystemConfig

SystemConfig 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SystemConfig | 系统配置
Top
属性
 | 名称 | 说明
公共属性 | account_admin_email | 管理员邮箱
公共属性 | admin_verify_control_name | 需要输入密码的应用
公共属性 | allow_bind_create_order_time | 允许手动绑定的订单时间
公共属性 | AwardCreator | 群主奖励
公共属性 | AwardDepot | 提成类型
公共属性 | AwardOne | 一级提成
公共属性 | AwardThree | 三级提成
公共属性 | AwardTwo | 二级提成
公共属性 | CheckUrlSwitch | 自定义域名中间页屏蔽通知
公共属性 | cps_server_api | 联盟API通信平台
公共属性 | dwz_type | 自定义短网址
公共属性 | DwzToken | 自定义短网址（百度付费Token）
公共属性 | FreezingCondition | 订单冻结依据
公共属性 | is_lock_main | 锁定界面开关
公共属性 | mess_frequent_sleep_time | 消息发送间隔
公共属性 | message_warning_switch | 消息预警方案
公共属性 | msg_error | 系统异常提示语
公共属性 | msg_wx_convertswich | 微信辅助客户输入
公共属性 | notice_dingding_robotapi | 钉钉群接口
公共属性 | notice_dingding_robotSecret | 钉钉群秘钥
公共属性 | notice_robotname | 钉钉/微信群机器人
公共属性 | order_alimama_bind | 淘宝订单自动绑定
公共属性 | order_alimama_down_type | 淘宝订单下载依据
公共属性 | order_alimama_download_set_pids | 只下载使用中推广位淘宝订单
公共属性 | order_alimama_last_auto_bind | 淘宝订单尾号识别绑定
公共属性 | order_alimama_last_auto_capture | 淘宝订单尾号自动采集
公共属性 | order_alimama_not_download_pid | 淘宝订单[不]下载推广位
公共属性 | order_alimama_same_shop_bind | 淘宝同店订单绑定
公共属性 | order_douyin_bind | 抖音订单自动绑定
公共属性 | order_jingdong_bind | 京东订单自动绑定
公共属性 | order_jingdong_down_type | 京东订单下载依据
公共属性 | order_jingdong_download_set_pids | 只下载使用中推广位京东订单
公共属性 | order_jingdong_not_download_pid | 京东订单[不]下载推广位
公共属性 | order_pinduoduo_bind | 拼多多订单自动绑定
公共属性 | order_pinduoduo_down_type | 拼多多订单下载依据
公共属性 | order_pinduoduo_download_set_pids | 只下载使用中推广位拼多多订单
公共属性 | order_pinduoduo_not_download_pid | 拼多多订单[不]下载推广位
公共属性 | order_weipinhui_bind | 唯品会订单自动绑定
公共属性 | order_weipinhui_down_type | 唯品会订单下载依据
公共属性 | order_weipinhui_download_set_pids | 只下载使用中推广位唯品会订单
公共属性 | order_weipinhui_not_download_pid | 唯品会订单[不]下载推广位
公共属性 | pay_wechat_gzh_appid | 公众号AppId
公共属性 | pay_wechat_gzh_appsecret | 公众号AppSecret
公共属性 | pay_wechat_host | 支付平台地址
公共属性 | pay_wechat_hostSign | 易提现 - API接口
公共属性 | pay_wechat_sh_appid | 商户号AppId
公共属性 | pay_wechat_sh_appsecret | 商户号AppSecret
公共属性 | pay_wechat_sh_cerpath | 商户号证书路径
公共属性 | pay_wechat_web_footer | 著作授权信息
公共属性 | PointName | 积分名称
公共属性 | PointRitio | 换算比例
公共属性 | QueryItemExpireTime | 精准查询链接过期时间 - 分钟
公共属性 | send_shpay_msg | 商户未领取提示语
公共属性 | send_shpay_switch | 24小时发送未领取商户开关
公共属性 | show_debug_log | 显示debug日志
公共属性 | SMTP_Host | 邮件服务器
公共属性 | SMTP_Pass | 邮件授权密码
公共属性 | SMTP_Port | 邮件端口号
公共属性 | SMTP_SSL | SSL加密传输
公共属性 | SMTP_User | 邮件用户名
公共属性 | SubsidyJd | 京东0元补助
公共属性 | SubsidyPdd | 拼多多0元补助
公共属性 | SubsidyTb | 淘宝0元补助
公共属性 | TGWRandomCount | 淘宝随机推广位切换频率
公共属性 | time_down_douyin | 定时-下载抖音订单
公共属性 | time_down_jingdong | 定时-下载京东订单
公共属性 | time_down_pinduoduo | 定时-下载拼多多订单
公共属性 | time_down_weipinhui | 定时-下载唯品会订单
公共属性 | timer_clear_memory | 定时-清理内存
公共属性 | timer_down_alimama | 定时-下载淘宝订单
公共属性 | TKLStr_End | 淘口令末尾符号
公共属性 | TklStr_First | 淘口令开始符号
公共属性 | URLDwz | 自定义域名-短网址
公共属性 | URLTbCms | 自定义域名-产品库
公共属性 | URLTbDdxq | 自定义域名-订单详情
公共属性 | URLTbTkl | 自定义域名-淘口令
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Config 命名空间


SystemConfig 构造函数

系统配置

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SystemConfig()
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig 属性

SystemConfig 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | account_admin_email | 管理员邮箱
公共属性 | admin_verify_control_name | 需要输入密码的应用
公共属性 | allow_bind_create_order_time | 允许手动绑定的订单时间
公共属性 | AwardCreator | 群主奖励
公共属性 | AwardDepot | 提成类型
公共属性 | AwardOne | 一级提成
公共属性 | AwardThree | 三级提成
公共属性 | AwardTwo | 二级提成
公共属性 | CheckUrlSwitch | 自定义域名中间页屏蔽通知
公共属性 | cps_server_api | 联盟API通信平台
公共属性 | dwz_type | 自定义短网址
公共属性 | DwzToken | 自定义短网址（百度付费Token）
公共属性 | FreezingCondition | 订单冻结依据
公共属性 | is_lock_main | 锁定界面开关
公共属性 | mess_frequent_sleep_time | 消息发送间隔
公共属性 | message_warning_switch | 消息预警方案
公共属性 | msg_error | 系统异常提示语
公共属性 | msg_wx_convertswich | 微信辅助客户输入
公共属性 | notice_dingding_robotapi | 钉钉群接口
公共属性 | notice_dingding_robotSecret | 钉钉群秘钥
公共属性 | notice_robotname | 钉钉/微信群机器人
公共属性 | order_alimama_bind | 淘宝订单自动绑定
公共属性 | order_alimama_down_type | 淘宝订单下载依据
公共属性 | order_alimama_download_set_pids | 只下载使用中推广位淘宝订单
公共属性 | order_alimama_last_auto_bind | 淘宝订单尾号识别绑定
公共属性 | order_alimama_last_auto_capture | 淘宝订单尾号自动采集
公共属性 | order_alimama_not_download_pid | 淘宝订单[不]下载推广位
公共属性 | order_alimama_same_shop_bind | 淘宝同店订单绑定
公共属性 | order_douyin_bind | 抖音订单自动绑定
公共属性 | order_jingdong_bind | 京东订单自动绑定
公共属性 | order_jingdong_down_type | 京东订单下载依据
公共属性 | order_jingdong_download_set_pids | 只下载使用中推广位京东订单
公共属性 | order_jingdong_not_download_pid | 京东订单[不]下载推广位
公共属性 | order_pinduoduo_bind | 拼多多订单自动绑定
公共属性 | order_pinduoduo_down_type | 拼多多订单下载依据
公共属性 | order_pinduoduo_download_set_pids | 只下载使用中推广位拼多多订单
公共属性 | order_pinduoduo_not_download_pid | 拼多多订单[不]下载推广位
公共属性 | order_weipinhui_bind | 唯品会订单自动绑定
公共属性 | order_weipinhui_down_type | 唯品会订单下载依据
公共属性 | order_weipinhui_download_set_pids | 只下载使用中推广位唯品会订单
公共属性 | order_weipinhui_not_download_pid | 唯品会订单[不]下载推广位
公共属性 | pay_wechat_gzh_appid | 公众号AppId
公共属性 | pay_wechat_gzh_appsecret | 公众号AppSecret
公共属性 | pay_wechat_host | 支付平台地址
公共属性 | pay_wechat_hostSign | 易提现 - API接口
公共属性 | pay_wechat_sh_appid | 商户号AppId
公共属性 | pay_wechat_sh_appsecret | 商户号AppSecret
公共属性 | pay_wechat_sh_cerpath | 商户号证书路径
公共属性 | pay_wechat_web_footer | 著作授权信息
公共属性 | PointName | 积分名称
公共属性 | PointRitio | 换算比例
公共属性 | QueryItemExpireTime | 精准查询链接过期时间 - 分钟
公共属性 | send_shpay_msg | 商户未领取提示语
公共属性 | send_shpay_switch | 24小时发送未领取商户开关
公共属性 | show_debug_log | 显示debug日志
公共属性 | SMTP_Host | 邮件服务器
公共属性 | SMTP_Pass | 邮件授权密码
公共属性 | SMTP_Port | 邮件端口号
公共属性 | SMTP_SSL | SSL加密传输
公共属性 | SMTP_User | 邮件用户名
公共属性 | SubsidyJd | 京东0元补助
公共属性 | SubsidyPdd | 拼多多0元补助
公共属性 | SubsidyTb | 淘宝0元补助
公共属性 | TGWRandomCount | 淘宝随机推广位切换频率
公共属性 | time_down_douyin | 定时-下载抖音订单
公共属性 | time_down_jingdong | 定时-下载京东订单
公共属性 | time_down_pinduoduo | 定时-下载拼多多订单
公共属性 | time_down_weipinhui | 定时-下载唯品会订单
公共属性 | timer_clear_memory | 定时-清理内存
公共属性 | timer_down_alimama | 定时-下载淘宝订单
公共属性 | TKLStr_End | 淘口令末尾符号
公共属性 | TklStr_First | 淘口令开始符号
公共属性 | URLDwz | 自定义域名-短网址
公共属性 | URLTbCms | 自定义域名-产品库
公共属性 | URLTbDdxq | 自定义域名-订单详情
公共属性 | URLTbTkl | 自定义域名-淘口令
Top
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.account_admin_email 属性

SystemConfigaccount_admin_email 属性

管理员邮箱

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string account_admin_email { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.admin_verify_control_name 属性

SystemConfigadmin_verify_control_name 属性

需要输入密码的应用

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> admin_verify_control_name { get; set; }

属性值

类型：List String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.allow_bind_create_order_time 属性

SystemConfigallow_bind_create_order_time 属性

允许手动绑定的订单时间

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime allow_bind_create_order_time { get; set; }

属性值

类型：DateTime
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.AwardCreator 属性

SystemConfigAwardCreator 属性

群主奖励

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int AwardCreator { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.AwardDepot 属性

SystemConfigAwardDepot 属性

提成类型

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public AwardDepotType AwardDepot { get; set; }

属性值

类型：AwardDepotType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.AwardOne 属性

SystemConfigAwardOne 属性

一级提成

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int AwardOne { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.AwardThree 属性

SystemConfigAwardThree 属性

三级提成

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int AwardThree { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.AwardTwo 属性

SystemConfigAwardTwo 属性

二级提成

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int AwardTwo { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.CheckUrlSwitch 属性

SystemConfigCheckUrlSwitch 属性

自定义域名中间页屏蔽通知

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType CheckUrlSwitch { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.cps_server_api 属性

SystemConfigcps_server_api 属性

联盟API通信平台

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cps_server_api { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.dwz_type 属性

SystemConfigdwz_type 属性

自定义短网址

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DwzType dwz_type { get; set; }

属性值

类型：DwzType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.DwzToken 属性

SystemConfigDwzToken 属性

自定义短网址（百度付费Token）

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DwzToken { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.FreezingCondition 属性

SystemConfigFreezingCondition 属性

订单冻结依据

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public FreezingConditionType FreezingCondition { get; set; }

属性值

类型：FreezingConditionType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.is_lock_main 属性

SystemConfigis_lock_main 属性

锁定界面开关

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType is_lock_main { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.mess_frequent_sleep_time 属性

SystemConfigmess_frequent_sleep_time 属性

消息发送间隔

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int mess_frequent_sleep_time { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.message_warning_switch 属性

SystemConfigmessage_warning_switch 属性

消息预警方案

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool message_warning_switch { get; set; }

属性值

类型：Boolean
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.msg_error 属性

SystemConfigmsg_error 属性

系统异常提示语

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string msg_error { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.msg_wx_convertswich 属性

SystemConfigmsg_wx_convertswich 属性

微信辅助客户输入
短网址

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType msg_wx_convertswich { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.notice_dingding_robotapi 属性

SystemConfignotice_dingding_robotapi 属性

钉钉群接口

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string notice_dingding_robotapi { get; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.notice_dingding_robotSecret 属性

SystemConfignotice_dingding_robotSecret 属性

钉钉群秘钥

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string notice_dingding_robotSecret { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.notice_robotname 属性

SystemConfignotice_robotname 属性

钉钉/微信群机器人

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
[TypeConverterAttribute(typeof(SystemConfignotice_robotname_item))]
public string notice_robotname { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_alimama_bind 属性

SystemConfigorder_alimama_bind 属性

淘宝订单自动绑定

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_alimama_bind { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_alimama_down_type 属性

SystemConfigorder_alimama_down_type 属性

淘宝订单下载依据

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DownAdzoneType order_alimama_down_type { get; set; }

属性值

类型：DownAdzoneType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_alimama_download_set_pids 属性

SystemConfigorder_alimama_download_set_pids 属性

只下载使用中推广位淘宝订单

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_alimama_download_set_pids { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_alimama_last_auto_bind 属性

SystemConfigorder_alimama_last_auto_bind 属性

淘宝订单尾号识别绑定

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_alimama_last_auto_bind { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_alimama_last_auto_capture 属性

SystemConfigorder_alimama_last_auto_capture 属性

淘宝订单尾号自动采集

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_alimama_last_auto_capture { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_alimama_not_download_pid 属性

SystemConfigorder_alimama_not_download_pid 属性

淘宝订单[不]下载推广位

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_alimama_not_download_pid { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_alimama_same_shop_bind 属性

SystemConfigorder_alimama_same_shop_bind 属性

淘宝同店订单绑定

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_alimama_same_shop_bind { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_douyin_bind 属性

SystemConfigorder_douyin_bind 属性

抖音订单自动绑定

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_douyin_bind { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_jingdong_bind 属性

SystemConfigorder_jingdong_bind 属性

京东订单自动绑定

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_jingdong_bind { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_jingdong_down_type 属性

SystemConfigorder_jingdong_down_type 属性

京东订单下载依据

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DownAdzoneType order_jingdong_down_type { get; set; }

属性值

类型：DownAdzoneType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_jingdong_download_set_pids 属性

SystemConfigorder_jingdong_download_set_pids 属性

只下载使用中推广位京东订单

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_jingdong_download_set_pids { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_jingdong_not_download_pid 属性

SystemConfigorder_jingdong_not_download_pid 属性

京东订单[不]下载推广位

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_jingdong_not_download_pid { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_pinduoduo_bind 属性

SystemConfigorder_pinduoduo_bind 属性

拼多多订单自动绑定

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_pinduoduo_bind { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_pinduoduo_down_type 属性

SystemConfigorder_pinduoduo_down_type 属性

拼多多订单下载依据

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DownAdzoneType order_pinduoduo_down_type { get; set; }

属性值

类型：DownAdzoneType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_pinduoduo_download_set_pids 属性

SystemConfigorder_pinduoduo_download_set_pids 属性

只下载使用中推广位拼多多订单

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_pinduoduo_download_set_pids { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_pinduoduo_not_download_pid 属性

SystemConfigorder_pinduoduo_not_download_pid 属性

拼多多订单[不]下载推广位

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_pinduoduo_not_download_pid { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_weipinhui_bind 属性

SystemConfigorder_weipinhui_bind 属性

唯品会订单自动绑定

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_weipinhui_bind { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_weipinhui_down_type 属性

SystemConfigorder_weipinhui_down_type 属性

唯品会订单下载依据

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DownAdzoneType order_weipinhui_down_type { get; set; }

属性值

类型：DownAdzoneType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_weipinhui_download_set_pids 属性

SystemConfigorder_weipinhui_download_set_pids 属性

只下载使用中推广位唯品会订单

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType order_weipinhui_download_set_pids { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.order_weipinhui_not_download_pid 属性

SystemConfigorder_weipinhui_not_download_pid 属性

唯品会订单[不]下载推广位

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_weipinhui_not_download_pid { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.pay_wechat_gzh_appid 属性

SystemConfigpay_wechat_gzh_appid 属性

公众号AppId

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pay_wechat_gzh_appid { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.pay_wechat_gzh_appsecret 属性

SystemConfigpay_wechat_gzh_appsecret 属性

公众号AppSecret

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pay_wechat_gzh_appsecret { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.pay_wechat_host 属性

SystemConfigpay_wechat_host 属性

支付平台地址

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pay_wechat_host { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.pay_wechat_hostSign 属性

SystemConfigpay_wechat_hostSign 属性

易提现 - API接口

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pay_wechat_hostSign { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.pay_wechat_sh_appid 属性

SystemConfigpay_wechat_sh_appid 属性

商户号AppId

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pay_wechat_sh_appid { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.pay_wechat_sh_appsecret 属性

SystemConfigpay_wechat_sh_appsecret 属性

商户号AppSecret

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pay_wechat_sh_appsecret { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.pay_wechat_sh_cerpath 属性

SystemConfigpay_wechat_sh_cerpath 属性

商户号证书路径

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pay_wechat_sh_cerpath { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.pay_wechat_web_footer 属性

SystemConfigpay_wechat_web_footer 属性

著作授权信息

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pay_wechat_web_footer { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.PointName 属性

SystemConfigPointName 属性

积分名称

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string PointName { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.PointRitio 属性

SystemConfigPointRitio 属性

换算比例

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int PointRitio { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.QueryItemExpireTime 属性

SystemConfigQueryItemExpireTime 属性

精准查询链接过期时间 - 分钟

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int QueryItemExpireTime { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.send_shpay_msg 属性

SystemConfigsend_shpay_msg 属性

商户未领取提示语

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string send_shpay_msg { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.send_shpay_switch 属性

SystemConfigsend_shpay_switch 属性

24小时发送未领取商户开关

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool send_shpay_switch { get; set; }

属性值

类型：Boolean
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.show_debug_log 属性

SystemConfigshow_debug_log 属性

显示debug日志

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool show_debug_log { get; set; }

属性值

类型：Boolean
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.SMTP_Host 属性

SystemConfigSMTP_Host 属性

邮件服务器

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SMTP_Host { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.SMTP_Pass 属性

SystemConfigSMTP_Pass 属性

邮件授权密码

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SMTP_Pass { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.SMTP_Port 属性

SystemConfigSMTP_Port 属性

邮件端口号

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int SMTP_Port { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.SMTP_SSL 属性

SystemConfigSMTP_SSL 属性

SSL加密传输

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType SMTP_SSL { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.SMTP_User 属性

SystemConfigSMTP_User 属性

邮件用户名

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SMTP_User { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.SubsidyJd 属性

SystemConfigSubsidyJd 属性

京东0元补助

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType SubsidyJd { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.SubsidyPdd 属性

SystemConfigSubsidyPdd 属性

拼多多0元补助

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType SubsidyPdd { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.SubsidyTb 属性

SystemConfigSubsidyTb 属性

淘宝0元补助

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType SubsidyTb { get; set; }

属性值

类型：SwitchType
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.TGWRandomCount 属性

SystemConfigTGWRandomCount 属性

淘宝随机推广位切换频率

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int TGWRandomCount { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.time_down_douyin 属性

SystemConfigtime_down_douyin 属性

定时-下载抖音订单

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int time_down_douyin { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.time_down_jingdong 属性

SystemConfigtime_down_jingdong 属性

定时-下载京东订单

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int time_down_jingdong { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.time_down_pinduoduo 属性

SystemConfigtime_down_pinduoduo 属性

定时-下载拼多多订单

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int time_down_pinduoduo { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.time_down_weipinhui 属性

SystemConfigtime_down_weipinhui 属性

定时-下载唯品会订单

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int time_down_weipinhui { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.timer_clear_memory 属性

SystemConfigtimer_clear_memory 属性

定时-清理内存

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int timer_clear_memory { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.timer_down_alimama 属性

SystemConfigtimer_down_alimama 属性

定时-下载淘宝订单

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int timer_down_alimama { get; set; }

属性值

类型：Int32
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.TKLStr_End 属性

SystemConfigTKLStr_End 属性

淘口令末尾符号

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string TKLStr_End { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.TklStr_First 属性

SystemConfigTklStr_First 属性

淘口令开始符号

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string TklStr_First { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.URLDwz 属性

SystemConfigURLDwz 属性

自定义域名-短网址

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string URLDwz { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.URLTbCms 属性

SystemConfigURLTbCms 属性

自定义域名-产品库

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string URLTbCms { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.URLTbDdxq 属性

SystemConfigURLTbDdxq 属性

自定义域名-订单详情

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string URLTbDdxq { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.URLTbTkl 属性

SystemConfigURLTbTkl 属性

自定义域名-淘口令

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string URLTbTkl { get; set; }

属性值

类型：String
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig 方法

SystemConfig 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SystemConfig 类
Api.Framework.Config 命名空间


SystemConfig.notice_robotname_item 类

SystemConfignotice_robotname_item 类

[缺少 "T:Api.Framework.Config.SystemConfig.notice_robotname_item" 的 <summary> 文档]

继承层次
SystemObject
System.ComponentModelTypeConverter
MyTypeConverter
Api.Framework.ConfigSystemConfignotice_robotname_item

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class notice_robotname_item : MyTypeConverter

SystemConfignotice_robotname_item 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SystemConfignotice_robotname_item | 初始化 SystemConfignotice_robotname_item 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | CanConvertFrom(Type) | (继承自 TypeConverter。)
公共方法 | CanConvertFrom(ITypeDescriptorContext, Type) | (继承自 TypeConverter。)
公共方法 | CanConvertTo(Type) | (继承自 TypeConverter。)
公共方法 | CanConvertTo(ITypeDescriptorContext, Type) | (继承自 TypeConverter。)
公共方法 | ConvertFrom(Object) | (继承自 TypeConverter。)
公共方法 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (继承自 TypeConverter。)
公共方法 | ConvertFromInvariantString(String) | (继承自 TypeConverter。)
公共方法 | ConvertFromInvariantString(ITypeDescriptorContext, String) | (继承自 TypeConverter。)
公共方法 | ConvertFromString(String) | (继承自 TypeConverter。)
公共方法 | ConvertFromString(ITypeDescriptorContext, String) | (继承自 TypeConverter。)
公共方法 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | (继承自 TypeConverter。)
公共方法 | ConvertTo(Object, Type) | (继承自 TypeConverter。)
公共方法 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (继承自 TypeConverter。)
公共方法 | ConvertToInvariantString(Object) | (继承自 TypeConverter。)
公共方法 | ConvertToInvariantString(ITypeDescriptorContext, Object) | (继承自 TypeConverter。)
公共方法 | ConvertToString(Object) | (继承自 TypeConverter。)
公共方法 | ConvertToString(ITypeDescriptorContext, Object) | (继承自 TypeConverter。)
公共方法 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | (继承自 TypeConverter。)
公共方法 | CreateInstance(IDictionary) | (继承自 TypeConverter。)
公共方法 | CreateInstance(ITypeDescriptorContext, IDictionary) | (继承自 TypeConverter。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
受保护的方法 | GetConvertFromException | (继承自 TypeConverter。)
受保护的方法 | GetConvertToException | (继承自 TypeConverter。)
公共方法 | GetCreateInstanceSupported | (继承自 TypeConverter。)
公共方法 | GetCreateInstanceSupported(ITypeDescriptorContext) | (继承自 TypeConverter。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetProperties(Object) | (继承自 TypeConverter。)
公共方法 | GetProperties(ITypeDescriptorContext, Object) | (继承自 TypeConverter。)
公共方法 | GetProperties(ITypeDescriptorContext, Object, Attribute) | (继承自 TypeConverter。)
公共方法 | GetPropertiesSupported | (继承自 TypeConverter。)
公共方法 | GetPropertiesSupported(ITypeDescriptorContext) | (继承自 TypeConverter。)
公共方法 | GetStandardValues | (继承自 TypeConverter。)
公共方法 | GetStandardValues(ITypeDescriptorContext) | (继承自 MyTypeConverter。)
公共方法 | GetStandardValuesExclusive | (继承自 TypeConverter。)
公共方法 | GetStandardValuesExclusive(ITypeDescriptorContext) | (继承自 MyTypeConverter。)
公共方法 | GetStandardValuesSupported | (继承自 TypeConverter。)
公共方法 | GetStandardValuesSupported(ITypeDescriptorContext) | (继承自 MyTypeConverter。)
公共方法 | GetType | (继承自 Object。)
公共方法 | GetValues | (重写 MyTypeConverter.GetValues.)
公共方法 | IsValid(Object) | (继承自 TypeConverter。)
公共方法 | IsValid(ITypeDescriptorContext, Object) | (继承自 TypeConverter。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | SortProperties | (继承自 TypeConverter。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Config 命名空间


SystemConfig.notice_robotname_item 构造函数

SystemConfignotice_robotname_item 构造函数

初始化 SystemConfignotice_robotname_item 类的一个新实例

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public notice_robotname_item()
参见

引用

SystemConfignotice_robotname_item 类
Api.Framework.Config 命名空间


notice_robotname_item 方法

SystemConfignotice_robotname_item 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CanConvertFrom(Type) | (继承自 TypeConverter。)
公共方法 | CanConvertFrom(ITypeDescriptorContext, Type) | (继承自 TypeConverter。)
公共方法 | CanConvertTo(Type) | (继承自 TypeConverter。)
公共方法 | CanConvertTo(ITypeDescriptorContext, Type) | (继承自 TypeConverter。)
公共方法 | ConvertFrom(Object) | (继承自 TypeConverter。)
公共方法 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (继承自 TypeConverter。)
公共方法 | ConvertFromInvariantString(String) | (继承自 TypeConverter。)
公共方法 | ConvertFromInvariantString(ITypeDescriptorContext, String) | (继承自 TypeConverter。)
公共方法 | ConvertFromString(String) | (继承自 TypeConverter。)
公共方法 | ConvertFromString(ITypeDescriptorContext, String) | (继承自 TypeConverter。)
公共方法 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | (继承自 TypeConverter。)
公共方法 | ConvertTo(Object, Type) | (继承自 TypeConverter。)
公共方法 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (继承自 TypeConverter。)
公共方法 | ConvertToInvariantString(Object) | (继承自 TypeConverter。)
公共方法 | ConvertToInvariantString(ITypeDescriptorContext, Object) | (继承自 TypeConverter。)
公共方法 | ConvertToString(Object) | (继承自 TypeConverter。)
公共方法 | ConvertToString(ITypeDescriptorContext, Object) | (继承自 TypeConverter。)
公共方法 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | (继承自 TypeConverter。)
公共方法 | CreateInstance(IDictionary) | (继承自 TypeConverter。)
公共方法 | CreateInstance(ITypeDescriptorContext, IDictionary) | (继承自 TypeConverter。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
受保护的方法 | GetConvertFromException | (继承自 TypeConverter。)
受保护的方法 | GetConvertToException | (继承自 TypeConverter。)
公共方法 | GetCreateInstanceSupported | (继承自 TypeConverter。)
公共方法 | GetCreateInstanceSupported(ITypeDescriptorContext) | (继承自 TypeConverter。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetProperties(Object) | (继承自 TypeConverter。)
公共方法 | GetProperties(ITypeDescriptorContext, Object) | (继承自 TypeConverter。)
公共方法 | GetProperties(ITypeDescriptorContext, Object, Attribute) | (继承自 TypeConverter。)
公共方法 | GetPropertiesSupported | (继承自 TypeConverter。)
公共方法 | GetPropertiesSupported(ITypeDescriptorContext) | (继承自 TypeConverter。)
公共方法 | GetStandardValues | (继承自 TypeConverter。)
公共方法 | GetStandardValues(ITypeDescriptorContext) | (继承自 MyTypeConverter。)
公共方法 | GetStandardValuesExclusive | (继承自 TypeConverter。)
公共方法 | GetStandardValuesExclusive(ITypeDescriptorContext) | (继承自 MyTypeConverter。)
公共方法 | GetStandardValuesSupported | (继承自 TypeConverter。)
公共方法 | GetStandardValuesSupported(ITypeDescriptorContext) | (继承自 MyTypeConverter。)
公共方法 | GetType | (继承自 Object。)
公共方法 | GetValues | (重写 MyTypeConverter.GetValues.)
公共方法 | IsValid(Object) | (继承自 TypeConverter。)
公共方法 | IsValid(ITypeDescriptorContext, Object) | (继承自 TypeConverter。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | SortProperties | (继承自 TypeConverter。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SystemConfignotice_robotname_item 类
Api.Framework.Config 命名空间


SystemConfig.notice_robotname_item.GetValues 方法

SystemConfignotice_robotname_itemGetValues 方法

[缺少 "M:Api.Framework.Config.SystemConfig.notice_robotname_item.GetValues" 的 <summary> 文档]

命名空间： Api.Framework.Config
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string[] GetValues()

返回值

类型：String
参见

引用

SystemConfignotice_robotname_item 类
Api.Framework.Config 命名空间


Api.Framework.Cps 命名空间

[缺少 "N:Api.Framework.Cps" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | AlimamaApi | 阿里妈妈操作Api
公共类 | AlimamaApiCoupon | 优惠券结构类
公共类 | AlimamaApiTBEidExid | 淘宝eid绑定缓存
公共类 | BaseCpsApi | CpsApi基础类
公共类 | DouyinApi | 抖音操作Api
公共类 | jingdong_form_select_tgw | 京东推广位选择
公共类 | JingdongApi | 京东操作Api
公共类 | PinduoduoApi | 拼多多操作Api
公共类 | Tuiguangwei | 阿里妈妈推广位
公共类 | TuiguangweiActivity | 推广位强制返利
公共类 | weipinhui_form_login | 唯品会登录
公共类 | weipinhui_form_select_tgw | 唯品会推广位选择
公共类 | weipinhui_form_usernick | 唯品会名称设置
公共类 | WeipinhuiApi | 唯品会操作Api
枚举
 | 枚举 | 说明
公共枚举 | AlimamaApiAlimamaOrderStatus | 阿里妈妈订单状态
公共枚举 | AlimamaApiOrderType | 订单类型
公共枚举 | AlimamaApiTargetType | 请求目标类型 产品库/淘口令/订单页


AlimamaApi 类

阿里妈妈操作Api
继承层次
SystemObject
Api.Framework.CpsBaseCpsApi
Api.Framework.CpsAlimamaApi

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class AlimamaApi : BaseCpsApi

AlimamaApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
方法
 | 名称 | 说明
公共方法 | AddTBEid | 添加Eid缓存
公共方法 | AdzoneManage | 普通推广位列表
公共方法 | CheckCoupon | 检测淘宝优惠券
公共方法 | ComposeTbClick | 淘宝防屏蔽地址
公共方法 | ComposeTbCms | 拼接淘宝Cms地址.关键词:[推广位]、[关键词](注:小写的url编码)、[关键词U](注:大写的url编码)、
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | FindTransferAddress | 淘宝防屏蔽地址缓存
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | GetUnionPubContextInfo | 校验阿里妈妈cookiecs是否有效
公共方法 | IsTianmao | 判断是否是天猫商品
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | mtop_alimama_union_hsf_coupon_get | 解析优惠券信息
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | SendTaobao(String, Object) | 发送阿里妈妈报文
公共方法 | SendTaobao(String, Object, String, String) | 淘礼金调用
公共方法 | SerchOrder | 爬虫 - 从阿里妈妈官网提取订单
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


AlimamaApi 属性

AlimamaApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi 方法

AlimamaApi 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddTBEid | 添加Eid缓存
公共方法 | AdzoneManage | 普通推广位列表
公共方法 | CheckCoupon | 检测淘宝优惠券
公共方法 | ComposeTbClick | 淘宝防屏蔽地址
公共方法 | ComposeTbCms | 拼接淘宝Cms地址.关键词:[推广位]、[关键词](注:小写的url编码)、[关键词U](注:大写的url编码)、
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | FindTransferAddress | 淘宝防屏蔽地址缓存
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | GetUnionPubContextInfo | 校验阿里妈妈cookiecs是否有效
公共方法 | IsTianmao | 判断是否是天猫商品
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | mtop_alimama_union_hsf_coupon_get | 解析优惠券信息
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | SendTaobao(String, Object) | 发送阿里妈妈报文
公共方法 | SendTaobao(String, Object, String, String) | 淘礼金调用
公共方法 | SerchOrder | 爬虫 - 从阿里妈妈官网提取订单
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.AddTBEid 方法

AlimamaApiAddTBEid 方法

添加Eid缓存

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void AddTBEid(
    string external_id
)

参数

external_id
类型：SystemString
eid
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.AdzoneManage 方法

AlimamaApiAdzoneManage 方法

普通推广位列表

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> AdzoneManage(
    int topage,
    int pagesize
)

参数

topage
类型：SystemInt32
第几页
pagesize
类型：SystemInt32
页大小

返回值

类型：Dictionary String, Object
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.CheckCoupon 方法

AlimamaApiCheckCoupon 方法

检测淘宝优惠券

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public AlimamaApiCoupon CheckCoupon(
    string coupon_click_url
)

参数

coupon_click_url
类型：SystemString
优惠券地址

返回值

类型：AlimamaApiCoupon
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.ComposeTbClick 方法

AlimamaApiComposeTbClick 方法

淘宝防屏蔽地址

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ComposeTbClick(
    string itemId,
    string img,
    string tkl,
    string url,
    bool isShortUrl,
    int DwzType = -1,
    string target = ""
)

参数

itemId
类型：SystemString
淘宝ID
img
类型：SystemString
图片地址
tkl
类型：SystemString
淘口令
url
类型：SystemString
下单地址
isShortUrl
类型：SystemBoolean
是否缩短
DwzType (Optional)
类型：SystemInt32
缩短的枚举类型数值(-1为系统基础设置)
target (Optional)
类型：SystemString
自定义的目标地址

返回值

类型：String
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.ComposeTbCms 方法

AlimamaApiComposeTbCms 方法

拼接淘宝Cms地址.关键词:[推广位]、[关键词](注:小写的url编码)、[关键词U](注:大写的url编码)、

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ComposeTbCms(
    string pid,
    string keyword
)

参数

pid
类型：SystemString
推广位id
keyword
类型：SystemString
搜索的关键词

返回值

类型：String
拼接好的url
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.FindTransferAddress 方法

AlimamaApiFindTransferAddress 方法

淘宝防屏蔽地址缓存

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string FindTransferAddress(
    AlimamaApiTargetType type,
    bool refresh = false
)

参数

type
类型：Api.Framework.CpsAlimamaApiTargetType
请求目标类型(产品库/淘口令/订单页)
refresh (Optional)
类型：SystemBoolean
false获取缓存,true重新获取

返回值

类型：String
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.GetUnionPubContextInfo 方法

AlimamaApiGetUnionPubContextInfo 方法

校验阿里妈妈cookiecs是否有效

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, Object> GetUnionPubContextInfo(
    string cookies
)

参数

cookies
类型：SystemString
cookies

返回值

类型：Dictionary String, Object
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.IsTianmao 方法

AlimamaApiIsTianmao 方法

判断是否是天猫商品

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsTianmao(
    string itemid
)

参数

itemid
类型：SystemString
商品id

返回值

类型：Boolean
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.mtop_alimama_union_hsf_coupon_get 方法

AlimamaApimtop_alimama_union_hsf_coupon_get 方法

解析优惠券信息

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, Object> mtop_alimama_union_hsf_coupon_get(
    string sellerId,
    string activityId,
    string pid = ""
)

参数

sellerId
类型：SystemString
商家id
activityId
类型：SystemString
优惠券id
pid (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Cps.AlimamaApi.mtop_alimama_union_hsf_coupon_get(System.String,System.String,System.String)" 的 <param name="pid"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.SendTaobao 方法

AlimamaApiSendTaobao 方法

重载列表
 | 名称 | 说明
公共方法 | SendTaobao(String, Object) | 发送阿里妈妈报文
公共方法 | SendTaobao(String, Object, String, String) | 淘礼金调用
Top
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.SendTaobao 方法 (String, Object)

AlimamaApiSendTaobao 方法 (String, Object)

发送阿里妈妈报文

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> SendTaobao(
    string _api,
    Object _data
)

参数

_api
类型：SystemString
api名称
_data
类型：SystemObject
参数

返回值

类型：Dictionary String, Object
参见

引用

AlimamaApi 类
SendTaobao 重载
Api.Framework.Cps 命名空间


AlimamaApi.SendTaobao 方法 (String, Object, String, String)

AlimamaApiSendTaobao 方法 (String, Object, String, String)

淘礼金调用

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> SendTaobao(
    string _api,
    Object _data,
    string _appkey = "",
    string _appsecret = ""
)

参数

_api
类型：SystemString
api名称
_data
类型：SystemObject
参数
_appkey (Optional)
类型：SystemString
appkey
_appsecret (Optional)
类型：SystemString
appsecret

返回值

类型：Dictionary String, Object
参见

引用

AlimamaApi 类
SendTaobao 重载
Api.Framework.Cps 命名空间


AlimamaApi.SerchOrder 方法

AlimamaApiSerchOrder 方法

爬虫 - 从阿里妈妈官网提取订单

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<Dictionary<string, Object>> SerchOrder(
    AlimamaApiOrderType type,
    int queryType,
    string payStatus,
    int maxSize,
    DateTime day,
    int toPage
)

参数

type
类型：Api.Framework.CpsAlimamaApiOrderType
爬取的订单类型
queryType
类型：SystemInt32
写0吧
payStatus
类型：SystemString
写空吧
maxSize
类型：SystemInt32
最大1000
day
类型：SystemDateTime
不能操作90天最好少于90天
toPage
类型：SystemInt32
第几页

返回值

类型：List Dictionary String, Object
参见

引用

AlimamaApi 类
Api.Framework.Cps 命名空间


AlimamaApi.AlimamaOrderStatus 枚举

AlimamaApiAlimamaOrderStatus 枚举

阿里妈妈订单状态

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum AlimamaOrderStatus
成员
成员名称 | 值 | 说明
全部订单 | 1 |
订单结算 | 3 |
订单付款 | 12 |
订单失效 | 13 |
订单成功 | 14 |
订单维权中 | 15 |
参见

引用

Api.Framework.Cps 命名空间


AlimamaApi.Coupon 类

AlimamaApiCoupon 类

优惠券结构类
继承层次
SystemObject
Api.Framework.CpsAlimamaApiCoupon

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Coupon

AlimamaApiCoupon 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AlimamaApiCoupon | 初始化 AlimamaApiCoupon 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | amount | 使用金额
公共属性 | biz30Day | 30天销量
公共属性 | clickUrl | 点击下单
公共属性 | couponFlowLimit | 未知参数
公共属性 | discountPrice | 折扣价格
公共属性 | effectiveEndTime | 活动截止时间
公共属性 | effectiveStartTime | 使用时间
公共属性 | itemId | 宝贝ID
公共属性 | postFree | 未知参数
公共属性 | reservePrice | 原价
公共属性 | retStatus | 优惠券状态,!=0表示优惠券失效或没有优惠券
公共属性 | shareUrl | 分享地址
公共属性 | shopLogo | 店铺Logo
公共属性 | shopName | 店铺名称
公共属性 | startFee | 使用条件
公共属性 | title | 软件标题
公共属性 | tmall | 是否是天猫 ,1(是)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


AlimamaApi.Coupon 构造函数

AlimamaApiCoupon 构造函数

初始化 AlimamaApiCoupon 类的一个新实例

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Coupon()
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


Coupon 属性

AlimamaApiCoupon 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | amount | 使用金额
公共属性 | biz30Day | 30天销量
公共属性 | clickUrl | 点击下单
公共属性 | couponFlowLimit | 未知参数
公共属性 | discountPrice | 折扣价格
公共属性 | effectiveEndTime | 活动截止时间
公共属性 | effectiveStartTime | 使用时间
公共属性 | itemId | 宝贝ID
公共属性 | postFree | 未知参数
公共属性 | reservePrice | 原价
公共属性 | retStatus | 优惠券状态,!=0表示优惠券失效或没有优惠券
公共属性 | shareUrl | 分享地址
公共属性 | shopLogo | 店铺Logo
公共属性 | shopName | 店铺名称
公共属性 | startFee | 使用条件
公共属性 | title | 软件标题
公共属性 | tmall | 是否是天猫 ,1(是)
Top
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.amount 属性

AlimamaApiCouponamount 属性

使用金额

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string amount { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.biz30Day 属性

AlimamaApiCouponbiz30Day 属性

30天销量

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int biz30Day { get; set; }

属性值

类型：Int32
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.clickUrl 属性

AlimamaApiCouponclickUrl 属性

点击下单

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string clickUrl { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.couponFlowLimit 属性

AlimamaApiCouponcouponFlowLimit 属性

未知参数

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string couponFlowLimit { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.discountPrice 属性

AlimamaApiCoupondiscountPrice 属性

折扣价格

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string discountPrice { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.effectiveEndTime 属性

AlimamaApiCouponeffectiveEndTime 属性

活动截止时间

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime effectiveEndTime { get; set; }

属性值

类型：DateTime
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.effectiveStartTime 属性

AlimamaApiCouponeffectiveStartTime 属性

使用时间

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime effectiveStartTime { get; set; }

属性值

类型：DateTime
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.itemId 属性

AlimamaApiCouponitemId 属性

宝贝ID

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string itemId { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.postFree 属性

AlimamaApiCouponpostFree 属性

未知参数

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int postFree { get; set; }

属性值

类型：Int32
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.reservePrice 属性

AlimamaApiCouponreservePrice 属性

原价

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string reservePrice { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.retStatus 属性

AlimamaApiCouponretStatus 属性

优惠券状态,!=0表示优惠券失效或没有优惠券

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int retStatus { get; set; }

属性值

类型：Int32
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.shareUrl 属性

AlimamaApiCouponshareUrl 属性

分享地址

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string shareUrl { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.shopLogo 属性

AlimamaApiCouponshopLogo 属性

店铺Logo

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string shopLogo { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.shopName 属性

AlimamaApiCouponshopName 属性

店铺名称

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string shopName { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.startFee 属性

AlimamaApiCouponstartFee 属性

使用条件

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string startFee { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.title 属性

AlimamaApiCoupontitle 属性

软件标题

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string title { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.Coupon.tmall 属性

AlimamaApiCoupontmall 属性

是否是天猫 ,1(是)

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string tmall { get; set; }

属性值

类型：String
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


Coupon 方法

AlimamaApiCoupon 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

AlimamaApiCoupon 类
Api.Framework.Cps 命名空间


AlimamaApi.OrderType 枚举

AlimamaApiOrderType 枚举

订单类型

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum OrderType
成员
成员名称 | 值 | 说明
淘客订单明细 | 1 |
第三方订单明细 | 2 |
维权退款明细 | 3 |
参见

引用

Api.Framework.Cps 命名空间


AlimamaApi.TargetType 枚举

AlimamaApiTargetType 枚举

请求目标类型 产品库/淘口令/订单页

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum TargetType
成员
成员名称 | 值 | 说明
淘口令 | 1 |
产品库 | 2 |
订单页 | 3 |
参见

引用

Api.Framework.Cps 命名空间


AlimamaApi.TBEidExid 类

AlimamaApiTBEidExid 类

淘宝eid绑定缓存
继承层次
SystemObject
Api.Framework.CpsAlimamaApiTBEidExid

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class TBEidExid

AlimamaApiTBEidExid 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AlimamaApiTBEidExid | 初始化 AlimamaApiTBEidExid 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | dietime | 失效时间
公共属性 | external_id | eid
公共属性 | special_id | 淘宝客外部用户标记，如自身系统账户ID；微信ID等
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


AlimamaApi.TBEidExid 构造函数

AlimamaApiTBEidExid 构造函数

初始化 AlimamaApiTBEidExid 类的一个新实例

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TBEidExid()
参见

引用

AlimamaApiTBEidExid 类
Api.Framework.Cps 命名空间


TBEidExid 属性

AlimamaApiTBEidExid 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | dietime | 失效时间
公共属性 | external_id | eid
公共属性 | special_id | 淘宝客外部用户标记，如自身系统账户ID；微信ID等
Top
参见

引用

AlimamaApiTBEidExid 类
Api.Framework.Cps 命名空间


AlimamaApi.TBEidExid.dietime 属性

AlimamaApiTBEidExiddietime 属性

失效时间

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int dietime { get; set; }

属性值

类型：Int32
参见

引用

AlimamaApiTBEidExid 类
Api.Framework.Cps 命名空间


AlimamaApi.TBEidExid.external_id 属性

AlimamaApiTBEidExidexternal_id 属性

eid

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string external_id { get; set; }

属性值

类型：String
参见

引用

AlimamaApiTBEidExid 类
Api.Framework.Cps 命名空间


AlimamaApi.TBEidExid.special_id 属性

AlimamaApiTBEidExidspecial_id 属性

淘宝客外部用户标记，如自身系统账户ID；微信ID等

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string special_id { get; set; }

属性值

类型：String
参见

引用

AlimamaApiTBEidExid 类
Api.Framework.Cps 命名空间


TBEidExid 方法

AlimamaApiTBEidExid 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

AlimamaApiTBEidExid 类
Api.Framework.Cps 命名空间


BaseCpsApi 类

CpsApi基础类
继承层次
SystemObject
Api.Framework.CpsBaseCpsApi
Api.Framework.CpsAlimamaApi
Api.Framework.CpsDouyinApi
Api.Framework.CpsJingdongApi
Api.Framework.CpsPinduoduoApi
Api.Framework.CpsWeipinhuiApi

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class BaseCpsApi

BaseCpsApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SendServer(String, Object) | 发送API数据
公共方法 | SendServer(String, String, Object) | 请求报文
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


BaseCpsApi 属性

BaseCpsApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象
Top
参见

引用

BaseCpsApi 类
Api.Framework.Cps 命名空间


BaseCpsApi.Member 属性

BaseCpsApiMember 属性

cps数据对象

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_cps_member Member { get; protected set; }

属性值

类型：fl_cps_member
参见

引用

BaseCpsApi 类
Api.Framework.Cps 命名空间


BaseCpsApi 方法

BaseCpsApi 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SendServer(String, Object) | 发送API数据
公共方法 | SendServer(String, String, Object) | 请求报文
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

BaseCpsApi 类
Api.Framework.Cps 命名空间


BaseCpsApi.SendServer 方法

BaseCpsApiSendServer 方法

重载列表
 | 名称 | 说明
公共方法 | SendServer(String, Object) | 发送API数据
公共方法 | SendServer(String, String, Object) | 请求报文
Top
参见

引用

BaseCpsApi 类
Api.Framework.Cps 命名空间


BaseCpsApi.SendServer 方法 (String, Object)

BaseCpsApiSendServer 方法 (String, Object)

发送API数据

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WebResult SendServer(
    string method,
    Object param = null
)

参数

method
类型：SystemString
API接口
param (Optional)
类型：SystemObject
参数

返回值

类型：WebResult
参见

引用

BaseCpsApi 类
SendServer 重载
Api.Framework.Cps 命名空间


BaseCpsApi.SendServer 方法 (String, String, Object)

BaseCpsApiSendServer 方法 (String, String, Object)

请求报文

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WebResult SendServer(
    string method,
    string target = "",
    Object param = null
)

参数

method
类型：SystemString

[缺少 "M:Api.Framework.Cps.BaseCpsApi.SendServer(System.String,System.String,System.Object)" 的 <param name="method"/> 文档]

target (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Cps.BaseCpsApi.SendServer(System.String,System.String,System.Object)" 的 <param name="target"/> 文档]

param (Optional)
类型：SystemObject

[缺少 "M:Api.Framework.Cps.BaseCpsApi.SendServer(System.String,System.String,System.Object)" 的 <param name="param"/> 文档]

返回值

类型：WebResult
参见

引用

BaseCpsApi 类
SendServer 重载
Api.Framework.Cps 命名空间


DouyinApi 类

抖音操作Api
继承层次
SystemObject
Api.Framework.CpsBaseCpsApi
Api.Framework.CpsDouyinApi

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DouyinApi : BaseCpsApi

DouyinApi 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DouyinApi | 初始化抖音cps
Top
属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
方法
 | 名称 | 说明
公共方法 | AddGoodsWindowUrl | 添加商品至橱柜
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindGoodsInfo | 通过商品链接查询商品信息
公共方法 | GetCookie | 获取登录的抖音cookie
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetShopWindow_PromotionUrlToGoodsId | 通过商品id查询橱柜中的商品,获取推广链接
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | SetMember | 设置登录的抖音数据库实例
公共方法 | ToString | (继承自 Object。)
Top
字段
 | 名称 | 说明
公共字段 | chromeBrowser | cef对象
 | douyinApiAction | 抖音登录委托
公共字段 | IsQualifiedAction | 登录抖音账号是否满足条件委托
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


DouyinApi 构造函数

初始化抖音cps

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DouyinApi(
    fl_cps_member member
)

参数

member
类型：Api.Framework.Modelfl_cps_member

[缺少 "M:Api.Framework.Cps.DouyinApi.#ctor(Api.Framework.Model.fl_cps_member)" 的 <param name="member"/> 文档]

参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi 属性

DouyinApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi 方法

DouyinApi 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddGoodsWindowUrl | 添加商品至橱柜
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindGoodsInfo | 通过商品链接查询商品信息
公共方法 | GetCookie | 获取登录的抖音cookie
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetShopWindow_PromotionUrlToGoodsId | 通过商品id查询橱柜中的商品,获取推广链接
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | SetMember | 设置登录的抖音数据库实例
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi.AddGoodsWindowUrl 方法

DouyinApiAddGoodsWindowUrl 方法

添加商品至橱柜

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool AddGoodsWindowUrl(
    string product_id
)

参数

product_id
类型：SystemString
商品id

返回值

类型：Boolean
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi.FindGoodsInfo 方法

DouyinApiFindGoodsInfo 方法

通过商品链接查询商品信息

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DouyinGoodsInfo FindGoodsInfo(
    string goodsId
)

参数

goodsId
类型：SystemString
商品id

返回值

类型：DouyinGoodsInfo
返回商品的基础信息
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi.GetCookie 方法

DouyinApiGetCookie 方法

获取登录的抖音cookie

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetCookie()

返回值

类型：String
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi.GetShopWindow_PromotionUrlToGoodsId 方法

DouyinApiGetShopWindow_PromotionUrlToGoodsId 方法

通过商品id查询橱柜中的商品,获取推广链接

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetShopWindow_PromotionUrlToGoodsId(
    string goodsid
)

参数

goodsid
类型：SystemString
商品id

返回值

类型：String
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi.SetMember 方法

DouyinApiSetMember 方法

设置登录的抖音数据库实例

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SetMember(
    fl_cps_member Member
)

参数

Member
类型：Api.Framework.Modelfl_cps_member

[缺少 "M:Api.Framework.Cps.DouyinApi.SetMember(Api.Framework.Model.fl_cps_member)" 的 <param name="Member"/> 文档]

参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi 字段

DouyinApi 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | chromeBrowser | cef对象
 | douyinApiAction | 抖音登录委托
公共字段 | IsQualifiedAction | 登录抖音账号是否满足条件委托
Top
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi.chromeBrowser 字段

DouyinApichromeBrowser 字段

cef对象

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChromiumWebBrowser chromeBrowser

字段值

类型：ChromiumWebBrowser
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi.douyinApiAction 字段

DouyinApidouyinApiAction 字段

抖音登录委托

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Action<DouyinApi> douyinApiAction

字段值

类型：Action DouyinApi
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


DouyinApi.IsQualifiedAction 字段

DouyinApiIsQualifiedAction 字段

登录抖音账号是否满足条件委托

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Action<DouyinLoginType, DouyinApi> IsQualifiedAction

字段值

类型：Action DouyinLoginType, DouyinApi
参见

引用

DouyinApi 类
Api.Framework.Cps 命名空间


jingdong_form_select_tgw 类

京东推广位选择
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
Api.Framework.Cpsjingdong_form_select_tgw

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class jingdong_form_select_tgw : BaseForm

jingdong_form_select_tgw 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


jingdong_form_select_tgw 属性

jingdong_form_select_tgw 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

jingdong_form_select_tgw 类
Api.Framework.Cps 命名空间


jingdong_form_select_tgw 方法

jingdong_form_select_tgw 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

jingdong_form_select_tgw 类
Api.Framework.Cps 命名空间


jingdong_form_select_tgw.Dispose 方法

jingdong_form_select_tgwDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
Top
参见

引用

jingdong_form_select_tgw 类
Api.Framework.Cps 命名空间


jingdong_form_select_tgw.Dispose 方法 (Boolean)

jingdong_form_select_tgwDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

jingdong_form_select_tgw 类
Dispose 重载
Api.Framework.Cps 命名空间


jingdong_form_select_tgw 事件

jingdong_form_select_tgw 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

jingdong_form_select_tgw 类
Api.Framework.Cps 命名空间


jingdong_form_select_tgw 字段

jingdong_form_select_tgw 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
参见

引用

jingdong_form_select_tgw 类
Api.Framework.Cps 命名空间


JingdongApi 类

京东操作Api
继承层次
SystemObject
Api.Framework.CpsBaseCpsApi
Api.Framework.CpsJingdongApi

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class JingdongApi : BaseCpsApi

JingdongApi 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | JingdongApi | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | RefreshStatus | 刷新授权
公共方法 | SendJingdong | 发送京东报文
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


JingdongApi 构造函数

构造方法

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public JingdongApi(
    fl_cps_member member
)

参数

member
类型：Api.Framework.Modelfl_cps_member
fl_cps_member实例
参见

引用

JingdongApi 类
Api.Framework.Cps 命名空间


JingdongApi 属性

JingdongApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
参见

引用

JingdongApi 类
Api.Framework.Cps 命名空间


JingdongApi 方法

JingdongApi 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | RefreshStatus | 刷新授权
公共方法 | SendJingdong | 发送京东报文
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

JingdongApi 类
Api.Framework.Cps 命名空间


JingdongApi.RefreshStatus 方法

JingdongApiRefreshStatus 方法

刷新授权

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void RefreshStatus()
参见

引用

JingdongApi 类
Api.Framework.Cps 命名空间


JingdongApi.SendJingdong 方法

JingdongApiSendJingdong 方法

发送京东报文

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> SendJingdong(
    string api,
    Object data
)

参数

api
类型：SystemString
api接口
data
类型：SystemObject
参数

返回值

类型：Dictionary String, Object
参见

引用

JingdongApi 类
Api.Framework.Cps 命名空间


PinduoduoApi 类

拼多多操作Api
继承层次
SystemObject
Api.Framework.CpsBaseCpsApi
Api.Framework.CpsPinduoduoApi

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PinduoduoApi : BaseCpsApi

PinduoduoApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SendPinduoduo | 发送拼多多报文
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


PinduoduoApi 属性

PinduoduoApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
参见

引用

PinduoduoApi 类
Api.Framework.Cps 命名空间


PinduoduoApi 方法

PinduoduoApi 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SendPinduoduo | 发送拼多多报文
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PinduoduoApi 类
Api.Framework.Cps 命名空间


PinduoduoApi.SendPinduoduo 方法

PinduoduoApiSendPinduoduo 方法

发送拼多多报文

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> SendPinduoduo(
    string api,
    Object data
)

参数

api
类型：SystemString
请求的api
data
类型：SystemObject
参数

返回值

类型：Dictionary String, Object
参见

引用

PinduoduoApi 类
Api.Framework.Cps 命名空间


Tuiguangwei 类

阿里妈妈推广位
继承层次
SystemObject
Api.Framework.CpsTuiguangwei
Api.Framework.CpsTuiguangweiActivity

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Tuiguangwei

Tuiguangwei 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Tuiguangwei | 初始化 Tuiguangwei 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Member | 账号
公共属性 | Name | 推广位名称
公共属性 | Pid | 推广位
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


Tuiguangwei 构造函数

初始化 Tuiguangwei 类的一个新实例

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Tuiguangwei()
参见

引用

Tuiguangwei 类
Api.Framework.Cps 命名空间


Tuiguangwei 属性

Tuiguangwei 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | 账号
公共属性 | Name | 推广位名称
公共属性 | Pid | 推广位
Top
参见

引用

Tuiguangwei 类
Api.Framework.Cps 命名空间


Tuiguangwei.Member 属性

TuiguangweiMember 属性

账号

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_cps_member Member { get; set; }

属性值

类型：fl_cps_member
参见

引用

Tuiguangwei 类
Api.Framework.Cps 命名空间


Tuiguangwei.Name 属性

TuiguangweiName 属性

推广位名称

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Name { get; set; }

属性值

类型：String
参见

引用

Tuiguangwei 类
Api.Framework.Cps 命名空间


Tuiguangwei.Pid 属性

TuiguangweiPid 属性

推广位

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Pid { get; set; }

属性值

类型：String
参见

引用

Tuiguangwei 类
Api.Framework.Cps 命名空间


Tuiguangwei 方法

Tuiguangwei 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Tuiguangwei 类
Api.Framework.Cps 命名空间


TuiguangweiActivity 类

推广位强制返利
继承层次
SystemObject
Api.Framework.CpsTuiguangwei
Api.Framework.CpsTuiguangweiActivity

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class TuiguangweiActivity : Tuiguangwei

TuiguangweiActivity 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TuiguangweiActivity | 初始化 TuiguangweiActivity 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Member | 账号 (继承自 Tuiguangwei。)
公共属性 | Name | 推广位名称 (继承自 Tuiguangwei。)
公共属性 | Pid | 推广位 (继承自 Tuiguangwei。)
公共属性 | ShortUrl | 短连接
公共属性 | Tkl | 淘口令
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


TuiguangweiActivity 构造函数

初始化 TuiguangweiActivity 类的一个新实例

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TuiguangweiActivity()
参见

引用

TuiguangweiActivity 类
Api.Framework.Cps 命名空间


TuiguangweiActivity 属性

TuiguangweiActivity 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | 账号 (继承自 Tuiguangwei。)
公共属性 | Name | 推广位名称 (继承自 Tuiguangwei。)
公共属性 | Pid | 推广位 (继承自 Tuiguangwei。)
公共属性 | ShortUrl | 短连接
公共属性 | Tkl | 淘口令
Top
参见

引用

TuiguangweiActivity 类
Api.Framework.Cps 命名空间


TuiguangweiActivity.ShortUrl 属性

TuiguangweiActivityShortUrl 属性

短连接

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ShortUrl { get; set; }

属性值

类型：String
参见

引用

TuiguangweiActivity 类
Api.Framework.Cps 命名空间


TuiguangweiActivity.Tkl 属性

TuiguangweiActivityTkl 属性

淘口令

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Tkl { get; set; }

属性值

类型：String
参见

引用

TuiguangweiActivity 类
Api.Framework.Cps 命名空间


TuiguangweiActivity 方法

TuiguangweiActivity 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

TuiguangweiActivity 类
Api.Framework.Cps 命名空间


weipinhui_form_login 类

唯品会登录
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
Api.Framework.Cpsweipinhui_form_login

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class weipinhui_form_login : BaseForm

weipinhui_form_login 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


weipinhui_form_login 属性

weipinhui_form_login 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

weipinhui_form_login 类
Api.Framework.Cps 命名空间


weipinhui_form_login 方法

weipinhui_form_login 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

weipinhui_form_login 类
Api.Framework.Cps 命名空间


weipinhui_form_login.Dispose 方法

weipinhui_form_loginDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
Top
参见

引用

weipinhui_form_login 类
Api.Framework.Cps 命名空间


weipinhui_form_login.Dispose 方法 (Boolean)

weipinhui_form_loginDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

weipinhui_form_login 类
Dispose 重载
Api.Framework.Cps 命名空间


weipinhui_form_login 事件

weipinhui_form_login 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

weipinhui_form_login 类
Api.Framework.Cps 命名空间


weipinhui_form_login 字段

weipinhui_form_login 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
参见

引用

weipinhui_form_login 类
Api.Framework.Cps 命名空间


weipinhui_form_select_tgw 类

唯品会推广位选择
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
Api.Framework.Cpsweipinhui_form_select_tgw

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class weipinhui_form_select_tgw : BaseForm

weipinhui_form_select_tgw 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


weipinhui_form_select_tgw 属性

weipinhui_form_select_tgw 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

weipinhui_form_select_tgw 类
Api.Framework.Cps 命名空间


weipinhui_form_select_tgw 方法

weipinhui_form_select_tgw 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

weipinhui_form_select_tgw 类
Api.Framework.Cps 命名空间


weipinhui_form_select_tgw.Dispose 方法

weipinhui_form_select_tgwDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
Top
参见

引用

weipinhui_form_select_tgw 类
Api.Framework.Cps 命名空间


weipinhui_form_select_tgw.Dispose 方法 (Boolean)

weipinhui_form_select_tgwDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

weipinhui_form_select_tgw 类
Dispose 重载
Api.Framework.Cps 命名空间


weipinhui_form_select_tgw 事件

weipinhui_form_select_tgw 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

weipinhui_form_select_tgw 类
Api.Framework.Cps 命名空间


weipinhui_form_select_tgw 字段

weipinhui_form_select_tgw 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
参见

引用

weipinhui_form_select_tgw 类
Api.Framework.Cps 命名空间


weipinhui_form_usernick 类

唯品会名称设置
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
Api.Framework.Cpsweipinhui_form_usernick

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class weipinhui_form_usernick : BaseForm

weipinhui_form_usernick 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


weipinhui_form_usernick 属性

weipinhui_form_usernick 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

weipinhui_form_usernick 类
Api.Framework.Cps 命名空间


weipinhui_form_usernick 方法

weipinhui_form_usernick 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

weipinhui_form_usernick 类
Api.Framework.Cps 命名空间


weipinhui_form_usernick.Dispose 方法

weipinhui_form_usernickDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
Top
参见

引用

weipinhui_form_usernick 类
Api.Framework.Cps 命名空间


weipinhui_form_usernick.Dispose 方法 (Boolean)

weipinhui_form_usernickDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

weipinhui_form_usernick 类
Dispose 重载
Api.Framework.Cps 命名空间


weipinhui_form_usernick 事件

weipinhui_form_usernick 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

weipinhui_form_usernick 类
Api.Framework.Cps 命名空间


weipinhui_form_usernick 字段

weipinhui_form_usernick 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
参见

引用

weipinhui_form_usernick 类
Api.Framework.Cps 命名空间


WeipinhuiApi 类

唯品会操作Api
继承层次
SystemObject
Api.Framework.CpsBaseCpsApi
Api.Framework.CpsWeipinhuiApi

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WeipinhuiApi : BaseCpsApi

WeipinhuiApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
方法
 | 名称 | 说明
 | CreateWphTgw | 创建推广位
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | GetWphTgw | 获取唯品会推广位
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | RefreshStatus | 刷新授权
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | SendWeipinhui(String, Object) | 发送唯品会报文
公共方法 | SendWeipinhuiT(String, Object) | 发送唯品会报文
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps 命名空间


WeipinhuiApi 属性

WeipinhuiApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Member | cps数据对象 (继承自 BaseCpsApi。)
Top
参见

引用

WeipinhuiApi 类
Api.Framework.Cps 命名空间


WeipinhuiApi 方法

WeipinhuiApi 类型公开以下成员。

方法
 | 名称 | 说明
 | CreateWphTgw | 创建推广位
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | GetWphTgw | 获取唯品会推广位
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | RefreshStatus | 刷新授权
公共方法 | SendServer(String, Object) | 发送API数据 (继承自 BaseCpsApi。)
公共方法 | SendServer(String, String, Object) | 请求报文 (继承自 BaseCpsApi。)
公共方法 | SendWeipinhui(String, Object) | 发送唯品会报文
公共方法 | SendWeipinhuiT(String, Object) | 发送唯品会报文
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WeipinhuiApi 类
Api.Framework.Cps 命名空间


WeipinhuiApi.CreateWphTgw 方法

WeipinhuiApiCreateWphTgw 方法

创建推广位

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void CreateWphTgw(
    WeipinhuiApi api,
    List<string> pidList = null
)

参数

api
类型：Api.Framework.CpsWeipinhuiApi
WeipinhuiApi对象
pidList (Optional)
类型：System.Collections.GenericList String
要创建的推广位名称
参见

引用

WeipinhuiApi 类
Api.Framework.Cps 命名空间


WeipinhuiApi.GetWphTgw 方法

WeipinhuiApiGetWphTgw 方法

获取唯品会推广位

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ArrayList GetWphTgw(
    WeipinhuiApi api,
    int page = 1,
    int pageSize = 20
)

参数

api
类型：Api.Framework.CpsWeipinhuiApi
WeipinhuiApi对象
page (Optional)
类型：SystemInt32
第几页
pageSize (Optional)
类型：SystemInt32
每页的数量

返回值

类型：ArrayList
参见

引用

WeipinhuiApi 类
Api.Framework.Cps 命名空间


WeipinhuiApi.RefreshStatus 方法

WeipinhuiApiRefreshStatus 方法

刷新授权

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void RefreshStatus()
参见

引用

WeipinhuiApi 类
Api.Framework.Cps 命名空间


WeipinhuiApi.SendWeipinhui 方法

WeipinhuiApiSendWeipinhui 方法

重载列表
 | 名称 | 说明
公共方法 | SendWeipinhui(String, Object) | 发送唯品会报文
公共方法 | SendWeipinhuiT(String, Object) | 发送唯品会报文
Top
参见

引用

WeipinhuiApi 类
Api.Framework.Cps 命名空间


WeipinhuiApi.SendWeipinhui 方法 (String, Object)

WeipinhuiApiSendWeipinhui 方法 (String, Object)

发送唯品会报文

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> SendWeipinhui(
    string api,
    Object data
)

参数

api
类型：SystemString
api接口
data
类型：SystemObject
参数

返回值

类型：Dictionary String, Object
参见

引用

WeipinhuiApi 类
SendWeipinhui 重载
Api.Framework.Cps 命名空间


WeipinhuiApi.SendWeipinhui(T) 方法 (String, Object)

WeipinhuiApiSendWeipinhuiT 方法 (String, Object)

发送唯品会报文

命名空间： Api.Framework.Cps
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public T SendWeipinhui<T>(
    string api,
    Object data
)

参数

api
类型：SystemString
api接口
data
类型：SystemObject
参数

类型参数

T

返回值

类型：T
参见

引用

WeipinhuiApi 类
SendWeipinhui 重载
Api.Framework.Cps 命名空间


Api.Framework.Cps.CefSharp1 命名空间

[缺少 "N:Api.Framework.Cps.CefSharp1" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | BaseResult |
公共类 | BrowseInfo |
公共类 | BrowserAndLoginInfo |
公共类 | CEFRequestHandler | 拦截请求
公共类 | CEFResponseHandler | 拦截响应数据
公共类 | CookieVisitor |
公共类 | DouyinPackHist |
公共类 | DouyinPool |
公共类 | LoginInfo |


BaseResult 类

[缺少 "T:Api.Framework.Cps.CefSharp1.BaseResult" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.Cps.CefSharp1BaseResult

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class BaseResult

BaseResult 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BaseResult | 初始化 BaseResult 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Json |
公共属性 | MsgId |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps.CefSharp1 命名空间


BaseResult 构造函数

初始化 BaseResult 类的一个新实例

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BaseResult()
参见

引用

BaseResult 类
Api.Framework.Cps.CefSharp1 命名空间


BaseResult 属性

BaseResult 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Json |
公共属性 | MsgId |
Top
参见

引用

BaseResult 类
Api.Framework.Cps.CefSharp1 命名空间


BaseResult.Json 属性

BaseResultJson 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BaseResult.Json" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Json { get; set; }

属性值

类型：String
参见

引用

BaseResult 类
Api.Framework.Cps.CefSharp1 命名空间


BaseResult.MsgId 属性

BaseResultMsgId 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BaseResult.MsgId" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string MsgId { get; set; }

属性值

类型：String
参见

引用

BaseResult 类
Api.Framework.Cps.CefSharp1 命名空间


BaseResult 方法

BaseResult 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

BaseResult 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo 类

[缺少 "T:Api.Framework.Cps.CefSharp1.BrowseInfo" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.Cps.CefSharp1BrowseInfo

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class BrowseInfo

BrowseInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BrowseInfo | 初始化 BrowseInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | app_id |
公共属性 | browser |
公共属性 | browser_version |
公共属性 | custom |
公共属性 | device_model |
公共属性 | height |
公共属性 | language |
公共属性 | os_name |
公共属性 | os_version |
公共属性 | platform |
公共属性 | referrer |
公共属性 | referrer_host |
公共属性 | resolution |
公共属性 | screen_height |
公共属性 | screen_width |
公共属性 | sdk_lib |
公共属性 | sdk_version |
公共属性 | timezone |
公共属性 | tz_offset |
公共属性 | width |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo 构造函数

初始化 BrowseInfo 类的一个新实例

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BrowseInfo()
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo 属性

BrowseInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | app_id |
公共属性 | browser |
公共属性 | browser_version |
公共属性 | custom |
公共属性 | device_model |
公共属性 | height |
公共属性 | language |
公共属性 | os_name |
公共属性 | os_version |
公共属性 | platform |
公共属性 | referrer |
公共属性 | referrer_host |
公共属性 | resolution |
公共属性 | screen_height |
公共属性 | screen_width |
公共属性 | sdk_lib |
公共属性 | sdk_version |
公共属性 | timezone |
公共属性 | tz_offset |
公共属性 | width |
Top
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.app_id 属性

BrowseInfoapp_id 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.app_id" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int app_id { get; set; }

属性值

类型：Int32
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.browser 属性

BrowseInfobrowser 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.browser" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string browser { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.browser_version 属性

BrowseInfobrowser_version 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.browser_version" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string browser_version { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.custom 属性

BrowseInfocustom 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.custom" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object custom { get; set; }

属性值

类型：Object
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.device_model 属性

BrowseInfodevice_model 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.device_model" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string device_model { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.height 属性

BrowseInfoheight 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.height" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int height { get; set; }

属性值

类型：Int32
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.language 属性

BrowseInfolanguage 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.language" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string language { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.os_name 属性

BrowseInfoos_name 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.os_name" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string os_name { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.os_version 属性

BrowseInfoos_version 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.os_version" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string os_version { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.platform 属性

BrowseInfoplatform 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.platform" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string platform { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.referrer 属性

BrowseInforeferrer 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.referrer" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string referrer { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.referrer_host 属性

BrowseInforeferrer_host 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.referrer_host" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string referrer_host { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.resolution 属性

BrowseInforesolution 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.resolution" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string resolution { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.screen_height 属性

BrowseInfoscreen_height 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.screen_height" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int screen_height { get; set; }

属性值

类型：Int32
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.screen_width 属性

BrowseInfoscreen_width 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.screen_width" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int screen_width { get; set; }

属性值

类型：Int32
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.sdk_lib 属性

BrowseInfosdk_lib 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.sdk_lib" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string sdk_lib { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.sdk_version 属性

BrowseInfosdk_version 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.sdk_version" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string sdk_version { get; set; }

属性值

类型：String
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.timezone 属性

BrowseInfotimezone 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.timezone" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int timezone { get; set; }

属性值

类型：Int32
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.tz_offset 属性

BrowseInfotz_offset 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.tz_offset" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int tz_offset { get; set; }

属性值

类型：Int32
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo.width 属性

BrowseInfowidth 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowseInfo.width" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int width { get; set; }

属性值

类型：Int32
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowseInfo 方法

BrowseInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

BrowseInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowserAndLoginInfo 类

[缺少 "T:Api.Framework.Cps.CefSharp1.BrowserAndLoginInfo" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.Cps.CefSharp1BrowserAndLoginInfo

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class BrowserAndLoginInfo

BrowserAndLoginInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BrowserAndLoginInfo | 初始化 BrowserAndLoginInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | browseInfo |
公共属性 | event_index |
公共属性 | loginInfo |
公共属性 | session_id |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps.CefSharp1 命名空间


BrowserAndLoginInfo 构造函数

初始化 BrowserAndLoginInfo 类的一个新实例

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BrowserAndLoginInfo()
参见

引用

BrowserAndLoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowserAndLoginInfo 属性

BrowserAndLoginInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | browseInfo |
公共属性 | event_index |
公共属性 | loginInfo |
公共属性 | session_id |
Top
参见

引用

BrowserAndLoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowserAndLoginInfo.browseInfo 属性

BrowserAndLoginInfobrowseInfo 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowserAndLoginInfo.browseInfo" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BrowseInfo browseInfo { get; set; }

属性值

类型：BrowseInfo
参见

引用

BrowserAndLoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowserAndLoginInfo.event_index 属性

BrowserAndLoginInfoevent_index 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowserAndLoginInfo.event_index" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long event_index { get; set; }

属性值

类型：Int64
参见

引用

BrowserAndLoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowserAndLoginInfo.loginInfo 属性

BrowserAndLoginInfologinInfo 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowserAndLoginInfo.loginInfo" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public LoginInfo loginInfo { get; set; }

属性值

类型：LoginInfo
参见

引用

BrowserAndLoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowserAndLoginInfo.session_id 属性

BrowserAndLoginInfosession_id 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.BrowserAndLoginInfo.session_id" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string session_id { get; set; }

属性值

类型：String
参见

引用

BrowserAndLoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


BrowserAndLoginInfo 方法

BrowserAndLoginInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

BrowserAndLoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler 类

拦截请求
继承层次
SystemObject
Api.Framework.Cps.CefSharp1CEFRequestHandler

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CEFRequestHandler : IRequestHandler

CEFRequestHandler 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CEFRequestHandler | 初始化 CEFRequestHandler 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetAuthCredentials |
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResourceRequestHandler |
公共方法 | GetResourceResponseFilter |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | OnBeforeBrowse(IWebBrowser, IBrowser, IFrame, IRequest, Boolean) |
公共方法 | OnBeforeBrowse(IWebBrowser, IBrowser, IFrame, IRequest, Boolean, Boolean) |
公共方法 | OnBeforeResourceLoad |
公共方法 | OnCertificateError |
公共方法 | OnDocumentAvailableInMainFrame |
公共方法 | OnOpenUrlFromTab |
公共方法 | OnPluginCrashed |
公共方法 | OnProtocolExecution |
公共方法 | OnQuotaRequest |
公共方法 | OnRenderProcessTerminated |
公共方法 | OnRenderViewReady |
公共方法 | OnResourceLoadComplete |
公共方法 | OnResourceRedirect(IWebBrowser, IBrowser, IFrame, IRequest, String) |
公共方法 | OnResourceRedirect(IWebBrowser, IBrowser, IFrame, IRequest, IResponse, String) |
公共方法 | OnResourceResponse |
公共方法 | OnSelectClientCertificate |
公共方法 | ToString | (继承自 Object。)
Top
事件
 | 名称 | 说明
公共事件 | BrowserAndLoginInfoAction |
公共事件 | JsonAction |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler 构造函数

初始化 CEFRequestHandler 类的一个新实例

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CEFRequestHandler()
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler 方法

CEFRequestHandler 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetAuthCredentials |
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResourceRequestHandler |
公共方法 | GetResourceResponseFilter |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | OnBeforeBrowse(IWebBrowser, IBrowser, IFrame, IRequest, Boolean) |
公共方法 | OnBeforeBrowse(IWebBrowser, IBrowser, IFrame, IRequest, Boolean, Boolean) |
公共方法 | OnBeforeResourceLoad |
公共方法 | OnCertificateError |
公共方法 | OnDocumentAvailableInMainFrame |
公共方法 | OnOpenUrlFromTab |
公共方法 | OnPluginCrashed |
公共方法 | OnProtocolExecution |
公共方法 | OnQuotaRequest |
公共方法 | OnRenderProcessTerminated |
公共方法 | OnRenderViewReady |
公共方法 | OnResourceLoadComplete |
公共方法 | OnResourceRedirect(IWebBrowser, IBrowser, IFrame, IRequest, String) |
公共方法 | OnResourceRedirect(IWebBrowser, IBrowser, IFrame, IRequest, IResponse, String) |
公共方法 | OnResourceResponse |
公共方法 | OnSelectClientCertificate |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.GetAuthCredentials 方法

CEFRequestHandlerGetAuthCredentials 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool GetAuthCredentials(
    IWebBrowser chromiumWebBrowser,
    IBrowser browser,
    string originUrl,
    bool isProxy,
    string host,
    int port,
    string realm,
    string scheme,
    IAuthCallback callback
)

参数

chromiumWebBrowser
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <param name="chromiumWebBrowser"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <param name="browser"/> 文档]

originUrl
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <param name="originUrl"/> 文档]

isProxy
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <param name="isProxy"/> 文档]

host
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <param name="host"/> 文档]

port
类型：SystemInt32

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <param name="port"/> 文档]

realm
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <param name="realm"/> 文档]

scheme
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <param name="scheme"/> 文档]

callback
类型：IAuthCallback

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetAuthCredentials(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Boolean,System.String,System.Int32,System.String,System.String,CefSharp.IAuthCallback)" 的 <param name="callback"/> 文档]

返回值

类型：Boolean

实现

IRequestHandler.GetAuthCredentials(IWebBrowser, IBrowser, String, Boolean, String, Int32, String, String, IAuthCallback)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.GetResourceRequestHandler 方法

CEFRequestHandlerGetResourceRequestHandler 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceRequestHandler(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean,System.String,System.Boolean@)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public IResourceRequestHandler GetResourceRequestHandler(
    IWebBrowser chromiumWebBrowser,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    bool isNavigation,
    bool isDownload,
    string requestInitiator,
    ref bool disableDefaultHandling
)

参数

chromiumWebBrowser
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceRequestHandler(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean,System.String,System.Boolean@)" 的 <param name="chromiumWebBrowser"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceRequestHandler(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean,System.String,System.Boolean@)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceRequestHandler(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean,System.String,System.Boolean@)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceRequestHandler(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean,System.String,System.Boolean@)" 的 <param name="request"/> 文档]

isNavigation
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceRequestHandler(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean,System.String,System.Boolean@)" 的 <param name="isNavigation"/> 文档]

isDownload
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceRequestHandler(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean,System.String,System.Boolean@)" 的 <param name="isDownload"/> 文档]

requestInitiator
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceRequestHandler(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean,System.String,System.Boolean@)" 的 <param name="requestInitiator"/> 文档]

disableDefaultHandling
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceRequestHandler(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean,System.String,System.Boolean@)" 的 <param name="disableDefaultHandling"/> 文档]

返回值

类型：IResourceRequestHandler

实现

IRequestHandler.GetResourceRequestHandler(IWebBrowser, IBrowser, IFrame, IRequest, Boolean, Boolean, String, Boolean)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.GetResourceResponseFilter 方法

CEFRequestHandlerGetResourceResponseFilter 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public IResponseFilter GetResourceResponseFilter(
    IWebBrowser browserControl,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    IResponse response
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="request"/> 文档]

response
类型：IResponse

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="response"/> 文档]

返回值

类型：IResponseFilter
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnBeforeBrowse 方法

CEFRequestHandlerOnBeforeBrowse 方法

重载列表
 | 名称 | 说明
公共方法 | OnBeforeBrowse(IWebBrowser, IBrowser, IFrame, IRequest, Boolean) |
公共方法 | OnBeforeBrowse(IWebBrowser, IBrowser, IFrame, IRequest, Boolean, Boolean) |
Top
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnBeforeBrowse 方法 (IWebBrowser, IBrowser, IFrame, IRequest, Boolean)

CEFRequestHandlerOnBeforeBrowse 方法 (IWebBrowser, IBrowser, IFrame, IRequest, Boolean)

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool OnBeforeBrowse(
    IWebBrowser browserControl,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    bool isRedirect
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean)" 的 <param name="request"/> 文档]

isRedirect
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean)" 的 <param name="isRedirect"/> 文档]

返回值

类型：Boolean
参见

引用

CEFRequestHandler 类
OnBeforeBrowse 重载
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnBeforeBrowse 方法 (IWebBrowser, IBrowser, IFrame, IRequest, Boolean, Boolean)

CEFRequestHandlerOnBeforeBrowse 方法 (IWebBrowser, IBrowser, IFrame, IRequest, Boolean, Boolean)

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool OnBeforeBrowse(
    IWebBrowser chromiumWebBrowser,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    bool userGesture,
    bool isRedirect
)

参数

chromiumWebBrowser
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean)" 的 <param name="chromiumWebBrowser"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean)" 的 <param name="request"/> 文档]

userGesture
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean)" 的 <param name="userGesture"/> 文档]

isRedirect
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeBrowse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.Boolean,System.Boolean)" 的 <param name="isRedirect"/> 文档]

返回值

类型：Boolean

实现

IRequestHandler.OnBeforeBrowse(IWebBrowser, IBrowser, IFrame, IRequest, Boolean, Boolean)
参见

引用

CEFRequestHandler 类
OnBeforeBrowse 重载
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnBeforeResourceLoad 方法

CEFRequestHandlerOnBeforeResourceLoad 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeResourceLoad(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IRequestCallback)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CefReturnValue OnBeforeResourceLoad(
    IWebBrowser browserControl,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    IRequestCallback callback
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeResourceLoad(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IRequestCallback)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeResourceLoad(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IRequestCallback)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeResourceLoad(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IRequestCallback)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeResourceLoad(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IRequestCallback)" 的 <param name="request"/> 文档]

callback
类型：IRequestCallback

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnBeforeResourceLoad(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IRequestCallback)" 的 <param name="callback"/> 文档]

返回值

类型：CefReturnValue
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnCertificateError 方法

CEFRequestHandlerOnCertificateError 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnCertificateError(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefErrorCode,System.String,CefSharp.ISslInfo,CefSharp.IRequestCallback)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool OnCertificateError(
    IWebBrowser browserControl,
    IBrowser browser,
    CefErrorCode errorCode,
    string requestUrl,
    ISslInfo sslInfo,
    IRequestCallback callback
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnCertificateError(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefErrorCode,System.String,CefSharp.ISslInfo,CefSharp.IRequestCallback)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnCertificateError(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefErrorCode,System.String,CefSharp.ISslInfo,CefSharp.IRequestCallback)" 的 <param name="browser"/> 文档]

errorCode
类型：CefErrorCode

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnCertificateError(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefErrorCode,System.String,CefSharp.ISslInfo,CefSharp.IRequestCallback)" 的 <param name="errorCode"/> 文档]

requestUrl
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnCertificateError(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefErrorCode,System.String,CefSharp.ISslInfo,CefSharp.IRequestCallback)" 的 <param name="requestUrl"/> 文档]

sslInfo
类型：ISslInfo

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnCertificateError(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefErrorCode,System.String,CefSharp.ISslInfo,CefSharp.IRequestCallback)" 的 <param name="sslInfo"/> 文档]

callback
类型：IRequestCallback

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnCertificateError(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefErrorCode,System.String,CefSharp.ISslInfo,CefSharp.IRequestCallback)" 的 <param name="callback"/> 文档]

返回值

类型：Boolean

实现

IRequestHandler.OnCertificateError(IWebBrowser, IBrowser, CefErrorCode, String, ISslInfo, IRequestCallback)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnDocumentAvailableInMainFrame 方法

CEFRequestHandlerOnDocumentAvailableInMainFrame 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnDocumentAvailableInMainFrame(CefSharp.IWebBrowser,CefSharp.IBrowser)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void OnDocumentAvailableInMainFrame(
    IWebBrowser chromiumWebBrowser,
    IBrowser browser
)

参数

chromiumWebBrowser
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnDocumentAvailableInMainFrame(CefSharp.IWebBrowser,CefSharp.IBrowser)" 的 <param name="chromiumWebBrowser"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnDocumentAvailableInMainFrame(CefSharp.IWebBrowser,CefSharp.IBrowser)" 的 <param name="browser"/> 文档]

实现

IRequestHandler.OnDocumentAvailableInMainFrame(IWebBrowser, IBrowser)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnOpenUrlFromTab 方法

CEFRequestHandlerOnOpenUrlFromTab 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnOpenUrlFromTab(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,System.String,CefSharp.WindowOpenDisposition,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool OnOpenUrlFromTab(
    IWebBrowser browserControl,
    IBrowser browser,
    IFrame frame,
    string targetUrl,
    WindowOpenDisposition targetDisposition,
    bool userGesture
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnOpenUrlFromTab(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,System.String,CefSharp.WindowOpenDisposition,System.Boolean)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnOpenUrlFromTab(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,System.String,CefSharp.WindowOpenDisposition,System.Boolean)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnOpenUrlFromTab(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,System.String,CefSharp.WindowOpenDisposition,System.Boolean)" 的 <param name="frame"/> 文档]

targetUrl
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnOpenUrlFromTab(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,System.String,CefSharp.WindowOpenDisposition,System.Boolean)" 的 <param name="targetUrl"/> 文档]

targetDisposition
类型：WindowOpenDisposition

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnOpenUrlFromTab(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,System.String,CefSharp.WindowOpenDisposition,System.Boolean)" 的 <param name="targetDisposition"/> 文档]

userGesture
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnOpenUrlFromTab(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,System.String,CefSharp.WindowOpenDisposition,System.Boolean)" 的 <param name="userGesture"/> 文档]

返回值

类型：Boolean

实现

IRequestHandler.OnOpenUrlFromTab(IWebBrowser, IBrowser, IFrame, String, WindowOpenDisposition, Boolean)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnPluginCrashed 方法

CEFRequestHandlerOnPluginCrashed 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnPluginCrashed(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void OnPluginCrashed(
    IWebBrowser browserControl,
    IBrowser browser,
    string pluginPath
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnPluginCrashed(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnPluginCrashed(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String)" 的 <param name="browser"/> 文档]

pluginPath
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnPluginCrashed(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String)" 的 <param name="pluginPath"/> 文档]

实现

IRequestHandler.OnPluginCrashed(IWebBrowser, IBrowser, String)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnProtocolExecution 方法

CEFRequestHandlerOnProtocolExecution 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnProtocolExecution(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool OnProtocolExecution(
    IWebBrowser browserControl,
    IBrowser browser,
    string url
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnProtocolExecution(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnProtocolExecution(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String)" 的 <param name="browser"/> 文档]

url
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnProtocolExecution(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String)" 的 <param name="url"/> 文档]

返回值

类型：Boolean
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnQuotaRequest 方法

CEFRequestHandlerOnQuotaRequest 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnQuotaRequest(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Int64,CefSharp.IRequestCallback)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool OnQuotaRequest(
    IWebBrowser browserControl,
    IBrowser browser,
    string originUrl,
    long newSize,
    IRequestCallback callback
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnQuotaRequest(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Int64,CefSharp.IRequestCallback)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnQuotaRequest(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Int64,CefSharp.IRequestCallback)" 的 <param name="browser"/> 文档]

originUrl
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnQuotaRequest(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Int64,CefSharp.IRequestCallback)" 的 <param name="originUrl"/> 文档]

newSize
类型：SystemInt64

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnQuotaRequest(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Int64,CefSharp.IRequestCallback)" 的 <param name="newSize"/> 文档]

callback
类型：IRequestCallback

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnQuotaRequest(CefSharp.IWebBrowser,CefSharp.IBrowser,System.String,System.Int64,CefSharp.IRequestCallback)" 的 <param name="callback"/> 文档]

返回值

类型：Boolean

实现

IRequestHandler.OnQuotaRequest(IWebBrowser, IBrowser, String, Int64, IRequestCallback)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnRenderProcessTerminated 方法

CEFRequestHandlerOnRenderProcessTerminated 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnRenderProcessTerminated(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefTerminationStatus)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void OnRenderProcessTerminated(
    IWebBrowser browserControl,
    IBrowser browser,
    CefTerminationStatus status
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnRenderProcessTerminated(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefTerminationStatus)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnRenderProcessTerminated(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefTerminationStatus)" 的 <param name="browser"/> 文档]

status
类型：CefTerminationStatus

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnRenderProcessTerminated(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.CefTerminationStatus)" 的 <param name="status"/> 文档]

实现

IRequestHandler.OnRenderProcessTerminated(IWebBrowser, IBrowser, CefTerminationStatus)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnRenderViewReady 方法

CEFRequestHandlerOnRenderViewReady 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnRenderViewReady(CefSharp.IWebBrowser,CefSharp.IBrowser)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void OnRenderViewReady(
    IWebBrowser browserControl,
    IBrowser browser
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnRenderViewReady(CefSharp.IWebBrowser,CefSharp.IBrowser)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnRenderViewReady(CefSharp.IWebBrowser,CefSharp.IBrowser)" 的 <param name="browser"/> 文档]

实现

IRequestHandler.OnRenderViewReady(IWebBrowser, IBrowser)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnResourceLoadComplete 方法

CEFRequestHandlerOnResourceLoadComplete 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void OnResourceLoadComplete(
    IWebBrowser browserControl,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    IResponse response,
    UrlRequestStatus status,
    long receivedContentLength
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="request"/> 文档]

response
类型：IResponse

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="response"/> 文档]

status
类型：UrlRequestStatus

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="status"/> 文档]

receivedContentLength
类型：SystemInt64

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="receivedContentLength"/> 文档]

参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnResourceRedirect 方法

CEFRequestHandlerOnResourceRedirect 方法

重载列表
 | 名称 | 说明
公共方法 | OnResourceRedirect(IWebBrowser, IBrowser, IFrame, IRequest, String) |
公共方法 | OnResourceRedirect(IWebBrowser, IBrowser, IFrame, IRequest, IResponse, String) |
Top
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnResourceRedirect 方法 (IWebBrowser, IBrowser, IFrame, IRequest, String)

CEFRequestHandlerOnResourceRedirect 方法 (IWebBrowser, IBrowser, IFrame, IRequest, String)

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.String@)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void OnResourceRedirect(
    IWebBrowser browserControl,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    ref string newUrl
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.String@)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.String@)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.String@)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.String@)" 的 <param name="request"/> 文档]

newUrl
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,System.String@)" 的 <param name="newUrl"/> 文档]

参见

引用

CEFRequestHandler 类
OnResourceRedirect 重载
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnResourceRedirect 方法 (IWebBrowser, IBrowser, IFrame, IRequest, IResponse, String)

CEFRequestHandlerOnResourceRedirect 方法 (IWebBrowser, IBrowser, IFrame, IRequest, IResponse, String)

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,System.String@)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void OnResourceRedirect(
    IWebBrowser browserControl,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    IResponse response,
    ref string newUrl
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,System.String@)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,System.String@)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,System.String@)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,System.String@)" 的 <param name="request"/> 文档]

response
类型：IResponse

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,System.String@)" 的 <param name="response"/> 文档]

newUrl
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceRedirect(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,System.String@)" 的 <param name="newUrl"/> 文档]

参见

引用

CEFRequestHandler 类
OnResourceRedirect 重载
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnResourceResponse 方法

CEFRequestHandlerOnResourceResponse 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceResponse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool OnResourceResponse(
    IWebBrowser browserControl,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    IResponse response
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceResponse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceResponse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceResponse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceResponse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="request"/> 文档]

response
类型：IResponse

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnResourceResponse(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="response"/> 文档]

返回值

类型：Boolean
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.OnSelectClientCertificate 方法

CEFRequestHandlerOnSelectClientCertificate 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnSelectClientCertificate(CefSharp.IWebBrowser,CefSharp.IBrowser,System.Boolean,System.String,System.Int32,System.Security.Cryptography.X509Certificates.X509Certificate2Collection,CefSharp.ISelectClientCertificateCallback)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool OnSelectClientCertificate(
    IWebBrowser browserControl,
    IBrowser browser,
    bool isProxy,
    string host,
    int port,
    X509Certificate2Collection certificates,
    ISelectClientCertificateCallback callback
)

参数

browserControl
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnSelectClientCertificate(CefSharp.IWebBrowser,CefSharp.IBrowser,System.Boolean,System.String,System.Int32,System.Security.Cryptography.X509Certificates.X509Certificate2Collection,CefSharp.ISelectClientCertificateCallback)" 的 <param name="browserControl"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnSelectClientCertificate(CefSharp.IWebBrowser,CefSharp.IBrowser,System.Boolean,System.String,System.Int32,System.Security.Cryptography.X509Certificates.X509Certificate2Collection,CefSharp.ISelectClientCertificateCallback)" 的 <param name="browser"/> 文档]

isProxy
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnSelectClientCertificate(CefSharp.IWebBrowser,CefSharp.IBrowser,System.Boolean,System.String,System.Int32,System.Security.Cryptography.X509Certificates.X509Certificate2Collection,CefSharp.ISelectClientCertificateCallback)" 的 <param name="isProxy"/> 文档]

host
类型：SystemString

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnSelectClientCertificate(CefSharp.IWebBrowser,CefSharp.IBrowser,System.Boolean,System.String,System.Int32,System.Security.Cryptography.X509Certificates.X509Certificate2Collection,CefSharp.ISelectClientCertificateCallback)" 的 <param name="host"/> 文档]

port
类型：SystemInt32

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnSelectClientCertificate(CefSharp.IWebBrowser,CefSharp.IBrowser,System.Boolean,System.String,System.Int32,System.Security.Cryptography.X509Certificates.X509Certificate2Collection,CefSharp.ISelectClientCertificateCallback)" 的 <param name="port"/> 文档]

certificates
类型：System.Security.Cryptography.X509CertificatesX509Certificate2Collection

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnSelectClientCertificate(CefSharp.IWebBrowser,CefSharp.IBrowser,System.Boolean,System.String,System.Int32,System.Security.Cryptography.X509Certificates.X509Certificate2Collection,CefSharp.ISelectClientCertificateCallback)" 的 <param name="certificates"/> 文档]

callback
类型：ISelectClientCertificateCallback

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFRequestHandler.OnSelectClientCertificate(CefSharp.IWebBrowser,CefSharp.IBrowser,System.Boolean,System.String,System.Int32,System.Security.Cryptography.X509Certificates.X509Certificate2Collection,CefSharp.ISelectClientCertificateCallback)" 的 <param name="callback"/> 文档]

返回值

类型：Boolean

实现

IRequestHandler.OnSelectClientCertificate(IWebBrowser, IBrowser, Boolean, String, Int32, X509Certificate2Collection, ISelectClientCertificateCallback)
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler 事件

CEFRequestHandler 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | BrowserAndLoginInfoAction |
公共事件 | JsonAction |
Top
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.BrowserAndLoginInfoAction 事件

CEFRequestHandlerBrowserAndLoginInfoAction 事件

[缺少 "E:Api.Framework.Cps.CefSharp1.CEFRequestHandler.BrowserAndLoginInfoAction" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event Action<BrowserAndLoginInfo> BrowserAndLoginInfoAction

值

类型：SystemAction BrowserAndLoginInfo
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFRequestHandler.JsonAction 事件

CEFRequestHandlerJsonAction 事件

[缺少 "E:Api.Framework.Cps.CefSharp1.CEFRequestHandler.JsonAction" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event Action<string, string> JsonAction

值

类型：SystemAction String, String
参见

引用

CEFRequestHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFResponseHandler 类

拦截响应数据
继承层次
SystemObject
ResourceRequestHandler
Api.Framework.Cps.CefSharp1CEFResponseHandler

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CEFResponseHandler : ResourceRequestHandler

CEFResponseHandler 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CEFResponseHandler | 初始化 CEFResponseHandler 类的一个新实例
Top
方法
 | 名称 | 说明
受保护的方法 | Dispose | (继承自 ResourceRequestHandler。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
受保护的方法 | GetCookieAccessFilter | (继承自 ResourceRequestHandler。)
公共方法 | GetHashCode | (继承自 Object。)
受保护的方法 | GetResourceHandler | (继承自 ResourceRequestHandler。)
受保护的方法 | GetResourceResponseFilter | (重写 ResourceRequestHandler.GetResourceResponseFilter(IWebBrowser, IBrowser, IFrame, IRequest, IResponse).)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnBeforeResourceLoad | (继承自 ResourceRequestHandler。)
受保护的方法 | OnProtocolExecution | (继承自 ResourceRequestHandler。)
受保护的方法 | OnResourceLoadComplete | (重写 ResourceRequestHandler.OnResourceLoadComplete(IWebBrowser, IBrowser, IFrame, IRequest, IResponse, UrlRequestStatus, Int64).)
受保护的方法 | OnResourceRedirect | (继承自 ResourceRequestHandler。)
受保护的方法 | OnResourceResponse | (继承自 ResourceRequestHandler。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps.CefSharp1 命名空间


CEFResponseHandler 构造函数

初始化 CEFResponseHandler 类的一个新实例

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CEFResponseHandler(
    Action<string, string> JsonAction
)

参数

JsonAction
类型：SystemAction String, String

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.#ctor(System.Action{System.String,System.String})" 的 <param name="JsonAction"/> 文档]

参见

引用

CEFResponseHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFResponseHandler 方法

CEFResponseHandler 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | Dispose | (继承自 ResourceRequestHandler。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
受保护的方法 | GetCookieAccessFilter | (继承自 ResourceRequestHandler。)
公共方法 | GetHashCode | (继承自 Object。)
受保护的方法 | GetResourceHandler | (继承自 ResourceRequestHandler。)
受保护的方法 | GetResourceResponseFilter | (重写 ResourceRequestHandler.GetResourceResponseFilter(IWebBrowser, IBrowser, IFrame, IRequest, IResponse).)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnBeforeResourceLoad | (继承自 ResourceRequestHandler。)
受保护的方法 | OnProtocolExecution | (继承自 ResourceRequestHandler。)
受保护的方法 | OnResourceLoadComplete | (重写 ResourceRequestHandler.OnResourceLoadComplete(IWebBrowser, IBrowser, IFrame, IRequest, IResponse, UrlRequestStatus, Int64).)
受保护的方法 | OnResourceRedirect | (继承自 ResourceRequestHandler。)
受保护的方法 | OnResourceResponse | (继承自 ResourceRequestHandler。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CEFResponseHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFResponseHandler.GetResourceResponseFilter 方法

CEFResponseHandlerGetResourceResponseFilter 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override IResponseFilter GetResourceResponseFilter(
    IWebBrowser chromiumWebBrowser,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    IResponse response
)

参数

chromiumWebBrowser
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="chromiumWebBrowser"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="request"/> 文档]

response
类型：IResponse

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.GetResourceResponseFilter(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse)" 的 <param name="response"/> 文档]

返回值

类型：IResponseFilter
参见

引用

CEFResponseHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CEFResponseHandler.OnResourceLoadComplete 方法

CEFResponseHandlerOnResourceLoadComplete 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void OnResourceLoadComplete(
    IWebBrowser chromiumWebBrowser,
    IBrowser browser,
    IFrame frame,
    IRequest request,
    IResponse response,
    UrlRequestStatus status,
    long receivedContentLength
)

参数

chromiumWebBrowser
类型：IWebBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="chromiumWebBrowser"/> 文档]

browser
类型：IBrowser

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="browser"/> 文档]

frame
类型：IFrame

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="frame"/> 文档]

request
类型：IRequest

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="request"/> 文档]

response
类型：IResponse

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="response"/> 文档]

status
类型：UrlRequestStatus

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="status"/> 文档]

receivedContentLength
类型：SystemInt64

[缺少 "M:Api.Framework.Cps.CefSharp1.CEFResponseHandler.OnResourceLoadComplete(CefSharp.IWebBrowser,CefSharp.IBrowser,CefSharp.IFrame,CefSharp.IRequest,CefSharp.IResponse,CefSharp.UrlRequestStatus,System.Int64)" 的 <param name="receivedContentLength"/> 文档]

参见

引用

CEFResponseHandler 类
Api.Framework.Cps.CefSharp1 命名空间


CookieVisitor 类

[缺少 "T:Api.Framework.Cps.CefSharp1.CookieVisitor" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.Cps.CefSharp1CookieVisitor

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CookieVisitor : ICookieVisitor,
    IDisposable

CookieVisitor 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CookieVisitor | 初始化 CookieVisitor 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 释放被 CookieVisitor 使用的所有资源
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | Visit |
Top
事件
 | 名称 | 说明
公共事件 | SendCookie |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps.CefSharp1 命名空间


CookieVisitor 构造函数

初始化 CookieVisitor 类的一个新实例

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CookieVisitor()
参见

引用

CookieVisitor 类
Api.Framework.Cps.CefSharp1 命名空间


CookieVisitor 方法

CookieVisitor 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | Visit |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CookieVisitor 类
Api.Framework.Cps.CefSharp1 命名空间


CookieVisitor.Dispose 方法

CookieVisitorDispose 方法

释放被 CookieVisitor 使用的所有资源

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()

实现

IDisposableDispose
参见

引用

CookieVisitor 类
Api.Framework.Cps.CefSharp1 命名空间


CookieVisitor.Visit 方法

CookieVisitorVisit 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.CookieVisitor.Visit(CefSharp.Cookie,System.Int32,System.Int32,System.Boolean@)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Visit(
    Cookie cookie,
    int count,
    int total,
    ref bool deleteCookie
)

参数

cookie
类型：Cookie

[缺少 "M:Api.Framework.Cps.CefSharp1.CookieVisitor.Visit(CefSharp.Cookie,System.Int32,System.Int32,System.Boolean@)" 的 <param name="cookie"/> 文档]

count
类型：SystemInt32

[缺少 "M:Api.Framework.Cps.CefSharp1.CookieVisitor.Visit(CefSharp.Cookie,System.Int32,System.Int32,System.Boolean@)" 的 <param name="count"/> 文档]

total
类型：SystemInt32

[缺少 "M:Api.Framework.Cps.CefSharp1.CookieVisitor.Visit(CefSharp.Cookie,System.Int32,System.Int32,System.Boolean@)" 的 <param name="total"/> 文档]

deleteCookie
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.CookieVisitor.Visit(CefSharp.Cookie,System.Int32,System.Int32,System.Boolean@)" 的 <param name="deleteCookie"/> 文档]

返回值

类型：Boolean

实现

ICookieVisitor.Visit(Cookie, Int32, Int32, Boolean)
参见

引用

CookieVisitor 类
Api.Framework.Cps.CefSharp1 命名空间


CookieVisitor 事件

CookieVisitor 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | SendCookie |
Top
参见

引用

CookieVisitor 类
Api.Framework.Cps.CefSharp1 命名空间


CookieVisitor.SendCookie 事件

CookieVisitorSendCookie 事件

[缺少 "E:Api.Framework.Cps.CefSharp1.CookieVisitor.SendCookie" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event Action<Cookie> SendCookie

值

类型：SystemAction Cookie
参见

引用

CookieVisitor 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist 类

[缺少 "T:Api.Framework.Cps.CefSharp1.DouyinPackHist" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.Cps.CefSharp1DouyinPackHist

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DouyinPackHist : IRunable,
    IDisposable

DouyinPackHist 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DouyinPackHist | 初始化 DouyinPackHist 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning |
公共属性 | RegisterdHandler |
公共属性 | WaitHandler |
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 释放被 DouyinPackHist 使用的所有资源
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResult | 获取接收数据包
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run |
公共方法 | SetResult | 设置接收数据包
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist 构造函数

初始化 DouyinPackHist 类的一个新实例

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DouyinPackHist()
参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist 属性

DouyinPackHist 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning |
公共属性 | RegisterdHandler |
公共属性 | WaitHandler |
Top
参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist.IsRunning 属性

DouyinPackHistIsRunning 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.DouyinPackHist.IsRunning" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsRunning { get; set; }

属性值

类型：Boolean

实现

IRunableIsRunning
参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist.RegisterdHandler 属性

DouyinPackHistRegisterdHandler 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.DouyinPackHist.RegisterdHandler" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public RegisteredWaitHandle RegisterdHandler { get; set; }

属性值

类型：RegisteredWaitHandle

实现

IRunableRegisterdHandler
参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist.WaitHandler 属性

DouyinPackHistWaitHandler 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.DouyinPackHist.WaitHandler" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WaitHandle WaitHandler { get; set; }

属性值

类型：WaitHandle

实现

IRunableWaitHandler
参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist 方法

DouyinPackHist 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResult | 获取接收数据包
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run |
公共方法 | SetResult | 设置接收数据包
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist.Dispose 方法

DouyinPackHistDispose 方法

释放被 DouyinPackHist 使用的所有资源

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()

实现

IDisposableDispose
参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist.GetResult 方法

DouyinPackHistGetResult 方法

获取接收数据包

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Task<BaseResult> GetResult(
    string _msg_id
)

参数

_msg_id
类型：SystemString
msgId

返回值

类型：Task BaseResult
参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist.Run 方法

DouyinPackHistRun 方法

[缺少 "M:Api.Framework.Cps.CefSharp1.DouyinPackHist.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Run(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Api.Framework.Cps.CefSharp1.DouyinPackHist.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Api.Framework.Cps.CefSharp1.DouyinPackHist.Run(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

实现

IRunableRun(Object, Boolean)
参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPackHist.SetResult 方法

DouyinPackHistSetResult 方法

设置接收数据包

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SetResult(
    BaseResult msg
)

参数

msg
类型：Api.Framework.Cps.CefSharp1BaseResult

[缺少 "M:Api.Framework.Cps.CefSharp1.DouyinPackHist.SetResult(Api.Framework.Cps.CefSharp1.BaseResult)" 的 <param name="msg"/> 文档]

参见

引用

DouyinPackHist 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPool 类

[缺少 "T:Api.Framework.Cps.CefSharp1.DouyinPool" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.Cps.CefSharp1DouyinPool

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DouyinPool

DouyinPool 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DouyinPool | 初始化 DouyinPool 类的一个新实例
Top
属性
名称 | 说明
PackHist |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps.CefSharp1 命名空间


DouyinPool 构造函数

初始化 DouyinPool 类的一个新实例

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DouyinPool()
参见

引用

DouyinPool 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPool 属性

DouyinPool 类型公开以下成员。

属性
名称 | 说明
PackHist |
Top
参见

引用

DouyinPool 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPool.PackHist 属性

DouyinPoolPackHist 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.DouyinPool.PackHist" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static DouyinPackHist PackHist { get; }

属性值

类型：DouyinPackHist
参见

引用

DouyinPool 类
Api.Framework.Cps.CefSharp1 命名空间


DouyinPool 方法

DouyinPool 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DouyinPool 类
Api.Framework.Cps.CefSharp1 命名空间


LoginInfo 类

[缺少 "T:Api.Framework.Cps.CefSharp1.LoginInfo" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.Cps.CefSharp1LoginInfo

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class LoginInfo

LoginInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | LoginInfo | 初始化 LoginInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ssid |
公共属性 | user_id |
公共属性 | user_type |
公共属性 | user_unique_id |
公共属性 | web_id |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Cps.CefSharp1 命名空间


LoginInfo 构造函数

初始化 LoginInfo 类的一个新实例

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public LoginInfo()
参见

引用

LoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


LoginInfo 属性

LoginInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ssid |
公共属性 | user_id |
公共属性 | user_type |
公共属性 | user_unique_id |
公共属性 | web_id |
Top
参见

引用

LoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


LoginInfo.ssid 属性

LoginInfossid 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.LoginInfo.ssid" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ssid { get; set; }

属性值

类型：String
参见

引用

LoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


LoginInfo.user_id 属性

LoginInfouser_id 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.LoginInfo.user_id" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string user_id { get; set; }

属性值

类型：String
参见

引用

LoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


LoginInfo.user_type 属性

LoginInfouser_type 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.LoginInfo.user_type" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int user_type { get; set; }

属性值

类型：Int32
参见

引用

LoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


LoginInfo.user_unique_id 属性

LoginInfouser_unique_id 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.LoginInfo.user_unique_id" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string user_unique_id { get; set; }

属性值

类型：String
参见

引用

LoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


LoginInfo.web_id 属性

LoginInfoweb_id 属性

[缺少 "P:Api.Framework.Cps.CefSharp1.LoginInfo.web_id" 的 <summary> 文档]

命名空间： Api.Framework.Cps.CefSharp1
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string web_id { get; set; }

属性值

类型：String
参见

引用

LoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


LoginInfo 方法

LoginInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

LoginInfo 类
Api.Framework.Cps.CefSharp1 命名空间


Api.Framework.Enums 命名空间

[缺少 "N:Api.Framework.Enums" 的 <summary> 文档]

枚举
 | 枚举 | 说明
公共枚举 | AlimamaOrderSubsidyType | 阿里订单归属平台
公共枚举 | AlimamaOrderTerminalType | 成交平台
公共枚举 | AwardDepotType |
公共枚举 | CpsType | Cps平台类型
公共枚举 | DouyinLoginType | 抖音登录状态
公共枚举 | DouyinQueryButtonType | 抖音查询订单按钮类型
公共枚举 | DouyinQueryOrderType | 同步订单类型
公共枚举 | DownAdzoneType | 订单推广位下载条件
公共枚举 | DwzType | 缩短类型
公共枚举 | FreezingConditionType | 冻结佣金条件
公共枚举 | JingdongOrderStatus | 京东订单男状态
公共枚举 | MemberType | 用户类型
公共枚举 | OperateType | 防撸处理类型
公共枚举 | OperationType | 系统修改操作类型
公共枚举 | OrderNoticeType | 订单通知类型
公共枚举 | OrderRefundStatus | 阿里订单维权状态
公共枚举 | PayGetType | 商户领取状态
公共枚举 | PinduoduoBiJiaType | 拼多多比价类型
公共枚举 | PinduoduoOrderStatus | 拼多多订单状态
公共枚举 | PointType | 积分操作类型
公共枚举 | PrivateAdzoneCustomType | 私人推广位类型
公共枚举 | PrivateAdzoneType | 私人推广位
公共枚举 | SubsidyType | 补贴类型
公共枚举 | SwitchType | 打开关闭类型
公共枚举 | SystemOrderStatus | 系统订单状态
公共枚举 | TBDownType | 阿里妈妈同步订单类型
公共枚举 | WeipinhuiAfterSaleStatus | 商品售后状态：1-售后中，2-售后完成，3-售后取消，无售后时为空
公共枚举 | WeipinhuiGuiYin | 订单归因方式
公共枚举 | WeipinhuiNewCustomer | 唯品会新老客：0-待定，1-新客，2-老客
公共枚举 | WeipinhuiOrderSettled | 唯品会订单结算状态
公共枚举 | WeipinhuiOrderStatus | 唯品会订单状态
公共枚举 | WeipinhuiOrderSubStatusName | 唯品会订单子状态 流转状态-支持状态
公共枚举 | WeipinhuiSfterSaleType | 售后类型：1-退货，2-换货,无售后时为空
公共枚举 | WeipinhuiShiFou | 唯品会状态 是否


AlimamaOrderSubsidyType 枚举

阿里订单归属平台

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum AlimamaOrderSubsidyType
成员
成员名称 | 值 | 说明
其他 | -1 |
天猫 | 1 |
聚划算 | 2 |
航旅 | 3 |
阿里云 | 4 |
参见

引用

Api.Framework.Enums 命名空间


AlimamaOrderTerminalType 枚举

成交平台

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum AlimamaOrderTerminalType
成员
成员名称 | 值 | 说明
其他 | -1 |
PC | 1 |
无线 | 2 |
参见

引用

Api.Framework.Enums 命名空间


AwardDepotType 枚举

[缺少 "T:Api.Framework.Enums.AwardDepotType" 的 <summary> 文档]

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum AwardDepotType
成员
成员名称 | 值 | 说明
扣除分出佣金 | 1 |
不扣分出佣金 | 2 |
参见

引用

Api.Framework.Enums 命名空间


CpsType 枚举

Cps平台类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum CpsType
成员
成员名称 | 值 | 说明
阿里妈妈 | 1 |
多多进宝 | 2 |
京东联盟 | 3 |
唯品联盟 | 4 |
抖音联盟 | 5 |
参见

引用

Api.Framework.Enums 命名空间


DouyinLoginType 枚举

抖音登录状态

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum DouyinLoginType
成员
成员名称 | 值 | 说明
权限不足 | 0 |
登录过期 | 1 |
登录成功 | 2 |
新号登录成功 | 3 |
删除登录账号 | 4 |
参见

引用

Api.Framework.Enums 命名空间


DouyinQueryButtonType 枚举

抖音查询订单按钮类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum DouyinQueryButtonType
成员
成员名称 | 值 | 说明
查询 | 0 |
重置 | 1 |
参见

引用

Api.Framework.Enums 命名空间


DouyinQueryOrderType 枚举

同步订单类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum DouyinQueryOrderType
成员
成员名称 | 值 | 说明
付款订单 | 0 |
结算订单 | 1 |
参见

引用

Api.Framework.Enums 命名空间


DownAdzoneType 枚举

订单推广位下载条件

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum DownAdzoneType
成员
成员名称 | 值 | 说明
不下载推广位 | 1 |
只下载推广位 | 2 |
参见

引用

Api.Framework.Enums 命名空间


DwzType 枚举

缩短类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum DwzType
成员
成员名称 | 值 | 说明
不缩短域名 | 0 |
新浪短网址 | 1 |
腾讯短网址 | 2 |
缩我短网址 | 3 |
百度短网址 | 4 |
UC浏览器短网址 | 5 |
新新浪短网址 | 6 |
官方短网址 | 7 |
快站短网址 | 8 |
参见

引用

Api.Framework.Enums 命名空间


FreezingConditionType 枚举

冻结佣金条件

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum FreezingConditionType
成员
成员名称 | 值 | 说明
商品总佣金 | 1 |
客户所得佣金 | 2 |
参见

引用

Api.Framework.Enums 命名空间


JingdongOrderStatus 枚举

京东订单男状态

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum JingdongOrderStatus
成员
成员名称 | 值 | 说明
未知 | -1 |
无效_拆单 | 2 |
无效_取消 | 3 |
无效_京东帮帮主订单 | 4 |
无效_账号异常 | 5 |
无效_赠品类目不返佣 | 6 |
无效_校园订单 | 7 |
无效_企业订单 | 8 |
无效_团购订单 | 9 |
无效_开增值税专用发票订单 | 10 |
无效_乡村推广员下单 | 11 |
无效_自己推广自己下单 | 12 |
无效_违规订单 | 13 |
无效_来源与备案网址不符 | 14 |
待付款 | 15 |
已付款 | 16 |
已完成 | 17 |
已结算 | 18 |
售后中 | 19 |
结算后失效 | 20 |
参见

引用

Api.Framework.Enums 命名空间


MemberType 枚举

用户类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum MemberType
成员
成员名称 | 值 | 说明
正常 | 0 |
黑名单 | 1 |
白名单 | 2 |
参见

引用

Api.Framework.Enums 命名空间


OperateType 枚举

防撸处理类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum OperateType
成员
成员名称 | 值 | 说明
拉入黑名单 | 1 |
通知钉钉群 | 2 |
订单冻结 | 3 |
参见

引用

Api.Framework.Enums 命名空间


OperationType 枚举

系统修改操作类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum OperationType
参见

引用

Api.Framework.Enums 命名空间


OrderNoticeType 枚举

订单通知类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum OrderNoticeType
成员
成员名称 | 值 | 说明
客户订单 | 1 |
一级提成 | 2 |
二级提成 | 3 |
三级提成 | 5 |
群主分成 | 4 |
参见

引用

Api.Framework.Enums 命名空间


OrderRefundStatus 枚举

阿里订单维权状态

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum OrderRefundStatus
成员
成员名称 | 值 | 说明
维权创建 | 1000 |
维权成功 | 1001 |
维权失败 | 1002 |
等待处理 | 1003 |
维权成功_等待补扣佣金 | 1004 |
维权成功_佣金补扣成功 | 1005 |
维权失败_等待卖家返还佣金 | 1006 |
维权失败_卖家佣金返还成功 | 1007 |
参见

引用

Api.Framework.Enums 命名空间


PayGetType 枚举

商户领取状态

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum PayGetType
成员
成员名称 | 值 | 说明
未领取 | 0 |
已领取 | 1 |
参见

引用

Api.Framework.Enums 命名空间


PinduoduoBiJiaType 枚举

拼多多比价类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum PinduoduoBiJiaType
成员
成员名称 | 值 | 说明
非比价 | 0 |
比价 | 1 |
参见

引用

Api.Framework.Enums 命名空间


PinduoduoOrderStatus 枚举

拼多多订单状态

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum PinduoduoOrderStatus
成员
成员名称 | 值 | 说明
等待付款 | -1 |
已经付款 | 0 |
已经成团 | 1 |
确认收货 | 2 |
审核成功 | 3 |
审核失败 | 4 |
已经结算 | 5 |
没有佣金 | 8 |
违规订单 | 10 |
未知状态 | -99 |
参见

引用

Api.Framework.Enums 命名空间


PointType 枚举

积分操作类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum PointType
成员
成员名称 | 值 | 说明
维权扣除 | -2 |
提现扣除 | -1 |
消费补贴 | 1 |
提成奖励 | 2 |
退回积分 | 3 |
其他奖励 | 99 |
人为修改 | 0 |
参见

引用

Api.Framework.Enums 命名空间


PrivateAdzoneCustomType 枚举

私人推广位类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum PrivateAdzoneCustomType
成员
成员名称 | 值 | 说明
用户私人pid | 1 |
群pid | 2 |
参见

引用

Api.Framework.Enums 命名空间


PrivateAdzoneType 枚举

私人推广位

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum PrivateAdzoneType
成员
成员名称 | 值 | 说明
淘宝私人pid | 1 |
拼多多私人pid | 2 |
京东私人pid | 3 |
唯品会私人pid | 4 |
抖音私人pid | 5 |
参见

引用

Api.Framework.Enums 命名空间


SubsidyType 枚举

补贴类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum SubsidyType
成员
成员名称 | 值 | 说明
百分比 | 1 |
固定积分 | 2 |
参见

引用

Api.Framework.Enums 命名空间


SwitchType 枚举

打开关闭类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum SwitchType
成员
成员名称 | 值 | 说明
开启 | 1 |
关闭 | 0 |
参见

引用

Api.Framework.Enums 命名空间


SystemOrderStatus 枚举

系统订单状态

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum SystemOrderStatus
成员
成员名称 | 值 | 说明
订单创建 | 1006 |
订单付款 | 1005 |
订单失效 | 1004 |
订单退款 | 1003 |
订单结算 | 1002 |
订单冻结 | 1001 |
订单维权中 | 1000 |
全额退款 | 999 |
部分退款 | 998 |
订单未知 | -99 |
参见

引用

Api.Framework.Enums 命名空间


TBDownType 枚举

阿里妈妈同步订单类型

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum TBDownType
成员
成员名称 | 值 | 说明
常规订单 | 1 |
渠道订单 | 2 |
会员运营订单 | 3 |
参见

引用

Api.Framework.Enums 命名空间


WeipinhuiAfterSaleStatus 枚举

商品售后状态：1-售后中，2-售后完成，3-售后取消，无售后时为空

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WeipinhuiAfterSaleStatus
成员
成员名称 | 值 | 说明
无 | 0 |
售后中 | 1 |
售后完成 | 2 |
售后取消 | 3 |
参见

引用

Api.Framework.Enums 命名空间


WeipinhuiGuiYin 枚举

订单归因方式

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WeipinhuiGuiYin
成员
成员名称 | 值 | 说明
常规推广 | 0 |
惊喜红包 | 1 |
锁粉 | 2 |
超级红包 | 3 |
参见

引用

Api.Framework.Enums 命名空间


WeipinhuiNewCustomer 枚举

唯品会新老客：0-待定，1-新客，2-老客

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WeipinhuiNewCustomer
成员
成员名称 | 值 | 说明
待定 | 0 |
新客 | 1 |
老客 | 2 |
参见

引用

Api.Framework.Enums 命名空间


WeipinhuiOrderSettled 枚举

唯品会订单结算状态

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WeipinhuiOrderSettled
成员
成员名称 | 值 | 说明
未结算 | 0 |
已结算 | 1 |
参见

引用

Api.Framework.Enums 命名空间


WeipinhuiOrderStatus 枚举

唯品会订单状态

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WeipinhuiOrderStatus
成员
成员名称 | 值 | 说明
不合格 | 0 |
待定 | 1 |
已完结 | 2 |
参见

引用

Api.Framework.Enums 命名空间


WeipinhuiOrderSubStatusName 枚举

唯品会订单子状态 流转状态-支持状态

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WeipinhuiOrderSubStatusName
成员
成员名称 | 值 | 说明
已下单 | 1001 |
已付款 | 1002 |
已签收 | 1003 |
待结算 | 1004 |
已结算 | 1005 |
已失效 | 1006 |
维权中 | 1007 |
维权完成 | 1008 |
手动失效 | 1009 |
参见

引用

Api.Framework.Enums 命名空间


WeipinhuiSfterSaleType 枚举

售后类型：1-退货，2-换货,无售后时为空

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WeipinhuiSfterSaleType
成员
成员名称 | 值 | 说明
无 | 0 |
退货 | 1 |
换货 | 2 |
参见

引用

Api.Framework.Enums 命名空间


WeipinhuiShiFou 枚举

唯品会状态 是否

命名空间： Api.Framework.Enums
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WeipinhuiShiFou
成员
成员名称 | 值 | 说明
否 | 0 |
是 | 1 |
参见

引用

Api.Framework.Enums 命名空间


Api.Framework.Events 命名空间

[缺少 "N:Api.Framework.Events" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | BaseEvents | 事件基类
公共类 | DebugEvent | 调试事件
公共类 | LogEvents | 日志事件
公共类 | OrderNoticeEvent | 订单通知事件
公共类 | SharedEvents | 通用事件,可实现插件之间的数据传输,自己定义规则
公共类 | WebRequestEvents | web请求事件
委托
 | 委托 | 说明
公共委托 | DebugEventSendDebugMsgs | 定义发送调试委托
枚举
 | 枚举 | 说明
公共枚举 | MethodType | 界面常用操作类型


BaseEvents 类

事件基类
继承层次
SystemObject
SystemEventArgs
Api.Framework.EventsBaseEvents
更多...

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class BaseEvents : EventArgs

BaseEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BaseEvents | 初始化 BaseEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Events 命名空间
继承层次
SystemObject
SystemEventArgs
Api.Framework.EventsBaseEvents
Api.Framework.EventsLogEvents
Api.Framework.EventsOrderNoticeEvent
Api.Framework.EventsSharedEvents
Api.Framework.EventsWebRequestEvents
Api.Framework.SDKMemberPointChangeEvent
Api.Framework.SDKReciveIMEvent


BaseEvents 构造函数

初始化 BaseEvents 类的一个新实例

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BaseEvents()
参见

引用

BaseEvents 类
Api.Framework.Events 命名空间


BaseEvents 属性

BaseEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递
Top
参见

引用

BaseEvents 类
Api.Framework.Events 命名空间


BaseEvents.Cancel 属性

BaseEventsCancel 属性

是否取消传递 true:消息将不往后传,false:继续传递

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Cancel { get; set; }

属性值

类型：Boolean
参见

引用

BaseEvents 类
Api.Framework.Events 命名空间


BaseEvents 方法

BaseEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

BaseEvents 类
Api.Framework.Events 命名空间


DebugEvent 类

调试事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Api.Framework.EventsDebugEvent

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DebugEvent : ChatEvent

DebugEvent 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DebugEvent | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | chatType | 机器人平台类型
公共属性 | content | 发送的消息
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | username | 接收者账号
公共属性 | usernick | 接收者昵称
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
字段
 | 名称 | 说明
公共字段 | SendDebugMsg | 发送调试委托
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Events 命名空间


DebugEvent 构造函数

构造方法

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DebugEvent(
    DebugEventSendDebugMsgs sendmsg,
    string username,
    string usernick,
    string content,
    ChatType type
)

参数

sendmsg
类型：Api.Framework.EventsDebugEventSendDebugMsgs
委托
username
类型：SystemString
接收者账号
usernick
类型：SystemString
接收者昵称
content
类型：SystemString
发送的消息
type
类型：Api.Framework.SDKChatType
机器人平台类型
参见

引用

DebugEvent 类
Api.Framework.Events 命名空间


DebugEvent 属性

DebugEvent 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | chatType | 机器人平台类型
公共属性 | content | 发送的消息
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | username | 接收者账号
公共属性 | usernick | 接收者昵称
Top
参见

引用

DebugEvent 类
Api.Framework.Events 命名空间


DebugEvent.chatType 属性

DebugEventchatType 属性

机器人平台类型

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChatType chatType { get; }

属性值

类型：ChatType
参见

引用

DebugEvent 类
Api.Framework.Events 命名空间


DebugEvent.content 属性

DebugEventcontent 属性

发送的消息

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string content { get; }

属性值

类型：String
参见

引用

DebugEvent 类
Api.Framework.Events 命名空间


DebugEvent.username 属性

DebugEventusername 属性

接收者账号

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string username { get; }

属性值

类型：String
参见

引用

DebugEvent 类
Api.Framework.Events 命名空间


DebugEvent.usernick 属性

DebugEventusernick 属性

接收者昵称

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string usernick { get; }

属性值

类型：String
参见

引用

DebugEvent 类
Api.Framework.Events 命名空间


DebugEvent 方法

DebugEvent 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DebugEvent 类
Api.Framework.Events 命名空间


DebugEvent 字段

DebugEvent 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | SendDebugMsg | 发送调试委托
Top
参见

引用

DebugEvent 类
Api.Framework.Events 命名空间


DebugEvent.SendDebugMsg 字段

DebugEventSendDebugMsg 字段

发送调试委托

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DebugEventSendDebugMsgs SendDebugMsg

字段值

类型：DebugEventSendDebugMsgs
参见

引用

DebugEvent 类
Api.Framework.Events 命名空间


DebugEvent.SendDebugMsgs 委托

DebugEventSendDebugMsgs 委托

定义发送调试委托

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public delegate void SendDebugMsgs(
    string username,
    string message
)

参数

username
类型：SystemString
接收者账号
message
类型：SystemString
发送的消息
参见

引用

Api.Framework.Events 命名空间


LogEvents 类

日志事件
继承层次
SystemObject
SystemEventArgs
Api.Framework.EventsBaseEvents
Api.Framework.EventsLogEvents

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class LogEvents : BaseEvents

LogEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | LogEvents | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | CrtTime | 触发时间
公共属性 | Exception | 异常对象
公共属性 | Message | 日志内容
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Events 命名空间


LogEvents 构造函数

构造方法

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public LogEvents(
    string message
)

参数

message
类型：SystemString
日志内容
参见

引用

LogEvents 类
Api.Framework.Events 命名空间


LogEvents 属性

LogEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | CrtTime | 触发时间
公共属性 | Exception | 异常对象
公共属性 | Message | 日志内容
Top
参见

引用

LogEvents 类
Api.Framework.Events 命名空间


LogEvents.CrtTime 属性

LogEventsCrtTime 属性

触发时间

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime CrtTime { get; }

属性值

类型：DateTime
参见

引用

LogEvents 类
Api.Framework.Events 命名空间


LogEvents.Exception 属性

LogEventsException 属性

异常对象

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Exception Exception { get; }

属性值

类型：Exception
参见

引用

LogEvents 类
Api.Framework.Events 命名空间


LogEvents.Message 属性

LogEventsMessage 属性

日志内容

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; set; }

属性值

类型：String
参见

引用

LogEvents 类
Api.Framework.Events 命名空间


LogEvents 方法

LogEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

LogEvents 类
Api.Framework.Events 命名空间


MethodType 枚举

界面常用操作类型

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum MethodType
成员
成员名称 | 值 | 说明
刷新应用 | 1 |
删除机器人 | 2 |
刷新联盟 | 3 |
刷新机器人 | 4 |
刷新数据报表 | 5 |
参见

引用

Api.Framework.Events 命名空间


OrderNoticeEvent 类

订单通知事件
继承层次
SystemObject
SystemEventArgs
Api.Framework.EventsBaseEvents
Api.Framework.EventsOrderNoticeEvent

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class OrderNoticeEvent : BaseEvents

OrderNoticeEvent 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | OrderNoticeEvent | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | ChatType | 联盟类型
公共属性 | Customer | 消费者 - 客户信息 注:通知类型(OrderNoticeType)为客户订单时,改对象为空;为其他类型,该值为订单所属者
公共属性 | IsRewards | 【Customer为null,IsRewards为true（订单拥有者完成首单奖励规则）；Customer不为null,IsRewards为true（上级完成首单并且符合推荐奖励规则）】
公共属性 | Member | 事件触发人
公共属性 | Order | 订单 父类(base_model_order): 强转为原始的订单类型,如阿里妈妈 fl_order_alimama ...
公共属性 | OrderNoticeType | 通知类型
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Events 命名空间


OrderNoticeEvent 构造函数

构造方法

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OrderNoticeEvent(
    CpsType chatType,
    fl_member_info member,
    Object order,
    OrderNoticeType noticeType = OrderNoticeType.客户订单
)

参数

chatType
类型：Api.Framework.EnumsCpsType
cps类型
member
类型：Api.Framework.Modelfl_member_info
用户对象
order
类型：SystemObject
订单对象
noticeType (Optional)
类型：Api.Framework.EnumsOrderNoticeType
订单所属
参见

引用

OrderNoticeEvent 类
Api.Framework.Events 命名空间


OrderNoticeEvent 属性

OrderNoticeEvent 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | ChatType | 联盟类型
公共属性 | Customer | 消费者 - 客户信息 注:通知类型(OrderNoticeType)为客户订单时,改对象为空;为其他类型,该值为订单所属者
公共属性 | IsRewards | 【Customer为null,IsRewards为true（订单拥有者完成首单奖励规则）；Customer不为null,IsRewards为true（上级完成首单并且符合推荐奖励规则）】
公共属性 | Member | 事件触发人
公共属性 | Order | 订单 父类(base_model_order): 强转为原始的订单类型,如阿里妈妈 fl_order_alimama ...
公共属性 | OrderNoticeType | 通知类型
Top
参见

引用

OrderNoticeEvent 类
Api.Framework.Events 命名空间


OrderNoticeEvent.ChatType 属性

OrderNoticeEventChatType 属性

联盟类型

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CpsType ChatType { get; }

属性值

类型：CpsType
参见

引用

OrderNoticeEvent 类
Api.Framework.Events 命名空间


OrderNoticeEvent.Customer 属性

OrderNoticeEventCustomer 属性

消费者 - 客户信息 注:通知类型(OrderNoticeType)为客户订单时,改对象为空;为其他类型,该值为订单所属者

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_member_info Customer { get; }

属性值

类型：fl_member_info
参见

引用

OrderNoticeEvent 类
Api.Framework.Events 命名空间


OrderNoticeEvent.IsRewards 属性

OrderNoticeEventIsRewards 属性

【Customer为null,IsRewards为true（订单拥有者完成首单奖励规则）；Customer不为null,IsRewards为true（上级完成首单并且符合推荐奖励规则）】

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsRewards { get; }

属性值

类型：Boolean
参见

引用

OrderNoticeEvent 类
Api.Framework.Events 命名空间


OrderNoticeEvent.Member 属性

OrderNoticeEventMember 属性

事件触发人

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_member_info Member { get; }

属性值

类型：fl_member_info
参见

引用

OrderNoticeEvent 类
Api.Framework.Events 命名空间


OrderNoticeEvent.Order 属性

OrderNoticeEventOrder 属性

订单 父类(base_model_order): 强转为原始的订单类型,如阿里妈妈 fl_order_alimama ...

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object Order { get; }

属性值

类型：Object
参见

引用

OrderNoticeEvent 类
Api.Framework.Events 命名空间


OrderNoticeEvent.OrderNoticeType 属性

OrderNoticeEventOrderNoticeType 属性

通知类型

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OrderNoticeType OrderNoticeType { get; set; }

属性值

类型：OrderNoticeType
参见

引用

OrderNoticeEvent 类
Api.Framework.Events 命名空间


OrderNoticeEvent 方法

OrderNoticeEvent 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

OrderNoticeEvent 类
Api.Framework.Events 命名空间


SharedEvents 类

通用事件,可实现插件之间的数据传输,自己定义规则
继承层次
SystemObject
SystemEventArgs
Api.Framework.EventsBaseEvents
Api.Framework.EventsSharedEvents

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SharedEvents : BaseEvents

SharedEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SharedEvents | 构造方法
公共方法 | SharedEvents(DictionaryString, Object) | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | Shareds | 参数
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Events 命名空间


SharedEvents 构造函数

重载列表
 | 名称 | 说明
公共方法 | SharedEvents | 构造方法
公共方法 | SharedEvents(DictionaryString, Object) | 构造方法
Top
参见

引用

SharedEvents 类
Api.Framework.Events 命名空间


SharedEvents 构造函数

构造方法

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SharedEvents()
参见

引用

SharedEvents 类
SharedEvents 重载
Api.Framework.Events 命名空间


SharedEvents 构造函数 (Dictionary(String, Object))

SharedEvents 构造函数 (DictionaryString, Object)

构造方法

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SharedEvents(
    Dictionary<string, Object> Shareds
)

参数

Shareds
类型：System.Collections.GenericDictionary String, Object
参数
参见

引用

SharedEvents 类
SharedEvents 重载
Api.Framework.Events 命名空间


SharedEvents 属性

SharedEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | Shareds | 参数
Top
参见

引用

SharedEvents 类
Api.Framework.Events 命名空间


SharedEvents.Shareds 属性

SharedEventsShareds 属性

参数

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> Shareds { get; }

属性值

类型：Dictionary String, Object
参见

引用

SharedEvents 类
Api.Framework.Events 命名空间


SharedEvents 方法

SharedEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SharedEvents 类
Api.Framework.Events 命名空间


WebRequestEvents 类

web请求事件
继承层次
SystemObject
SystemEventArgs
Api.Framework.EventsBaseEvents
Api.Framework.EventsWebRequestEvents

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WebRequestEvents : BaseEvents

WebRequestEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WebRequestEvents | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | Context | 上下文
公共属性 | Cookies | cookies
公共属性 | Param | 提交的参数 包含:GET POST 合集
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Send(Exception, Int32) | 发送错误请求
公共方法 | Send(Object, Int32) | 发送正确请求
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Events 命名空间


WebRequestEvents 构造函数

构造方法

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WebRequestEvents(
    IOwinContext context,
    Dictionary<string, string> Param,
    WebClientResult Respose
)

参数

context
类型：IOwinContext
上下文
Param
类型：System.Collections.GenericDictionary String, String
提交的参数 包含:GET POST 合集
Respose
类型：Api.FrameworkWebClientResult
响应的对象
参见

引用

WebRequestEvents 类
Api.Framework.Events 命名空间


WebRequestEvents 属性

WebRequestEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | Context | 上下文
公共属性 | Cookies | cookies
公共属性 | Param | 提交的参数 包含:GET POST 合集
Top
参见

引用

WebRequestEvents 类
Api.Framework.Events 命名空间


WebRequestEvents.Context 属性

WebRequestEventsContext 属性

上下文

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public IOwinContext Context { get; }

属性值

类型：IOwinContext
参见

引用

WebRequestEvents 类
Api.Framework.Events 命名空间


WebRequestEvents.Cookies 属性

WebRequestEventsCookies 属性

cookies

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public NameValueCollection Cookies { get; }

属性值

类型：NameValueCollection
参见

引用

WebRequestEvents 类
Api.Framework.Events 命名空间


WebRequestEvents.Param 属性

WebRequestEventsParam 属性

提交的参数 包含:GET POST 合集

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, string> Param { get; }

属性值

类型：Dictionary String, String
参见

引用

WebRequestEvents 类
Api.Framework.Events 命名空间


WebRequestEvents 方法

WebRequestEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Send(Exception, Int32) | 发送错误请求
公共方法 | Send(Object, Int32) | 发送正确请求
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WebRequestEvents 类
Api.Framework.Events 命名空间


WebRequestEvents.Send 方法

WebRequestEventsSend 方法

重载列表
 | 名称 | 说明
公共方法 | Send(Exception, Int32) | 发送错误请求
公共方法 | Send(Object, Int32) | 发送正确请求
Top
参见

引用

WebRequestEvents 类
Api.Framework.Events 命名空间


WebRequestEvents.Send 方法 (Exception, Int32)

WebRequestEventsSend 方法 (Exception, Int32)

发送错误请求

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Send(
    Exception e,
    int code = -1
)

参数

e
类型：SystemException
异常
code (Optional)
类型：SystemInt32
错误代码
参见

引用

WebRequestEvents 类
Send 重载
Api.Framework.Events 命名空间


WebRequestEvents.Send 方法 (Object, Int32)

WebRequestEventsSend 方法 (Object, Int32)

发送正确请求

命名空间： Api.Framework.Events
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Send(
    Object message,
    int code = 0
)

参数

message
类型：SystemObject
请求内容
code (Optional)
类型：SystemInt32
正确代码
参见

引用

WebRequestEvents 类
Send 重载
Api.Framework.Events 命名空间


Api.Framework.Model 命名空间

[缺少 "N:Api.Framework.Model" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | base_model_order | 基础订单类
公共类 | DouYinOrder | 抖音订单响应
公共类 | Extra | 其他
公共类 | fl_adzone_group | 推广位组
公共类 | fl_adzone_info | 推广位
公共类 | fl_alimama_order_lastnum | 阿里订单尾号
公共类 | fl_alimama_tlj_create_record | 阿里淘礼金创建记录
公共类 | fl_alimama_tlj_get_record | 阿里淘礼金获取记录
公共类 | fl_alimama_tlj_info | 阿里淘礼金信息
公共类 | fl_bind_cache | 订单绑定记录表
公共类 | fl_cloud_black | 云黑名单
公共类 | fl_cps_member | 平台账号对象(拼多多|阿里妈妈|京东联盟)
公共类 | fl_create_info | 無用
公共类 | fl_debug_log | debug日志
公共类 | fl_dictionary_item | 配置
公共类 | fl_exchange_info | 兑换记录
公共类 | fl_group_person | 群管理
公共类 | fl_member_group | 会员分组表
公共类 | fl_member_info | 用户信息表
公共类 | fl_member_level | 分组
公共类 | fl_noticeapi_info | 通知机器人信息
公共类 | fl_operation_log | 操作日志
公共类 | fl_order_alimama | 阿里订单
公共类 | fl_order_douyin | 抖音订单
公共类 | fl_order_jingdong | 京东订单
公共类 | fl_order_pinduoduo | 拼多多订单
公共类 | fl_order_refund_alimama | 阿里订单维权
公共类 | fl_order_sleep | 订单冻结规则
公共类 | fl_order_weipinhui | 唯品会订单
公共类 | fl_plugin_allrebatesactivity_info | 全额免单
公共类 | fl_plugin_allrebatesactivity_orderlist | 全额免单订单
公共类 | fl_plugin_info | 插件基础信息
公共类 | fl_point_hist | 积分改变记录
公共类 | fl_prevent_theft_cache | 防撸处理
公共类 | fl_private_pid | 私人PID绑定
公共类 | fl_query_hist | 查询记录
公共类 | fl_ratio_info | 分出比例
公共类 | fl_robot_info | 机器人信息
公共类 | fl_shpay_hist | 商户支付记录
公共类 | fl_statistics_record | 用户基础记录
公共类 | fl_tb_relation | 淘宝关系类
公共类 | fl_uservariate_info | 用户自定义全局变量
公共类 | fl_wechat_contacts | 联系人
公共类 | fl_wechat_device | 微信协议设备信息
公共类 | fl_weixin_password | 协议微信支付信息
公共类 | ModelExtend | 扩展方法
公共类 | temp_send_data | 发送消息临时类
枚举
 | 枚举 | 说明
公共枚举 | fl_alimama_activity_type | 天猫推广位类型
公共枚举 | NoticeApiType | 通知Api类型


base_model_order 类

基础订单类
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelbase_model_order
更多...

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class base_model_order : base_model

base_model_order 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | base_model_order | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | db_cpsname | 联盟账号
公共属性 | db_cpsnick | 联盟昵称
公共属性 | db_endtime | 完结时间
公共属性 | db_point | 积分信息
公共属性 | db_robotname | 机器人ID
公共属性 | db_robottype | 机器人类型
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算
公共属性 | db_status_time | 订单状态修改时间戳
公共属性 | db_userid | 用户标识
公共属性 | db_userpoint | 用户积分 - 临时记录
公共属性 | id | (继承自 base_model。)
公共属性 | msg_groupid | 订单来源群
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelbase_model_order
Api.Framework.Modelfl_order_alimama
Api.Framework.Modelfl_order_douyin
Api.Framework.Modelfl_order_jingdong
Api.Framework.Modelfl_order_pinduoduo
Api.Framework.Modelfl_order_weipinhui
Api.Framework.Modelfl_weixin_password


base_model_order 构造函数

构造方法

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public base_model_order()
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order 属性

base_model_order 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | db_cpsname | 联盟账号
公共属性 | db_cpsnick | 联盟昵称
公共属性 | db_endtime | 完结时间
公共属性 | db_point | 积分信息
公共属性 | db_robotname | 机器人ID
公共属性 | db_robottype | 机器人类型
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算
公共属性 | db_status_time | 订单状态修改时间戳
公共属性 | db_userid | 用户标识
公共属性 | db_userpoint | 用户积分 - 临时记录
公共属性 | id | (继承自 base_model。)
公共属性 | msg_groupid | 订单来源群
Top
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_cpsname 属性

base_model_orderdb_cpsname 属性

联盟账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string db_cpsname { get; set; }

属性值

类型：String
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_cpsnick 属性

base_model_orderdb_cpsnick 属性

联盟昵称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string db_cpsnick { get; set; }

属性值

类型：String
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_endtime 属性

base_model_orderdb_endtime 属性

完结时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime db_endtime { get; set; }

属性值

类型：DateTime
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_point 属性

base_model_orderdb_point 属性

积分信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string db_point { get; set; }

属性值

类型：String
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_robotname 属性

base_model_orderdb_robotname 属性

机器人ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string db_robotname { get; set; }

属性值

类型：String
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_robottype 属性

base_model_orderdb_robottype 属性

机器人类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChatType db_robottype { get; set; }

属性值

类型：ChatType
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_status 属性

base_model_orderdb_status 属性

完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SystemOrderStatus db_status { get; set; }

属性值

类型：SystemOrderStatus
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_status_time 属性

base_model_orderdb_status_time 属性

订单状态修改时间戳

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string db_status_time { get; set; }

属性值

类型：String
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_userid 属性

base_model_orderdb_userid 属性

用户标识

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long db_userid { get; set; }

属性值

类型：Int64
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.db_userpoint 属性

base_model_orderdb_userpoint 属性

用户积分 - 临时记录

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double db_userpoint { get; set; }

属性值

类型：Double
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.msg_groupid 属性

base_model_ordermsg_groupid 属性

订单来源群

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string msg_groupid { get; set; }

属性值

类型：String
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order 方法

base_model_order 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


base_model_order.IsFinish 方法

base_model_orderIsFinish 方法

订单是否完成

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsFinish()

返回值

类型：Boolean
参见

引用

base_model_order 类
Api.Framework.Model 命名空间


DouYinOrder 类

抖音订单响应
继承层次
SystemObject
Api.Framework.ModelDouYinOrder

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DouYinOrder

DouYinOrder 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DouYinOrder | 初始化 DouYinOrder 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | code | 响应值
公共属性 | data | 数据
公共属性 | extra | 其他信息
公共属性 | msg | 响应状态内容
公共属性 | st | 不知道是什么
公共属性 | total | 查询出来的数据量
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


DouYinOrder 构造函数

初始化 DouYinOrder 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DouYinOrder()
参见

引用

DouYinOrder 类
Api.Framework.Model 命名空间


DouYinOrder 属性

DouYinOrder 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | code | 响应值
公共属性 | data | 数据
公共属性 | extra | 其他信息
公共属性 | msg | 响应状态内容
公共属性 | st | 不知道是什么
公共属性 | total | 查询出来的数据量
Top
参见

引用

DouYinOrder 类
Api.Framework.Model 命名空间


DouYinOrder.code 属性

DouYinOrdercode 属性

响应值

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long code { get; set; }

属性值

类型：Int64
参见

引用

DouYinOrder 类
Api.Framework.Model 命名空间


DouYinOrder.data 属性

DouYinOrderdata 属性

数据

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<fl_order_douyin> data { get; set; }

属性值

类型：List fl_order_douyin
参见

引用

DouYinOrder 类
Api.Framework.Model 命名空间


DouYinOrder.extra 属性

DouYinOrderextra 属性

其他信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Extra extra { get; set; }

属性值

类型：Extra
参见

引用

DouYinOrder 类
Api.Framework.Model 命名空间


DouYinOrder.msg 属性

DouYinOrdermsg 属性

响应状态内容

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string msg { get; set; }

属性值

类型：String
参见

引用

DouYinOrder 类
Api.Framework.Model 命名空间


DouYinOrder.st 属性

DouYinOrderst 属性

不知道是什么

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long st { get; set; }

属性值

类型：Int64
参见

引用

DouYinOrder 类
Api.Framework.Model 命名空间


DouYinOrder.total 属性

DouYinOrdertotal 属性

查询出来的数据量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long total { get; set; }

属性值

类型：Int64
参见

引用

DouYinOrder 类
Api.Framework.Model 命名空间


DouYinOrder 方法

DouYinOrder 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DouYinOrder 类
Api.Framework.Model 命名空间


Extra 类

其他
继承层次
SystemObject
Api.Framework.ModelExtra

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Extra

Extra 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Extra | 初始化 Extra 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | log_id | 日志id
公共属性 | now | 时间戳毫秒
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


Extra 构造函数

初始化 Extra 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Extra()
参见

引用

Extra 类
Api.Framework.Model 命名空间


Extra 属性

Extra 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | log_id | 日志id
公共属性 | now | 时间戳毫秒
Top
参见

引用

Extra 类
Api.Framework.Model 命名空间


Extra.log_id 属性

Extralog_id 属性

日志id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string log_id { get; set; }

属性值

类型：String
参见

引用

Extra 类
Api.Framework.Model 命名空间


Extra.now 属性

Extranow 属性

时间戳毫秒

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long now { get; set; }

属性值

类型：Int64
参见

引用

Extra 类
Api.Framework.Model 命名空间


Extra 方法

Extra 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Extra 类
Api.Framework.Model 命名空间


fl_adzone_group 类

推广位组
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_adzone_group

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_adzone_group : base_model

fl_adzone_group 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_adzone_group | 初始化 fl_adzone_group 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | adzones | 推广位集合
公共属性 | cps_type | 联盟类型
公共属性 | id | (继承自 base_model。)
公共属性 | name | 组名称
公共属性 | remark | 备注
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_adzone_group 构造函数

初始化 fl_adzone_group 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_adzone_group()
参见

引用

fl_adzone_group 类
Api.Framework.Model 命名空间


fl_adzone_group 属性

fl_adzone_group 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | adzones | 推广位集合
公共属性 | cps_type | 联盟类型
公共属性 | id | (继承自 base_model。)
公共属性 | name | 组名称
公共属性 | remark | 备注
Top
参见

引用

fl_adzone_group 类
Api.Framework.Model 命名空间


fl_adzone_group.adzones 属性

fl_adzone_groupadzones 属性

推广位集合

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzones { get; set; }

属性值

类型：String
参见

引用

fl_adzone_group 类
Api.Framework.Model 命名空间


fl_adzone_group.cps_type 属性

fl_adzone_groupcps_type 属性

联盟类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CpsType cps_type { get; set; }

属性值

类型：CpsType
参见

引用

fl_adzone_group 类
Api.Framework.Model 命名空间


fl_adzone_group.name 属性

fl_adzone_groupname 属性

组名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string name { get; set; }

属性值

类型：String
参见

引用

fl_adzone_group 类
Api.Framework.Model 命名空间


fl_adzone_group.remark 属性

fl_adzone_groupremark 属性

备注

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string remark { get; set; }

属性值

类型：String
参见

引用

fl_adzone_group 类
Api.Framework.Model 命名空间


fl_adzone_group 方法

fl_adzone_group 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_adzone_group 类
Api.Framework.Model 命名空间


fl_adzone_info 类

推广位
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_adzone_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_adzone_info : base_model

fl_adzone_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_adzone_info | 初始化 fl_adzone_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | adzone_group | 推广位组
公共属性 | adzone_name | 推广位名称
公共属性 | adzone_pid | 推广位pid
公共属性 | adzone_pid_cps_name | 推广位CPS名称
公共属性 | alliance_id | 联盟id
公共属性 | custom_type | 自定义类型(用处)
公共属性 | extend | 扩展属性
公共属性 | group_id | 群id(用于群pid)
公共属性 | id | (继承自 base_model。)
公共属性 | is_auto_bind | 是否强制绑定
公共属性 | is_download | 是否下载报表
公共属性 | member_id | 用户id(用于私人pid)
公共属性 | onoff | 是否禁用(true为禁用)
公共属性 | robot_id | 机器人id
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_adzone_info 构造函数

初始化 fl_adzone_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_adzone_info()
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info 属性

fl_adzone_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | adzone_group | 推广位组
公共属性 | adzone_name | 推广位名称
公共属性 | adzone_pid | 推广位pid
公共属性 | adzone_pid_cps_name | 推广位CPS名称
公共属性 | alliance_id | 联盟id
公共属性 | custom_type | 自定义类型(用处)
公共属性 | extend | 扩展属性
公共属性 | group_id | 群id(用于群pid)
公共属性 | id | (继承自 base_model。)
公共属性 | is_auto_bind | 是否强制绑定
公共属性 | is_download | 是否下载报表
公共属性 | member_id | 用户id(用于私人pid)
公共属性 | onoff | 是否禁用(true为禁用)
公共属性 | robot_id | 机器人id
Top
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.adzone_group 属性

fl_adzone_infoadzone_group 属性

推广位组

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long adzone_group { get; set; }

属性值

类型：Int64
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.adzone_name 属性

fl_adzone_infoadzone_name 属性

推广位名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzone_name { get; set; }

属性值

类型：String
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.adzone_pid 属性

fl_adzone_infoadzone_pid 属性

推广位pid

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzone_pid { get; set; }

属性值

类型：String
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.adzone_pid_cps_name 属性

fl_adzone_infoadzone_pid_cps_name 属性

推广位CPS名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzone_pid_cps_name { get; set; }

属性值

类型：String
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.alliance_id 属性

fl_adzone_infoalliance_id 属性

联盟id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long alliance_id { get; set; }

属性值

类型：Int64
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.custom_type 属性

fl_adzone_infocustom_type 属性

自定义类型(用处)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string custom_type { get; set; }

属性值

类型：String
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.extend 属性

fl_adzone_infoextend 属性

扩展属性

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string extend { get; set; }

属性值

类型：String
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.group_id 属性

fl_adzone_infogroup_id 属性

群id(用于群pid)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string group_id { get; set; }

属性值

类型：String
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.is_auto_bind 属性

fl_adzone_infois_auto_bind 属性

是否强制绑定

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool is_auto_bind { get; set; }

属性值

类型：Boolean
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.is_download 属性

fl_adzone_infois_download 属性

是否下载报表

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool is_download { get; set; }

属性值

类型：Boolean
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.member_id 属性

fl_adzone_infomember_id 属性

用户id(用于私人pid)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long member_id { get; set; }

属性值

类型：Int64
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.onoff 属性

fl_adzone_infoonoff 属性

是否禁用(true为禁用)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool onoff { get; set; }

属性值

类型：Boolean
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info.robot_id 属性

fl_adzone_inforobot_id 属性

机器人id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long robot_id { get; set; }

属性值

类型：Int64
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_adzone_info 方法

fl_adzone_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_adzone_info 类
Api.Framework.Model 命名空间


fl_alimama_activity_type 枚举

天猫推广位类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum fl_alimama_activity_type
成员
成员名称 | 值 | 说明
天猫精选 | 2015012602 |
参见

引用

Api.Framework.Model 命名空间


fl_alimama_order_lastnum 类

阿里订单尾号
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_alimama_order_lastnum

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_alimama_order_lastnum : base_model

fl_alimama_order_lastnum 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_alimama_order_lastnum | 初始化 fl_alimama_order_lastnum 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | id | (继承自 base_model。)
公共属性 | lastnumber | 尾号
公共属性 | userid | 所属用户
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_alimama_order_lastnum 构造函数

初始化 fl_alimama_order_lastnum 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_alimama_order_lastnum()
参见

引用

fl_alimama_order_lastnum 类
Api.Framework.Model 命名空间


fl_alimama_order_lastnum 属性

fl_alimama_order_lastnum 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | id | (继承自 base_model。)
公共属性 | lastnumber | 尾号
公共属性 | userid | 所属用户
Top
参见

引用

fl_alimama_order_lastnum 类
Api.Framework.Model 命名空间


fl_alimama_order_lastnum.lastnumber 属性

fl_alimama_order_lastnumlastnumber 属性

尾号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string lastnumber { get; set; }

属性值

类型：String
参见

引用

fl_alimama_order_lastnum 类
Api.Framework.Model 命名空间


fl_alimama_order_lastnum.userid 属性

fl_alimama_order_lastnumuserid 属性

所属用户

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long userid { get; set; }

属性值

类型：Int64
参见

引用

fl_alimama_order_lastnum 类
Api.Framework.Model 命名空间


fl_alimama_order_lastnum 方法

fl_alimama_order_lastnum 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_alimama_order_lastnum 类
Api.Framework.Model 命名空间


fl_alimama_tlj_create_record 类

阿里淘礼金创建记录
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_alimama_tlj_create_record

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_alimama_tlj_create_record : base_model

fl_alimama_tlj_create_record 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_alimama_tlj_create_record | 初始化 fl_alimama_tlj_create_record 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | cpsname | cps名称
公共属性 | date | 创建的日期
公共属性 | id | (继承自 base_model。)
公共属性 | number | 创建的数量
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_alimama_tlj_create_record 构造函数

初始化 fl_alimama_tlj_create_record 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_alimama_tlj_create_record()
参见

引用

fl_alimama_tlj_create_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_create_record 属性

fl_alimama_tlj_create_record 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | cpsname | cps名称
公共属性 | date | 创建的日期
公共属性 | id | (继承自 base_model。)
公共属性 | number | 创建的数量
Top
参见

引用

fl_alimama_tlj_create_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_create_record.cpsname 属性

fl_alimama_tlj_create_recordcpsname 属性

cps名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cpsname { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_create_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_create_record.date 属性

fl_alimama_tlj_create_recorddate 属性

创建的日期

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string date { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_create_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_create_record.number 属性

fl_alimama_tlj_create_recordnumber 属性

创建的数量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int number { get; set; }

属性值

类型：Int32
参见

引用

fl_alimama_tlj_create_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_create_record 方法

fl_alimama_tlj_create_record 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_alimama_tlj_create_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_get_record 类

阿里淘礼金获取记录
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_alimama_tlj_get_record

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_alimama_tlj_get_record : base_model

fl_alimama_tlj_get_record 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_alimama_tlj_get_record | 初始化 fl_alimama_tlj_get_record 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | adzoneid | tlj使用的pid
公共属性 | cpsname | 阿里id
公共属性 | expiredate | 淘礼金有效期
公共属性 | id | (继承自 base_model。)
公共属性 | itemid | 商品id
公共属性 | number | 数量
公共属性 | url | 淘礼金链接
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_alimama_tlj_get_record 构造函数

初始化 fl_alimama_tlj_get_record 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_alimama_tlj_get_record()
参见

引用

fl_alimama_tlj_get_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_get_record 属性

fl_alimama_tlj_get_record 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | adzoneid | tlj使用的pid
公共属性 | cpsname | 阿里id
公共属性 | expiredate | 淘礼金有效期
公共属性 | id | (继承自 base_model。)
公共属性 | itemid | 商品id
公共属性 | number | 数量
公共属性 | url | 淘礼金链接
Top
参见

引用

fl_alimama_tlj_get_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_get_record.adzoneid 属性

fl_alimama_tlj_get_recordadzoneid 属性

tlj使用的pid

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzoneid { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_get_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_get_record.cpsname 属性

fl_alimama_tlj_get_recordcpsname 属性

阿里id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cpsname { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_get_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_get_record.expiredate 属性

fl_alimama_tlj_get_recordexpiredate 属性

淘礼金有效期

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime expiredate { get; set; }

属性值

类型：DateTime
参见

引用

fl_alimama_tlj_get_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_get_record.itemid 属性

fl_alimama_tlj_get_recorditemid 属性

商品id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string itemid { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_get_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_get_record.number 属性

fl_alimama_tlj_get_recordnumber 属性

数量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int number { get; set; }

属性值

类型：Int32
参见

引用

fl_alimama_tlj_get_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_get_record.url 属性

fl_alimama_tlj_get_recordurl 属性

淘礼金链接

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string url { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_get_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_get_record 方法

fl_alimama_tlj_get_record 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_alimama_tlj_get_record 类
Api.Framework.Model 命名空间


fl_alimama_tlj_info 类

阿里淘礼金信息
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_alimama_tlj_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_alimama_tlj_info : base_model

fl_alimama_tlj_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_alimama_tlj_info | 初始化 fl_alimama_tlj_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | adzone_name | 推广位名称
公共属性 | adzone_pid | 推广位pid
公共属性 | appkey | 淘礼金appkey
公共属性 | appsecret | 淘礼金appsecret
公共属性 | id | (继承自 base_model。)
公共属性 | username | 淘宝username
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_alimama_tlj_info 构造函数

初始化 fl_alimama_tlj_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_alimama_tlj_info()
参见

引用

fl_alimama_tlj_info 类
Api.Framework.Model 命名空间


fl_alimama_tlj_info 属性

fl_alimama_tlj_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | adzone_name | 推广位名称
公共属性 | adzone_pid | 推广位pid
公共属性 | appkey | 淘礼金appkey
公共属性 | appsecret | 淘礼金appsecret
公共属性 | id | (继承自 base_model。)
公共属性 | username | 淘宝username
Top
参见

引用

fl_alimama_tlj_info 类
Api.Framework.Model 命名空间


fl_alimama_tlj_info.adzone_name 属性

fl_alimama_tlj_infoadzone_name 属性

推广位名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzone_name { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_info 类
Api.Framework.Model 命名空间


fl_alimama_tlj_info.adzone_pid 属性

fl_alimama_tlj_infoadzone_pid 属性

推广位pid

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzone_pid { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_info 类
Api.Framework.Model 命名空间


fl_alimama_tlj_info.appkey 属性

fl_alimama_tlj_infoappkey 属性

淘礼金appkey

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string appkey { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_info 类
Api.Framework.Model 命名空间


fl_alimama_tlj_info.appsecret 属性

fl_alimama_tlj_infoappsecret 属性

淘礼金appsecret

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string appsecret { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_info 类
Api.Framework.Model 命名空间


fl_alimama_tlj_info.username 属性

fl_alimama_tlj_infousername 属性

淘宝username

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string username { get; set; }

属性值

类型：String
参见

引用

fl_alimama_tlj_info 类
Api.Framework.Model 命名空间


fl_alimama_tlj_info 方法

fl_alimama_tlj_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_alimama_tlj_info 类
Api.Framework.Model 命名空间


fl_bind_cache 类

订单绑定记录表
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_bind_cache

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_bind_cache : base_model

fl_bind_cache 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_bind_cache | fl绑定缓存
Top
属性
 | 名称 | 说明
公共属性 | crt_time | 创建时间
公共属性 | db_robotid | 机器人ID
公共属性 | db_userid | 用户ID
公共属性 | groupid | 群号
公共属性 | id | (继承自 base_model。)
公共属性 | orderid | 绑定的订单号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_bind_cache 构造函数

fl绑定缓存

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_bind_cache()
参见

引用

fl_bind_cache 类
Api.Framework.Model 命名空间


fl_bind_cache 属性

fl_bind_cache 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | crt_time | 创建时间
公共属性 | db_robotid | 机器人ID
公共属性 | db_userid | 用户ID
公共属性 | groupid | 群号
公共属性 | id | (继承自 base_model。)
公共属性 | orderid | 绑定的订单号
Top
参见

引用

fl_bind_cache 类
Api.Framework.Model 命名空间


fl_bind_cache.crt_time 属性

fl_bind_cachecrt_time 属性

创建时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime crt_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_bind_cache 类
Api.Framework.Model 命名空间


fl_bind_cache.db_robotid 属性

fl_bind_cachedb_robotid 属性

机器人ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long db_robotid { get; set; }

属性值

类型：Int64
参见

引用

fl_bind_cache 类
Api.Framework.Model 命名空间


fl_bind_cache.db_userid 属性

fl_bind_cachedb_userid 属性

用户ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long db_userid { get; set; }

属性值

类型：Int64
参见

引用

fl_bind_cache 类
Api.Framework.Model 命名空间


fl_bind_cache.groupid 属性

fl_bind_cachegroupid 属性

群号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string groupid { get; set; }

属性值

类型：String
参见

引用

fl_bind_cache 类
Api.Framework.Model 命名空间


fl_bind_cache.orderid 属性

fl_bind_cacheorderid 属性

绑定的订单号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string orderid { get; set; }

属性值

类型：String
参见

引用

fl_bind_cache 类
Api.Framework.Model 命名空间


fl_bind_cache 方法

fl_bind_cache 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_bind_cache 类
Api.Framework.Model 命名空间


fl_cloud_black 类

云黑名单
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_cloud_black

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_cloud_black : base_model

fl_cloud_black 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_cloud_black | 初始化 fl_cloud_black 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | id | (继承自 base_model。)
公共属性 | is_black | 是否是黑名单
公共属性 | last_check_time | 最后一次检测时间
公共属性 | memberid | 用户id
公共属性 | remark | 被拉黑的原因
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_cloud_black 构造函数

初始化 fl_cloud_black 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_cloud_black()
参见

引用

fl_cloud_black 类
Api.Framework.Model 命名空间


fl_cloud_black 属性

fl_cloud_black 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | id | (继承自 base_model。)
公共属性 | is_black | 是否是黑名单
公共属性 | last_check_time | 最后一次检测时间
公共属性 | memberid | 用户id
公共属性 | remark | 被拉黑的原因
Top
参见

引用

fl_cloud_black 类
Api.Framework.Model 命名空间


fl_cloud_black.is_black 属性

fl_cloud_blackis_black 属性

是否是黑名单

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool is_black { get; set; }

属性值

类型：Boolean
参见

引用

fl_cloud_black 类
Api.Framework.Model 命名空间


fl_cloud_black.last_check_time 属性

fl_cloud_blacklast_check_time 属性

最后一次检测时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime last_check_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_cloud_black 类
Api.Framework.Model 命名空间


fl_cloud_black.memberid 属性

fl_cloud_blackmemberid 属性

用户id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long memberid { get; set; }

属性值

类型：Int64
参见

引用

fl_cloud_black 类
Api.Framework.Model 命名空间


fl_cloud_black.remark 属性

fl_cloud_blackremark 属性

被拉黑的原因

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string remark { get; set; }

属性值

类型：String
参见

引用

fl_cloud_black 类
Api.Framework.Model 命名空间


fl_cloud_black 方法

fl_cloud_black 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_cloud_black 类
Api.Framework.Model 命名空间


fl_cps_member 类

平台账号对象(拼多多|阿里妈妈|京东联盟)
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_cps_member

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_cps_member : base_model

fl_cps_member 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_cps_member | 初始化 fl_cps_member 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | abnormal_tip | 异常通知
公共属性 | cookies | Cookies
公共属性 | cpstype | 账号类型
公共属性 | id | (继承自 base_model。)
公共属性 | is_download | 是否下载
公共属性 | is_valid | 高佣是否有效(淘宝有效)
公共属性 | logintime | 登录时间
公共属性 | online | 在线
公共属性 | username | 登录名(京东联盟:key)
公共属性 | usernick | 用户昵称(京东联盟:unionId)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_cps_member 构造函数

初始化 fl_cps_member 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_cps_member()
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member 属性

fl_cps_member 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | abnormal_tip | 异常通知
公共属性 | cookies | Cookies
公共属性 | cpstype | 账号类型
公共属性 | id | (继承自 base_model。)
公共属性 | is_download | 是否下载
公共属性 | is_valid | 高佣是否有效(淘宝有效)
公共属性 | logintime | 登录时间
公共属性 | online | 在线
公共属性 | username | 登录名(京东联盟:key)
公共属性 | usernick | 用户昵称(京东联盟:unionId)
Top
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.abnormal_tip 属性

fl_cps_memberabnormal_tip 属性

异常通知

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType abnormal_tip { get; set; }

属性值

类型：SwitchType
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.cookies 属性

fl_cps_membercookies 属性

Cookies

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cookies { get; set; }

属性值

类型：String
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.cpstype 属性

fl_cps_membercpstype 属性

账号类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CpsType cpstype { get; set; }

属性值

类型：CpsType
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.is_download 属性

fl_cps_memberis_download 属性

是否下载

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType is_download { get; set; }

属性值

类型：SwitchType
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.is_valid 属性

fl_cps_memberis_valid 属性

高佣是否有效(淘宝有效)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool is_valid { get; set; }

属性值

类型：Boolean
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.logintime 属性

fl_cps_memberlogintime 属性

登录时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime logintime { get; set; }

属性值

类型：DateTime
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.online 属性

fl_cps_memberonline 属性

在线

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool online { get; set; }

属性值

类型：Boolean
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.username 属性

fl_cps_memberusername 属性

登录名(京东联盟:key)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string username { get; set; }

属性值

类型：String
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.usernick 属性

fl_cps_memberusernick 属性

用户昵称(京东联盟:unionId)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string usernick { get; set; }

属性值

类型：String
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member 方法

fl_cps_member 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_cps_member.ToString 方法

fl_cps_memberToString 方法

[缺少 "M:Api.Framework.Model.fl_cps_member.ToString" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

fl_cps_member 类
Api.Framework.Model 命名空间


fl_create_info 类

無用
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_create_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_create_info : base_model

fl_create_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_create_info | 初始化 fl_create_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | chat_type | 类型
公共属性 | groupid | 群号
公共属性 | groupname | 群名
公共属性 | id | (继承自 base_model。)
公共属性 | userid | 用户ID
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_create_info 构造函数

初始化 fl_create_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_create_info()
参见

引用

fl_create_info 类
Api.Framework.Model 命名空间


fl_create_info 属性

fl_create_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | chat_type | 类型
公共属性 | groupid | 群号
公共属性 | groupname | 群名
公共属性 | id | (继承自 base_model。)
公共属性 | userid | 用户ID
Top
参见

引用

fl_create_info 类
Api.Framework.Model 命名空间


fl_create_info.chat_type 属性

fl_create_infochat_type 属性

类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int chat_type { get; set; }

属性值

类型：Int32
参见

引用

fl_create_info 类
Api.Framework.Model 命名空间


fl_create_info.groupid 属性

fl_create_infogroupid 属性

群号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string groupid { get; set; }

属性值

类型：String
参见

引用

fl_create_info 类
Api.Framework.Model 命名空间


fl_create_info.groupname 属性

fl_create_infogroupname 属性

群名

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string groupname { get; set; }

属性值

类型：String
参见

引用

fl_create_info 类
Api.Framework.Model 命名空间


fl_create_info.userid 属性

fl_create_infouserid 属性

用户ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long userid { get; set; }

属性值

类型：Int64
参见

引用

fl_create_info 类
Api.Framework.Model 命名空间


fl_create_info 方法

fl_create_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_create_info 类
Api.Framework.Model 命名空间


fl_debug_log 类

debug日志
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_debug_log

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_debug_log : base_model

fl_debug_log 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_debug_log | 初始化 fl_debug_log 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | crt_time | 创建时间
公共属性 | id | (继承自 base_model。)
公共属性 | message | 消息
公共属性 | time | 时间
公共属性 | token | token
公共属性 | userid | 用户ID
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_debug_log 构造函数

初始化 fl_debug_log 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_debug_log()
参见

引用

fl_debug_log 类
Api.Framework.Model 命名空间


fl_debug_log 属性

fl_debug_log 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | crt_time | 创建时间
公共属性 | id | (继承自 base_model。)
公共属性 | message | 消息
公共属性 | time | 时间
公共属性 | token | token
公共属性 | userid | 用户ID
Top
参见

引用

fl_debug_log 类
Api.Framework.Model 命名空间


fl_debug_log.crt_time 属性

fl_debug_logcrt_time 属性

创建时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime crt_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_debug_log 类
Api.Framework.Model 命名空间


fl_debug_log.message 属性

fl_debug_logmessage 属性

消息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string message { get; set; }

属性值

类型：String
参见

引用

fl_debug_log 类
Api.Framework.Model 命名空间


fl_debug_log.time 属性

fl_debug_logtime 属性

时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double time { get; set; }

属性值

类型：Double
参见

引用

fl_debug_log 类
Api.Framework.Model 命名空间


fl_debug_log.token 属性

fl_debug_logtoken 属性

token

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string token { get; set; }

属性值

类型：String
参见

引用

fl_debug_log 类
Api.Framework.Model 命名空间


fl_debug_log.userid 属性

fl_debug_loguserid 属性

用户ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long userid { get; set; }

属性值

类型：Int64
参见

引用

fl_debug_log 类
Api.Framework.Model 命名空间


fl_debug_log 方法

fl_debug_log 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_debug_log 类
Api.Framework.Model 命名空间


fl_dictionary_item 类

配置
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_dictionary_item

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_dictionary_item : base_model

fl_dictionary_item 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_dictionary_item | 初始化 fl_dictionary_item 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | dickey | 配置的名称
公共属性 | dicvalue | 配置的数据
公共属性 | id | (继承自 base_model。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_dictionary_item 构造函数

初始化 fl_dictionary_item 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_dictionary_item()
参见

引用

fl_dictionary_item 类
Api.Framework.Model 命名空间


fl_dictionary_item 属性

fl_dictionary_item 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | dickey | 配置的名称
公共属性 | dicvalue | 配置的数据
公共属性 | id | (继承自 base_model。)
Top
参见

引用

fl_dictionary_item 类
Api.Framework.Model 命名空间


fl_dictionary_item.dickey 属性

fl_dictionary_itemdickey 属性

配置的名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string dickey { get; set; }

属性值

类型：String
参见

引用

fl_dictionary_item 类
Api.Framework.Model 命名空间


fl_dictionary_item.dicvalue 属性

fl_dictionary_itemdicvalue 属性

配置的数据

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string dicvalue { get; set; }

属性值

类型：String
参见

引用

fl_dictionary_item 类
Api.Framework.Model 命名空间


fl_dictionary_item 方法

fl_dictionary_item 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_dictionary_item 类
Api.Framework.Model 命名空间


fl_exchange_info 类

兑换记录
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_exchange_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_exchange_info : base_model

fl_exchange_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_exchange_info | 初始化 fl_exchange_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | check_time | 审核时间
公共属性 | groupid | 群id
公共属性 | id | (继承自 base_model。)
公共属性 | IsTransmatic | 是否为自动转账(之后用于计算当天自动转账金额总数)
公共属性 | point | 积分
公共属性 | remark | 备注
公共属性 | rid | 机器人的id fl_robot_info表
公共属性 | state | 申请状态
公共属性 | time | 兑换时间
公共属性 | uid | 用户fl_member_info的id
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_exchange_info 构造函数

初始化 fl_exchange_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_exchange_info()
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info 属性

fl_exchange_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | check_time | 审核时间
公共属性 | groupid | 群id
公共属性 | id | (继承自 base_model。)
公共属性 | IsTransmatic | 是否为自动转账(之后用于计算当天自动转账金额总数)
公共属性 | point | 积分
公共属性 | remark | 备注
公共属性 | rid | 机器人的id fl_robot_info表
公共属性 | state | 申请状态
公共属性 | time | 兑换时间
公共属性 | uid | 用户fl_member_info的id
Top
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info.check_time 属性

fl_exchange_infocheck_time 属性

审核时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime check_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info.groupid 属性

fl_exchange_infogroupid 属性

群id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string groupid { get; set; }

属性值

类型：String
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info.IsTransmatic 属性

fl_exchange_infoIsTransmatic 属性

是否为自动转账(之后用于计算当天自动转账金额总数)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsTransmatic { get; set; }

属性值

类型：Boolean
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info.point 属性

fl_exchange_infopoint 属性

积分

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double point { get; set; }

属性值

类型：Double
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info.remark 属性

fl_exchange_inforemark 属性

备注

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string remark { get; set; }

属性值

类型：String
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info.rid 属性

fl_exchange_inforid 属性

机器人的id fl_robot_info表

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long rid { get; set; }

属性值

类型：Int64
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info.state 属性

fl_exchange_infostate 属性

申请状态

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ApplyType state { get; set; }

属性值

类型：ApplyType
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info.time 属性

fl_exchange_infotime 属性

兑换时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime time { get; set; }

属性值

类型：DateTime
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info.uid 属性

fl_exchange_infouid 属性

用户fl_member_info的id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long uid { get; set; }

属性值

类型：Int64
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_exchange_info 方法

fl_exchange_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_exchange_info 类
Api.Framework.Model 命名空间


fl_group_person 类

群管理
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_group_person

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_group_person : base_model

fl_group_person 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_group_person | 初始化 fl_group_person 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | groupid | 群号
公共属性 | groupname | 群名
公共属性 | id | (继承自 base_model。)
公共属性 | mid | 用户ID
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_group_person 构造函数

初始化 fl_group_person 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_group_person()
参见

引用

fl_group_person 类
Api.Framework.Model 命名空间


fl_group_person 属性

fl_group_person 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | groupid | 群号
公共属性 | groupname | 群名
公共属性 | id | (继承自 base_model。)
公共属性 | mid | 用户ID
Top
参见

引用

fl_group_person 类
Api.Framework.Model 命名空间


fl_group_person.groupid 属性

fl_group_persongroupid 属性

群号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string groupid { get; set; }

属性值

类型：String
参见

引用

fl_group_person 类
Api.Framework.Model 命名空间


fl_group_person.groupname 属性

fl_group_persongroupname 属性

群名

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string groupname { get; set; }

属性值

类型：String
参见

引用

fl_group_person 类
Api.Framework.Model 命名空间


fl_group_person.mid 属性

fl_group_personmid 属性

用户ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long mid { get; set; }

属性值

类型：Int64
参见

引用

fl_group_person 类
Api.Framework.Model 命名空间


fl_group_person 方法

fl_group_person 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_group_person 类
Api.Framework.Model 命名空间


fl_member_group 类

会员分组表
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_member_group

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_member_group : base_model

fl_member_group 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_member_group | 初始化 fl_member_group 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | id | (继承自 base_model。)
公共属性 | name | 名称
公共属性 | subsidy | 补贴
公共属性 | subsidy_type | 补贴类型
公共属性 | terms | 条件 - 积分数
公共属性 | terms_ordersum | 条件 - 订单数
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLevel | 获取会员组等级
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SetLevel | 设置会员组等级
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_member_group 构造函数

初始化 fl_member_group 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_member_group()
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group 属性

fl_member_group 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | id | (继承自 base_model。)
公共属性 | name | 名称
公共属性 | subsidy | 补贴
公共属性 | subsidy_type | 补贴类型
公共属性 | terms | 条件 - 积分数
公共属性 | terms_ordersum | 条件 - 订单数
Top
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group.name 属性

fl_member_groupname 属性

名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string name { get; set; }

属性值

类型：String
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group.subsidy 属性

fl_member_groupsubsidy 属性

补贴

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double subsidy { get; set; }

属性值

类型：Double
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group.subsidy_type 属性

fl_member_groupsubsidy_type 属性

补贴类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
[TypeConverterAttribute(typeof(SubsidyType))]
public SubsidyType subsidy_type { get; set; }

属性值

类型：SubsidyType
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group.terms 属性

fl_member_groupterms 属性

条件 - 积分数

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double terms { get; set; }

属性值

类型：Double
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group.terms_ordersum 属性

fl_member_groupterms_ordersum 属性

条件 - 订单数

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long terms_ordersum { get; set; }

属性值

类型：Int64
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group 方法

fl_member_group 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLevel | 获取会员组等级
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SetLevel | 设置会员组等级
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group.GetLevel 方法

fl_member_groupGetLevel 方法

获取会员组等级

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int GetLevel()

返回值

类型：Int32
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group.SetLevel 方法

fl_member_groupSetLevel 方法

设置会员组等级

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SetLevel(
    int level
)

参数

level
类型：SystemInt32

[缺少 "M:Api.Framework.Model.fl_member_group.SetLevel(System.Int32)" 的 <param name="level"/> 文档]

参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_group.ToString 方法

fl_member_groupToString 方法

[缺少 "M:Api.Framework.Model.fl_member_group.ToString" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

fl_member_group 类
Api.Framework.Model 命名空间


fl_member_info 类

用户信息表
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_member_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_member_info : base_model

fl_member_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_member_info | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | alipay_name | 支付宝姓名
公共属性 | alipay_num | 支付宝账号
公共属性 | ban_exchange_time |
公共属性 | bind_order | 绑定订单数
公共属性 | blackout_time |
公共属性 | buy_point | 购物积分
公共属性 | chat_count |
公共属性 | check_cloud_black_time | 云黑名单上次检测时间
公共属性 | crt_time | 创建时间
公共属性 | cur_point | 当前积分
公共属性 | ext_point | 提成奖励
公共属性 | finish_order | 已完成订单
公共属性 | group_id | 分组ID
公共属性 | id | (继承自 base_model。)
公共属性 | identity_card | 身份证号码
公共属性 | identity_name | 身份证姓名
公共属性 | ignore_group_update | 无视分组升级
公共属性 | inviter_id | 邀请人ID
公共属性 | is_cloud_black | 是否为云黑名单人员
公共属性 | private_ratio | 私人返利比例
公共属性 | realnick | 真实昵称
公共属性 | remark | 备注信息
公共属性 | rew_point | 其他奖励
公共属性 | robot_name | 机器人名称
公共属性 | robot_type | 机器人类型
公共属性 | status | 用户状态
公共属性 | sum_point | 累计积分
公共属性 | upd_time | 最后更新时间
公共属性 | username | 用户名
公共属性 | usernick | 用户昵称
公共属性 | wechatid | 微信号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_member_info 构造函数

构造方法

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_member_info()
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info 属性

fl_member_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | alipay_name | 支付宝姓名
公共属性 | alipay_num | 支付宝账号
公共属性 | ban_exchange_time |
公共属性 | bind_order | 绑定订单数
公共属性 | blackout_time |
公共属性 | buy_point | 购物积分
公共属性 | chat_count |
公共属性 | check_cloud_black_time | 云黑名单上次检测时间
公共属性 | crt_time | 创建时间
公共属性 | cur_point | 当前积分
公共属性 | ext_point | 提成奖励
公共属性 | finish_order | 已完成订单
公共属性 | group_id | 分组ID
公共属性 | id | (继承自 base_model。)
公共属性 | identity_card | 身份证号码
公共属性 | identity_name | 身份证姓名
公共属性 | ignore_group_update | 无视分组升级
公共属性 | inviter_id | 邀请人ID
公共属性 | is_cloud_black | 是否为云黑名单人员
公共属性 | private_ratio | 私人返利比例
公共属性 | realnick | 真实昵称
公共属性 | remark | 备注信息
公共属性 | rew_point | 其他奖励
公共属性 | robot_name | 机器人名称
公共属性 | robot_type | 机器人类型
公共属性 | status | 用户状态
公共属性 | sum_point | 累计积分
公共属性 | upd_time | 最后更新时间
公共属性 | username | 用户名
公共属性 | usernick | 用户昵称
公共属性 | wechatid | 微信号
Top
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.alipay_name 属性

fl_member_infoalipay_name 属性

支付宝姓名

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string alipay_name { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.alipay_num 属性

fl_member_infoalipay_num 属性

支付宝账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string alipay_num { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.ban_exchange_time 属性

fl_member_infoban_exchange_time 属性

[缺少 "P:Api.Framework.Model.fl_member_info.ban_exchange_time" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime ban_exchange_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.bind_order 属性

fl_member_infobind_order 属性

绑定订单数

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long bind_order { get; set; }

属性值

类型：Int64
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.blackout_time 属性

fl_member_infoblackout_time 属性

[缺少 "P:Api.Framework.Model.fl_member_info.blackout_time" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime blackout_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.buy_point 属性

fl_member_infobuy_point 属性

购物积分

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double buy_point { get; set; }

属性值

类型：Double
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.chat_count 属性

fl_member_infochat_count 属性

[缺少 "P:Api.Framework.Model.fl_member_info.chat_count" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int chat_count { get; set; }

属性值

类型：Int32
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.check_cloud_black_time 属性

fl_member_infocheck_cloud_black_time 属性

云黑名单上次检测时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime check_cloud_black_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.crt_time 属性

fl_member_infocrt_time 属性

创建时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime crt_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.cur_point 属性

fl_member_infocur_point 属性

当前积分

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double cur_point { get; set; }

属性值

类型：Double
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.ext_point 属性

fl_member_infoext_point 属性

提成奖励

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double ext_point { get; set; }

属性值

类型：Double
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.finish_order 属性

fl_member_infofinish_order 属性

已完成订单

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long finish_order { get; set; }

属性值

类型：Int64
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.group_id 属性

fl_member_infogroup_id 属性

分组ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long group_id { get; set; }

属性值

类型：Int64
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.identity_card 属性

fl_member_infoidentity_card 属性

身份证号码

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string identity_card { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.identity_name 属性

fl_member_infoidentity_name 属性

身份证姓名

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string identity_name { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.ignore_group_update 属性

fl_member_infoignore_group_update 属性

无视分组升级

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType ignore_group_update { get; set; }

属性值

类型：SwitchType
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.inviter_id 属性

fl_member_infoinviter_id 属性

邀请人ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long inviter_id { get; set; }

属性值

类型：Int64
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.is_cloud_black 属性

fl_member_infois_cloud_black 属性

是否为云黑名单人员

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool is_cloud_black { get; set; }

属性值

类型：Boolean
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.private_ratio 属性

fl_member_infoprivate_ratio 属性

私人返利比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double private_ratio { get; set; }

属性值

类型：Double
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.realnick 属性

fl_member_inforealnick 属性

真实昵称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string realnick { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.remark 属性

fl_member_inforemark 属性

备注信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string remark { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.rew_point 属性

fl_member_inforew_point 属性

其他奖励

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double rew_point { get; set; }

属性值

类型：Double
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.robot_name 属性

fl_member_inforobot_name 属性

机器人名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string robot_name { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.robot_type 属性

fl_member_inforobot_type 属性

机器人类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChatType robot_type { get; set; }

属性值

类型：ChatType
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.status 属性

fl_member_infostatus 属性

用户状态

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public MemberType status { get; set; }

属性值

类型：MemberType
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.sum_point 属性

fl_member_infosum_point 属性

累计积分

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double sum_point { get; set; }

属性值

类型：Double
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.upd_time 属性

fl_member_infoupd_time 属性

最后更新时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime upd_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.username 属性

fl_member_infousername 属性

用户名

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string username { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.usernick 属性

fl_member_infousernick 属性

用户昵称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string usernick { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info.wechatid 属性

fl_member_infowechatid 属性

微信号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string wechatid { get; set; }

属性值

类型：String
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_info 方法

fl_member_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_member_info 类
Api.Framework.Model 命名空间


fl_member_level 类

分组
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_member_level

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_member_level : base_model

fl_member_level 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_member_level | 初始化 fl_member_level 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | id | (继承自 base_model。)
公共属性 | name | 分组名称
公共属性 | point | 所需积分
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_member_level 构造函数

初始化 fl_member_level 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_member_level()
参见

引用

fl_member_level 类
Api.Framework.Model 命名空间


fl_member_level 属性

fl_member_level 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | id | (继承自 base_model。)
公共属性 | name | 分组名称
公共属性 | point | 所需积分
Top
参见

引用

fl_member_level 类
Api.Framework.Model 命名空间


fl_member_level.name 属性

fl_member_levelname 属性

分组名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string name { get; set; }

属性值

类型：String
参见

引用

fl_member_level 类
Api.Framework.Model 命名空间


fl_member_level.point 属性

fl_member_levelpoint 属性

所需积分

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double point { get; set; }

属性值

类型：Double
参见

引用

fl_member_level 类
Api.Framework.Model 命名空间


fl_member_level 方法

fl_member_level 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_member_level 类
Api.Framework.Model 命名空间


fl_noticeapi_info 类

通知机器人信息
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_noticeapi_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_noticeapi_info : base_model

fl_noticeapi_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_noticeapi_info | 初始化 fl_noticeapi_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | api_location | API位置
公共属性 | id | (继承自 base_model。)
公共属性 | name | 名称
公共属性 | notice_apitype |
公共属性 | remark | 备注
公共属性 | token | Token等,验证字段
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_noticeapi_info 构造函数

初始化 fl_noticeapi_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_noticeapi_info()
参见

引用

fl_noticeapi_info 类
Api.Framework.Model 命名空间


fl_noticeapi_info 属性

fl_noticeapi_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | api_location | API位置
公共属性 | id | (继承自 base_model。)
公共属性 | name | 名称
公共属性 | notice_apitype |
公共属性 | remark | 备注
公共属性 | token | Token等,验证字段
Top
参见

引用

fl_noticeapi_info 类
Api.Framework.Model 命名空间


fl_noticeapi_info.api_location 属性

fl_noticeapi_infoapi_location 属性

API位置

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string api_location { get; set; }

属性值

类型：String
参见

引用

fl_noticeapi_info 类
Api.Framework.Model 命名空间


fl_noticeapi_info.name 属性

fl_noticeapi_infoname 属性

名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string name { get; set; }

属性值

类型：String
参见

引用

fl_noticeapi_info 类
Api.Framework.Model 命名空间


fl_noticeapi_info.notice_apitype 属性

fl_noticeapi_infonotice_apitype 属性

[缺少 "P:Api.Framework.Model.fl_noticeapi_info.notice_apitype" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public NoticeApiType notice_apitype { get; set; }

属性值

类型：NoticeApiType
参见

引用

fl_noticeapi_info 类
Api.Framework.Model 命名空间


fl_noticeapi_info.remark 属性

fl_noticeapi_inforemark 属性

备注

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string remark { get; set; }

属性值

类型：String
参见

引用

fl_noticeapi_info 类
Api.Framework.Model 命名空间


fl_noticeapi_info.token 属性

fl_noticeapi_infotoken 属性

Token等,验证字段

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string token { get; set; }

属性值

类型：String
参见

引用

fl_noticeapi_info 类
Api.Framework.Model 命名空间


fl_noticeapi_info 方法

fl_noticeapi_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_noticeapi_info 类
Api.Framework.Model 命名空间


fl_operation_log 类

操作日志
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_operation_log

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_operation_log : base_model

fl_operation_log 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_operation_log | 初始化 fl_operation_log 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | datetime | 修改日志
公共属性 | id | (继承自 base_model。)
公共属性 | new_text | 新数据
公共属性 | old_text | 旧数据
公共属性 | otype | 操作类型
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_operation_log 构造函数

初始化 fl_operation_log 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_operation_log()
参见

引用

fl_operation_log 类
Api.Framework.Model 命名空间


fl_operation_log 属性

fl_operation_log 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | datetime | 修改日志
公共属性 | id | (继承自 base_model。)
公共属性 | new_text | 新数据
公共属性 | old_text | 旧数据
公共属性 | otype | 操作类型
Top
参见

引用

fl_operation_log 类
Api.Framework.Model 命名空间


fl_operation_log.datetime 属性

fl_operation_logdatetime 属性

修改日志

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime datetime { get; set; }

属性值

类型：DateTime
参见

引用

fl_operation_log 类
Api.Framework.Model 命名空间


fl_operation_log.new_text 属性

fl_operation_lognew_text 属性

新数据

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string new_text { get; set; }

属性值

类型：String
参见

引用

fl_operation_log 类
Api.Framework.Model 命名空间


fl_operation_log.old_text 属性

fl_operation_logold_text 属性

旧数据

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string old_text { get; set; }

属性值

类型：String
参见

引用

fl_operation_log 类
Api.Framework.Model 命名空间


fl_operation_log.otype 属性

fl_operation_logotype 属性

操作类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OperationType otype { get; set; }

属性值

类型：OperationType
参见

引用

fl_operation_log 类
Api.Framework.Model 命名空间


fl_operation_log 方法

fl_operation_log 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_operation_log 类
Api.Framework.Model 命名空间


fl_order_alimama 类

阿里订单
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelbase_model_order
Api.Framework.Modelfl_order_alimama

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_order_alimama : base_model_order

fl_order_alimama 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_order_alimama | 初始化 fl_order_alimama 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | adzone_id | PID-第三段-ID
公共属性 | adzone_name | PID-第三段-名称
公共属性 | alimama_rate | 技术服务费比率
公共属性 | alimama_share_fee | 技术服务费金额
公共属性 | alipay_total_price | 付款金额
公共属性 | auction_category | 类目名称,(这个用来判断维权中订单手动结算状态 - 值:手动处理)
公共属性 | commission | 结算预估总佣金
公共属性 | commission_rate | 佣金比例
公共属性 | create_time | 创建时间
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | deposit_price | 预付款金额
公共属性 | earning_time | 结算时间
公共属性 | id | (继承自 base_model。)
公共属性 | income_rate | 补贴比例
公共属性 | item_num | 商品数量
公共属性 | item_title | 商品标题
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | num_iid | 商品ID
公共属性 | order_type | 订单类型 例如： 天猫、淘宝
公共属性 | paid_time | 付款时间
公共属性 | pay_price | 实际付款
公共属性 | price | 宝贝原价
公共属性 | pub_share_pre_fee | 预估佣金
公共属性 | relation_id | 渠道关系id
公共属性 | seller_id | 店铺ID
公共属性 | seller_nick | 店铺昵称
公共属性 | seller_shop_title | 店铺标题
公共属性 | site_id | PID-第二段
公共属性 | site_name | PID-第二段名称
公共属性 | special_id | 会员运营id
公共属性 | subsidy_fee | 补贴佣金
公共属性 | subsidy_rate | 补贴比例
公共属性 | subsidy_type | 补贴类型
公共属性 | tb_deposit_time | 预售时期，用户对预售商品支付定金的付款时间
公共属性 | terminal_type | 终端类型
公共属性 | tk_status | 订单状态
公共属性 | total_commission_fee | 佣金金额
公共属性 | total_commission_rate | 总共比例
公共属性 | trade_id | 子订单号
公共属性 | trade_parent_id | 父订单号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_order_alimama 构造函数

初始化 fl_order_alimama 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_order_alimama()
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama 属性

fl_order_alimama 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | adzone_id | PID-第三段-ID
公共属性 | adzone_name | PID-第三段-名称
公共属性 | alimama_rate | 技术服务费比率
公共属性 | alimama_share_fee | 技术服务费金额
公共属性 | alipay_total_price | 付款金额
公共属性 | auction_category | 类目名称,(这个用来判断维权中订单手动结算状态 - 值:手动处理)
公共属性 | commission | 结算预估总佣金
公共属性 | commission_rate | 佣金比例
公共属性 | create_time | 创建时间
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | deposit_price | 预付款金额
公共属性 | earning_time | 结算时间
公共属性 | id | (继承自 base_model。)
公共属性 | income_rate | 补贴比例
公共属性 | item_num | 商品数量
公共属性 | item_title | 商品标题
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | num_iid | 商品ID
公共属性 | order_type | 订单类型 例如： 天猫、淘宝
公共属性 | paid_time | 付款时间
公共属性 | pay_price | 实际付款
公共属性 | price | 宝贝原价
公共属性 | pub_share_pre_fee | 预估佣金
公共属性 | relation_id | 渠道关系id
公共属性 | seller_id | 店铺ID
公共属性 | seller_nick | 店铺昵称
公共属性 | seller_shop_title | 店铺标题
公共属性 | site_id | PID-第二段
公共属性 | site_name | PID-第二段名称
公共属性 | special_id | 会员运营id
公共属性 | subsidy_fee | 补贴佣金
公共属性 | subsidy_rate | 补贴比例
公共属性 | subsidy_type | 补贴类型
公共属性 | tb_deposit_time | 预售时期，用户对预售商品支付定金的付款时间
公共属性 | terminal_type | 终端类型
公共属性 | tk_status | 订单状态
公共属性 | total_commission_fee | 佣金金额
公共属性 | total_commission_rate | 总共比例
公共属性 | trade_id | 子订单号
公共属性 | trade_parent_id | 父订单号
Top
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.adzone_id 属性

fl_order_alimamaadzone_id 属性

PID-第三段-ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzone_id { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.adzone_name 属性

fl_order_alimamaadzone_name 属性

PID-第三段-名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzone_name { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.alimama_rate 属性

fl_order_alimamaalimama_rate 属性

技术服务费比率

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double alimama_rate { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.alimama_share_fee 属性

fl_order_alimamaalimama_share_fee 属性

技术服务费金额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double alimama_share_fee { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.alipay_total_price 属性

fl_order_alimamaalipay_total_price 属性

付款金额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double alipay_total_price { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.auction_category 属性

fl_order_alimamaauction_category 属性

类目名称,(这个用来判断维权中订单手动结算状态 - 值:手动处理)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string auction_category { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.commission 属性

fl_order_alimamacommission 属性

结算预估总佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double commission { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.commission_rate 属性

fl_order_alimamacommission_rate 属性

佣金比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double commission_rate { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.create_time 属性

fl_order_alimamacreate_time 属性

创建时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime create_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.deposit_price 属性

fl_order_alimamadeposit_price 属性

预付款金额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string deposit_price { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.earning_time 属性

fl_order_alimamaearning_time 属性

结算时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime earning_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.income_rate 属性

fl_order_alimamaincome_rate 属性

补贴比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double income_rate { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.item_num 属性

fl_order_alimamaitem_num 属性

商品数量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int item_num { get; set; }

属性值

类型：Int32
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.item_title 属性

fl_order_alimamaitem_title 属性

商品标题

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string item_title { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.num_iid 属性

fl_order_alimamanum_iid 属性

商品ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string num_iid { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.order_type 属性

fl_order_alimamaorder_type 属性

订单类型 例如： 天猫、淘宝

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_type { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.paid_time 属性

fl_order_alimamapaid_time 属性

付款时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime paid_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.pay_price 属性

fl_order_alimamapay_price 属性

实际付款

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double pay_price { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.price 属性

fl_order_alimamaprice 属性

宝贝原价

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double price { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.pub_share_pre_fee 属性

fl_order_alimamapub_share_pre_fee 属性

预估佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double pub_share_pre_fee { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.relation_id 属性

fl_order_alimamarelation_id 属性

渠道关系id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long relation_id { get; set; }

属性值

类型：Int64
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.seller_id 属性

fl_order_alimamaseller_id 属性

店铺ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string seller_id { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.seller_nick 属性

fl_order_alimamaseller_nick 属性

店铺昵称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string seller_nick { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.seller_shop_title 属性

fl_order_alimamaseller_shop_title 属性

店铺标题

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string seller_shop_title { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.site_id 属性

fl_order_alimamasite_id 属性

PID-第二段

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string site_id { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.site_name 属性

fl_order_alimamasite_name 属性

PID-第二段名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string site_name { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.special_id 属性

fl_order_alimamaspecial_id 属性

会员运营id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long special_id { get; set; }

属性值

类型：Int64
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.subsidy_fee 属性

fl_order_alimamasubsidy_fee 属性

补贴佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double subsidy_fee { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.subsidy_rate 属性

fl_order_alimamasubsidy_rate 属性

补贴比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double subsidy_rate { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.subsidy_type 属性

fl_order_alimamasubsidy_type 属性

补贴类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int subsidy_type { get; set; }

属性值

类型：Int32
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.tb_deposit_time 属性

fl_order_alimamatb_deposit_time 属性

预售时期，用户对预售商品支付定金的付款时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string tb_deposit_time { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.terminal_type 属性

fl_order_alimamaterminal_type 属性

终端类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int terminal_type { get; set; }

属性值

类型：Int32
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.tk_status 属性

fl_order_alimamatk_status 属性

订单状态

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int tk_status { get; set; }

属性值

类型：Int32
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.total_commission_fee 属性

fl_order_alimamatotal_commission_fee 属性

佣金金额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double total_commission_fee { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.total_commission_rate 属性

fl_order_alimamatotal_commission_rate 属性

总共比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double total_commission_rate { get; set; }

属性值

类型：Double
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.trade_id 属性

fl_order_alimamatrade_id 属性

子订单号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string trade_id { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama.trade_parent_id 属性

fl_order_alimamatrade_parent_id 属性

父订单号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string trade_parent_id { get; set; }

属性值

类型：String
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_alimama 方法

fl_order_alimama 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_order_alimama 类
Api.Framework.Model 命名空间


fl_order_douyin 类

抖音订单
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelbase_model_order
Api.Framework.Modelfl_order_douyin

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_order_douyin : base_model_order

fl_order_douyin 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_order_douyin | 初始化 fl_order_douyin 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | account_type | 账户类型(值:正式账户)
公共属性 | commission_rate | 佣金率
公共属性 | confirm_time | 确定收货时间(已付款时值为1)
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | estimated_comission | 预估佣金（已经扣除了技术费）
公共属性 | estimated_inst_comission | 预计本月佣金
公共属性 | estimated_user_comission | 估计用户佣金
公共属性 | id | (继承自 base_model。)
公共属性 | is_haitao | 是否为海淘
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | order_id | 订单号
公共属性 | order_status | 订单的状态 “PAY_SUCC”
公共属性 | pay_time | 付款时间
公共属性 | platform_service_fee | 平台服务费(百分之10)
公共属性 | product_detail | 商品详情页
公共属性 | product_id | 商品id
公共属性 | product_name | 商品标题
公共属性 | promotion_source | 推销来源(推销类型)
公共属性 | real_comission | 实际佣金 (应该是结算有才有值,已付款为0)
公共属性 | settle_inst_comission | 本月结算佣金
公共属性 | settle_time | 建立时间?(已付款时值为1)
公共属性 | settle_user_comission | 确定的用户佣金
公共属性 | stage_one_pay_money | 第一阶段支付付款
公共属性 | stage_one_pay_time | 第一阶段支付时间
公共属性 | stage_order | 阶段顺序
公共属性 | stage_two_pay_time | 第二阶段支付时间
公共属性 | total_commission | 全部佣金
公共属性 | total_pay_amount | 支付金额
公共属性 | user_name | 用户名称
公共属性 | user_profit_ratio | 用户利润比例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_order_douyin 构造函数

初始化 fl_order_douyin 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_order_douyin()
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin 属性

fl_order_douyin 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | account_type | 账户类型(值:正式账户)
公共属性 | commission_rate | 佣金率
公共属性 | confirm_time | 确定收货时间(已付款时值为1)
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | estimated_comission | 预估佣金（已经扣除了技术费）
公共属性 | estimated_inst_comission | 预计本月佣金
公共属性 | estimated_user_comission | 估计用户佣金
公共属性 | id | (继承自 base_model。)
公共属性 | is_haitao | 是否为海淘
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | order_id | 订单号
公共属性 | order_status | 订单的状态 “PAY_SUCC”
公共属性 | pay_time | 付款时间
公共属性 | platform_service_fee | 平台服务费(百分之10)
公共属性 | product_detail | 商品详情页
公共属性 | product_id | 商品id
公共属性 | product_name | 商品标题
公共属性 | promotion_source | 推销来源(推销类型)
公共属性 | real_comission | 实际佣金 (应该是结算有才有值,已付款为0)
公共属性 | settle_inst_comission | 本月结算佣金
公共属性 | settle_time | 建立时间?(已付款时值为1)
公共属性 | settle_user_comission | 确定的用户佣金
公共属性 | stage_one_pay_money | 第一阶段支付付款
公共属性 | stage_one_pay_time | 第一阶段支付时间
公共属性 | stage_order | 阶段顺序
公共属性 | stage_two_pay_time | 第二阶段支付时间
公共属性 | total_commission | 全部佣金
公共属性 | total_pay_amount | 支付金额
公共属性 | user_name | 用户名称
公共属性 | user_profit_ratio | 用户利润比例
Top
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.account_type 属性

fl_order_douyinaccount_type 属性

账户类型(值:正式账户)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string account_type { get; set; }

属性值

类型：String
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.commission_rate 属性

fl_order_douyincommission_rate 属性

佣金率

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int commission_rate { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.confirm_time 属性

fl_order_douyinconfirm_time 属性

确定收货时间(已付款时值为1)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int confirm_time { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.estimated_comission 属性

fl_order_douyinestimated_comission 属性

预估佣金（已经扣除了技术费）

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int estimated_comission { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.estimated_inst_comission 属性

fl_order_douyinestimated_inst_comission 属性

预计本月佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int estimated_inst_comission { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.estimated_user_comission 属性

fl_order_douyinestimated_user_comission 属性

估计用户佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int estimated_user_comission { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.is_haitao 属性

fl_order_douyinis_haitao 属性

是否为海淘

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool is_haitao { get; set; }

属性值

类型：Boolean
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.order_id 属性

fl_order_douyinorder_id 属性

订单号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_id { get; set; }

属性值

类型：String
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.order_status 属性

fl_order_douyinorder_status 属性

订单的状态 “PAY_SUCC”

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_status { get; set; }

属性值

类型：String
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.pay_time 属性

fl_order_douyinpay_time 属性

付款时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int pay_time { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.platform_service_fee 属性

fl_order_douyinplatform_service_fee 属性

平台服务费(百分之10)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int platform_service_fee { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.product_detail 属性

fl_order_douyinproduct_detail 属性

商品详情页

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string product_detail { get; set; }

属性值

类型：String
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.product_id 属性

fl_order_douyinproduct_id 属性

商品id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string product_id { get; set; }

属性值

类型：String
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.product_name 属性

fl_order_douyinproduct_name 属性

商品标题

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string product_name { get; set; }

属性值

类型：String
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.promotion_source 属性

fl_order_douyinpromotion_source 属性

推销来源(推销类型)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int promotion_source { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.real_comission 属性

fl_order_douyinreal_comission 属性

实际佣金 (应该是结算有才有值,已付款为0)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int real_comission { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.settle_inst_comission 属性

fl_order_douyinsettle_inst_comission 属性

本月结算佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int settle_inst_comission { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.settle_time 属性

fl_order_douyinsettle_time 属性

建立时间?(已付款时值为1)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int settle_time { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.settle_user_comission 属性

fl_order_douyinsettle_user_comission 属性

确定的用户佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int settle_user_comission { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.stage_one_pay_money 属性

fl_order_douyinstage_one_pay_money 属性

第一阶段支付付款

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int stage_one_pay_money { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.stage_one_pay_time 属性

fl_order_douyinstage_one_pay_time 属性

第一阶段支付时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string stage_one_pay_time { get; set; }

属性值

类型：String
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.stage_order 属性

fl_order_douyinstage_order 属性

阶段顺序

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool stage_order { get; set; }

属性值

类型：Boolean
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.stage_two_pay_time 属性

fl_order_douyinstage_two_pay_time 属性

第二阶段支付时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string stage_two_pay_time { get; set; }

属性值

类型：String
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.total_commission 属性

fl_order_douyintotal_commission 属性

全部佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int total_commission { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.total_pay_amount 属性

fl_order_douyintotal_pay_amount 属性

支付金额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int total_pay_amount { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.user_name 属性

fl_order_douyinuser_name 属性

用户名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string user_name { get; set; }

属性值

类型：String
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin.user_profit_ratio 属性

fl_order_douyinuser_profit_ratio 属性

用户利润比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int user_profit_ratio { get; set; }

属性值

类型：Int32
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_douyin 方法

fl_order_douyin 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_order_douyin 类
Api.Framework.Model 命名空间


fl_order_jingdong 类

京东订单
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelbase_model_order
Api.Framework.Modelfl_order_jingdong

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_order_jingdong : base_model_order

fl_order_jingdong 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_order_jingdong | 初始化 fl_order_jingdong 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | actualCosPrice | 实际计算佣金的金额。订单完成后，会将误扣除的运费券金额更正。如订单完成后发生退款，此金额会更新。
公共属性 | actualFee | (商品总佣金)推客获得的实际佣金（实际计佣金额*佣金比例*最终比例）。如订单完成后发生退款，此金额会更新。
公共属性 | cid1 |
公共属性 | cid2 |
公共属性 | cid3 |
公共属性 | commissionRate | 佣金比例
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | estimateCosPrice | 预估计佣金额，即用户下单的金额(已扣除优惠券、白条、支付优惠、进口税，未扣除红包和京豆)，有时会误扣除运费券金额，完成结算时会在实际计佣金额中更正。如订单完成前发生退款，此金额也会更新。
公共属性 | estimateFee | 推客的预估佣金（预估计佣金额*佣金比例*最终比例），如订单完成前发生退款，此金额也会更新。
公共属性 | ext1 | 推客生成推广链接时传入的扩展字段（需要联系运营开放白名单才能拿到数据）。(订单行维度);
公共属性 | finalRate | 最终比例（分成比例+补贴比例）
公共属性 | finishTime | 完成时间
公共属性 | frozenSkuNum | 商品售后中数量
公共属性 | id | (继承自 base_model。)
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | orderId | 订单号
公共属性 | orderTime | 下单时间
公共属性 | payMonth | 京东结算时间（格式：yyyyMMdd），0：未结算
公共属性 | pid | 联盟子站长身份标识，格式：子站长ID_子站长网站ID_子站长推广位ID
公共属性 | plus | 是否是会员
公共属性 | popId | 商家ID。(订单行维度);
公共属性 | positionId | 推广位ID,0代表无推广位
公共属性 | price | 商品单价
公共属性 | proPriceAmount | 价保赔付金额,非为0时,给客户结算的金额为0
公共属性 | refundcreatetime | 维权时间
公共属性 | siteId | 应用id（网站id、appid、社交媒体id）
公共属性 | skuId | 商品ID
公共属性 | skuName | 商品名称
公共属性 | skuNum | 商品数量
公共属性 | skuReturnNum | 商品已退货数量
公共属性 | subSideRate | 分成比例
公共属性 | subsidyRate | 补贴比例
公共属性 | subUnionId | 子联盟ID(需要联系运营开放白名单才能拿到数据)
公共属性 | traceType | 2：同店；3：跨店
公共属性 | unionAlias | PID所属母账号平台名称（原第三方服务商来源）
公共属性 | unionTag | 联盟标签数据（整型的二进制字符串(32位)，目前只返回8位：00000001。数据从右向左进行，每一位为1表示符合联盟的标签特征，第1位：优惠券，第2位：组合推广订单，第3位：拼购订单，第5位：有效首次购订单（00011XXX表示有效首购，最终奖励活动结算金额会结合订单状态判断，以联盟后台对应活动效果数据报表https://union.jd.com/active为准）。例如：00000001:优惠券，00000010:组合推广订单，00000100:拼购订单，00011000:有效首购，00000111：优惠券+组合推广+拼购等）
公共属性 | unionTrafficGroup | 渠道组 1：1号店，其他：京东
公共属性 | validCode | sku维度的有效码（-1：未知,2.无效-拆单,3.无效-取消,4.无效-京东帮帮主订单,5.无效-账号异常,6.无效-赠品类目不返佣,7.无效-校园订单,8.无效-企业订单,9.无效-团购订单,10.无效-开增值税专用发票订单,11.无效-乡村推广员下单,12.无效-自己推广自己下单,13.无效-违规订单,14.无效-来源与备案网址不符,15.待付款,16.已付款,17.已完成,18.已结算）注：自2018/7/13起，自己推广自己下单已经允许返佣，故12无效码仅针对历史数据有效
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_order_jingdong 构造函数

初始化 fl_order_jingdong 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_order_jingdong()
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong 属性

fl_order_jingdong 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | actualCosPrice | 实际计算佣金的金额。订单完成后，会将误扣除的运费券金额更正。如订单完成后发生退款，此金额会更新。
公共属性 | actualFee | (商品总佣金)推客获得的实际佣金（实际计佣金额*佣金比例*最终比例）。如订单完成后发生退款，此金额会更新。
公共属性 | cid1 |
公共属性 | cid2 |
公共属性 | cid3 |
公共属性 | commissionRate | 佣金比例
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | estimateCosPrice | 预估计佣金额，即用户下单的金额(已扣除优惠券、白条、支付优惠、进口税，未扣除红包和京豆)，有时会误扣除运费券金额，完成结算时会在实际计佣金额中更正。如订单完成前发生退款，此金额也会更新。
公共属性 | estimateFee | 推客的预估佣金（预估计佣金额*佣金比例*最终比例），如订单完成前发生退款，此金额也会更新。
公共属性 | ext1 | 推客生成推广链接时传入的扩展字段（需要联系运营开放白名单才能拿到数据）。(订单行维度);
公共属性 | finalRate | 最终比例（分成比例+补贴比例）
公共属性 | finishTime | 完成时间
公共属性 | frozenSkuNum | 商品售后中数量
公共属性 | id | (继承自 base_model。)
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | orderId | 订单号
公共属性 | orderTime | 下单时间
公共属性 | payMonth | 京东结算时间（格式：yyyyMMdd），0：未结算
公共属性 | pid | 联盟子站长身份标识，格式：子站长ID_子站长网站ID_子站长推广位ID
公共属性 | plus | 是否是会员
公共属性 | popId | 商家ID。(订单行维度);
公共属性 | positionId | 推广位ID,0代表无推广位
公共属性 | price | 商品单价
公共属性 | proPriceAmount | 价保赔付金额,非为0时,给客户结算的金额为0
公共属性 | refundcreatetime | 维权时间
公共属性 | siteId | 应用id（网站id、appid、社交媒体id）
公共属性 | skuId | 商品ID
公共属性 | skuName | 商品名称
公共属性 | skuNum | 商品数量
公共属性 | skuReturnNum | 商品已退货数量
公共属性 | subSideRate | 分成比例
公共属性 | subsidyRate | 补贴比例
公共属性 | subUnionId | 子联盟ID(需要联系运营开放白名单才能拿到数据)
公共属性 | traceType | 2：同店；3：跨店
公共属性 | unionAlias | PID所属母账号平台名称（原第三方服务商来源）
公共属性 | unionTag | 联盟标签数据（整型的二进制字符串(32位)，目前只返回8位：00000001。数据从右向左进行，每一位为1表示符合联盟的标签特征，第1位：优惠券，第2位：组合推广订单，第3位：拼购订单，第5位：有效首次购订单（00011XXX表示有效首购，最终奖励活动结算金额会结合订单状态判断，以联盟后台对应活动效果数据报表https://union.jd.com/active为准）。例如：00000001:优惠券，00000010:组合推广订单，00000100:拼购订单，00011000:有效首购，00000111：优惠券+组合推广+拼购等）
公共属性 | unionTrafficGroup | 渠道组 1：1号店，其他：京东
公共属性 | validCode | sku维度的有效码（-1：未知,2.无效-拆单,3.无效-取消,4.无效-京东帮帮主订单,5.无效-账号异常,6.无效-赠品类目不返佣,7.无效-校园订单,8.无效-企业订单,9.无效-团购订单,10.无效-开增值税专用发票订单,11.无效-乡村推广员下单,12.无效-自己推广自己下单,13.无效-违规订单,14.无效-来源与备案网址不符,15.待付款,16.已付款,17.已完成,18.已结算）注：自2018/7/13起，自己推广自己下单已经允许返佣，故12无效码仅针对历史数据有效
Top
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.actualCosPrice 属性

fl_order_jingdongactualCosPrice 属性

实际计算佣金的金额。订单完成后，会将误扣除的运费券金额更正。如订单完成后发生退款，此金额会更新。

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double actualCosPrice { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.actualFee 属性

fl_order_jingdongactualFee 属性

(商品总佣金)推客获得的实际佣金（实际计佣金额*佣金比例*最终比例）。如订单完成后发生退款，此金额会更新。

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double actualFee { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.cid1 属性

fl_order_jingdongcid1 属性

[缺少 "P:Api.Framework.Model.fl_order_jingdong.cid1" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long cid1 { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.cid2 属性

fl_order_jingdongcid2 属性

[缺少 "P:Api.Framework.Model.fl_order_jingdong.cid2" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long cid2 { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.cid3 属性

fl_order_jingdongcid3 属性

[缺少 "P:Api.Framework.Model.fl_order_jingdong.cid3" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long cid3 { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.commissionRate 属性

fl_order_jingdongcommissionRate 属性

佣金比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double commissionRate { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.estimateCosPrice 属性

fl_order_jingdongestimateCosPrice 属性

预估计佣金额，即用户下单的金额(已扣除优惠券、白条、支付优惠、进口税，未扣除红包和京豆)，有时会误扣除运费券金额，完成结算时会在实际计佣金额中更正。如订单完成前发生退款，此金额也会更新。

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double estimateCosPrice { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.estimateFee 属性

fl_order_jingdongestimateFee 属性

推客的预估佣金（预估计佣金额*佣金比例*最终比例），如订单完成前发生退款，此金额也会更新。

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double estimateFee { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.ext1 属性

fl_order_jingdongext1 属性

推客生成推广链接时传入的扩展字段（需要联系运营开放白名单才能拿到数据）。(订单行维度);

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ext1 { get; set; }

属性值

类型：String
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.finalRate 属性

fl_order_jingdongfinalRate 属性

最终比例（分成比例+补贴比例）

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double finalRate { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.finishTime 属性

fl_order_jingdongfinishTime 属性

完成时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime finishTime { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.frozenSkuNum 属性

fl_order_jingdongfrozenSkuNum 属性

商品售后中数量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long frozenSkuNum { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.orderId 属性

fl_order_jingdongorderId 属性

订单号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long orderId { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.orderTime 属性

fl_order_jingdongorderTime 属性

下单时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime orderTime { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.payMonth 属性

fl_order_jingdongpayMonth 属性

京东结算时间（格式：yyyyMMdd），0：未结算

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string payMonth { get; set; }

属性值

类型：String
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.pid 属性

fl_order_jingdongpid 属性

联盟子站长身份标识，格式：子站长ID_子站长网站ID_子站长推广位ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pid { get; set; }

属性值

类型：String
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.plus 属性

fl_order_jingdongplus 属性

是否是会员

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int plus { get; set; }

属性值

类型：Int32
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.popId 属性

fl_order_jingdongpopId 属性

商家ID。(订单行维度);

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long popId { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.positionId 属性

fl_order_jingdongpositionId 属性

推广位ID,0代表无推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long positionId { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.price 属性

fl_order_jingdongprice 属性

商品单价

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double price { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.proPriceAmount 属性

fl_order_jingdongproPriceAmount 属性

价保赔付金额,非为0时,给客户结算的金额为0

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double proPriceAmount { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.refundcreatetime 属性

fl_order_jingdongrefundcreatetime 属性

维权时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime refundcreatetime { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.siteId 属性

fl_order_jingdongsiteId 属性

应用id（网站id、appid、社交媒体id）

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long siteId { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.skuId 属性

fl_order_jingdongskuId 属性

商品ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long skuId { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.skuName 属性

fl_order_jingdongskuName 属性

商品名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string skuName { get; set; }

属性值

类型：String
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.skuNum 属性

fl_order_jingdongskuNum 属性

商品数量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long skuNum { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.skuReturnNum 属性

fl_order_jingdongskuReturnNum 属性

商品已退货数量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long skuReturnNum { get; set; }

属性值

类型：Int64
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.subSideRate 属性

fl_order_jingdongsubSideRate 属性

分成比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double subSideRate { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.subsidyRate 属性

fl_order_jingdongsubsidyRate 属性

补贴比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double subsidyRate { get; set; }

属性值

类型：Double
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.subUnionId 属性

fl_order_jingdongsubUnionId 属性

子联盟ID(需要联系运营开放白名单才能拿到数据)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string subUnionId { get; set; }

属性值

类型：String
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.traceType 属性

fl_order_jingdongtraceType 属性

2：同店；3：跨店

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int traceType { get; set; }

属性值

类型：Int32
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.unionAlias 属性

fl_order_jingdongunionAlias 属性

PID所属母账号平台名称（原第三方服务商来源）

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string unionAlias { get; set; }

属性值

类型：String
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.unionTag 属性

fl_order_jingdongunionTag 属性

联盟标签数据（整型的二进制字符串(32位)，目前只返回8位：00000001。数据从右向左进行，每一位为1表示符合联盟的标签特征，第1位：优惠券，第2位：组合推广订单，第3位：拼购订单，第5位：有效首次购订单（00011XXX表示有效首购，最终奖励活动结算金额会结合订单状态判断，以联盟后台对应活动效果数据报表https://union.jd.com/active为准）。例如：00000001:优惠券，00000010:组合推广订单，00000100:拼购订单，00011000:有效首购，00000111：优惠券+组合推广+拼购等）

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string unionTag { get; set; }

属性值

类型：String
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.unionTrafficGroup 属性

fl_order_jingdongunionTrafficGroup 属性

渠道组 1：1号店，其他：京东

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int unionTrafficGroup { get; set; }

属性值

类型：Int32
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong.validCode 属性

fl_order_jingdongvalidCode 属性

sku维度的有效码（-1：未知,2.无效-拆单,3.无效-取消,4.无效-京东帮帮主订单,5.无效-账号异常,6.无效-赠品类目不返佣,7.无效-校园订单,8.无效-企业订单,9.无效-团购订单,10.无效-开增值税专用发票订单,11.无效-乡村推广员下单,12.无效-自己推广自己下单,13.无效-违规订单,14.无效-来源与备案网址不符,15.待付款,16.已付款,17.已完成,18.已结算）注：自2018/7/13起，自己推广自己下单已经允许返佣，故12无效码仅针对历史数据有效

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int validCode { get; set; }

属性值

类型：Int32
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_jingdong 方法

fl_order_jingdong 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_order_jingdong 类
Api.Framework.Model 命名空间


fl_order_pinduoduo 类

拼多多订单
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelbase_model_order
Api.Framework.Modelfl_order_pinduoduo

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_order_pinduoduo : base_model_order

fl_order_pinduoduo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_order_pinduoduo | 初始化 fl_order_pinduoduo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | custom_parameters | 自定义参数
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | goods_id | 商品id
公共属性 | goods_name | 商品名称
公共属性 | goods_price | 订单单价
公共属性 | goods_quantity | 订单数量
公共属性 | goods_thumbnail_url | 缩率图
公共属性 | id | (继承自 base_model。)
公共属性 | mall_id | 店铺ID
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | order_amount | 支付金额
公共属性 | order_create_time | 订单生成时间
公共属性 | order_group_success_time | 成团时间
公共属性 | order_modify_at | 最后更新时间
公共属性 | order_pay_time | 支付时间
公共属性 | order_receive_time | 拼多多结算时间
公共属性 | order_sn | 订单号
公共属性 | order_status | 订单状态
公共属性 | order_status_desc | 状态描述
公共属性 | order_verify_time | 审核时间
公共属性 | p_id | 推广位ID
公共属性 | price_compare_status | 0非比价,1比价
公共属性 | promotion_amount | 佣金金额
公共属性 | promotion_rate | 佣金比例
公共属性 | type | 订单类型
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_order_pinduoduo 构造函数

初始化 fl_order_pinduoduo 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_order_pinduoduo()
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo 属性

fl_order_pinduoduo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | custom_parameters | 自定义参数
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | goods_id | 商品id
公共属性 | goods_name | 商品名称
公共属性 | goods_price | 订单单价
公共属性 | goods_quantity | 订单数量
公共属性 | goods_thumbnail_url | 缩率图
公共属性 | id | (继承自 base_model。)
公共属性 | mall_id | 店铺ID
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | order_amount | 支付金额
公共属性 | order_create_time | 订单生成时间
公共属性 | order_group_success_time | 成团时间
公共属性 | order_modify_at | 最后更新时间
公共属性 | order_pay_time | 支付时间
公共属性 | order_receive_time | 拼多多结算时间
公共属性 | order_sn | 订单号
公共属性 | order_status | 订单状态
公共属性 | order_status_desc | 状态描述
公共属性 | order_verify_time | 审核时间
公共属性 | p_id | 推广位ID
公共属性 | price_compare_status | 0非比价,1比价
公共属性 | promotion_amount | 佣金金额
公共属性 | promotion_rate | 佣金比例
公共属性 | type | 订单类型
Top
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.custom_parameters 属性

fl_order_pinduoduocustom_parameters 属性

自定义参数

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string custom_parameters { get; set; }

属性值

类型：String
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.goods_id 属性

fl_order_pinduoduogoods_id 属性

商品id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goods_id { get; set; }

属性值

类型：String
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.goods_name 属性

fl_order_pinduoduogoods_name 属性

商品名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goods_name { get; set; }

属性值

类型：String
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.goods_price 属性

fl_order_pinduoduogoods_price 属性

订单单价

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double goods_price { get; set; }

属性值

类型：Double
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.goods_quantity 属性

fl_order_pinduoduogoods_quantity 属性

订单数量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int goods_quantity { get; set; }

属性值

类型：Int32
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.goods_thumbnail_url 属性

fl_order_pinduoduogoods_thumbnail_url 属性

缩率图

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goods_thumbnail_url { get; set; }

属性值

类型：String
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.mall_id 属性

fl_order_pinduoduomall_id 属性

店铺ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string mall_id { get; set; }

属性值

类型：String
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_amount 属性

fl_order_pinduoduoorder_amount 属性

支付金额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double order_amount { get; set; }

属性值

类型：Double
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_create_time 属性

fl_order_pinduoduoorder_create_time 属性

订单生成时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime order_create_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_group_success_time 属性

fl_order_pinduoduoorder_group_success_time 属性

成团时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime order_group_success_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_modify_at 属性

fl_order_pinduoduoorder_modify_at 属性

最后更新时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime order_modify_at { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_pay_time 属性

fl_order_pinduoduoorder_pay_time 属性

支付时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime order_pay_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_receive_time 属性

fl_order_pinduoduoorder_receive_time 属性

拼多多结算时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime order_receive_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_sn 属性

fl_order_pinduoduoorder_sn 属性

订单号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_sn { get; set; }

属性值

类型：String
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_status 属性

fl_order_pinduoduoorder_status 属性

订单状态

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int order_status { get; set; }

属性值

类型：Int32
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_status_desc 属性

fl_order_pinduoduoorder_status_desc 属性

状态描述

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_status_desc { get; set; }

属性值

类型：String
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.order_verify_time 属性

fl_order_pinduoduoorder_verify_time 属性

审核时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime order_verify_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.p_id 属性

fl_order_pinduoduop_id 属性

推广位ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string p_id { get; set; }

属性值

类型：String
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.price_compare_status 属性

fl_order_pinduoduoprice_compare_status 属性

0非比价,1比价

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PinduoduoBiJiaType price_compare_status { get; set; }

属性值

类型：PinduoduoBiJiaType
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.promotion_amount 属性

fl_order_pinduoduopromotion_amount 属性

佣金金额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double promotion_amount { get; set; }

属性值

类型：Double
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.promotion_rate 属性

fl_order_pinduoduopromotion_rate 属性

佣金比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int promotion_rate { get; set; }

属性值

类型：Int32
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo.type 属性

fl_order_pinduoduotype 属性

订单类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int type { get; set; }

属性值

类型：Int32
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_pinduoduo 方法

fl_order_pinduoduo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_order_pinduoduo 类
Api.Framework.Model 命名空间


fl_order_refund_alimama 类

阿里订单维权
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_order_refund_alimama

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_order_refund_alimama : base_model

fl_order_refund_alimama 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_order_refund_alimama | 初始化 fl_order_refund_alimama 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | earningtime | 订单结算时间
公共属性 | id | (继承自 base_model。)
公共属性 | inviteraccountname | 邀请人帐户名称
公共属性 | inviterid | 邀请者id
公共属性 | refundcreatetime | 退款创建时间
公共属性 | refundfee | 退款手续费
公共属性 | refundfinishtime | 退款完成时间
公共属性 | refundservicefee | 退还服务费用
公共属性 | relationapp | 关系app
公共属性 | relationappname | 关系app名称
公共属性 | relationid | 关系id
公共属性 | showrefundreason | 显示退款原因
公共属性 | showrefundstatus | 维权状态
公共属性 | showreturnfee | 显示返回的费用
公共属性 | tbauctionnum | tbauctionnum
公共属性 | tbauctiontitle | 订单标题
公共属性 | tbsellershoptitle | 淘宝卖家商店标题
公共属性 | tbtradefinishprice | TB贸易成品价格
公共属性 | tbtradeid | 淘宝交易id
公共属性 | tbtradeparentid | 父订单号
公共属性 | tkcommissionfee | 手续费
公共属性 | tksubsidyfee | 补贴费用
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_order_refund_alimama 构造函数

初始化 fl_order_refund_alimama 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_order_refund_alimama()
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama 属性

fl_order_refund_alimama 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | earningtime | 订单结算时间
公共属性 | id | (继承自 base_model。)
公共属性 | inviteraccountname | 邀请人帐户名称
公共属性 | inviterid | 邀请者id
公共属性 | refundcreatetime | 退款创建时间
公共属性 | refundfee | 退款手续费
公共属性 | refundfinishtime | 退款完成时间
公共属性 | refundservicefee | 退还服务费用
公共属性 | relationapp | 关系app
公共属性 | relationappname | 关系app名称
公共属性 | relationid | 关系id
公共属性 | showrefundreason | 显示退款原因
公共属性 | showrefundstatus | 维权状态
公共属性 | showreturnfee | 显示返回的费用
公共属性 | tbauctionnum | tbauctionnum
公共属性 | tbauctiontitle | 订单标题
公共属性 | tbsellershoptitle | 淘宝卖家商店标题
公共属性 | tbtradefinishprice | TB贸易成品价格
公共属性 | tbtradeid | 淘宝交易id
公共属性 | tbtradeparentid | 父订单号
公共属性 | tkcommissionfee | 手续费
公共属性 | tksubsidyfee | 补贴费用
Top
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.earningtime 属性

fl_order_refund_alimamaearningtime 属性

订单结算时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string earningtime { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.inviteraccountname 属性

fl_order_refund_alimamainviteraccountname 属性

邀请人帐户名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string inviteraccountname { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.inviterid 属性

fl_order_refund_alimamainviterid 属性

邀请者id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string inviterid { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.refundcreatetime 属性

fl_order_refund_alimamarefundcreatetime 属性

退款创建时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string refundcreatetime { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.refundfee 属性

fl_order_refund_alimamarefundfee 属性

退款手续费

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double refundfee { get; set; }

属性值

类型：Double
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.refundfinishtime 属性

fl_order_refund_alimamarefundfinishtime 属性

退款完成时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string refundfinishtime { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.refundservicefee 属性

fl_order_refund_alimamarefundservicefee 属性

退还服务费用

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double refundservicefee { get; set; }

属性值

类型：Double
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.relationapp 属性

fl_order_refund_alimamarelationapp 属性

关系app

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string relationapp { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.relationappname 属性

fl_order_refund_alimamarelationappname 属性

关系app名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string relationappname { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.relationid 属性

fl_order_refund_alimamarelationid 属性

关系id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string relationid { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.showrefundreason 属性

fl_order_refund_alimamashowrefundreason 属性

显示退款原因

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string showrefundreason { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.showrefundstatus 属性

fl_order_refund_alimamashowrefundstatus 属性

维权状态

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string showrefundstatus { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.showreturnfee 属性

fl_order_refund_alimamashowreturnfee 属性

显示返回的费用

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double showreturnfee { get; set; }

属性值

类型：Double
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.tbauctionnum 属性

fl_order_refund_alimamatbauctionnum 属性

tbauctionnum

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string tbauctionnum { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.tbauctiontitle 属性

fl_order_refund_alimamatbauctiontitle 属性

订单标题

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string tbauctiontitle { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.tbsellershoptitle 属性

fl_order_refund_alimamatbsellershoptitle 属性

淘宝卖家商店标题

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string tbsellershoptitle { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.tbtradefinishprice 属性

fl_order_refund_alimamatbtradefinishprice 属性

TB贸易成品价格

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string tbtradefinishprice { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.tbtradeid 属性

fl_order_refund_alimamatbtradeid 属性

淘宝交易id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string tbtradeid { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.tbtradeparentid 属性

fl_order_refund_alimamatbtradeparentid 属性

父订单号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string tbtradeparentid { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.tkcommissionfee 属性

fl_order_refund_alimamatkcommissionfee 属性

手续费

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double tkcommissionfee { get; set; }

属性值

类型：Double
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama.tksubsidyfee 属性

fl_order_refund_alimamatksubsidyfee 属性

补贴费用

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string tksubsidyfee { get; set; }

属性值

类型：String
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_refund_alimama 方法

fl_order_refund_alimama 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_order_refund_alimama 类
Api.Framework.Model 命名空间


fl_order_sleep 类

订单冻结规则
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_order_sleep

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_order_sleep : base_model

fl_order_sleep 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_order_sleep | 无参构造函数
Top
属性
 | 名称 | 说明
公共属性 | cps_type | 联盟类型
公共属性 | id | (继承自 base_model。)
公共属性 | money | 金额满足
公共属性 | sleep | 结算后延迟返佣金(单位:小时)
公共属性 | white_groups | 不受限的会员组
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_order_sleep 构造函数

无参构造函数

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_order_sleep()
参见

引用

fl_order_sleep 类
Api.Framework.Model 命名空间


fl_order_sleep 属性

fl_order_sleep 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | cps_type | 联盟类型
公共属性 | id | (继承自 base_model。)
公共属性 | money | 金额满足
公共属性 | sleep | 结算后延迟返佣金(单位:小时)
公共属性 | white_groups | 不受限的会员组
Top
参见

引用

fl_order_sleep 类
Api.Framework.Model 命名空间


fl_order_sleep.cps_type 属性

fl_order_sleepcps_type 属性

联盟类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CpsType cps_type { get; set; }

属性值

类型：CpsType
参见

引用

fl_order_sleep 类
Api.Framework.Model 命名空间


fl_order_sleep.money 属性

fl_order_sleepmoney 属性

金额满足

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double money { get; set; }

属性值

类型：Double
参见

引用

fl_order_sleep 类
Api.Framework.Model 命名空间


fl_order_sleep.sleep 属性

fl_order_sleepsleep 属性

结算后延迟返佣金(单位:小时)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int sleep { get; set; }

属性值

类型：Int32
参见

引用

fl_order_sleep 类
Api.Framework.Model 命名空间


fl_order_sleep.white_groups 属性

fl_order_sleepwhite_groups 属性

不受限的会员组

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string white_groups { get; set; }

属性值

类型：String
参见

引用

fl_order_sleep 类
Api.Framework.Model 命名空间


fl_order_sleep 方法

fl_order_sleep 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_order_sleep 类
Api.Framework.Model 命名空间


fl_order_weipinhui 类

唯品会订单
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelbase_model_order
Api.Framework.Modelfl_order_weipinhui

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_order_weipinhui : base_model_order

fl_order_weipinhui 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_order_weipinhui | 初始化 fl_order_weipinhui 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | afterSaleChangeCommission | 售后订单佣金变动：仅在订单完结之后发生售后行为时返回
公共属性 | afterSaleChangedCommission | 商品佣金售后变动:仅在订单完结之后发生售后时返回，无售后时为空
公共属性 | afterSaleChangedGoodsCount | 商品数量售后变动:仅在订单完结之后发生售后时返回，无售后时为空
公共属性 | afterSaleChangeGoodsCount | 售后订单总商品数量变动：仅在订单完结之后发生售后行为时返回
公共属性 | afterSaleFinishTime | 售后完成时间，时间戳，单位：毫秒，无售后时为空
公共属性 | afterSaleSn | 商品售后单号，无售后时为空
公共属性 | afterSaleStatus | 商品售后状态：1-售后中，2-售后完成，3-售后取消，无售后时为空
公共属性 | afterSaleType | 售后类型：1-退货，2-换货,无售后时为空
公共属性 | brandStoreName | 品牌名称
公共属性 | brandStoreSn | 品牌编号
公共属性 | channelTag | 渠道商模式下表示自定义渠道标识；工具商模式下表示pid
公共属性 | commCode | 佣金编码：对应商品二级分类
公共属性 | commission | 商品佣金金额(元,保留两位小数)
公共属性 | commissionEnterTime | 入账时间，时间戳，单位毫秒
公共属性 | commissionRate | 商品佣金比例(%)
公共属性 | commissionTotalCost | 商品计佣金额(元,保留两位小数)
公共属性 | commName | 佣金方案名称
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | goodsCount | 商品数量
公共属性 | goodsFinalPrice | 商品成交价（元,保留两位小数,商品成交价上线之后的订单才有该值）
公共属性 | goodsId | 商品id
公共属性 | goodsName | 商品名称
公共属性 | goodsThumb | 商品缩略图
公共属性 | id | (继承自 base_model。)
公共属性 | isPrepay | 是否预付订单:0-否，1-是
公共属性 | isSplit | 订单拆单标识: 0-否，1-是
公共属性 | lastUpdateTime | 订单上次更新时间 时间戳 单位毫秒
公共属性 | mallId | 店铺ID
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | newCustomer | 新老客：0-待定，1-新客，2-老客
公共属性 | orderSn | 订单号
公共属性 | orderSource | 订单来源
公共属性 | orderSubStatusName | 订单子状态：流转状态-支持状态：（已下单、已付款、已签收、待结算、已结算、已失效）
公共属性 | orderTime | 下单时间 时间戳 单位毫秒
公共属性 | orderTrackReason | 订单归因方式：0-常规推广,1-惊喜红包,2-锁粉,3-超级红包
公共属性 | parentSn | 订单母单号:订单为拆单子单时返回
公共属性 | pid | 推广PID:目前等同于channelTag
公共属性 | selfBuy | 是否自推自买 0-否，1-是
公共属性 | settled | 订单结算状态 0-未结算,1-已结算
公共属性 | settledTime | 结算时间 时间戳 单位毫秒
公共属性 | signTime | 签收时间 时间戳 单位毫秒
公共属性 | sizeId | 商品尺码：2019.01.01之后可用
公共属性 | spuId | 商品spuId
公共属性 | statParam | 自定义统计参数
公共属性 | status | 商品状态：0-不合格，1-待定，2-已完结
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_order_weipinhui 构造函数

初始化 fl_order_weipinhui 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_order_weipinhui()
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui 属性

fl_order_weipinhui 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | afterSaleChangeCommission | 售后订单佣金变动：仅在订单完结之后发生售后行为时返回
公共属性 | afterSaleChangedCommission | 商品佣金售后变动:仅在订单完结之后发生售后时返回，无售后时为空
公共属性 | afterSaleChangedGoodsCount | 商品数量售后变动:仅在订单完结之后发生售后时返回，无售后时为空
公共属性 | afterSaleChangeGoodsCount | 售后订单总商品数量变动：仅在订单完结之后发生售后行为时返回
公共属性 | afterSaleFinishTime | 售后完成时间，时间戳，单位：毫秒，无售后时为空
公共属性 | afterSaleSn | 商品售后单号，无售后时为空
公共属性 | afterSaleStatus | 商品售后状态：1-售后中，2-售后完成，3-售后取消，无售后时为空
公共属性 | afterSaleType | 售后类型：1-退货，2-换货,无售后时为空
公共属性 | brandStoreName | 品牌名称
公共属性 | brandStoreSn | 品牌编号
公共属性 | channelTag | 渠道商模式下表示自定义渠道标识；工具商模式下表示pid
公共属性 | commCode | 佣金编码：对应商品二级分类
公共属性 | commission | 商品佣金金额(元,保留两位小数)
公共属性 | commissionEnterTime | 入账时间，时间戳，单位毫秒
公共属性 | commissionRate | 商品佣金比例(%)
公共属性 | commissionTotalCost | 商品计佣金额(元,保留两位小数)
公共属性 | commName | 佣金方案名称
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | goodsCount | 商品数量
公共属性 | goodsFinalPrice | 商品成交价（元,保留两位小数,商品成交价上线之后的订单才有该值）
公共属性 | goodsId | 商品id
公共属性 | goodsName | 商品名称
公共属性 | goodsThumb | 商品缩略图
公共属性 | id | (继承自 base_model。)
公共属性 | isPrepay | 是否预付订单:0-否，1-是
公共属性 | isSplit | 订单拆单标识: 0-否，1-是
公共属性 | lastUpdateTime | 订单上次更新时间 时间戳 单位毫秒
公共属性 | mallId | 店铺ID
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | newCustomer | 新老客：0-待定，1-新客，2-老客
公共属性 | orderSn | 订单号
公共属性 | orderSource | 订单来源
公共属性 | orderSubStatusName | 订单子状态：流转状态-支持状态：（已下单、已付款、已签收、待结算、已结算、已失效）
公共属性 | orderTime | 下单时间 时间戳 单位毫秒
公共属性 | orderTrackReason | 订单归因方式：0-常规推广,1-惊喜红包,2-锁粉,3-超级红包
公共属性 | parentSn | 订单母单号:订单为拆单子单时返回
公共属性 | pid | 推广PID:目前等同于channelTag
公共属性 | selfBuy | 是否自推自买 0-否，1-是
公共属性 | settled | 订单结算状态 0-未结算,1-已结算
公共属性 | settledTime | 结算时间 时间戳 单位毫秒
公共属性 | signTime | 签收时间 时间戳 单位毫秒
公共属性 | sizeId | 商品尺码：2019.01.01之后可用
公共属性 | spuId | 商品spuId
公共属性 | statParam | 自定义统计参数
公共属性 | status | 商品状态：0-不合格，1-待定，2-已完结
Top
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.afterSaleChangeCommission 属性

fl_order_weipinhuiafterSaleChangeCommission 属性

售后订单佣金变动：仅在订单完结之后发生售后行为时返回

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string afterSaleChangeCommission { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.afterSaleChangedCommission 属性

fl_order_weipinhuiafterSaleChangedCommission 属性

商品佣金售后变动:仅在订单完结之后发生售后时返回，无售后时为空

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double afterSaleChangedCommission { get; set; }

属性值

类型：Double
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.afterSaleChangedGoodsCount 属性

fl_order_weipinhuiafterSaleChangedGoodsCount 属性

商品数量售后变动:仅在订单完结之后发生售后时返回，无售后时为空

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int afterSaleChangedGoodsCount { get; set; }

属性值

类型：Int32
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.afterSaleChangeGoodsCount 属性

fl_order_weipinhuiafterSaleChangeGoodsCount 属性

售后订单总商品数量变动：仅在订单完结之后发生售后行为时返回

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string afterSaleChangeGoodsCount { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.afterSaleFinishTime 属性

fl_order_weipinhuiafterSaleFinishTime 属性

售后完成时间，时间戳，单位：毫秒，无售后时为空

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long afterSaleFinishTime { get; set; }

属性值

类型：Int64
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.afterSaleSn 属性

fl_order_weipinhuiafterSaleSn 属性

商品售后单号，无售后时为空

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string afterSaleSn { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.afterSaleStatus 属性

fl_order_weipinhuiafterSaleStatus 属性

商品售后状态：1-售后中，2-售后完成，3-售后取消，无售后时为空

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiAfterSaleStatus afterSaleStatus { get; set; }

属性值

类型：WeipinhuiAfterSaleStatus
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.afterSaleType 属性

fl_order_weipinhuiafterSaleType 属性

售后类型：1-退货，2-换货,无售后时为空

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiSfterSaleType afterSaleType { get; set; }

属性值

类型：WeipinhuiSfterSaleType
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.brandStoreName 属性

fl_order_weipinhuibrandStoreName 属性

品牌名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandStoreName { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.brandStoreSn 属性

fl_order_weipinhuibrandStoreSn 属性

品牌编号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandStoreSn { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.channelTag 属性

fl_order_weipinhuichannelTag 属性

渠道商模式下表示自定义渠道标识；工具商模式下表示pid

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string channelTag { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.commCode 属性

fl_order_weipinhuicommCode 属性

佣金编码：对应商品二级分类

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commCode { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.commission 属性

fl_order_weipinhuicommission 属性

商品佣金金额(元,保留两位小数)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double commission { get; set; }

属性值

类型：Double
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.commissionEnterTime 属性

fl_order_weipinhuicommissionEnterTime 属性

入账时间，时间戳，单位毫秒

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long commissionEnterTime { get; set; }

属性值

类型：Int64
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.commissionRate 属性

fl_order_weipinhuicommissionRate 属性

商品佣金比例(%)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double commissionRate { get; set; }

属性值

类型：Double
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.commissionTotalCost 属性

fl_order_weipinhuicommissionTotalCost 属性

商品计佣金额(元,保留两位小数)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double commissionTotalCost { get; set; }

属性值

类型：Double
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.commName 属性

fl_order_weipinhuicommName 属性

佣金方案名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commName { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.goodsCount 属性

fl_order_weipinhuigoodsCount 属性

商品数量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int goodsCount { get; set; }

属性值

类型：Int32
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.goodsFinalPrice 属性

fl_order_weipinhuigoodsFinalPrice 属性

商品成交价（元,保留两位小数,商品成交价上线之后的订单才有该值）

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double goodsFinalPrice { get; set; }

属性值

类型：Double
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.goodsId 属性

fl_order_weipinhuigoodsId 属性

商品id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsId { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.goodsName 属性

fl_order_weipinhuigoodsName 属性

商品名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsName { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.goodsThumb 属性

fl_order_weipinhuigoodsThumb 属性

商品缩略图

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsThumb { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.isPrepay 属性

fl_order_weipinhuiisPrepay 属性

是否预付订单:0-否，1-是

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiShiFou isPrepay { get; set; }

属性值

类型：WeipinhuiShiFou
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.isSplit 属性

fl_order_weipinhuiisSplit 属性

订单拆单标识: 0-否，1-是

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiShiFou isSplit { get; set; }

属性值

类型：WeipinhuiShiFou
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.lastUpdateTime 属性

fl_order_weipinhuilastUpdateTime 属性

订单上次更新时间 时间戳 单位毫秒

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long lastUpdateTime { get; set; }

属性值

类型：Int64
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.mallId 属性

fl_order_weipinhuimallId 属性

店铺ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string mallId { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.newCustomer 属性

fl_order_weipinhuinewCustomer 属性

新老客：0-待定，1-新客，2-老客

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiNewCustomer newCustomer { get; set; }

属性值

类型：WeipinhuiNewCustomer
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.orderSn 属性

fl_order_weipinhuiorderSn 属性

订单号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string orderSn { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.orderSource 属性

fl_order_weipinhuiorderSource 属性

订单来源

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string orderSource { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.orderSubStatusName 属性

fl_order_weipinhuiorderSubStatusName 属性

订单子状态：流转状态-支持状态：（已下单、已付款、已签收、待结算、已结算、已失效）

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiOrderSubStatusName orderSubStatusName { get; set; }

属性值

类型：WeipinhuiOrderSubStatusName
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.orderTime 属性

fl_order_weipinhuiorderTime 属性

下单时间 时间戳 单位毫秒

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long orderTime { get; set; }

属性值

类型：Int64
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.orderTrackReason 属性

fl_order_weipinhuiorderTrackReason 属性

订单归因方式：0-常规推广,1-惊喜红包,2-锁粉,3-超级红包

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiGuiYin orderTrackReason { get; set; }

属性值

类型：WeipinhuiGuiYin
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.parentSn 属性

fl_order_weipinhuiparentSn 属性

订单母单号:订单为拆单子单时返回

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string parentSn { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.pid 属性

fl_order_weipinhuipid 属性

推广PID:目前等同于channelTag

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pid { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.selfBuy 属性

fl_order_weipinhuiselfBuy 属性

是否自推自买 0-否，1-是

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiShiFou selfBuy { get; set; }

属性值

类型：WeipinhuiShiFou
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.settled 属性

fl_order_weipinhuisettled 属性

订单结算状态 0-未结算,1-已结算

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiOrderSettled settled { get; set; }

属性值

类型：WeipinhuiOrderSettled
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.settledTime 属性

fl_order_weipinhuisettledTime 属性

结算时间 时间戳 单位毫秒

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long settledTime { get; set; }

属性值

类型：Int64
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.signTime 属性

fl_order_weipinhuisignTime 属性

签收时间 时间戳 单位毫秒

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long signTime { get; set; }

属性值

类型：Int64
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.sizeId 属性

fl_order_weipinhuisizeId 属性

商品尺码：2019.01.01之后可用

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string sizeId { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.spuId 属性

fl_order_weipinhuispuId 属性

商品spuId

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string spuId { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.statParam 属性

fl_order_weipinhuistatParam 属性

自定义统计参数

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string statParam { get; set; }

属性值

类型：String
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui.status 属性

fl_order_weipinhuistatus 属性

商品状态：0-不合格，1-待定，2-已完结

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiOrderStatus status { get; set; }

属性值

类型：WeipinhuiOrderStatus
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_order_weipinhui 方法

fl_order_weipinhui 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_order_weipinhui 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info 类

全额免单
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_plugin_allrebatesactivity_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_plugin_allrebatesactivity_info : base_model

fl_plugin_allrebatesactivity_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_plugin_allrebatesactivity_info | 初始化 fl_plugin_allrebatesactivity_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | brokerage_money | 返利金额
公共属性 | brokerage_ratio | 返利比例
公共属性 | coupon | 优惠券面额
公共属性 | goods_id | 活动宝贝
公共属性 | groups | 参加活动的用户组(-1未所有用户)
公共属性 | id | (继承自 base_model。)
公共属性 | limit_quantity_number | 限制购买数量
公共属性 | name | 活动名称
公共属性 | price | 单价
公共属性 | return_money | 返回客户金额比例.用户付款金额为基数
公共属性 | robots | 机器人列表 (机器人name)
公共属性 | time_begin | 活动开始时间
公共属性 | time_end | 活动结束时间
公共属性 | title | 宝贝标题
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info 构造函数

初始化 fl_plugin_allrebatesactivity_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_plugin_allrebatesactivity_info()
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info 属性

fl_plugin_allrebatesactivity_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | brokerage_money | 返利金额
公共属性 | brokerage_ratio | 返利比例
公共属性 | coupon | 优惠券面额
公共属性 | goods_id | 活动宝贝
公共属性 | groups | 参加活动的用户组(-1未所有用户)
公共属性 | id | (继承自 base_model。)
公共属性 | limit_quantity_number | 限制购买数量
公共属性 | name | 活动名称
公共属性 | price | 单价
公共属性 | return_money | 返回客户金额比例.用户付款金额为基数
公共属性 | robots | 机器人列表 (机器人name)
公共属性 | time_begin | 活动开始时间
公共属性 | time_end | 活动结束时间
公共属性 | title | 宝贝标题
Top
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.brokerage_money 属性

fl_plugin_allrebatesactivity_infobrokerage_money 属性

返利金额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double brokerage_money { get; set; }

属性值

类型：Double
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.brokerage_ratio 属性

fl_plugin_allrebatesactivity_infobrokerage_ratio 属性

返利比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int brokerage_ratio { get; set; }

属性值

类型：Int32
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.coupon 属性

fl_plugin_allrebatesactivity_infocoupon 属性

优惠券面额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double coupon { get; set; }

属性值

类型：Double
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.goods_id 属性

fl_plugin_allrebatesactivity_infogoods_id 属性

活动宝贝

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goods_id { get; set; }

属性值

类型：String
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.groups 属性

fl_plugin_allrebatesactivity_infogroups 属性

参加活动的用户组(-1未所有用户)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string groups { get; set; }

属性值

类型：String
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.limit_quantity_number 属性

fl_plugin_allrebatesactivity_infolimit_quantity_number 属性

限制购买数量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int limit_quantity_number { get; set; }

属性值

类型：Int32
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.name 属性

fl_plugin_allrebatesactivity_infoname 属性

活动名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string name { get; set; }

属性值

类型：String
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.price 属性

fl_plugin_allrebatesactivity_infoprice 属性

单价

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double price { get; set; }

属性值

类型：Double
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.return_money 属性

fl_plugin_allrebatesactivity_inforeturn_money 属性

返回客户金额比例.用户付款金额为基数

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double return_money { get; set; }

属性值

类型：Double
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.robots 属性

fl_plugin_allrebatesactivity_inforobots 属性

机器人列表 (机器人name)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string robots { get; set; }

属性值

类型：String
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.time_begin 属性

fl_plugin_allrebatesactivity_infotime_begin 属性

活动开始时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime time_begin { get; set; }

属性值

类型：DateTime
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.time_end 属性

fl_plugin_allrebatesactivity_infotime_end 属性

活动结束时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime time_end { get; set; }

属性值

类型：DateTime
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info.title 属性

fl_plugin_allrebatesactivity_infotitle 属性

宝贝标题

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string title { get; set; }

属性值

类型：String
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_info 方法

fl_plugin_allrebatesactivity_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_plugin_allrebatesactivity_info 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_orderlist 类

全额免单订单
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_plugin_allrebatesactivity_orderlist

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_plugin_allrebatesactivity_orderlist : base_model

fl_plugin_allrebatesactivity_orderlist 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_plugin_allrebatesactivity_orderlist | 初始化 fl_plugin_allrebatesactivity_orderlist 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | activity_id | 任务ID
公共属性 | id | (继承自 base_model。)
公共属性 | mid | 用户ID
公共属性 | oid | 订单ID
公共属性 | rid | 机器人ID
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_orderlist 构造函数

初始化 fl_plugin_allrebatesactivity_orderlist 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_plugin_allrebatesactivity_orderlist()
参见

引用

fl_plugin_allrebatesactivity_orderlist 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_orderlist 属性

fl_plugin_allrebatesactivity_orderlist 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | activity_id | 任务ID
公共属性 | id | (继承自 base_model。)
公共属性 | mid | 用户ID
公共属性 | oid | 订单ID
公共属性 | rid | 机器人ID
Top
参见

引用

fl_plugin_allrebatesactivity_orderlist 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_orderlist.activity_id 属性

fl_plugin_allrebatesactivity_orderlistactivity_id 属性

任务ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long activity_id { get; set; }

属性值

类型：Int64
参见

引用

fl_plugin_allrebatesactivity_orderlist 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_orderlist.mid 属性

fl_plugin_allrebatesactivity_orderlistmid 属性

用户ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long mid { get; set; }

属性值

类型：Int64
参见

引用

fl_plugin_allrebatesactivity_orderlist 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_orderlist.oid 属性

fl_plugin_allrebatesactivity_orderlistoid 属性

订单ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long oid { get; set; }

属性值

类型：Int64
参见

引用

fl_plugin_allrebatesactivity_orderlist 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_orderlist.rid 属性

fl_plugin_allrebatesactivity_orderlistrid 属性

机器人ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long rid { get; set; }

属性值

类型：Int64
参见

引用

fl_plugin_allrebatesactivity_orderlist 类
Api.Framework.Model 命名空间


fl_plugin_allrebatesactivity_orderlist 方法

fl_plugin_allrebatesactivity_orderlist 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_plugin_allrebatesactivity_orderlist 类
Api.Framework.Model 命名空间


fl_plugin_info 类

插件基础信息
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_plugin_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_plugin_info : base_model

fl_plugin_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_plugin_info | 初始化 fl_plugin_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | assembly | 程序集
公共属性 | file | 文件
公共属性 | id | (继承自 base_model。)
公共属性 | level | 顺序
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_plugin_info 构造函数

初始化 fl_plugin_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_plugin_info()
参见

引用

fl_plugin_info 类
Api.Framework.Model 命名空间


fl_plugin_info 属性

fl_plugin_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | assembly | 程序集
公共属性 | file | 文件
公共属性 | id | (继承自 base_model。)
公共属性 | level | 顺序
Top
参见

引用

fl_plugin_info 类
Api.Framework.Model 命名空间


fl_plugin_info.assembly 属性

fl_plugin_infoassembly 属性

程序集

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string assembly { get; set; }

属性值

类型：String
参见

引用

fl_plugin_info 类
Api.Framework.Model 命名空间


fl_plugin_info.file 属性

fl_plugin_infofile 属性

文件

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string file { get; set; }

属性值

类型：String
参见

引用

fl_plugin_info 类
Api.Framework.Model 命名空间


fl_plugin_info.level 属性

fl_plugin_infolevel 属性

顺序

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int level { get; set; }

属性值

类型：Int32
参见

引用

fl_plugin_info 类
Api.Framework.Model 命名空间


fl_plugin_info 方法

fl_plugin_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_plugin_info 类
Api.Framework.Model 命名空间


fl_point_hist 类

积分改变记录
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_point_hist

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_point_hist : base_model

fl_point_hist 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_point_hist | 初始化 fl_point_hist 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | after_point | 修改后积分
公共属性 | before_point | 修改前积分
公共属性 | crt_time | 创建时间
公共属性 | id | (继承自 base_model。)
公共属性 | message | 内容
公共属性 | point | 改变的值
公共属性 | rid | 机器人id
公共属性 | type | 类型
公共属性 | uid | 用户ID
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_point_hist 构造函数

初始化 fl_point_hist 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_point_hist()
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist 属性

fl_point_hist 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | after_point | 修改后积分
公共属性 | before_point | 修改前积分
公共属性 | crt_time | 创建时间
公共属性 | id | (继承自 base_model。)
公共属性 | message | 内容
公共属性 | point | 改变的值
公共属性 | rid | 机器人id
公共属性 | type | 类型
公共属性 | uid | 用户ID
Top
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist.after_point 属性

fl_point_histafter_point 属性

修改后积分

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double after_point { get; set; }

属性值

类型：Double
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist.before_point 属性

fl_point_histbefore_point 属性

修改前积分

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double before_point { get; set; }

属性值

类型：Double
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist.crt_time 属性

fl_point_histcrt_time 属性

创建时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime crt_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist.message 属性

fl_point_histmessage 属性

内容

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string message { get; set; }

属性值

类型：String
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist.point 属性

fl_point_histpoint 属性

改变的值

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double point { get; set; }

属性值

类型：Double
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist.rid 属性

fl_point_histrid 属性

机器人id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long rid { get; set; }

属性值

类型：Int64
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist.type 属性

fl_point_histtype 属性

类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string type { get; set; }

属性值

类型：String
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist.uid 属性

fl_point_histuid 属性

用户ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long uid { get; set; }

属性值

类型：Int64
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_point_hist 方法

fl_point_hist 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_point_hist 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache 类

防撸处理
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_prevent_theft_cache

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_prevent_theft_cache : base_model

fl_prevent_theft_cache 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_prevent_theft_cache | 初始化 fl_prevent_theft_cache 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | cps_type | 订单平台类型
公共属性 | extend |
公共属性 | id | (继承自 base_model。)
公共属性 | item_id | 商品ID
公共属性 | mall_id | 店铺ID
公共属性 | member_id | 用户id
公共属性 | operate_type | 处理类型
公共属性 | order_id | 订单编码
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_prevent_theft_cache 构造函数

初始化 fl_prevent_theft_cache 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_prevent_theft_cache()
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache 属性

fl_prevent_theft_cache 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | cps_type | 订单平台类型
公共属性 | extend |
公共属性 | id | (继承自 base_model。)
公共属性 | item_id | 商品ID
公共属性 | mall_id | 店铺ID
公共属性 | member_id | 用户id
公共属性 | operate_type | 处理类型
公共属性 | order_id | 订单编码
Top
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache.cps_type 属性

fl_prevent_theft_cachecps_type 属性

订单平台类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CpsType cps_type { get; set; }

属性值

类型：CpsType
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache.extend 属性

fl_prevent_theft_cacheextend 属性

[缺少 "P:Api.Framework.Model.fl_prevent_theft_cache.extend" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string extend { get; set; }

属性值

类型：String
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache.item_id 属性

fl_prevent_theft_cacheitem_id 属性

商品ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string item_id { get; set; }

属性值

类型：String
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache.mall_id 属性

fl_prevent_theft_cachemall_id 属性

店铺ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string mall_id { get; set; }

属性值

类型：String
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache.member_id 属性

fl_prevent_theft_cachemember_id 属性

用户id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long member_id { get; set; }

属性值

类型：Int64
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache.operate_type 属性

fl_prevent_theft_cacheoperate_type 属性

处理类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OperateType operate_type { get; set; }

属性值

类型：OperateType
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache.order_id 属性

fl_prevent_theft_cacheorder_id 属性

订单编码

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string order_id { get; set; }

属性值

类型：String
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_prevent_theft_cache 方法

fl_prevent_theft_cache 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_prevent_theft_cache 类
Api.Framework.Model 命名空间


fl_private_pid 类

私人PID绑定
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_private_pid

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_private_pid : base_model

fl_private_pid 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_private_pid | 初始化 fl_private_pid 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | bind_order | 订单绑定
公共属性 | bind_query | 查询绑定
公共属性 | cps_name | 联盟账号
公共属性 | cps_type | cps类型
公共属性 | id | (继承自 base_model。)
公共属性 | pid_id | 推广位ID
公共属性 | pid_name | 推广位名称
公共属性 | uid | 用户编号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_private_pid 构造函数

初始化 fl_private_pid 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_private_pid()
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_private_pid 属性

fl_private_pid 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | bind_order | 订单绑定
公共属性 | bind_query | 查询绑定
公共属性 | cps_name | 联盟账号
公共属性 | cps_type | cps类型
公共属性 | id | (继承自 base_model。)
公共属性 | pid_id | 推广位ID
公共属性 | pid_name | 推广位名称
公共属性 | uid | 用户编号
Top
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_private_pid.bind_order 属性

fl_private_pidbind_order 属性

订单绑定

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool bind_order { get; set; }

属性值

类型：Boolean
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_private_pid.bind_query 属性

fl_private_pidbind_query 属性

查询绑定

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool bind_query { get; set; }

属性值

类型：Boolean
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_private_pid.cps_name 属性

fl_private_pidcps_name 属性

联盟账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cps_name { get; set; }

属性值

类型：String
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_private_pid.cps_type 属性

fl_private_pidcps_type 属性

cps类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CpsType cps_type { get; set; }

属性值

类型：CpsType
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_private_pid.pid_id 属性

fl_private_pidpid_id 属性

推广位ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pid_id { get; set; }

属性值

类型：String
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_private_pid.pid_name 属性

fl_private_pidpid_name 属性

推广位名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pid_name { get; set; }

属性值

类型：String
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_private_pid.uid 属性

fl_private_piduid 属性

用户编号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long uid { get; set; }

属性值

类型：Int64
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_private_pid 方法

fl_private_pid 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_private_pid 类
Api.Framework.Model 命名空间


fl_query_hist 类

查询记录
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_query_hist

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_query_hist : base_model

fl_query_hist 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_query_hist | 初始化 fl_query_hist 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | adzoneid | 推广位ID
公共属性 | crt_time | 创建时间
公共属性 | groupid | 群号
公共属性 | id | (继承自 base_model。)
公共属性 | itemid | 商品ID
公共属性 | mallid | 店铺ID
公共属性 | robot_name | 机器人ID
公共属性 | robot_type | 机器人类型
公共属性 | title | 标题
公共属性 | type | cps类型
公共属性 | userid | 用户ID
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_query_hist 构造函数

初始化 fl_query_hist 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_query_hist()
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist 属性

fl_query_hist 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | adzoneid | 推广位ID
公共属性 | crt_time | 创建时间
公共属性 | groupid | 群号
公共属性 | id | (继承自 base_model。)
公共属性 | itemid | 商品ID
公共属性 | mallid | 店铺ID
公共属性 | robot_name | 机器人ID
公共属性 | robot_type | 机器人类型
公共属性 | title | 标题
公共属性 | type | cps类型
公共属性 | userid | 用户ID
Top
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.adzoneid 属性

fl_query_histadzoneid 属性

推广位ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string adzoneid { get; set; }

属性值

类型：String
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.crt_time 属性

fl_query_histcrt_time 属性

创建时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime crt_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.groupid 属性

fl_query_histgroupid 属性

群号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string groupid { get; set; }

属性值

类型：String
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.itemid 属性

fl_query_histitemid 属性

商品ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string itemid { get; set; }

属性值

类型：String
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.mallid 属性

fl_query_histmallid 属性

店铺ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string mallid { get; set; }

属性值

类型：String
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.robot_name 属性

fl_query_histrobot_name 属性

机器人ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string robot_name { get; set; }

属性值

类型：String
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.robot_type 属性

fl_query_histrobot_type 属性

机器人类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChatType robot_type { get; set; }

属性值

类型：ChatType
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.title 属性

fl_query_histtitle 属性

标题

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string title { get; set; }

属性值

类型：String
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.type 属性

fl_query_histtype 属性

cps类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CpsType type { get; set; }

属性值

类型：CpsType
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist.userid 属性

fl_query_histuserid 属性

用户ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long userid { get; set; }

属性值

类型：Int64
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_query_hist 方法

fl_query_hist 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_query_hist 类
Api.Framework.Model 命名空间


fl_ratio_info 类

分出比例
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_ratio_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_ratio_info : base_model

fl_ratio_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_ratio_info | 初始化 fl_ratio_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | comm | 佣金
公共属性 | cps_type | CPS类型
公共属性 | id | (继承自 base_model。)
公共属性 | subsidy_num | 返点数值
公共属性 | subsidy_type | 补贴类型
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_ratio_info 构造函数

初始化 fl_ratio_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_ratio_info()
参见

引用

fl_ratio_info 类
Api.Framework.Model 命名空间


fl_ratio_info 属性

fl_ratio_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | comm | 佣金
公共属性 | cps_type | CPS类型
公共属性 | id | (继承自 base_model。)
公共属性 | subsidy_num | 返点数值
公共属性 | subsidy_type | 补贴类型
Top
参见

引用

fl_ratio_info 类
Api.Framework.Model 命名空间


fl_ratio_info.comm 属性

fl_ratio_infocomm 属性

佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double comm { get; set; }

属性值

类型：Double
参见

引用

fl_ratio_info 类
Api.Framework.Model 命名空间


fl_ratio_info.cps_type 属性

fl_ratio_infocps_type 属性

CPS类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CpsType cps_type { get; set; }

属性值

类型：CpsType
参见

引用

fl_ratio_info 类
Api.Framework.Model 命名空间


fl_ratio_info.subsidy_num 属性

fl_ratio_infosubsidy_num 属性

返点数值

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double subsidy_num { get; set; }

属性值

类型：Double
参见

引用

fl_ratio_info 类
Api.Framework.Model 命名空间


fl_ratio_info.subsidy_type 属性

fl_ratio_infosubsidy_type 属性

补贴类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SubsidyType subsidy_type { get; set; }

属性值

类型：SubsidyType
参见

引用

fl_ratio_info 类
Api.Framework.Model 命名空间


fl_ratio_info 方法

fl_ratio_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_ratio_info 类
Api.Framework.Model 命名空间


fl_robot_info 类

机器人信息
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_robot_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_robot_info : base_model

fl_robot_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_robot_info | 初始化 fl_robot_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | crt_time | 创建时间
公共属性 | end_time | 到期时间
公共属性 | id | (继承自 base_model。)
公共属性 | is_login | 是否登录
公共属性 | is_receives | 是否接收消息
公共属性 | name | 机器人账号
公共属性 | nick | 机器人昵称
公共属性 | off_line_auto_login | 离线自动重登
公共属性 | off_line_tip | 离线通知
公共属性 | remark |
公共属性 | token | token
公共属性 | type | 平台类型
公共属性 | uin | 授权编号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetToken | 获取token
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_robot_info 构造函数

初始化 fl_robot_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_robot_info()
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info 属性

fl_robot_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | crt_time | 创建时间
公共属性 | end_time | 到期时间
公共属性 | id | (继承自 base_model。)
公共属性 | is_login | 是否登录
公共属性 | is_receives | 是否接收消息
公共属性 | name | 机器人账号
公共属性 | nick | 机器人昵称
公共属性 | off_line_auto_login | 离线自动重登
公共属性 | off_line_tip | 离线通知
公共属性 | remark |
公共属性 | token | token
公共属性 | type | 平台类型
公共属性 | uin | 授权编号
Top
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.crt_time 属性

fl_robot_infocrt_time 属性

创建时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime crt_time { get; set; }

属性值

类型：DateTime
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.end_time 属性

fl_robot_infoend_time 属性

到期时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string end_time { get; set; }

属性值

类型：String
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.is_login 属性

fl_robot_infois_login 属性

是否登录

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool is_login { get; set; }

属性值

类型：Boolean
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.is_receives 属性

fl_robot_infois_receives 属性

是否接收消息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType is_receives { get; set; }

属性值

类型：SwitchType
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.name 属性

fl_robot_infoname 属性

机器人账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string name { get; set; }

属性值

类型：String
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.nick 属性

fl_robot_infonick 属性

机器人昵称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string nick { get; set; }

属性值

类型：String
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.off_line_auto_login 属性

fl_robot_infooff_line_auto_login 属性

离线自动重登

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType off_line_auto_login { get; set; }

属性值

类型：SwitchType
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.off_line_tip 属性

fl_robot_infooff_line_tip 属性

离线通知

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SwitchType off_line_tip { get; set; }

属性值

类型：SwitchType
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.remark 属性

fl_robot_inforemark 属性

[缺少 "P:Api.Framework.Model.fl_robot_info.remark" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string remark { get; set; }

属性值

类型：String
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.token 属性

fl_robot_infotoken 属性

token

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string token { get; set; }

属性值

类型：String
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.type 属性

fl_robot_infotype 属性

平台类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChatType type { get; set; }

属性值

类型：ChatType
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.uin 属性

fl_robot_infouin 属性

授权编号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string uin { get; set; }

属性值

类型：String
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info 方法

fl_robot_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetToken | 获取token
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.GetToken 方法

fl_robot_infoGetToken 方法

获取token

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object GetToken()

返回值

类型：Object
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_robot_info.ToString 方法

fl_robot_infoToString 方法

[缺少 "M:Api.Framework.Model.fl_robot_info.ToString" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

fl_robot_info 类
Api.Framework.Model 命名空间


fl_shpay_hist 类

商户支付记录
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_shpay_hist

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_shpay_hist : base_model

fl_shpay_hist 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_shpay_hist | 初始化 fl_shpay_hist 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | chattype | 平台
公共属性 | ctime | 生成连接时间
公共属性 | ctimedate | 生成日期
公共属性 | id | (继承自 base_model。)
公共属性 | orderid | 商户orderid
公共属性 | paytime | 用户领取时间
公共属性 | paytype | 领取状态
公共属性 | payurl | 商户连接
公共属性 | point | 提现金额
公共属性 | rid | 机器人id
公共属性 | robotname | 机器人账号
公共属性 | robotnick | 机器人昵称
公共属性 | sendtime | 通知发送时间
公共属性 | uid | 用户id
公共属性 | username | 用户账号
公共属性 | usernick | 用户昵称
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_shpay_hist 构造函数

初始化 fl_shpay_hist 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_shpay_hist()
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist 属性

fl_shpay_hist 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | chattype | 平台
公共属性 | ctime | 生成连接时间
公共属性 | ctimedate | 生成日期
公共属性 | id | (继承自 base_model。)
公共属性 | orderid | 商户orderid
公共属性 | paytime | 用户领取时间
公共属性 | paytype | 领取状态
公共属性 | payurl | 商户连接
公共属性 | point | 提现金额
公共属性 | rid | 机器人id
公共属性 | robotname | 机器人账号
公共属性 | robotnick | 机器人昵称
公共属性 | sendtime | 通知发送时间
公共属性 | uid | 用户id
公共属性 | username | 用户账号
公共属性 | usernick | 用户昵称
Top
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.chattype 属性

fl_shpay_histchattype 属性

平台

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChatType chattype { get; set; }

属性值

类型：ChatType
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.ctime 属性

fl_shpay_histctime 属性

生成连接时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ctime { get; set; }

属性值

类型：Int64
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.ctimedate 属性

fl_shpay_histctimedate 属性

生成日期

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ctimedate { get; set; }

属性值

类型：Int64
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.orderid 属性

fl_shpay_historderid 属性

商户orderid

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string orderid { get; set; }

属性值

类型：String
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.paytime 属性

fl_shpay_histpaytime 属性

用户领取时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long paytime { get; set; }

属性值

类型：Int64
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.paytype 属性

fl_shpay_histpaytype 属性

领取状态

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PayGetType paytype { get; set; }

属性值

类型：PayGetType
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.payurl 属性

fl_shpay_histpayurl 属性

商户连接

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string payurl { get; set; }

属性值

类型：String
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.point 属性

fl_shpay_histpoint 属性

提现金额

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double point { get; set; }

属性值

类型：Double
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.rid 属性

fl_shpay_histrid 属性

机器人id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long rid { get; set; }

属性值

类型：Int64
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.robotname 属性

fl_shpay_histrobotname 属性

机器人账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string robotname { get; set; }

属性值

类型：String
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.robotnick 属性

fl_shpay_histrobotnick 属性

机器人昵称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string robotnick { get; set; }

属性值

类型：String
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.sendtime 属性

fl_shpay_histsendtime 属性

通知发送时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long sendtime { get; set; }

属性值

类型：Int64
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.uid 属性

fl_shpay_histuid 属性

用户id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long uid { get; set; }

属性值

类型：Int64
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.username 属性

fl_shpay_histusername 属性

用户账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string username { get; set; }

属性值

类型：String
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist.usernick 属性

fl_shpay_histusernick 属性

用户昵称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string usernick { get; set; }

属性值

类型：String
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_shpay_hist 方法

fl_shpay_hist 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_shpay_hist 类
Api.Framework.Model 命名空间


fl_statistics_record 类

用户基础记录
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_statistics_record

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_statistics_record : base_model

fl_statistics_record 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_statistics_record | 初始化 fl_statistics_record 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ex1 | 下级首单付款金额满足奖励上级(上级推荐)
公共属性 | ex10 |
公共属性 | ex11 |
公共属性 | ex12 |
公共属性 | ex2 | 订单付款后奖励
公共属性 | ex3 | 首次查询时间
公共属性 | ex4 | 首次付款时间
公共属性 | ex5 | 最后付款时间
公共属性 | ex6 |
公共属性 | ex7 |
公共属性 | ex8 |
公共属性 | ex9 |
公共属性 | id | (继承自 base_model。)
公共属性 | querynum | 查询次数
公共属性 | uid | 用户id
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_statistics_record 构造函数

初始化 fl_statistics_record 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_statistics_record()
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record 属性

fl_statistics_record 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ex1 | 下级首单付款金额满足奖励上级(上级推荐)
公共属性 | ex10 |
公共属性 | ex11 |
公共属性 | ex12 |
公共属性 | ex2 | 订单付款后奖励
公共属性 | ex3 | 首次查询时间
公共属性 | ex4 | 首次付款时间
公共属性 | ex5 | 最后付款时间
公共属性 | ex6 |
公共属性 | ex7 |
公共属性 | ex8 |
公共属性 | ex9 |
公共属性 | id | (继承自 base_model。)
公共属性 | querynum | 查询次数
公共属性 | uid | 用户id
Top
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex1 属性

fl_statistics_recordex1 属性

下级首单付款金额满足奖励上级(上级推荐)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex1 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex10 属性

fl_statistics_recordex10 属性

[缺少 "P:Api.Framework.Model.fl_statistics_record.ex10" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex10 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex11 属性

fl_statistics_recordex11 属性

[缺少 "P:Api.Framework.Model.fl_statistics_record.ex11" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex11 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex12 属性

fl_statistics_recordex12 属性

[缺少 "P:Api.Framework.Model.fl_statistics_record.ex12" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex12 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex2 属性

fl_statistics_recordex2 属性

订单付款后奖励

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex2 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex3 属性

fl_statistics_recordex3 属性

首次查询时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex3 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex4 属性

fl_statistics_recordex4 属性

首次付款时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex4 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex5 属性

fl_statistics_recordex5 属性

最后付款时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex5 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex6 属性

fl_statistics_recordex6 属性

[缺少 "P:Api.Framework.Model.fl_statistics_record.ex6" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex6 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex7 属性

fl_statistics_recordex7 属性

[缺少 "P:Api.Framework.Model.fl_statistics_record.ex7" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex7 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex8 属性

fl_statistics_recordex8 属性

[缺少 "P:Api.Framework.Model.fl_statistics_record.ex8" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex8 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.ex9 属性

fl_statistics_recordex9 属性

[缺少 "P:Api.Framework.Model.fl_statistics_record.ex9" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long ex9 { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.querynum 属性

fl_statistics_recordquerynum 属性

查询次数

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long querynum { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record.uid 属性

fl_statistics_recorduid 属性

用户id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long uid { get; set; }

属性值

类型：Int64
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_statistics_record 方法

fl_statistics_record 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_statistics_record 类
Api.Framework.Model 命名空间


fl_tb_relation 类

淘宝关系类
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_tb_relation

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_tb_relation : base_model

fl_tb_relation 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_tb_relation | 初始化 fl_tb_relation 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | cps_memberid | cps账号
公共属性 | id | (继承自 base_model。)
公共属性 | special_id | 特别的id
公共属性 | username | 用户对应的账号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_tb_relation 构造函数

初始化 fl_tb_relation 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_tb_relation()
参见

引用

fl_tb_relation 类
Api.Framework.Model 命名空间


fl_tb_relation 属性

fl_tb_relation 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | cps_memberid | cps账号
公共属性 | id | (继承自 base_model。)
公共属性 | special_id | 特别的id
公共属性 | username | 用户对应的账号
Top
参见

引用

fl_tb_relation 类
Api.Framework.Model 命名空间


fl_tb_relation.cps_memberid 属性

fl_tb_relationcps_memberid 属性

cps账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cps_memberid { get; set; }

属性值

类型：String
参见

引用

fl_tb_relation 类
Api.Framework.Model 命名空间


fl_tb_relation.special_id 属性

fl_tb_relationspecial_id 属性

特别的id

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long special_id { get; set; }

属性值

类型：Int64
参见

引用

fl_tb_relation 类
Api.Framework.Model 命名空间


fl_tb_relation.username 属性

fl_tb_relationusername 属性

用户对应的账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string username { get; set; }

属性值

类型：String
参见

引用

fl_tb_relation 类
Api.Framework.Model 命名空间


fl_tb_relation 方法

fl_tb_relation 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_tb_relation 类
Api.Framework.Model 命名空间


fl_uservariate_info 类

用户自定义全局变量
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_uservariate_info

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_uservariate_info : base_model

fl_uservariate_info 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_uservariate_info | 初始化 fl_uservariate_info 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | data | 替换的数据
公共属性 | id | (继承自 base_model。)
公共属性 | variate | 变量
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_uservariate_info 构造函数

初始化 fl_uservariate_info 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_uservariate_info()
参见

引用

fl_uservariate_info 类
Api.Framework.Model 命名空间


fl_uservariate_info 属性

fl_uservariate_info 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | data | 替换的数据
公共属性 | id | (继承自 base_model。)
公共属性 | variate | 变量
Top
参见

引用

fl_uservariate_info 类
Api.Framework.Model 命名空间


fl_uservariate_info.data 属性

fl_uservariate_infodata 属性

替换的数据

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string data { get; set; }

属性值

类型：String
参见

引用

fl_uservariate_info 类
Api.Framework.Model 命名空间


fl_uservariate_info.variate 属性

fl_uservariate_infovariate 属性

变量

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string variate { get; set; }

属性值

类型：String
参见

引用

fl_uservariate_info 类
Api.Framework.Model 命名空间


fl_uservariate_info 方法

fl_uservariate_info 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_uservariate_info 类
Api.Framework.Model 命名空间


fl_wechat_contacts 类

联系人
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_wechat_contacts

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_wechat_contacts : base_model

fl_wechat_contacts 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_wechat_contacts | 初始化 fl_wechat_contacts 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | alias | 微信号
公共属性 | bigheadimgurl | 大头像
公共属性 | chatroomowner |
公共属性 | chatroomversion | 版本
公共属性 | city | 城市
公共属性 | contacttype |
公共属性 | extinfo |
公共属性 | id | (继承自 base_model。)
公共属性 | msg_type |
公共属性 | nick_name | 昵称
公共属性 | province | 省份
公共属性 | remark | 备注
公共属性 | sex | 性别
公共属性 | signature | 签名
公共属性 | smallheadimgurl | 小头像
公共属性 | ticket | 是否为相互好友,值为空时为好友
公共属性 | user_name | 账号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_wechat_contacts 构造函数

初始化 fl_wechat_contacts 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_wechat_contacts()
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts 属性

fl_wechat_contacts 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | alias | 微信号
公共属性 | bigheadimgurl | 大头像
公共属性 | chatroomowner |
公共属性 | chatroomversion | 版本
公共属性 | city | 城市
公共属性 | contacttype |
公共属性 | extinfo |
公共属性 | id | (继承自 base_model。)
公共属性 | msg_type |
公共属性 | nick_name | 昵称
公共属性 | province | 省份
公共属性 | remark | 备注
公共属性 | sex | 性别
公共属性 | signature | 签名
公共属性 | smallheadimgurl | 小头像
公共属性 | ticket | 是否为相互好友,值为空时为好友
公共属性 | user_name | 账号
Top
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.alias 属性

fl_wechat_contactsalias 属性

微信号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string alias { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.bigheadimgurl 属性

fl_wechat_contactsbigheadimgurl 属性

大头像

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string bigheadimgurl { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.chatroomowner 属性

fl_wechat_contactschatroomowner 属性

[缺少 "P:Api.Framework.Model.fl_wechat_contacts.chatroomowner" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string chatroomowner { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.chatroomversion 属性

fl_wechat_contactschatroomversion 属性

版本

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string chatroomversion { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.city 属性

fl_wechat_contactscity 属性

城市

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string city { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.contacttype 属性

fl_wechat_contactscontacttype 属性

[缺少 "P:Api.Framework.Model.fl_wechat_contacts.contacttype" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int contacttype { get; set; }

属性值

类型：Int32
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.extinfo 属性

fl_wechat_contactsextinfo 属性

[缺少 "P:Api.Framework.Model.fl_wechat_contacts.extinfo" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string extinfo { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.msg_type 属性

fl_wechat_contactsmsg_type 属性

[缺少 "P:Api.Framework.Model.fl_wechat_contacts.msg_type" 的 <summary> 文档]

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int msg_type { get; set; }

属性值

类型：Int32
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.nick_name 属性

fl_wechat_contactsnick_name 属性

昵称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string nick_name { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.province 属性

fl_wechat_contactsprovince 属性

省份

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string province { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.remark 属性

fl_wechat_contactsremark 属性

备注

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string remark { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.sex 属性

fl_wechat_contactssex 属性

性别

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int sex { get; set; }

属性值

类型：Int32
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.signature 属性

fl_wechat_contactssignature 属性

签名

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string signature { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.smallheadimgurl 属性

fl_wechat_contactssmallheadimgurl 属性

小头像

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string smallheadimgurl { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.ticket 属性

fl_wechat_contactsticket 属性

是否为相互好友,值为空时为好友

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ticket { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts.user_name 属性

fl_wechat_contactsuser_name 属性

账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string user_name { get; set; }

属性值

类型：String
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_contacts 方法

fl_wechat_contacts 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_wechat_contacts 类
Api.Framework.Model 命名空间


fl_wechat_device 类

微信协议设备信息
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelfl_wechat_device

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_wechat_device : base_model

fl_wechat_device 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_wechat_device | 初始化 fl_wechat_device 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | device_info | 设备信息
公共属性 | id | (继承自 base_model。)
公共属性 | weixinhao | 微信号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_wechat_device 构造函数

初始化 fl_wechat_device 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_wechat_device()
参见

引用

fl_wechat_device 类
Api.Framework.Model 命名空间


fl_wechat_device 属性

fl_wechat_device 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | device_info | 设备信息
公共属性 | id | (继承自 base_model。)
公共属性 | weixinhao | 微信号
Top
参见

引用

fl_wechat_device 类
Api.Framework.Model 命名空间


fl_wechat_device.device_info 属性

fl_wechat_devicedevice_info 属性

设备信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string device_info { get; set; }

属性值

类型：String
参见

引用

fl_wechat_device 类
Api.Framework.Model 命名空间


fl_wechat_device.weixinhao 属性

fl_wechat_deviceweixinhao 属性

微信号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string weixinhao { get; set; }

属性值

类型：String
参见

引用

fl_wechat_device 类
Api.Framework.Model 命名空间


fl_wechat_device 方法

fl_wechat_device 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_wechat_device 类
Api.Framework.Model 命名空间


fl_weixin_password 类

协议微信支付信息
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelbase_model_order
Api.Framework.Modelfl_weixin_password

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class fl_weixin_password : base_model_order

fl_weixin_password 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | fl_weixin_password | 初始化 fl_weixin_password 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | bank_name | 银行名称
公共属性 | bank_serial | 银行序列号
公共属性 | bank_tail | 银行卡尾号
公共属性 | bank_type | 银行卡类型
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | id | (继承自 base_model。)
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | password | 支付密码
公共属性 | robot_id | 机器人编号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetBank | 获得银行卡信息
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SetBank | 设置银行卡信息
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


fl_weixin_password 构造函数

初始化 fl_weixin_password 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_weixin_password()
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password 属性

fl_weixin_password 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | bank_name | 银行名称
公共属性 | bank_serial | 银行序列号
公共属性 | bank_tail | 银行卡尾号
公共属性 | bank_type | 银行卡类型
公共属性 | db_cpsname | 联盟账号 (继承自 base_model_order。)
公共属性 | db_cpsnick | 联盟昵称 (继承自 base_model_order。)
公共属性 | db_endtime | 完结时间 (继承自 base_model_order。)
公共属性 | db_point | 积分信息 (继承自 base_model_order。)
公共属性 | db_robotname | 机器人ID (继承自 base_model_order。)
公共属性 | db_robottype | 机器人类型 (继承自 base_model_order。)
公共属性 | db_status | 完结状态：-2、未支付、-1、已退款 0、订单付款 1、冻结中 99、已结算 (继承自 base_model_order。)
公共属性 | db_status_time | 订单状态修改时间戳 (继承自 base_model_order。)
公共属性 | db_userid | 用户标识 (继承自 base_model_order。)
公共属性 | db_userpoint | 用户积分 - 临时记录 (继承自 base_model_order。)
公共属性 | id | (继承自 base_model。)
公共属性 | msg_groupid | 订单来源群 (继承自 base_model_order。)
公共属性 | password | 支付密码
公共属性 | robot_id | 机器人编号
Top
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password.bank_name 属性

fl_weixin_passwordbank_name 属性

银行名称

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string bank_name { get; set; }

属性值

类型：String
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password.bank_serial 属性

fl_weixin_passwordbank_serial 属性

银行序列号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string bank_serial { get; set; }

属性值

类型：String
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password.bank_tail 属性

fl_weixin_passwordbank_tail 属性

银行卡尾号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string bank_tail { get; set; }

属性值

类型：String
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password.bank_type 属性

fl_weixin_passwordbank_type 属性

银行卡类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string bank_type { get; set; }

属性值

类型：String
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password.password 属性

fl_weixin_passwordpassword 属性

支付密码

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string password { get; set; }

属性值

类型：String
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password.robot_id 属性

fl_weixin_passwordrobot_id 属性

机器人编号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long robot_id { get; set; }

属性值

类型：Int64
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password 方法

fl_weixin_password 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetBank | 获得银行卡信息
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsFinish | 订单是否完成 (继承自 base_model_order。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SetBank | 设置银行卡信息
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password.GetBank 方法

fl_weixin_passwordGetBank 方法

获得银行卡信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BankCar GetBank()

返回值

类型：BankCar
参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


fl_weixin_password.SetBank 方法

fl_weixin_passwordSetBank 方法

设置银行卡信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SetBank(
    BankCar bank
)

参数

bank
类型：Chat.Framework.WXSdkBankCar

[缺少 "M:Api.Framework.Model.fl_weixin_password.SetBank(Chat.Framework.WXSdk.BankCar)" 的 <param name="bank"/> 文档]

参见

引用

fl_weixin_password 类
Api.Framework.Model 命名空间


ModelExtend 类

扩展方法
继承层次
SystemObject
Api.Framework.ModelModelExtend

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class ModelExtend

ModelExtend 类型公开以下成员。

方法
名称 | 说明
AddTljCreateNum | 累加淘礼金创建次数
ChangePoint | 改变积分
CheckIsTljOrder | 通过推广位id判断是否为淘礼金订单
Delete(SqlSugarClient, fl_cps_member) | 删除cps对象
Delete(SqlSugarClient, fl_member_group) | 删除会员分组
FindAdzoneGroups | 获得推广位组信息
FindAdzoneInfos | 获取推广位集合
FindAlimamaAutoBindPid | 查询淘宝自动绑定PID集合
FindAlimamaOrderLastnums | 扩展方法订单尾号集合缓存
FindAlimamaPrivatePid | 阿里私人推广位
FindAlimamaTailBindPid | 尾号绑定.非订单查询绑定(朋友圈等其他推广)
FindBindCache | 读取绑定记录
FindBlacklistMemberInfos | 获取黑名单用户信息
FindCreateInfo | 获得创建者信息
FindDictionaryItem | 通过文件key,获取配置文件
FindDictionaryItems | 获取软件与插件的Config的配置
FindDouyinAutoBindPid | 抖音推广位自动绑定推广位
FindDouyinPrivatePid | 抖音私人推广位
FindGroup(SqlSugarClient, fl_member_info) | 获得用户组
FindGroup(SqlSugarClient, Int64) | 获得会员组
FindGroup(SqlSugarClient, String) | 获得会员组
FindGroup(SqlSugarClient, Double, Int64) | 根据消费总积分获得会员组
FindGroups | 获取会员组列表
FindItemPoint | 获得商品积分
FindJingdongAutoBindPid | 京东推广位自动绑定推广位
FindJingdongPrivatePid | 京东私人推广位
FindMemberinfo | 获得会员数据
FindMemberInfoById | 通过用户id查询用户对象
FindMemberInfoByUsername | 通过用户账号查询用户对象
FindNoticeapiRobots | 获取通知Robots
FindPinduoduoAutoBindPid | 拼多多推广位自动绑定推广位
FindPinduoduoPrivatePid | 拼多多私人推广位
FindRatio | 根据金额获得佣金比例
FindRatios | 获得积分列表
FindRobotInfo | 获得机器人信息
FindRobots | 获取机器人集合
FindSleep | 获得延迟冻结时间
FindSleeps | 获得延迟冻结信息
FindStatisticsRecord | 查询用户基础记录
FindTbRelations | 获取eid(关系)集合
FindTljByItemid | 通过阿里商品id获取已经创建的淘礼金
FindTljCreateNum | 检测淘宝账号是否符合创建淘礼金(淘礼金每天创建30个)
FindTljInfos | 获取所有的淘宝淘礼金信息
FindUserVariates | 获得用户自定义变量信息
FindWeipinhuiAutoBindPid | 唯品会推广位自动绑定推广位
FindWeipinhuiPrivatePid | 唯品会私人推广位
FindWeixinpassword | 查询微信密码信息
FindWeixinpasswords | 微信支付密码集合
GetPddComparisonFeeRate | 获取查询拼多多比价佣金的扣除后的计算佣金
GetTbComparisonFeeRate | 获取查询阿里比价佣金的扣除后的计算佣金
SaveOrUpdate(SqlSugarClient, fl_adzone_info) | 添加/修改推广位信息
SaveOrUpdate(SqlSugarClient, fl_alimama_tlj_get_record) | 添加/修改阿里淘礼金记录
SaveOrUpdate(SqlSugarClient, fl_cps_member) | 添加/修改cps对象
SaveOrUpdate(SqlSugarClient, fl_dictionary_item) | 添加/修改配置
SaveOrUpdate(SqlSugarClient, fl_group_person) | 添加/修改群管理
SaveOrUpdate(SqlSugarClient, fl_member_group) | 添加/修改会员分组
SaveOrUpdate(SqlSugarClient, fl_order_alimama) | 添加/修改阿里订单
SaveOrUpdate(SqlSugarClient, fl_order_douyin) | 添加/修改抖音订单
SaveOrUpdate(SqlSugarClient, fl_order_jingdong) | 添加/修改京东订单
SaveOrUpdate(SqlSugarClient, fl_order_pinduoduo) | 添加/修改拼多多订单
SaveOrUpdate(SqlSugarClient, fl_order_refund_alimama) | 添加/修改订单维权
SaveOrUpdate(SqlSugarClient, fl_order_sleep) | 添加/修改订单冻结规则
SaveOrUpdate(SqlSugarClient, fl_order_weipinhui) | 添加/修改唯品会订单
SaveOrUpdate(SqlSugarClient, fl_ratio_info) | 添加/修改分出比例
SaveOrUpdate(SqlSugarClient, fl_robot_info) | 添加/修改机器人对象
SaveOrUpdate(SqlSugarClient, fl_weixin_password) | 添加/修改微信支付信息
SaveOrUpdate(SqlSugarClient, fl_member_info, Boolean) | 添加/修改用户对象
TemporaryBypassedBlack | 15天内被拉黑过的用户不拉黑
UpdateMemberGroup | 更新用户所在分组
UpdateRecord | 记录用户基础记录(商品查询次数)
Top
参见

引用

Api.Framework.Model 命名空间


ModelExtend 方法

ModelExtend 类型公开以下成员。

方法
名称 | 说明
AddTljCreateNum | 累加淘礼金创建次数
ChangePoint | 改变积分
CheckIsTljOrder | 通过推广位id判断是否为淘礼金订单
Delete(SqlSugarClient, fl_cps_member) | 删除cps对象
Delete(SqlSugarClient, fl_member_group) | 删除会员分组
FindAdzoneGroups | 获得推广位组信息
FindAdzoneInfos | 获取推广位集合
FindAlimamaAutoBindPid | 查询淘宝自动绑定PID集合
FindAlimamaOrderLastnums | 扩展方法订单尾号集合缓存
FindAlimamaPrivatePid | 阿里私人推广位
FindAlimamaTailBindPid | 尾号绑定.非订单查询绑定(朋友圈等其他推广)
FindBindCache | 读取绑定记录
FindBlacklistMemberInfos | 获取黑名单用户信息
FindCreateInfo | 获得创建者信息
FindDictionaryItem | 通过文件key,获取配置文件
FindDictionaryItems | 获取软件与插件的Config的配置
FindDouyinAutoBindPid | 抖音推广位自动绑定推广位
FindDouyinPrivatePid | 抖音私人推广位
FindGroup(SqlSugarClient, fl_member_info) | 获得用户组
FindGroup(SqlSugarClient, Int64) | 获得会员组
FindGroup(SqlSugarClient, String) | 获得会员组
FindGroup(SqlSugarClient, Double, Int64) | 根据消费总积分获得会员组
FindGroups | 获取会员组列表
FindItemPoint | 获得商品积分
FindJingdongAutoBindPid | 京东推广位自动绑定推广位
FindJingdongPrivatePid | 京东私人推广位
FindMemberinfo | 获得会员数据
FindMemberInfoById | 通过用户id查询用户对象
FindMemberInfoByUsername | 通过用户账号查询用户对象
FindNoticeapiRobots | 获取通知Robots
FindPinduoduoAutoBindPid | 拼多多推广位自动绑定推广位
FindPinduoduoPrivatePid | 拼多多私人推广位
FindRatio | 根据金额获得佣金比例
FindRatios | 获得积分列表
FindRobotInfo | 获得机器人信息
FindRobots | 获取机器人集合
FindSleep | 获得延迟冻结时间
FindSleeps | 获得延迟冻结信息
FindStatisticsRecord | 查询用户基础记录
FindTbRelations | 获取eid(关系)集合
FindTljByItemid | 通过阿里商品id获取已经创建的淘礼金
FindTljCreateNum | 检测淘宝账号是否符合创建淘礼金(淘礼金每天创建30个)
FindTljInfos | 获取所有的淘宝淘礼金信息
FindUserVariates | 获得用户自定义变量信息
FindWeipinhuiAutoBindPid | 唯品会推广位自动绑定推广位
FindWeipinhuiPrivatePid | 唯品会私人推广位
FindWeixinpassword | 查询微信密码信息
FindWeixinpasswords | 微信支付密码集合
GetPddComparisonFeeRate | 获取查询拼多多比价佣金的扣除后的计算佣金
GetTbComparisonFeeRate | 获取查询阿里比价佣金的扣除后的计算佣金
SaveOrUpdate(SqlSugarClient, fl_adzone_info) | 添加/修改推广位信息
SaveOrUpdate(SqlSugarClient, fl_alimama_tlj_get_record) | 添加/修改阿里淘礼金记录
SaveOrUpdate(SqlSugarClient, fl_cps_member) | 添加/修改cps对象
SaveOrUpdate(SqlSugarClient, fl_dictionary_item) | 添加/修改配置
SaveOrUpdate(SqlSugarClient, fl_group_person) | 添加/修改群管理
SaveOrUpdate(SqlSugarClient, fl_member_group) | 添加/修改会员分组
SaveOrUpdate(SqlSugarClient, fl_order_alimama) | 添加/修改阿里订单
SaveOrUpdate(SqlSugarClient, fl_order_douyin) | 添加/修改抖音订单
SaveOrUpdate(SqlSugarClient, fl_order_jingdong) | 添加/修改京东订单
SaveOrUpdate(SqlSugarClient, fl_order_pinduoduo) | 添加/修改拼多多订单
SaveOrUpdate(SqlSugarClient, fl_order_refund_alimama) | 添加/修改订单维权
SaveOrUpdate(SqlSugarClient, fl_order_sleep) | 添加/修改订单冻结规则
SaveOrUpdate(SqlSugarClient, fl_order_weipinhui) | 添加/修改唯品会订单
SaveOrUpdate(SqlSugarClient, fl_ratio_info) | 添加/修改分出比例
SaveOrUpdate(SqlSugarClient, fl_robot_info) | 添加/修改机器人对象
SaveOrUpdate(SqlSugarClient, fl_weixin_password) | 添加/修改微信支付信息
SaveOrUpdate(SqlSugarClient, fl_member_info, Boolean) | 添加/修改用户对象
TemporaryBypassedBlack | 15天内被拉黑过的用户不拉黑
UpdateMemberGroup | 更新用户所在分组
UpdateRecord | 记录用户基础记录(商品查询次数)
Top
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.AddTljCreateNum 方法

ModelExtendAddTljCreateNum 方法

累加淘礼金创建次数

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void AddTljCreateNum(
    this SqlSugarClient session,
    string cpsname
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.AddTljCreateNum(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

cpsname
类型：SystemString
cps账号

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.ChangePoint 方法

ModelExtendChangePoint 方法

改变积分

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_member_info ChangePoint(
    this SqlSugarClient session,
    PointType type,
    double money,
    long memberid,
    string message,
    string pointType_name = ""
)

参数

session
类型：SqlSugarClient
数据库操作对象
type
类型：Api.Framework.EnumsPointType
类型
money
类型：SystemDouble
金额(单位:元)
memberid
类型：SystemInt64
用户id
message
类型：SystemString
备注
pointType_name (Optional)
类型：SystemString
自定义积分类型(为空即可)

返回值

类型：fl_member_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.CheckIsTljOrder 方法

ModelExtendCheckIsTljOrder 方法

通过推广位id判断是否为淘礼金订单

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool CheckIsTljOrder(
    this SqlSugarClient session,
    string adzone_id
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.CheckIsTljOrder(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

adzone_id
类型：SystemString
推广位id

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.Delete 方法

ModelExtendDelete 方法

重载列表
名称 | 说明
Delete(SqlSugarClient, fl_cps_member) | 删除cps对象
Delete(SqlSugarClient, fl_member_group) | 删除会员分组
Top
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.Delete 方法 (SqlSugarClient, fl_cps_member)

ModelExtendDelete 方法 (SqlSugarClient, fl_cps_member)

删除cps对象

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Delete(
    this SqlSugarClient session,
    fl_cps_member obj
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.Delete(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_cps_member)" 的 <param name="session"/> 文档]

obj
类型：Api.Framework.Modelfl_cps_member
cps对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Delete 重载
Api.Framework.Model 命名空间


ModelExtend.Delete 方法 (SqlSugarClient, fl_member_group)

ModelExtendDelete 方法 (SqlSugarClient, fl_member_group)

删除会员分组

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Delete(
    this SqlSugarClient session,
    fl_member_group obj
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.Delete(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_member_group)" 的 <param name="session"/> 文档]

obj
类型：Api.Framework.Modelfl_member_group
会员分组

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Delete 重载
Api.Framework.Model 命名空间


ModelExtend.FindAdzoneGroups 方法

ModelExtendFindAdzoneGroups 方法

获得推广位组信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_adzone_group> FindAdzoneGroups(
    this SqlSugarClient session,
    CpsType type,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindAdzoneGroups(SqlSugar.SqlSugarClient,Api.Framework.Enums.CpsType,System.Boolean)" 的 <param name="session"/> 文档]

type
类型：Api.Framework.EnumsCpsType
cps类型
refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_adzone_group

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindAdzoneInfos 方法

ModelExtendFindAdzoneInfos 方法

获取推广位集合

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_adzone_info> FindAdzoneInfos(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindAdzoneInfos(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_adzone_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindAlimamaAutoBindPid 方法

ModelExtendFindAlimamaAutoBindPid 方法

查询淘宝自动绑定PID集合

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_adzone_info> FindAlimamaAutoBindPid(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindAlimamaAutoBindPid(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
true刷新

返回值

类型：List fl_adzone_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindAlimamaOrderLastnums 方法

ModelExtendFindAlimamaOrderLastnums 方法

扩展方法订单尾号集合缓存

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_alimama_order_lastnum> FindAlimamaOrderLastnums(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindAlimamaOrderLastnums(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Model.ModelExtend.FindAlimamaOrderLastnums(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：List fl_alimama_order_lastnum

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindAlimamaPrivatePid 方法

ModelExtendFindAlimamaPrivatePid 方法

阿里私人推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_adzone_info> FindAlimamaPrivatePid(
    this SqlSugarClient session,
    string adzone_id
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindAlimamaPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

adzone_id
类型：SystemString

[缺少 "M:Api.Framework.Model.ModelExtend.FindAlimamaPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="adzone_id"/> 文档]

返回值

类型：List fl_adzone_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindAlimamaTailBindPid 方法

ModelExtendFindAlimamaTailBindPid 方法

尾号绑定.非订单查询绑定(朋友圈等其他推广)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_adzone_info> FindAlimamaTailBindPid(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindAlimamaTailBindPid(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Model.ModelExtend.FindAlimamaTailBindPid(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：List fl_adzone_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindBindCache 方法

ModelExtendFindBindCache 方法

读取绑定记录

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_bind_cache FindBindCache(
    this SqlSugarClient session,
    string orderid,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindBindCache(SqlSugar.SqlSugarClient,System.String,System.Boolean)" 的 <param name="session"/> 文档]

orderid
类型：SystemString
订单编号
refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：fl_bind_cache

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindBlacklistMemberInfos 方法

ModelExtendFindBlacklistMemberInfos 方法

获取黑名单用户信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_member_info> FindBlacklistMemberInfos(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindBlacklistMemberInfos(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Model.ModelExtend.FindBlacklistMemberInfos(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：List fl_member_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindCreateInfo 方法

ModelExtendFindCreateInfo 方法

获得创建者信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_group_person FindCreateInfo(
    this SqlSugarClient session,
    string groupid,
    ChatType type,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindCreateInfo(SqlSugar.SqlSugarClient,System.String,Api.Framework.SDK.ChatType,System.Boolean)" 的 <param name="session"/> 文档]

groupid
类型：SystemString
群号
type
类型：Api.Framework.SDKChatType
类型
refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：fl_group_person

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindDictionaryItem 方法

ModelExtendFindDictionaryItem 方法

通过文件key,获取配置文件

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_dictionary_item FindDictionaryItem(
    this SqlSugarClient session,
    string key,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindDictionaryItem(SqlSugar.SqlSugarClient,System.String,System.Boolean)" 的 <param name="session"/> 文档]

key
类型：SystemString
配置文件的名称
refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：fl_dictionary_item

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindDictionaryItems 方法

ModelExtendFindDictionaryItems 方法

获取软件与插件的Config的配置

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_dictionary_item> FindDictionaryItems(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindDictionaryItems(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_dictionary_item

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindDouyinAutoBindPid 方法

ModelExtendFindDouyinAutoBindPid 方法

抖音推广位自动绑定推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<string> FindDouyinAutoBindPid(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindDouyinAutoBindPid(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List String

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindDouyinPrivatePid 方法

ModelExtendFindDouyinPrivatePid 方法

抖音私人推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_adzone_info> FindDouyinPrivatePid(
    this SqlSugarClient session,
    string adzone_id
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindDouyinPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

adzone_id
类型：SystemString

[缺少 "M:Api.Framework.Model.ModelExtend.FindDouyinPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="adzone_id"/> 文档]

返回值

类型：List fl_adzone_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindGroup 方法

ModelExtendFindGroup 方法

重载列表
名称 | 说明
FindGroup(SqlSugarClient, fl_member_info) | 获得用户组
FindGroup(SqlSugarClient, Int64) | 获得会员组
FindGroup(SqlSugarClient, String) | 获得会员组
FindGroup(SqlSugarClient, Double, Int64) | 根据消费总积分获得会员组
Top
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindGroup 方法 (SqlSugarClient, fl_member_info)

ModelExtendFindGroup 方法 (SqlSugarClient, fl_member_info)

获得用户组

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_member_group FindGroup(
    this SqlSugarClient session,
    fl_member_info member
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindGroup(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_member_info)" 的 <param name="session"/> 文档]

member
类型：Api.Framework.Modelfl_member_info
根据会员表

返回值

类型：fl_member_group

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
FindGroup 重载
Api.Framework.Model 命名空间


ModelExtend.FindGroup 方法 (SqlSugarClient, Int64)

ModelExtendFindGroup 方法 (SqlSugarClient, Int64)

获得会员组

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_member_group FindGroup(
    this SqlSugarClient session,
    long id
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindGroup(SqlSugar.SqlSugarClient,System.Int64)" 的 <param name="session"/> 文档]

id
类型：SystemInt64
会员组id

返回值

类型：fl_member_group

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
FindGroup 重载
Api.Framework.Model 命名空间


ModelExtend.FindGroup 方法 (SqlSugarClient, String)

ModelExtendFindGroup 方法 (SqlSugarClient, String)

获得会员组

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_member_group FindGroup(
    this SqlSugarClient session,
    string group_name
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindGroup(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

group_name
类型：SystemString
根据组名称

返回值

类型：fl_member_group

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
FindGroup 重载
Api.Framework.Model 命名空间


ModelExtend.FindGroup 方法 (SqlSugarClient, Double, Int64)

ModelExtendFindGroup 方法 (SqlSugarClient, Double, Int64)

根据消费总积分获得会员组

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_member_group FindGroup(
    this SqlSugarClient session,
    double sum_point,
    long bind_order
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindGroup(SqlSugar.SqlSugarClient,System.Double,System.Int64)" 的 <param name="session"/> 文档]

sum_point
类型：SystemDouble
消费总积分
bind_order
类型：SystemInt64
绑定订单数

返回值

类型：fl_member_group

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
FindGroup 重载
Api.Framework.Model 命名空间


ModelExtend.FindGroups 方法

ModelExtendFindGroups 方法

获取会员组列表

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_member_group> FindGroups(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindGroups(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_member_group

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindItemPoint 方法

ModelExtendFindItemPoint 方法

获得商品积分

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ItemPoint FindItemPoint(
    this SqlSugarClient session,
    fl_member_info member,
    double _commission,
    int buy_count,
    CpsType type
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindItemPoint(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_member_info,System.Double,System.Int32,Api.Framework.Enums.CpsType)" 的 <param name="session"/> 文档]

member
类型：Api.Framework.Modelfl_member_info
用户对象
_commission
类型：SystemDouble
佣金
buy_count
类型：SystemInt32
购买数量
type
类型：Api.Framework.EnumsCpsType
cps类型

返回值

类型：ItemPoint

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindJingdongAutoBindPid 方法

ModelExtendFindJingdongAutoBindPid 方法

京东推广位自动绑定推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<string> FindJingdongAutoBindPid(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindJingdongAutoBindPid(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List String

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindJingdongPrivatePid 方法

ModelExtendFindJingdongPrivatePid 方法

京东私人推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_adzone_info> FindJingdongPrivatePid(
    this SqlSugarClient session,
    string adzone_id
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindJingdongPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

adzone_id
类型：SystemString

[缺少 "M:Api.Framework.Model.ModelExtend.FindJingdongPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="adzone_id"/> 文档]

返回值

类型：List fl_adzone_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindMemberinfo 方法

ModelExtendFindMemberinfo 方法

获得会员数据

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_member_info FindMemberinfo(
    this SqlSugarClient session,
    ReciveIMEvent e
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindMemberinfo(SqlSugar.SqlSugarClient,Api.Framework.SDK.ReciveIMEvent)" 的 <param name="session"/> 文档]

e
类型：Api.Framework.SDKReciveIMEvent
通用IM消息

返回值

类型：fl_member_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindMemberInfoById 方法

ModelExtendFindMemberInfoById 方法

通过用户id查询用户对象

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_member_info FindMemberInfoById(
    this SqlSugarClient session,
    long uid
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindMemberInfoById(SqlSugar.SqlSugarClient,System.Int64)" 的 <param name="session"/> 文档]

uid
类型：SystemInt64
用户id

返回值

类型：fl_member_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindMemberInfoByUsername 方法

ModelExtendFindMemberInfoByUsername 方法

通过用户账号查询用户对象

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_member_info FindMemberInfoByUsername(
    this SqlSugarClient session,
    string username
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindMemberInfoByUsername(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

username
类型：SystemString
用户账号

返回值

类型：fl_member_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindNoticeapiRobots 方法

ModelExtendFindNoticeapiRobots 方法

获取通知Robots

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_noticeapi_info> FindNoticeapiRobots(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindNoticeapiRobots(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_noticeapi_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindPinduoduoAutoBindPid 方法

ModelExtendFindPinduoduoAutoBindPid 方法

拼多多推广位自动绑定推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<string> FindPinduoduoAutoBindPid(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindPinduoduoAutoBindPid(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List String

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindPinduoduoPrivatePid 方法

ModelExtendFindPinduoduoPrivatePid 方法

拼多多私人推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_adzone_info> FindPinduoduoPrivatePid(
    this SqlSugarClient session,
    string adzone_id
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindPinduoduoPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

adzone_id
类型：SystemString

[缺少 "M:Api.Framework.Model.ModelExtend.FindPinduoduoPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="adzone_id"/> 文档]

返回值

类型：List fl_adzone_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindRatio 方法

ModelExtendFindRatio 方法

根据金额获得佣金比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_ratio_info FindRatio(
    this SqlSugarClient session,
    CpsType type,
    double commission
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindRatio(SqlSugar.SqlSugarClient,Api.Framework.Enums.CpsType,System.Double)" 的 <param name="session"/> 文档]

type
类型：Api.Framework.EnumsCpsType
cps类型
commission
类型：SystemDouble
佣金

返回值

类型：fl_ratio_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindRatios 方法

ModelExtendFindRatios 方法

获得积分列表

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_ratio_info> FindRatios(
    this SqlSugarClient session,
    CpsType type,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindRatios(SqlSugar.SqlSugarClient,Api.Framework.Enums.CpsType,System.Boolean)" 的 <param name="session"/> 文档]

type
类型：Api.Framework.EnumsCpsType
cps类型
refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_ratio_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindRobotInfo 方法

ModelExtendFindRobotInfo 方法

获得机器人信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_robot_info FindRobotInfo(
    this SqlSugarClient session,
    string robot_name,
    ChatType robot_type,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindRobotInfo(SqlSugar.SqlSugarClient,System.String,Api.Framework.SDK.ChatType,System.Boolean)" 的 <param name="session"/> 文档]

robot_name
类型：SystemString

[缺少 "M:Api.Framework.Model.ModelExtend.FindRobotInfo(SqlSugar.SqlSugarClient,System.String,Api.Framework.SDK.ChatType,System.Boolean)" 的 <param name="robot_name"/> 文档]

robot_type
类型：Api.Framework.SDKChatType
机器人平台类型
refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：fl_robot_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindRobots 方法

ModelExtendFindRobots 方法

获取机器人集合

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_robot_info> FindRobots(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindRobots(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_robot_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindSleep 方法

ModelExtendFindSleep 方法

获得延迟冻结时间

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_order_sleep FindSleep(
    this SqlSugarClient session,
    CpsType type,
    double commission
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindSleep(SqlSugar.SqlSugarClient,Api.Framework.Enums.CpsType,System.Double)" 的 <param name="session"/> 文档]

type
类型：Api.Framework.EnumsCpsType
cps类型
commission
类型：SystemDouble
佣金

返回值

类型：fl_order_sleep

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindSleeps 方法

ModelExtendFindSleeps 方法

获得延迟冻结信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_order_sleep> FindSleeps(
    this SqlSugarClient session,
    CpsType type,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindSleeps(SqlSugar.SqlSugarClient,Api.Framework.Enums.CpsType,System.Boolean)" 的 <param name="session"/> 文档]

type
类型：Api.Framework.EnumsCpsType
cps类型
refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_order_sleep

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindStatisticsRecord 方法

ModelExtendFindStatisticsRecord 方法

查询用户基础记录

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_statistics_record FindStatisticsRecord(
    this SqlSugarClient session,
    long uid
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindStatisticsRecord(SqlSugar.SqlSugarClient,System.Int64)" 的 <param name="session"/> 文档]

uid
类型：SystemInt64
用户id

返回值

类型：fl_statistics_record

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindTbRelations 方法

ModelExtendFindTbRelations 方法

获取eid(关系)集合

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_tb_relation> FindTbRelations(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindTbRelations(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_tb_relation

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindTljByItemid 方法

ModelExtendFindTljByItemid 方法

通过阿里商品id获取已经创建的淘礼金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_alimama_tlj_get_record FindTljByItemid(
    this SqlSugarClient session,
    string itemid
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindTljByItemid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

itemid
类型：SystemString
商品id

返回值

类型：fl_alimama_tlj_get_record

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindTljCreateNum 方法

ModelExtendFindTljCreateNum 方法

检测淘宝账号是否符合创建淘礼金(淘礼金每天创建30个)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool FindTljCreateNum(
    this SqlSugarClient session,
    string cpsname
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindTljCreateNum(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

cpsname
类型：SystemString
cps账号

返回值

类型：Boolean
返回true

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindTljInfos 方法

ModelExtendFindTljInfos 方法

获取所有的淘宝淘礼金信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_alimama_tlj_info> FindTljInfos(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindTljInfos(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_alimama_tlj_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindUserVariates 方法

ModelExtendFindUserVariates 方法

获得用户自定义变量信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_uservariate_info> FindUserVariates(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindUserVariates(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List fl_uservariate_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindWeipinhuiAutoBindPid 方法

ModelExtendFindWeipinhuiAutoBindPid 方法

唯品会推广位自动绑定推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<string> FindWeipinhuiAutoBindPid(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindWeipinhuiAutoBindPid(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：List String

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindWeipinhuiPrivatePid 方法

ModelExtendFindWeipinhuiPrivatePid 方法

唯品会私人推广位

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_adzone_info> FindWeipinhuiPrivatePid(
    this SqlSugarClient session,
    string adzone_id
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindWeipinhuiPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

adzone_id
类型：SystemString

[缺少 "M:Api.Framework.Model.ModelExtend.FindWeipinhuiPrivatePid(SqlSugar.SqlSugarClient,System.String)" 的 <param name="adzone_id"/> 文档]

返回值

类型：List fl_adzone_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindWeixinpassword 方法

ModelExtendFindWeixinpassword 方法

查询微信密码信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_weixin_password FindWeixinpassword(
    this SqlSugarClient session,
    long robot_id,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindWeixinpassword(SqlSugar.SqlSugarClient,System.Int64,System.Boolean)" 的 <param name="session"/> 文档]

robot_id
类型：SystemInt64

[缺少 "M:Api.Framework.Model.ModelExtend.FindWeixinpassword(SqlSugar.SqlSugarClient,System.Int64,System.Boolean)" 的 <param name="robot_id"/> 文档]

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Model.ModelExtend.FindWeixinpassword(SqlSugar.SqlSugarClient,System.Int64,System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：fl_weixin_password

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.FindWeixinpasswords 方法

ModelExtendFindWeixinpasswords 方法

微信支付密码集合

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<fl_weixin_password> FindWeixinpasswords(
    this SqlSugarClient session,
    bool refresh = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.FindWeixinpasswords(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="session"/> 文档]

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Model.ModelExtend.FindWeixinpasswords(SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：List fl_weixin_password

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.GetPddComparisonFeeRate 方法

ModelExtendGetPddComparisonFeeRate 方法

获取查询拼多多比价佣金的扣除后的计算佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static double GetPddComparisonFeeRate(
    this SqlSugarClient session,
    double commission
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.GetPddComparisonFeeRate(SqlSugar.SqlSugarClient,System.Double)" 的 <param name="session"/> 文档]

commission
类型：SystemDouble
正常佣金

返回值

类型：Double

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.GetTbComparisonFeeRate 方法

ModelExtendGetTbComparisonFeeRate 方法

获取查询阿里比价佣金的扣除后的计算佣金

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static double GetTbComparisonFeeRate(
    this SqlSugarClient session,
    fl_order_alimama order
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.GetTbComparisonFeeRate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_alimama)" 的 <param name="session"/> 文档]

order
类型：Api.Framework.Modelfl_order_alimama
阿里订单

返回值

类型：Double

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法

ModelExtendSaveOrUpdate 方法

重载列表
名称 | 说明
SaveOrUpdate(SqlSugarClient, fl_adzone_info) | 添加/修改推广位信息
SaveOrUpdate(SqlSugarClient, fl_alimama_tlj_get_record) | 添加/修改阿里淘礼金记录
SaveOrUpdate(SqlSugarClient, fl_cps_member) | 添加/修改cps对象
SaveOrUpdate(SqlSugarClient, fl_dictionary_item) | 添加/修改配置
SaveOrUpdate(SqlSugarClient, fl_group_person) | 添加/修改群管理
SaveOrUpdate(SqlSugarClient, fl_member_group) | 添加/修改会员分组
SaveOrUpdate(SqlSugarClient, fl_order_alimama) | 添加/修改阿里订单
SaveOrUpdate(SqlSugarClient, fl_order_douyin) | 添加/修改抖音订单
SaveOrUpdate(SqlSugarClient, fl_order_jingdong) | 添加/修改京东订单
SaveOrUpdate(SqlSugarClient, fl_order_pinduoduo) | 添加/修改拼多多订单
SaveOrUpdate(SqlSugarClient, fl_order_refund_alimama) | 添加/修改订单维权
SaveOrUpdate(SqlSugarClient, fl_order_sleep) | 添加/修改订单冻结规则
SaveOrUpdate(SqlSugarClient, fl_order_weipinhui) | 添加/修改唯品会订单
SaveOrUpdate(SqlSugarClient, fl_ratio_info) | 添加/修改分出比例
SaveOrUpdate(SqlSugarClient, fl_robot_info) | 添加/修改机器人对象
SaveOrUpdate(SqlSugarClient, fl_weixin_password) | 添加/修改微信支付信息
SaveOrUpdate(SqlSugarClient, fl_member_info, Boolean) | 添加/修改用户对象
Top
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_adzone_info)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_adzone_info)

添加/修改推广位信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_adzone_info model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_adzone_info)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_adzone_info
推广位对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_alimama_tlj_get_record)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_alimama_tlj_get_record)

添加/修改阿里淘礼金记录

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_alimama_tlj_get_record model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_alimama_tlj_get_record)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_alimama_tlj_get_record
阿里淘礼金记录对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_cps_member)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_cps_member)

添加/修改cps对象

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_cps_member model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_cps_member)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_cps_member

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_cps_member)" 的 <param name="model"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_dictionary_item)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_dictionary_item)

添加/修改配置

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_dictionary_item model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_dictionary_item)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_dictionary_item
配置对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_group_person)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_group_person)

添加/修改群管理

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_group_person model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_group_person)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_group_person
群管理对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_member_group)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_member_group)

添加/修改会员分组

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_member_group model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_member_group)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_member_group
会员分组对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_order_alimama)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_order_alimama)

添加/修改阿里订单

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_order_alimama model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_alimama)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_order_alimama
阿里订单对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_order_douyin)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_order_douyin)

添加/修改抖音订单

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_order_douyin model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_douyin)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_order_douyin
抖音订单对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_order_jingdong)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_order_jingdong)

添加/修改京东订单

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_order_jingdong model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_jingdong)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_order_jingdong
京东订单对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_order_pinduoduo)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_order_pinduoduo)

添加/修改拼多多订单

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_order_pinduoduo model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_pinduoduo)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_order_pinduoduo
拼多多订单对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_order_refund_alimama)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_order_refund_alimama)

添加/修改订单维权

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_order_refund_alimama model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_refund_alimama)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_order_refund_alimama

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_refund_alimama)" 的 <param name="model"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_order_sleep)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_order_sleep)

添加/修改订单冻结规则

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_order_sleep model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_sleep)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_order_sleep
订单冻结规则对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_order_weipinhui)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_order_weipinhui)

添加/修改唯品会订单

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_order_weipinhui model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_weipinhui)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_order_weipinhui
唯品会订单对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_ratio_info)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_ratio_info)

添加/修改分出比例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_ratio_info model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_ratio_info)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_ratio_info
分出比例对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_robot_info)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_robot_info)

添加/修改机器人对象

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_robot_info model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_robot_info)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_robot_info
机器人对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_weixin_password)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_weixin_password)

添加/修改微信支付信息

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_weixin_password model
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_weixin_password)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_weixin_password
微信支付信息对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.SaveOrUpdate 方法 (SqlSugarClient, fl_member_info, Boolean)

ModelExtendSaveOrUpdate 方法 (SqlSugarClient, fl_member_info, Boolean)

添加/修改用户对象

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveOrUpdate(
    this SqlSugarClient session,
    fl_member_info model,
    bool all = false
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.SaveOrUpdate(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_member_info,System.Boolean)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Modelfl_member_info
用户对象
all (Optional)
类型：SystemBoolean
false:只修改关键信息

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
SaveOrUpdate 重载
Api.Framework.Model 命名空间


ModelExtend.TemporaryBypassedBlack 方法

ModelExtendTemporaryBypassedBlack 方法

15天内被拉黑过的用户不拉黑

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool TemporaryBypassedBlack(
    this SqlSugarClient session,
    fl_member_info member
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.TemporaryBypassedBlack(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_member_info)" 的 <param name="session"/> 文档]

member
类型：Api.Framework.Modelfl_member_info
用户对象

返回值

类型：Boolean
返回true不需要拉黑

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.UpdateMemberGroup 方法

ModelExtendUpdateMemberGroup 方法

更新用户所在分组

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_member_info UpdateMemberGroup(
    this SqlSugarClient session,
    fl_member_info member
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.UpdateMemberGroup(SqlSugar.SqlSugarClient,Api.Framework.Model.fl_member_info)" 的 <param name="session"/> 文档]

member
类型：Api.Framework.Modelfl_member_info
用户对象

返回值

类型：fl_member_info

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


ModelExtend.UpdateRecord 方法

ModelExtendUpdateRecord 方法

记录用户基础记录(商品查询次数)

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void UpdateRecord(
    this SqlSugarClient session,
    long uid
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Model.ModelExtend.UpdateRecord(SqlSugar.SqlSugarClient,System.Int64)" 的 <param name="session"/> 文档]

uid
类型：SystemInt64
用户id

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

ModelExtend 类
Api.Framework.Model 命名空间


NoticeApiType 枚举

通知Api类型

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum NoticeApiType
成员
成员名称 | 值 | 说明
企业钉钉机器人API | 0 |
企业微信机器人API | 1 |
飞书机器人API | 2 |
参见

引用

Api.Framework.Model 命名空间


temp_send_data 类

发送消息临时类
继承层次
SystemObject
Api.Framework.Modeltemp_send_data

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class temp_send_data

temp_send_data 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | temp_send_data | 初始化 temp_send_data 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Groupid | 接收群账号
公共属性 | IsTemp | 如果为QQ这个值一定要赋值,为临时会话时,一定要传true
公共属性 | Message | 消息内容
公共属性 | Robot | 机器人ID
公共属性 | TouserName | 接收者账号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Model 命名空间


temp_send_data 构造函数

初始化 temp_send_data 类的一个新实例

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public temp_send_data()
参见

引用

temp_send_data 类
Api.Framework.Model 命名空间


temp_send_data 属性

temp_send_data 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Groupid | 接收群账号
公共属性 | IsTemp | 如果为QQ这个值一定要赋值,为临时会话时,一定要传true
公共属性 | Message | 消息内容
公共属性 | Robot | 机器人ID
公共属性 | TouserName | 接收者账号
Top
参见

引用

temp_send_data 类
Api.Framework.Model 命名空间


temp_send_data.Groupid 属性

temp_send_dataGroupid 属性

接收群账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Groupid { get; set; }

属性值

类型：String
参见

引用

temp_send_data 类
Api.Framework.Model 命名空间


temp_send_data.IsTemp 属性

temp_send_dataIsTemp 属性

如果为QQ这个值一定要赋值,为临时会话时,一定要传true

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsTemp { get; set; }

属性值

类型：Boolean
参见

引用

temp_send_data 类
Api.Framework.Model 命名空间


temp_send_data.Message 属性

temp_send_dataMessage 属性

消息内容

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; set; }

属性值

类型：String
参见

引用

temp_send_data 类
Api.Framework.Model 命名空间


temp_send_data.Robot 属性

temp_send_dataRobot 属性

机器人ID

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_robot_info Robot { get; set; }

属性值

类型：fl_robot_info
参见

引用

temp_send_data 类
Api.Framework.Model 命名空间


temp_send_data.TouserName 属性

temp_send_dataTouserName 属性

接收者账号

命名空间： Api.Framework.Model
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string TouserName { get; set; }

属性值

类型：String
参见

引用

temp_send_data 类
Api.Framework.Model 命名空间


temp_send_data 方法

temp_send_data 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

temp_send_data 类
Api.Framework.Model 命名空间


Api.Framework.SDK 命名空间

[缺少 "N:Api.Framework.SDK" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | ConfigAttribute | 配置文件属性
公共类 | MemberPointChangeEvent | 用户积分变动事件
公共类 | ParamAttribute | 配置属性
公共类 | Plugin | 插件基础类 - 插件开发继承后重写
公共类 | PluginExtend | 插件扩展类
公共类 | PluginVersion | 插件版本
公共类 | ReciveIMEvent | 通用消息事件
公共类 | SDKEvent | SDK事件管理
公共类 | TimerTask | 定时器
枚举
 | 枚举 | 说明
公共枚举 | ChatType | 平台类型


ChatType 枚举

平台类型

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum ChatType
成员
成员名称 | 值 | 说明
未知来源 | 0 |
QQ | 1 |
微信 | 2 |
微信公众号 | 3 |
企业微信 | 4 |
参见

引用

Api.Framework.SDK 命名空间


ConfigAttribute 类

配置文件属性
继承层次
SystemObject
SystemAttribute
Api.Framework.SDKConfigAttribute

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ConfigAttribute : Attribute

ConfigAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ConfigAttribute | 初始化 ConfigAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | EncKey | 16位密钥 - 不填写则使用系统秘钥
公共属性 | IsEncryption | 是否加密数据信息 默认为False
公共属性 | IsSaveDB | 是否存档到数据库
公共属性 | Name | 保存的文件名
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.SDK 命名空间


ConfigAttribute 构造函数

初始化 ConfigAttribute 类的一个新实例

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ConfigAttribute()
参见

引用

ConfigAttribute 类
Api.Framework.SDK 命名空间


ConfigAttribute 属性

ConfigAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | EncKey | 16位密钥 - 不填写则使用系统秘钥
公共属性 | IsEncryption | 是否加密数据信息 默认为False
公共属性 | IsSaveDB | 是否存档到数据库
公共属性 | Name | 保存的文件名
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

ConfigAttribute 类
Api.Framework.SDK 命名空间


ConfigAttribute.EncKey 属性

ConfigAttributeEncKey 属性

16位密钥 - 不填写则使用系统秘钥

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] EncKey { get; set; }

属性值

类型：Byte
参见

引用

ConfigAttribute 类
Api.Framework.SDK 命名空间


ConfigAttribute.IsEncryption 属性

ConfigAttributeIsEncryption 属性

是否加密数据信息 默认为False

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsEncryption { get; set; }

属性值

类型：Boolean
参见

引用

ConfigAttribute 类
Api.Framework.SDK 命名空间


ConfigAttribute.IsSaveDB 属性

ConfigAttributeIsSaveDB 属性

是否存档到数据库

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsSaveDB { get; set; }

属性值

类型：Boolean
参见

引用

ConfigAttribute 类
Api.Framework.SDK 命名空间


ConfigAttribute.Name 属性

ConfigAttributeName 属性

保存的文件名

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Name { get; set; }

属性值

类型：String
参见

引用

ConfigAttribute 类
Api.Framework.SDK 命名空间


ConfigAttribute 方法

ConfigAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ConfigAttribute 类
Api.Framework.SDK 命名空间


MemberPointChangeEvent 类

用户积分变动事件
继承层次
SystemObject
SystemEventArgs
Api.Framework.EventsBaseEvents
Api.Framework.SDKMemberPointChangeEvent

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class MemberPointChangeEvent : BaseEvents

MemberPointChangeEvent 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | MemberPointChangeEvent | 初始化 MemberPointChangeEvent 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | Point | 修改积分信息
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.SDK 命名空间


MemberPointChangeEvent 构造函数

初始化 MemberPointChangeEvent 类的一个新实例

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public MemberPointChangeEvent(
    fl_point_hist point
)

参数

point
类型：Api.Framework.Modelfl_point_hist

[缺少 "M:Api.Framework.SDK.MemberPointChangeEvent.#ctor(Api.Framework.Model.fl_point_hist)" 的 <param name="point"/> 文档]

参见

引用

MemberPointChangeEvent 类
Api.Framework.SDK 命名空间


MemberPointChangeEvent 属性

MemberPointChangeEvent 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | Point | 修改积分信息
Top
参见

引用

MemberPointChangeEvent 类
Api.Framework.SDK 命名空间


MemberPointChangeEvent.Point 属性

MemberPointChangeEventPoint 属性

修改积分信息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_point_hist Point { get; }

属性值

类型：fl_point_hist
参见

引用

MemberPointChangeEvent 类
Api.Framework.SDK 命名空间


MemberPointChangeEvent 方法

MemberPointChangeEvent 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

MemberPointChangeEvent 类
Api.Framework.SDK 命名空间


ParamAttribute 类

配置属性
继承层次
SystemObject
SystemAttribute
Api.Framework.SDKParamAttribute

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ParamAttribute : Attribute

ParamAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ParamAttribute | 初始化 ParamAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Describe | 描述信息
公共属性 | Tags | 标签信息 - 一般表示变量
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.SDK 命名空间


ParamAttribute 构造函数

初始化 ParamAttribute 类的一个新实例

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ParamAttribute()
参见

引用

ParamAttribute 类
Api.Framework.SDK 命名空间


ParamAttribute 属性

ParamAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Describe | 描述信息
公共属性 | Tags | 标签信息 - 一般表示变量
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

ParamAttribute 类
Api.Framework.SDK 命名空间


ParamAttribute.Describe 属性

ParamAttributeDescribe 属性

描述信息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Describe { get; set; }

属性值

类型：String
参见

引用

ParamAttribute 类
Api.Framework.SDK 命名空间


ParamAttribute.Tags 属性

ParamAttributeTags 属性

标签信息 - 一般表示变量

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string[] Tags { get; set; }

属性值

类型：String
参见

引用

ParamAttribute 类
Api.Framework.SDK 命名空间


ParamAttribute 方法

ParamAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ParamAttribute 类
Api.Framework.SDK 命名空间


Plugin 类

插件基础类 - 插件开发继承后重写
继承层次
SystemObject
Api.Framework.SDKPlugin

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Plugin : IDisposable, IComparable

Plugin 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Plugin | 初始化 Plugin 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CurVersion | 当前版本号
公共属性 | FilePath | 文件路径
公共属性 | IsRun |
公共属性 | Level | 插件顺序
公共属性 | Logo | 插件图标
公共属性 | Md5 | 插件MD5信息
公共属性 | Name | 插件名称
公共属性 | Note | 插件简介
公共属性 | SDK | 事件
公共属性 | VersionXML | XML版本信息
Top
方法
 | 名称 | 说明
公共方法 | CompareTo |
公共方法 | Dispose | 释放被 Plugin 使用的所有资源
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ShowForm | 窗体
公共方法 | Start | 启动
公共方法 | Stop | 停用
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | OnLog | 输出日志 (由 PluginExtend 定义。)
公共扩展器方法 | ReadConfigT | 读入配置 (由 PluginExtend 定义。)
公共扩展器方法 | SaveConfig | 保存配置 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.SDK 命名空间


Plugin 构造函数

初始化 Plugin 类的一个新实例

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Plugin()
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin 属性

Plugin 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CurVersion | 当前版本号
公共属性 | FilePath | 文件路径
公共属性 | IsRun |
公共属性 | Level | 插件顺序
公共属性 | Logo | 插件图标
公共属性 | Md5 | 插件MD5信息
公共属性 | Name | 插件名称
公共属性 | Note | 插件简介
公共属性 | SDK | 事件
公共属性 | VersionXML | XML版本信息
Top
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.CurVersion 属性

PluginCurVersion 属性

当前版本号

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Version CurVersion { get; }

属性值

类型：Version
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.FilePath 属性

PluginFilePath 属性

文件路径

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string FilePath { get; }

属性值

类型：String
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.IsRun 属性

PluginIsRun 属性

[缺少 "P:Api.Framework.SDK.Plugin.IsRun" 的 <summary> 文档]

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsRun { get; }

属性值

类型：Boolean
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.Level 属性

PluginLevel 属性

插件顺序

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Level { get; }

属性值

类型：Int32
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.Logo 属性

PluginLogo 属性

插件图标

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Image Logo { get; set; }

属性值

类型：Image
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.Md5 属性

PluginMd5 属性

插件MD5信息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Md5 { get; }

属性值

类型：String
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.Name 属性

PluginName 属性

插件名称

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Name { get; set; }

属性值

类型：String
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.Note 属性

PluginNote 属性

插件简介

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Note { get; set; }

属性值

类型：String
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.SDK 属性

PluginSDK 属性

事件

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SDKEvent SDK { get; }

属性值

类型：SDKEvent
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.VersionXML 属性

PluginVersionXML 属性

XML版本信息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string VersionXML { get; set; }

属性值

类型：String
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin 方法

Plugin 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CompareTo |
公共方法 | Dispose |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ShowForm | 窗体
公共方法 | Start | 启动
公共方法 | Stop | 停用
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | OnLog | 输出日志 (由 PluginExtend 定义。)
公共扩展器方法 | ReadConfigT | 读入配置 (由 PluginExtend 定义。)
公共扩展器方法 | SaveConfig | 保存配置 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.CompareTo 方法

PluginCompareTo 方法

[缺少 "M:Api.Framework.SDK.Plugin.CompareTo(System.Object)" 的 <summary> 文档]

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int CompareTo(
    Object obj
)

参数

obj
类型：SystemObject

[缺少 "M:Api.Framework.SDK.Plugin.CompareTo(System.Object)" 的 <param name="obj"/> 文档]

返回值

类型：Int32

实现

IComparableCompareTo(Object)
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.Dispose 方法

PluginDispose 方法

释放被 Plugin 使用的所有资源

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()

实现

IDisposableDispose
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.ShowForm 方法

PluginShowForm 方法

窗体

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void ShowForm()
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.Start 方法

PluginStart 方法

启动

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void Start()
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


Plugin.Stop 方法

PluginStop 方法

停用

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void Stop()
参见

引用

Plugin 类
Api.Framework.SDK 命名空间


PluginExtend 类

插件扩展类
继承层次
SystemObject
Api.Framework.SDKPluginExtend

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class PluginExtend

PluginExtend 类型公开以下成员。

方法
名称 | 说明
FindPropertyInfo | 反射获取某个对象属性信息
FindPropertyValue | 反射获取某个对象属性的值
OnLog | 输出日志
ReadConfigT | 读入配置
SaveConfig | 保存配置
Top
参见

引用

Api.Framework.SDK 命名空间


PluginExtend 方法

PluginExtend 类型公开以下成员。

方法
名称 | 说明
FindPropertyInfo | 反射获取某个对象属性信息
FindPropertyValue | 反射获取某个对象属性的值
OnLog | 输出日志
ReadConfigT | 读入配置
SaveConfig | 保存配置
Top
参见

引用

PluginExtend 类
Api.Framework.SDK 命名空间


PluginExtend.FindPropertyInfo 方法

PluginExtendFindPropertyInfo 方法

反射获取某个对象属性信息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static PropertyInfo FindPropertyInfo(
    this Object obj,
    string name
)

参数

obj
类型：SystemObject
对象
name
类型：SystemString
对象中的属性

返回值

类型：PropertyInfo

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 Object 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

PluginExtend 类
Api.Framework.SDK 命名空间


PluginExtend.FindPropertyValue 方法

PluginExtendFindPropertyValue 方法

反射获取某个对象属性的值

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Object FindPropertyValue(
    this Object obj,
    string name
)

参数

obj
类型：SystemObject
对象
name
类型：SystemString
对象中的属性

返回值

类型：Object

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 Object 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

PluginExtend 类
Api.Framework.SDK 命名空间


PluginExtend.OnLog 方法

PluginExtendOnLog 方法

输出日志

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void OnLog(
    this Plugin plugin,
    string message
)

参数

plugin
类型：Api.Framework.SDKPlugin

[缺少 "M:Api.Framework.SDK.PluginExtend.OnLog(Api.Framework.SDK.Plugin,System.String)" 的 <param name="plugin"/> 文档]

message
类型：SystemString
日志内容

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 Plugin 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

PluginExtend 类
Api.Framework.SDK 命名空间


PluginExtend.ReadConfig(T) 方法

PluginExtendReadConfigT 方法

读入配置

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T ReadConfig<T>(
    this Plugin plugin
)

参数

plugin
类型：Api.Framework.SDKPlugin

[缺少 "M:Api.Framework.SDK.PluginExtend.ReadConfig``1(Api.Framework.SDK.Plugin)" 的 <param name="plugin"/> 文档]

类型参数

T

返回值

类型：T

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 Plugin 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

PluginExtend 类
Api.Framework.SDK 命名空间


PluginExtend.SaveConfig 方法

PluginExtendSaveConfig 方法

保存配置

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveConfig(
    this Plugin plugin,
    Object obj
)

参数

plugin
类型：Api.Framework.SDKPlugin

[缺少 "M:Api.Framework.SDK.PluginExtend.SaveConfig(Api.Framework.SDK.Plugin,System.Object)" 的 <param name="plugin"/> 文档]

obj
类型：SystemObject
保存的对象

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 Plugin 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

PluginExtend 类
Api.Framework.SDK 命名空间


PluginVersion 类

插件版本
继承层次
SystemObject
Api.Framework.SDKPluginVersion

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PluginVersion

PluginVersion 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PluginVersion | 初始化 PluginVersion 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CurMessage | 当前版本更新内容
公共属性 | CurVersion | 当前版本号
公共属性 | DownURL | 下载地址
公共属性 | SoftVersion | 软件最低版本
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.SDK 命名空间


PluginVersion 构造函数

初始化 PluginVersion 类的一个新实例

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PluginVersion()
参见

引用

PluginVersion 类
Api.Framework.SDK 命名空间


PluginVersion 属性

PluginVersion 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CurMessage | 当前版本更新内容
公共属性 | CurVersion | 当前版本号
公共属性 | DownURL | 下载地址
公共属性 | SoftVersion | 软件最低版本
Top
参见

引用

PluginVersion 类
Api.Framework.SDK 命名空间


PluginVersion.CurMessage 属性

PluginVersionCurMessage 属性

当前版本更新内容

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string CurMessage { get; set; }

属性值

类型：String
参见

引用

PluginVersion 类
Api.Framework.SDK 命名空间


PluginVersion.CurVersion 属性

PluginVersionCurVersion 属性

当前版本号

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Version CurVersion { get; set; }

属性值

类型：Version
参见

引用

PluginVersion 类
Api.Framework.SDK 命名空间


PluginVersion.DownURL 属性

PluginVersionDownURL 属性

下载地址

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DownURL { get; set; }

属性值

类型：String
参见

引用

PluginVersion 类
Api.Framework.SDK 命名空间


PluginVersion.SoftVersion 属性

PluginVersionSoftVersion 属性

软件最低版本

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Version SoftVersion { get; set; }

属性值

类型：Version
参见

引用

PluginVersion 类
Api.Framework.SDK 命名空间


PluginVersion 方法

PluginVersion 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PluginVersion 类
Api.Framework.SDK 命名空间


ReciveIMEvent 类

通用消息事件
继承层次
SystemObject
SystemEventArgs
Api.Framework.EventsBaseEvents
Api.Framework.SDKReciveIMEvent

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ReciveIMEvent : BaseEvents

ReciveIMEvent 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ReciveIMEvent | 通用解析
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | ChatType | 机器人类型
公共属性 | Event | 事件原形
公共属性 | EventType | 事件Type
公共属性 | Groupid | 群号,私聊为空
公共属性 | Message | 消息
公共属性 | NickName | 发送者昵称
公共属性 | RealNick | 发送者原始昵称
公共属性 | RobotInfo | 机器人对象
公共属性 | RobotName | 机器人账号
公共属性 | RobotNick | 机器人账号
公共属性 | Sender | 事件来源(机器人),强转即可 (注:机器人基类为:WeixinBase)
公共属性 | Username | 发送者账号
公共属性 | Wechatid | 微信号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetMemberinfo | 获取用户对象方法
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SendMessage | 发送消息
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.SDK 命名空间


ReciveIMEvent 构造函数

通用解析

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ReciveIMEvent(
    Object Sender,
    Object Event
)

参数

Sender
类型：SystemObject

[缺少 "M:Api.Framework.SDK.ReciveIMEvent.#ctor(System.Object,System.Object)" 的 <param name="Sender"/> 文档]

Event
类型：SystemObject

[缺少 "M:Api.Framework.SDK.ReciveIMEvent.#ctor(System.Object,System.Object)" 的 <param name="Event"/> 文档]

参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent 属性

ReciveIMEvent 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 true:消息将不往后传,false:继续传递 (继承自 BaseEvents。)
公共属性 | ChatType | 机器人类型
公共属性 | Event | 事件原形
公共属性 | EventType | 事件Type
公共属性 | Groupid | 群号,私聊为空
公共属性 | Message | 消息
公共属性 | NickName | 发送者昵称
公共属性 | RealNick | 发送者原始昵称
公共属性 | RobotInfo | 机器人对象
公共属性 | RobotName | 机器人账号
公共属性 | RobotNick | 机器人账号
公共属性 | Sender | 事件来源(机器人),强转即可 (注:机器人基类为:WeixinBase)
公共属性 | Username | 发送者账号
公共属性 | Wechatid | 微信号
Top
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.ChatType 属性

ReciveIMEventChatType 属性

机器人类型

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChatType ChatType { get; }

属性值

类型：ChatType
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.Event 属性

ReciveIMEventEvent 属性

事件原形

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object Event { get; }

属性值

类型：Object
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.EventType 属性

ReciveIMEventEventType 属性

事件Type

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Type EventType { get; }

属性值

类型：Type
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.Groupid 属性

ReciveIMEventGroupid 属性

群号,私聊为空

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Groupid { get; }

属性值

类型：String
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.Message 属性

ReciveIMEventMessage 属性

消息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.NickName 属性

ReciveIMEventNickName 属性

发送者昵称

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string NickName { get; }

属性值

类型：String
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.RealNick 属性

ReciveIMEventRealNick 属性

发送者原始昵称

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string RealNick { get; set; }

属性值

类型：String
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.RobotInfo 属性

ReciveIMEventRobotInfo 属性

机器人对象

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_robot_info RobotInfo { get; }

属性值

类型：fl_robot_info
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.RobotName 属性

ReciveIMEventRobotName 属性

机器人账号

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string RobotName { get; }

属性值

类型：String
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.RobotNick 属性

ReciveIMEventRobotNick 属性

机器人账号

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string RobotNick { get; }

属性值

类型：String
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.Sender 属性

ReciveIMEventSender 属性

事件来源(机器人),强转即可 (注:机器人基类为:WeixinBase)

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object Sender { get; }

属性值

类型：Object
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.Username 属性

ReciveIMEventUsername 属性

发送者账号

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Username { get; }

属性值

类型：String
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.Wechatid 属性

ReciveIMEventWechatid 属性

微信号

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Wechatid { get; set; }

属性值

类型：String
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent 方法

ReciveIMEvent 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetMemberinfo | 获取用户对象方法
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SendMessage | 发送消息
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.GetMemberinfo 方法

ReciveIMEventGetMemberinfo 方法

获取用户对象方法

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_member_info GetMemberinfo(
    bool refresh = false
)

参数

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：fl_member_info
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


ReciveIMEvent.SendMessage 方法

ReciveIMEventSendMessage 方法

发送消息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SendMessage(
    string Message,
    bool SetCancel = true
)

参数

Message
类型：SystemString
发送的消息
SetCancel (Optional)
类型：SystemBoolean
是否取消传递消息给后续插件
参见

引用

ReciveIMEvent 类
Api.Framework.SDK 命名空间


SDKEvent 类

SDK事件管理
继承层次
SystemObject
Api.Framework.SDKSDKEvent

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SDKEvent

SDKEvent 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SDKEvent | 初始化 SDKEvent 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
事件
 | 名称 | 说明
公共事件 | MemberPointChangeEvent | 用户积分变动通知事件
公共事件 | OrderNoticeEvent | 订单通知接口
公共事件 | QQAddMeNeedAuthEvents | 有人添加我为好友,需要审核
公共事件 | QQAddToClusterNeedAuthEvents | 有人申请进群,需要审核
公共事件 | QQNewFriendEvents | 有人添加我为好友
公共事件 | QQNewGroupMemberEvents | QQ群新增成员
公共事件 | QQReceiveFriendMsgEvents | 收到QQ消息
公共事件 | ReciveIMEvent | 通用解析事件
公共事件 | SharedEvent | 共享自定义事件
公共事件 | WebRequestEvent | web请求事件
公共事件 | WXApplyFriendEvent | 微信 - 申请添加我为好友,需要审核
公共事件 | WXApplyGroupEvent | 微信 - 申请进入群,需要审核
公共事件 | WXChangeStatusEvent | 微信 - 在线状态发生改变
公共事件 | WXNewFriendEvent | 微信 - 新增微信好友
公共事件 | WXNewMemerEvent | 微信 - 新增群成员
公共事件 | WXOpenWindowEvent | 打开窗口事件
公共事件 | WXReceiveGroupMsgEvent | 收到微信群消息
公共事件 | WXRefreshContactSuccess | 微信刷新好友成功
公共事件 | WXReiceveFriendMsgEvent | 微信 - 收到微信好友消息
公共事件 | WXReicevePay | 微信收到支付
公共事件 | WXSendMessage | 微信发送消息成功
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.SDK 命名空间


SDKEvent 构造函数

初始化 SDKEvent 类的一个新实例

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SDKEvent(
    Plugin plugin
)

参数

plugin
类型：Api.Framework.SDKPlugin

[缺少 "M:Api.Framework.SDK.SDKEvent.#ctor(Api.Framework.SDK.Plugin)" 的 <param name="plugin"/> 文档]

参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent 方法

SDKEvent 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent 事件

SDKEvent 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | MemberPointChangeEvent | 用户积分变动通知事件
公共事件 | OrderNoticeEvent | 订单通知接口
公共事件 | QQAddMeNeedAuthEvents | 有人添加我为好友,需要审核
公共事件 | QQAddToClusterNeedAuthEvents | 有人申请进群,需要审核
公共事件 | QQNewFriendEvents | 有人添加我为好友
公共事件 | QQNewGroupMemberEvents | QQ群新增成员
公共事件 | QQReceiveFriendMsgEvents | 收到QQ消息
公共事件 | ReciveIMEvent | 通用解析事件
公共事件 | SharedEvent | 共享自定义事件
公共事件 | WebRequestEvent | web请求事件
公共事件 | WXApplyFriendEvent | 微信 - 申请添加我为好友,需要审核
公共事件 | WXApplyGroupEvent | 微信 - 申请进入群,需要审核
公共事件 | WXChangeStatusEvent | 微信 - 在线状态发生改变
公共事件 | WXNewFriendEvent | 微信 - 新增微信好友
公共事件 | WXNewMemerEvent | 微信 - 新增群成员
公共事件 | WXOpenWindowEvent | 打开窗口事件
公共事件 | WXReceiveGroupMsgEvent | 收到微信群消息
公共事件 | WXRefreshContactSuccess | 微信刷新好友成功
公共事件 | WXReiceveFriendMsgEvent | 微信 - 收到微信好友消息
公共事件 | WXReicevePay | 微信收到支付
公共事件 | WXSendMessage | 微信发送消息成功
Top
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.MemberPointChangeEvent 事件

SDKEventMemberPointChangeEvent 事件

用户积分变动通知事件

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<MemberPointChangeEvent> MemberPointChangeEvent

值

类型：SystemEventHandler MemberPointChangeEvent
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.OrderNoticeEvent 事件

SDKEventOrderNoticeEvent 事件

订单通知接口

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<OrderNoticeEvent> OrderNoticeEvent

值

类型：SystemEventHandler OrderNoticeEvent
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.QQAddMeNeedAuthEvents 事件

SDKEventQQAddMeNeedAuthEvents 事件

有人添加我为好友,需要审核

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQAddMeNeedAuthEvents> QQAddMeNeedAuthEvents

值

类型：SystemEventHandler QQAddMeNeedAuthEvents
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.QQAddToClusterNeedAuthEvents 事件

SDKEventQQAddToClusterNeedAuthEvents 事件

有人申请进群,需要审核

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQAddToClusterNeedAuthEvents> QQAddToClusterNeedAuthEvents

值

类型：SystemEventHandler QQAddToClusterNeedAuthEvents
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.QQNewFriendEvents 事件

SDKEventQQNewFriendEvents 事件

有人添加我为好友

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQNewFriendEvents> QQNewFriendEvents

值

类型：SystemEventHandler QQNewFriendEvents
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.QQNewGroupMemberEvents 事件

SDKEventQQNewGroupMemberEvents 事件

QQ群新增成员

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQNewGroupMemberEvents> QQNewGroupMemberEvents

值

类型：SystemEventHandler QQNewGroupMemberEvents
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.QQReceiveFriendMsgEvents 事件

SDKEventQQReceiveFriendMsgEvents 事件

收到QQ消息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQReceiveFriendMsgEvents> QQReceiveFriendMsgEvents

值

类型：SystemEventHandler QQReceiveFriendMsgEvents
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.ReciveIMEvent 事件

SDKEventReciveIMEvent 事件

通用解析事件

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<ReciveIMEvent> ReciveIMEvent

值

类型：SystemEventHandler ReciveIMEvent
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.SharedEvent 事件

SDKEventSharedEvent 事件

共享自定义事件

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<SharedEvents> SharedEvent

值

类型：SystemEventHandler SharedEvents
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WebRequestEvent 事件

SDKEventWebRequestEvent 事件

web请求事件

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WebRequestEvents> WebRequestEvent

值

类型：SystemEventHandler WebRequestEvents
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXApplyFriendEvent 事件

SDKEventWXApplyFriendEvent 事件

微信 - 申请添加我为好友,需要审核

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXApplyFriend> WXApplyFriendEvent

值

类型：SystemEventHandler WXApplyFriend
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXApplyGroupEvent 事件

SDKEventWXApplyGroupEvent 事件

微信 - 申请进入群,需要审核

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXApplyGroup> WXApplyGroupEvent

值

类型：SystemEventHandler WXApplyGroup
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXChangeStatusEvent 事件

SDKEventWXChangeStatusEvent 事件

微信 - 在线状态发生改变

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXChangeStatus> WXChangeStatusEvent

值

类型：SystemEventHandler WXChangeStatus
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXNewFriendEvent 事件

SDKEventWXNewFriendEvent 事件

微信 - 新增微信好友

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXNewFriend> WXNewFriendEvent

值

类型：SystemEventHandler WXNewFriend
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXNewMemerEvent 事件

SDKEventWXNewMemerEvent 事件

微信 - 新增群成员

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXNewMemer> WXNewMemerEvent

值

类型：SystemEventHandler WXNewMemer
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXOpenWindowEvent 事件

SDKEventWXOpenWindowEvent 事件

打开窗口事件

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXOpenWindow> WXOpenWindowEvent

值

类型：SystemEventHandler WXOpenWindow
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXReceiveGroupMsgEvent 事件

SDKEventWXReceiveGroupMsgEvent 事件

收到微信群消息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXReceiveGroupMsg> WXReceiveGroupMsgEvent

值

类型：SystemEventHandler WXReceiveGroupMsg
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXRefreshContactSuccess 事件

SDKEventWXRefreshContactSuccess 事件

微信刷新好友成功

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXRefreshContactSuccess> WXRefreshContactSuccess

值

类型：SystemEventHandler WXRefreshContactSuccess
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXReiceveFriendMsgEvent 事件

SDKEventWXReiceveFriendMsgEvent 事件

微信 - 收到微信好友消息

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXReiceveFriendMsg> WXReiceveFriendMsgEvent

值

类型：SystemEventHandler WXReiceveFriendMsg
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXReicevePay 事件

SDKEventWXReicevePay 事件

微信收到支付

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXReicevePay> WXReicevePay

值

类型：SystemEventHandler WXReicevePay
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


SDKEvent.WXSendMessage 事件

SDKEventWXSendMessage 事件

微信发送消息成功

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXSendMessage> WXSendMessage

值

类型：SystemEventHandler WXSendMessage
参见

引用

SDKEvent 类
Api.Framework.SDK 命名空间


TimerTask 类

定时器
继承层次
SystemObject
Api.Framework.SDKTimerTask
更多...

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public abstract class TimerTask : IDisposable

TimerTask 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | TimerTask | 初始化 TimerTask 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行
受保护的属性 | IsStart |
公共属性 | RegisterdHandler | RegisterdHandler
公共属性 | RunningCount | 运行的数量
公共属性 | WaitHandler | WaitHandler
Top
方法
 | 名称 | 说明
 | CloseT | 关闭一个定时器
公共方法 | Dispose | 销毁方法 - 可以被重写
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetTimerT | 获得定时器
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | NewTimerT(Int32, Object) | 创建一个定时器
 | NewTimerT(T, Int32, Object) |
公共方法 | Run | 运行主体 - 需要重写
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.SDK 命名空间
继承层次
SystemObject
Api.Framework.SDKTimerTask
Api.Framework.TimersClearGarbageTimer
Api.Framework.TimersDownAlimamaTimer
Api.Framework.TimersDownDouyinTimer
Api.Framework.TimersDownJingdongTimer
Api.Framework.TimersDownPinduoduoTimer
Api.Framework.TimersDownWeipinhuiTimer
Api.Framework.TimersUpdate_NoticeQueue


TimerTask 构造函数

初始化 TimerTask 类的一个新实例

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected TimerTask()
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask 属性

TimerTask 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行
受保护的属性 | IsStart |
公共属性 | RegisterdHandler | RegisterdHandler
公共属性 | RunningCount | 运行的数量
公共属性 | WaitHandler | WaitHandler
Top
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.IsRunning 属性

TimerTaskIsRunning 属性

是否在运行

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsRunning { get; protected set; }

属性值

类型：Boolean
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.IsStart 属性

TimerTaskIsStart 属性

[缺少 "P:Api.Framework.SDK.TimerTask.IsStart" 的 <summary> 文档]

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected bool IsStart { get; }

属性值

类型：Boolean
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.RegisterdHandler 属性

TimerTaskRegisterdHandler 属性

RegisterdHandler

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public RegisteredWaitHandle RegisterdHandler { get; }

属性值

类型：RegisteredWaitHandle
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.RunningCount 属性

TimerTaskRunningCount 属性

运行的数量

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long RunningCount { get; set; }

属性值

类型：Int64
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.WaitHandler 属性

TimerTaskWaitHandler 属性

WaitHandler

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WaitHandle WaitHandler { get; }

属性值

类型：WaitHandle
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask 方法

TimerTask 类型公开以下成员。

方法
 | 名称 | 说明
 | CloseT | 关闭一个定时器
公共方法 | Dispose | 销毁方法 - 可以被重写
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetTimerT | 获得定时器
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | NewTimerT(Int32, Object) | 创建一个定时器
 | NewTimerT(T, Int32, Object) |
公共方法 | Run | 运行主体 - 需要重写
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.Close(T) 方法

TimerTaskCloseT 方法

关闭一个定时器

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Close<T>()

类型参数

T
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.Dispose 方法

TimerTaskDispose 方法

销毁方法 - 可以被重写

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void Dispose()

实现

IDisposableDispose
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.ExecutionTask 方法

TimerTaskExecutionTask 方法

执行任务

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void ExecutionTask(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Api.Framework.SDK.TimerTask.ExecutionTask(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Api.Framework.SDK.TimerTask.ExecutionTask(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.GetTimer(T) 方法

TimerTaskGetTimerT 方法

获得定时器

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static TimerTask GetTimer<T>()

类型参数

T

返回值

类型：TimerTask
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.NewTimer 方法

TimerTaskNewTimer 方法

重载列表
名称 | 说明
NewTimerT(Int32, Object) | 创建一个定时器
NewTimerT(T, Int32, Object) |
Top
参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


TimerTask.NewTimer(T) 方法 (Int32, Object)

TimerTaskNewTimerT 方法 (Int32, Object)

创建一个定时器

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T NewTimer<T>(
    int second,
    Object state = null
)

参数

second
类型：SystemInt32

[缺少 "M:Api.Framework.SDK.TimerTask.NewTimer``1(System.Int32,System.Object)" 的 <param name="second"/> 文档]

state (Optional)
类型：SystemObject

[缺少 "M:Api.Framework.SDK.TimerTask.NewTimer``1(System.Int32,System.Object)" 的 <param name="state"/> 文档]

类型参数

T

返回值

类型：T
参见

引用

TimerTask 类
NewTimer 重载
Api.Framework.SDK 命名空间


TimerTask.NewTimer(T) 方法 (T, Int32, Object)

TimerTaskNewTimerT 方法 (T, Int32, Object)

[缺少 "M:Api.Framework.SDK.TimerTask.NewTimer``1(``0,System.Int32,System.Object)" 的 <summary> 文档]

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T NewTimer<T>(
    T task,
    int second,
    Object state = null
)

参数

task
类型：T

[缺少 "M:Api.Framework.SDK.TimerTask.NewTimer``1(``0,System.Int32,System.Object)" 的 <param name="task"/> 文档]

second
类型：SystemInt32

[缺少 "M:Api.Framework.SDK.TimerTask.NewTimer``1(``0,System.Int32,System.Object)" 的 <param name="second"/> 文档]

state (Optional)
类型：SystemObject

[缺少 "M:Api.Framework.SDK.TimerTask.NewTimer``1(``0,System.Int32,System.Object)" 的 <param name="state"/> 文档]

类型参数

T

返回值

类型：T
参见

引用

TimerTask 类
NewTimer 重载
Api.Framework.SDK 命名空间


TimerTask.Run 方法

TimerTaskRun 方法

运行主体 - 需要重写

命名空间： Api.Framework.SDK
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public abstract void Run(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Api.Framework.SDK.TimerTask.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Api.Framework.SDK.TimerTask.Run(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

参见

引用

TimerTask 类
Api.Framework.SDK 命名空间


Api.Framework.Timers 命名空间

[缺少 "N:Api.Framework.Timers" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | ClearGarbageTimer | 清理垃圾线程
公共类 | DownAlimamaTimer | 阿里订单下载定时器
公共类 | DownDouyinTimer | 抖音订单下载定时器
公共类 | DownJingdongTimer | 京东订单下载定时器
公共类 | DownPinduoduoTimer | 拼多多订单下载定时器
公共类 | DownWeipinhuiTimer | 唯品会订单下载定时器
公共类 | Update_NoticeQueue | 更新同时队列定时器


ClearGarbageTimer 类

清理垃圾线程
继承层次
SystemObject
Api.Framework.SDKTimerTask
Api.Framework.TimersClearGarbageTimer

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ClearGarbageTimer : TimerTask

ClearGarbageTimer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ClearGarbageTimer | 初始化 ClearGarbageTimer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Timers 命名空间


ClearGarbageTimer 构造函数

初始化 ClearGarbageTimer 类的一个新实例

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ClearGarbageTimer()
参见

引用

ClearGarbageTimer 类
Api.Framework.Timers 命名空间


ClearGarbageTimer 属性

ClearGarbageTimer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
参见

引用

ClearGarbageTimer 类
Api.Framework.Timers 命名空间


ClearGarbageTimer 方法

ClearGarbageTimer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ClearGarbageTimer 类
Api.Framework.Timers 命名空间


ClearGarbageTimer.Run 方法

ClearGarbageTimerRun 方法

[缺少 "M:Api.Framework.Timers.ClearGarbageTimer.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Run(
    Object time,
    bool timeout
)

参数

time
类型：SystemObject

[缺少 "M:Api.Framework.Timers.ClearGarbageTimer.Run(System.Object,System.Boolean)" 的 <param name="time"/> 文档]

timeout
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.ClearGarbageTimer.Run(System.Object,System.Boolean)" 的 <param name="timeout"/> 文档]

参见

引用

ClearGarbageTimer 类
Api.Framework.Timers 命名空间


DownAlimamaTimer 类

阿里订单下载定时器
继承层次
SystemObject
Api.Framework.SDKTimerTask
Api.Framework.TimersDownAlimamaTimer

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DownAlimamaTimer : TimerTask

DownAlimamaTimer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DownAlimamaTimer | 初始化 DownAlimamaTimer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetAlimamaApi | 通过cps获取AlimamaApi
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(AlimamaApi, DateTime, Int32) | 爬虫更新阿里妈妈订单 - 下载维权退款订单
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) |
公共方法 | UpdateOrder(fl_cps_member, DateTime, DateTime, AlimamaApiAlimamaOrderStatus) | 手动同步指定阿里妈妈订单状态
公共方法 | UpdateOrder(fl_order_alimama, ListOrderNoticeEvent, SqlSugarClient, fl_order_refund_alimama, Boolean) | 订单绑定逻辑
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Timers 命名空间


DownAlimamaTimer 构造函数

初始化 DownAlimamaTimer 类的一个新实例

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DownAlimamaTimer()
参见

引用

DownAlimamaTimer 类
Api.Framework.Timers 命名空间


DownAlimamaTimer 属性

DownAlimamaTimer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
参见

引用

DownAlimamaTimer 类
Api.Framework.Timers 命名空间


DownAlimamaTimer 方法

DownAlimamaTimer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetAlimamaApi | 通过cps获取AlimamaApi
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(AlimamaApi, DateTime, Int32) | 爬虫更新阿里妈妈订单 - 下载维权退款订单
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) |
公共方法 | UpdateOrder(fl_cps_member, DateTime, DateTime, AlimamaApiAlimamaOrderStatus) | 手动同步指定阿里妈妈订单状态
公共方法 | UpdateOrder(fl_order_alimama, ListOrderNoticeEvent, SqlSugarClient, fl_order_refund_alimama, Boolean) | 订单绑定逻辑
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DownAlimamaTimer 类
Api.Framework.Timers 命名空间


DownAlimamaTimer.GetAlimamaApi 方法

DownAlimamaTimerGetAlimamaApi 方法

通过cps获取AlimamaApi

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public AlimamaApi GetAlimamaApi(
    fl_cps_member cps
)

参数

cps
类型：Api.Framework.Modelfl_cps_member
cps对象

返回值

类型：AlimamaApi
参见

引用

DownAlimamaTimer 类
Api.Framework.Timers 命名空间


DownAlimamaTimer.Run 方法

DownAlimamaTimerRun 方法

[缺少 "M:Api.Framework.Timers.DownAlimamaTimer.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Run(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Api.Framework.Timers.DownAlimamaTimer.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownAlimamaTimer.Run(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

参见

引用

DownAlimamaTimer 类
Api.Framework.Timers 命名空间


DownAlimamaTimer.UpdateOrder 方法

DownAlimamaTimerUpdateOrder 方法

重载列表
 | 名称 | 说明
公共方法 | UpdateOrder(AlimamaApi, DateTime, Int32) | 爬虫更新阿里妈妈订单 - 下载维权退款订单
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) |
公共方法 | UpdateOrder(fl_cps_member, DateTime, DateTime, AlimamaApiAlimamaOrderStatus) | 手动同步指定阿里妈妈订单状态
公共方法 | UpdateOrder(fl_order_alimama, ListOrderNoticeEvent, SqlSugarClient, fl_order_refund_alimama, Boolean) | 订单绑定逻辑
Top
参见

引用

DownAlimamaTimer 类
Api.Framework.Timers 命名空间


DownAlimamaTimer.UpdateOrder 方法 (AlimamaApi, DateTime, Int32)

DownAlimamaTimerUpdateOrder 方法 (AlimamaApi, DateTime, Int32)

爬虫更新阿里妈妈订单 - 下载维权退款订单

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    AlimamaApi api,
    DateTime startTime,
    int maxPage = 999999
)

参数

api
类型：Api.Framework.CpsAlimamaApi
AlimamaApi对象
startTime
类型：SystemDateTime
开始时间
maxPage (Optional)
类型：SystemInt32
最大的页数
参见

引用

DownAlimamaTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownAlimamaTimer.UpdateOrder 方法 (List(fl_cps_member), DateTime, DateTime)

DownAlimamaTimerUpdateOrder 方法 (Listfl_cps_member, DateTime, DateTime)

[缺少 "M:Api.Framework.Timers.DownAlimamaTimer.UpdateOrder(System.Collections.Generic.List{Api.Framework.Model.fl_cps_member},System.DateTime,System.DateTime)" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    List<fl_cps_member> members,
    DateTime start_time,
    DateTime end_time
)

参数

members
类型：System.Collections.GenericList fl_cps_member

[缺少 "M:Api.Framework.Timers.DownAlimamaTimer.UpdateOrder(System.Collections.Generic.List{Api.Framework.Model.fl_cps_member},System.DateTime,System.DateTime)" 的 <param name="members"/> 文档]

start_time
类型：SystemDateTime

[缺少 "M:Api.Framework.Timers.DownAlimamaTimer.UpdateOrder(System.Collections.Generic.List{Api.Framework.Model.fl_cps_member},System.DateTime,System.DateTime)" 的 <param name="start_time"/> 文档]

end_time
类型：SystemDateTime

[缺少 "M:Api.Framework.Timers.DownAlimamaTimer.UpdateOrder(System.Collections.Generic.List{Api.Framework.Model.fl_cps_member},System.DateTime,System.DateTime)" 的 <param name="end_time"/> 文档]

参见

引用

DownAlimamaTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownAlimamaTimer.UpdateOrder 方法 (fl_cps_member[], DateTime, DateTime, AlimamaApi.AlimamaOrderStatus)

DownAlimamaTimerUpdateOrder 方法 (fl_cps_member, DateTime, DateTime, AlimamaApiAlimamaOrderStatus)

手动同步指定阿里妈妈订单状态

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    fl_cps_member[] _members,
    DateTime start_time,
    DateTime end_time,
    AlimamaApiAlimamaOrderStatus status
)

参数

_members
类型：Api.Framework.Modelfl_cps_member

[缺少 "M:Api.Framework.Timers.DownAlimamaTimer.UpdateOrder(Api.Framework.Model.fl_cps_member[],System.DateTime,System.DateTime,Api.Framework.Cps.AlimamaApi.AlimamaOrderStatus)" 的 <param name="_members"/> 文档]

start_time
类型：SystemDateTime
同步的时间
end_time
类型：SystemDateTime
同步结束的时间
status
类型：Api.Framework.CpsAlimamaApiAlimamaOrderStatus
订单的状态
参见

引用

DownAlimamaTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownAlimamaTimer.UpdateOrder 方法 (fl_order_alimama, List(OrderNoticeEvent), SqlSugarClient, fl_order_refund_alimama, Boolean)

DownAlimamaTimerUpdateOrder 方法 (fl_order_alimama, ListOrderNoticeEvent, SqlSugarClient, fl_order_refund_alimama, Boolean)

订单绑定逻辑

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    fl_order_alimama db_order,
    List<OrderNoticeEvent> notice,
    SqlSugarClient session,
    fl_order_refund_alimama order_refund = null,
    bool isFrontData = false
)

参数

db_order
类型：Api.Framework.Modelfl_order_alimama
阿里订单对象
notice
类型：System.Collections.GenericList OrderNoticeEvent
事件集合
session
类型：SqlSugarClient
数据库操作对象
order_refund (Optional)
类型：Api.Framework.Modelfl_order_refund_alimama
阿里订单维权对象
isFrontData (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownAlimamaTimer.UpdateOrder(Api.Framework.Model.fl_order_alimama,System.Collections.Generic.List{Api.Framework.Events.OrderNoticeEvent},SqlSugar.SqlSugarClient,Api.Framework.Model.fl_order_refund_alimama,System.Boolean)" 的 <param name="isFrontData"/> 文档]

参见

引用

DownAlimamaTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownDouyinTimer 类

抖音订单下载定时器
继承层次
SystemObject
Api.Framework.SDKTimerTask
Api.Framework.TimersDownDouyinTimer

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DownDouyinTimer : TimerTask

DownDouyinTimer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DownDouyinTimer | 初始化 DownDouyinTimer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) | 手动下载订单
公共方法 | UpdateOrder(fl_order_douyin, ListOrderNoticeEvent, SqlSugarClient, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Timers 命名空间


DownDouyinTimer 构造函数

初始化 DownDouyinTimer 类的一个新实例

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DownDouyinTimer()
参见

引用

DownDouyinTimer 类
Api.Framework.Timers 命名空间


DownDouyinTimer 属性

DownDouyinTimer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
参见

引用

DownDouyinTimer 类
Api.Framework.Timers 命名空间


DownDouyinTimer 方法

DownDouyinTimer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) | 手动下载订单
公共方法 | UpdateOrder(fl_order_douyin, ListOrderNoticeEvent, SqlSugarClient, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DownDouyinTimer 类
Api.Framework.Timers 命名空间


DownDouyinTimer.Run 方法

DownDouyinTimerRun 方法

[缺少 "M:Api.Framework.Timers.DownDouyinTimer.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Run(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Api.Framework.Timers.DownDouyinTimer.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownDouyinTimer.Run(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

参见

引用

DownDouyinTimer 类
Api.Framework.Timers 命名空间


DownDouyinTimer.UpdateOrder 方法

DownDouyinTimerUpdateOrder 方法

重载列表
 | 名称 | 说明
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) | 手动下载订单
公共方法 | UpdateOrder(fl_order_douyin, ListOrderNoticeEvent, SqlSugarClient, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
参见

引用

DownDouyinTimer 类
Api.Framework.Timers 命名空间


DownDouyinTimer.UpdateOrder 方法 (List(fl_cps_member), DateTime, DateTime)

DownDouyinTimerUpdateOrder 方法 (Listfl_cps_member, DateTime, DateTime)

手动下载订单

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    List<fl_cps_member> members,
    DateTime start_time,
    DateTime end_time
)

参数

members
类型：System.Collections.GenericList fl_cps_member

[缺少 "M:Api.Framework.Timers.DownDouyinTimer.UpdateOrder(System.Collections.Generic.List{Api.Framework.Model.fl_cps_member},System.DateTime,System.DateTime)" 的 <param name="members"/> 文档]

start_time
类型：SystemDateTime
订单同步开始时间
end_time
类型：SystemDateTime
订单同步结束时间
参见

引用

DownDouyinTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownDouyinTimer.UpdateOrder 方法 (fl_order_douyin, List(OrderNoticeEvent), SqlSugarClient, Boolean)

DownDouyinTimerUpdateOrder 方法 (fl_order_douyin, ListOrderNoticeEvent, SqlSugarClient, Boolean)

订单 修改状态/用户绑定等操作通知用户

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    fl_order_douyin db_order,
    List<OrderNoticeEvent> notice,
    SqlSugarClient session,
    bool isFrontData = false
)

参数

db_order
类型：Api.Framework.Modelfl_order_douyin
抖音订单对象
notice
类型：System.Collections.GenericList OrderNoticeEvent
事件集合
session
类型：SqlSugarClient
数据库操作对象
isFrontData (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownDouyinTimer.UpdateOrder(Api.Framework.Model.fl_order_douyin,System.Collections.Generic.List{Api.Framework.Events.OrderNoticeEvent},SqlSugar.SqlSugarClient,System.Boolean)" 的 <param name="isFrontData"/> 文档]

参见

引用

DownDouyinTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownJingdongTimer 类

京东订单下载定时器
继承层次
SystemObject
Api.Framework.SDKTimerTask
Api.Framework.TimersDownJingdongTimer

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DownJingdongTimer : TimerTask

DownJingdongTimer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DownJingdongTimer | 初始化 DownJingdongTimer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(Listfl_cps_member, DateTime) | 手动同步订单
公共方法 | UpdateOrder(fl_order_jingdong, SqlSugarClient, ListOrderNoticeEvent, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Timers 命名空间


DownJingdongTimer 构造函数

初始化 DownJingdongTimer 类的一个新实例

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DownJingdongTimer()
参见

引用

DownJingdongTimer 类
Api.Framework.Timers 命名空间


DownJingdongTimer 属性

DownJingdongTimer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
参见

引用

DownJingdongTimer 类
Api.Framework.Timers 命名空间


DownJingdongTimer 方法

DownJingdongTimer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(Listfl_cps_member, DateTime) | 手动同步订单
公共方法 | UpdateOrder(fl_order_jingdong, SqlSugarClient, ListOrderNoticeEvent, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DownJingdongTimer 类
Api.Framework.Timers 命名空间


DownJingdongTimer.Run 方法

DownJingdongTimerRun 方法

[缺少 "M:Api.Framework.Timers.DownJingdongTimer.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Run(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Api.Framework.Timers.DownJingdongTimer.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownJingdongTimer.Run(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

参见

引用

DownJingdongTimer 类
Api.Framework.Timers 命名空间


DownJingdongTimer.UpdateOrder 方法

DownJingdongTimerUpdateOrder 方法

重载列表
 | 名称 | 说明
公共方法 | UpdateOrder(Listfl_cps_member, DateTime) | 手动同步订单
公共方法 | UpdateOrder(fl_order_jingdong, SqlSugarClient, ListOrderNoticeEvent, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
参见

引用

DownJingdongTimer 类
Api.Framework.Timers 命名空间


DownJingdongTimer.UpdateOrder 方法 (List(fl_cps_member), DateTime)

DownJingdongTimerUpdateOrder 方法 (Listfl_cps_member, DateTime)

手动同步订单

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    List<fl_cps_member> members,
    DateTime start_time
)

参数

members
类型：System.Collections.GenericList fl_cps_member

[缺少 "M:Api.Framework.Timers.DownJingdongTimer.UpdateOrder(System.Collections.Generic.List{Api.Framework.Model.fl_cps_member},System.DateTime)" 的 <param name="members"/> 文档]

start_time
类型：SystemDateTime
开始同步的时间
参见

引用

DownJingdongTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownJingdongTimer.UpdateOrder 方法 (fl_order_jingdong, SqlSugarClient, List(OrderNoticeEvent), Boolean)

DownJingdongTimerUpdateOrder 方法 (fl_order_jingdong, SqlSugarClient, ListOrderNoticeEvent, Boolean)

订单 修改状态/用户绑定等操作通知用户

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    fl_order_jingdong db_order,
    SqlSugarClient session,
    List<OrderNoticeEvent> notices,
    bool isFrontData = false
)

参数

db_order
类型：Api.Framework.Modelfl_order_jingdong
京东订单对象
session
类型：SqlSugarClient
数据库操作对象
notices
类型：System.Collections.GenericList OrderNoticeEvent
事件集合
isFrontData (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownJingdongTimer.UpdateOrder(Api.Framework.Model.fl_order_jingdong,SqlSugar.SqlSugarClient,System.Collections.Generic.List{Api.Framework.Events.OrderNoticeEvent},System.Boolean)" 的 <param name="isFrontData"/> 文档]

参见

引用

DownJingdongTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownPinduoduoTimer 类

拼多多订单下载定时器
继承层次
SystemObject
Api.Framework.SDKTimerTask
Api.Framework.TimersDownPinduoduoTimer

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DownPinduoduoTimer : TimerTask

DownPinduoduoTimer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DownPinduoduoTimer | 初始化 DownPinduoduoTimer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) | 手动同步订单
公共方法 | UpdateOrder(fl_order_pinduoduo, SqlSugarClient, ListOrderNoticeEvent, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Timers 命名空间


DownPinduoduoTimer 构造函数

初始化 DownPinduoduoTimer 类的一个新实例

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DownPinduoduoTimer()
参见

引用

DownPinduoduoTimer 类
Api.Framework.Timers 命名空间


DownPinduoduoTimer 属性

DownPinduoduoTimer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
参见

引用

DownPinduoduoTimer 类
Api.Framework.Timers 命名空间


DownPinduoduoTimer 方法

DownPinduoduoTimer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) | 手动同步订单
公共方法 | UpdateOrder(fl_order_pinduoduo, SqlSugarClient, ListOrderNoticeEvent, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DownPinduoduoTimer 类
Api.Framework.Timers 命名空间


DownPinduoduoTimer.Run 方法

DownPinduoduoTimerRun 方法

[缺少 "M:Api.Framework.Timers.DownPinduoduoTimer.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Run(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Api.Framework.Timers.DownPinduoduoTimer.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownPinduoduoTimer.Run(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

参见

引用

DownPinduoduoTimer 类
Api.Framework.Timers 命名空间


DownPinduoduoTimer.UpdateOrder 方法

DownPinduoduoTimerUpdateOrder 方法

重载列表
 | 名称 | 说明
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) | 手动同步订单
公共方法 | UpdateOrder(fl_order_pinduoduo, SqlSugarClient, ListOrderNoticeEvent, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
参见

引用

DownPinduoduoTimer 类
Api.Framework.Timers 命名空间


DownPinduoduoTimer.UpdateOrder 方法 (List(fl_cps_member), DateTime, DateTime)

DownPinduoduoTimerUpdateOrder 方法 (Listfl_cps_member, DateTime, DateTime)

手动同步订单

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    List<fl_cps_member> members,
    DateTime start_time,
    DateTime end_time
)

参数

members
类型：System.Collections.GenericList fl_cps_member

[缺少 "M:Api.Framework.Timers.DownPinduoduoTimer.UpdateOrder(System.Collections.Generic.List{Api.Framework.Model.fl_cps_member},System.DateTime,System.DateTime)" 的 <param name="members"/> 文档]

start_time
类型：SystemDateTime
开始时间
end_time
类型：SystemDateTime
结束时间
参见

引用

DownPinduoduoTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownPinduoduoTimer.UpdateOrder 方法 (fl_order_pinduoduo, SqlSugarClient, List(OrderNoticeEvent), Boolean)

DownPinduoduoTimerUpdateOrder 方法 (fl_order_pinduoduo, SqlSugarClient, ListOrderNoticeEvent, Boolean)

订单 修改状态/用户绑定等操作通知用户

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    fl_order_pinduoduo db_order,
    SqlSugarClient session,
    List<OrderNoticeEvent> notice,
    bool isFrontData = false
)

参数

db_order
类型：Api.Framework.Modelfl_order_pinduoduo
拼多多订单对象
session
类型：SqlSugarClient
数据库操作对象
notice
类型：System.Collections.GenericList OrderNoticeEvent
事件集合
isFrontData (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownPinduoduoTimer.UpdateOrder(Api.Framework.Model.fl_order_pinduoduo,SqlSugar.SqlSugarClient,System.Collections.Generic.List{Api.Framework.Events.OrderNoticeEvent},System.Boolean)" 的 <param name="isFrontData"/> 文档]

参见

引用

DownPinduoduoTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownWeipinhuiTimer 类

唯品会订单下载定时器
继承层次
SystemObject
Api.Framework.SDKTimerTask
Api.Framework.TimersDownWeipinhuiTimer

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DownWeipinhuiTimer : TimerTask

DownWeipinhuiTimer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DownWeipinhuiTimer | 初始化 DownWeipinhuiTimer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) | 手动同步订单
公共方法 | UpdateOrder(fl_order_weipinhui, SqlSugarClient, ListOrderNoticeEvent, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Timers 命名空间


DownWeipinhuiTimer 构造函数

初始化 DownWeipinhuiTimer 类的一个新实例

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DownWeipinhuiTimer()
参见

引用

DownWeipinhuiTimer 类
Api.Framework.Timers 命名空间


DownWeipinhuiTimer 属性

DownWeipinhuiTimer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
参见

引用

DownWeipinhuiTimer 类
Api.Framework.Timers 命名空间


DownWeipinhuiTimer 方法

DownWeipinhuiTimer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) | 手动同步订单
公共方法 | UpdateOrder(fl_order_weipinhui, SqlSugarClient, ListOrderNoticeEvent, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DownWeipinhuiTimer 类
Api.Framework.Timers 命名空间


DownWeipinhuiTimer.Run 方法

DownWeipinhuiTimerRun 方法

[缺少 "M:Api.Framework.Timers.DownWeipinhuiTimer.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Run(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Api.Framework.Timers.DownWeipinhuiTimer.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownWeipinhuiTimer.Run(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

参见

引用

DownWeipinhuiTimer 类
Api.Framework.Timers 命名空间


DownWeipinhuiTimer.UpdateOrder 方法

DownWeipinhuiTimerUpdateOrder 方法

重载列表
 | 名称 | 说明
公共方法 | UpdateOrder(Listfl_cps_member, DateTime, DateTime) | 手动同步订单
公共方法 | UpdateOrder(fl_order_weipinhui, SqlSugarClient, ListOrderNoticeEvent, Boolean) | 订单 修改状态/用户绑定等操作通知用户
Top
参见

引用

DownWeipinhuiTimer 类
Api.Framework.Timers 命名空间


DownWeipinhuiTimer.UpdateOrder 方法 (List(fl_cps_member), DateTime, DateTime)

DownWeipinhuiTimerUpdateOrder 方法 (Listfl_cps_member, DateTime, DateTime)

手动同步订单

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    List<fl_cps_member> members,
    DateTime start_time,
    DateTime end_time
)

参数

members
类型：System.Collections.GenericList fl_cps_member

[缺少 "M:Api.Framework.Timers.DownWeipinhuiTimer.UpdateOrder(System.Collections.Generic.List{Api.Framework.Model.fl_cps_member},System.DateTime,System.DateTime)" 的 <param name="members"/> 文档]

start_time
类型：SystemDateTime
开始时间
end_time
类型：SystemDateTime
结束时间
参见

引用

DownWeipinhuiTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


DownWeipinhuiTimer.UpdateOrder 方法 (fl_order_weipinhui, SqlSugarClient, List(OrderNoticeEvent), Boolean)

DownWeipinhuiTimerUpdateOrder 方法 (fl_order_weipinhui, SqlSugarClient, ListOrderNoticeEvent, Boolean)

订单 修改状态/用户绑定等操作通知用户

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void UpdateOrder(
    fl_order_weipinhui db_order,
    SqlSugarClient session,
    List<OrderNoticeEvent> notice,
    bool isFrontData = false
)

参数

db_order
类型：Api.Framework.Modelfl_order_weipinhui
唯品会订单对象
session
类型：SqlSugarClient
数据库操作对象
notice
类型：System.Collections.GenericList OrderNoticeEvent
事件集合
isFrontData (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.DownWeipinhuiTimer.UpdateOrder(Api.Framework.Model.fl_order_weipinhui,SqlSugar.SqlSugarClient,System.Collections.Generic.List{Api.Framework.Events.OrderNoticeEvent},System.Boolean)" 的 <param name="isFrontData"/> 文档]

参见

引用

DownWeipinhuiTimer 类
UpdateOrder 重载
Api.Framework.Timers 命名空间


Update_NoticeQueue 类

更新同时队列定时器
继承层次
SystemObject
Api.Framework.SDKTimerTask
Api.Framework.TimersUpdate_NoticeQueue

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Update_NoticeQueue : TimerTask

Update_NoticeQueue 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Update_NoticeQueue | 初始化 Update_NoticeQueue 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
方法
 | 名称 | 说明
公共方法 | Add(OrderNoticeEvent) |
公共方法 | Add(ListOrderNoticeEvent) |
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Timers 命名空间


Update_NoticeQueue 构造函数

初始化 Update_NoticeQueue 类的一个新实例

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Update_NoticeQueue()
参见

引用

Update_NoticeQueue 类
Api.Framework.Timers 命名空间


Update_NoticeQueue 属性

Update_NoticeQueue 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning | 是否在运行 (继承自 TimerTask。)
受保护的属性 | IsStart | (继承自 TimerTask。)
公共属性 | RegisterdHandler | RegisterdHandler (继承自 TimerTask。)
公共属性 | RunningCount | 运行的数量 (继承自 TimerTask。)
公共属性 | WaitHandler | WaitHandler (继承自 TimerTask。)
Top
参见

引用

Update_NoticeQueue 类
Api.Framework.Timers 命名空间


Update_NoticeQueue 方法

Update_NoticeQueue 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add(OrderNoticeEvent) |
公共方法 | Add(ListOrderNoticeEvent) |
公共方法 | Dispose | 销毁方法 - 可以被重写 (继承自 TimerTask。)
公共方法 | Equals | (继承自 Object。)
公共方法 | ExecutionTask | 执行任务 (继承自 TimerTask。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run | (重写 TimerTaskRun(Object, Boolean).)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Update_NoticeQueue 类
Api.Framework.Timers 命名空间


Update_NoticeQueue.Add 方法

Update_NoticeQueueAdd 方法

重载列表
 | 名称 | 说明
公共方法 | Add(OrderNoticeEvent) |
公共方法 | Add(ListOrderNoticeEvent) |
Top
参见

引用

Update_NoticeQueue 类
Api.Framework.Timers 命名空间


Update_NoticeQueue.Add 方法 (OrderNoticeEvent)

Update_NoticeQueueAdd 方法 (OrderNoticeEvent)

[缺少 "M:Api.Framework.Timers.Update_NoticeQueue.Add(Api.Framework.Events.OrderNoticeEvent)" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Add(
    OrderNoticeEvent e
)

参数

e
类型：Api.Framework.EventsOrderNoticeEvent

[缺少 "M:Api.Framework.Timers.Update_NoticeQueue.Add(Api.Framework.Events.OrderNoticeEvent)" 的 <param name="e"/> 文档]

参见

引用

Update_NoticeQueue 类
Add 重载
Api.Framework.Timers 命名空间


Update_NoticeQueue.Add 方法 (List(OrderNoticeEvent))

Update_NoticeQueueAdd 方法 (ListOrderNoticeEvent)

[缺少 "M:Api.Framework.Timers.Update_NoticeQueue.Add(System.Collections.Generic.List{Api.Framework.Events.OrderNoticeEvent})" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Add(
    List<OrderNoticeEvent> e
)

参数

e
类型：System.Collections.GenericList OrderNoticeEvent

[缺少 "M:Api.Framework.Timers.Update_NoticeQueue.Add(System.Collections.Generic.List{Api.Framework.Events.OrderNoticeEvent})" 的 <param name="e"/> 文档]

参见

引用

Update_NoticeQueue 类
Add 重载
Api.Framework.Timers 命名空间


Update_NoticeQueue.Run 方法

Update_NoticeQueueRun 方法

[缺少 "M:Api.Framework.Timers.Update_NoticeQueue.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Timers
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Run(
    Object state,
    bool timeout
)

参数

state
类型：SystemObject

[缺少 "M:Api.Framework.Timers.Update_NoticeQueue.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timeout
类型：SystemBoolean

[缺少 "M:Api.Framework.Timers.Update_NoticeQueue.Run(System.Object,System.Boolean)" 的 <param name="timeout"/> 文档]

参见

引用

Update_NoticeQueue 类
Api.Framework.Timers 命名空间


Api.Framework.Tools 命名空间

[缺少 "N:Api.Framework.Tools" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | AfterSaleInfo | 商品售后信息
公共类 | base_model | 数据库基础类
公共类 | Brand_icon | 图片
公共类 | CacheTool | 自定义内存缓存助手
公共类 | CloudBlack | 云黑命大类
公共类 | CloudBlackBlackResult |
公共类 | CommentsInfo | 商品评价信息
公共类 | ConnectionConfig | 数据库链接配置
公共类 | CouponInfo | 红包信息
公共类 | CouponInfo1 | 红包信息
公共类 | Cover | 其他
公共类 | Data | 商品信息
公共类 | DetailList | 商品明细
公共类 | DouyinGoodsInfo | 抖音商品信息
公共类 | DYHelper | 抖音解析助手
公共类 | ExclusiveCoupon | 渠道专属红包：目前仅开放单品券，没有则返回空
公共类 | GoodsInfoList | 精选商品列表
公共类 | GoodsInfoResponseResult |
公共类 | GoodsInfoResult | 精选商品列表
公共类 | h5Top | h5
公共类 | HTTPClass |
公共类 | IniHelper | ini配置文件操作类
公共类 | JDHelper | 京东解析助手
公共类 | JoinedActivities | 商品参与活动信息:未参与活动集合为空
公共类 | KuaiZhanShort | 快站短网址
公共类 | OrderHelper | 订单助手
公共类 | OrderInfoList | 业绩查询响应结果
公共类 | OrderResponseResult | 订单响应结果
公共类 | OrderResult | 订单数据
公共类 | PageResultT | 分页查询结果
公共类 | ParamMap |
公共类 | PDDHelper | 拼多多解析助手
公共类 | PrepayInfo | 商品预付信息
公共类 | PromotionsItem | 推广项目
公共类 | Response |
公共类 | Result1 |
公共类 | Sale_infos | 销售信息(优惠券信息)
公共类 | SessionThreadLocal | 持久层线程池
公共类 | SkuInfos | 对应sku信息
公共类 | SqlSugarExtend |
公共类 | StoreInfo | 店铺信息
公共类 | StoreServiceCapability | 商品所属店铺服务能力评价
公共类 | SynchronizedDictionaryTKey, TValue | 线程安全的数据字典
公共类 | TBHelper | 淘宝导购帮助类
公共类 | TBHelperTbAnalysis | 淘宝解析方法
公共类 | TBHelperTbBaseInfo | 保存淘宝基础信息的类
公共类 | TBHelperTbExCoupon | 外围淘宝商品信息(优惠券等信息)
公共类 | TBHelperTbTools |
公共类 | TeaEncryption | 加密解密QQ消息包的工具类.
公共类 | UrlInfoList | 链接数据
公共类 | Util |
公共类 | VariateReplace | 变量替换
公共类 | WechatPay | 商户支付类
公共类 | WPHCpsUrl | 转链后返回的数据解构
公共类 | WphGoodsInfo |
公共类 | WphGoodsInfoResult | 唯品会商品查询详情结果
公共类 | WPHHelper | 唯品会助手类
公共类 | ZipHelper |
枚举
 | 枚举 | 说明
公共枚举 | CloudBlackBlackType | 黑名单所属平台类型
公共枚举 | DatabaseType | 数据库类型枚举，需要扩展类型可在此添加
公共枚举 | TBHelperTbAnalysisPublisherType | 私域查詢数据的類型
公共枚举 | UtilDecodeQRCodeType | 二维码解析类型


AfterSaleInfo 类

商品售后信息
继承层次
SystemObject
Api.Framework.ToolsAfterSaleInfo

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class AfterSaleInfo

AfterSaleInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AfterSaleInfo | 初始化 AfterSaleInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | afterSaleChangedCommission | 商品佣金售后变动:仅在订单完结之后发生售后时返回，无售后时为空
公共属性 | afterSaleChangedGoodsCount | 商品数量售后变动:仅在订单完结之后发生售后时返回，无售后时为空
公共属性 | afterSaleFinishTime | 售后完成时间，时间戳，单位：毫秒，无售后时为空
公共属性 | afterSaleSn | 商品售后单号，无售后时为空
公共属性 | afterSaleStatus | 商品售后状态：1-售后中，2-售后完成，3-售后取消，无售后时为空
公共属性 | afterSaleType | 售后类型：1-退货，2-换货,无售后时为空
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


AfterSaleInfo 构造函数

初始化 AfterSaleInfo 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public AfterSaleInfo()
参见

引用

AfterSaleInfo 类
Api.Framework.Tools 命名空间


AfterSaleInfo 属性

AfterSaleInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | afterSaleChangedCommission | 商品佣金售后变动:仅在订单完结之后发生售后时返回，无售后时为空
公共属性 | afterSaleChangedGoodsCount | 商品数量售后变动:仅在订单完结之后发生售后时返回，无售后时为空
公共属性 | afterSaleFinishTime | 售后完成时间，时间戳，单位：毫秒，无售后时为空
公共属性 | afterSaleSn | 商品售后单号，无售后时为空
公共属性 | afterSaleStatus | 商品售后状态：1-售后中，2-售后完成，3-售后取消，无售后时为空
公共属性 | afterSaleType | 售后类型：1-退货，2-换货,无售后时为空
Top
参见

引用

AfterSaleInfo 类
Api.Framework.Tools 命名空间


AfterSaleInfo.afterSaleChangedCommission 属性

AfterSaleInfoafterSaleChangedCommission 属性

商品佣金售后变动:仅在订单完结之后发生售后时返回，无售后时为空

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string afterSaleChangedCommission { get; set; }

属性值

类型：String
参见

引用

AfterSaleInfo 类
Api.Framework.Tools 命名空间


AfterSaleInfo.afterSaleChangedGoodsCount 属性

AfterSaleInfoafterSaleChangedGoodsCount 属性

商品数量售后变动:仅在订单完结之后发生售后时返回，无售后时为空

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int afterSaleChangedGoodsCount { get; set; }

属性值

类型：Int32
参见

引用

AfterSaleInfo 类
Api.Framework.Tools 命名空间


AfterSaleInfo.afterSaleFinishTime 属性

AfterSaleInfoafterSaleFinishTime 属性

售后完成时间，时间戳，单位：毫秒，无售后时为空

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long afterSaleFinishTime { get; set; }

属性值

类型：Int64
参见

引用

AfterSaleInfo 类
Api.Framework.Tools 命名空间


AfterSaleInfo.afterSaleSn 属性

AfterSaleInfoafterSaleSn 属性

商品售后单号，无售后时为空

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string afterSaleSn { get; set; }

属性值

类型：String
参见

引用

AfterSaleInfo 类
Api.Framework.Tools 命名空间


AfterSaleInfo.afterSaleStatus 属性

AfterSaleInfoafterSaleStatus 属性

商品售后状态：1-售后中，2-售后完成，3-售后取消，无售后时为空

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiAfterSaleStatus afterSaleStatus { get; set; }

属性值

类型：WeipinhuiAfterSaleStatus
参见

引用

AfterSaleInfo 类
Api.Framework.Tools 命名空间


AfterSaleInfo.afterSaleType 属性

AfterSaleInfoafterSaleType 属性

售后类型：1-退货，2-换货,无售后时为空

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiSfterSaleType afterSaleType { get; set; }

属性值

类型：WeipinhuiSfterSaleType
参见

引用

AfterSaleInfo 类
Api.Framework.Tools 命名空间


AfterSaleInfo 方法

AfterSaleInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

AfterSaleInfo 类
Api.Framework.Tools 命名空间


base_model 类

数据库基础类
继承层次
SystemObject
Api.Framework.Toolsbase_model
更多...

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class base_model

base_model 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | base_model | 初始化 base_model 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | id |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间
继承层次
SystemObject
Api.Framework.Toolsbase_model
Api.Framework.Modelbase_model_order
Api.Framework.Modelfl_adzone_group
Api.Framework.Modelfl_adzone_info
Api.Framework.Modelfl_alimama_order_lastnum
Api.Framework.Modelfl_alimama_tlj_create_record
Api.Framework.Modelfl_alimama_tlj_get_record
Api.Framework.Modelfl_alimama_tlj_info
Api.Framework.Modelfl_bind_cache
Api.Framework.Modelfl_cloud_black
Api.Framework.Modelfl_cps_member
Api.Framework.Modelfl_create_info
Api.Framework.Modelfl_debug_log
Api.Framework.Modelfl_dictionary_item
Api.Framework.Modelfl_exchange_info
Api.Framework.Modelfl_group_person
Api.Framework.Modelfl_member_group
Api.Framework.Modelfl_member_info
Api.Framework.Modelfl_member_level
Api.Framework.Modelfl_noticeapi_info
Api.Framework.Modelfl_operation_log
Api.Framework.Modelfl_order_refund_alimama
Api.Framework.Modelfl_order_sleep
Api.Framework.Modelfl_plugin_allrebatesactivity_info
Api.Framework.Modelfl_plugin_allrebatesactivity_orderlist
Api.Framework.Modelfl_plugin_info
Api.Framework.Modelfl_point_hist
Api.Framework.Modelfl_prevent_theft_cache
Api.Framework.Modelfl_private_pid
Api.Framework.Modelfl_query_hist
Api.Framework.Modelfl_ratio_info
Api.Framework.Modelfl_robot_info
Api.Framework.Modelfl_shpay_hist
Api.Framework.Modelfl_statistics_record
Api.Framework.Modelfl_tb_relation
Api.Framework.Modelfl_uservariate_info
Api.Framework.Modelfl_wechat_contacts
Api.Framework.Modelfl_wechat_device


base_model 构造函数

初始化 base_model 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public base_model()
参见

引用

base_model 类
Api.Framework.Tools 命名空间


base_model 属性

base_model 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | id |
Top
参见

引用

base_model 类
Api.Framework.Tools 命名空间


base_model.id 属性

base_modelid 属性

[缺少 "P:Api.Framework.Tools.base_model.id" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long id { get; set; }

属性值

类型：Int64
参见

引用

base_model 类
Api.Framework.Tools 命名空间


base_model 方法

base_model 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

base_model 类
Api.Framework.Tools 命名空间


Brand_icon 类

图片
继承层次
SystemObject
Api.Framework.ToolsBrand_icon

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Brand_icon

Brand_icon 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Brand_icon | 初始化 Brand_icon 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | url_list | 店铺图片
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


Brand_icon 构造函数

初始化 Brand_icon 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Brand_icon()
参见

引用

Brand_icon 类
Api.Framework.Tools 命名空间


Brand_icon 属性

Brand_icon 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | url_list | 店铺图片
Top
参见

引用

Brand_icon 类
Api.Framework.Tools 命名空间


Brand_icon.url_list 属性

Brand_iconurl_list 属性

店铺图片

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> url_list { get; set; }

属性值

类型：List String
参见

引用

Brand_icon 类
Api.Framework.Tools 命名空间


Brand_icon 方法

Brand_icon 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Brand_icon 类
Api.Framework.Tools 命名空间


CacheTool 类

自定义内存缓存助手
继承层次
SystemObject
Api.Framework.ToolsCacheTool

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public sealed class CacheTool

CacheTool 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 索引器
Top
方法
 | 名称 | 说明
公共方法 | Cleaner | 清空所有缓存
公共方法 | Count | 获取缓存个数
公共方法 | Equals | (继承自 Object。)
公共方法 | Exist | 检查key是否存在 2.被动过期，保证任何过期缓存都无法取值
公共方法 | GetT | 通过key获取缓存value 2.被动过期
公共方法 | GetHashCode | (继承自 Object。)
 | GetSingleObj |
公共方法 | GetType | (继承自 Object。)
公共方法 | Remove | 删除指定key的value
公共方法 | Set | 设置相对过期缓存
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


CacheTool 属性

CacheTool 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Item | 索引器
Top
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CacheTool.Item 属性

CacheToolItem 属性

索引器

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object this[
    string key
] { get; set; }

参数

key
类型：SystemString

返回值

类型：Object
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CacheTool 方法

CacheTool 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Cleaner | 清空所有缓存
公共方法 | Count | 获取缓存个数
公共方法 | Equals | (继承自 Object。)
公共方法 | Exist | 检查key是否存在 2.被动过期，保证任何过期缓存都无法取值
公共方法 | GetT | 通过key获取缓存value 2.被动过期
公共方法 | GetHashCode | (继承自 Object。)
 | GetSingleObj |
公共方法 | GetType | (继承自 Object。)
公共方法 | Remove | 删除指定key的value
公共方法 | Set | 设置相对过期缓存
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CacheTool.Cleaner 方法

CacheToolCleaner 方法

清空所有缓存

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Cleaner()
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CacheTool.Count 方法

CacheToolCount 方法

获取缓存个数

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Count()

返回值

类型：Int32
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CacheTool.Exist 方法

CacheToolExist 方法

检查key是否存在 2.被动过期，保证任何过期缓存都无法取值

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Exist(
    string key
)

参数

key
类型：SystemString

[缺少 "M:Api.Framework.Tools.CacheTool.Exist(System.String)" 的 <param name="key"/> 文档]

返回值

类型：Boolean
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CacheTool.Get(T) 方法

CacheToolGetT 方法

通过key获取缓存value 2.被动过期

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public T Get<T>(
    string key
)

参数

key
类型：SystemString

[缺少 "M:Api.Framework.Tools.CacheTool.Get``1(System.String)" 的 <param name="key"/> 文档]

类型参数

T

返回值

类型：T
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CacheTool.GetSingleObj 方法

CacheToolGetSingleObj 方法

[缺少 "M:Api.Framework.Tools.CacheTool.GetSingleObj" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static CacheTool GetSingleObj()

返回值

类型：CacheTool
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CacheTool.Remove 方法

CacheToolRemove 方法

删除指定key的value

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Remove(
    string key
)

参数

key
类型：SystemString

[缺少 "M:Api.Framework.Tools.CacheTool.Remove(System.String)" 的 <param name="key"/> 文档]

返回值

类型：Boolean
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CacheTool.Set 方法

CacheToolSet 方法

设置相对过期缓存

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Set(
    string key,
    Object data,
    int minute = 10
)

参数

key
类型：SystemString
键
data
类型：SystemObject
数据包
minute (Optional)
类型：SystemInt32
相对过期时间
参见

引用

CacheTool 类
Api.Framework.Tools 命名空间


CloudBlack 类

云黑命大类
继承层次
SystemObject
Api.Framework.ToolsCloudBlack

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CloudBlack

CloudBlack 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CloudBlack | 初始化 CloudBlack 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | InsertBlack | 插入黑名单
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | QueryBlack(String) | 判断用户是否为黑名单
公共方法 | QueryBlack(fl_member_info) | 查询用户是否黑名单
公共方法 | RemoveBlack | 删除用户黑名单
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


CloudBlack 构造函数

初始化 CloudBlack 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CloudBlack()
参见

引用

CloudBlack 类
Api.Framework.Tools 命名空间


CloudBlack 方法

CloudBlack 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | InsertBlack | 插入黑名单
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | QueryBlack(String) | 判断用户是否为黑名单
公共方法 | QueryBlack(fl_member_info) | 查询用户是否黑名单
公共方法 | RemoveBlack | 删除用户黑名单
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CloudBlack 类
Api.Framework.Tools 命名空间


CloudBlack.InsertBlack 方法

CloudBlackInsertBlack 方法

插入黑名单

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CloudBlackBlackResult InsertBlack(
    fl_member_info member,
    string remark
)

参数

member
类型：Api.Framework.Modelfl_member_info
用户对象
remark
类型：SystemString
备注

返回值

类型：CloudBlackBlackResult
参见

引用

CloudBlack 类
Api.Framework.Tools 命名空间


CloudBlack.QueryBlack 方法

CloudBlackQueryBlack 方法

重载列表
 | 名称 | 说明
公共方法 | QueryBlack(String) | 判断用户是否为黑名单
公共方法 | QueryBlack(fl_member_info) | 查询用户是否黑名单
Top
参见

引用

CloudBlack 类
Api.Framework.Tools 命名空间


CloudBlack.QueryBlack 方法 (String)

CloudBlackQueryBlack 方法 (String)

判断用户是否为黑名单

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool QueryBlack(
    string username
)

参数

username
类型：SystemString
用户账号

返回值

类型：Boolean
参见

引用

CloudBlack 类
QueryBlack 重载
Api.Framework.Tools 命名空间


CloudBlack.QueryBlack 方法 (fl_member_info)

CloudBlackQueryBlack 方法 (fl_member_info)

查询用户是否黑名单

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public fl_cloud_black QueryBlack(
    fl_member_info member
)

参数

member
类型：Api.Framework.Modelfl_member_info
用户对象

返回值

类型：fl_cloud_black
参见

引用

CloudBlack 类
QueryBlack 重载
Api.Framework.Tools 命名空间


CloudBlack.RemoveBlack 方法

CloudBlackRemoveBlack 方法

删除用户黑名单

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CloudBlackBlackResult RemoveBlack(
    fl_member_info member
)

参数

member
类型：Api.Framework.Modelfl_member_info
用户对象

返回值

类型：CloudBlackBlackResult
参见

引用

CloudBlack 类
Api.Framework.Tools 命名空间


CloudBlack.BlackResult 类

CloudBlackBlackResult 类

[缺少 "T:Api.Framework.Tools.CloudBlack.BlackResult" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsCloudBlackBlackResult

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class BlackResult

CloudBlackBlackResult 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CloudBlackBlackResult | 初始化 CloudBlackBlackResult 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Code |
公共属性 | Data |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


CloudBlack.BlackResult 构造函数

CloudBlackBlackResult 构造函数

初始化 CloudBlackBlackResult 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BlackResult()
参见

引用

CloudBlackBlackResult 类
Api.Framework.Tools 命名空间


BlackResult 属性

CloudBlackBlackResult 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Code |
公共属性 | Data |
Top
参见

引用

CloudBlackBlackResult 类
Api.Framework.Tools 命名空间


CloudBlack.BlackResult.Code 属性

CloudBlackBlackResultCode 属性

[缺少 "P:Api.Framework.Tools.CloudBlack.BlackResult.Code" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Code { get; set; }

属性值

类型：Int32
参见

引用

CloudBlackBlackResult 类
Api.Framework.Tools 命名空间


CloudBlack.BlackResult.Data 属性

CloudBlackBlackResultData 属性

[缺少 "P:Api.Framework.Tools.CloudBlack.BlackResult.Data" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object Data { get; set; }

属性值

类型：Object
参见

引用

CloudBlackBlackResult 类
Api.Framework.Tools 命名空间


BlackResult 方法

CloudBlackBlackResult 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CloudBlackBlackResult 类
Api.Framework.Tools 命名空间


CloudBlack.BlackType 枚举

CloudBlackBlackType 枚举

黑名单所属平台类型

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum BlackType
成员
成员名称 | 值 | 说明
wechat | 0 |
参见

引用

Api.Framework.Tools 命名空间


CommentsInfo 类

商品评价信息
继承层次
SystemObject
Api.Framework.ToolsCommentsInfo

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CommentsInfo

CommentsInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CommentsInfo | 初始化 CommentsInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | comments | 商品评论数
公共属性 | goodCommentsShare | 商品好评率:百分比，不带百分号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


CommentsInfo 构造函数

初始化 CommentsInfo 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CommentsInfo()
参见

引用

CommentsInfo 类
Api.Framework.Tools 命名空间


CommentsInfo 属性

CommentsInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | comments | 商品评论数
公共属性 | goodCommentsShare | 商品好评率:百分比，不带百分号
Top
参见

引用

CommentsInfo 类
Api.Framework.Tools 命名空间


CommentsInfo.comments 属性

CommentsInfocomments 属性

商品评论数

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int comments { get; set; }

属性值

类型：Int32
参见

引用

CommentsInfo 类
Api.Framework.Tools 命名空间


CommentsInfo.goodCommentsShare 属性

CommentsInfogoodCommentsShare 属性

商品好评率:百分比，不带百分号

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodCommentsShare { get; set; }

属性值

类型：String
参见

引用

CommentsInfo 类
Api.Framework.Tools 命名空间


CommentsInfo 方法

CommentsInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CommentsInfo 类
Api.Framework.Tools 命名空间


ConnectionConfig 类

数据库链接配置
继承层次
SystemObject
Api.Framework.ToolsConnectionConfig

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ConnectionConfig

ConnectionConfig 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ConnectionConfig | 初始化 ConnectionConfig 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ConnectionString | 数据库连接信息
公共属性 | DatabaseType | 数据库类型
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


ConnectionConfig 构造函数

初始化 ConnectionConfig 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ConnectionConfig()
参见

引用

ConnectionConfig 类
Api.Framework.Tools 命名空间


ConnectionConfig 属性

ConnectionConfig 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ConnectionString | 数据库连接信息
公共属性 | DatabaseType | 数据库类型
Top
参见

引用

ConnectionConfig 类
Api.Framework.Tools 命名空间


ConnectionConfig.ConnectionString 属性

ConnectionConfigConnectionString 属性

数据库连接信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ConnectionString { get; set; }

属性值

类型：String
参见

引用

ConnectionConfig 类
Api.Framework.Tools 命名空间


ConnectionConfig.DatabaseType 属性

ConnectionConfigDatabaseType 属性

数据库类型

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DatabaseType DatabaseType { get; set; }

属性值

类型：DatabaseType
参见

引用

ConnectionConfig 类
Api.Framework.Tools 命名空间


ConnectionConfig 方法

ConnectionConfig 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ConnectionConfig 类
Api.Framework.Tools 命名空间


CouponInfo 类

红包信息
继承层次
SystemObject
Api.Framework.ToolsCouponInfo

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CouponInfo

CouponInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CouponInfo | 初始化 CouponInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | activateBeginTime | 券激活开始时间,毫秒级时间戳
公共属性 | activateEndTime | 券激活结束时间,毫秒级时间戳
公共属性 | activedAmount | 劵已激活的数量
公共属性 | buy | 使用门槛
公共属性 | couponName | 优惠劵名称
公共属性 | couponNo | 优惠券批次号
公共属性 | fav | 优惠金额
公共属性 | totalAmount | 生成劵的总量
公共属性 | useBeginTime | 使用开始时间，毫秒级时间戳
公共属性 | useEndTime | 使用结束时间，毫秒级时间戳
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


CouponInfo 构造函数

初始化 CouponInfo 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CouponInfo()
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo 属性

CouponInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | activateBeginTime | 券激活开始时间,毫秒级时间戳
公共属性 | activateEndTime | 券激活结束时间,毫秒级时间戳
公共属性 | activedAmount | 劵已激活的数量
公共属性 | buy | 使用门槛
公共属性 | couponName | 优惠劵名称
公共属性 | couponNo | 优惠券批次号
公共属性 | fav | 优惠金额
公共属性 | totalAmount | 生成劵的总量
公共属性 | useBeginTime | 使用开始时间，毫秒级时间戳
公共属性 | useEndTime | 使用结束时间，毫秒级时间戳
Top
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.activateBeginTime 属性

CouponInfoactivateBeginTime 属性

券激活开始时间,毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long activateBeginTime { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.activateEndTime 属性

CouponInfoactivateEndTime 属性

券激活结束时间,毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long activateEndTime { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.activedAmount 属性

CouponInfoactivedAmount 属性

劵已激活的数量

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int activedAmount { get; set; }

属性值

类型：Int32
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.buy 属性

CouponInfobuy 属性

使用门槛

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string buy { get; set; }

属性值

类型：String
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.couponName 属性

CouponInfocouponName 属性

优惠劵名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string couponName { get; set; }

属性值

类型：String
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.couponNo 属性

CouponInfocouponNo 属性

优惠券批次号

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string couponNo { get; set; }

属性值

类型：String
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.fav 属性

CouponInfofav 属性

优惠金额

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fav { get; set; }

属性值

类型：String
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.totalAmount 属性

CouponInfototalAmount 属性

生成劵的总量

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long totalAmount { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.useBeginTime 属性

CouponInfouseBeginTime 属性

使用开始时间，毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long useBeginTime { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo.useEndTime 属性

CouponInfouseEndTime 属性

使用结束时间，毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long useEndTime { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo 方法

CouponInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CouponInfo 类
Api.Framework.Tools 命名空间


CouponInfo1 类

红包信息
继承层次
SystemObject
Api.Framework.ToolsCouponInfo1

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CouponInfo1

CouponInfo1 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CouponInfo1 | 初始化 CouponInfo1 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | activateBeginTime | 券激活开始时间, 毫秒级时间戳
公共属性 | activateEndTime | 券激活结束时间, 毫秒级时间戳
公共属性 | activedAmount | 劵已激活的数量
公共属性 | buy | 使用门槛
公共属性 | couponName | 优惠券名称
公共属性 | couponNo | 优惠券批次号
公共属性 | fav | 优惠券金额
公共属性 | totalAmount | 生成劵的总量
公共属性 | useBeginTime |
公共属性 | useEndTime | 使用结束时间，毫秒级时间戳
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


CouponInfo1 构造函数

初始化 CouponInfo1 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CouponInfo1()
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1 属性

CouponInfo1 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | activateBeginTime | 券激活开始时间, 毫秒级时间戳
公共属性 | activateEndTime | 券激活结束时间, 毫秒级时间戳
公共属性 | activedAmount | 劵已激活的数量
公共属性 | buy | 使用门槛
公共属性 | couponName | 优惠券名称
公共属性 | couponNo | 优惠券批次号
公共属性 | fav | 优惠券金额
公共属性 | totalAmount | 生成劵的总量
公共属性 | useBeginTime |
公共属性 | useEndTime | 使用结束时间，毫秒级时间戳
Top
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.activateBeginTime 属性

CouponInfo1activateBeginTime 属性

券激活开始时间, 毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long activateBeginTime { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.activateEndTime 属性

CouponInfo1activateEndTime 属性

券激活结束时间, 毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long activateEndTime { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.activedAmount 属性

CouponInfo1activedAmount 属性

劵已激活的数量

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long activedAmount { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.buy 属性

CouponInfo1buy 属性

使用门槛

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string buy { get; set; }

属性值

类型：String
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.couponName 属性

CouponInfo1couponName 属性

优惠券名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string couponName { get; set; }

属性值

类型：String
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.couponNo 属性

CouponInfo1couponNo 属性

优惠券批次号

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string couponNo { get; set; }

属性值

类型：String
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.fav 属性

CouponInfo1fav 属性

优惠券金额

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fav { get; set; }

属性值

类型：String
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.totalAmount 属性

CouponInfo1totalAmount 属性

生成劵的总量

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long totalAmount { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.useBeginTime 属性

CouponInfo1useBeginTime 属性

[缺少 "P:Api.Framework.Tools.CouponInfo1.useBeginTime" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long useBeginTime { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1.useEndTime 属性

CouponInfo1useEndTime 属性

使用结束时间，毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long useEndTime { get; set; }

属性值

类型：Int64
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


CouponInfo1 方法

CouponInfo1 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CouponInfo1 类
Api.Framework.Tools 命名空间


Cover 类

其他
继承层次
SystemObject
Api.Framework.ToolsCover

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Cover

Cover 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Cover | 初始化 Cover 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | uri | xxxxxxxx 不知道是什么
公共属性 | url_list | 商品图片
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


Cover 构造函数

初始化 Cover 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Cover()
参见

引用

Cover 类
Api.Framework.Tools 命名空间


Cover 属性

Cover 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | uri | xxxxxxxx 不知道是什么
公共属性 | url_list | 商品图片
Top
参见

引用

Cover 类
Api.Framework.Tools 命名空间


Cover.uri 属性

Coveruri 属性

xxxxxxxx 不知道是什么

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string uri { get; set; }

属性值

类型：String
参见

引用

Cover 类
Api.Framework.Tools 命名空间


Cover.url_list 属性

Coverurl_list 属性

商品图片

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> url_list { get; set; }

属性值

类型：List String
参见

引用

Cover 类
Api.Framework.Tools 命名空间


Cover 方法

Cover 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Cover 类
Api.Framework.Tools 命名空间


Data 类

商品信息
继承层次
SystemObject
Api.Framework.ToolsData

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Data

Data 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Data | 初始化 Data 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | has_more | 是否还有更多
公共属性 | promotions | 商品信息
公共属性 | search_id | 搜索id
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


Data 构造函数

初始化 Data 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Data()
参见

引用

Data 类
Api.Framework.Tools 命名空间


Data 属性

Data 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | has_more | 是否还有更多
公共属性 | promotions | 商品信息
公共属性 | search_id | 搜索id
Top
参见

引用

Data 类
Api.Framework.Tools 命名空间


Data.has_more 属性

Datahas_more 属性

是否还有更多

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool has_more { get; set; }

属性值

类型：Boolean
参见

引用

Data 类
Api.Framework.Tools 命名空间


Data.promotions 属性

Datapromotions 属性

商品信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<PromotionsItem> promotions { get; set; }

属性值

类型：List PromotionsItem
参见

引用

Data 类
Api.Framework.Tools 命名空间


Data.search_id 属性

Datasearch_id 属性

搜索id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string search_id { get; set; }

属性值

类型：String
参见

引用

Data 类
Api.Framework.Tools 命名空间


Data 方法

Data 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Data 类
Api.Framework.Tools 命名空间


DatabaseType 枚举

数据库类型枚举，需要扩展类型可在此添加

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum DatabaseType
成员
成员名称 | 值 | 说明
SQLSERVER | 1 | MSSQL数据库
ORACLE | 2 | ORACLE数据库
ACCESS | 3 | ACCESS数据库
MYSQL | 4 | MYSQL数据库
SQLITE | 5 | SQLITE数据库
参见

引用

Api.Framework.Tools 命名空间


DetailList 类

商品明细
继承层次
SystemObject
Api.Framework.ToolsDetailList

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DetailList

DetailList 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DetailList | 初始化 DetailList 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | afterSaleInfo | 商品售后信息
公共属性 | brandStoreName | 品牌名称
公共属性 | brandStoreSn | 品牌编号
公共属性 | commCode | 佣金编码：对应商品二级分类
公共属性 | commission | 商品佣金金额(元,保留两位小数)
公共属性 | commissionRate | 商品佣金比例(%)
公共属性 | commissionTotalCost | 商品计佣金额(元,保留两位小数)
公共属性 | commName | 佣金方案名称
公共属性 | goodsCount | 商品数量
公共属性 | goodsFinalPrice | 商品成交价（元,保留两位小数,商品成交价上线之后的订单才有该值）
公共属性 | goodsId | 商品id
公共属性 | goodsName | 商品名称
公共属性 | goodsThumb | 商品缩略图
公共属性 | orderSource | 订单来源
公共属性 | sizeId | 商品尺码：2019.01.01之后可用
公共属性 | spuId | 商品spuId
公共属性 | status | 商品状态：0-不合格，1-待定，2-已完结
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


DetailList 构造函数

初始化 DetailList 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DetailList()
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList 属性

DetailList 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | afterSaleInfo | 商品售后信息
公共属性 | brandStoreName | 品牌名称
公共属性 | brandStoreSn | 品牌编号
公共属性 | commCode | 佣金编码：对应商品二级分类
公共属性 | commission | 商品佣金金额(元,保留两位小数)
公共属性 | commissionRate | 商品佣金比例(%)
公共属性 | commissionTotalCost | 商品计佣金额(元,保留两位小数)
公共属性 | commName | 佣金方案名称
公共属性 | goodsCount | 商品数量
公共属性 | goodsFinalPrice | 商品成交价（元,保留两位小数,商品成交价上线之后的订单才有该值）
公共属性 | goodsId | 商品id
公共属性 | goodsName | 商品名称
公共属性 | goodsThumb | 商品缩略图
公共属性 | orderSource | 订单来源
公共属性 | sizeId | 商品尺码：2019.01.01之后可用
公共属性 | spuId | 商品spuId
公共属性 | status | 商品状态：0-不合格，1-待定，2-已完结
Top
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.afterSaleInfo 属性

DetailListafterSaleInfo 属性

商品售后信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<AfterSaleInfo> afterSaleInfo { get; set; }

属性值

类型：List AfterSaleInfo
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.brandStoreName 属性

DetailListbrandStoreName 属性

品牌名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandStoreName { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.brandStoreSn 属性

DetailListbrandStoreSn 属性

品牌编号

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandStoreSn { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.commCode 属性

DetailListcommCode 属性

佣金编码：对应商品二级分类

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commCode { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.commission 属性

DetailListcommission 属性

商品佣金金额(元,保留两位小数)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commission { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.commissionRate 属性

DetailListcommissionRate 属性

商品佣金比例(%)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commissionRate { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.commissionTotalCost 属性

DetailListcommissionTotalCost 属性

商品计佣金额(元,保留两位小数)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commissionTotalCost { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.commName 属性

DetailListcommName 属性

佣金方案名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commName { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.goodsCount 属性

DetailListgoodsCount 属性

商品数量

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int goodsCount { get; set; }

属性值

类型：Int32
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.goodsFinalPrice 属性

DetailListgoodsFinalPrice 属性

商品成交价（元,保留两位小数,商品成交价上线之后的订单才有该值）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsFinalPrice { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.goodsId 属性

DetailListgoodsId 属性

商品id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsId { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.goodsName 属性

DetailListgoodsName 属性

商品名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsName { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.goodsThumb 属性

DetailListgoodsThumb 属性

商品缩略图

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsThumb { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.orderSource 属性

DetailListorderSource 属性

订单来源

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string orderSource { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.sizeId 属性

DetailListsizeId 属性

商品尺码：2019.01.01之后可用

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string sizeId { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.spuId 属性

DetailListspuId 属性

商品spuId

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string spuId { get; set; }

属性值

类型：String
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList.status 属性

DetailListstatus 属性

商品状态：0-不合格，1-待定，2-已完结

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiOrderStatus status { get; set; }

属性值

类型：WeipinhuiOrderStatus
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DetailList 方法

DetailList 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DetailList 类
Api.Framework.Tools 命名空间


DouyinGoodsInfo 类

抖音商品信息
继承层次
SystemObject
Api.Framework.ToolsDouyinGoodsInfo

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DouyinGoodsInfo

DouyinGoodsInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DouyinGoodsInfo | 初始化 DouyinGoodsInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | code | 返回编码
公共属性 | data | 订单数据对象
公共属性 | log_id | 可能是日志编码
公共属性 | msg | 错误信息
公共属性 | st |
公共属性 | total | 订单数量
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


DouyinGoodsInfo 构造函数

初始化 DouyinGoodsInfo 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DouyinGoodsInfo()
参见

引用

DouyinGoodsInfo 类
Api.Framework.Tools 命名空间


DouyinGoodsInfo 属性

DouyinGoodsInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | code | 返回编码
公共属性 | data | 订单数据对象
公共属性 | log_id | 可能是日志编码
公共属性 | msg | 错误信息
公共属性 | st |
公共属性 | total | 订单数量
Top
参见

引用

DouyinGoodsInfo 类
Api.Framework.Tools 命名空间


DouyinGoodsInfo.code 属性

DouyinGoodsInfocode 属性

返回编码

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int code { get; set; }

属性值

类型：Int32
参见

引用

DouyinGoodsInfo 类
Api.Framework.Tools 命名空间


DouyinGoodsInfo.data 属性

DouyinGoodsInfodata 属性

订单数据对象

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Data data { get; set; }

属性值

类型：Data
参见

引用

DouyinGoodsInfo 类
Api.Framework.Tools 命名空间


DouyinGoodsInfo.log_id 属性

DouyinGoodsInfolog_id 属性

可能是日志编码

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string log_id { get; set; }

属性值

类型：String
参见

引用

DouyinGoodsInfo 类
Api.Framework.Tools 命名空间


DouyinGoodsInfo.msg 属性

DouyinGoodsInfomsg 属性

错误信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string msg { get; set; }

属性值

类型：String
参见

引用

DouyinGoodsInfo 类
Api.Framework.Tools 命名空间


DouyinGoodsInfo.st 属性

DouyinGoodsInfost 属性

[缺少 "P:Api.Framework.Tools.DouyinGoodsInfo.st" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int st { get; set; }

属性值

类型：Int32
参见

引用

DouyinGoodsInfo 类
Api.Framework.Tools 命名空间


DouyinGoodsInfo.total 属性

DouyinGoodsInfototal 属性

订单数量

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int total { get; set; }

属性值

类型：Int32
参见

引用

DouyinGoodsInfo 类
Api.Framework.Tools 命名空间


DouyinGoodsInfo 方法

DouyinGoodsInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DouyinGoodsInfo 类
Api.Framework.Tools 命名空间


DYHelper 类

抖音解析助手
继承层次
SystemObject
Api.Framework.ToolsDYHelper

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class DYHelper

DYHelper 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DYHelper | 初始化 DYHelper 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDyGoodsID | 获取抖音链接中的商品ID
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


DYHelper 构造函数

初始化 DYHelper 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DYHelper()
参见

引用

DYHelper 类
Api.Framework.Tools 命名空间


DYHelper 方法

DYHelper 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDyGoodsID | 获取抖音链接中的商品ID
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

DYHelper 类
Api.Framework.Tools 命名空间


DYHelper.GetDyGoodsID 方法

DYHelperGetDyGoodsID 方法

获取抖音链接中的商品ID

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetDyGoodsID(
    string mess
)

参数

mess
类型：SystemString
包含抖音链接的文本

返回值

类型：String
参见

引用

DYHelper 类
Api.Framework.Tools 命名空间


ExclusiveCoupon 类

渠道专属红包：目前仅开放单品券，没有则返回空
继承层次
SystemObject
Api.Framework.ToolsExclusiveCoupon

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ExclusiveCoupon

ExclusiveCoupon 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExclusiveCoupon | 初始化 ExclusiveCoupon 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | activateBeginTime | 券激活开始时间,毫秒级时间戳
公共属性 | activateEndTime | 券激活结束时间,毫秒级时间戳
公共属性 | activedAmount | 劵已激活的数量：查询详情时返回
公共属性 | buy | 使用门槛：单位-元，查询详情时返回
公共属性 | couponName | 优惠劵名称
公共属性 | couponNo | 优惠券批次号
公共属性 | fav | 优惠金额：单位-元,查询详情时返回
公共属性 | receiveUrl | 专属领券页地址
公共属性 | totalAmount | 生成劵的总量：查询详情时返回
公共属性 | useBeginTime | 使用开始时间，毫秒级时间戳
公共属性 | useEndTime | 使用结束时间，毫秒级时间戳
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


ExclusiveCoupon 构造函数

初始化 ExclusiveCoupon 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExclusiveCoupon()
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon 属性

ExclusiveCoupon 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | activateBeginTime | 券激活开始时间,毫秒级时间戳
公共属性 | activateEndTime | 券激活结束时间,毫秒级时间戳
公共属性 | activedAmount | 劵已激活的数量：查询详情时返回
公共属性 | buy | 使用门槛：单位-元，查询详情时返回
公共属性 | couponName | 优惠劵名称
公共属性 | couponNo | 优惠券批次号
公共属性 | fav | 优惠金额：单位-元,查询详情时返回
公共属性 | receiveUrl | 专属领券页地址
公共属性 | totalAmount | 生成劵的总量：查询详情时返回
公共属性 | useBeginTime | 使用开始时间，毫秒级时间戳
公共属性 | useEndTime | 使用结束时间，毫秒级时间戳
Top
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.activateBeginTime 属性

ExclusiveCouponactivateBeginTime 属性

券激活开始时间,毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long activateBeginTime { get; set; }

属性值

类型：Int64
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.activateEndTime 属性

ExclusiveCouponactivateEndTime 属性

券激活结束时间,毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long activateEndTime { get; set; }

属性值

类型：Int64
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.activedAmount 属性

ExclusiveCouponactivedAmount 属性

劵已激活的数量：查询详情时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long activedAmount { get; set; }

属性值

类型：Int64
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.buy 属性

ExclusiveCouponbuy 属性

使用门槛：单位-元，查询详情时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string buy { get; set; }

属性值

类型：String
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.couponName 属性

ExclusiveCouponcouponName 属性

优惠劵名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string couponName { get; set; }

属性值

类型：String
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.couponNo 属性

ExclusiveCouponcouponNo 属性

优惠券批次号

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string couponNo { get; set; }

属性值

类型：String
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.fav 属性

ExclusiveCouponfav 属性

优惠金额：单位-元,查询详情时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fav { get; set; }

属性值

类型：String
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.receiveUrl 属性

ExclusiveCouponreceiveUrl 属性

专属领券页地址

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string receiveUrl { get; set; }

属性值

类型：String
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.totalAmount 属性

ExclusiveCoupontotalAmount 属性

生成劵的总量：查询详情时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long totalAmount { get; set; }

属性值

类型：Int64
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.useBeginTime 属性

ExclusiveCouponuseBeginTime 属性

使用开始时间，毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long useBeginTime { get; set; }

属性值

类型：Int64
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon.useEndTime 属性

ExclusiveCouponuseEndTime 属性

使用结束时间，毫秒级时间戳

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long useEndTime { get; set; }

属性值

类型：Int64
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


ExclusiveCoupon 方法

ExclusiveCoupon 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ExclusiveCoupon 类
Api.Framework.Tools 命名空间


GoodsInfoList 类

精选商品列表
继承层次
SystemObject
Api.Framework.ToolsGoodsInfoList

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class GoodsInfoList

GoodsInfoList 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GoodsInfoList | 初始化 GoodsInfoList 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | brandId | 商品所属档期（专场）id
公共属性 | brandLogoFull | 商品品牌logo全路径地址
公共属性 | brandName | 商品品牌名称
公共属性 | brandStoreSn | 商品品牌sn
公共属性 | cat1stId | 商品一级分类id
公共属性 | cat1stName | 商品一级分类名称
公共属性 | cat2ndId | 商品二级分类id
公共属性 | cat2ndName | 商品二级分类名称
公共属性 | categoryId | 商品三级分类id
公共属性 | categoryName | 商品三级分类
公共属性 | commission | 佣金金额（元）
公共属性 | commissionRate | 佣金比例（%）
公共属性 | couponInfo | 红包信息
公共属性 | destUrl | 商品落地页
公共属性 | discount | 折扣:唯品价/市场价 保留两位小数字符串
公共属性 | goodsCarouselPictures | 商品轮播图：根据商品id查询时返回，商品列表不返回
公共属性 | goodsDesc | 商品描述,字段暂不输出
公共属性 | goodsDetailPictures | 商品详情图片：根据商品id查询商品信息时返回，商品列表不返回
公共属性 | goodsId | 商品id
公共属性 | goodsMainPicture | 商品主图
公共属性 | goodsName | 商品名称
公共属性 | goodsThumbUrl | 商品缩略图
公共属性 | haiTao | 是否海淘商品标识：1是 0不是
公共属性 | marketPrice | 市场价（元）
公共属性 | schemeEndTime | 商品推广计划有效期预估截止时间：仅为预估时间，仅做参考；时间戳，单位：毫秒
公共属性 | schemeStartTime | 商品所属推广方案开始时间：时间戳，单位：毫秒
公共属性 | sellTimeFrom | 商品售卖开始时间,时间戳，单位毫秒
公共属性 | sellTimeTo | 商品售卖结束时间,时间戳, 单位毫秒
公共属性 | sourceType | 商品类型：0-自营，1-MP
公共属性 | spuId | 商品spuId
公共属性 | status | 商品状态：0-下架，1-上架
公共属性 | storeInfo | 店铺信息
公共属性 | vipPrice | 唯品价（元）
公共属性 | weight | 推广权重，用于确定推广该商品的优先级，权重值越大，优先级越高
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


GoodsInfoList 构造函数

初始化 GoodsInfoList 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public GoodsInfoList()
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList 属性

GoodsInfoList 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | brandId | 商品所属档期（专场）id
公共属性 | brandLogoFull | 商品品牌logo全路径地址
公共属性 | brandName | 商品品牌名称
公共属性 | brandStoreSn | 商品品牌sn
公共属性 | cat1stId | 商品一级分类id
公共属性 | cat1stName | 商品一级分类名称
公共属性 | cat2ndId | 商品二级分类id
公共属性 | cat2ndName | 商品二级分类名称
公共属性 | categoryId | 商品三级分类id
公共属性 | categoryName | 商品三级分类
公共属性 | commission | 佣金金额（元）
公共属性 | commissionRate | 佣金比例（%）
公共属性 | couponInfo | 红包信息
公共属性 | destUrl | 商品落地页
公共属性 | discount | 折扣:唯品价/市场价 保留两位小数字符串
公共属性 | goodsCarouselPictures | 商品轮播图：根据商品id查询时返回，商品列表不返回
公共属性 | goodsDesc | 商品描述,字段暂不输出
公共属性 | goodsDetailPictures | 商品详情图片：根据商品id查询商品信息时返回，商品列表不返回
公共属性 | goodsId | 商品id
公共属性 | goodsMainPicture | 商品主图
公共属性 | goodsName | 商品名称
公共属性 | goodsThumbUrl | 商品缩略图
公共属性 | haiTao | 是否海淘商品标识：1是 0不是
公共属性 | marketPrice | 市场价（元）
公共属性 | schemeEndTime | 商品推广计划有效期预估截止时间：仅为预估时间，仅做参考；时间戳，单位：毫秒
公共属性 | schemeStartTime | 商品所属推广方案开始时间：时间戳，单位：毫秒
公共属性 | sellTimeFrom | 商品售卖开始时间,时间戳，单位毫秒
公共属性 | sellTimeTo | 商品售卖结束时间,时间戳, 单位毫秒
公共属性 | sourceType | 商品类型：0-自营，1-MP
公共属性 | spuId | 商品spuId
公共属性 | status | 商品状态：0-下架，1-上架
公共属性 | storeInfo | 店铺信息
公共属性 | vipPrice | 唯品价（元）
公共属性 | weight | 推广权重，用于确定推广该商品的优先级，权重值越大，优先级越高
Top
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.brandId 属性

GoodsInfoListbrandId 属性

商品所属档期（专场）id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int brandId { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.brandLogoFull 属性

GoodsInfoListbrandLogoFull 属性

商品品牌logo全路径地址

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandLogoFull { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.brandName 属性

GoodsInfoListbrandName 属性

商品品牌名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandName { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.brandStoreSn 属性

GoodsInfoListbrandStoreSn 属性

商品品牌sn

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandStoreSn { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.cat1stId 属性

GoodsInfoListcat1stId 属性

商品一级分类id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int cat1stId { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.cat1stName 属性

GoodsInfoListcat1stName 属性

商品一级分类名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cat1stName { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.cat2ndId 属性

GoodsInfoListcat2ndId 属性

商品二级分类id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int cat2ndId { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.cat2ndName 属性

GoodsInfoListcat2ndName 属性

商品二级分类名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cat2ndName { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.categoryId 属性

GoodsInfoListcategoryId 属性

商品三级分类id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int categoryId { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.categoryName 属性

GoodsInfoListcategoryName 属性

商品三级分类

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string categoryName { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.commission 属性

GoodsInfoListcommission 属性

佣金金额（元）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commission { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.commissionRate 属性

GoodsInfoListcommissionRate 属性

佣金比例（%）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commissionRate { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.couponInfo 属性

GoodsInfoListcouponInfo 属性

红包信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CouponInfo couponInfo { get; set; }

属性值

类型：CouponInfo
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.destUrl 属性

GoodsInfoListdestUrl 属性

商品落地页

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string destUrl { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.discount 属性

GoodsInfoListdiscount 属性

折扣:唯品价/市场价 保留两位小数字符串

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string discount { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.goodsCarouselPictures 属性

GoodsInfoListgoodsCarouselPictures 属性

商品轮播图：根据商品id查询时返回，商品列表不返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> goodsCarouselPictures { get; set; }

属性值

类型：List String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.goodsDesc 属性

GoodsInfoListgoodsDesc 属性

商品描述,字段暂不输出

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsDesc { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.goodsDetailPictures 属性

GoodsInfoListgoodsDetailPictures 属性

商品详情图片：根据商品id查询商品信息时返回，商品列表不返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> goodsDetailPictures { get; set; }

属性值

类型：List String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.goodsId 属性

GoodsInfoListgoodsId 属性

商品id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsId { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.goodsMainPicture 属性

GoodsInfoListgoodsMainPicture 属性

商品主图

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsMainPicture { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.goodsName 属性

GoodsInfoListgoodsName 属性

商品名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsName { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.goodsThumbUrl 属性

GoodsInfoListgoodsThumbUrl 属性

商品缩略图

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsThumbUrl { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.haiTao 属性

GoodsInfoListhaiTao 属性

是否海淘商品标识：1是 0不是

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int haiTao { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.marketPrice 属性

GoodsInfoListmarketPrice 属性

市场价（元）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string marketPrice { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.schemeEndTime 属性

GoodsInfoListschemeEndTime 属性

商品推广计划有效期预估截止时间：仅为预估时间，仅做参考；时间戳，单位：毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long schemeEndTime { get; set; }

属性值

类型：Int64
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.schemeStartTime 属性

GoodsInfoListschemeStartTime 属性

商品所属推广方案开始时间：时间戳，单位：毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long schemeStartTime { get; set; }

属性值

类型：Int64
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.sellTimeFrom 属性

GoodsInfoListsellTimeFrom 属性

商品售卖开始时间,时间戳，单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long sellTimeFrom { get; set; }

属性值

类型：Int64
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.sellTimeTo 属性

GoodsInfoListsellTimeTo 属性

商品售卖结束时间,时间戳, 单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long sellTimeTo { get; set; }

属性值

类型：Int64
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.sourceType 属性

GoodsInfoListsourceType 属性

商品类型：0-自营，1-MP

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int sourceType { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.spuId 属性

GoodsInfoListspuId 属性

商品spuId

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string spuId { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.status 属性

GoodsInfoListstatus 属性

商品状态：0-下架，1-上架

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int status { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.storeInfo 属性

GoodsInfoListstoreInfo 属性

店铺信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public StoreInfo storeInfo { get; set; }

属性值

类型：StoreInfo
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.vipPrice 属性

GoodsInfoListvipPrice 属性

唯品价（元）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string vipPrice { get; set; }

属性值

类型：String
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList.weight 属性

GoodsInfoListweight 属性

推广权重，用于确定推广该商品的优先级，权重值越大，优先级越高

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long weight { get; set; }

属性值

类型：Int64
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoList 方法

GoodsInfoList 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

GoodsInfoList 类
Api.Framework.Tools 命名空间


GoodsInfoResponseResult 类

[缺少 "T:Api.Framework.Tools.GoodsInfoResponseResult" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsGoodsInfoResponseResult

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class GoodsInfoResponseResult

GoodsInfoResponseResult 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GoodsInfoResponseResult | 初始化 GoodsInfoResponseResult 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | result |
公共属性 | returnCode |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


GoodsInfoResponseResult 构造函数

初始化 GoodsInfoResponseResult 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public GoodsInfoResponseResult()
参见

引用

GoodsInfoResponseResult 类
Api.Framework.Tools 命名空间


GoodsInfoResponseResult 属性

GoodsInfoResponseResult 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | result |
公共属性 | returnCode |
Top
参见

引用

GoodsInfoResponseResult 类
Api.Framework.Tools 命名空间


GoodsInfoResponseResult.result 属性

GoodsInfoResponseResultresult 属性

[缺少 "P:Api.Framework.Tools.GoodsInfoResponseResult.result" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public GoodsInfoResult result { get; set; }

属性值

类型：GoodsInfoResult
参见

引用

GoodsInfoResponseResult 类
Api.Framework.Tools 命名空间


GoodsInfoResponseResult.returnCode 属性

GoodsInfoResponseResultreturnCode 属性

[缺少 "P:Api.Framework.Tools.GoodsInfoResponseResult.returnCode" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string returnCode { get; set; }

属性值

类型：String
参见

引用

GoodsInfoResponseResult 类
Api.Framework.Tools 命名空间


GoodsInfoResponseResult 方法

GoodsInfoResponseResult 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

GoodsInfoResponseResult 类
Api.Framework.Tools 命名空间


GoodsInfoResult 类

精选商品列表
继承层次
SystemObject
Api.Framework.ToolsGoodsInfoResult

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class GoodsInfoResult

GoodsInfoResult 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GoodsInfoResult | 初始化 GoodsInfoResult 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | goodsInfoList | 精选商品列表
公共属性 | page | 当前页码
公共属性 | pageSize | 分页大小
公共属性 | sortFields | 支持的排序字段,为空时仅支持默认排序
公共属性 | total | 总数
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


GoodsInfoResult 构造函数

初始化 GoodsInfoResult 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public GoodsInfoResult()
参见

引用

GoodsInfoResult 类
Api.Framework.Tools 命名空间


GoodsInfoResult 属性

GoodsInfoResult 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | goodsInfoList | 精选商品列表
公共属性 | page | 当前页码
公共属性 | pageSize | 分页大小
公共属性 | sortFields | 支持的排序字段,为空时仅支持默认排序
公共属性 | total | 总数
Top
参见

引用

GoodsInfoResult 类
Api.Framework.Tools 命名空间


GoodsInfoResult.goodsInfoList 属性

GoodsInfoResultgoodsInfoList 属性

精选商品列表

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<GoodsInfoList> goodsInfoList { get; set; }

属性值

类型：List GoodsInfoList
参见

引用

GoodsInfoResult 类
Api.Framework.Tools 命名空间


GoodsInfoResult.page 属性

GoodsInfoResultpage 属性

当前页码

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int page { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoResult 类
Api.Framework.Tools 命名空间


GoodsInfoResult.pageSize 属性

GoodsInfoResultpageSize 属性

分页大小

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int pageSize { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoResult 类
Api.Framework.Tools 命名空间


GoodsInfoResult.sortFields 属性

GoodsInfoResultsortFields 属性

支持的排序字段,为空时仅支持默认排序

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<Object> sortFields { get; set; }

属性值

类型：List Object
参见

引用

GoodsInfoResult 类
Api.Framework.Tools 命名空间


GoodsInfoResult.total 属性

GoodsInfoResulttotal 属性

总数

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int total { get; set; }

属性值

类型：Int32
参见

引用

GoodsInfoResult 类
Api.Framework.Tools 命名空间


GoodsInfoResult 方法

GoodsInfoResult 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

GoodsInfoResult 类
Api.Framework.Tools 命名空间


h5Top 类

h5
继承层次
SystemObject
Api.Framework.Toolsh5Top

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class h5Top

h5Top 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | h5Top | 初始化 h5Top 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | AnalysisItemidByTljUrl |
公共方法 | AnalysisTljUrl |
公共方法 | CreateTaopass |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCookiesValue |
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetItemIdByTKL | 通过淘口令获取商品连接
公共方法 | GetMobileTaobao |
公共方法 | GetPasswordDetail | 通过淘宝口令获取信息(返回字典)
公共方法 | GetType | (继承自 Object。)
公共方法 | M_GET |
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
字段
 | 名称 | 说明
公共字段 | activityId | 优惠券activityId
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


h5Top 构造函数

初始化 h5Top 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public h5Top()
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top 方法

h5Top 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AnalysisItemidByTljUrl |
公共方法 | AnalysisTljUrl |
公共方法 | CreateTaopass |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCookiesValue |
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetItemIdByTKL | 通过淘口令获取商品连接
公共方法 | GetMobileTaobao |
公共方法 | GetPasswordDetail | 通过淘宝口令获取信息(返回字典)
公共方法 | GetType | (继承自 Object。)
公共方法 | M_GET |
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top.AnalysisItemidByTljUrl 方法

h5TopAnalysisItemidByTljUrl 方法

[缺少 "M:Api.Framework.Tools.h5Top.AnalysisItemidByTljUrl(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string AnalysisItemidByTljUrl(
    string url
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.AnalysisItemidByTljUrl(System.String)" 的 <param name="url"/> 文档]

返回值

类型：String
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top.AnalysisTljUrl 方法

h5TopAnalysisTljUrl 方法

[缺少 "M:Api.Framework.Tools.h5Top.AnalysisTljUrl(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> AnalysisTljUrl(
    string vegasCode
)

参数

vegasCode
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.AnalysisTljUrl(System.String)" 的 <param name="vegasCode"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top.CreateTaopass 方法

h5TopCreateTaopass 方法

[缺少 "M:Api.Framework.Tools.h5Top.CreateTaopass(System.String,System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> CreateTaopass(
    string text,
    string url,
    string pic
)

参数

text
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.CreateTaopass(System.String,System.String,System.String)" 的 <param name="text"/> 文档]

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.CreateTaopass(System.String,System.String,System.String)" 的 <param name="url"/> 文档]

pic
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.CreateTaopass(System.String,System.String,System.String)" 的 <param name="pic"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top.GetCookiesValue 方法

h5TopGetCookiesValue 方法

[缺少 "M:Api.Framework.Tools.h5Top.GetCookiesValue(System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetCookiesValue(
    string key,
    string cookies
)

参数

key
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.GetCookiesValue(System.String,System.String)" 的 <param name="key"/> 文档]

cookies
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.GetCookiesValue(System.String,System.String)" 的 <param name="cookies"/> 文档]

返回值

类型：String
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top.GetItemIdByTKL 方法

h5TopGetItemIdByTKL 方法

通过淘口令获取商品连接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetItemIdByTKL(
    string password,
    AlimamaApi api = null
)

参数

password
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.GetItemIdByTKL(System.String,Api.Framework.Cps.AlimamaApi)" 的 <param name="password"/> 文档]

api (Optional)
类型：Api.Framework.CpsAlimamaApi

[缺少 "M:Api.Framework.Tools.h5Top.GetItemIdByTKL(System.String,Api.Framework.Cps.AlimamaApi)" 的 <param name="api"/> 文档]

返回值

类型：String
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top.GetMobileTaobao 方法

h5TopGetMobileTaobao 方法

[缺少 "M:Api.Framework.Tools.h5Top.GetMobileTaobao(System.String,System.Object,System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> GetMobileTaobao(
    string api,
    Object data,
    string v,
    string method = "get"
)

参数

api
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.GetMobileTaobao(System.String,System.Object,System.String,System.String)" 的 <param name="api"/> 文档]

data
类型：SystemObject

[缺少 "M:Api.Framework.Tools.h5Top.GetMobileTaobao(System.String,System.Object,System.String,System.String)" 的 <param name="data"/> 文档]

v
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.GetMobileTaobao(System.String,System.Object,System.String,System.String)" 的 <param name="v"/> 文档]

method (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.GetMobileTaobao(System.String,System.Object,System.String,System.String)" 的 <param name="method"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top.GetPasswordDetail 方法

h5TopGetPasswordDetail 方法

通过淘宝口令获取信息(返回字典)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> GetPasswordDetail(
    string password
)

参数

password
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.GetPasswordDetail(System.String)" 的 <param name="password"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top.M_GET 方法

h5TopM_GET 方法

[缺少 "M:Api.Framework.Tools.h5Top.M_GET(System.String,System.Object,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> M_GET(
    string api,
    Object data,
    string version = "1.0"
)

参数

api
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.M_GET(System.String,System.Object,System.String)" 的 <param name="api"/> 文档]

data
类型：SystemObject

[缺少 "M:Api.Framework.Tools.h5Top.M_GET(System.String,System.Object,System.String)" 的 <param name="data"/> 文档]

version (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.h5Top.M_GET(System.String,System.Object,System.String)" 的 <param name="version"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top 字段

h5Top 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | activityId | 优惠券activityId
Top
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


h5Top.activityId 字段

h5TopactivityId 字段

优惠券activityId

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string activityId

字段值

类型：String
参见

引用

h5Top 类
Api.Framework.Tools 命名空间


HTTPClass 类

[缺少 "T:Api.Framework.Tools.HTTPClass" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsHTTPClass

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class HTTPClass

HTTPClass 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | HTTPClass | 初始化 HTTPClass 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | HTTP |
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


HTTPClass 构造函数

初始化 HTTPClass 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public HTTPClass()
参见

引用

HTTPClass 类
Api.Framework.Tools 命名空间


HTTPClass 方法

HTTPClass 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | HTTP |
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

HTTPClass 类
Api.Framework.Tools 命名空间


HTTPClass.HTTP 方法

HTTPClassHTTP 方法

[缺少 "M:Api.Framework.Tools.HTTPClass.HTTP(System.String,System.String,System.String,System.String,System.Text.Encoding)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Response HTTP(
    string _url,
    string _type,
    string _postdata,
    string _cookie,
    Encoding _responseEncode
)

参数

_url
类型：SystemString

[缺少 "M:Api.Framework.Tools.HTTPClass.HTTP(System.String,System.String,System.String,System.String,System.Text.Encoding)" 的 <param name="_url"/> 文档]

_type
类型：SystemString

[缺少 "M:Api.Framework.Tools.HTTPClass.HTTP(System.String,System.String,System.String,System.String,System.Text.Encoding)" 的 <param name="_type"/> 文档]

_postdata
类型：SystemString

[缺少 "M:Api.Framework.Tools.HTTPClass.HTTP(System.String,System.String,System.String,System.String,System.Text.Encoding)" 的 <param name="_postdata"/> 文档]

_cookie
类型：SystemString

[缺少 "M:Api.Framework.Tools.HTTPClass.HTTP(System.String,System.String,System.String,System.String,System.Text.Encoding)" 的 <param name="_cookie"/> 文档]

_responseEncode
类型：System.TextEncoding

[缺少 "M:Api.Framework.Tools.HTTPClass.HTTP(System.String,System.String,System.String,System.String,System.Text.Encoding)" 的 <param name="_responseEncode"/> 文档]

返回值

类型：Response
参见

引用

HTTPClass 类
Api.Framework.Tools 命名空间


IniHelper 类

ini配置文件操作类
继承层次
SystemObject
Api.Framework.ToolsIniHelper

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class IniHelper

IniHelper 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | IniHelper | ini文件完整路径
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | GetValue | 获取ini配置文件中指定key的数据
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SetValue | 设置ini配置文件的字段
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


IniHelper 构造函数

ini文件完整路径

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public IniHelper(
    string fileName
)

参数

fileName
类型：SystemString

[缺少 "M:Api.Framework.Tools.IniHelper.#ctor(System.String)" 的 <param name="fileName"/> 文档]

参见

引用

IniHelper 类
Api.Framework.Tools 命名空间


IniHelper 方法

IniHelper 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | GetValue | 获取ini配置文件中指定key的数据
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | SetValue | 设置ini配置文件的字段
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

IniHelper 类
Api.Framework.Tools 命名空间


IniHelper.GetValue 方法

IniHelperGetValue 方法

获取ini配置文件中指定key的数据

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetValue(
    string node,
    string key
)

参数

node
类型：SystemString
头
key
类型：SystemString
头下面的key

返回值

类型：String
参见

引用

IniHelper 类
Api.Framework.Tools 命名空间


IniHelper.SetValue 方法

IniHelperSetValue 方法

设置ini配置文件的字段

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SetValue(
    string node,
    string key,
    string value
)

参数

node
类型：SystemString
头
key
类型：SystemString
键
value
类型：SystemString
值
参见

引用

IniHelper 类
Api.Framework.Tools 命名空间


JDHelper 类

京东解析助手
继承层次
SystemObject
Api.Framework.ToolsJDHelper

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class JDHelper

JDHelper 类型公开以下成员。

方法
名称 | 说明
GetJingdongItemId | 通过字符串获取京东商品id
Top
参见

引用

Api.Framework.Tools 命名空间


JDHelper 方法

JDHelper 类型公开以下成员。

方法
名称 | 说明
GetJingdongItemId | 通过字符串获取京东商品id
Top
参见

引用

JDHelper 类
Api.Framework.Tools 命名空间


JDHelper.GetJingdongItemId 方法

JDHelperGetJingdongItemId 方法

通过字符串获取京东商品id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetJingdongItemId(
    string str
)

参数

str
类型：SystemString
包含京东链接的文本

返回值

类型：String
参见

引用

JDHelper 类
Api.Framework.Tools 命名空间


JoinedActivities 类

商品参与活动信息:未参与活动集合为空
继承层次
SystemObject
Api.Framework.ToolsJoinedActivities

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class JoinedActivities

JoinedActivities 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | JoinedActivities | 初始化 JoinedActivities 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | actName | 活动名称
公共属性 | actType | 活动类型:18-唯品快抢
公共属性 | beginTime | 开始时间：时间戳，单位毫秒
公共属性 | endTime | 结束时间：时间戳，单位毫秒
公共属性 | foreShowBeginTime | 预热开始时间：时间戳，单位毫秒
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


JoinedActivities 构造函数

初始化 JoinedActivities 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public JoinedActivities()
参见

引用

JoinedActivities 类
Api.Framework.Tools 命名空间


JoinedActivities 属性

JoinedActivities 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | actName | 活动名称
公共属性 | actType | 活动类型:18-唯品快抢
公共属性 | beginTime | 开始时间：时间戳，单位毫秒
公共属性 | endTime | 结束时间：时间戳，单位毫秒
公共属性 | foreShowBeginTime | 预热开始时间：时间戳，单位毫秒
Top
参见

引用

JoinedActivities 类
Api.Framework.Tools 命名空间


JoinedActivities.actName 属性

JoinedActivitiesactName 属性

活动名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string actName { get; set; }

属性值

类型：String
参见

引用

JoinedActivities 类
Api.Framework.Tools 命名空间


JoinedActivities.actType 属性

JoinedActivitiesactType 属性

活动类型:18-唯品快抢

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int actType { get; set; }

属性值

类型：Int32
参见

引用

JoinedActivities 类
Api.Framework.Tools 命名空间


JoinedActivities.beginTime 属性

JoinedActivitiesbeginTime 属性

开始时间：时间戳，单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long beginTime { get; set; }

属性值

类型：Int64
参见

引用

JoinedActivities 类
Api.Framework.Tools 命名空间


JoinedActivities.endTime 属性

JoinedActivitiesendTime 属性

结束时间：时间戳，单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long endTime { get; set; }

属性值

类型：Int64
参见

引用

JoinedActivities 类
Api.Framework.Tools 命名空间


JoinedActivities.foreShowBeginTime 属性

JoinedActivitiesforeShowBeginTime 属性

预热开始时间：时间戳，单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long foreShowBeginTime { get; set; }

属性值

类型：Int64
参见

引用

JoinedActivities 类
Api.Framework.Tools 命名空间


JoinedActivities 方法

JoinedActivities 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

JoinedActivities 类
Api.Framework.Tools 命名空间


KuaiZhanShort 类

快站短网址
继承层次
SystemObject
Api.Framework.ToolsKuaiZhanShort

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class KuaiZhanShort

KuaiZhanShort 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | KuaiZhanShort | 初始化 KuaiZhanShort 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetShort | 快站缩短
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


KuaiZhanShort 构造函数

初始化 KuaiZhanShort 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public KuaiZhanShort()
参见

引用

KuaiZhanShort 类
Api.Framework.Tools 命名空间


KuaiZhanShort 方法

KuaiZhanShort 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetShort | 快站缩短
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

KuaiZhanShort 类
Api.Framework.Tools 命名空间


KuaiZhanShort.GetShort 方法

KuaiZhanShortGetShort 方法

快站缩短

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetShort(
    string url
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.KuaiZhanShort.GetShort(System.String)" 的 <param name="url"/> 文档]

返回值

类型：String
参见

引用

KuaiZhanShort 类
Api.Framework.Tools 命名空间


OrderHelper 类

订单助手
继承层次
SystemObject
Api.Framework.ToolsOrderHelper

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class OrderHelper

OrderHelper 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | OrderHelper | 初始化 OrderHelper 类的一个新实例
Top
方法
 | 名称 | 说明
 | CheckMemberFirstOrderRewards | 判断是否用户首单奖励
 | CheckSuperiorInviteRewards | 判断上级是否获得推荐奖励
公共方法 | DeductAliOrderPoint | 扣除已经阿里结算订单的用户所得
公共方法 | DeductJingDongOrderPoint | 扣除已经京东结算订单的用户所得
公共方法 | DeductPinDuoOrderPoint | 扣除已经拼多结算订单的用户所得
公共方法 | DeductWeipinhuiOrderPoint | 扣除已经唯品会结算订单的用户所得
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | IsCurrentCpsMess | 简单判断消息是否为指定cps类型
 | IsOrderId | 判断是否是三个平台的订单号
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | RefreshConfig | 刷新用户裂变配置
 | RefreshDyConfig | 获取抖音配置
 | RefreshPddConfig | 获取拼多多配置
 | RefreshTbConfig | 获取阿里配置
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


OrderHelper 构造函数

初始化 OrderHelper 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OrderHelper()
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper 方法

OrderHelper 类型公开以下成员。

方法
 | 名称 | 说明
 | CheckMemberFirstOrderRewards | 判断是否用户首单奖励
 | CheckSuperiorInviteRewards | 判断上级是否获得推荐奖励
公共方法 | DeductAliOrderPoint | 扣除已经阿里结算订单的用户所得
公共方法 | DeductJingDongOrderPoint | 扣除已经京东结算订单的用户所得
公共方法 | DeductPinDuoOrderPoint | 扣除已经拼多结算订单的用户所得
公共方法 | DeductWeipinhuiOrderPoint | 扣除已经唯品会结算订单的用户所得
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | IsCurrentCpsMess | 简单判断消息是否为指定cps类型
 | IsOrderId | 判断是否是三个平台的订单号
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | RefreshConfig | 刷新用户裂变配置
 | RefreshDyConfig | 获取抖音配置
 | RefreshPddConfig | 获取拼多多配置
 | RefreshTbConfig | 获取阿里配置
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.CheckMemberFirstOrderRewards 方法

OrderHelperCheckMemberFirstOrderRewards 方法

判断是否用户首单奖励

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool CheckMemberFirstOrderRewards(
    fl_member_info _member,
    SystemOrderStatus _orderStatus
)

参数

_member
类型：Api.Framework.Modelfl_member_info

[缺少 "M:Api.Framework.Tools.OrderHelper.CheckMemberFirstOrderRewards(Api.Framework.Model.fl_member_info,Api.Framework.Enums.SystemOrderStatus)" 的 <param name="_member"/> 文档]

_orderStatus
类型：Api.Framework.EnumsSystemOrderStatus
系统订单类型

返回值

类型：Boolean
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.CheckSuperiorInviteRewards 方法

OrderHelperCheckSuperiorInviteRewards 方法

判断上级是否获得推荐奖励

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool CheckSuperiorInviteRewards(
    fl_member_info _member,
    DateTime _endtime,
    double _price
)

参数

_member
类型：Api.Framework.Modelfl_member_info
订单所绑定的用户对象
_endtime
类型：SystemDateTime
订单结算时间
_price
类型：SystemDouble
付款金额

返回值

类型：Boolean
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.DeductAliOrderPoint 方法

OrderHelperDeductAliOrderPoint 方法

扣除已经阿里结算订单的用户所得

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void DeductAliOrderPoint(
    List<OrderNoticeEvent> notices,
    fl_order_alimama order
)

参数

notices
类型：System.Collections.GenericList OrderNoticeEvent
通知集合
order
类型：Api.Framework.Modelfl_order_alimama
阿里订单对象
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.DeductJingDongOrderPoint 方法

OrderHelperDeductJingDongOrderPoint 方法

扣除已经京东结算订单的用户所得

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void DeductJingDongOrderPoint(
    List<OrderNoticeEvent> notices,
    fl_order_jingdong order,
    ItemPoint itempoint
)

参数

notices
类型：System.Collections.GenericList OrderNoticeEvent
通知集合
order
类型：Api.Framework.Modelfl_order_jingdong
京东订单对象
itempoint
类型：ItemPoint
积分分配对象
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.DeductPinDuoOrderPoint 方法

OrderHelperDeductPinDuoOrderPoint 方法

扣除已经拼多结算订单的用户所得

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void DeductPinDuoOrderPoint(
    List<OrderNoticeEvent> notice,
    fl_order_pinduoduo db_order
)

参数

notice
类型：System.Collections.GenericList OrderNoticeEvent
通知集合
db_order
类型：Api.Framework.Modelfl_order_pinduoduo
拼多多订单对象
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.DeductWeipinhuiOrderPoint 方法

OrderHelperDeductWeipinhuiOrderPoint 方法

扣除已经唯品会结算订单的用户所得

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool DeductWeipinhuiOrderPoint(
    List<OrderNoticeEvent> notice,
    fl_order_weipinhui db_order
)

参数

notice
类型：System.Collections.GenericList OrderNoticeEvent
通知集合
db_order
类型：Api.Framework.Modelfl_order_weipinhui
唯品会订单对象

返回值

类型：Boolean
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.IsCurrentCpsMess 方法

OrderHelperIsCurrentCpsMess 方法

简单判断消息是否为指定cps类型

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool IsCurrentCpsMess(
    string mess,
    CpsType cpsType
)

参数

mess
类型：SystemString
消息
cpsType
类型：Api.Framework.EnumsCpsType
cps类型

返回值

类型：Boolean
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.IsOrderId 方法

OrderHelperIsOrderId 方法

判断是否是三个平台的订单号

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool IsOrderId(
    string mess
)

参数

mess
类型：SystemString
判断是否为已知的cps订单

返回值

类型：Boolean
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.RefreshConfig 方法

OrderHelperRefreshConfig 方法

刷新用户裂变配置

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void RefreshConfig(
    bool refresh = false
)

参数

refresh (Optional)
类型：SystemBoolean
刷新
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.RefreshDyConfig 方法

OrderHelperRefreshDyConfig 方法

获取抖音配置

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, Object> RefreshDyConfig(
    bool refresh = false
)

参数

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：Dictionary String, Object
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.RefreshPddConfig 方法

OrderHelperRefreshPddConfig 方法

获取拼多多配置

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, Object> RefreshPddConfig(
    bool refresh = false
)

参数

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：Dictionary String, Object
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderHelper.RefreshTbConfig 方法

OrderHelperRefreshTbConfig 方法

获取阿里配置

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, Object> RefreshTbConfig(
    bool refresh = false
)

参数

refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：Dictionary String, Object
参见

引用

OrderHelper 类
Api.Framework.Tools 命名空间


OrderInfoList 类

业绩查询响应结果
继承层次
SystemObject
Api.Framework.ToolsOrderInfoList

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class OrderInfoList

OrderInfoList 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | OrderInfoList | 初始化 OrderInfoList 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | afterSaleChangeCommission | 售后订单佣金变动：仅在订单完结之后发生售后行为时返回
公共属性 | afterSaleChangeGoodsCount | 售后订单总商品数量变动：仅在订单完结之后发生售后行为时返回
公共属性 | appKey | 开发者调用的appKey：当订单是通过开发者API推广成单时返回，其余时候返回为空
公共属性 | channelTag | 渠道商模式下表示自定义渠道标识；工具商模式下表示pid
公共属性 | commission | 商品总佣金:单位元
公共属性 | commissionEnterTime | 入账时间，时间戳，单位毫秒
公共属性 | detailList | 商品明细
公共属性 | isPrepay | 是否预付订单:0-否，1-是
公共属性 | isSplit | 订单拆单标识: 0-否，1-是
公共属性 | lastUpdateTime | 订单上次更新时间 时间戳 单位毫秒
公共属性 | newCustomer | 新老客：0-待定，1-新客，2-老客
公共属性 | orderSn | 订单号
公共属性 | orderSource | 订单来源
公共属性 | orderSubStatusName | 订单子状态：流转状态-支持状态：（已下单、已付款、已签收、待结算、已结算、已失效）
公共属性 | orderTime | 下单时间 时间戳 单位毫秒
公共属性 | orderTrackReason | 订单归因方式：0-常规推广,1-惊喜红包,2-锁粉,3-超级红包
公共属性 | parentSn | 订单母单号:订单为拆单子单时返回
公共属性 | pid | 推广PID:目前等同于channelTag
公共属性 | selfBuy | 是否自推自买 0-否，1-是
公共属性 | settled | 订单结算状态 0-未结算,1-已结算
公共属性 | settledTime | 结算时间 时间戳 单位毫秒
公共属性 | signTime | 签收时间 时间戳 单位毫秒
公共属性 | statParam | 自定义统计参数
公共属性 | status | 订单状态:0-不合格，1-待定，2-已完结
公共属性 | totalCost | 订单支付金额:单位元
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


OrderInfoList 构造函数

初始化 OrderInfoList 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OrderInfoList()
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList 属性

OrderInfoList 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | afterSaleChangeCommission | 售后订单佣金变动：仅在订单完结之后发生售后行为时返回
公共属性 | afterSaleChangeGoodsCount | 售后订单总商品数量变动：仅在订单完结之后发生售后行为时返回
公共属性 | appKey | 开发者调用的appKey：当订单是通过开发者API推广成单时返回，其余时候返回为空
公共属性 | channelTag | 渠道商模式下表示自定义渠道标识；工具商模式下表示pid
公共属性 | commission | 商品总佣金:单位元
公共属性 | commissionEnterTime | 入账时间，时间戳，单位毫秒
公共属性 | detailList | 商品明细
公共属性 | isPrepay | 是否预付订单:0-否，1-是
公共属性 | isSplit | 订单拆单标识: 0-否，1-是
公共属性 | lastUpdateTime | 订单上次更新时间 时间戳 单位毫秒
公共属性 | newCustomer | 新老客：0-待定，1-新客，2-老客
公共属性 | orderSn | 订单号
公共属性 | orderSource | 订单来源
公共属性 | orderSubStatusName | 订单子状态：流转状态-支持状态：（已下单、已付款、已签收、待结算、已结算、已失效）
公共属性 | orderTime | 下单时间 时间戳 单位毫秒
公共属性 | orderTrackReason | 订单归因方式：0-常规推广,1-惊喜红包,2-锁粉,3-超级红包
公共属性 | parentSn | 订单母单号:订单为拆单子单时返回
公共属性 | pid | 推广PID:目前等同于channelTag
公共属性 | selfBuy | 是否自推自买 0-否，1-是
公共属性 | settled | 订单结算状态 0-未结算,1-已结算
公共属性 | settledTime | 结算时间 时间戳 单位毫秒
公共属性 | signTime | 签收时间 时间戳 单位毫秒
公共属性 | statParam | 自定义统计参数
公共属性 | status | 订单状态:0-不合格，1-待定，2-已完结
公共属性 | totalCost | 订单支付金额:单位元
Top
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.afterSaleChangeCommission 属性

OrderInfoListafterSaleChangeCommission 属性

售后订单佣金变动：仅在订单完结之后发生售后行为时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string afterSaleChangeCommission { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.afterSaleChangeGoodsCount 属性

OrderInfoListafterSaleChangeGoodsCount 属性

售后订单总商品数量变动：仅在订单完结之后发生售后行为时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string afterSaleChangeGoodsCount { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.appKey 属性

OrderInfoListappKey 属性

开发者调用的appKey：当订单是通过开发者API推广成单时返回，其余时候返回为空

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string appKey { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.channelTag 属性

OrderInfoListchannelTag 属性

渠道商模式下表示自定义渠道标识；工具商模式下表示pid

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string channelTag { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.commission 属性

OrderInfoListcommission 属性

商品总佣金:单位元

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commission { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.commissionEnterTime 属性

OrderInfoListcommissionEnterTime 属性

入账时间，时间戳，单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long commissionEnterTime { get; set; }

属性值

类型：Int64
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.detailList 属性

OrderInfoListdetailList 属性

商品明细

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<DetailList> detailList { get; set; }

属性值

类型：List DetailList
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.isPrepay 属性

OrderInfoListisPrepay 属性

是否预付订单:0-否，1-是

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiShiFou isPrepay { get; set; }

属性值

类型：WeipinhuiShiFou
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.isSplit 属性

OrderInfoListisSplit 属性

订单拆单标识: 0-否，1-是

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiShiFou isSplit { get; set; }

属性值

类型：WeipinhuiShiFou
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.lastUpdateTime 属性

OrderInfoListlastUpdateTime 属性

订单上次更新时间 时间戳 单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long lastUpdateTime { get; set; }

属性值

类型：Int64
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.newCustomer 属性

OrderInfoListnewCustomer 属性

新老客：0-待定，1-新客，2-老客

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiNewCustomer newCustomer { get; set; }

属性值

类型：WeipinhuiNewCustomer
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.orderSn 属性

OrderInfoListorderSn 属性

订单号

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string orderSn { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.orderSource 属性

OrderInfoListorderSource 属性

订单来源

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string orderSource { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.orderSubStatusName 属性

OrderInfoListorderSubStatusName 属性

订单子状态：流转状态-支持状态：（已下单、已付款、已签收、待结算、已结算、已失效）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string orderSubStatusName { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.orderTime 属性

OrderInfoListorderTime 属性

下单时间 时间戳 单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long orderTime { get; set; }

属性值

类型：Int64
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.orderTrackReason 属性

OrderInfoListorderTrackReason 属性

订单归因方式：0-常规推广,1-惊喜红包,2-锁粉,3-超级红包

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiGuiYin orderTrackReason { get; set; }

属性值

类型：WeipinhuiGuiYin
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.parentSn 属性

OrderInfoListparentSn 属性

订单母单号:订单为拆单子单时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string parentSn { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.pid 属性

OrderInfoListpid 属性

推广PID:目前等同于channelTag

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string pid { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.selfBuy 属性

OrderInfoListselfBuy 属性

是否自推自买 0-否，1-是

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiShiFou selfBuy { get; set; }

属性值

类型：WeipinhuiShiFou
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.settled 属性

OrderInfoListsettled 属性

订单结算状态 0-未结算,1-已结算

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiOrderSettled settled { get; set; }

属性值

类型：WeipinhuiOrderSettled
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.settledTime 属性

OrderInfoListsettledTime 属性

结算时间 时间戳 单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long settledTime { get; set; }

属性值

类型：Int64
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.signTime 属性

OrderInfoListsignTime 属性

签收时间 时间戳 单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long signTime { get; set; }

属性值

类型：Int64
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.statParam 属性

OrderInfoListstatParam 属性

自定义统计参数

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string statParam { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.status 属性

OrderInfoListstatus 属性

订单状态:0-不合格，1-待定，2-已完结

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeipinhuiOrderStatus status { get; set; }

属性值

类型：WeipinhuiOrderStatus
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList.totalCost 属性

OrderInfoListtotalCost 属性

订单支付金额:单位元

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string totalCost { get; set; }

属性值

类型：String
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderInfoList 方法

OrderInfoList 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

OrderInfoList 类
Api.Framework.Tools 命名空间


OrderResponseResult 类

订单响应结果
继承层次
SystemObject
Api.Framework.ToolsOrderResponseResult

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class OrderResponseResult

OrderResponseResult 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | OrderResponseResult | 初始化 OrderResponseResult 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | result | 返回数据
公共属性 | returnCode | 返回代码
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


OrderResponseResult 构造函数

初始化 OrderResponseResult 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OrderResponseResult()
参见

引用

OrderResponseResult 类
Api.Framework.Tools 命名空间


OrderResponseResult 属性

OrderResponseResult 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | result | 返回数据
公共属性 | returnCode | 返回代码
Top
参见

引用

OrderResponseResult 类
Api.Framework.Tools 命名空间


OrderResponseResult.result 属性

OrderResponseResultresult 属性

返回数据

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OrderResult result { get; set; }

属性值

类型：OrderResult
参见

引用

OrderResponseResult 类
Api.Framework.Tools 命名空间


OrderResponseResult.returnCode 属性

OrderResponseResultreturnCode 属性

返回代码

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string returnCode { get; set; }

属性值

类型：String
参见

引用

OrderResponseResult 类
Api.Framework.Tools 命名空间


OrderResponseResult 方法

OrderResponseResult 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

OrderResponseResult 类
Api.Framework.Tools 命名空间


OrderResult 类

订单数据
继承层次
SystemObject
Api.Framework.ToolsOrderResult

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class OrderResult

OrderResult 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | OrderResult | 初始化 OrderResult 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | orderInfoList | 业绩查询响应结果
公共属性 | page | 页面大小
公共属性 | pageSize | 当前页码
公共属性 | total | 业绩总条数
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


OrderResult 构造函数

初始化 OrderResult 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public OrderResult()
参见

引用

OrderResult 类
Api.Framework.Tools 命名空间


OrderResult 属性

OrderResult 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | orderInfoList | 业绩查询响应结果
公共属性 | page | 页面大小
公共属性 | pageSize | 当前页码
公共属性 | total | 业绩总条数
Top
参见

引用

OrderResult 类
Api.Framework.Tools 命名空间


OrderResult.orderInfoList 属性

OrderResultorderInfoList 属性

业绩查询响应结果

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<OrderInfoList> orderInfoList { get; set; }

属性值

类型：List OrderInfoList
参见

引用

OrderResult 类
Api.Framework.Tools 命名空间


OrderResult.page 属性

OrderResultpage 属性

页面大小

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int page { get; set; }

属性值

类型：Int32
参见

引用

OrderResult 类
Api.Framework.Tools 命名空间


OrderResult.pageSize 属性

OrderResultpageSize 属性

当前页码

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int pageSize { get; set; }

属性值

类型：Int32
参见

引用

OrderResult 类
Api.Framework.Tools 命名空间


OrderResult.total 属性

OrderResulttotal 属性

业绩总条数

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int total { get; set; }

属性值

类型：Int32
参见

引用

OrderResult 类
Api.Framework.Tools 命名空间


OrderResult 方法

OrderResult 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

OrderResult 类
Api.Framework.Tools 命名空间


PageResult(T) 类

PageResultT 类

分页查询结果
继承层次
SystemObject
Api.Framework.ToolsPageResultT

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PageResult<T>

类型参数

T
数据库表实体类

PageResultT 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PageResultT | 初始化 PageResultT 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DataList | 分页查询中结果集合
公共属性 | Total | 分页查询中总记录数
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


PageResult(T) 构造函数

PageResultT 构造函数

初始化 PageResultT 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PageResult()
参见

引用

PageResultT 类
Api.Framework.Tools 命名空间


PageResult(T) 属性

PageResultT 属性

PageResultT 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DataList | 分页查询中结果集合
公共属性 | Total | 分页查询中总记录数
Top
参见

引用

PageResultT 类
Api.Framework.Tools 命名空间


PageResult(T).DataList 属性

PageResultTDataList 属性

分页查询中结果集合

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<T> DataList { get; set; }

属性值

类型：List T
参见

引用

PageResultT 类
Api.Framework.Tools 命名空间


PageResult(T).Total 属性

PageResultTTotal 属性

分页查询中总记录数

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Total { get; set; }

属性值

类型：Int32
参见

引用

PageResultT 类
Api.Framework.Tools 命名空间


PageResult(T) 方法

PageResultT 方法

PageResultT 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PageResultT 类
Api.Framework.Tools 命名空间


ParamMap 类

[缺少 "T:Api.Framework.Tools.ParamMap" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsParamMap

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ParamMap

ParamMap 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ParamMap | 初始化 ParamMap 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Index |
公共属性 | OrderBySQL |
公共属性 | PageSize |
公共属性 | SugarParameters |
Top
方法
 | 名称 | 说明
公共方法 | ContainsKey |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | setOrderFields | 设置排序字段及排序方式
公共方法 | setPageParamters |
公共方法 | setParameter |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


ParamMap 构造函数

初始化 ParamMap 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ParamMap()
参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap 属性

ParamMap 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Index |
公共属性 | OrderBySQL |
公共属性 | PageSize |
公共属性 | SugarParameters |
Top
参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap.Index 属性

ParamMapIndex 属性

[缺少 "P:Api.Framework.Tools.ParamMap.Index" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Index { get; }

属性值

类型：Int32
参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap.OrderBySQL 属性

ParamMapOrderBySQL 属性

[缺少 "P:Api.Framework.Tools.ParamMap.OrderBySQL" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string OrderBySQL { get; }

属性值

类型：String
参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap.PageSize 属性

ParamMapPageSize 属性

[缺少 "P:Api.Framework.Tools.ParamMap.PageSize" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int PageSize { get; }

属性值

类型：Int32
参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap.SugarParameters 属性

ParamMapSugarParameters 属性

[缺少 "P:Api.Framework.Tools.ParamMap.SugarParameters" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<SugarParameter> SugarParameters { get; }

属性值

类型：List SugarParameter
参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap 方法

ParamMap 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ContainsKey |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | setOrderFields | 设置排序字段及排序方式
公共方法 | setPageParamters |
公共方法 | setParameter |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap.ContainsKey 方法

ParamMapContainsKey 方法

[缺少 "M:Api.Framework.Tools.ParamMap.ContainsKey(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool ContainsKey(
    string name
)

参数

name
类型：SystemString

[缺少 "M:Api.Framework.Tools.ParamMap.ContainsKey(System.String)" 的 <param name="name"/> 文档]

返回值

类型：Boolean
参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap.setOrderFields 方法

ParamMapsetOrderFields 方法

设置排序字段及排序方式

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void setOrderFields(
    string orderFields,
    bool isDesc
)

参数

orderFields
类型：SystemString
排序字段
isDesc
类型：SystemBoolean
是否为递减排序
参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap.setPageParamters 方法

ParamMapsetPageParamters 方法

[缺少 "M:Api.Framework.Tools.ParamMap.setPageParamters(System.Int32,System.Int32)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void setPageParamters(
    int index,
    int pagesize
)

参数

index
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.ParamMap.setPageParamters(System.Int32,System.Int32)" 的 <param name="index"/> 文档]

pagesize
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.ParamMap.setPageParamters(System.Int32,System.Int32)" 的 <param name="pagesize"/> 文档]

参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


ParamMap.setParameter 方法

ParamMapsetParameter 方法

[缺少 "M:Api.Framework.Tools.ParamMap.setParameter(System.String,System.Object)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void setParameter(
    string name,
    Object value
)

参数

name
类型：SystemString

[缺少 "M:Api.Framework.Tools.ParamMap.setParameter(System.String,System.Object)" 的 <param name="name"/> 文档]

value
类型：SystemObject

[缺少 "M:Api.Framework.Tools.ParamMap.setParameter(System.String,System.Object)" 的 <param name="value"/> 文档]

参见

引用

ParamMap 类
Api.Framework.Tools 命名空间


PDDHelper 类

拼多多解析助手
继承层次
SystemObject
Api.Framework.ToolsPDDHelper

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PDDHelper

PDDHelper 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PDDHelper | 初始化 PDDHelper 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | FindGoodsInfo | 查询商品信息(自己的账号,以保佣金比例的正确性)
 | FindGoodsSign_H5 | 多多进宝app中获取高佣商品的招商id
 | FindSendGuideGoodsInfo(PinduoduoApi, Object) | 获取商品高佣信息
 | FindSendGuideGoodsInfo(PinduoduoApi, String, String, Boolean) | 获取商品高佣信息
公共方法 | GetHashCode | (继承自 Object。)
 | GetPddGoodsID | 获取拼多多链接中的商品ID
公共方法 | GetShoppingUrl | 获取单人团 / 多人团地址
公共方法 | GetShoppingUrls |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | RandomGuidePddMembers | 获取随机公共拼多多查询商品信息账号
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


PDDHelper 构造函数

初始化 PDDHelper 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PDDHelper()
参见

引用

PDDHelper 类
Api.Framework.Tools 命名空间


PDDHelper 方法

PDDHelper 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | FindGoodsInfo | 查询商品信息(自己的账号,以保佣金比例的正确性)
 | FindGoodsSign_H5 | 多多进宝app中获取高佣商品的招商id
 | FindSendGuideGoodsInfo(PinduoduoApi, Object) | 获取商品高佣信息
 | FindSendGuideGoodsInfo(PinduoduoApi, String, String, Boolean) | 获取商品高佣信息
公共方法 | GetHashCode | (继承自 Object。)
 | GetPddGoodsID | 获取拼多多链接中的商品ID
公共方法 | GetShoppingUrl | 获取单人团 / 多人团地址
公共方法 | GetShoppingUrls |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | RandomGuidePddMembers | 获取随机公共拼多多查询商品信息账号
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PDDHelper 类
Api.Framework.Tools 命名空间


PDDHelper.FindGoodsInfo 方法

PDDHelperFindGoodsInfo 方法

查询商品信息(自己的账号,以保佣金比例的正确性)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ArrayList FindGoodsInfo(
    PinduoduoApi api,
    string goods_sign,
    string pid
)

参数

api
类型：Api.Framework.CpsPinduoduoApi
PinduoduoApi对象
goods_sign
类型：SystemString
商品sign
pid
类型：SystemString
推广位pid

返回值

类型：ArrayList
参见

引用

PDDHelper 类
Api.Framework.Tools 命名空间


PDDHelper.FindGoodsSign_H5 方法

PDDHelperFindGoodsSign_H5 方法

多多进宝app中获取高佣商品的招商id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string FindGoodsSign_H5(
    string goodsid
)

参数

goodsid
类型：SystemString
商id

返回值

类型：String
参见

引用

PDDHelper 类
Api.Framework.Tools 命名空间


PDDHelper.FindSendGuideGoodsInfo 方法

PDDHelperFindSendGuideGoodsInfo 方法

重载列表
名称 | 说明
FindSendGuideGoodsInfo(PinduoduoApi, Object) | 获取商品高佣信息
FindSendGuideGoodsInfo(PinduoduoApi, String, String, Boolean) | 获取商品高佣信息
Top
参见

引用

PDDHelper 类
Api.Framework.Tools 命名空间


PDDHelper.FindSendGuideGoodsInfo 方法 (PinduoduoApi, Object)

PDDHelperFindSendGuideGoodsInfo 方法 (PinduoduoApi, Object)

获取商品高佣信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ArrayList FindSendGuideGoodsInfo(
    PinduoduoApi api,
    Object data
)

参数

api
类型：Api.Framework.CpsPinduoduoApi
PinduoduoApi对象
data
类型：SystemObject
参数

返回值

类型：ArrayList
参见

引用

PDDHelper 类
FindSendGuideGoodsInfo 重载
Api.Framework.Tools 命名空间


PDDHelper.FindSendGuideGoodsInfo 方法 (PinduoduoApi, String, String, Boolean)

PDDHelperFindSendGuideGoodsInfo 方法 (PinduoduoApi, String, String, Boolean)

获取商品高佣信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ArrayList FindSendGuideGoodsInfo(
    PinduoduoApi api,
    string pid,
    string goods_id,
    bool isBind = false
)

参数

api
类型：Api.Framework.CpsPinduoduoApi
PinduoduoApi对象
pid
类型：SystemString
推广位pid
goods_id
类型：SystemString
商品id
isBind (Optional)
类型：SystemBoolean
是否授权绑定

返回值

类型：ArrayList
参见

引用

PDDHelper 类
FindSendGuideGoodsInfo 重载
Api.Framework.Tools 命名空间


PDDHelper.GetPddGoodsID 方法

PDDHelperGetPddGoodsID 方法

获取拼多多链接中的商品ID

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetPddGoodsID(
    string url
)

参数

url
类型：SystemString
拼多多商品连接

返回值

类型：String
参见

引用

PDDHelper 类
Api.Framework.Tools 命名空间


PDDHelper.GetShoppingUrl 方法

PDDHelperGetShoppingUrl 方法

获取单人团 / 多人团地址

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetShoppingUrl(
    PinduoduoApi api,
    Object obj
)

参数

api
类型：Api.Framework.CpsPinduoduoApi
PinduoduoApi对象
obj
类型：SystemObject
接口的必要参数

返回值

类型：String
参见

引用

PDDHelper 类
Api.Framework.Tools 命名空间


PDDHelper.GetShoppingUrls 方法

PDDHelperGetShoppingUrls 方法

[缺少 "M:Api.Framework.Tools.PDDHelper.GetShoppingUrls(Api.Framework.Cps.PinduoduoApi,System.Object)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> GetShoppingUrls(
    PinduoduoApi api,
    Object obj
)

参数

api
类型：Api.Framework.CpsPinduoduoApi
PinduoduoApi对象
obj
类型：SystemObject
参数

返回值

类型：Dictionary String, Object
参见

引用

PDDHelper 类
Api.Framework.Tools 命名空间


PDDHelper.RandomGuidePddMembers 方法

PDDHelperRandomGuidePddMembers 方法

获取随机公共拼多多查询商品信息账号

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static fl_cps_member RandomGuidePddMembers()

返回值

类型：fl_cps_member
参见

引用

PDDHelper 类
Api.Framework.Tools 命名空间


PrepayInfo 类

商品预付信息
继承层次
SystemObject
Api.Framework.ToolsPrepayInfo

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PrepayInfo

PrepayInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PrepayInfo | 初始化 PrepayInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | deductionPrice | 抵扣价格(首款+优惠金额)：元
公共属性 | firstAmount | 预付首款金额：元
公共属性 | isPrepay | 是否预付商品:0-否，1-是
公共属性 | lastAmount | 预付尾款金额：元
公共属性 | prepayDiscount | 预付折扣：(唯品价-优惠金额)/唯品价 保留两位小数的数字字符串
公共属性 | prepayFavAmount | 预付优惠金额: 元
公共属性 | prepayFirstEndTime | 首款支付结束时间:时间戳,单位毫秒
公共属性 | prepayFirstStartTime | 首款支付开始时间:时间戳,单位毫秒
公共属性 | prepayLastEndTime | 尾款支付结束时间:时间戳,单位毫秒
公共属性 | prepayLastStartTime | 尾款支付开始时间:时间戳,单位毫秒
公共属性 | prepayPrice | 预付到手价：元
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


PrepayInfo 构造函数

初始化 PrepayInfo 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PrepayInfo()
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo 属性

PrepayInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | deductionPrice | 抵扣价格(首款+优惠金额)：元
公共属性 | firstAmount | 预付首款金额：元
公共属性 | isPrepay | 是否预付商品:0-否，1-是
公共属性 | lastAmount | 预付尾款金额：元
公共属性 | prepayDiscount | 预付折扣：(唯品价-优惠金额)/唯品价 保留两位小数的数字字符串
公共属性 | prepayFavAmount | 预付优惠金额: 元
公共属性 | prepayFirstEndTime | 首款支付结束时间:时间戳,单位毫秒
公共属性 | prepayFirstStartTime | 首款支付开始时间:时间戳,单位毫秒
公共属性 | prepayLastEndTime | 尾款支付结束时间:时间戳,单位毫秒
公共属性 | prepayLastStartTime | 尾款支付开始时间:时间戳,单位毫秒
公共属性 | prepayPrice | 预付到手价：元
Top
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.deductionPrice 属性

PrepayInfodeductionPrice 属性

抵扣价格(首款+优惠金额)：元

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string deductionPrice { get; set; }

属性值

类型：String
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.firstAmount 属性

PrepayInfofirstAmount 属性

预付首款金额：元

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string firstAmount { get; set; }

属性值

类型：String
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.isPrepay 属性

PrepayInfoisPrepay 属性

是否预付商品:0-否，1-是

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int isPrepay { get; set; }

属性值

类型：Int32
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.lastAmount 属性

PrepayInfolastAmount 属性

预付尾款金额：元

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string lastAmount { get; set; }

属性值

类型：String
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.prepayDiscount 属性

PrepayInfoprepayDiscount 属性

预付折扣：(唯品价-优惠金额)/唯品价 保留两位小数的数字字符串

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string prepayDiscount { get; set; }

属性值

类型：String
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.prepayFavAmount 属性

PrepayInfoprepayFavAmount 属性

预付优惠金额: 元

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string prepayFavAmount { get; set; }

属性值

类型：String
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.prepayFirstEndTime 属性

PrepayInfoprepayFirstEndTime 属性

首款支付结束时间:时间戳,单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long prepayFirstEndTime { get; set; }

属性值

类型：Int64
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.prepayFirstStartTime 属性

PrepayInfoprepayFirstStartTime 属性

首款支付开始时间:时间戳,单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long prepayFirstStartTime { get; set; }

属性值

类型：Int64
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.prepayLastEndTime 属性

PrepayInfoprepayLastEndTime 属性

尾款支付结束时间:时间戳,单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long prepayLastEndTime { get; set; }

属性值

类型：Int64
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.prepayLastStartTime 属性

PrepayInfoprepayLastStartTime 属性

尾款支付开始时间:时间戳,单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long prepayLastStartTime { get; set; }

属性值

类型：Int64
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo.prepayPrice 属性

PrepayInfoprepayPrice 属性

预付到手价：元

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string prepayPrice { get; set; }

属性值

类型：String
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PrepayInfo 方法

PrepayInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PrepayInfo 类
Api.Framework.Tools 命名空间


PromotionsItem 类

推广项目
继承层次
SystemObject
Api.Framework.ToolsPromotionsItem

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PromotionsItem

PromotionsItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PromotionsItem | 初始化 PromotionsItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | brand_icon | 品牌图标
公共属性 | cos_fee | 佣金(分)
公共属性 | cos_ratio | 佣金率(要除以100)
公共属性 | cover | 商品图片等信息
公共属性 | detail_url | 细节链接
公共属性 | exp_score | 商品评分
公共属性 | in_promotion | 是否在促销
公共属性 | in_shop | 在商店
公共属性 | market_price | 市场价
公共属性 | month_sales | 月销售
公共属性 | price | 商品现价价格
公共属性 | product_id | 产品id
公共属性 | promotion_id | 推广id
公共属性 | promotion_source | 推广来源编码
公共属性 | sale_infos | 优惠券信息(没有为空)
公共属性 | sales | 销售
公共属性 | shop_id | 商店id
公共属性 | shop_name | 商店名称
公共属性 | title | 产品标题
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


PromotionsItem 构造函数

初始化 PromotionsItem 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PromotionsItem()
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem 属性

PromotionsItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | brand_icon | 品牌图标
公共属性 | cos_fee | 佣金(分)
公共属性 | cos_ratio | 佣金率(要除以100)
公共属性 | cover | 商品图片等信息
公共属性 | detail_url | 细节链接
公共属性 | exp_score | 商品评分
公共属性 | in_promotion | 是否在促销
公共属性 | in_shop | 在商店
公共属性 | market_price | 市场价
公共属性 | month_sales | 月销售
公共属性 | price | 商品现价价格
公共属性 | product_id | 产品id
公共属性 | promotion_id | 推广id
公共属性 | promotion_source | 推广来源编码
公共属性 | sale_infos | 优惠券信息(没有为空)
公共属性 | sales | 销售
公共属性 | shop_id | 商店id
公共属性 | shop_name | 商店名称
公共属性 | title | 产品标题
Top
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.brand_icon 属性

PromotionsItembrand_icon 属性

品牌图标

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Brand_icon brand_icon { get; set; }

属性值

类型：Brand_icon
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.cos_fee 属性

PromotionsItemcos_fee 属性

佣金(分)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int cos_fee { get; set; }

属性值

类型：Int32
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.cos_ratio 属性

PromotionsItemcos_ratio 属性

佣金率(要除以100)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int cos_ratio { get; set; }

属性值

类型：Int32
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.cover 属性

PromotionsItemcover 属性

商品图片等信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Cover cover { get; set; }

属性值

类型：Cover
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.detail_url 属性

PromotionsItemdetail_url 属性

细节链接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string detail_url { get; set; }

属性值

类型：String
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.exp_score 属性

PromotionsItemexp_score 属性

商品评分

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string exp_score { get; set; }

属性值

类型：String
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.in_promotion 属性

PromotionsItemin_promotion 属性

是否在促销

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool in_promotion { get; set; }

属性值

类型：Boolean
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.in_shop 属性

PromotionsItemin_shop 属性

在商店

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool in_shop { get; set; }

属性值

类型：Boolean
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.market_price 属性

PromotionsItemmarket_price 属性

市场价

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int market_price { get; set; }

属性值

类型：Int32
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.month_sales 属性

PromotionsItemmonth_sales 属性

月销售

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int month_sales { get; set; }

属性值

类型：Int32
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.price 属性

PromotionsItemprice 属性

商品现价价格

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int price { get; set; }

属性值

类型：Int32
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.product_id 属性

PromotionsItemproduct_id 属性

产品id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string product_id { get; set; }

属性值

类型：String
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.promotion_id 属性

PromotionsItempromotion_id 属性

推广id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string promotion_id { get; set; }

属性值

类型：String
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.promotion_source 属性

PromotionsItempromotion_source 属性

推广来源编码

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int promotion_source { get; set; }

属性值

类型：Int32
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.sale_infos 属性

PromotionsItemsale_infos 属性

优惠券信息(没有为空)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<Sale_infos> sale_infos { get; set; }

属性值

类型：List Sale_infos
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.sales 属性

PromotionsItemsales 属性

销售

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int sales { get; set; }

属性值

类型：Int32
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.shop_id 属性

PromotionsItemshop_id 属性

商店id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int shop_id { get; set; }

属性值

类型：Int32
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.shop_name 属性

PromotionsItemshop_name 属性

商店名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string shop_name { get; set; }

属性值

类型：String
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem.title 属性

PromotionsItemtitle 属性

产品标题

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string title { get; set; }

属性值

类型：String
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


PromotionsItem 方法

PromotionsItem 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PromotionsItem 类
Api.Framework.Tools 命名空间


Response 类

[缺少 "T:Api.Framework.Tools.Response" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsResponse

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Response

Response 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Response | 初始化 Response 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | HTTPResponseHeader |
公共属性 | HTTPResponseText |
公共属性 | HTTPStatusCode |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


Response 构造函数

初始化 Response 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Response()
参见

引用

Response 类
Api.Framework.Tools 命名空间


Response 属性

Response 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | HTTPResponseHeader |
公共属性 | HTTPResponseText |
公共属性 | HTTPStatusCode |
Top
参见

引用

Response 类
Api.Framework.Tools 命名空间


Response.HTTPResponseHeader 属性

ResponseHTTPResponseHeader 属性

[缺少 "P:Api.Framework.Tools.Response.HTTPResponseHeader" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> HTTPResponseHeader { get; set; }

属性值

类型：Dictionary String, Object
参见

引用

Response 类
Api.Framework.Tools 命名空间


Response.HTTPResponseText 属性

ResponseHTTPResponseText 属性

[缺少 "P:Api.Framework.Tools.Response.HTTPResponseText" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string HTTPResponseText { get; set; }

属性值

类型：String
参见

引用

Response 类
Api.Framework.Tools 命名空间


Response.HTTPStatusCode 属性

ResponseHTTPStatusCode 属性

[缺少 "P:Api.Framework.Tools.Response.HTTPStatusCode" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string HTTPStatusCode { get; set; }

属性值

类型：String
参见

引用

Response 类
Api.Framework.Tools 命名空间


Response 方法

Response 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Response 类
Api.Framework.Tools 命名空间


Result1 类

[缺少 "T:Api.Framework.Tools.Result1" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsResult1

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Result1

Result1 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Result1 | 初始化 Result1 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | urlInfoList | 链接数据
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


Result1 构造函数

初始化 Result1 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Result1()
参见

引用

Result1 类
Api.Framework.Tools 命名空间


Result1 属性

Result1 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | urlInfoList | 链接数据
Top
参见

引用

Result1 类
Api.Framework.Tools 命名空间


Result1.urlInfoList 属性

Result1urlInfoList 属性

链接数据

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<UrlInfoList> urlInfoList { get; set; }

属性值

类型：List UrlInfoList
参见

引用

Result1 类
Api.Framework.Tools 命名空间


Result1 方法

Result1 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Result1 类
Api.Framework.Tools 命名空间


Sale_infos 类

销售信息(优惠券信息)
继承层次
SystemObject
Api.Framework.ToolsSale_infos

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Sale_infos

Sale_infos 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Sale_infos | 初始化 Sale_infos 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | begin_time | 优惠券开始
公共属性 | campaign_type | 券
公共属性 | end_time | 优惠券结束
公共属性 | title | 券信息(100减5)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


Sale_infos 构造函数

初始化 Sale_infos 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Sale_infos()
参见

引用

Sale_infos 类
Api.Framework.Tools 命名空间


Sale_infos 属性

Sale_infos 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | begin_time | 优惠券开始
公共属性 | campaign_type | 券
公共属性 | end_time | 优惠券结束
公共属性 | title | 券信息(100减5)
Top
参见

引用

Sale_infos 类
Api.Framework.Tools 命名空间


Sale_infos.begin_time 属性

Sale_infosbegin_time 属性

优惠券开始

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int begin_time { get; set; }

属性值

类型：Int32
参见

引用

Sale_infos 类
Api.Framework.Tools 命名空间


Sale_infos.campaign_type 属性

Sale_infoscampaign_type 属性

券

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string campaign_type { get; set; }

属性值

类型：String
参见

引用

Sale_infos 类
Api.Framework.Tools 命名空间


Sale_infos.end_time 属性

Sale_infosend_time 属性

优惠券结束

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int end_time { get; set; }

属性值

类型：Int32
参见

引用

Sale_infos 类
Api.Framework.Tools 命名空间


Sale_infos.title 属性

Sale_infostitle 属性

券信息(100减5)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string title { get; set; }

属性值

类型：String
参见

引用

Sale_infos 类
Api.Framework.Tools 命名空间


Sale_infos 方法

Sale_infos 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Sale_infos 类
Api.Framework.Tools 命名空间


SessionThreadLocal 类

持久层线程池
继承层次
SystemObject
Api.Framework.ToolsSessionThreadLocal

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SessionThreadLocal

SessionThreadLocal 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SessionThreadLocal | 初始化 SessionThreadLocal 类的一个新实例
Top
方法
 | 名称 | 说明
 | Clear | 清空线程池
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | Get | 从线程池获取持久层
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | Set | 设置持久层到线程池
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


SessionThreadLocal 构造函数

初始化 SessionThreadLocal 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SessionThreadLocal()
参见

引用

SessionThreadLocal 类
Api.Framework.Tools 命名空间


SessionThreadLocal 方法

SessionThreadLocal 类型公开以下成员。

方法
 | 名称 | 说明
 | Clear | 清空线程池
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | Get | 从线程池获取持久层
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | Set | 设置持久层到线程池
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SessionThreadLocal 类
Api.Framework.Tools 命名空间


SessionThreadLocal.Clear 方法

SessionThreadLocalClear 方法

清空线程池

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Clear()
参见

引用

SessionThreadLocal 类
Api.Framework.Tools 命名空间


SessionThreadLocal.Get 方法

SessionThreadLocalGet 方法

从线程池获取持久层

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static SqlSugarClient Get()

返回值

类型：SqlSugarClient
参见

引用

SessionThreadLocal 类
Api.Framework.Tools 命名空间


SessionThreadLocal.Set 方法

SessionThreadLocalSet 方法

设置持久层到线程池

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Set(
    SqlSugarClient session
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SessionThreadLocal.Set(SqlSugar.SqlSugarClient)" 的 <param name="session"/> 文档]

参见

引用

SessionThreadLocal 类
Api.Framework.Tools 命名空间


SkuInfos 类

对应sku信息
继承层次
SystemObject
Api.Framework.ToolsSkuInfos

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SkuInfos

SkuInfos 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SkuInfos | 初始化 SkuInfos 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | leavingStock | 剩余库存:查询库存时返回
公共属性 | marketPrice | 市场价:单位元
公共属性 | saleProps | 售卖属性信息（134 - 颜色,453 - 尺码）
公共属性 | saleStockStatus | 商品库存状态：1-已抢光，2-有库存，3-有机会
公共属性 | sizeId | 商品尺码id(唯品会体系下和skuId等同)
公共属性 | vipPrice | 唯品价:单位元
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


SkuInfos 构造函数

初始化 SkuInfos 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SkuInfos()
参见

引用

SkuInfos 类
Api.Framework.Tools 命名空间


SkuInfos 属性

SkuInfos 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | leavingStock | 剩余库存:查询库存时返回
公共属性 | marketPrice | 市场价:单位元
公共属性 | saleProps | 售卖属性信息（134 - 颜色,453 - 尺码）
公共属性 | saleStockStatus | 商品库存状态：1-已抢光，2-有库存，3-有机会
公共属性 | sizeId | 商品尺码id(唯品会体系下和skuId等同)
公共属性 | vipPrice | 唯品价:单位元
Top
参见

引用

SkuInfos 类
Api.Framework.Tools 命名空间


SkuInfos.leavingStock 属性

SkuInfosleavingStock 属性

剩余库存:查询库存时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int leavingStock { get; set; }

属性值

类型：Int32
参见

引用

SkuInfos 类
Api.Framework.Tools 命名空间


SkuInfos.marketPrice 属性

SkuInfosmarketPrice 属性

市场价:单位元

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string marketPrice { get; set; }

属性值

类型：String
参见

引用

SkuInfos 类
Api.Framework.Tools 命名空间


SkuInfos.saleProps 属性

SkuInfossaleProps 属性

售卖属性信息（134 - 颜色,453 - 尺码）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<int, string> saleProps { get; set; }

属性值

类型：Dictionary Int32, String
参见

引用

SkuInfos 类
Api.Framework.Tools 命名空间


SkuInfos.saleStockStatus 属性

SkuInfossaleStockStatus 属性

商品库存状态：1-已抢光，2-有库存，3-有机会

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int saleStockStatus { get; set; }

属性值

类型：Int32
参见

引用

SkuInfos 类
Api.Framework.Tools 命名空间


SkuInfos.sizeId 属性

SkuInfossizeId 属性

商品尺码id(唯品会体系下和skuId等同)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string sizeId { get; set; }

属性值

类型：String
参见

引用

SkuInfos 类
Api.Framework.Tools 命名空间


SkuInfos.vipPrice 属性

SkuInfosvipPrice 属性

唯品价:单位元

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string vipPrice { get; set; }

属性值

类型：String
参见

引用

SkuInfos 类
Api.Framework.Tools 命名空间


SkuInfos 方法

SkuInfos 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SkuInfos 类
Api.Framework.Tools 命名空间


SqlSugarExtend 类

[缺少 "T:Api.Framework.Tools.SqlSugarExtend" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsSqlSugarExtend

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class SqlSugarExtend

SqlSugarExtend 类型公开以下成员。

方法
名称 | 说明
AddColumn | 增加列
AddIndexT | 添加索引
AddUnique(SqlSugarClient, String, Object) | 添加唯一约束
AddUniqueT(SqlSugarClient, Object) | 添加唯一约束
BeginTransaction | 开启事务
ColumnExist | 检测列是否存在
Commit | 提交
CreateTable(SqlSugarClient, Type) | 创建表
CreateTableT(SqlSugarClient) |
DeleteIndex |
DeleteUnique |
DropTable(SqlSugarClient, String) | 删除表
DropTableT(SqlSugarClient) | 删除表
ExcuteSQL | 执行sql
ExistUnique |
FindT |
FindByIdT | 根据ID查数据、必须有为ID的字段
FindPageT |
FindRow | 获得第一条数据
FindSingleT |
FindTable | 获得Table
IndexExist(SqlSugarClient, String, Object) |
IndexExist(SqlSugarClient, String, String) | 索引是否存在
IndexExistT(SqlSugarClient, Object) |
IndexExistT(SqlSugarClient, String) | 索引是否存在
Insertable |
NewParamMap |
Rollback | 回滚
TableExist(SqlSugarClient, String) | 判断表是否存在
TableExistT(SqlSugarClient) | 判断表是否存在
Update |
UpdateColumnType | 修改字段类型
Top
参见

引用

Api.Framework.Tools 命名空间


SqlSugarExtend 方法

SqlSugarExtend 类型公开以下成员。

方法
名称 | 说明
AddColumn | 增加列
AddIndexT | 添加索引
AddUnique(SqlSugarClient, String, Object) | 添加唯一约束
AddUniqueT(SqlSugarClient, Object) | 添加唯一约束
BeginTransaction | 开启事务
ColumnExist | 检测列是否存在
Commit | 提交
CreateTable(SqlSugarClient, Type) | 创建表
CreateTableT(SqlSugarClient) |
DeleteIndex |
DeleteUnique |
DropTable(SqlSugarClient, String) | 删除表
DropTableT(SqlSugarClient) | 删除表
ExcuteSQL | 执行sql
ExistUnique |
FindT |
FindByIdT | 根据ID查数据、必须有为ID的字段
FindPageT |
FindRow | 获得第一条数据
FindSingleT |
FindTable | 获得Table
IndexExist(SqlSugarClient, String, Object) |
IndexExist(SqlSugarClient, String, String) | 索引是否存在
IndexExistT(SqlSugarClient, Object) |
IndexExistT(SqlSugarClient, String) | 索引是否存在
Insertable |
NewParamMap |
Rollback | 回滚
TableExist(SqlSugarClient, String) | 判断表是否存在
TableExistT(SqlSugarClient) | 判断表是否存在
Update |
UpdateColumnType | 修改字段类型
Top
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.AddColumn 方法

SqlSugarExtendAddColumn 方法

增加列

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void AddColumn(
    this SqlSugarClient session,
    string tableName,
    string columnName,
    string sqlType
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddColumn(SqlSugar.SqlSugarClient,System.String,System.String,System.String)" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddColumn(SqlSugar.SqlSugarClient,System.String,System.String,System.String)" 的 <param name="tableName"/> 文档]

columnName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddColumn(SqlSugar.SqlSugarClient,System.String,System.String,System.String)" 的 <param name="columnName"/> 文档]

sqlType
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddColumn(SqlSugar.SqlSugarClient,System.String,System.String,System.String)" 的 <param name="sqlType"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.AddIndex(T) 方法

SqlSugarExtendAddIndexT 方法

添加索引

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool AddIndex<T>(
    this SqlSugarClient session,
    params Object[] values
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddIndex``1(SqlSugar.SqlSugarClient,System.Object[])" 的 <param name="session"/> 文档]

values
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddIndex``1(SqlSugar.SqlSugarClient,System.Object[])" 的 <param name="values"/> 文档]

类型参数

T

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.AddUnique 方法

SqlSugarExtendAddUnique 方法

重载列表
名称 | 说明
AddUniqueT(SqlSugarClient, Object) | 添加唯一约束
AddUnique(SqlSugarClient, String, Object) | 添加唯一约束
Top
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.AddUnique(T) 方法 (SqlSugarClient, Object[])

SqlSugarExtendAddUniqueT 方法 (SqlSugarClient, Object)

添加唯一约束

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void AddUnique<T>(
    this SqlSugarClient session,
    params Object[] values
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddUnique``1(SqlSugar.SqlSugarClient,System.Object[])" 的 <param name="session"/> 文档]

values
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddUnique``1(SqlSugar.SqlSugarClient,System.Object[])" 的 <param name="values"/> 文档]

类型参数

T

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
AddUnique 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.AddUnique 方法 (SqlSugarClient, String, Object[])

SqlSugarExtendAddUnique 方法 (SqlSugarClient, String, Object)

添加唯一约束

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void AddUnique(
    this SqlSugarClient session,
    string tableName,
    params Object[] values
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="tableName"/> 文档]

values
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.AddUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="values"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
AddUnique 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.BeginTransaction 方法

SqlSugarExtendBeginTransaction 方法

开启事务

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void BeginTransaction(
    this SqlSugarClient session
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.BeginTransaction(SqlSugar.SqlSugarClient)" 的 <param name="session"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.ColumnExist 方法

SqlSugarExtendColumnExist 方法

检测列是否存在

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool ColumnExist(
    this SqlSugarClient session,
    string tableName,
    string columnName
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ColumnExist(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ColumnExist(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <param name="tableName"/> 文档]

columnName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ColumnExist(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <param name="columnName"/> 文档]

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.Commit 方法

SqlSugarExtendCommit 方法

提交

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Commit(
    this SqlSugarClient session
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Commit(SqlSugar.SqlSugarClient)" 的 <param name="session"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.CreateTable 方法

SqlSugarExtendCreateTable 方法

重载列表
名称 | 说明
CreateTableT(SqlSugarClient) |
CreateTable(SqlSugarClient, Type) | 创建表
Top
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.CreateTable(T) 方法 (SqlSugarClient)

SqlSugarExtendCreateTableT 方法 (SqlSugarClient)

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.CreateTable``1(SqlSugar.SqlSugarClient)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void CreateTable<T>(
    this SqlSugarClient session
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.CreateTable``1(SqlSugar.SqlSugarClient)" 的 <param name="session"/> 文档]

类型参数

T

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
CreateTable 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.CreateTable 方法 (SqlSugarClient, Type)

SqlSugarExtendCreateTable 方法 (SqlSugarClient, Type)

创建表

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void CreateTable(
    this SqlSugarClient session,
    Type type
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.CreateTable(SqlSugar.SqlSugarClient,System.Type)" 的 <param name="session"/> 文档]

type
类型：SystemType

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.CreateTable(SqlSugar.SqlSugarClient,System.Type)" 的 <param name="type"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
CreateTable 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.DeleteIndex 方法

SqlSugarExtendDeleteIndex 方法

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DeleteIndex(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool DeleteIndex(
    this SqlSugarClient session,
    string tableName,
    string indexName
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DeleteIndex(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DeleteIndex(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <param name="tableName"/> 文档]

indexName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DeleteIndex(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <param name="indexName"/> 文档]

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.DeleteUnique 方法

SqlSugarExtendDeleteUnique 方法

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DeleteUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool DeleteUnique(
    this SqlSugarClient session,
    string tableName,
    params Object[] values
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DeleteUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DeleteUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="tableName"/> 文档]

values
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DeleteUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="values"/> 文档]

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.DropTable 方法

SqlSugarExtendDropTable 方法

重载列表
名称 | 说明
DropTableT(SqlSugarClient) | 删除表
DropTable(SqlSugarClient, String) | 删除表
Top
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.DropTable(T) 方法 (SqlSugarClient)

SqlSugarExtendDropTableT 方法 (SqlSugarClient)

删除表

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void DropTable<T>(
    this SqlSugarClient session
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DropTable``1(SqlSugar.SqlSugarClient)" 的 <param name="session"/> 文档]

类型参数

T

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
DropTable 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.DropTable 方法 (SqlSugarClient, String)

SqlSugarExtendDropTable 方法 (SqlSugarClient, String)

删除表

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void DropTable(
    this SqlSugarClient session,
    string tableName
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DropTable(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.DropTable(SqlSugar.SqlSugarClient,System.String)" 的 <param name="tableName"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
DropTable 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.ExcuteSQL 方法

SqlSugarExtendExcuteSQL 方法

执行sql

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void ExcuteSQL(
    this SqlSugarClient session,
    string sql,
    Object parameters = null
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ExcuteSQL(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="session"/> 文档]

sql
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ExcuteSQL(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="sql"/> 文档]

parameters (Optional)
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ExcuteSQL(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="parameters"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.ExistUnique 方法

SqlSugarExtendExistUnique 方法

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ExistUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool ExistUnique(
    this SqlSugarClient session,
    string tableName,
    params Object[] values
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ExistUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ExistUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="tableName"/> 文档]

values
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.ExistUnique(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="values"/> 文档]

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.Find(T) 方法

SqlSugarExtendFindT 方法

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Find``1(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<T> Find<T>(
    this SqlSugarClient session,
    string strSQL,
    Object param = null
)
where T : new()

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Find``1(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="session"/> 文档]

strSQL
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Find``1(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="strSQL"/> 文档]

param (Optional)
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Find``1(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="param"/> 文档]

类型参数

T

返回值

类型：List T

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.FindById(T) 方法

SqlSugarExtendFindByIdT 方法

根据ID查数据、必须有为ID的字段

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T FindById<T>(
    this SqlSugarClient session,
    long id
)
where T : new()

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindById``1(SqlSugar.SqlSugarClient,System.Int64)" 的 <param name="session"/> 文档]

id
类型：SystemInt64

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindById``1(SqlSugar.SqlSugarClient,System.Int64)" 的 <param name="id"/> 文档]

类型参数

T

返回值

类型：T

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.FindPage(T) 方法

SqlSugarExtendFindPageT 方法

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindPage``1(SqlSugar.SqlSugarClient,System.String,Api.Framework.Tools.ParamMap)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static PageResult<T> FindPage<T>(
    this SqlSugarClient session,
    string sql,
    ParamMap map
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindPage``1(SqlSugar.SqlSugarClient,System.String,Api.Framework.Tools.ParamMap)" 的 <param name="session"/> 文档]

sql
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindPage``1(SqlSugar.SqlSugarClient,System.String,Api.Framework.Tools.ParamMap)" 的 <param name="sql"/> 文档]

map
类型：Api.Framework.ToolsParamMap

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindPage``1(SqlSugar.SqlSugarClient,System.String,Api.Framework.Tools.ParamMap)" 的 <param name="map"/> 文档]

类型参数

T

返回值

类型：PageResult T

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.FindRow 方法

SqlSugarExtendFindRow 方法

获得第一条数据

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static DataRow FindRow(
    this SqlSugarClient session,
    string strSQL,
    Object obj
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindRow(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="session"/> 文档]

strSQL
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindRow(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="strSQL"/> 文档]

obj
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindRow(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="obj"/> 文档]

返回值

类型：DataRow

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.FindSingle(T) 方法

SqlSugarExtendFindSingleT 方法

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindSingle``1(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T FindSingle<T>(
    this SqlSugarClient session,
    string strSQL,
    Object param = null
)
where T : new()

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindSingle``1(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="session"/> 文档]

strSQL
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindSingle``1(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="strSQL"/> 文档]

param (Optional)
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindSingle``1(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="param"/> 文档]

类型参数

T

返回值

类型：T

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.FindTable 方法

SqlSugarExtendFindTable 方法

获得Table

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static DataTable FindTable(
    this SqlSugarClient session,
    string strSQL,
    Object param = null
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindTable(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="session"/> 文档]

strSQL
类型：SystemString
SQL
param (Optional)
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.FindTable(SqlSugar.SqlSugarClient,System.String,System.Object)" 的 <param name="param"/> 文档]

返回值

类型：DataTable

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.IndexExist 方法

SqlSugarExtendIndexExist 方法

重载列表
名称 | 说明
IndexExistT(SqlSugarClient, Object) |
IndexExistT(SqlSugarClient, String) | 索引是否存在
IndexExist(SqlSugarClient, String, Object) |
IndexExist(SqlSugarClient, String, String) | 索引是否存在
Top
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.IndexExist(T) 方法 (SqlSugarClient, Object[])

SqlSugarExtendIndexExistT 方法 (SqlSugarClient, Object)

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist``1(SqlSugar.SqlSugarClient,System.Object[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool IndexExist<T>(
    this SqlSugarClient session,
    params Object[] values
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist``1(SqlSugar.SqlSugarClient,System.Object[])" 的 <param name="session"/> 文档]

values
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist``1(SqlSugar.SqlSugarClient,System.Object[])" 的 <param name="values"/> 文档]

类型参数

T

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
IndexExist 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.IndexExist(T) 方法 (SqlSugarClient, String)

SqlSugarExtendIndexExistT 方法 (SqlSugarClient, String)

索引是否存在

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool IndexExist<T>(
    this SqlSugarClient session,
    string indexName
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist``1(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

indexName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist``1(SqlSugar.SqlSugarClient,System.String)" 的 <param name="indexName"/> 文档]

类型参数

T

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
IndexExist 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.IndexExist 方法 (SqlSugarClient, String, Object[])

SqlSugarExtendIndexExist 方法 (SqlSugarClient, String, Object)

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool IndexExist(
    this SqlSugarClient session,
    string tableName,
    params Object[] values
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="tableName"/> 文档]

values
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist(SqlSugar.SqlSugarClient,System.String,System.Object[])" 的 <param name="values"/> 文档]

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
IndexExist 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.IndexExist 方法 (SqlSugarClient, String, String)

SqlSugarExtendIndexExist 方法 (SqlSugarClient, String, String)

索引是否存在

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool IndexExist(
    this SqlSugarClient session,
    string tableName,
    string indexName
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <param name="tableName"/> 文档]

indexName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.IndexExist(SqlSugar.SqlSugarClient,System.String,System.String)" 的 <param name="indexName"/> 文档]

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
IndexExist 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.Insertable 方法

SqlSugarExtendInsertable 方法

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Insertable(SqlSugar.SqlSugarClient,Api.Framework.Tools.base_model)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static int Insertable(
    this SqlSugarClient session,
    base_model obj
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Insertable(SqlSugar.SqlSugarClient,Api.Framework.Tools.base_model)" 的 <param name="session"/> 文档]

obj
类型：Api.Framework.Toolsbase_model

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Insertable(SqlSugar.SqlSugarClient,Api.Framework.Tools.base_model)" 的 <param name="obj"/> 文档]

返回值

类型：Int32

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.NewParamMap 方法

SqlSugarExtendNewParamMap 方法

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.NewParamMap(SqlSugar.SqlSugarClient)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ParamMap NewParamMap(
    this SqlSugarClient session
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.NewParamMap(SqlSugar.SqlSugarClient)" 的 <param name="session"/> 文档]

返回值

类型：ParamMap

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.Rollback 方法

SqlSugarExtendRollback 方法

回滚

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Rollback(
    this SqlSugarClient session
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Rollback(SqlSugar.SqlSugarClient)" 的 <param name="session"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.TableExist 方法

SqlSugarExtendTableExist 方法

重载列表
名称 | 说明
TableExistT(SqlSugarClient) | 判断表是否存在
TableExist(SqlSugarClient, String) | 判断表是否存在
Top
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.TableExist(T) 方法 (SqlSugarClient)

SqlSugarExtendTableExistT 方法 (SqlSugarClient)

判断表是否存在

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool TableExist<T>(
    this SqlSugarClient session
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.TableExist``1(SqlSugar.SqlSugarClient)" 的 <param name="session"/> 文档]

类型参数

T

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
TableExist 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.TableExist 方法 (SqlSugarClient, String)

SqlSugarExtendTableExist 方法 (SqlSugarClient, String)

判断表是否存在

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool TableExist(
    this SqlSugarClient session,
    string tableName
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.TableExist(SqlSugar.SqlSugarClient,System.String)" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.TableExist(SqlSugar.SqlSugarClient,System.String)" 的 <param name="tableName"/> 文档]

返回值

类型：Boolean

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
TableExist 重载
Api.Framework.Tools 命名空间


SqlSugarExtend.Update 方法

SqlSugarExtendUpdate 方法

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Update(SqlSugar.SqlSugarClient,Api.Framework.Tools.base_model,System.Object)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Update(
    this SqlSugarClient session,
    base_model model,
    Object param = null
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Update(SqlSugar.SqlSugarClient,Api.Framework.Tools.base_model,System.Object)" 的 <param name="session"/> 文档]

model
类型：Api.Framework.Toolsbase_model

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Update(SqlSugar.SqlSugarClient,Api.Framework.Tools.base_model,System.Object)" 的 <param name="model"/> 文档]

param (Optional)
类型：SystemObject

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.Update(SqlSugar.SqlSugarClient,Api.Framework.Tools.base_model,System.Object)" 的 <param name="param"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


SqlSugarExtend.UpdateColumnType 方法

SqlSugarExtendUpdateColumnType 方法

修改字段类型

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void UpdateColumnType(
    this SqlSugarClient session,
    string tableName,
    string cloumnName,
    string newType
)

参数

session
类型：SqlSugarClient

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.UpdateColumnType(SqlSugar.SqlSugarClient,System.String,System.String,System.String)" 的 <param name="session"/> 文档]

tableName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.UpdateColumnType(SqlSugar.SqlSugarClient,System.String,System.String,System.String)" 的 <param name="tableName"/> 文档]

cloumnName
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.UpdateColumnType(SqlSugar.SqlSugarClient,System.String,System.String,System.String)" 的 <param name="cloumnName"/> 文档]

newType
类型：SystemString

[缺少 "M:Api.Framework.Tools.SqlSugarExtend.UpdateColumnType(SqlSugar.SqlSugarClient,System.String,System.String,System.String)" 的 <param name="newType"/> 文档]

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 SqlSugarClient 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

SqlSugarExtend 类
Api.Framework.Tools 命名空间


StoreInfo 类

店铺信息
继承层次
SystemObject
Api.Framework.ToolsStoreInfo

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class StoreInfo

StoreInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | StoreInfo | 初始化 StoreInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | storeId | 店铺id
公共属性 | storeName | 店铺名称
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


StoreInfo 构造函数

初始化 StoreInfo 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public StoreInfo()
参见

引用

StoreInfo 类
Api.Framework.Tools 命名空间


StoreInfo 属性

StoreInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | storeId | 店铺id
公共属性 | storeName | 店铺名称
Top
参见

引用

StoreInfo 类
Api.Framework.Tools 命名空间


StoreInfo.storeId 属性

StoreInfostoreId 属性

店铺id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string storeId { get; set; }

属性值

类型：String
参见

引用

StoreInfo 类
Api.Framework.Tools 命名空间


StoreInfo.storeName 属性

StoreInfostoreName 属性

店铺名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string storeName { get; set; }

属性值

类型：String
参见

引用

StoreInfo 类
Api.Framework.Tools 命名空间


StoreInfo 方法

StoreInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

StoreInfo 类
Api.Framework.Tools 命名空间


StoreServiceCapability 类

商品所属店铺服务能力评价
继承层次
SystemObject
Api.Framework.ToolsStoreServiceCapability

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class StoreServiceCapability

StoreServiceCapability 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | StoreServiceCapability | 初始化 StoreServiceCapability 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | storeRankRate | 店铺同品类排名比例：例如10表示前10%
公共属性 | storeScore | 店铺评分：保留两位小数
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


StoreServiceCapability 构造函数

初始化 StoreServiceCapability 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public StoreServiceCapability()
参见

引用

StoreServiceCapability 类
Api.Framework.Tools 命名空间


StoreServiceCapability 属性

StoreServiceCapability 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | storeRankRate | 店铺同品类排名比例：例如10表示前10%
公共属性 | storeScore | 店铺评分：保留两位小数
Top
参见

引用

StoreServiceCapability 类
Api.Framework.Tools 命名空间


StoreServiceCapability.storeRankRate 属性

StoreServiceCapabilitystoreRankRate 属性

店铺同品类排名比例：例如10表示前10%

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string storeRankRate { get; set; }

属性值

类型：String
参见

引用

StoreServiceCapability 类
Api.Framework.Tools 命名空间


StoreServiceCapability.storeScore 属性

StoreServiceCapabilitystoreScore 属性

店铺评分：保留两位小数

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string storeScore { get; set; }

属性值

类型：String
参见

引用

StoreServiceCapability 类
Api.Framework.Tools 命名空间


StoreServiceCapability 方法

StoreServiceCapability 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

StoreServiceCapability 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue) 类

SynchronizedDictionaryTKey, TValue 类

线程安全的数据字典
继承层次
SystemObject
Api.Framework.ToolsSynchronizedDictionaryTKey, TValue

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SynchronizedDictionary<TKey, TValue>

类型参数

TKey
TValue

SynchronizedDictionaryTKey, TValue 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SynchronizedDictionaryTKey, TValue | 初始化 SynchronizedDictionaryTKey, TValue 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Comparer |
公共属性 | Count | 字典中键值对的数目
公共属性 | Item | 通过key获取特定的值
公共属性 | Keys | 字典的键集合
公共属性 | KeysToArray | 字典键数组
公共属性 | Values | 字典值集合
公共属性 | ValuesToArray | 字典值数组
Top
方法
 | 名称 | 说明
公共方法 | Add | 向字典中增加键值对
公共方法 | AddRange | 向字典中添加列表
公共方法 | Clear | 清空数据字典
公共方法 | ContainsKey | 字典是否包含特定的键
公共方法 | ContainsValue | 字典是否包含特定的值
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetEnumerator | 返回字典循环访问的枚举
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Key | 获取字典特定位置的键
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Remove | 从字典中移除特定的键值对
公共方法 | ToString | (继承自 Object。)
公共方法 | Value |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue) 构造函数

SynchronizedDictionaryTKey, TValue 构造函数

初始化 SynchronizedDictionaryTKey, TValue 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SynchronizedDictionary()
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue) 属性

SynchronizedDictionaryTKey, TValue 属性

SynchronizedDictionaryTKey, TValue 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Comparer |
公共属性 | Count | 字典中键值对的数目
公共属性 | Item | 通过key获取特定的值
公共属性 | Keys | 字典的键集合
公共属性 | KeysToArray | 字典键数组
公共属性 | Values | 字典值集合
公共属性 | ValuesToArray | 字典值数组
Top
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Comparer 属性

SynchronizedDictionaryTKey, TValueComparer 属性

[缺少 "P:Api.Framework.Tools.SynchronizedDictionary`2.Comparer" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public IEqualityComparer<TKey> Comparer { get; }

属性值

类型：IEqualityComparer TKey
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Count 属性

SynchronizedDictionaryTKey, TValueCount 属性

字典中键值对的数目

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Count { get; }

属性值

类型：Int32
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Item 属性

SynchronizedDictionaryTKey, TValueItem 属性

通过key获取特定的值

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TValue this[
    TKey key
] { get; set; }

参数

key
类型：TKey

返回值

类型：TValue
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Keys 属性

SynchronizedDictionaryTKey, TValueKeys 属性

字典的键集合

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DictionaryTKey, TValueKeyCollection Keys { get; }

属性值

类型：DictionaryTKey, TValueKeyCollection
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).KeysToArray 属性

SynchronizedDictionaryTKey, TValueKeysToArray 属性

字典键数组

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TKey[] KeysToArray { get; }

属性值

类型：TKey
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Values 属性

SynchronizedDictionaryTKey, TValueValues 属性

字典值集合

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DictionaryTKey, TValueValueCollection Values { get; }

属性值

类型：DictionaryTKey, TValueValueCollection
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).ValuesToArray 属性

SynchronizedDictionaryTKey, TValueValuesToArray 属性

字典值数组

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TValue[] ValuesToArray { get; }

属性值

类型：TValue
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue) 方法

SynchronizedDictionaryTKey, TValue 方法

SynchronizedDictionaryTKey, TValue 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Add | 向字典中增加键值对
公共方法 | AddRange | 向字典中添加列表
公共方法 | Clear | 清空数据字典
公共方法 | ContainsKey | 字典是否包含特定的键
公共方法 | ContainsValue | 字典是否包含特定的值
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetEnumerator | 返回字典循环访问的枚举
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Key | 获取字典特定位置的键
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Remove | 从字典中移除特定的键值对
公共方法 | ToString | (继承自 Object。)
公共方法 | Value |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Add 方法

SynchronizedDictionaryTKey, TValueAdd 方法

向字典中增加键值对

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Add(
    TKey key,
    TValue value
)

参数

key
类型：TKey

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.Add(`0,`1)" 的 <param name="key"/> 文档]

value
类型：TValue

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.Add(`0,`1)" 的 <param name="value"/> 文档]

参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).AddRange 方法

SynchronizedDictionaryTKey, TValueAddRange 方法

向字典中添加列表

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void AddRange(
    ICollection<TValue> valueList,
    Func<TValue, TKey> func
)

参数

valueList
类型：System.Collections.GenericICollection TValue

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.AddRange(System.Collections.Generic.ICollection{`1},System.Func{`1,`0})" 的 <param name="valueList"/> 文档]

func
类型：SystemFunc TValue, TKey

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.AddRange(System.Collections.Generic.ICollection{`1},System.Func{`1,`0})" 的 <param name="func"/> 文档]

参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Clear 方法

SynchronizedDictionaryTKey, TValueClear 方法

清空数据字典

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Clear()
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).ContainsKey 方法

SynchronizedDictionaryTKey, TValueContainsKey 方法

字典是否包含特定的键

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool ContainsKey(
    TKey key
)

参数

key
类型：TKey

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.ContainsKey(`0)" 的 <param name="key"/> 文档]

返回值

类型：Boolean
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).ContainsValue 方法

SynchronizedDictionaryTKey, TValueContainsValue 方法

字典是否包含特定的值

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool ContainsValue(
    TValue value
)

参数

value
类型：TValue

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.ContainsValue(`1)" 的 <param name="value"/> 文档]

返回值

类型：Boolean
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).GetEnumerator 方法

SynchronizedDictionaryTKey, TValueGetEnumerator 方法

返回字典循环访问的枚举

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DictionaryTKey, TValueEnumerator GetEnumerator()

返回值

类型：DictionaryTKey, TValueEnumerator
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Key 方法

SynchronizedDictionaryTKey, TValueKey 方法

获取字典特定位置的键

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TKey Key(
    int index
)

参数

index
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.Key(System.Int32)" 的 <param name="index"/> 文档]

返回值

类型：TKey
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Remove 方法

SynchronizedDictionaryTKey, TValueRemove 方法

从字典中移除特定的键值对

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Remove(
    TKey key
)

参数

key
类型：TKey

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.Remove(`0)" 的 <param name="key"/> 文档]

返回值

类型：Boolean
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


SynchronizedDictionary(TKey, TValue).Value 方法

SynchronizedDictionaryTKey, TValueValue 方法

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.Value(System.Int32)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TValue Value(
    int index
)

参数

index
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.SynchronizedDictionary`2.Value(System.Int32)" 的 <param name="index"/> 文档]

返回值

类型：TValue
参见

引用

SynchronizedDictionaryTKey, TValue 类
Api.Framework.Tools 命名空间


TBHelper 类

淘宝导购帮助类
继承层次
SystemObject
Api.Framework.ToolsTBHelper

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class TBHelper

TBHelper 类型公开以下成员。

方法
名称 | 说明
FindGoodsActivityId_DaTaoKe | 通过商品id获取大淘客的信息
FindGoodsActivityId_HaoDanKu | 通过商品id获取好单库的信息
FindGoodsCouponInfo | 通过商品id获取优惠券信息(爬大淘客优惠券信息)
FindTBCouponByItemIdCache | 在存有优惠券的字典中查询商品编码
SetTBCouponByItemIdCache | 将优惠券链接和商品编码保存在字典中
Top
参见

引用

Api.Framework.Tools 命名空间


TBHelper 方法

TBHelper 类型公开以下成员。

方法
名称 | 说明
FindGoodsActivityId_DaTaoKe | 通过商品id获取大淘客的信息
FindGoodsActivityId_HaoDanKu | 通过商品id获取好单库的信息
FindGoodsCouponInfo | 通过商品id获取优惠券信息(爬大淘客优惠券信息)
FindTBCouponByItemIdCache | 在存有优惠券的字典中查询商品编码
SetTBCouponByItemIdCache | 将优惠券链接和商品编码保存在字典中
Top
参见

引用

TBHelper 类
Api.Framework.Tools 命名空间


TBHelper.FindGoodsActivityId_DaTaoKe 方法

TBHelperFindGoodsActivityId_DaTaoKe 方法

通过商品id获取大淘客的信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static TBHelperTbExCoupon FindGoodsActivityId_DaTaoKe(
    string itemId
)

参数

itemId
类型：SystemString
商品id

返回值

类型：TBHelperTbExCoupon
参见

引用

TBHelper 类
Api.Framework.Tools 命名空间


TBHelper.FindGoodsActivityId_HaoDanKu 方法

TBHelperFindGoodsActivityId_HaoDanKu 方法

通过商品id获取好单库的信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static TBHelperTbExCoupon FindGoodsActivityId_HaoDanKu(
    string itemId
)

参数

itemId
类型：SystemString
商品id

返回值

类型：TBHelperTbExCoupon
参见

引用

TBHelper 类
Api.Framework.Tools 命名空间


TBHelper.FindGoodsCouponInfo 方法

TBHelperFindGoodsCouponInfo 方法

通过商品id获取优惠券信息(爬大淘客优惠券信息)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static TBHelperTbExCoupon FindGoodsCouponInfo(
    string itemId
)

参数

itemId
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.FindGoodsCouponInfo(System.String)" 的 <param name="itemId"/> 文档]

返回值

类型：TBHelperTbExCoupon
参见

引用

TBHelper 类
Api.Framework.Tools 命名空间


TBHelper.FindTBCouponByItemIdCache 方法

TBHelperFindTBCouponByItemIdCache 方法

在存有优惠券的字典中查询商品编码

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string FindTBCouponByItemIdCache(
    string url
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.FindTBCouponByItemIdCache(System.String)" 的 <param name="url"/> 文档]

返回值

类型：String
参见

引用

TBHelper 类
Api.Framework.Tools 命名空间


TBHelper.SetTBCouponByItemIdCache 方法

TBHelperSetTBCouponByItemIdCache 方法

将优惠券链接和商品编码保存在字典中

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SetTBCouponByItemIdCache(
    string url,
    string item_id
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.SetTBCouponByItemIdCache(System.String,System.String)" 的 <param name="url"/> 文档]

item_id
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.SetTBCouponByItemIdCache(System.String,System.String)" 的 <param name="item_id"/> 文档]

参见

引用

TBHelper 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis 类

TBHelperTbAnalysis 类

淘宝解析方法
继承层次
SystemObject
Api.Framework.ToolsTBHelperTbAnalysis

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class TbAnalysis

TBHelperTbAnalysis 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TBHelperTbAnalysis | 初始化 TBHelperTbAnalysis 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | CouponByItemId | 通过优惠券链接获取淘宝宝贝的id
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindItemIdByUrlAndTklAndMkl(String, AlimamaApi) | 已过时。 获取宝贝Id.解析所有的各种链接/淘口令/喵口令等,先解析商品类型的链接,在去解析其他类型的链接
公共方法 | FindItemIdByUrlAndTklAndMkl(String, AlimamaApi, String) | 获取宝贝Id.解析所有的各种链接/淘口令/喵口令等,先解析商品类型的链接,在去解析其他类型的链接
公共方法 | FindShortUrlBySrcUrl | 生成淘宝短连接
公共方法 | FindTbInfoByItemId | 通过宝贝id,查询宝贝所有的信息
公共方法 | FindTbItemIdByStr | 从字符串中获取淘宝宝贝id
公共方法 | FindTbPublisherInfoAll | 私域用户备案信息查询,默认查询所有
公共方法 | FindTbPublisherInfoFirst | 私域用户备案信息查询
公共方法 | FindTKL | 将淘宝url生成淘口令
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPrivilege |
公共方法 | GetType | (继承自 Object。)
公共方法 | IsRunTBSiYu | 是否运行淘宝私域功能,用于同步私域数据
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ReplaceTklModifier | 替换淘口令前后符号(系统配置)
公共方法 | ToString | (继承自 Object。)
Top
字段
 | 名称 | 说明
公共字段 | activityId | 活动ID
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


TBHelper.TbAnalysis 构造函数

TBHelperTbAnalysis 构造函数

初始化 TBHelperTbAnalysis 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TbAnalysis()
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TbAnalysis 方法

TBHelperTbAnalysis 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CouponByItemId | 通过优惠券链接获取淘宝宝贝的id
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindItemIdByUrlAndTklAndMkl(String, AlimamaApi) | 已过时。 获取宝贝Id.解析所有的各种链接/淘口令/喵口令等,先解析商品类型的链接,在去解析其他类型的链接
公共方法 | FindItemIdByUrlAndTklAndMkl(String, AlimamaApi, String) | 获取宝贝Id.解析所有的各种链接/淘口令/喵口令等,先解析商品类型的链接,在去解析其他类型的链接
公共方法 | FindShortUrlBySrcUrl | 生成淘宝短连接
公共方法 | FindTbInfoByItemId | 通过宝贝id,查询宝贝所有的信息
公共方法 | FindTbItemIdByStr | 从字符串中获取淘宝宝贝id
公共方法 | FindTbPublisherInfoAll | 私域用户备案信息查询,默认查询所有
公共方法 | FindTbPublisherInfoFirst | 私域用户备案信息查询
公共方法 | FindTKL | 将淘宝url生成淘口令
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPrivilege |
公共方法 | GetType | (继承自 Object。)
公共方法 | IsRunTBSiYu | 是否运行淘宝私域功能,用于同步私域数据
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ReplaceTklModifier | 替换淘口令前后符号(系统配置)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.CouponByItemId 方法

TBHelperTbAnalysisCouponByItemId 方法

通过优惠券链接获取淘宝宝贝的id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string CouponByItemId(
    string url,
    AlimamaApi api
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.CouponByItemId(System.String,Api.Framework.Cps.AlimamaApi)" 的 <param name="url"/> 文档]

api
类型：Api.Framework.CpsAlimamaApi

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.CouponByItemId(System.String,Api.Framework.Cps.AlimamaApi)" 的 <param name="api"/> 文档]

返回值

类型：String
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TbAnalysis.FindItemIdByUrlAndTklAndMkl 方法

TbAnalysisFindItemIdByUrlAndTklAndMkl 方法

重载列表
 | 名称 | 说明
公共方法 | FindItemIdByUrlAndTklAndMkl(String, AlimamaApi) | 已过时。 获取宝贝Id.解析所有的各种链接/淘口令/喵口令等,先解析商品类型的链接,在去解析其他类型的链接
公共方法 | FindItemIdByUrlAndTklAndMkl(String, AlimamaApi, String) | 获取宝贝Id.解析所有的各种链接/淘口令/喵口令等,先解析商品类型的链接,在去解析其他类型的链接
Top
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.FindItemIdByUrlAndTklAndMkl 方法 (String, AlimamaApi)

TBHelperTbAnalysisFindItemIdByUrlAndTklAndMkl 方法 (String, AlimamaApi)

注意：此 API 现在已过时。

获取宝贝Id.解析所有的各种链接/淘口令/喵口令等,先解析商品类型的链接,在去解析其他类型的链接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
[ObsoleteAttribute("过时的")]
public string FindItemIdByUrlAndTklAndMkl(
    string mess,
    AlimamaApi api
)

参数

mess
类型：SystemString
要解析内容
api
类型：Api.Framework.CpsAlimamaApi
AlimamaApi对象

返回值

类型：String
返回宝贝Id,找不到返回空,异常返回异常的信息
参见

引用

TBHelperTbAnalysis 类
FindItemIdByUrlAndTklAndMkl 重载
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.FindItemIdByUrlAndTklAndMkl 方法 (String, AlimamaApi, String[])

TBHelperTbAnalysisFindItemIdByUrlAndTklAndMkl 方法 (String, AlimamaApi, String)

获取宝贝Id.解析所有的各种链接/淘口令/喵口令等,先解析商品类型的链接,在去解析其他类型的链接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string FindItemIdByUrlAndTklAndMkl(
    string mess,
    AlimamaApi api,
    string[] pids = null
)

参数

mess
类型：SystemString
要解析内容
api
类型：Api.Framework.CpsAlimamaApi
AlimamaApi对象
pids (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.FindItemIdByUrlAndTklAndMkl(System.String,Api.Framework.Cps.AlimamaApi,System.String[])" 的 <param name="pids"/> 文档]

返回值

类型：String
返回宝贝Id,找不到返回空,异常返回异常的信息
参见

引用

TBHelperTbAnalysis 类
FindItemIdByUrlAndTklAndMkl 重载
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.FindShortUrlBySrcUrl 方法

TBHelperTbAnalysisFindShortUrlBySrcUrl 方法

生成淘宝短连接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string FindShortUrlBySrcUrl(
    string url,
    AlimamaApi api
)

参数

url
类型：SystemString
url链接
api
类型：Api.Framework.CpsAlimamaApi
AlimamaApi对象

返回值

类型：String
返回缩短后的链接或原始链接
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.FindTbInfoByItemId 方法

TBHelperTbAnalysisFindTbInfoByItemId 方法

通过宝贝id,查询宝贝所有的信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TBHelperTbBaseInfo FindTbInfoByItemId(
    string itemId
)

参数

itemId
类型：SystemString
宝贝ID

返回值

类型：TBHelperTbBaseInfo
返回TbInfo对象,异常返回Null
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.FindTbItemIdByStr 方法

TBHelperTbAnalysisFindTbItemIdByStr 方法

从字符串中获取淘宝宝贝id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string FindTbItemIdByStr(
    string str
)

参数

str
类型：SystemString
要查找的字符串

返回值

类型：String
返回查找到的宝贝id,未找到返回空,异常返回异常的信息
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.FindTbPublisherInfoAll 方法

TBHelperTbAnalysisFindTbPublisherInfoAll 方法

私域用户备案信息查询,默认查询所有

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ArrayList FindTbPublisherInfoAll(
    AlimamaApi api,
    Object _data = null
)

参数

api
类型：Api.Framework.CpsAlimamaApi
AlimamaApi对象
_data (Optional)
类型：SystemObject
参数

返回值

类型：ArrayList
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.FindTbPublisherInfoFirst 方法

TBHelperTbAnalysisFindTbPublisherInfoFirst 方法

私域用户备案信息查询

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string FindTbPublisherInfoFirst(
    AlimamaApi api,
    Object _data,
    TBHelperTbAnalysisPublisherType publisherType = TBHelperTbAnalysisPublisherType.SpecialId
)

参数

api
类型：Api.Framework.CpsAlimamaApi

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.FindTbPublisherInfoFirst(Api.Framework.Cps.AlimamaApi,System.Object,Api.Framework.Tools.TBHelper.TbAnalysis.PublisherType)" 的 <param name="api"/> 文档]

_data
类型：SystemObject

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.FindTbPublisherInfoFirst(Api.Framework.Cps.AlimamaApi,System.Object,Api.Framework.Tools.TBHelper.TbAnalysis.PublisherType)" 的 <param name="_data"/> 文档]

publisherType (Optional)
类型：Api.Framework.ToolsTBHelperTbAnalysisPublisherType

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.FindTbPublisherInfoFirst(Api.Framework.Cps.AlimamaApi,System.Object,Api.Framework.Tools.TBHelper.TbAnalysis.PublisherType)" 的 <param name="publisherType"/> 文档]

返回值

类型：String
special_id
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.FindTKL 方法

TBHelperTbAnalysisFindTKL 方法

将淘宝url生成淘口令

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string FindTKL(
    string _url,
    string title,
    string logo,
    AlimamaApi api
)

参数

_url
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.FindTKL(System.String,System.String,System.String,Api.Framework.Cps.AlimamaApi)" 的 <param name="_url"/> 文档]

title
类型：SystemString
标题
logo
类型：SystemString
图片url[宝贝图片,非本地图片]
api
类型：Api.Framework.CpsAlimamaApi
AlimamaApi对象

返回值

类型：String
返回淘口令或空
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.GetPrivilege 方法

TBHelperTbAnalysisGetPrivilege 方法

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.GetPrivilege(Api.Framework.Cps.AlimamaApi,System.String,System.String[],System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Object> GetPrivilege(
    AlimamaApi api,
    string item_id,
    string[] pid_split,
    string external_id = "",
    string special_id = ""
)

参数

api
类型：Api.Framework.CpsAlimamaApi

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.GetPrivilege(Api.Framework.Cps.AlimamaApi,System.String,System.String[],System.String,System.String)" 的 <param name="api"/> 文档]

item_id
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.GetPrivilege(Api.Framework.Cps.AlimamaApi,System.String,System.String[],System.String,System.String)" 的 <param name="item_id"/> 文档]

pid_split
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.GetPrivilege(Api.Framework.Cps.AlimamaApi,System.String,System.String[],System.String,System.String)" 的 <param name="pid_split"/> 文档]

external_id (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.GetPrivilege(Api.Framework.Cps.AlimamaApi,System.String,System.String[],System.String,System.String)" 的 <param name="external_id"/> 文档]

special_id (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbAnalysis.GetPrivilege(Api.Framework.Cps.AlimamaApi,System.String,System.String[],System.String,System.String)" 的 <param name="special_id"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.IsRunTBSiYu 方法

TBHelperTbAnalysisIsRunTBSiYu 方法

是否运行淘宝私域功能,用于同步私域数据

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsRunTBSiYu()

返回值

类型：Boolean
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.ReplaceTklModifier 方法

TBHelperTbAnalysisReplaceTklModifier 方法

替换淘口令前后符号(系统配置)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ReplaceTklModifier(
    string tkl
)

参数

tkl
类型：SystemString
需要替换的淘口令

返回值

类型：String
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TbAnalysis 字段

TBHelperTbAnalysis 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | activityId | 活动ID
Top
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.activityId 字段

TBHelperTbAnalysisactivityId 字段

活动ID

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string activityId

字段值

类型：String
参见

引用

TBHelperTbAnalysis 类
Api.Framework.Tools 命名空间


TBHelper.TbAnalysis.PublisherType 枚举

TBHelperTbAnalysisPublisherType 枚举

私域查詢数据的類型

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum PublisherType
成员
成员名称 | 值 | 说明
SpecialId | 0 |
ExternalId | 1 |
参见

引用

Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo 类

TBHelperTbBaseInfo 类

保存淘宝基础信息的类
继承层次
SystemObject
Api.Framework.ToolsTBHelperTbBaseInfo

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class TbBaseInfo

TBHelperTbBaseInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TBHelperTbBaseInfo | 初始化 TBHelperTbBaseInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ItemId | 宝贝ID
公共属性 | ItemImage | 商品主图
公共属性 | ItemTitle | 商品标题
公共属性 | Price | 价格
公共属性 | SellCount | 月销量
公共属性 | SellerId | 店铺Id
公共属性 | ShopIcon | 店铺头像
公共属性 | ShopName | 店铺名称
公共属性 | UserId |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo 构造函数

TBHelperTbBaseInfo 构造函数

初始化 TBHelperTbBaseInfo 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TbBaseInfo()
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TbBaseInfo 属性

TBHelperTbBaseInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ItemId | 宝贝ID
公共属性 | ItemImage | 商品主图
公共属性 | ItemTitle | 商品标题
公共属性 | Price | 价格
公共属性 | SellCount | 月销量
公共属性 | SellerId | 店铺Id
公共属性 | ShopIcon | 店铺头像
公共属性 | ShopName | 店铺名称
公共属性 | UserId |
Top
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo.ItemId 属性

TBHelperTbBaseInfoItemId 属性

宝贝ID

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ItemId { get; set; }

属性值

类型：String
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo.ItemImage 属性

TBHelperTbBaseInfoItemImage 属性

商品主图

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ItemImage { get; set; }

属性值

类型：String
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo.ItemTitle 属性

TBHelperTbBaseInfoItemTitle 属性

商品标题

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ItemTitle { get; set; }

属性值

类型：String
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo.Price 属性

TBHelperTbBaseInfoPrice 属性

价格

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Price { get; set; }

属性值

类型：String
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo.SellCount 属性

TBHelperTbBaseInfoSellCount 属性

月销量

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SellCount { get; set; }

属性值

类型：String
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo.SellerId 属性

TBHelperTbBaseInfoSellerId 属性

店铺Id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SellerId { get; set; }

属性值

类型：String
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo.ShopIcon 属性

TBHelperTbBaseInfoShopIcon 属性

店铺头像

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ShopIcon { get; set; }

属性值

类型：String
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo.ShopName 属性

TBHelperTbBaseInfoShopName 属性

店铺名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ShopName { get; set; }

属性值

类型：String
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbBaseInfo.UserId 属性

TBHelperTbBaseInfoUserId 属性

[缺少 "P:Api.Framework.Tools.TBHelper.TbBaseInfo.UserId" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string UserId { get; set; }

属性值

类型：String
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TbBaseInfo 方法

TBHelperTbBaseInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

TBHelperTbBaseInfo 类
Api.Framework.Tools 命名空间


TBHelper.TbExCoupon 类

TBHelperTbExCoupon 类

外围淘宝商品信息(优惠券等信息)
继承层次
SystemObject
Api.Framework.ToolsTBHelperTbExCoupon

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class TbExCoupon

TBHelperTbExCoupon 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TBHelperTbExCoupon | 初始化 TBHelperTbExCoupon 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | activityId | 优惠券信息
公共属性 | couponAmount | 优惠券金额
公共属性 | endPrice | 折后价格减去优惠券金额
公共属性 | salePrice | 折后价(活动价)
公共属性 | sellerId | 店铺Id
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


TBHelper.TbExCoupon 构造函数

TBHelperTbExCoupon 构造函数

初始化 TBHelperTbExCoupon 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TbExCoupon()
参见

引用

TBHelperTbExCoupon 类
Api.Framework.Tools 命名空间


TbExCoupon 属性

TBHelperTbExCoupon 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | activityId | 优惠券信息
公共属性 | couponAmount | 优惠券金额
公共属性 | endPrice | 折后价格减去优惠券金额
公共属性 | salePrice | 折后价(活动价)
公共属性 | sellerId | 店铺Id
Top
参见

引用

TBHelperTbExCoupon 类
Api.Framework.Tools 命名空间


TBHelper.TbExCoupon.activityId 属性

TBHelperTbExCouponactivityId 属性

优惠券信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string activityId { get; set; }

属性值

类型：String
参见

引用

TBHelperTbExCoupon 类
Api.Framework.Tools 命名空间


TBHelper.TbExCoupon.couponAmount 属性

TBHelperTbExCouponcouponAmount 属性

优惠券金额

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double couponAmount { get; set; }

属性值

类型：Double
参见

引用

TBHelperTbExCoupon 类
Api.Framework.Tools 命名空间


TBHelper.TbExCoupon.endPrice 属性

TBHelperTbExCouponendPrice 属性

折后价格减去优惠券金额

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double endPrice { get; set; }

属性值

类型：Double
参见

引用

TBHelperTbExCoupon 类
Api.Framework.Tools 命名空间


TBHelper.TbExCoupon.salePrice 属性

TBHelperTbExCouponsalePrice 属性

折后价(活动价)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double salePrice { get; set; }

属性值

类型：Double
参见

引用

TBHelperTbExCoupon 类
Api.Framework.Tools 命名空间


TBHelper.TbExCoupon.sellerId 属性

TBHelperTbExCouponsellerId 属性

店铺Id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string sellerId { get; set; }

属性值

类型：String
参见

引用

TBHelperTbExCoupon 类
Api.Framework.Tools 命名空间


TbExCoupon 方法

TBHelperTbExCoupon 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

TBHelperTbExCoupon 类
Api.Framework.Tools 命名空间


TBHelper.TbTools 类

TBHelperTbTools 类

[缺少 "T:Api.Framework.Tools.TBHelper.TbTools" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsTBHelperTbTools

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class TbTools

TBHelperTbTools 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TBHelperTbTools | 初始化 TBHelperTbTools 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | FindLocationByUrl | 链接跳转获取Location
 | GetH5Result |
公共方法 | GetHashCode | (继承自 Object。)
 | GetLocation(String) |
 | GetLocation(String, String, Boolean) |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | SendData | 发送API数据
公共方法 | ToString | (继承自 Object。)
Top
字段
名称 | 说明
Reg_CheckIsUrl |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


TBHelper.TbTools 构造函数

TBHelperTbTools 构造函数

初始化 TBHelperTbTools 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TbTools()
参见

引用

TBHelperTbTools 类
Api.Framework.Tools 命名空间


TbTools 方法

TBHelperTbTools 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | FindLocationByUrl | 链接跳转获取Location
 | GetH5Result |
公共方法 | GetHashCode | (继承自 Object。)
 | GetLocation(String) |
 | GetLocation(String, String, Boolean) |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | SendData | 发送API数据
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

TBHelperTbTools 类
Api.Framework.Tools 命名空间


TBHelper.TbTools.FindLocationByUrl 方法

TBHelperTbToolsFindLocationByUrl 方法

链接跳转获取Location

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string FindLocationByUrl(
    string url,
    string referer = "",
    bool allowautoredirect = false
)

参数

url
类型：SystemString
要获取Location的链接
referer (Optional)
类型：SystemString
来源
allowautoredirect (Optional)
类型：SystemBoolean
是否跳转

返回值

类型：String
参见

引用

TBHelperTbTools 类
Api.Framework.Tools 命名空间


TBHelper.TbTools.GetH5Result 方法

TBHelperTbToolsGetH5Result 方法

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetH5Result(System.String,System.Object,System.String@,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, Object> GetH5Result(
    string api,
    Object data,
    out string html,
    string version = "6.0"
)

参数

api
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetH5Result(System.String,System.Object,System.String@,System.String)" 的 <param name="api"/> 文档]

data
类型：SystemObject

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetH5Result(System.String,System.Object,System.String@,System.String)" 的 <param name="data"/> 文档]

html
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetH5Result(System.String,System.Object,System.String@,System.String)" 的 <param name="html"/> 文档]

version (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetH5Result(System.String,System.Object,System.String@,System.String)" 的 <param name="version"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

TBHelperTbTools 类
Api.Framework.Tools 命名空间


TbTools.GetLocation 方法

TbToolsGetLocation 方法

重载列表
名称 | 说明
GetLocation(String) |
GetLocation(String, String, Boolean) |
Top
参见

引用

TBHelperTbTools 类
Api.Framework.Tools 命名空间


TBHelper.TbTools.GetLocation 方法 (String)

TBHelperTbToolsGetLocation 方法 (String)

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetLocation(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetLocation(
    string url
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetLocation(System.String)" 的 <param name="url"/> 文档]

返回值

类型：String
参见

引用

TBHelperTbTools 类
GetLocation 重载
Api.Framework.Tools 命名空间


TBHelper.TbTools.GetLocation 方法 (String, String, Boolean)

TBHelperTbToolsGetLocation 方法 (String, String, Boolean)

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetLocation(System.String,System.String,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetLocation(
    string url,
    string referer = "",
    bool allowautoredirect = false
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetLocation(System.String,System.String,System.Boolean)" 的 <param name="url"/> 文档]

referer (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetLocation(System.String,System.String,System.Boolean)" 的 <param name="referer"/> 文档]

allowautoredirect (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.GetLocation(System.String,System.String,System.Boolean)" 的 <param name="allowautoredirect"/> 文档]

返回值

类型：String
参见

引用

TBHelperTbTools 类
GetLocation 重载
Api.Framework.Tools 命名空间


TBHelper.TbTools.SendData 方法

TBHelperTbToolsSendData 方法

发送API数据

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static WebResult SendData(
    string method,
    Object param = null,
    bool flag = true
)

参数

method
类型：SystemString
API接口
param (Optional)
类型：SystemObject
参数
flag (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Tools.TBHelper.TbTools.SendData(System.String,System.Object,System.Boolean)" 的 <param name="flag"/> 文档]

返回值

类型：WebResult
参见

引用

TBHelperTbTools 类
Api.Framework.Tools 命名空间


TbTools 字段

TBHelperTbTools 类型公开以下成员。

字段
名称 | 说明
Reg_CheckIsUrl |
Top
参见

引用

TBHelperTbTools 类
Api.Framework.Tools 命名空间


TBHelper.TbTools.Reg_CheckIsUrl 字段

TBHelperTbToolsReg_CheckIsUrl 字段

[缺少 "F:Api.Framework.Tools.TBHelper.TbTools.Reg_CheckIsUrl" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const string Reg_CheckIsUrl = "(?<链接>((ht|f)tps?):\/\/[\w\-]+(\.[\w\-]+)+([\w\-\.,@?^=%&:\/~\+#]*[\w\-\@?^=%&\/~\+#])?)"

字段值

类型：String
参见

引用

TBHelperTbTools 类
Api.Framework.Tools 命名空间


TeaEncryption 类

加密解密QQ消息包的工具类.
继承层次
SystemObject
Api.Framework.ToolsTeaEncryption

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class TeaEncryption
方法
名称 | 说明
Decrypt(Byte, Byte) |
Decrypt(Byte, Int32, Int32, Byte) |
Encrypt(Byte, Byte) |
Encrypt(Byte, Int32, Int32, Byte) |
Top
参见

引用

Api.Framework.Tools 命名空间


TeaEncryption 方法

方法
名称 | 说明
Decrypt(Byte, Byte) |
Decrypt(Byte, Int32, Int32, Byte) |
Encrypt(Byte, Byte) |
Encrypt(Byte, Int32, Int32, Byte) |
Top
参见

引用

TeaEncryption 类
Api.Framework.Tools 命名空间


TeaEncryption.Decrypt 方法

TeaEncryptionDecrypt 方法

重载列表
名称 | 说明
Decrypt(Byte, Byte) |
Decrypt(Byte, Int32, Int32, Byte) |
Top
参见

引用

TeaEncryption 类
Api.Framework.Tools 命名空间


TeaEncryption.Decrypt 方法 (Byte[], Byte[])

TeaEncryptionDecrypt 方法 (Byte, Byte)

[缺少 "M:Api.Framework.Tools.TeaEncryption.Decrypt(System.Byte[],System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] Decrypt(
    byte[] data,
    byte[] key
)

参数

data
类型：SystemByte

[缺少 "M:Api.Framework.Tools.TeaEncryption.Decrypt(System.Byte[],System.Byte[])" 的 <param name="data"/> 文档]

key
类型：SystemByte

[缺少 "M:Api.Framework.Tools.TeaEncryption.Decrypt(System.Byte[],System.Byte[])" 的 <param name="key"/> 文档]

返回值

类型：Byte
参见

引用

TeaEncryption 类
Decrypt 重载
Api.Framework.Tools 命名空间


TeaEncryption.Decrypt 方法 (Byte[], Int32, Int32, Byte[])

TeaEncryptionDecrypt 方法 (Byte, Int32, Int32, Byte)

[缺少 "M:Api.Framework.Tools.TeaEncryption.Decrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] Decrypt(
    byte[] In,
    int offset,
    int len,
    byte[] key
)

参数

In
类型：SystemByte

[缺少 "M:Api.Framework.Tools.TeaEncryption.Decrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <param name="In"/> 文档]

offset
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.TeaEncryption.Decrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <param name="offset"/> 文档]

len
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.TeaEncryption.Decrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <param name="len"/> 文档]

key
类型：SystemByte

[缺少 "M:Api.Framework.Tools.TeaEncryption.Decrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <param name="key"/> 文档]

返回值

类型：Byte
参见

引用

TeaEncryption 类
Decrypt 重载
Api.Framework.Tools 命名空间


TeaEncryption.Encrypt 方法

TeaEncryptionEncrypt 方法

重载列表
名称 | 说明
Encrypt(Byte, Byte) |
Encrypt(Byte, Int32, Int32, Byte) |
Top
参见

引用

TeaEncryption 类
Api.Framework.Tools 命名空间


TeaEncryption.Encrypt 方法 (Byte[], Byte[])

TeaEncryptionEncrypt 方法 (Byte, Byte)

[缺少 "M:Api.Framework.Tools.TeaEncryption.Encrypt(System.Byte[],System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] Encrypt(
    byte[] data,
    byte[] key
)

参数

data
类型：SystemByte

[缺少 "M:Api.Framework.Tools.TeaEncryption.Encrypt(System.Byte[],System.Byte[])" 的 <param name="data"/> 文档]

key
类型：SystemByte

[缺少 "M:Api.Framework.Tools.TeaEncryption.Encrypt(System.Byte[],System.Byte[])" 的 <param name="key"/> 文档]

返回值

类型：Byte
参见

引用

TeaEncryption 类
Encrypt 重载
Api.Framework.Tools 命名空间


TeaEncryption.Encrypt 方法 (Byte[], Int32, Int32, Byte[])

TeaEncryptionEncrypt 方法 (Byte, Int32, Int32, Byte)

[缺少 "M:Api.Framework.Tools.TeaEncryption.Encrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] Encrypt(
    byte[] In,
    int offset,
    int len,
    byte[] key
)

参数

In
类型：SystemByte

[缺少 "M:Api.Framework.Tools.TeaEncryption.Encrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <param name="In"/> 文档]

offset
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.TeaEncryption.Encrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <param name="offset"/> 文档]

len
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.TeaEncryption.Encrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <param name="len"/> 文档]

key
类型：SystemByte

[缺少 "M:Api.Framework.Tools.TeaEncryption.Encrypt(System.Byte[],System.Int32,System.Int32,System.Byte[])" 的 <param name="key"/> 文档]

返回值

类型：Byte
参见

引用

TeaEncryption 类
Encrypt 重载
Api.Framework.Tools 命名空间


UrlInfoList 类

链接数据
继承层次
SystemObject
Api.Framework.ToolsUrlInfoList

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class UrlInfoList

UrlInfoList 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | UrlInfoList | 初始化 UrlInfoList 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | deeplinkUrl | CPS Deeplink链接
公共属性 | longUrl | CPS长连接
公共属性 | noEvokeLongUrl | CPS长链接：不唤起快应用
公共属性 | noEvokeUrl | CPS短链接：不唤起快应用
公共属性 | source | 链接生成的数据源： 如果根据商品id生成链接，该值商品id， 如果根据链接生成链接，该值为唯品会链接
公共属性 | traFrom | 小程序CPS参数：通用小程序跟单参数
公共属性 | ulUrl | CPS通用连接
公共属性 | url | CPS短链接
公共属性 | vipQuickAppUrl | 唯品会快应用链接
公共属性 | vipWxCode | 唯品会小程序码：仅在根据商品id获取时返回，需获取小程序码高级权限
公共属性 | vipWxUrl | 唯品会小程序链接：仅在根据商品id获取时返回
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


UrlInfoList 构造函数

初始化 UrlInfoList 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public UrlInfoList()
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList 属性

UrlInfoList 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | deeplinkUrl | CPS Deeplink链接
公共属性 | longUrl | CPS长连接
公共属性 | noEvokeLongUrl | CPS长链接：不唤起快应用
公共属性 | noEvokeUrl | CPS短链接：不唤起快应用
公共属性 | source | 链接生成的数据源： 如果根据商品id生成链接，该值商品id， 如果根据链接生成链接，该值为唯品会链接
公共属性 | traFrom | 小程序CPS参数：通用小程序跟单参数
公共属性 | ulUrl | CPS通用连接
公共属性 | url | CPS短链接
公共属性 | vipQuickAppUrl | 唯品会快应用链接
公共属性 | vipWxCode | 唯品会小程序码：仅在根据商品id获取时返回，需获取小程序码高级权限
公共属性 | vipWxUrl | 唯品会小程序链接：仅在根据商品id获取时返回
Top
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.deeplinkUrl 属性

UrlInfoListdeeplinkUrl 属性

CPS Deeplink链接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string deeplinkUrl { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.longUrl 属性

UrlInfoListlongUrl 属性

CPS长连接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string longUrl { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.noEvokeLongUrl 属性

UrlInfoListnoEvokeLongUrl 属性

CPS长链接：不唤起快应用

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string noEvokeLongUrl { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.noEvokeUrl 属性

UrlInfoListnoEvokeUrl 属性

CPS短链接：不唤起快应用

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string noEvokeUrl { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.source 属性

UrlInfoListsource 属性

链接生成的数据源： 如果根据商品id生成链接，该值商品id， 如果根据链接生成链接，该值为唯品会链接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string source { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.traFrom 属性

UrlInfoListtraFrom 属性

小程序CPS参数：通用小程序跟单参数

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string traFrom { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.ulUrl 属性

UrlInfoListulUrl 属性

CPS通用连接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ulUrl { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.url 属性

UrlInfoListurl 属性

CPS短链接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string url { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.vipQuickAppUrl 属性

UrlInfoListvipQuickAppUrl 属性

唯品会快应用链接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string vipQuickAppUrl { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.vipWxCode 属性

UrlInfoListvipWxCode 属性

唯品会小程序码：仅在根据商品id获取时返回，需获取小程序码高级权限

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string vipWxCode { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList.vipWxUrl 属性

UrlInfoListvipWxUrl 属性

唯品会小程序链接：仅在根据商品id获取时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string vipWxUrl { get; set; }

属性值

类型：String
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


UrlInfoList 方法

UrlInfoList 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

UrlInfoList 类
Api.Framework.Tools 命名空间


Util 类

[缺少 "T:Api.Framework.Tools.Util" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsUtil

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Util

Util 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Util | 初始化 Util 类的一个新实例
Top
方法
 | 名称 | 说明
 | AddText2Image | 给图片添加文字水印
 | AddWaterMark | 添加水印
 | AppConfig_AddItem |
 | AppConfig_ExistItem |
 | AppConfig_GetValue |
 | AppConfig_ModifyItem |
 | AppConfig_RemoveItem |
 | Base64ToFileAndSave | Base64字符串转换成文件
 | BitmapToBytes |
 | byteArrayToImage |
 | BytesToBitmap |
 | CheckUrlDomain | 检测微信域名是否正常
 | CleanAll |
 | CleanCookie | 删除Cookie文件 Win7+ 需要管理员权限
 | CleanHistory | 删除历史记录 Win7+ 需要管理员权限
 | CleanTempFiles | 删除临时文件 Win7+ 需要管理员权限
 | ClearCookies |
 | ComposeArrays |
 | ConvertDouble_FenToYuan |
 | ConvertEnumT(Int32) |
 | ConvertEnumT(String) |
 | ConvertEnumT(UInt16) |
 | CopyOldLabFilesToNewLab | 拷贝oldlab的文件到newlab下面
 | DecodeQRCode(Bitmap) | 解析二维码
 | DecodeQRCode(String, UtilDecodeQRCodeType) | 解密二维码
 | DecryptDES |
公共方法 | DownloadFile | 下载文件
公共方法 | DownloadHtml | 下载HTML
 | EncryptDES |
公共方法 | Equals | (继承自 Object。)
 | FileDelete | 删除一个文件，System.IO.File.Delete()函数不可以删除只读文件，这个函数可以强行把只读文件删除。
 | FileToBase64 | 文件转换成Base64字符串
受保护的方法 | Finalize | (继承自 Object。)
 | FindTKlRandomModifier | 获取一个淘口令前后随机修饰符
 | FolderClear | 删除文件夹
 | GetCache | 缓存是否存在
 | GetDateTime | 时间戳转时间
 | GetFileMd5Code |
公共方法 | GetHashCode | (继承自 Object。)
 | GetImageByte(Bitmap) | 将图片Bitmap类型转成字节数组
 | GetImageByte(String) | 将图片转换为字节数组
 | GetMD5 | MD5字符串加密
 | GetMd5_32byte |
 | GetMD5Hash |
 | GetMimeType(Image) |
 | GetMimeType(String) |
 | GetMiNiAppXml | 获取小程序xml文本
 | GetRandomString | 生成指定位数的随机数
 | GetTimeSpan(DateTime) | 日期转换成时间戳Timestamp
 | GetTimeSpan(DateTime, Boolean) | 日期转换成时间戳Timestamp
公共方法 | GetType | (继承自 Object。)
 | GetUUID | 获取UUID
 | HexToStr |
 | imageToByteArray |
 | InternetSetOption | 设置IE
 | InvitationCode(Int64) | 10进制转换为62进制
 | InvitationCode(String) |
 | IsXML | 是否为XML
 | MapFile |
 | MapPath |
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | PercentImage | 将图片控制在宽度为指定得像素
 | ReadT | 读取配置文件
 | ReadConfig |
公共方法 | ReadFile | 读取数据
 | ReadFileToByte | 读文件到byte[]
 | ReadImageFile | 通过FileStream 来打开文件，这样就可以实现不锁定Image文件，到时可以让多用户同时访问Image文件
 | RemoveCache | 设置缓存(辅助输入)
 | RemoveEmoji |
 | ReturnPhoto |
 | RunCmd | 调用CMD执行命令
 | Save | 保存配置文件
 | SendEmail |
 | SetCache | 设置缓存(辅助输入)
 | ShowTgwz |
 | StrToHex |
 | SuppressWininetBehavior |
 | TimeDiffer |
 | ToDeserializeT |
 | ToGrey | 图像灰度化
 | ToSerializer |
公共方法 | ToString | (继承自 Object。)
 | WriteByteToFile | 写byte[]到fileName
 | YaSuo | 将图片按百分比压缩，
Top
字段
名称 | 说明
_DecodePictureFile |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


Util 构造函数

初始化 Util 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Util()
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util 方法

Util 类型公开以下成员。

方法
 | 名称 | 说明
 | AddText2Image | 给图片添加文字水印
 | AddWaterMark | 添加水印
 | AppConfig_AddItem |
 | AppConfig_ExistItem |
 | AppConfig_GetValue |
 | AppConfig_ModifyItem |
 | AppConfig_RemoveItem |
 | Base64ToFileAndSave | Base64字符串转换成文件
 | BitmapToBytes |
 | byteArrayToImage |
 | BytesToBitmap |
 | CheckUrlDomain | 检测微信域名是否正常
 | CleanAll |
 | CleanCookie | 删除Cookie文件 Win7+ 需要管理员权限
 | CleanHistory | 删除历史记录 Win7+ 需要管理员权限
 | CleanTempFiles | 删除临时文件 Win7+ 需要管理员权限
 | ClearCookies |
 | ComposeArrays |
 | ConvertDouble_FenToYuan |
 | ConvertEnumT(Int32) |
 | ConvertEnumT(String) |
 | ConvertEnumT(UInt16) |
 | CopyOldLabFilesToNewLab | 拷贝oldlab的文件到newlab下面
 | DecodeQRCode(Bitmap) | 解析二维码
 | DecodeQRCode(String, UtilDecodeQRCodeType) | 解密二维码
 | DecryptDES |
公共方法 | DownloadFile | 下载文件
公共方法 | DownloadHtml | 下载HTML
 | EncryptDES |
公共方法 | Equals | (继承自 Object。)
 | FileDelete | 删除一个文件，System.IO.File.Delete()函数不可以删除只读文件，这个函数可以强行把只读文件删除。
 | FileToBase64 | 文件转换成Base64字符串
受保护的方法 | Finalize | (继承自 Object。)
 | FindTKlRandomModifier | 获取一个淘口令前后随机修饰符
 | FolderClear | 删除文件夹
 | GetCache | 缓存是否存在
 | GetDateTime | 时间戳转时间
 | GetFileMd5Code |
公共方法 | GetHashCode | (继承自 Object。)
 | GetImageByte(Bitmap) | 将图片Bitmap类型转成字节数组
 | GetImageByte(String) | 将图片转换为字节数组
 | GetMD5 | MD5字符串加密
 | GetMd5_32byte |
 | GetMD5Hash |
 | GetMimeType(Image) |
 | GetMimeType(String) |
 | GetMiNiAppXml | 获取小程序xml文本
 | GetRandomString | 生成指定位数的随机数
 | GetTimeSpan(DateTime) | 日期转换成时间戳Timestamp
 | GetTimeSpan(DateTime, Boolean) | 日期转换成时间戳Timestamp
公共方法 | GetType | (继承自 Object。)
 | GetUUID | 获取UUID
 | HexToStr |
 | imageToByteArray |
 | InternetSetOption | 设置IE
 | InvitationCode(Int64) | 10进制转换为62进制
 | InvitationCode(String) |
 | IsXML | 是否为XML
 | MapFile |
 | MapPath |
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | PercentImage | 将图片控制在宽度为指定得像素
 | ReadT | 读取配置文件
 | ReadConfig |
公共方法 | ReadFile | 读取数据
 | ReadFileToByte | 读文件到byte[]
 | ReadImageFile | 通过FileStream 来打开文件，这样就可以实现不锁定Image文件，到时可以让多用户同时访问Image文件
 | RemoveCache | 设置缓存(辅助输入)
 | RemoveEmoji |
 | ReturnPhoto |
 | RunCmd | 调用CMD执行命令
 | Save | 保存配置文件
 | SendEmail |
 | SetCache | 设置缓存(辅助输入)
 | ShowTgwz |
 | StrToHex |
 | SuppressWininetBehavior |
 | TimeDiffer |
 | ToDeserializeT |
 | ToGrey | 图像灰度化
 | ToSerializer |
公共方法 | ToString | (继承自 Object。)
 | WriteByteToFile | 写byte[]到fileName
 | YaSuo | 将图片按百分比压缩，
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.AddText2Image 方法

UtilAddText2Image 方法

给图片添加文字水印

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Image AddText2Image(
    Image img,
    string text,
    Point p,
    Font font,
    Color fontColor,
    int angle
)

参数

img
类型：System.DrawingImage
图片
text
类型：SystemString
文字
p
类型：System.DrawingPoint
文本位置中心点坐标
font
类型：System.DrawingFont
字体
fontColor
类型：System.DrawingColor
字体颜色
angle
类型：SystemInt32
旋转角度（顺时针）

返回值

类型：Image
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.AddWaterMark 方法

UtilAddWaterMark 方法

添加水印

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] AddWaterMark(
    byte[] data,
    string text
)

参数

data
类型：SystemByte

[缺少 "M:Api.Framework.Tools.Util.AddWaterMark(System.Byte[],System.String)" 的 <param name="data"/> 文档]

text
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.AddWaterMark(System.Byte[],System.String)" 的 <param name="text"/> 文档]

返回值

类型：Byte
resMsg[0] 成功,失败
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.AppConfig_AddItem 方法

UtilAppConfig_AddItem 方法

[缺少 "M:Api.Framework.Tools.Util.AppConfig_AddItem(System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void AppConfig_AddItem(
    string keyName,
    string keyValue
)

参数

keyName
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.AppConfig_AddItem(System.String,System.String)" 的 <param name="keyName"/> 文档]

keyValue
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.AppConfig_AddItem(System.String,System.String)" 的 <param name="keyValue"/> 文档]

参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.AppConfig_ExistItem 方法

UtilAppConfig_ExistItem 方法

[缺少 "M:Api.Framework.Tools.Util.AppConfig_ExistItem(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool AppConfig_ExistItem(
    string keyName
)

参数

keyName
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.AppConfig_ExistItem(System.String)" 的 <param name="keyName"/> 文档]

返回值

类型：Boolean
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.AppConfig_GetValue 方法

UtilAppConfig_GetValue 方法

[缺少 "M:Api.Framework.Tools.Util.AppConfig_GetValue(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string AppConfig_GetValue(
    string keyName
)

参数

keyName
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.AppConfig_GetValue(System.String)" 的 <param name="keyName"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.AppConfig_ModifyItem 方法

UtilAppConfig_ModifyItem 方法

[缺少 "M:Api.Framework.Tools.Util.AppConfig_ModifyItem(System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool AppConfig_ModifyItem(
    string keyName,
    string newKeyValue
)

参数

keyName
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.AppConfig_ModifyItem(System.String,System.String)" 的 <param name="keyName"/> 文档]

newKeyValue
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.AppConfig_ModifyItem(System.String,System.String)" 的 <param name="newKeyValue"/> 文档]

返回值

类型：Boolean
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.AppConfig_RemoveItem 方法

UtilAppConfig_RemoveItem 方法

[缺少 "M:Api.Framework.Tools.Util.AppConfig_RemoveItem(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void AppConfig_RemoveItem(
    string keyName
)

参数

keyName
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.AppConfig_RemoveItem(System.String)" 的 <param name="keyName"/> 文档]

参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.Base64ToFileAndSave 方法

UtilBase64ToFileAndSave 方法

Base64字符串转换成文件

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool Base64ToFileAndSave(
    string strInput,
    string fileName
)

参数

strInput
类型：SystemString
base64字符串
fileName
类型：SystemString
保存文件的绝对路径

返回值

类型：Boolean
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.BitmapToBytes 方法

UtilBitmapToBytes 方法

[缺少 "M:Api.Framework.Tools.Util.BitmapToBytes(System.Drawing.Bitmap)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] BitmapToBytes(
    Bitmap Bitmap
)

参数

Bitmap
类型：System.DrawingBitmap

[缺少 "M:Api.Framework.Tools.Util.BitmapToBytes(System.Drawing.Bitmap)" 的 <param name="Bitmap"/> 文档]

返回值

类型：Byte
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.byteArrayToImage 方法

UtilbyteArrayToImage 方法

[缺少 "M:Api.Framework.Tools.Util.byteArrayToImage(System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Image byteArrayToImage(
    byte[] byteArrayIn
)

参数

byteArrayIn
类型：SystemByte

[缺少 "M:Api.Framework.Tools.Util.byteArrayToImage(System.Byte[])" 的 <param name="byteArrayIn"/> 文档]

返回值

类型：Image
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.BytesToBitmap 方法

UtilBytesToBitmap 方法

[缺少 "M:Api.Framework.Tools.Util.BytesToBitmap(System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Bitmap BytesToBitmap(
    byte[] Bytes
)

参数

Bytes
类型：SystemByte

[缺少 "M:Api.Framework.Tools.Util.BytesToBitmap(System.Byte[])" 的 <param name="Bytes"/> 文档]

返回值

类型：Bitmap
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.CheckUrlDomain 方法

UtilCheckUrlDomain 方法

检测微信域名是否正常

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void CheckUrlDomain(
    string url,
    string noticeName = ""
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.CheckUrlDomain(System.String,System.String)" 的 <param name="url"/> 文档]

noticeName (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.CheckUrlDomain(System.String,System.String)" 的 <param name="noticeName"/> 文档]

参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.CleanAll 方法

UtilCleanAll 方法

[缺少 "M:Api.Framework.Tools.Util.CleanAll" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void CleanAll()
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.CleanCookie 方法

UtilCleanCookie 方法

删除Cookie文件 Win7+ 需要管理员权限

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void CleanCookie()
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.CleanHistory 方法

UtilCleanHistory 方法

删除历史记录 Win7+ 需要管理员权限

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void CleanHistory()
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.CleanTempFiles 方法

UtilCleanTempFiles 方法

删除临时文件 Win7+ 需要管理员权限

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void CleanTempFiles()
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ClearCookies 方法

UtilClearCookies 方法

[缺少 "M:Api.Framework.Tools.Util.ClearCookies" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void ClearCookies()
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ComposeArrays 方法

UtilComposeArrays 方法

[缺少 "M:Api.Framework.Tools.Util.ComposeArrays(System.Byte[],System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] ComposeArrays(
    byte[] Array1,
    byte[] Array2
)

参数

Array1
类型：SystemByte

[缺少 "M:Api.Framework.Tools.Util.ComposeArrays(System.Byte[],System.Byte[])" 的 <param name="Array1"/> 文档]

Array2
类型：SystemByte

[缺少 "M:Api.Framework.Tools.Util.ComposeArrays(System.Byte[],System.Byte[])" 的 <param name="Array2"/> 文档]

返回值

类型：Byte
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ConvertDouble_FenToYuan 方法

UtilConvertDouble_FenToYuan 方法

[缺少 "M:Api.Framework.Tools.Util.ConvertDouble_FenToYuan(System.Int32)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static double ConvertDouble_FenToYuan(
    int value
)

参数

value
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.Util.ConvertDouble_FenToYuan(System.Int32)" 的 <param name="value"/> 文档]

返回值

类型：Double
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ConvertEnum 方法

UtilConvertEnum 方法

重载列表
名称 | 说明
ConvertEnumT(Int32) |
ConvertEnumT(String) |
ConvertEnumT(UInt16) |
Top
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ConvertEnum(T) 方法 (Int32)

UtilConvertEnumT 方法 (Int32)

[缺少 "M:Api.Framework.Tools.Util.ConvertEnum``1(System.Int32)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T ConvertEnum<T>(
    int value
)

参数

value
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.Util.ConvertEnum``1(System.Int32)" 的 <param name="value"/> 文档]

类型参数

T

返回值

类型：T
参见

引用

Util 类
ConvertEnum 重载
Api.Framework.Tools 命名空间


Util.ConvertEnum(T) 方法 (String)

UtilConvertEnumT 方法 (String)

[缺少 "M:Api.Framework.Tools.Util.ConvertEnum``1(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T ConvertEnum<T>(
    string value
)

参数

value
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.ConvertEnum``1(System.String)" 的 <param name="value"/> 文档]

类型参数

T

返回值

类型：T
参见

引用

Util 类
ConvertEnum 重载
Api.Framework.Tools 命名空间


Util.ConvertEnum(T) 方法 (UInt16)

UtilConvertEnumT 方法 (UInt16)

[缺少 "M:Api.Framework.Tools.Util.ConvertEnum``1(System.UInt16)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T ConvertEnum<T>(
    ushort value
)

参数

value
类型：SystemUInt16

[缺少 "M:Api.Framework.Tools.Util.ConvertEnum``1(System.UInt16)" 的 <param name="value"/> 文档]

类型参数

T

返回值

类型：T
参见

引用

Util 类
ConvertEnum 重载
Api.Framework.Tools 命名空间


Util.CopyOldLabFilesToNewLab 方法

UtilCopyOldLabFilesToNewLab 方法

拷贝oldlab的文件到newlab下面

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool CopyOldLabFilesToNewLab(
    string sourcePath,
    string savePath
)

参数

sourcePath
类型：SystemString
lab文件所在目录(@"~\labs\oldlab")
savePath
类型：SystemString
保存的目标目录(@"~\labs\newlab")

返回值

类型：Boolean
返回:true-拷贝成功;false:拷贝失败
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.DecodeQRCode 方法

UtilDecodeQRCode 方法

重载列表
名称 | 说明
DecodeQRCode(Bitmap) | 解析二维码
DecodeQRCode(String, UtilDecodeQRCodeType) | 解密二维码
Top
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.DecodeQRCode 方法 (Bitmap)

UtilDecodeQRCode 方法 (Bitmap)

解析二维码

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string DecodeQRCode(
    Bitmap bitmap
)

参数

bitmap
类型：System.DrawingBitmap

[缺少 "M:Api.Framework.Tools.Util.DecodeQRCode(System.Drawing.Bitmap)" 的 <param name="bitmap"/> 文档]

返回值

类型：String
参见

引用

Util 类
DecodeQRCode 重载
Api.Framework.Tools 命名空间


Util.DecodeQRCode 方法 (String, Util.DecodeQRCodeType)

UtilDecodeQRCode 方法 (String, UtilDecodeQRCodeType)

解密二维码

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string DecodeQRCode(
    string filename,
    UtilDecodeQRCodeType type = UtilDecodeQRCodeType.Zxing
)

参数

filename
类型：SystemString
文件路径
type (Optional)
类型：Api.Framework.ToolsUtilDecodeQRCodeType

[缺少 "M:Api.Framework.Tools.Util.DecodeQRCode(System.String,Api.Framework.Tools.Util.DecodeQRCodeType)" 的 <param name="type"/> 文档]

返回值

类型：String
参见

引用

Util 类
DecodeQRCode 重载
Api.Framework.Tools 命名空间


Util.DecryptDES 方法

UtilDecryptDES 方法

[缺少 "M:Api.Framework.Tools.Util.DecryptDES(System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string DecryptDES(
    string decryptString,
    string decryptKey = "2#~1*oW0"
)

参数

decryptString
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.DecryptDES(System.String,System.String)" 的 <param name="decryptString"/> 文档]

decryptKey (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.DecryptDES(System.String,System.String)" 的 <param name="decryptKey"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.DownloadFile 方法

UtilDownloadFile 方法

下载文件

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void DownloadFile(
    string url,
    string filename,
    ProgressBar prog = null
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.DownloadFile(System.String,System.String,System.Windows.Forms.ProgressBar)" 的 <param name="url"/> 文档]

filename
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.DownloadFile(System.String,System.String,System.Windows.Forms.ProgressBar)" 的 <param name="filename"/> 文档]

prog (Optional)
类型：System.Windows.FormsProgressBar

[缺少 "M:Api.Framework.Tools.Util.DownloadFile(System.String,System.String,System.Windows.Forms.ProgressBar)" 的 <param name="prog"/> 文档]

参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.DownloadHtml 方法

UtilDownloadHtml 方法

下载HTML

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DownloadHtml(
    string url,
    string data = ""
)

参数

url
类型：SystemString
地址
data (Optional)
类型：SystemString
Post参数

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.EncryptDES 方法

UtilEncryptDES 方法

[缺少 "M:Api.Framework.Tools.Util.EncryptDES(System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string EncryptDES(
    string encryptString,
    string encryptKey = "2#~1*oW0"
)

参数

encryptString
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.EncryptDES(System.String,System.String)" 的 <param name="encryptString"/> 文档]

encryptKey (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.EncryptDES(System.String,System.String)" 的 <param name="encryptKey"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.FileDelete 方法

UtilFileDelete 方法

删除一个文件，System.IO.File.Delete()函数不可以删除只读文件，这个函数可以强行把只读文件删除。

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool FileDelete(
    string path
)

参数

path
类型：SystemString
文件路径

返回值

类型：Boolean
成功为true
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.FileToBase64 方法

UtilFileToBase64 方法

文件转换成Base64字符串

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string FileToBase64(
    string fileName
)

参数

fileName
类型：SystemString
文件绝对路径

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.FindTKlRandomModifier 方法

UtilFindTKlRandomModifier 方法

获取一个淘口令前后随机修饰符

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string FindTKlRandomModifier(
    string str,
    char separator = '|'
)

参数

str
类型：SystemString
要随机的修饰符
separator (Optional)
类型：SystemChar
分隔符,默认'|'

返回值

类型：String
返回随机的一个修饰符或传入的str值
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.FolderClear 方法

UtilFolderClear 方法

删除文件夹

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void FolderClear(
    string path
)

参数

path
类型：SystemString
文件夹路径
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetCache 方法

UtilGetCache 方法

缓存是否存在

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool GetCache(
    string text
)

参数

text
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.GetCache(System.String)" 的 <param name="text"/> 文档]

返回值

类型：Boolean
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetDateTime 方法

UtilGetDateTime 方法

时间戳转时间

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static DateTime GetDateTime(
    long timeSpan
)

参数

timeSpan
类型：SystemInt64

[缺少 "M:Api.Framework.Tools.Util.GetDateTime(System.Int64)" 的 <param name="timeSpan"/> 文档]

返回值

类型：DateTime
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetFileMd5Code 方法

UtilGetFileMd5Code 方法

[缺少 "M:Api.Framework.Tools.Util.GetFileMd5Code(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetFileMd5Code(
    string filePath
)

参数

filePath
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.GetFileMd5Code(System.String)" 的 <param name="filePath"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetImageByte 方法

UtilGetImageByte 方法

重载列表
名称 | 说明
GetImageByte(Bitmap) | 将图片Bitmap类型转成字节数组
GetImageByte(String) | 将图片转换为字节数组
Top
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetImageByte 方法 (Bitmap)

UtilGetImageByte 方法 (Bitmap)

将图片Bitmap类型转成字节数组

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] GetImageByte(
    Bitmap bmp
)

参数

bmp
类型：System.DrawingBitmap

[缺少 "M:Api.Framework.Tools.Util.GetImageByte(System.Drawing.Bitmap)" 的 <param name="bmp"/> 文档]

返回值

类型：Byte
参见

引用

Util 类
GetImageByte 重载
Api.Framework.Tools 命名空间


Util.GetImageByte 方法 (String)

UtilGetImageByte 方法 (String)

将图片转换为字节数组

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] GetImageByte(
    string imagePath
)

参数

imagePath
类型：SystemString
完整的图片路径

返回值

类型：Byte
参见

引用

Util 类
GetImageByte 重载
Api.Framework.Tools 命名空间


Util.GetMD5 方法

UtilGetMD5 方法

MD5字符串加密

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetMD5(
    string txt
)

参数

txt
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.GetMD5(System.String)" 的 <param name="txt"/> 文档]

返回值

类型：String
加密后字符串
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetMd5_32byte 方法

UtilGetMd5_32byte 方法

[缺少 "M:Api.Framework.Tools.Util.GetMd5_32byte(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetMd5_32byte(
    string str
)

参数

str
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.GetMd5_32byte(System.String)" 的 <param name="str"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetMD5Hash 方法

UtilGetMD5Hash 方法

[缺少 "M:Api.Framework.Tools.Util.GetMD5Hash(System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetMD5Hash(
    byte[] bytedata
)

参数

bytedata
类型：SystemByte

[缺少 "M:Api.Framework.Tools.Util.GetMD5Hash(System.Byte[])" 的 <param name="bytedata"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetMimeType 方法

UtilGetMimeType 方法

重载列表
名称 | 说明
GetMimeType(Image) |
GetMimeType(String) |
Top
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetMimeType 方法 (Image)

UtilGetMimeType 方法 (Image)

[缺少 "M:Api.Framework.Tools.Util.GetMimeType(System.Drawing.Image)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetMimeType(
    Image image
)

参数

image
类型：System.DrawingImage

[缺少 "M:Api.Framework.Tools.Util.GetMimeType(System.Drawing.Image)" 的 <param name="image"/> 文档]

返回值

类型：String
参见

引用

Util 类
GetMimeType 重载
Api.Framework.Tools 命名空间


Util.GetMimeType 方法 (String)

UtilGetMimeType 方法 (String)

[缺少 "M:Api.Framework.Tools.Util.GetMimeType(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetMimeType(
    string filename
)

参数

filename
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.GetMimeType(System.String)" 的 <param name="filename"/> 文档]

返回值

类型：String
参见

引用

Util 类
GetMimeType 重载
Api.Framework.Tools 命名空间


Util.GetMiNiAppXml 方法

UtilGetMiNiAppXml 方法

获取小程序xml文本

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetMiNiAppXml(
    Object data,
    ChatType chatType
)

参数

data
类型：SystemObject

[缺少 "M:Api.Framework.Tools.Util.GetMiNiAppXml(System.Object,Api.Framework.SDK.ChatType)" 的 <param name="data"/> 文档]

chatType
类型：Api.Framework.SDKChatType

[缺少 "M:Api.Framework.Tools.Util.GetMiNiAppXml(System.Object,Api.Framework.SDK.ChatType)" 的 <param name="chatType"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetRandomString 方法

UtilGetRandomString 方法

生成指定位数的随机数

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetRandomString(
    int iLength
)

参数

iLength
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.Util.GetRandomString(System.Int32)" 的 <param name="iLength"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetTimeSpan 方法

UtilGetTimeSpan 方法

重载列表
名称 | 说明
GetTimeSpan(DateTime) | 日期转换成时间戳Timestamp
GetTimeSpan(DateTime, Boolean) | 日期转换成时间戳Timestamp
Top
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.GetTimeSpan 方法 (DateTime)

UtilGetTimeSpan 方法 (DateTime)

日期转换成时间戳Timestamp

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static long GetTimeSpan(
    DateTime time
)

参数

time
类型：SystemDateTime

[缺少 "M:Api.Framework.Tools.Util.GetTimeSpan(System.DateTime)" 的 <param name="time"/> 文档]

返回值

类型：Int64
参见

引用

Util 类
GetTimeSpan 重载
Api.Framework.Tools 命名空间


Util.GetTimeSpan 方法 (DateTime, Boolean)

UtilGetTimeSpan 方法 (DateTime, Boolean)

日期转换成时间戳Timestamp

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static long GetTimeSpan(
    DateTime time,
    bool Milliseconds = false
)

参数

time
类型：SystemDateTime

[缺少 "M:Api.Framework.Tools.Util.GetTimeSpan(System.DateTime,System.Boolean)" 的 <param name="time"/> 文档]

Milliseconds (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Tools.Util.GetTimeSpan(System.DateTime,System.Boolean)" 的 <param name="Milliseconds"/> 文档]

返回值

类型：Int64
参见

引用

Util 类
GetTimeSpan 重载
Api.Framework.Tools 命名空间


Util.GetUUID 方法

UtilGetUUID 方法

获取UUID

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetUUID()

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.HexToStr 方法

UtilHexToStr 方法

[缺少 "M:Api.Framework.Tools.Util.HexToStr(System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string HexToStr(
    byte[] bytes
)

参数

bytes
类型：SystemByte

[缺少 "M:Api.Framework.Tools.Util.HexToStr(System.Byte[])" 的 <param name="bytes"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.imageToByteArray 方法

UtilimageToByteArray 方法

[缺少 "M:Api.Framework.Tools.Util.imageToByteArray(System.Drawing.Image)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] imageToByteArray(
    Image imageIn
)

参数

imageIn
类型：System.DrawingImage

[缺少 "M:Api.Framework.Tools.Util.imageToByteArray(System.Drawing.Image)" 的 <param name="imageIn"/> 文档]

返回值

类型：Byte
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.InternetSetOption 方法

UtilInternetSetOption 方法

设置IE

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool InternetSetOption(
    IntPtr hInternet,
    int dwOption,
    IntPtr lpBuffer,
    int lpdwBufferLength
)

参数

hInternet
类型：SystemIntPtr
hInternet
dwOption
类型：SystemInt32
dwOption
lpBuffer
类型：SystemIntPtr
lpBuffer
lpdwBufferLength
类型：SystemInt32
lpdwBufferLength

返回值

类型：Boolean
处理结果
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.InvitationCode 方法

UtilInvitationCode 方法

重载列表
名称 | 说明
InvitationCode(Int64) | 10进制转换为62进制
InvitationCode(String) |
Top
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.InvitationCode 方法 (Int64)

UtilInvitationCode 方法 (Int64)

10进制转换为62进制

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string InvitationCode(
    long id
)

参数

id
类型：SystemInt64

[缺少 "M:Api.Framework.Tools.Util.InvitationCode(System.Int64)" 的 <param name="id"/> 文档]

返回值

类型：String
参见

引用

Util 类
InvitationCode 重载
Api.Framework.Tools 命名空间


Util.InvitationCode 方法 (String)

UtilInvitationCode 方法 (String)

[缺少 "M:Api.Framework.Tools.Util.InvitationCode(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static long InvitationCode(
    string Num
)

参数

Num
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.InvitationCode(System.String)" 的 <param name="Num"/> 文档]

返回值

类型：Int64
参见

引用

Util 类
InvitationCode 重载
Api.Framework.Tools 命名空间


Util.IsXML 方法

UtilIsXML 方法

是否为XML

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool IsXML(
    string mess
)

参数

mess
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.IsXML(System.String)" 的 <param name="mess"/> 文档]

返回值

类型：Boolean
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.MapFile 方法

UtilMapFile 方法

[缺少 "M:Api.Framework.Tools.Util.MapFile(System.String,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string MapFile(
    string file,
    string path = ""
)

参数

file
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.MapFile(System.String,System.String)" 的 <param name="file"/> 文档]

path (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.MapFile(System.String,System.String)" 的 <param name="path"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.MapPath 方法

UtilMapPath 方法

[缺少 "M:Api.Framework.Tools.Util.MapPath(System.String,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string MapPath(
    string path = "",
    bool CreateDirectory = true
)

参数

path (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.MapPath(System.String,System.Boolean)" 的 <param name="path"/> 文档]

CreateDirectory (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Tools.Util.MapPath(System.String,System.Boolean)" 的 <param name="CreateDirectory"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.PercentImage 方法

UtilPercentImage 方法

将图片控制在宽度为指定得像素

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Bitmap PercentImage(
    Image srcImage,
    int size = 200
)

参数

srcImage
类型：System.DrawingImage

[缺少 "M:Api.Framework.Tools.Util.PercentImage(System.Drawing.Image,System.Int32)" 的 <param name="srcImage"/> 文档]

size (Optional)
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.Util.PercentImage(System.Drawing.Image,System.Int32)" 的 <param name="size"/> 文档]

返回值

类型：Bitmap
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.Read(T) 方法

UtilReadT 方法

读取配置文件

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T Read<T>(
    string name = ""
)

参数

name (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.Read``1(System.String)" 的 <param name="name"/> 文档]

类型参数

T

返回值

类型：T
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ReadConfig 方法

UtilReadConfig 方法

[缺少 "M:Api.Framework.Tools.Util.ReadConfig(System.String,System.Boolean)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, Object> ReadConfig(
    string name,
    bool refresh = false
)

参数

name
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.ReadConfig(System.String,System.Boolean)" 的 <param name="name"/> 文档]

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Tools.Util.ReadConfig(System.String,System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ReadFile 方法

UtilReadFile 方法

读取数据

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] ReadFile(
    string path
)

参数

path
类型：SystemString
文件路径

返回值

类型：Byte
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ReadFileToByte 方法

UtilReadFileToByte 方法

读文件到byte[]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] ReadFileToByte(
    string fileName
)

参数

fileName
类型：SystemString
硬盘文件路径

返回值

类型：Byte
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ReadImageFile 方法

UtilReadImageFile 方法

通过FileStream 来打开文件，这样就可以实现不锁定Image文件，到时可以让多用户同时访问Image文件

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Bitmap ReadImageFile(
    string path
)

参数

path
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.ReadImageFile(System.String)" 的 <param name="path"/> 文档]

返回值

类型：Bitmap
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.RemoveCache 方法

UtilRemoveCache 方法

设置缓存(辅助输入)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void RemoveCache(
    string text
)

参数

text
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.RemoveCache(System.String)" 的 <param name="text"/> 文档]

返回值

类型：
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.RemoveEmoji 方法

UtilRemoveEmoji 方法

[缺少 "M:Api.Framework.Tools.Util.RemoveEmoji(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string RemoveEmoji(
    string text
)

参数

text
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.RemoveEmoji(System.String)" 的 <param name="text"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ReturnPhoto 方法

UtilReturnPhoto 方法

[缺少 "M:Api.Framework.Tools.Util.ReturnPhoto(System.Byte[])" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Image ReturnPhoto(
    byte[] streamByte
)

参数

streamByte
类型：SystemByte

[缺少 "M:Api.Framework.Tools.Util.ReturnPhoto(System.Byte[])" 的 <param name="streamByte"/> 文档]

返回值

类型：Image
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.RunCmd 方法

UtilRunCmd 方法

调用CMD执行命令

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void RunCmd(
    string cmd
)

参数

cmd
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.RunCmd(System.String)" 的 <param name="cmd"/> 文档]

参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.Save 方法

UtilSave 方法

保存配置文件

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Save(
    Object obj,
    string name = ""
)

参数

obj
类型：SystemObject

[缺少 "M:Api.Framework.Tools.Util.Save(System.Object,System.String)" 的 <param name="obj"/> 文档]

name (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.Save(System.Object,System.String)" 的 <param name="name"/> 文档]

参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.SendEmail 方法

UtilSendEmail 方法

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SendEmail(
    string host,
    int port,
    string username,
    string userpass,
    bool ssl,
    string tousername,
    string title,
    string content,
    bool begin = false,
    string file = ""
)

参数

host
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="host"/> 文档]

port
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="port"/> 文档]

username
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="username"/> 文档]

userpass
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="userpass"/> 文档]

ssl
类型：SystemBoolean

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="ssl"/> 文档]

tousername
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="tousername"/> 文档]

title
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="title"/> 文档]

content
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="content"/> 文档]

begin (Optional)
类型：SystemBoolean

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="begin"/> 文档]

file (Optional)
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.SendEmail(System.String,System.Int32,System.String,System.String,System.Boolean,System.String,System.String,System.String,System.Boolean,System.String)" 的 <param name="file"/> 文档]

参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.SetCache 方法

UtilSetCache 方法

设置缓存(辅助输入)

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool SetCache(
    string text,
    int seconds = 60
)

参数

text
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.SetCache(System.String,System.Int32)" 的 <param name="text"/> 文档]

seconds (Optional)
类型：SystemInt32

[缺少 "M:Api.Framework.Tools.Util.SetCache(System.String,System.Int32)" 的 <param name="seconds"/> 文档]

返回值

类型：Boolean
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ShowTgwz 方法

UtilShowTgwz 方法

[缺少 "M:Api.Framework.Tools.Util.ShowTgwz" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool ShowTgwz()

返回值

类型：Boolean
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.StrToHex 方法

UtilStrToHex 方法

[缺少 "M:Api.Framework.Tools.Util.StrToHex(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] StrToHex(
    string hexString
)

参数

hexString
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.StrToHex(System.String)" 的 <param name="hexString"/> 文档]

返回值

类型：Byte
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.SuppressWininetBehavior 方法

UtilSuppressWininetBehavior 方法

[缺少 "M:Api.Framework.Tools.Util.SuppressWininetBehavior" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SuppressWininetBehavior()
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.TimeDiffer 方法

UtilTimeDiffer 方法

[缺少 "M:Api.Framework.Tools.Util.TimeDiffer(System.DateTime)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string TimeDiffer(
    DateTime time
)

参数

time
类型：SystemDateTime

[缺少 "M:Api.Framework.Tools.Util.TimeDiffer(System.DateTime)" 的 <param name="time"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ToDeserialize(T) 方法

UtilToDeserializeT 方法

[缺少 "M:Api.Framework.Tools.Util.ToDeserialize``1(System.String)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static T ToDeserialize<T>(
    string content
)

参数

content
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.ToDeserialize``1(System.String)" 的 <param name="content"/> 文档]

类型参数

T

返回值

类型：T
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ToGrey 方法

UtilToGrey 方法

图像灰度化

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Bitmap ToGrey(
    Image image
)

参数

image
类型：System.DrawingImage

[缺少 "M:Api.Framework.Tools.Util.ToGrey(System.Drawing.Image)" 的 <param name="image"/> 文档]

返回值

类型：Bitmap
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.ToSerializer 方法

UtilToSerializer 方法

[缺少 "M:Api.Framework.Tools.Util.ToSerializer(System.Object)" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string ToSerializer(
    Object entity
)

参数

entity
类型：SystemObject

[缺少 "M:Api.Framework.Tools.Util.ToSerializer(System.Object)" 的 <param name="entity"/> 文档]

返回值

类型：String
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.WriteByteToFile 方法

UtilWriteByteToFile 方法

写byte[]到fileName

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool WriteByteToFile(
    byte[] pReadByte,
    string fileName
)

参数

pReadByte
类型：SystemByte
byte[]
fileName
类型：SystemString
保存至硬盘路径

返回值

类型：Boolean
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.YaSuo 方法

UtilYaSuo 方法

将图片按百分比压缩，

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool YaSuo(
    Image iSource,
    string outPath,
    int flag = 80
)

参数

iSource
类型：System.DrawingImage

[缺少 "M:Api.Framework.Tools.Util.YaSuo(System.Drawing.Image,System.String,System.Int32)" 的 <param name="iSource"/> 文档]

outPath
类型：SystemString

[缺少 "M:Api.Framework.Tools.Util.YaSuo(System.Drawing.Image,System.String,System.Int32)" 的 <param name="outPath"/> 文档]

flag (Optional)
类型：SystemInt32
flag取值1到100，越小压缩比越大

返回值

类型：Boolean
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util 字段

Util 类型公开以下成员。

字段
名称 | 说明
_DecodePictureFile |
Top
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util._DecodePictureFile 字段

Util_DecodePictureFile 字段

[缺少 "F:Api.Framework.Tools.Util._DecodePictureFile" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Object _DecodePictureFile

字段值

类型：Object
参见

引用

Util 类
Api.Framework.Tools 命名空间


Util.DecodeQRCodeType 枚举

UtilDecodeQRCodeType 枚举

二维码解析类型

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum DecodeQRCodeType
成员
成员名称 | 值 | 说明
全部 | 0 |
Zxing | 1 |
ThoughtWorks | 2 |
Caoliao | 3 |
参见

引用

Api.Framework.Tools 命名空间


VariateReplace 类

变量替换
继承层次
SystemObject
Api.Framework.ToolsVariateReplace

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class VariateReplace

VariateReplace 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | VariateReplace | 初始化 VariateReplace 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | CommonReplace | 通用替换变量
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


VariateReplace 构造函数

初始化 VariateReplace 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public VariateReplace()
参见

引用

VariateReplace 类
Api.Framework.Tools 命名空间


VariateReplace 方法

VariateReplace 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CommonReplace | 通用替换变量
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

VariateReplace 类
Api.Framework.Tools 命名空间


VariateReplace.CommonReplace 方法

VariateReplaceCommonReplace 方法

通用替换变量

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string CommonReplace(
    string _mess,
    params Object[] objs
)

参数

_mess
类型：SystemString
替换的内容
objs
类型：SystemObject
与变量有关联的对象

返回值

类型：String
参见

引用

VariateReplace 类
Api.Framework.Tools 命名空间


WechatPay 类

商户支付类
继承层次
SystemObject
Api.Framework.ToolsWechatPay

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatPay

WechatPay 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatPay | 初始化 WechatPay 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Create(String, Object, String, Double) | 已过时。 商户创建
公共方法 | Create(String, Object, String, Double, Boolean) | 商户创建
公共方法 | Create(String, Object, String, Double, Boolean, Object) | 商户创建
公共方法 | Create(String, String, String, String, Double, String, String) | 商户创建
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | Upload | 商户数据上传
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


WechatPay 构造函数

初始化 WechatPay 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatPay()
参见

引用

WechatPay 类
Api.Framework.Tools 命名空间


WechatPay 方法

WechatPay 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Create(String, Object, String, Double) | 已过时。 商户创建
公共方法 | Create(String, Object, String, Double, Boolean) | 商户创建
公共方法 | Create(String, Object, String, Double, Boolean, Object) | 商户创建
公共方法 | Create(String, String, String, String, Double, String, String) | 商户创建
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | Upload | 商户数据上传
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatPay 类
Api.Framework.Tools 命名空间


WechatPay.Create 方法

WechatPayCreate 方法

重载列表
 | 名称 | 说明
公共方法 | Create(String, Object, String, Double) | 已过时。 商户创建
公共方法 | Create(String, Object, String, Double, Boolean) | 商户创建
公共方法 | Create(String, Object, String, Double, Boolean, Object) | 商户创建
公共方法 | Create(String, String, String, String, Double, String, String) | 商户创建
Top
参见

引用

WechatPay 类
Api.Framework.Tools 命名空间


WechatPay.Create 方法 (String, Object, String, Double)

WechatPayCreate 方法 (String, Object, String, Double)

注意：此 API 现在已过时。

商户创建

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
[ObsoleteAttribute("改方法已过时")]
public string Create(
    string url,
    Object remark,
    string describe,
    double money
)

参数

url
类型：SystemString
商户地址
remark
类型：SystemObject
备注
describe
类型：SystemString
描述
money
类型：SystemDouble
金额

返回值

类型：String
参见

引用

WechatPay 类
Create 重载
Api.Framework.Tools 命名空间


WechatPay.Create 方法 (String, Object, String, Double, Boolean)

WechatPayCreate 方法 (String, Object, String, Double, Boolean)

商户创建

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Create(
    string url,
    Object remark,
    string describe,
    double money,
    out bool ispaid
)

参数

url
类型：SystemString
商户地址
remark
类型：SystemObject
备注
describe
类型：SystemString
描述
money
类型：SystemDouble
金额
ispaid
类型：SystemBoolean
是否直接到账

返回值

类型：String
参见

引用

WechatPay 类
Create 重载
Api.Framework.Tools 命名空间


WechatPay.Create 方法 (String, Object, String, Double, Boolean, Object)

WechatPayCreate 方法 (String, Object, String, Double, Boolean, Object)

商户创建

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Create(
    string url,
    Object remark,
    string describe,
    double money,
    out bool ispaid,
    out Object appinfo
)

参数

url
类型：SystemString
商户地址
remark
类型：SystemObject
备注
describe
类型：SystemString
描述
money
类型：SystemDouble
金额
ispaid
类型：SystemBoolean
是否直接到账
appinfo
类型：SystemObject
小程序信息,微信可以用来发送小程序;不支持小程序返回null

返回值

类型：String
参见

引用

WechatPay 类
Create 重载
Api.Framework.Tools 命名空间


WechatPay.Create 方法 (String, String, String, String, Double, String, String)

WechatPayCreate 方法 (String, String, String, String, Double, String, String)

商户创建

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Create(
    string gzh_appid,
    string sh_appid,
    string gzh_appkey,
    string sh_appkey,
    double amount,
    string remark,
    string describe
)

参数

gzh_appid
类型：SystemString
公众号appid
sh_appid
类型：SystemString
商户appid
gzh_appkey
类型：SystemString
公众号appkey
sh_appkey
类型：SystemString
商户appkey
amount
类型：SystemDouble
金额
remark
类型：SystemString
备注
describe
类型：SystemString
描述

返回值

类型：String
参见

引用

WechatPay 类
Create 重载
Api.Framework.Tools 命名空间


WechatPay.Upload 方法

WechatPayUpload 方法

商户数据上传

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Upload(
    string url,
    string gzh_appid,
    string gzh_appsecret,
    string sh_appid,
    string sh_appsecret,
    byte[] sh_cerdata,
    string footer
)

参数

url
类型：SystemString

[缺少 "M:Api.Framework.Tools.WechatPay.Upload(System.String,System.String,System.String,System.String,System.String,System.Byte[],System.String)" 的 <param name="url"/> 文档]

gzh_appid
类型：SystemString

[缺少 "M:Api.Framework.Tools.WechatPay.Upload(System.String,System.String,System.String,System.String,System.String,System.Byte[],System.String)" 的 <param name="gzh_appid"/> 文档]

gzh_appsecret
类型：SystemString

[缺少 "M:Api.Framework.Tools.WechatPay.Upload(System.String,System.String,System.String,System.String,System.String,System.Byte[],System.String)" 的 <param name="gzh_appsecret"/> 文档]

sh_appid
类型：SystemString

[缺少 "M:Api.Framework.Tools.WechatPay.Upload(System.String,System.String,System.String,System.String,System.String,System.Byte[],System.String)" 的 <param name="sh_appid"/> 文档]

sh_appsecret
类型：SystemString

[缺少 "M:Api.Framework.Tools.WechatPay.Upload(System.String,System.String,System.String,System.String,System.String,System.Byte[],System.String)" 的 <param name="sh_appsecret"/> 文档]

sh_cerdata
类型：SystemByte

[缺少 "M:Api.Framework.Tools.WechatPay.Upload(System.String,System.String,System.String,System.String,System.String,System.Byte[],System.String)" 的 <param name="sh_cerdata"/> 文档]

footer
类型：SystemString

[缺少 "M:Api.Framework.Tools.WechatPay.Upload(System.String,System.String,System.String,System.String,System.String,System.Byte[],System.String)" 的 <param name="footer"/> 文档]

返回值

类型：String
参见

引用

WechatPay 类
Api.Framework.Tools 命名空间


WPHCpsUrl 类

转链后返回的数据解构
继承层次
SystemObject
Api.Framework.ToolsWPHCpsUrl

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WPHCpsUrl

WPHCpsUrl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WPHCpsUrl | 初始化 WPHCpsUrl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | result |
公共属性 | returnCode |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


WPHCpsUrl 构造函数

初始化 WPHCpsUrl 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WPHCpsUrl()
参见

引用

WPHCpsUrl 类
Api.Framework.Tools 命名空间


WPHCpsUrl 属性

WPHCpsUrl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | result |
公共属性 | returnCode |
Top
参见

引用

WPHCpsUrl 类
Api.Framework.Tools 命名空间


WPHCpsUrl.result 属性

WPHCpsUrlresult 属性

[缺少 "P:Api.Framework.Tools.WPHCpsUrl.result" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Result1 result { get; set; }

属性值

类型：Result1
参见

引用

WPHCpsUrl 类
Api.Framework.Tools 命名空间


WPHCpsUrl.returnCode 属性

WPHCpsUrlreturnCode 属性

[缺少 "P:Api.Framework.Tools.WPHCpsUrl.returnCode" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string returnCode { get; set; }

属性值

类型：String
参见

引用

WPHCpsUrl 类
Api.Framework.Tools 命名空间


WPHCpsUrl 方法

WPHCpsUrl 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WPHCpsUrl 类
Api.Framework.Tools 命名空间


WphGoodsInfo 类

[缺少 "T:Api.Framework.Tools.WphGoodsInfo" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsWphGoodsInfo

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WphGoodsInfo

WphGoodsInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WphGoodsInfo | 初始化 WphGoodsInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | result |
公共属性 | returnCode |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


WphGoodsInfo 构造函数

初始化 WphGoodsInfo 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WphGoodsInfo()
参见

引用

WphGoodsInfo 类
Api.Framework.Tools 命名空间


WphGoodsInfo 属性

WphGoodsInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | result |
公共属性 | returnCode |
Top
参见

引用

WphGoodsInfo 类
Api.Framework.Tools 命名空间


WphGoodsInfo.result 属性

WphGoodsInforesult 属性

[缺少 "P:Api.Framework.Tools.WphGoodsInfo.result" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<WphGoodsInfoResult> result { get; set; }

属性值

类型：List WphGoodsInfoResult
参见

引用

WphGoodsInfo 类
Api.Framework.Tools 命名空间


WphGoodsInfo.returnCode 属性

WphGoodsInforeturnCode 属性

[缺少 "P:Api.Framework.Tools.WphGoodsInfo.returnCode" 的 <summary> 文档]

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string returnCode { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfo 类
Api.Framework.Tools 命名空间


WphGoodsInfo 方法

WphGoodsInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WphGoodsInfo 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult 类

唯品会商品查询详情结果
继承层次
SystemObject
Api.Framework.ToolsWphGoodsInfoResult

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WphGoodsInfoResult

WphGoodsInfoResult 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WphGoodsInfoResult | 初始化 WphGoodsInfoResult 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | brandId | 商品所属档期（专场）id
公共属性 | brandLogoFull | 商品品牌logo全路径地址
公共属性 | brandName | 商品品牌名称
公共属性 | brandStoreSn | 商品品牌sn
公共属性 | cat1stId | 商品一级分类id
公共属性 | cat1stName | 商品一级分类名称
公共属性 | cat2ndId | 商品二级分类id
公共属性 | cat2ndName | 商品二级分类名称
公共属性 | categoryId | 商品三级分类id
公共属性 | categoryName | 商品三级分类
公共属性 | commentsInfo | 商品评价信息
公共属性 | commission | 佣金金额（元）
公共属性 | commissionRate | 佣金比例（%）
公共属性 | couponInfo | 红包信息
公共属性 | cpsInfo | cps推广信息：目前只返回小程序链接和通用追踪参数，其他链接请移步转链接口,1-通用推广参数(tra_from)，2-唯品会微信小程序链接
公共属性 | destUrl | 商品落地页
公共属性 | discount | 折扣:唯品价/市场价 保留两位小数字符串
公共属性 | exclusiveCoupon | 渠道专属红包：目前仅开放单品券，没有则返回空
公共属性 | goodsCarouselPictures | 商品轮播图：根据商品id查询时返回，商品列表不返回
公共属性 | goodsDesc | 商品描述,字段暂不输出
公共属性 | goodsDetailPictures | 商品详情图片：根据商品id查询商品信息时返回，商品列表不返回
公共属性 | goodsId | 商品id
公共属性 | goodsIdsWithSameSpu | 同spuId扩展商品id: 新版详情接口返回，其余接口不返回该字段
公共属性 | goodsMainPicture | 商品主图
公共属性 | goodsName | 商品名称
公共属性 | goodsThumbUrl | 商品缩略图
公共属性 | haiTao | 是否海淘商品标识：1是 0不是
公共属性 | joinedActivities | 商品参与活动信息:未参与活动集合为空
公共属性 | marketPrice | 市场价（元）
公共属性 | prepayInfo | 商品预付信息
公共属性 | saleStockStatus | 商品库存状态：1-已抢光，2-有库存，3-有机会,当列表查询库存或者查询商品详情时返回
公共属性 | schemeEndTime | 商品推广计划有效期预估截止时间：仅为预估时间，仅做参考；时间戳，单位：毫秒
公共属性 | schemeStartTime | 商品所属推广方案开始时间：时间戳，单位：毫秒
公共属性 | sellTimeFrom | 商品售卖开始时间,时间戳，单位毫秒
公共属性 | sellTimeTo | 商品售卖结束时间,时间戳, 单位毫秒
公共属性 | skuInfos | 对应sku信息
公共属性 | sourceType | 商品类型：0-自营，1-MP
公共属性 | spuId | 商品spuId
公共属性 | status | 商品状态：0-下架，1-上架
公共属性 | storeInfo | 店铺信息
公共属性 | storeServiceCapability | 商品所属店铺服务能力评价
公共属性 | vipPrice | 唯品价（元）
公共属性 | weight | 推广权重，用于确定推广该商品的优先级，权重值越大，优先级越高
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


WphGoodsInfoResult 构造函数

初始化 WphGoodsInfoResult 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WphGoodsInfoResult()
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult 属性

WphGoodsInfoResult 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | brandId | 商品所属档期（专场）id
公共属性 | brandLogoFull | 商品品牌logo全路径地址
公共属性 | brandName | 商品品牌名称
公共属性 | brandStoreSn | 商品品牌sn
公共属性 | cat1stId | 商品一级分类id
公共属性 | cat1stName | 商品一级分类名称
公共属性 | cat2ndId | 商品二级分类id
公共属性 | cat2ndName | 商品二级分类名称
公共属性 | categoryId | 商品三级分类id
公共属性 | categoryName | 商品三级分类
公共属性 | commentsInfo | 商品评价信息
公共属性 | commission | 佣金金额（元）
公共属性 | commissionRate | 佣金比例（%）
公共属性 | couponInfo | 红包信息
公共属性 | cpsInfo | cps推广信息：目前只返回小程序链接和通用追踪参数，其他链接请移步转链接口,1-通用推广参数(tra_from)，2-唯品会微信小程序链接
公共属性 | destUrl | 商品落地页
公共属性 | discount | 折扣:唯品价/市场价 保留两位小数字符串
公共属性 | exclusiveCoupon | 渠道专属红包：目前仅开放单品券，没有则返回空
公共属性 | goodsCarouselPictures | 商品轮播图：根据商品id查询时返回，商品列表不返回
公共属性 | goodsDesc | 商品描述,字段暂不输出
公共属性 | goodsDetailPictures | 商品详情图片：根据商品id查询商品信息时返回，商品列表不返回
公共属性 | goodsId | 商品id
公共属性 | goodsIdsWithSameSpu | 同spuId扩展商品id: 新版详情接口返回，其余接口不返回该字段
公共属性 | goodsMainPicture | 商品主图
公共属性 | goodsName | 商品名称
公共属性 | goodsThumbUrl | 商品缩略图
公共属性 | haiTao | 是否海淘商品标识：1是 0不是
公共属性 | joinedActivities | 商品参与活动信息:未参与活动集合为空
公共属性 | marketPrice | 市场价（元）
公共属性 | prepayInfo | 商品预付信息
公共属性 | saleStockStatus | 商品库存状态：1-已抢光，2-有库存，3-有机会,当列表查询库存或者查询商品详情时返回
公共属性 | schemeEndTime | 商品推广计划有效期预估截止时间：仅为预估时间，仅做参考；时间戳，单位：毫秒
公共属性 | schemeStartTime | 商品所属推广方案开始时间：时间戳，单位：毫秒
公共属性 | sellTimeFrom | 商品售卖开始时间,时间戳，单位毫秒
公共属性 | sellTimeTo | 商品售卖结束时间,时间戳, 单位毫秒
公共属性 | skuInfos | 对应sku信息
公共属性 | sourceType | 商品类型：0-自营，1-MP
公共属性 | spuId | 商品spuId
公共属性 | status | 商品状态：0-下架，1-上架
公共属性 | storeInfo | 店铺信息
公共属性 | storeServiceCapability | 商品所属店铺服务能力评价
公共属性 | vipPrice | 唯品价（元）
公共属性 | weight | 推广权重，用于确定推广该商品的优先级，权重值越大，优先级越高
Top
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.brandId 属性

WphGoodsInfoResultbrandId 属性

商品所属档期（专场）id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long brandId { get; set; }

属性值

类型：Int64
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.brandLogoFull 属性

WphGoodsInfoResultbrandLogoFull 属性

商品品牌logo全路径地址

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandLogoFull { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.brandName 属性

WphGoodsInfoResultbrandName 属性

商品品牌名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandName { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.brandStoreSn 属性

WphGoodsInfoResultbrandStoreSn 属性

商品品牌sn

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string brandStoreSn { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.cat1stId 属性

WphGoodsInfoResultcat1stId 属性

商品一级分类id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long cat1stId { get; set; }

属性值

类型：Int64
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.cat1stName 属性

WphGoodsInfoResultcat1stName 属性

商品一级分类名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cat1stName { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.cat2ndId 属性

WphGoodsInfoResultcat2ndId 属性

商品二级分类id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long cat2ndId { get; set; }

属性值

类型：Int64
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.cat2ndName 属性

WphGoodsInfoResultcat2ndName 属性

商品二级分类名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cat2ndName { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.categoryId 属性

WphGoodsInfoResultcategoryId 属性

商品三级分类id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long categoryId { get; set; }

属性值

类型：Int64
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.categoryName 属性

WphGoodsInfoResultcategoryName 属性

商品三级分类

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string categoryName { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.commentsInfo 属性

WphGoodsInfoResultcommentsInfo 属性

商品评价信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CommentsInfo commentsInfo { get; set; }

属性值

类型：CommentsInfo
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.commission 属性

WphGoodsInfoResultcommission 属性

佣金金额（元）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commission { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.commissionRate 属性

WphGoodsInfoResultcommissionRate 属性

佣金比例（%）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string commissionRate { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.couponInfo 属性

WphGoodsInfoResultcouponInfo 属性

红包信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CouponInfo1 couponInfo { get; set; }

属性值

类型：CouponInfo1
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.cpsInfo 属性

WphGoodsInfoResultcpsInfo 属性

cps推广信息：目前只返回小程序链接和通用追踪参数，其他链接请移步转链接口,1-通用推广参数(tra_from)，2-唯品会微信小程序链接

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<int, string> cpsInfo { get; set; }

属性值

类型：Dictionary Int32, String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.destUrl 属性

WphGoodsInfoResultdestUrl 属性

商品落地页

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string destUrl { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.discount 属性

WphGoodsInfoResultdiscount 属性

折扣:唯品价/市场价 保留两位小数字符串

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string discount { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.exclusiveCoupon 属性

WphGoodsInfoResultexclusiveCoupon 属性

渠道专属红包：目前仅开放单品券，没有则返回空

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExclusiveCoupon exclusiveCoupon { get; set; }

属性值

类型：ExclusiveCoupon
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.goodsCarouselPictures 属性

WphGoodsInfoResultgoodsCarouselPictures 属性

商品轮播图：根据商品id查询时返回，商品列表不返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> goodsCarouselPictures { get; set; }

属性值

类型：List String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.goodsDesc 属性

WphGoodsInfoResultgoodsDesc 属性

商品描述,字段暂不输出

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsDesc { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.goodsDetailPictures 属性

WphGoodsInfoResultgoodsDetailPictures 属性

商品详情图片：根据商品id查询商品信息时返回，商品列表不返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> goodsDetailPictures { get; set; }

属性值

类型：List String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.goodsId 属性

WphGoodsInfoResultgoodsId 属性

商品id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsId { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.goodsIdsWithSameSpu 属性

WphGoodsInfoResultgoodsIdsWithSameSpu 属性

同spuId扩展商品id: 新版详情接口返回，其余接口不返回该字段

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> goodsIdsWithSameSpu { get; set; }

属性值

类型：List String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.goodsMainPicture 属性

WphGoodsInfoResultgoodsMainPicture 属性

商品主图

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsMainPicture { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.goodsName 属性

WphGoodsInfoResultgoodsName 属性

商品名称

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsName { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.goodsThumbUrl 属性

WphGoodsInfoResultgoodsThumbUrl 属性

商品缩略图

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string goodsThumbUrl { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.haiTao 属性

WphGoodsInfoResulthaiTao 属性

是否海淘商品标识：1是 0不是

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int haiTao { get; set; }

属性值

类型：Int32
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.joinedActivities 属性

WphGoodsInfoResultjoinedActivities 属性

商品参与活动信息:未参与活动集合为空

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<JoinedActivities> joinedActivities { get; set; }

属性值

类型：List JoinedActivities
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.marketPrice 属性

WphGoodsInfoResultmarketPrice 属性

市场价（元）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string marketPrice { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.prepayInfo 属性

WphGoodsInfoResultprepayInfo 属性

商品预付信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PrepayInfo prepayInfo { get; set; }

属性值

类型：PrepayInfo
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.saleStockStatus 属性

WphGoodsInfoResultsaleStockStatus 属性

商品库存状态：1-已抢光，2-有库存，3-有机会,当列表查询库存或者查询商品详情时返回

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int saleStockStatus { get; set; }

属性值

类型：Int32
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.schemeEndTime 属性

WphGoodsInfoResultschemeEndTime 属性

商品推广计划有效期预估截止时间：仅为预估时间，仅做参考；时间戳，单位：毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long schemeEndTime { get; set; }

属性值

类型：Int64
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.schemeStartTime 属性

WphGoodsInfoResultschemeStartTime 属性

商品所属推广方案开始时间：时间戳，单位：毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long schemeStartTime { get; set; }

属性值

类型：Int64
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.sellTimeFrom 属性

WphGoodsInfoResultsellTimeFrom 属性

商品售卖开始时间,时间戳，单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long sellTimeFrom { get; set; }

属性值

类型：Int64
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.sellTimeTo 属性

WphGoodsInfoResultsellTimeTo 属性

商品售卖结束时间,时间戳, 单位毫秒

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long sellTimeTo { get; set; }

属性值

类型：Int64
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.skuInfos 属性

WphGoodsInfoResultskuInfos 属性

对应sku信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SkuInfos skuInfos { get; set; }

属性值

类型：SkuInfos
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.sourceType 属性

WphGoodsInfoResultsourceType 属性

商品类型：0-自营，1-MP

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int sourceType { get; set; }

属性值

类型：Int32
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.spuId 属性

WphGoodsInfoResultspuId 属性

商品spuId

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string spuId { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.status 属性

WphGoodsInfoResultstatus 属性

商品状态：0-下架，1-上架

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int status { get; set; }

属性值

类型：Int32
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.storeInfo 属性

WphGoodsInfoResultstoreInfo 属性

店铺信息

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public StoreInfo storeInfo { get; set; }

属性值

类型：StoreInfo
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.storeServiceCapability 属性

WphGoodsInfoResultstoreServiceCapability 属性

商品所属店铺服务能力评价

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public StoreServiceCapability storeServiceCapability { get; set; }

属性值

类型：StoreServiceCapability
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.vipPrice 属性

WphGoodsInfoResultvipPrice 属性

唯品价（元）

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string vipPrice { get; set; }

属性值

类型：String
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult.weight 属性

WphGoodsInfoResultweight 属性

推广权重，用于确定推广该商品的优先级，权重值越大，优先级越高

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int weight { get; set; }

属性值

类型：Int32
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WphGoodsInfoResult 方法

WphGoodsInfoResult 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WphGoodsInfoResult 类
Api.Framework.Tools 命名空间


WPHHelper 类

唯品会助手类
继承层次
SystemObject
Api.Framework.ToolsWPHHelper

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WPHHelper

WPHHelper 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WPHHelper | 初始化 WPHHelper 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetCpsUrl | 转链(根据商品id生成联盟链接) 参数参考:https://vop.vip.com/home#/api/method/detail/com.vip.adp.api.open.service.UnionUrlService-1.0.0/genByGoodsIdWithOauth
公共方法 | GetCpsUrl_Hide | 转链(根据唯品会链接生成联盟链接) 参数参考:https://vop.vip.com/home#/api/method/detail/com.vip.adp.api.open.service.UnionUrlService-1.0.0/genByVIPUrlWithOauth
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | GetWphGoodsID | 获取商品id
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


WPHHelper 构造函数

初始化 WPHHelper 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WPHHelper()
参见

引用

WPHHelper 类
Api.Framework.Tools 命名空间


WPHHelper 方法

WPHHelper 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetCpsUrl | 转链(根据商品id生成联盟链接) 参数参考:https://vop.vip.com/home#/api/method/detail/com.vip.adp.api.open.service.UnionUrlService-1.0.0/genByGoodsIdWithOauth
公共方法 | GetCpsUrl_Hide | 转链(根据唯品会链接生成联盟链接) 参数参考:https://vop.vip.com/home#/api/method/detail/com.vip.adp.api.open.service.UnionUrlService-1.0.0/genByVIPUrlWithOauth
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | GetWphGoodsID | 获取商品id
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WPHHelper 类
Api.Framework.Tools 命名空间


WPHHelper.GetCpsUrl 方法

WPHHelperGetCpsUrl 方法

转链(根据商品id生成联盟链接) 参数参考:https://vop.vip.com/home#/api/method/detail/com.vip.adp.api.open.service.UnionUrlService-1.0.0/genByGoodsIdWithOauth

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WPHCpsUrl GetCpsUrl(
    WeipinhuiApi api,
    Object data
)

参数

api
类型：Api.Framework.CpsWeipinhuiApi

[缺少 "M:Api.Framework.Tools.WPHHelper.GetCpsUrl(Api.Framework.Cps.WeipinhuiApi,System.Object)" 的 <param name="api"/> 文档]

data
类型：SystemObject
参数

返回值

类型：WPHCpsUrl
参见

引用

WPHHelper 类
Api.Framework.Tools 命名空间


WPHHelper.GetCpsUrl_Hide 方法

WPHHelperGetCpsUrl_Hide 方法

转链(根据唯品会链接生成联盟链接) 参数参考:https://vop.vip.com/home#/api/method/detail/com.vip.adp.api.open.service.UnionUrlService-1.0.0/genByVIPUrlWithOauth

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WPHCpsUrl GetCpsUrl_Hide(
    WeipinhuiApi api,
    Object data
)

参数

api
类型：Api.Framework.CpsWeipinhuiApi

[缺少 "M:Api.Framework.Tools.WPHHelper.GetCpsUrl_Hide(Api.Framework.Cps.WeipinhuiApi,System.Object)" 的 <param name="api"/> 文档]

data
类型：SystemObject
参数

返回值

类型：WPHCpsUrl
参见

引用

WPHHelper 类
Api.Framework.Tools 命名空间


WPHHelper.GetWphGoodsID 方法

WPHHelperGetWphGoodsID 方法

获取商品id

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetWphGoodsID(
    string mess
)

参数

mess
类型：SystemString
内容

返回值

类型：String
参见

引用

WPHHelper 类
Api.Framework.Tools 命名空间


ZipHelper 类

[缺少 "T:Api.Framework.Tools.ZipHelper" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.ToolsZipHelper

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ZipHelper

ZipHelper 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ZipHelper | 初始化 ZipHelper 类的一个新实例
Top
方法
 | 名称 | 说明
 | Compress | GZip压缩
 | Decompress | ZIP解压
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDatasetByString | 解压
公共方法 | GetHashCode | (继承自 Object。)
 | GetStringByDataset | 根据DATASET压缩字符串
公共方法 | GetType | (继承自 Object。)
 | GZipCompressString | 将传入字符串以GZip算法压缩后，返回Base64编码字符
 | GZipDecompressString | 将传入的二进制字符串资料以GZip算法解压缩
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Tools 命名空间


ZipHelper 构造函数

初始化 ZipHelper 类的一个新实例

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ZipHelper()
参见

引用

ZipHelper 类
Api.Framework.Tools 命名空间


ZipHelper 方法

ZipHelper 类型公开以下成员。

方法
 | 名称 | 说明
 | Compress | GZip压缩
 | Decompress | ZIP解压
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDatasetByString | 解压
公共方法 | GetHashCode | (继承自 Object。)
 | GetStringByDataset | 根据DATASET压缩字符串
公共方法 | GetType | (继承自 Object。)
 | GZipCompressString | 将传入字符串以GZip算法压缩后，返回Base64编码字符
 | GZipDecompressString | 将传入的二进制字符串资料以GZip算法解压缩
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ZipHelper 类
Api.Framework.Tools 命名空间


ZipHelper.Compress 方法

ZipHelperCompress 方法

GZip压缩

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] Compress(
    byte[] rawData
)

参数

rawData
类型：SystemByte

[缺少 "M:Api.Framework.Tools.ZipHelper.Compress(System.Byte[])" 的 <param name="rawData"/> 文档]

返回值

类型：Byte
参见

引用

ZipHelper 类
Api.Framework.Tools 命名空间


ZipHelper.Decompress 方法

ZipHelperDecompress 方法

ZIP解压

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static byte[] Decompress(
    byte[] zippedData
)

参数

zippedData
类型：SystemByte

[缺少 "M:Api.Framework.Tools.ZipHelper.Decompress(System.Byte[])" 的 <param name="zippedData"/> 文档]

返回值

类型：Byte
参见

引用

ZipHelper 类
Api.Framework.Tools 命名空间


ZipHelper.GetDatasetByString 方法

ZipHelperGetDatasetByString 方法

解压

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static DataSet GetDatasetByString(
    string Value
)

参数

Value
类型：SystemString

[缺少 "M:Api.Framework.Tools.ZipHelper.GetDatasetByString(System.String)" 的 <param name="Value"/> 文档]

返回值

类型：DataSet
参见

引用

ZipHelper 类
Api.Framework.Tools 命名空间


ZipHelper.GetStringByDataset 方法

ZipHelperGetStringByDataset 方法

根据DATASET压缩字符串

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetStringByDataset(
    string ds
)

参数

ds
类型：SystemString

[缺少 "M:Api.Framework.Tools.ZipHelper.GetStringByDataset(System.String)" 的 <param name="ds"/> 文档]

返回值

类型：String
参见

引用

ZipHelper 类
Api.Framework.Tools 命名空间


ZipHelper.GZipCompressString 方法

ZipHelperGZipCompressString 方法

将传入字符串以GZip算法压缩后，返回Base64编码字符

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GZipCompressString(
    string rawString
)

参数

rawString
类型：SystemString
需要压缩的字符串

返回值

类型：String
压缩后的Base64编码的字符串
参见

引用

ZipHelper 类
Api.Framework.Tools 命名空间


ZipHelper.GZipDecompressString 方法

ZipHelperGZipDecompressString 方法

将传入的二进制字符串资料以GZip算法解压缩

命名空间： Api.Framework.Tools
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GZipDecompressString(
    string zippedString
)

参数

zippedString
类型：SystemString
经GZip压缩后的二进制字符串

返回值

类型：String
原始未压缩字符串
参见

引用

ZipHelper 类
Api.Framework.Tools 命名空间


Api.Framework.UIForm 命名空间

[缺少 "N:Api.Framework.UIForm" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | SetConnectionConfig | 选择数据库


SetConnectionConfig 类

选择数据库
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
Api.Framework.UIFormSetConnectionConfig

命名空间： Api.Framework.UIForm
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SetConnectionConfig : BaseForm

SetConnectionConfig 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SetConnectionConfig | 初始化 SetConnectionConfig 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | IsOk |
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.UIForm 命名空间


SetConnectionConfig 构造函数

初始化 SetConnectionConfig 类的一个新实例

命名空间： Api.Framework.UIForm
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SetConnectionConfig()
参见

引用

SetConnectionConfig 类
Api.Framework.UIForm 命名空间


SetConnectionConfig 属性

SetConnectionConfig 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | IsOk |
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

SetConnectionConfig 类
Api.Framework.UIForm 命名空间


SetConnectionConfig.IsOk 属性

SetConnectionConfigIsOk 属性

[缺少 "P:Api.Framework.UIForm.SetConnectionConfig.IsOk" 的 <summary> 文档]

命名空间： Api.Framework.UIForm
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsOk { get; set; }

属性值

类型：Boolean
参见

引用

SetConnectionConfig 类
Api.Framework.UIForm 命名空间


SetConnectionConfig 方法

SetConnectionConfig 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SetConnectionConfig 类
Api.Framework.UIForm 命名空间


SetConnectionConfig.Dispose 方法

SetConnectionConfigDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
Top
参见

引用

SetConnectionConfig 类
Api.Framework.UIForm 命名空间


SetConnectionConfig.Dispose 方法 (Boolean)

SetConnectionConfigDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Api.Framework.UIForm
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

SetConnectionConfig 类
Dispose 重载
Api.Framework.UIForm 命名空间


SetConnectionConfig 事件

SetConnectionConfig 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

SetConnectionConfig 类
Api.Framework.UIForm 命名空间


SetConnectionConfig 字段

SetConnectionConfig 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
参见

引用

SetConnectionConfig 类
Api.Framework.UIForm 命名空间


Api.Framework.Utils 命名空间

[缺少 "N:Api.Framework.Utils" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | TaskExtend |
公共类 | TaskTool |


TaskExtend 类

[缺少 "T:Api.Framework.Utils.TaskExtend" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.UtilsTaskExtend

命名空间： Api.Framework.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class TaskExtend

TaskExtend 类型公开以下成员。

方法
名称 | 说明
Sleep | 不卡界面休眠
Top
参见

引用

Api.Framework.Utils 命名空间


TaskExtend 方法

TaskExtend 类型公开以下成员。

方法
名称 | 说明
Sleep | 不卡界面休眠
Top
参见

引用

TaskExtend 类
Api.Framework.Utils 命名空间


TaskExtend.Sleep 方法

TaskExtendSleep 方法

不卡界面休眠

命名空间： Api.Framework.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Sleep(
    this Object obj,
    int millisecondsTimeout
)

参数

obj
类型：SystemObject
源
millisecondsTimeout
类型：SystemInt32
毫秒

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 Object 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

TaskExtend 类
Api.Framework.Utils 命名空间


TaskTool 类

[缺少 "T:Api.Framework.Utils.TaskTool" 的 <summary> 文档]

继承层次
SystemObject
Api.Framework.UtilsTaskTool

命名空间： Api.Framework.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class TaskTool

TaskTool 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TaskTool | 创建线程池
Top
属性
 | 名称 | 说明
公共属性 | Tasks | 任务管理器
Top
方法
 | 名称 | 说明
公共方法 | AddTask | 增加任务
公共方法 | Clear |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Start | 执行线程池内所有线程
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Api.Framework.Utils 命名空间


TaskTool 构造函数

创建线程池

命名空间： Api.Framework.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public TaskTool()
参见

引用

TaskTool 类
Api.Framework.Utils 命名空间


TaskTool 属性

TaskTool 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Tasks | 任务管理器
Top
参见

引用

TaskTool 类
Api.Framework.Utils 命名空间


TaskTool.Tasks 属性

TaskToolTasks 属性

任务管理器

命名空间： Api.Framework.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<Task> Tasks { get; }

属性值

类型：List Task
参见

引用

TaskTool 类
Api.Framework.Utils 命名空间


TaskTool 方法

TaskTool 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddTask | 增加任务
公共方法 | Clear |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Start | 执行线程池内所有线程
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

TaskTool 类
Api.Framework.Utils 命名空间


TaskTool.AddTask 方法

TaskToolAddTask 方法

增加任务

命名空间： Api.Framework.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void AddTask(
    Action method
)

参数

method
类型：SystemAction

[缺少 "M:Api.Framework.Utils.TaskTool.AddTask(System.Action)" 的 <param name="method"/> 文档]

参见

引用

TaskTool 类
Api.Framework.Utils 命名空间


TaskTool.Clear 方法

TaskToolClear 方法

[缺少 "M:Api.Framework.Utils.TaskTool.Clear" 的 <summary> 文档]

命名空间： Api.Framework.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Clear()
参见

引用

TaskTool 类
Api.Framework.Utils 命名空间


TaskTool.Start 方法

TaskToolStart 方法

执行线程池内所有线程

命名空间： Api.Framework.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Start(
    int max_sync,
    AsyncCallback callback
)

参数

max_sync
类型：SystemInt32
最大并行线程数量
callback
类型：SystemAsyncCallback
执行完成后通知
参见

引用

TaskTool 类
Api.Framework.Utils 命名空间


Chat.Framework 命名空间

[缺少 "N:Chat.Framework" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | ChatClient | 机器人综合管理类
公共类 | ChatEvent | 事件基础类
公共类 | FileTools |
委托
 | 委托 | 说明
公共委托 | ChatClientFindLicenseData |
公共委托 | ChatClientGetServerData |


ChatClient 类

机器人综合管理类
继承层次
SystemObject
Chat.FrameworkChatClient

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ChatClient

ChatClient 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ChatClient | 初始化 ChatClient 类的一个新实例
Top
属性
名称 | 说明
Events | 微信事件管理
MessFrequentSleepTime | 消息频繁休眠时间
PCRobotPool | hook(易转发)
QQClients | 机器人QQ基础字典
QQEvents | QQ事件管理
SocketPassword | Hook通讯秘钥
WXClient | 机器人微信基类集合,已经登录微信机器人集合
WXSdkConfig |
Top
方法
 | 名称 | 说明
 | BindLicenseData |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | LoginOutQQ | 退出QQ
 | LoginOutWeixin(String) | hook协议退出微信
 | LoginOutWeixin(String, String) | hook协议退出调用此方法,附带提示语信息
 | LoginQQ | QQ登录
 | LoginWeixin(String, String) | 协议微信登录
 | LoginWeixin(String, String, String, String) | 协议微信登录
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | SetWeixinCore |
公共方法 | ToString | (继承自 Object。)
Top
字段
名称 | 说明
GetDBWechatFriend | 查询数据中的用户信息
GetServerDataMethod |
ImageCDNs | 图片CDN缓存
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework 命名空间


ChatClient 构造函数

初始化 ChatClient 类的一个新实例

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChatClient()
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient 属性

ChatClient 类型公开以下成员。

属性
名称 | 说明
Events | 微信事件管理
MessFrequentSleepTime | 消息频繁休眠时间
PCRobotPool | hook(易转发)
QQClients | 机器人QQ基础字典
QQEvents | QQ事件管理
SocketPassword | Hook通讯秘钥
WXClient | 机器人微信基类集合,已经登录微信机器人集合
WXSdkConfig |
Top
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.Events 属性

ChatClientEvents 属性

微信事件管理

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static EventManage Events { get; }

属性值

类型：EventManage
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.MessFrequentSleepTime 属性

ChatClientMessFrequentSleepTime 属性

消息频繁休眠时间

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static int MessFrequentSleepTime { get; set; }

属性值

类型：Int32
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.PCRobotPool 属性

ChatClientPCRobotPool 属性

hook(易转发)

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static PCRobotPool PCRobotPool { get; }

属性值

类型：PCRobotPool
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.QQClients 属性

ChatClientQQClients 属性

机器人QQ基础字典

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, QQBase> QQClients { get; }

属性值

类型：Dictionary String, QQBase
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.QQEvents 属性

ChatClientQQEvents 属性

QQ事件管理

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static QQEventManage QQEvents { get; }

属性值

类型：QQEventManage
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.SocketPassword 属性

ChatClientSocketPassword 属性

Hook通讯秘钥

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string SocketPassword { get; set; }

属性值

类型：String
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.WXClient 属性

ChatClientWXClient 属性

机器人微信基类集合,已经登录微信机器人集合

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, WeixinBase> WXClient { get; }

属性值

类型：Dictionary String, WeixinBase
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.WXSdkConfig 属性

ChatClientWXSdkConfig 属性

[缺少 "P:Chat.Framework.ChatClient.WXSdkConfig" 的 <summary> 文档]

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static WXSdkConfig WXSdkConfig { get; }

属性值

类型：WXSdkConfig
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient 方法

ChatClient 类型公开以下成员。

方法
 | 名称 | 说明
 | BindLicenseData |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | LoginOutQQ | 退出QQ
 | LoginOutWeixin(String) | hook协议退出微信
 | LoginOutWeixin(String, String) | hook协议退出调用此方法,附带提示语信息
 | LoginQQ | QQ登录
 | LoginWeixin(String, String) | 协议微信登录
 | LoginWeixin(String, String, String, String) | 协议微信登录
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | SetWeixinCore |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.BindLicenseData 方法

ChatClientBindLicenseData 方法

[缺少 "M:Chat.Framework.ChatClient.BindLicenseData(Chat.Framework.ChatClient.FindLicenseData)" 的 <summary> 文档]

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void BindLicenseData(
    ChatClientFindLicenseData action
)

参数

action
类型：Chat.FrameworkChatClientFindLicenseData

[缺少 "M:Chat.Framework.ChatClient.BindLicenseData(Chat.Framework.ChatClient.FindLicenseData)" 的 <param name="action"/> 文档]

参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.LoginOutQQ 方法

ChatClientLoginOutQQ 方法

退出QQ

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void LoginOutQQ(
    string qq
)

参数

qq
类型：SystemString
QQ
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.LoginOutWeixin 方法

ChatClientLoginOutWeixin 方法

重载列表
名称 | 说明
LoginOutWeixin(String) | hook协议退出微信
LoginOutWeixin(String, String) | hook协议退出调用此方法,附带提示语信息
Top
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.LoginOutWeixin 方法 (String)

ChatClientLoginOutWeixin 方法 (String)

hook协议退出微信

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void LoginOutWeixin(
    string wei_xin_hao
)

参数

wei_xin_hao
类型：SystemString
要退出的微信号
参见

引用

ChatClient 类
LoginOutWeixin 重载
Chat.Framework 命名空间


ChatClient.LoginOutWeixin 方法 (String, String)

ChatClientLoginOutWeixin 方法 (String, String)

hook协议退出调用此方法,附带提示语信息

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void LoginOutWeixin(
    string wei_xin_hao,
    string message
)

参数

wei_xin_hao
类型：SystemString
要退出的微信号
message
类型：SystemString
附带退出原因(弹窗)
参见

引用

ChatClient 类
LoginOutWeixin 重载
Chat.Framework 命名空间


ChatClient.LoginQQ 方法

ChatClientLoginQQ 方法

QQ登录

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool LoginQQ(
    string qqStr = "",
    string pass = "",
    bool isEQQ = false
)

参数

qqStr (Optional)
类型：SystemString
QQ账号
pass (Optional)
类型：SystemString
QQ密码
isEQQ (Optional)
类型：SystemBoolean
是否企业QQ

返回值

类型：Boolean
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.LoginWeixin 方法

ChatClientLoginWeixin 方法

重载列表
名称 | 说明
LoginWeixin(String, String) | 协议微信登录
LoginWeixin(String, String, String, String) | 协议微信登录
Top
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.LoginWeixin 方法 (String, String)

ChatClientLoginWeixin 方法 (String, String)

协议微信登录

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool LoginWeixin(
    string wei_xin_hao = "",
    string data = ""
)

参数

wei_xin_hao (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.ChatClient.LoginWeixin(System.String,System.String)" 的 <param name="wei_xin_hao"/> 文档]

data (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.ChatClient.LoginWeixin(System.String,System.String)" 的 <param name="data"/> 文档]

返回值

类型：Boolean
参见

引用

ChatClient 类
LoginWeixin 重载
Chat.Framework 命名空间


ChatClient.LoginWeixin 方法 (String, String, String, String)

ChatClientLoginWeixin 方法 (String, String, String, String)

协议微信登录

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string LoginWeixin(
    string weixinhao,
    string username,
    string userpass,
    string data62
)

参数

weixinhao
类型：SystemString

[缺少 "M:Chat.Framework.ChatClient.LoginWeixin(System.String,System.String,System.String,System.String)" 的 <param name="weixinhao"/> 文档]

username
类型：SystemString

[缺少 "M:Chat.Framework.ChatClient.LoginWeixin(System.String,System.String,System.String,System.String)" 的 <param name="username"/> 文档]

userpass
类型：SystemString

[缺少 "M:Chat.Framework.ChatClient.LoginWeixin(System.String,System.String,System.String,System.String)" 的 <param name="userpass"/> 文档]

data62
类型：SystemString

[缺少 "M:Chat.Framework.ChatClient.LoginWeixin(System.String,System.String,System.String,System.String)" 的 <param name="data62"/> 文档]

返回值

类型：String
参见

引用

ChatClient 类
LoginWeixin 重载
Chat.Framework 命名空间


ChatClient.SetWeixinCore 方法

ChatClientSetWeixinCore 方法

[缺少 "M:Chat.Framework.ChatClient.SetWeixinCore(System.String[],System.String[])" 的 <summary> 文档]

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SetWeixinCore(
    string[] grpc,
    string[] auth
)

参数

grpc
类型：SystemString

[缺少 "M:Chat.Framework.ChatClient.SetWeixinCore(System.String[],System.String[])" 的 <param name="grpc"/> 文档]

auth
类型：SystemString

[缺少 "M:Chat.Framework.ChatClient.SetWeixinCore(System.String[],System.String[])" 的 <param name="auth"/> 文档]

参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient 字段

ChatClient 类型公开以下成员。

字段
名称 | 说明
GetDBWechatFriend | 查询数据中的用户信息
GetServerDataMethod |
ImageCDNs | 图片CDN缓存
Top
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.GetDBWechatFriend 字段

ChatClientGetDBWechatFriend 字段

查询数据中的用户信息

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Func<string, Friend> GetDBWechatFriend

字段值

类型：Func String, Friend
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.GetServerDataMethod 字段

ChatClientGetServerDataMethod 字段

[缺少 "F:Chat.Framework.ChatClient.GetServerDataMethod" 的 <summary> 文档]

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ChatClientGetServerData GetServerDataMethod

字段值

类型：ChatClientGetServerData
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.ImageCDNs 字段

ChatClientImageCDNs 字段

图片CDN缓存

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Dictionary<string, Object> ImageCDNs

字段值

类型：Dictionary String, Object
参见

引用

ChatClient 类
Chat.Framework 命名空间


ChatClient.FindLicenseData 委托

ChatClientFindLicenseData 委托

[缺少 "T:Chat.Framework.ChatClient.FindLicenseData" 的 <summary> 文档]

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public delegate byte[] FindLicenseData(
    string method,
    string data,
    string api
)

参数

method
类型：SystemString
data
类型：SystemString
api
类型：SystemString

返回值

类型：Byte
参见

引用

Chat.Framework 命名空间


ChatClient.GetServerData 委托

ChatClientGetServerData 委托

[缺少 "T:Chat.Framework.ChatClient.GetServerData" 的 <summary> 文档]

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public delegate string GetServerData(
    string key
)

参数

key
类型：SystemString

返回值

类型：String
参见

引用

Chat.Framework 命名空间


ChatEvent 类

事件基础类
继承层次
SystemObject
Chat.FrameworkChatEvent
更多...

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ChatEvent

ChatEvent 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ChatEvent | 初始化 ChatEvent 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递
公共属性 | CrtTime | 创建时间
公共属性 | IsToString |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework 命名空间
继承层次
SystemObject
Chat.FrameworkChatEvent
Api.Framework.EventsDebugEvent
Chat.Framework.PCRobotSDK.WechatEventsWechatApplyFriendEvents
Chat.Framework.PCRobotSDK.WechatEventsWechatContactListEvents
Chat.Framework.PCRobotSDK.WechatEventsWechatGroupMemberEvents
Chat.Framework.PCRobotSDK.WechatEventsWechatNewMemerEvents
Chat.Framework.PCRobotSDK.WechatEventsWechatReceiveMsgEvents
Chat.Framework.PCRobotSDK.WechatEventsWechatReicevePayEvents
Chat.Framework.PCRobotSDK.WechatEventsWechatStatusEvents
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatApplyFriendEvents
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatContactListEvents
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatGroupMemberEvents
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatNewMemerEvents
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatReceiveMsgEvents
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatReicevePayEvents
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.WXSdk.EventsWXEvent


ChatEvent 构造函数

初始化 ChatEvent 类的一个新实例

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ChatEvent()
参见

引用

ChatEvent 类
Chat.Framework 命名空间


ChatEvent 属性

ChatEvent 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递
公共属性 | CrtTime | 创建时间
公共属性 | IsToString |
Top
参见

引用

ChatEvent 类
Chat.Framework 命名空间


ChatEvent.Cancel 属性

ChatEventCancel 属性

是否取消传递

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Cancel { get; set; }

属性值

类型：Boolean
参见

引用

ChatEvent 类
Chat.Framework 命名空间


ChatEvent.CrtTime 属性

ChatEventCrtTime 属性

创建时间

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime CrtTime { get; }

属性值

类型：DateTime
参见

引用

ChatEvent 类
Chat.Framework 命名空间


ChatEvent.IsToString 属性

ChatEventIsToString 属性

[缺少 "P:Chat.Framework.ChatEvent.IsToString" 的 <summary> 文档]

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsToString { get; set; }

属性值

类型：Boolean
参见

引用

ChatEvent 类
Chat.Framework 命名空间


ChatEvent 方法

ChatEvent 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ChatEvent 类
Chat.Framework 命名空间


FileTools 类

[缺少 "T:Chat.Framework.FileTools" 的 <summary> 文档]

继承层次
SystemObject
Chat.FrameworkFileTools

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class FileTools

FileTools 类型公开以下成员。

方法
名称 | 说明
DownloadImage | 图片下载
GetCacheObj | 缓存是否存在
GetMD5Hash | 文件MD5校验
SetCacheObj | 设置缓存
Top
参见

引用

Chat.Framework 命名空间


FileTools 方法

FileTools 类型公开以下成员。

方法
名称 | 说明
DownloadImage | 图片下载
GetCacheObj | 缓存是否存在
GetMD5Hash | 文件MD5校验
SetCacheObj | 设置缓存
Top
参见

引用

FileTools 类
Chat.Framework 命名空间


FileTools.DownloadImage 方法

FileToolsDownloadImage 方法

图片下载

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Image DownloadImage(
    string url,
    string path
)

参数

url
类型：SystemString

[缺少 "M:Chat.Framework.FileTools.DownloadImage(System.String,System.String)" 的 <param name="url"/> 文档]

path
类型：SystemString

[缺少 "M:Chat.Framework.FileTools.DownloadImage(System.String,System.String)" 的 <param name="path"/> 文档]

返回值

类型：Image
参见

引用

FileTools 类
Chat.Framework 命名空间


FileTools.GetCacheObj 方法

FileToolsGetCacheObj 方法

缓存是否存在

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Object GetCacheObj(
    string k
)

参数

k
类型：SystemString

[缺少 "M:Chat.Framework.FileTools.GetCacheObj(System.String)" 的 <param name="k"/> 文档]

返回值

类型：Object
参见

引用

FileTools 类
Chat.Framework 命名空间


FileTools.GetMD5Hash 方法

FileToolsGetMD5Hash 方法

文件MD5校验

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetMD5Hash(
    string pathName
)

参数

pathName
类型：SystemString

[缺少 "M:Chat.Framework.FileTools.GetMD5Hash(System.String)" 的 <param name="pathName"/> 文档]

返回值

类型：String
参见

引用

FileTools 类
Chat.Framework 命名空间


FileTools.SetCacheObj 方法

FileToolsSetCacheObj 方法

设置缓存

命名空间： Chat.Framework
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static bool SetCacheObj(
    string k,
    Object v,
    int m = 10
)

参数

k
类型：SystemString

[缺少 "M:Chat.Framework.FileTools.SetCacheObj(System.String,System.Object,System.Int32)" 的 <param name="k"/> 文档]

v
类型：SystemObject

[缺少 "M:Chat.Framework.FileTools.SetCacheObj(System.String,System.Object,System.Int32)" 的 <param name="v"/> 文档]

m (Optional)
类型：SystemInt32

[缺少 "M:Chat.Framework.FileTools.SetCacheObj(System.String,System.Object,System.Int32)" 的 <param name="m"/> 文档]

返回值

类型：Boolean
参见

引用

FileTools 类
Chat.Framework 命名空间


Chat.Framework.PCRobotSDK 命名空间

[缺少 "N:Chat.Framework.PCRobotSDK" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | AppServer |
公共类 | PackHist | 获取消息之心跳类
公共类 | PCRobotPool | PC机器人(易转发)管理端
公共类 | SupperSocketSession |


AppServer 类

[缺少 "T:Chat.Framework.PCRobotSDK.AppServer" 的 <summary> 文档]

继承层次
SystemObject
AppServerBaseSupperSocketSession, StringRequestInfo
AppServerSupperSocketSession, StringRequestInfo
AppServerSupperSocketSession
Chat.Framework.PCRobotSDKAppServer

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class AppServer : AppServer<SupperSocketSession>

AppServer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AppServer | 初始化 AppServer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | BasicSecurity | Gets the basic transfer layer security protocol. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的属性 | Bootstrap | Gets the bootstrap of this appServer instance. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Certificate | Gets the certificate of current server. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Config | Gets the server's config. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | ConnectionFilters | Gets or sets the server's connection filter (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Listeners | Gets or sets the listeners inforamtion. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | LogFactory | Gets or sets the log factory. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Logger | Gets the logger assosiated with this object. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Name | Gets the name of the server instance. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | ReceiveFilterFactory | Gets or sets the receive filter factory. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的属性 | RootConfig | Gets the root config. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | SessionCount | Gets the total session count. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共属性 | StartedTime | Gets the started time of this server instance. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | State | Gets the current state of the work item. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | TextEncoding | Gets the default text encoding. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的属性 | TotalHandledRequests | Gets the total handled requests number. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
Top
方法
 | 名称 | 说明
受保护的方法 | CreateAppSession | create a new TAppSession instance, you can override it to create the session instance in your own way (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | CreateLogger | Creates the logger for the AppServer. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Dispose | Releases unmanaged and - optionally - managed resources (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | ExecuteCommand | Executes the command. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetAllSessions | Gets all sessions in sessions snapshot. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | GetAppSessionByID | 已过时。 Gets the app session by ID. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
受保护的方法 | GetCertificate | Gets the certificate from server configuguration. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | GetFilePath | Gets the physical file path by the relative file path, search both in the appserver's root and in the supersocket root dir if the isolation level has been set other than 'None'. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetSessionByID | Gets the app session by ID. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | GetSessions | Gets the matched sessions from sessions snapshot. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnNewSessionConnected | (重写 AppServerBase.OnNewSessionConnected(UTP).)
受保护的方法 | OnServerStatusCollected | Called when [server status collected]. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnSessionClosed | (重写 AppServer.OnSessionClosed(UTP, CloseReason).)
受保护的方法 | OnStarted | (重写 AppServerBase.OnStarted.)
受保护的方法 | OnStartup | 已过时。 Called when [startup]. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnStopped | Called when [stopped]. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnSystemMessageReceived | Called when [system message received]. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | RegisterConfigHandler``1(IServerConfig, String, FuncUMP, Boolean) | (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | RegisterConfigHandler``1(IServerConfig, String, FuncUMP, Boolean) | Registers the configuration option value handler, it is used for reading configuration value and reload it after the configuration is changed; (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | RegisterSession | Registers the session into the session container. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | ResetSessionSecurity | Resets the session's security protocol. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Setup(Int32) | Setups with the specified port. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | Setup(IRootConfig, IServerConfig) | (重写 AppServerBase.Setup(IRootConfig, IServerConfig).)
公共方法 | Setup(IServerConfig, ISocketServerFactory, IReceiveFilterFactoryUTP, ILogFactory, IEnumerableIConnectionFilter, IEnumerableICommandLoaderICommandUTP, UTP) | Setups with the specified config. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Setup(IRootConfig, IServerConfig, ISocketServerFactory, IReceiveFilterFactoryUTP, ILogFactory, IEnumerableIConnectionFilter, IEnumerableICommandLoaderICommandUTP, UTP) | Setups the specified root config, this method used for programming setup (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Setup(String, Int32, ISocketServerFactory, IReceiveFilterFactoryUTP, ILogFactory, IEnumerableIConnectionFilter, IEnumerableICommandLoaderICommandUTP, UTP) | Setups with the specified ip and port. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | SetupCommandLoaders | Setups the command loaders. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | SetupCommands | Setups the command into command dictionary (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Start | Starts this AppServer instance. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | Stop | Stops this instance. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | ToString | (继承自 Object。)
受保护的方法 | UpdateServerStatus | Updates the summary of the server. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | ValidateClientCertificate | Validates the client certificate. This method is only used if the certificate configuration attribute "clientCertificateRequired" is true. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
Top
事件
 | 名称 | 说明
公共事件 | NewRequestReceived | Occurs when a full request item received. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共事件 | NewSessionConnected | The action which will be executed after a new session connect (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共事件 | SessionClosed | Gets/sets the session closed event handler. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
Top
字段
 | 名称 | 说明
受保护的字段 | NullAppSession | Null appSession instance (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK 命名空间


AppServer 构造函数

初始化 AppServer 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public AppServer()
参见

引用

AppServer 类
Chat.Framework.PCRobotSDK 命名空间


AppServer 属性

AppServer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BasicSecurity | Gets the basic transfer layer security protocol. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的属性 | Bootstrap | Gets the bootstrap of this appServer instance. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Certificate | Gets the certificate of current server. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Config | Gets the server's config. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | ConnectionFilters | Gets or sets the server's connection filter (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Listeners | Gets or sets the listeners inforamtion. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | LogFactory | Gets or sets the log factory. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Logger | Gets the logger assosiated with this object. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | Name | Gets the name of the server instance. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | ReceiveFilterFactory | Gets or sets the receive filter factory. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的属性 | RootConfig | Gets the root config. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | SessionCount | Gets the total session count. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共属性 | StartedTime | Gets the started time of this server instance. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | State | Gets the current state of the work item. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共属性 | TextEncoding | Gets the default text encoding. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的属性 | TotalHandledRequests | Gets the total handled requests number. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
Top
参见

引用

AppServer 类
Chat.Framework.PCRobotSDK 命名空间


AppServer 方法

AppServer 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | CreateAppSession | create a new TAppSession instance, you can override it to create the session instance in your own way (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | CreateLogger | Creates the logger for the AppServer. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Dispose | Releases unmanaged and - optionally - managed resources (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | ExecuteCommand | Executes the command. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetAllSessions | Gets all sessions in sessions snapshot. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | GetAppSessionByID | 已过时。 Gets the app session by ID. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
受保护的方法 | GetCertificate | Gets the certificate from server configuguration. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | GetFilePath | Gets the physical file path by the relative file path, search both in the appserver's root and in the supersocket root dir if the isolation level has been set other than 'None'. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetSessionByID | Gets the app session by ID. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | GetSessions | Gets the matched sessions from sessions snapshot. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnNewSessionConnected | (重写 AppServerBase.OnNewSessionConnected(UTP).)
受保护的方法 | OnServerStatusCollected | Called when [server status collected]. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnSessionClosed | (重写 AppServer.OnSessionClosed(UTP, CloseReason).)
受保护的方法 | OnStarted | (重写 AppServerBase.OnStarted.)
受保护的方法 | OnStartup | 已过时。 Called when [startup]. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnStopped | Called when [stopped]. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnSystemMessageReceived | Called when [system message received]. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | RegisterConfigHandler``1(IServerConfig, String, FuncUMP, Boolean) | (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | RegisterConfigHandler``1(IServerConfig, String, FuncUMP, Boolean) | Registers the configuration option value handler, it is used for reading configuration value and reload it after the configuration is changed; (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | RegisterSession | Registers the session into the session container. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | ResetSessionSecurity | Resets the session's security protocol. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Setup(Int32) | Setups with the specified port. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | Setup(IRootConfig, IServerConfig) | (重写 AppServerBase.Setup(IRootConfig, IServerConfig).)
公共方法 | Setup(IServerConfig, ISocketServerFactory, IReceiveFilterFactoryUTP, ILogFactory, IEnumerableIConnectionFilter, IEnumerableICommandLoaderICommandUTP, UTP) | Setups with the specified config. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Setup(IRootConfig, IServerConfig, ISocketServerFactory, IReceiveFilterFactoryUTP, ILogFactory, IEnumerableIConnectionFilter, IEnumerableICommandLoaderICommandUTP, UTP) | Setups the specified root config, this method used for programming setup (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Setup(String, Int32, ISocketServerFactory, IReceiveFilterFactoryUTP, ILogFactory, IEnumerableIConnectionFilter, IEnumerableICommandLoaderICommandUTP, UTP) | Setups with the specified ip and port. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | SetupCommandLoaders | Setups the command loaders. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | SetupCommands | Setups the command into command dictionary (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Start | Starts this AppServer instance. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | Stop | Stops this instance. (继承自 AppServerSupperSocketSession, StringRequestInfo。)
公共方法 | ToString | (继承自 Object。)
受保护的方法 | UpdateServerStatus | Updates the summary of the server. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | ValidateClientCertificate | Validates the client certificate. This method is only used if the certificate configuration attribute "clientCertificateRequired" is true. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

AppServer 类
Chat.Framework.PCRobotSDK 命名空间


AppServer.OnNewSessionConnected 方法

AppServerOnNewSessionConnected 方法

[缺少 "M:Chat.Framework.PCRobotSDK.AppServer.OnNewSessionConnected(Chat.Framework.PCRobotSDK.SupperSocketSession)" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void OnNewSessionConnected(
    SupperSocketSession session
)

参数

session
类型：Chat.Framework.PCRobotSDKSupperSocketSession

[缺少 "M:Chat.Framework.PCRobotSDK.AppServer.OnNewSessionConnected(Chat.Framework.PCRobotSDK.SupperSocketSession)" 的 <param name="session"/> 文档]

参见

引用

AppServer 类
Chat.Framework.PCRobotSDK 命名空间


AppServer.OnSessionClosed 方法

AppServerOnSessionClosed 方法

[缺少 "M:Chat.Framework.PCRobotSDK.AppServer.OnSessionClosed(Chat.Framework.PCRobotSDK.SupperSocketSession,SuperSocket.SocketBase.CloseReason)" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void OnSessionClosed(
    SupperSocketSession session,
    CloseReason reason
)

参数

session
类型：Chat.Framework.PCRobotSDKSupperSocketSession

[缺少 "M:Chat.Framework.PCRobotSDK.AppServer.OnSessionClosed(Chat.Framework.PCRobotSDK.SupperSocketSession,SuperSocket.SocketBase.CloseReason)" 的 <param name="session"/> 文档]

reason
类型：CloseReason

[缺少 "M:Chat.Framework.PCRobotSDK.AppServer.OnSessionClosed(Chat.Framework.PCRobotSDK.SupperSocketSession,SuperSocket.SocketBase.CloseReason)" 的 <param name="reason"/> 文档]

参见

引用

AppServer 类
Chat.Framework.PCRobotSDK 命名空间


AppServer.OnStarted 方法

AppServerOnStarted 方法

[缺少 "M:Chat.Framework.PCRobotSDK.AppServer.OnStarted" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void OnStarted()
参见

引用

AppServer 类
Chat.Framework.PCRobotSDK 命名空间


AppServer.Setup 方法

AppServerSetup 方法

重载列表
 | 名称 | 说明
公共方法 | Setup(Int32) | Setups with the specified port. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
受保护的方法 | Setup(IRootConfig, IServerConfig) | (重写 AppServerBase.Setup(IRootConfig, IServerConfig).)
公共方法 | Setup(IServerConfig, ISocketServerFactory, IReceiveFilterFactoryUTP, ILogFactory, IEnumerableIConnectionFilter, IEnumerableICommandLoaderICommandUTP, UTP) | Setups with the specified config. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Setup(IRootConfig, IServerConfig, ISocketServerFactory, IReceiveFilterFactoryUTP, ILogFactory, IEnumerableIConnectionFilter, IEnumerableICommandLoaderICommandUTP, UTP) | Setups the specified root config, this method used for programming setup (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共方法 | Setup(String, Int32, ISocketServerFactory, IReceiveFilterFactoryUTP, ILogFactory, IEnumerableIConnectionFilter, IEnumerableICommandLoaderICommandUTP, UTP) | Setups with the specified ip and port. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
Top
参见

引用

AppServer 类
Chat.Framework.PCRobotSDK 命名空间


AppServer.Setup 方法 (IRootConfig, IServerConfig)

AppServerSetup 方法 (IRootConfig, IServerConfig)

[缺少 "M:Chat.Framework.PCRobotSDK.AppServer.Setup(SuperSocket.SocketBase.Config.IRootConfig,SuperSocket.SocketBase.Config.IServerConfig)" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override bool Setup(
    IRootConfig rootConfig,
    IServerConfig config
)

参数

rootConfig
类型：IRootConfig

[缺少 "M:Chat.Framework.PCRobotSDK.AppServer.Setup(SuperSocket.SocketBase.Config.IRootConfig,SuperSocket.SocketBase.Config.IServerConfig)" 的 <param name="rootConfig"/> 文档]

config
类型：IServerConfig

[缺少 "M:Chat.Framework.PCRobotSDK.AppServer.Setup(SuperSocket.SocketBase.Config.IRootConfig,SuperSocket.SocketBase.Config.IServerConfig)" 的 <param name="config"/> 文档]

返回值

类型：Boolean
参见

引用

AppServer 类
Setup 重载
Chat.Framework.PCRobotSDK 命名空间


AppServer 事件

AppServer 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | NewRequestReceived | Occurs when a full request item received. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共事件 | NewSessionConnected | The action which will be executed after a new session connect (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
公共事件 | SessionClosed | Gets/sets the session closed event handler. (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
Top
参见

引用

AppServer 类
Chat.Framework.PCRobotSDK 命名空间


AppServer 字段

AppServer 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | NullAppSession | Null appSession instance (继承自 AppServerBaseSupperSocketSession, StringRequestInfo。)
Top
参见

引用

AppServer 类
Chat.Framework.PCRobotSDK 命名空间


PackHist 类

获取消息之心跳类
继承层次
SystemObject
Chat.Framework.PCRobotSDKPackHist

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PackHist : IRunable, IDisposable

PackHist 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PackHist | 初始化 PackHist 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsRunning |
公共属性 | RegisterdHandler |
公共属性 | WaitHandler |
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 释放被 PackHist 使用的所有资源
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResult | 获取接收数据包
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run |
公共方法 | SetResult | 设置接收数据包
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK 命名空间


PackHist 构造函数

初始化 PackHist 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PackHist()
参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PackHist 属性

PackHist 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning |
公共属性 | RegisterdHandler |
公共属性 | WaitHandler |
Top
参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PackHist.IsRunning 属性

PackHistIsRunning 属性

[缺少 "P:Chat.Framework.PCRobotSDK.PackHist.IsRunning" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsRunning { get; set; }

属性值

类型：Boolean

实现

IRunableIsRunning
参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PackHist.RegisterdHandler 属性

PackHistRegisterdHandler 属性

[缺少 "P:Chat.Framework.PCRobotSDK.PackHist.RegisterdHandler" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public RegisteredWaitHandle RegisterdHandler { get; set; }

属性值

类型：RegisteredWaitHandle

实现

IRunableRegisterdHandler
参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PackHist.WaitHandler 属性

PackHistWaitHandler 属性

[缺少 "P:Chat.Framework.PCRobotSDK.PackHist.WaitHandler" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WaitHandle WaitHandler { get; set; }

属性值

类型：WaitHandle

实现

IRunableWaitHandler
参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PackHist 方法

PackHist 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResult | 获取接收数据包
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Run |
公共方法 | SetResult | 设置接收数据包
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PackHist.Dispose 方法

PackHistDispose 方法

释放被 PackHist 使用的所有资源

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()

实现

IDisposableDispose
参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PackHist.GetResult 方法

PackHistGetResult 方法

获取接收数据包

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Task<BaseMsg> GetResult(
    string _msg_id
)

参数

_msg_id
类型：SystemString
msgId

返回值

类型：Task BaseMsg
参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PackHist.Run 方法

PackHistRun 方法

[缺少 "M:Chat.Framework.PCRobotSDK.PackHist.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Run(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Chat.Framework.PCRobotSDK.PackHist.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Chat.Framework.PCRobotSDK.PackHist.Run(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

实现

IRunableRun(Object, Boolean)
参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PackHist.SetResult 方法

PackHistSetResult 方法

设置接收数据包

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SetResult(
    BaseMsg msg
)

参数

msg
类型：BaseMsg

[缺少 "M:Chat.Framework.PCRobotSDK.PackHist.SetResult(PCRobot.Pack.BaseMsg)" 的 <param name="msg"/> 文档]

参见

引用

PackHist 类
Chat.Framework.PCRobotSDK 命名空间


PCRobotPool 类

PC机器人(易转发)管理端
继承层次
SystemObject
Chat.Framework.PCRobotSDKPCRobotPool

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PCRobotPool

PCRobotPool 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PCRobotPool | 初始化 PCRobotPool 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ClientSessions | 客户端链接集合
公共属性 | PackHist |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetSession | 获取连接
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Remove | 删除连接
公共方法 | SendAppUpdate |
公共方法 | ToString | (继承自 Object。)
公共方法 | Update | 更新连接
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK 命名空间


PCRobotPool 构造函数

初始化 PCRobotPool 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PCRobotPool()
参见

引用

PCRobotPool 类
Chat.Framework.PCRobotSDK 命名空间


PCRobotPool 属性

PCRobotPool 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ClientSessions | 客户端链接集合
公共属性 | PackHist |
Top
参见

引用

PCRobotPool 类
Chat.Framework.PCRobotSDK 命名空间


PCRobotPool.ClientSessions 属性

PCRobotPoolClientSessions 属性

客户端链接集合

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, AppSession> ClientSessions { get; set; }

属性值

类型：Dictionary String, AppSession
参见

引用

PCRobotPool 类
Chat.Framework.PCRobotSDK 命名空间


PCRobotPool.PackHist 属性

PCRobotPoolPackHist 属性

[缺少 "P:Chat.Framework.PCRobotSDK.PCRobotPool.PackHist" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PackHist PackHist { get; }

属性值

类型：PackHist
参见

引用

PCRobotPool 类
Chat.Framework.PCRobotSDK 命名空间


PCRobotPool 方法

PCRobotPool 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetSession | 获取连接
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Remove | 删除连接
公共方法 | SendAppUpdate |
公共方法 | ToString | (继承自 Object。)
公共方法 | Update | 更新连接
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PCRobotPool 类
Chat.Framework.PCRobotSDK 命名空间


PCRobotPool.GetSession 方法

PCRobotPoolGetSession 方法

获取连接

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public AppSession GetSession(
    string robotname
)

参数

robotname
类型：SystemString

[缺少 "M:Chat.Framework.PCRobotSDK.PCRobotPool.GetSession(System.String)" 的 <param name="robotname"/> 文档]

返回值

类型：AppSession
参见

引用

PCRobotPool 类
Chat.Framework.PCRobotSDK 命名空间


PCRobotPool.Remove 方法

PCRobotPoolRemove 方法

删除连接

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Remove(
    AppSession session
)

参数

session
类型：AppSession

[缺少 "M:Chat.Framework.PCRobotSDK.PCRobotPool.Remove(SuperSocket.SocketBase.AppSession)" 的 <param name="session"/> 文档]

返回值

类型：String
参见

引用

PCRobotPool 类
Chat.Framework.PCRobotSDK 命名空间


PCRobotPool.SendAppUpdate 方法

PCRobotPoolSendAppUpdate 方法

[缺少 "M:Chat.Framework.PCRobotSDK.PCRobotPool.SendAppUpdate" 的 <summary> 文档]

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SendAppUpdate()
参见

引用

PCRobotPool 类
Chat.Framework.PCRobotSDK 命名空间


PCRobotPool.Update 方法

PCRobotPoolUpdate 方法

更新连接

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Update(
    string username,
    AppSession session
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.PCRobotSDK.PCRobotPool.Update(System.String,SuperSocket.SocketBase.AppSession)" 的 <param name="username"/> 文档]

session
类型：AppSession

[缺少 "M:Chat.Framework.PCRobotSDK.PCRobotPool.Update(System.String,SuperSocket.SocketBase.AppSession)" 的 <param name="session"/> 文档]

参见

引用

PCRobotPool 类
Chat.Framework.PCRobotSDK 命名空间


SupperSocketSession 类

[缺少 "T:Chat.Framework.PCRobotSDK.SupperSocketSession" 的 <summary> 文档]

继承层次
SystemObject
AppSessionSupperSocketSession, StringRequestInfo
Chat.Framework.PCRobotSDKSupperSocketSession

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SupperSocketSession : AppSession<SupperSocketSession, StringRequestInfo>

SupperSocketSession 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SupperSocketSession | 初始化 SupperSocketSession 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AppServer | Gets the app server instance assosiated with the session. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Charset | Gets or sets the charset which is used for transfering text message. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Config | Gets the config of the server. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Connected | Gets a value indicating whether this IAppSession is connected. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | CurrentCommand | Gets or sets the current executing command. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Items | Gets the items dictionary, only support 10 items maximum (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | LastActiveTime | Gets or sets the last active time of the session. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | LocalEndPoint | Gets the local listening endpoint. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Logger | Gets the logger. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | PrevCommand | Gets or sets the previous command. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | RemoteEndPoint | Gets the remote endpoint of client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | SecureProtocol | Gets or sets the secure protocol of transportation layer. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | SessionID | Gets the session ID. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | SocketSession | Gets the socket session of the AppSession. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | StartTime | Gets the start time of the session. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
Top
方法
 | 名称 | 说明
公共方法 | Close | Closes this session. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Close(CloseReason) | Closes the session by the specified reason. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
受保护的方法 | GetMaxRequestLength | Gets the maximum allowed length of the request. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | HandleException | Handles the exceptional error, it only handles application error. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | HandleUnknownRequest | Handles the unknown request. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Initialize | Initializes the specified app session by AppServer and SocketSession. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnInit | Called when [init]. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnSessionClosed | Called when [session closed]. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnSessionStarted | Called when [session started]. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(String) | Sends the message to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(ArraySegmentByte) | Sends the data segment to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(IListArraySegmentByte) | Sends the data segments to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(String, Object) | Sends the response. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(Byte, Int32, Int32) | Sends the data to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | SetNextReceiveFilter | Sets the next Receive filter which will be used when next data block received (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | ToString | (继承自 Object。)
公共方法 | TrySend(String) | Try to send the message to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | TrySend(ArraySegmentByte) | Try to send the data segment to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | TrySend(IListArraySegmentByte) | Try to send the data segments to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | TrySend(Byte, Int32, Int32) | Try to send the data to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK 命名空间


SupperSocketSession 构造函数

初始化 SupperSocketSession 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SupperSocketSession()
参见

引用

SupperSocketSession 类
Chat.Framework.PCRobotSDK 命名空间


SupperSocketSession 属性

SupperSocketSession 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AppServer | Gets the app server instance assosiated with the session. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Charset | Gets or sets the charset which is used for transfering text message. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Config | Gets the config of the server. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Connected | Gets a value indicating whether this IAppSession is connected. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | CurrentCommand | Gets or sets the current executing command. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Items | Gets the items dictionary, only support 10 items maximum (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | LastActiveTime | Gets or sets the last active time of the session. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | LocalEndPoint | Gets the local listening endpoint. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | Logger | Gets the logger. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | PrevCommand | Gets or sets the previous command. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | RemoteEndPoint | Gets the remote endpoint of client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | SecureProtocol | Gets or sets the secure protocol of transportation layer. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | SessionID | Gets the session ID. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | SocketSession | Gets the socket session of the AppSession. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共属性 | StartTime | Gets the start time of the session. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
Top
参见

引用

SupperSocketSession 类
Chat.Framework.PCRobotSDK 命名空间


SupperSocketSession 方法

SupperSocketSession 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Close | Closes this session. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Close(CloseReason) | Closes the session by the specified reason. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
受保护的方法 | GetMaxRequestLength | Gets the maximum allowed length of the request. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | HandleException | Handles the exceptional error, it only handles application error. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | HandleUnknownRequest | Handles the unknown request. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Initialize | Initializes the specified app session by AppServer and SocketSession. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnInit | Called when [init]. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnSessionClosed | Called when [session closed]. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | OnSessionStarted | Called when [session started]. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(String) | Sends the message to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(ArraySegmentByte) | Sends the data segment to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(IListArraySegmentByte) | Sends the data segments to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(String, Object) | Sends the response. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | Send(Byte, Int32, Int32) | Sends the data to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
受保护的方法 | SetNextReceiveFilter | Sets the next Receive filter which will be used when next data block received (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | ToString | (继承自 Object。)
公共方法 | TrySend(String) | Try to send the message to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | TrySend(ArraySegmentByte) | Try to send the data segment to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | TrySend(IListArraySegmentByte) | Try to send the data segments to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
公共方法 | TrySend(Byte, Int32, Int32) | Try to send the data to client. (继承自 AppSessionSupperSocketSession, StringRequestInfo。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SupperSocketSession 类
Chat.Framework.PCRobotSDK 命名空间


Chat.Framework.PCRobotSDK.WechatEvents 命名空间

[缺少 "N:Chat.Framework.PCRobotSDK.WechatEvents" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | WechatApplyFriendEvents | 申请添加我为好友,需要审核事件
公共类 | WechatContactListEvents | 获取到通讯录列表事件
公共类 | WechatGroupMemberEvents | 微信获取到群成员信息事件
公共类 | WechatNewFriendEvents | 微信新好友事件
公共类 | WechatNewMemerEvents | 新用户入群事件
公共类 | WechatReceiveMsgEvents | 微信收到消息事件
公共类 | WechatReicevePayEvents | 微信收到转账收款事件
公共类 | WechatStatusEvents | 微信状态事件


WechatApplyFriendEvents 类

申请添加我为好友,需要审核事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WechatEventsWechatApplyFriendEvents

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatApplyFriendEvents : ChatEvent

WechatApplyFriendEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatApplyFriendEvents | 初始化 WechatApplyFriendEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 申请添加我为好友,需要审核信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatApplyFriendEvents 构造函数

初始化 WechatApplyFriendEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatApplyFriendEvents(
    WechatApplyFriend data
)

参数

data
类型：WechatApplyFriend

[缺少 "M:Chat.Framework.PCRobotSDK.WechatEvents.WechatApplyFriendEvents.#ctor(PCRobot.Pack.WechatApplyFriend)" 的 <param name="data"/> 文档]

参见

引用

WechatApplyFriendEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatApplyFriendEvents 属性

WechatApplyFriendEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 申请添加我为好友,需要审核信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WechatApplyFriendEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatApplyFriendEvents.Data 属性

WechatApplyFriendEventsData 属性

申请添加我为好友,需要审核信息

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatApplyFriend Data { get; }

属性值

类型：WechatApplyFriend
参见

引用

WechatApplyFriendEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatApplyFriendEvents 方法

WechatApplyFriendEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatApplyFriendEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatContactListEvents 类

获取到通讯录列表事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WechatEventsWechatContactListEvents

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatContactListEvents : ChatEvent

WechatContactListEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatContactListEvents | 初始化 WechatContactListEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 获取到通讯录信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatContactListEvents 构造函数

初始化 WechatContactListEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatContactListEvents(
    WechatContact data
)

参数

data
类型：WechatContact

[缺少 "M:Chat.Framework.PCRobotSDK.WechatEvents.WechatContactListEvents.#ctor(PCRobot.Pack.WechatContact)" 的 <param name="data"/> 文档]

参见

引用

WechatContactListEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatContactListEvents 属性

WechatContactListEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 获取到通讯录信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WechatContactListEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatContactListEvents.Data 属性

WechatContactListEventsData 属性

获取到通讯录信息

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatContact Data { get; }

属性值

类型：WechatContact
参见

引用

WechatContactListEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatContactListEvents 方法

WechatContactListEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatContactListEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatGroupMemberEvents 类

微信获取到群成员信息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WechatEventsWechatGroupMemberEvents

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatGroupMemberEvents : ChatEvent

WechatGroupMemberEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatGroupMemberEvents | 初始化 WechatGroupMemberEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 微信获取到群成员信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatGroupMemberEvents 构造函数

初始化 WechatGroupMemberEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatGroupMemberEvents(
    WechatGroupMember data
)

参数

data
类型：WechatGroupMember

[缺少 "M:Chat.Framework.PCRobotSDK.WechatEvents.WechatGroupMemberEvents.#ctor(PCRobot.Pack.WechatGroupMember)" 的 <param name="data"/> 文档]

参见

引用

WechatGroupMemberEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatGroupMemberEvents 属性

WechatGroupMemberEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 微信获取到群成员信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WechatGroupMemberEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatGroupMemberEvents.Data 属性

WechatGroupMemberEventsData 属性

微信获取到群成员信息

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatGroupMember Data { get; }

属性值

类型：WechatGroupMember
参见

引用

WechatGroupMemberEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatGroupMemberEvents 方法

WechatGroupMemberEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatGroupMemberEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewFriendEvents 类

微信新好友事件
继承层次
SystemObject
Chat.Framework.PCRobotSDK.WechatEventsWechatNewFriendEvents

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatNewFriendEvents

WechatNewFriendEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatNewFriendEvents | 初始化 WechatNewFriendEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Data | 微信新好友信息
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewFriendEvents 构造函数

初始化 WechatNewFriendEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatNewFriendEvents(
    WechatNewFriend data
)

参数

data
类型：WechatNewFriend

[缺少 "M:Chat.Framework.PCRobotSDK.WechatEvents.WechatNewFriendEvents.#ctor(PCRobot.Pack.WechatNewFriend)" 的 <param name="data"/> 文档]

参见

引用

WechatNewFriendEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewFriendEvents 属性

WechatNewFriendEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data | 微信新好友信息
Top
参见

引用

WechatNewFriendEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewFriendEvents.Data 属性

WechatNewFriendEventsData 属性

微信新好友信息

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatNewFriend Data { get; }

属性值

类型：WechatNewFriend
参见

引用

WechatNewFriendEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewFriendEvents 方法

WechatNewFriendEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatNewFriendEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewMemerEvents 类

新用户入群事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WechatEventsWechatNewMemerEvents

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatNewMemerEvents : ChatEvent

WechatNewMemerEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatNewMemerEvents | 初始化 WechatNewMemerEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 新用户入群信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewMemerEvents 构造函数

初始化 WechatNewMemerEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatNewMemerEvents(
    WechatNewMemer data
)

参数

data
类型：WechatNewMemer

[缺少 "M:Chat.Framework.PCRobotSDK.WechatEvents.WechatNewMemerEvents.#ctor(PCRobot.Pack.WechatNewMemer)" 的 <param name="data"/> 文档]

参见

引用

WechatNewMemerEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewMemerEvents 属性

WechatNewMemerEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 新用户入群信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WechatNewMemerEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewMemerEvents.Data 属性

WechatNewMemerEventsData 属性

新用户入群信息

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatNewMemer Data { get; }

属性值

类型：WechatNewMemer
参见

引用

WechatNewMemerEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatNewMemerEvents 方法

WechatNewMemerEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatNewMemerEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReceiveMsgEvents 类

微信收到消息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WechatEventsWechatReceiveMsgEvents

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatReceiveMsgEvents : ChatEvent

WechatReceiveMsgEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatReceiveMsgEvents | 初始化 WechatReceiveMsgEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 微信收到消息信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReceiveMsgEvents 构造函数

初始化 WechatReceiveMsgEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatReceiveMsgEvents(
    WechatReceiveMsg msg
)

参数

msg
类型：WechatReceiveMsg

[缺少 "M:Chat.Framework.PCRobotSDK.WechatEvents.WechatReceiveMsgEvents.#ctor(PCRobot.Pack.WechatReceiveMsg)" 的 <param name="msg"/> 文档]

参见

引用

WechatReceiveMsgEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReceiveMsgEvents 属性

WechatReceiveMsgEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 微信收到消息信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WechatReceiveMsgEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReceiveMsgEvents.Data 属性

WechatReceiveMsgEventsData 属性

微信收到消息信息

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatReceiveMsg Data { get; }

属性值

类型：WechatReceiveMsg
参见

引用

WechatReceiveMsgEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReceiveMsgEvents 方法

WechatReceiveMsgEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatReceiveMsgEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReicevePayEvents 类

微信收到转账收款事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WechatEventsWechatReicevePayEvents

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatReicevePayEvents : ChatEvent

WechatReicevePayEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatReicevePayEvents | 初始化 WechatReicevePayEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 微信收到转账收款
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReicevePayEvents 构造函数

初始化 WechatReicevePayEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatReicevePayEvents(
    WechatReicevePay data
)

参数

data
类型：WechatReicevePay

[缺少 "M:Chat.Framework.PCRobotSDK.WechatEvents.WechatReicevePayEvents.#ctor(PCRobot.Pack.WechatReicevePay)" 的 <param name="data"/> 文档]

参见

引用

WechatReicevePayEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReicevePayEvents 属性

WechatReicevePayEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 微信收到转账收款
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WechatReicevePayEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReicevePayEvents.Data 属性

WechatReicevePayEventsData 属性

微信收到转账收款

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatReicevePay Data { get; }

属性值

类型：WechatReicevePay
参见

引用

WechatReicevePayEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatReicevePayEvents 方法

WechatReicevePayEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatReicevePayEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents 类

微信状态事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WechatEventsWechatStatusEvents

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatStatusEvents : ChatEvent

WechatStatusEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatStatusEvents | 初始化 WechatStatusEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Cmd | 消息命令
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Key | 秘钥
公共属性 | MsgId | 消息命
公共属性 | RobotType | 机器人类型
公共属性 | RobotUsername | 机器人账号
公共属性 | RobotUsernick | 机器人昵称
公共属性 | Status | 状态
公共属性 | Uin | Uin
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents 构造函数

初始化 WechatStatusEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatStatusEvents(
    WechatStatus data
)

参数

data
类型：WechatStatus

[缺少 "M:Chat.Framework.PCRobotSDK.WechatEvents.WechatStatusEvents.#ctor(PCRobot.Pack.WechatStatus)" 的 <param name="data"/> 文档]

参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents 属性

WechatStatusEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Cmd | 消息命令
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Key | 秘钥
公共属性 | MsgId | 消息命
公共属性 | RobotType | 机器人类型
公共属性 | RobotUsername | 机器人账号
公共属性 | RobotUsernick | 机器人昵称
公共属性 | Status | 状态
公共属性 | Uin | Uin
Top
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents.Cmd 属性

WechatStatusEventsCmd 属性

消息命令

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PCRobotCMD Cmd { get; }

属性值

类型：PCRobotCMD
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents.Key 属性

WechatStatusEventsKey 属性

秘钥

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Key { get; }

属性值

类型：String
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents.MsgId 属性

WechatStatusEventsMsgId 属性

消息命

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string MsgId { get; }

属性值

类型：String
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents.RobotType 属性

WechatStatusEventsRobotType 属性

机器人类型

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public RobotType RobotType { get; }

属性值

类型：RobotType
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents.RobotUsername 属性

WechatStatusEventsRobotUsername 属性

机器人账号

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string RobotUsername { get; }

属性值

类型：String
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents.RobotUsernick 属性

WechatStatusEventsRobotUsernick 属性

机器人昵称

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string RobotUsernick { get; }

属性值

类型：String
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents.Status 属性

WechatStatusEventsStatus 属性

状态

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Status Status { get; }

属性值

类型：Status
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents.Uin 属性

WechatStatusEventsUin 属性

Uin

命名空间： Chat.Framework.PCRobotSDK.WechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Uin { get; }

属性值

类型：String
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


WechatStatusEvents 方法

WechatStatusEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatStatusEvents 类
Chat.Framework.PCRobotSDK.WechatEvents 命名空间


Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间

[缺少 "N:Chat.Framework.PCRobotSDK.WorkWechatEvents" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | WorkWechatApplyFriendEvents | 企业微信-申请添加我为好友,需要审核事件
公共类 | WorkWechatContactListEvents | 企业微信-获取到通讯录列表事件
公共类 | WorkWechatGroupMemberEvents | 企业微信-获取到群成员信息事件
公共类 | WorkWechatNewFriendEvents | 企业微信-增加新好友事件
公共类 | WorkWechatNewMemerEvents | 企业微信-增加新群成员事件
公共类 | WorkWechatReceiveMsgEvents | 企业微信-收到消息事件
公共类 | WorkWechatReicevePayEvents | 企业微信-收到红包事件


WorkWechatApplyFriendEvents 类

企业微信-申请添加我为好友,需要审核事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatApplyFriendEvents

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WorkWechatApplyFriendEvents : ChatEvent

WorkWechatApplyFriendEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WorkWechatApplyFriendEvents | 初始化 WorkWechatApplyFriendEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-申请添加我为好友,需要审核信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatApplyFriendEvents 构造函数

初始化 WorkWechatApplyFriendEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatApplyFriendEvents(
    WorkWechatApplyFriend data
)

参数

data
类型：WorkWechatApplyFriend

[缺少 "M:Chat.Framework.PCRobotSDK.WorkWechatEvents.WorkWechatApplyFriendEvents.#ctor(PCRobot.Pack.WorkWechatApplyFriend)" 的 <param name="data"/> 文档]

参见

引用

WorkWechatApplyFriendEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatApplyFriendEvents 属性

WorkWechatApplyFriendEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-申请添加我为好友,需要审核信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WorkWechatApplyFriendEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatApplyFriendEvents.Data 属性

WorkWechatApplyFriendEventsData 属性

企业微信-申请添加我为好友,需要审核信息

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatApplyFriend Data { get; }

属性值

类型：WorkWechatApplyFriend
参见

引用

WorkWechatApplyFriendEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatApplyFriendEvents 方法

WorkWechatApplyFriendEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WorkWechatApplyFriendEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatContactListEvents 类

企业微信-获取到通讯录列表事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatContactListEvents

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WorkWechatContactListEvents : ChatEvent

WorkWechatContactListEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WorkWechatContactListEvents | 初始化 WorkWechatContactListEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-获取到通讯录类列表信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatContactListEvents 构造函数

初始化 WorkWechatContactListEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatContactListEvents(
    WorkWechatContact data
)

参数

data
类型：WorkWechatContact

[缺少 "M:Chat.Framework.PCRobotSDK.WorkWechatEvents.WorkWechatContactListEvents.#ctor(PCRobot.Pack.WorkWechatContact)" 的 <param name="data"/> 文档]

参见

引用

WorkWechatContactListEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatContactListEvents 属性

WorkWechatContactListEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-获取到通讯录类列表信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WorkWechatContactListEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatContactListEvents.Data 属性

WorkWechatContactListEventsData 属性

企业微信-获取到通讯录类列表信息

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatContact Data { get; }

属性值

类型：WorkWechatContact
参见

引用

WorkWechatContactListEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatContactListEvents 方法

WorkWechatContactListEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WorkWechatContactListEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatGroupMemberEvents 类

企业微信-获取到群成员信息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatGroupMemberEvents

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WorkWechatGroupMemberEvents : ChatEvent

WorkWechatGroupMemberEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WorkWechatGroupMemberEvents | 初始化 WorkWechatGroupMemberEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-获取到群成员信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatGroupMemberEvents 构造函数

初始化 WorkWechatGroupMemberEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatGroupMemberEvents(
    WorkWechatGroupMember data
)

参数

data
类型：WorkWechatGroupMember

[缺少 "M:Chat.Framework.PCRobotSDK.WorkWechatEvents.WorkWechatGroupMemberEvents.#ctor(PCRobot.Pack.WorkWechatGroupMember)" 的 <param name="data"/> 文档]

参见

引用

WorkWechatGroupMemberEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatGroupMemberEvents 属性

WorkWechatGroupMemberEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-获取到群成员信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WorkWechatGroupMemberEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatGroupMemberEvents.Data 属性

WorkWechatGroupMemberEventsData 属性

企业微信-获取到群成员信息

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatGroupMember Data { get; }

属性值

类型：WorkWechatGroupMember
参见

引用

WorkWechatGroupMemberEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatGroupMemberEvents 方法

WorkWechatGroupMemberEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WorkWechatGroupMemberEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewFriendEvents 类

企业微信-增加新好友事件
继承层次
SystemObject
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatNewFriendEvents

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WorkWechatNewFriendEvents

WorkWechatNewFriendEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WorkWechatNewFriendEvents | 初始化 WorkWechatNewFriendEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Data | 企业微信-增加新好友信息
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewFriendEvents 构造函数

初始化 WorkWechatNewFriendEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatNewFriendEvents(
    WorkWechatNewFriend data
)

参数

data
类型：WorkWechatNewFriend

[缺少 "M:Chat.Framework.PCRobotSDK.WorkWechatEvents.WorkWechatNewFriendEvents.#ctor(PCRobot.Pack.WorkWechatNewFriend)" 的 <param name="data"/> 文档]

参见

引用

WorkWechatNewFriendEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewFriendEvents 属性

WorkWechatNewFriendEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data | 企业微信-增加新好友信息
Top
参见

引用

WorkWechatNewFriendEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewFriendEvents.Data 属性

WorkWechatNewFriendEventsData 属性

企业微信-增加新好友信息

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatNewFriend Data { get; }

属性值

类型：WorkWechatNewFriend
参见

引用

WorkWechatNewFriendEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewFriendEvents 方法

WorkWechatNewFriendEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WorkWechatNewFriendEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewMemerEvents 类

企业微信-增加新群成员事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatNewMemerEvents

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WorkWechatNewMemerEvents : ChatEvent

WorkWechatNewMemerEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WorkWechatNewMemerEvents | 初始化 WorkWechatNewMemerEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-增加新群成员信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewMemerEvents 构造函数

初始化 WorkWechatNewMemerEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatNewMemerEvents(
    WorkWechatNewMemer data
)

参数

data
类型：WorkWechatNewMemer

[缺少 "M:Chat.Framework.PCRobotSDK.WorkWechatEvents.WorkWechatNewMemerEvents.#ctor(PCRobot.Pack.WorkWechatNewMemer)" 的 <param name="data"/> 文档]

参见

引用

WorkWechatNewMemerEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewMemerEvents 属性

WorkWechatNewMemerEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-增加新群成员信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WorkWechatNewMemerEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewMemerEvents.Data 属性

WorkWechatNewMemerEventsData 属性

企业微信-增加新群成员信息

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatNewMemer Data { get; }

属性值

类型：WorkWechatNewMemer
参见

引用

WorkWechatNewMemerEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatNewMemerEvents 方法

WorkWechatNewMemerEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WorkWechatNewMemerEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReceiveMsgEvents 类

企业微信-收到消息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatReceiveMsgEvents

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WorkWechatReceiveMsgEvents : ChatEvent

WorkWechatReceiveMsgEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WorkWechatReceiveMsgEvents | 初始化 WorkWechatReceiveMsgEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-收到消息信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReceiveMsgEvents 构造函数

初始化 WorkWechatReceiveMsgEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatReceiveMsgEvents(
    WorkWechatReceiveMsg msg
)

参数

msg
类型：WorkWechatReceiveMsg

[缺少 "M:Chat.Framework.PCRobotSDK.WorkWechatEvents.WorkWechatReceiveMsgEvents.#ctor(PCRobot.Pack.WorkWechatReceiveMsg)" 的 <param name="msg"/> 文档]

参见

引用

WorkWechatReceiveMsgEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReceiveMsgEvents 属性

WorkWechatReceiveMsgEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-收到消息信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WorkWechatReceiveMsgEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReceiveMsgEvents.Data 属性

WorkWechatReceiveMsgEventsData 属性

企业微信-收到消息信息

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatReceiveMsg Data { get; }

属性值

类型：WorkWechatReceiveMsg
参见

引用

WorkWechatReceiveMsgEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReceiveMsgEvents 方法

WorkWechatReceiveMsgEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WorkWechatReceiveMsgEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReicevePayEvents 类

企业微信-收到红包事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.PCRobotSDK.WorkWechatEventsWorkWechatReicevePayEvents

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WorkWechatReicevePayEvents : ChatEvent

WorkWechatReicevePayEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WorkWechatReicevePayEvents | 初始化 WorkWechatReicevePayEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-收到红包信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReicevePayEvents 构造函数

初始化 WorkWechatReicevePayEvents 类的一个新实例

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatReicevePayEvents(
    WorkWechatReicevePay data
)

参数

data
类型：WorkWechatReicevePay

[缺少 "M:Chat.Framework.PCRobotSDK.WorkWechatEvents.WorkWechatReicevePayEvents.#ctor(PCRobot.Pack.WorkWechatReicevePay)" 的 <param name="data"/> 文档]

参见

引用

WorkWechatReicevePayEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReicevePayEvents 属性

WorkWechatReicevePayEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Data | 企业微信-收到红包信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WorkWechatReicevePayEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReicevePayEvents.Data 属性

WorkWechatReicevePayEventsData 属性

企业微信-收到红包信息

命名空间： Chat.Framework.PCRobotSDK.WorkWechatEvents
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WorkWechatReicevePay Data { get; }

属性值

类型：WorkWechatReicevePay
参见

引用

WorkWechatReicevePayEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


WorkWechatReicevePayEvents 方法

WorkWechatReicevePayEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WorkWechatReicevePayEvents 类
Chat.Framework.PCRobotSDK.WorkWechatEvents 命名空间


Chat.Framework.QQSdk 命名空间

[缺少 "N:Chat.Framework.QQSdk" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | QQBase | QQ基类
公共类 | QQEventManage | QQ事件管理


QQBase 类

QQ基类
继承层次
SystemObject
Chat.Framework.QQSdkQQBase
Chat.Framework.QQSdk.QPlusQQClientImpl_QQPlus

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public abstract class QQBase

QQBase 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | QQBase | 初始化 QQBase 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | EndTime |
公共属性 | IsEQQ | 是否企业QQ
公共属性 | IsLogin | 是否已经登录
受保护的属性 | IsRegisterEvent |
公共属性 | Nickname | 昵称
公共属性 | Password | 密码
公共属性 | QQ | QQ
Top
方法
 | 名称 | 说明
公共方法 | AerifyAddGroup | 同意用户入群
公共方法 | AerifyAddMe | 同意好友添加
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Login | 登录
公共方法 | Logout | 退出登录
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnLog | 发送日志
公共方法 | SendFriendImage | 发送好友图片消息
公共方法 | SendFriendMessage | 发送好友消息
公共方法 | SendGroupImage | 发送群图片消息
公共方法 | SendGroupMessage | 发送群消息
公共方法 | SendMessage | 发送消息
公共方法 | SendTempMessage(UInt32, String) | 发送临时消息
公共方法 | SendTempMessage(UInt32, String, Byte) | 发送临时消息
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk 命名空间


QQBase 构造函数

初始化 QQBase 类的一个新实例

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected QQBase()
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase 属性

QQBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | EndTime |
公共属性 | IsEQQ | 是否企业QQ
公共属性 | IsLogin | 是否已经登录
受保护的属性 | IsRegisterEvent |
公共属性 | Nickname | 昵称
公共属性 | Password | 密码
公共属性 | QQ | QQ
Top
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.EndTime 属性

QQBaseEndTime 属性

[缺少 "P:Chat.Framework.QQSdk.QQBase.EndTime" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime EndTime { get; }

属性值

类型：DateTime
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.IsEQQ 属性

QQBaseIsEQQ 属性

是否企业QQ

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsEQQ { get; set; }

属性值

类型：Boolean
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.IsLogin 属性

QQBaseIsLogin 属性

是否已经登录

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsLogin { get; }

属性值

类型：Boolean
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.IsRegisterEvent 属性

QQBaseIsRegisterEvent 属性

[缺少 "P:Chat.Framework.QQSdk.QQBase.IsRegisterEvent" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected bool IsRegisterEvent { get; set; }

属性值

类型：Boolean
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.Nickname 属性

QQBaseNickname 属性

昵称

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Nickname { get; protected set; }

属性值

类型：String
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.Password 属性

QQBasePassword 属性

密码

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Password { get; }

属性值

类型：String
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.QQ 属性

QQBaseQQ 属性

QQ

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint QQ { get; protected set; }

属性值

类型：UInt32
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase 方法

QQBase 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AerifyAddGroup | 同意用户入群
公共方法 | AerifyAddMe | 同意好友添加
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Login | 登录
公共方法 | Logout | 退出登录
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnLog | 发送日志
公共方法 | SendFriendImage | 发送好友图片消息
公共方法 | SendFriendMessage | 发送好友消息
公共方法 | SendGroupImage | 发送群图片消息
公共方法 | SendGroupMessage | 发送群消息
公共方法 | SendMessage | 发送消息
公共方法 | SendTempMessage(UInt32, String) | 发送临时消息
公共方法 | SendTempMessage(UInt32, String, Byte) | 发送临时消息
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.AerifyAddGroup 方法

QQBaseAerifyAddGroup 方法

同意用户入群

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void AerifyAddGroup(
    uint groupId,
    uint QQ,
    bool Agree = true,
    string Message = ""
)

参数

groupId
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QQBase.AerifyAddGroup(System.UInt32,System.UInt32,System.Boolean,System.String)" 的 <param name="groupId"/> 文档]

QQ
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QQBase.AerifyAddGroup(System.UInt32,System.UInt32,System.Boolean,System.String)" 的 <param name="QQ"/> 文档]

Agree (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.QQSdk.QQBase.AerifyAddGroup(System.UInt32,System.UInt32,System.Boolean,System.String)" 的 <param name="Agree"/> 文档]

Message (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QQBase.AerifyAddGroup(System.UInt32,System.UInt32,System.Boolean,System.String)" 的 <param name="Message"/> 文档]

参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.AerifyAddMe 方法

QQBaseAerifyAddMe 方法

同意好友添加

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void AerifyAddMe(
    uint QQ,
    byte Agree = 4,
    string Message = ""
)

参数

QQ
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QQBase.AerifyAddMe(System.UInt32,System.Byte,System.String)" 的 <param name="QQ"/> 文档]

Agree (Optional)
类型：SystemByte
3:同意并添加对方为好友;4:同意;5:拒绝
Message (Optional)
类型：SystemString
理由
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.Login 方法

QQBaseLogin 方法

登录

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void Login()
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.Logout 方法

QQBaseLogout 方法

退出登录

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void Logout()
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.OnLog 方法

QQBaseOnLog 方法

发送日志

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected void OnLog(
    string Message
)

参数

Message
类型：SystemString
日志内容
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.SendFriendImage 方法

QQBaseSendFriendImage 方法

发送好友图片消息

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendFriendImage(
    uint QQ,
    string ImageSrc
)

参数

QQ
类型：SystemUInt32
QQ号
ImageSrc
类型：SystemString
消息内容
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.SendFriendMessage 方法

QQBaseSendFriendMessage 方法

发送好友消息

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendFriendMessage(
    uint QQ,
    string Message
)

参数

QQ
类型：SystemUInt32
QQ
Message
类型：SystemString
消息的内容
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.SendGroupImage 方法

QQBaseSendGroupImage 方法

发送群图片消息

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendGroupImage(
    uint GroupId,
    string ImageSrc
)

参数

GroupId
类型：SystemUInt32
群号
ImageSrc
类型：SystemString
图片地址,支持本机或网络图片
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.SendGroupMessage 方法

QQBaseSendGroupMessage 方法

发送群消息

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendGroupMessage(
    uint GroupId,
    string Message
)

参数

GroupId
类型：SystemUInt32
群号
Message
类型：SystemString
图片地址,支持本机或网络图片
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.SendMessage 方法

QQBaseSendMessage 方法

发送消息

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual Task<bool> SendMessage(
    uint username,
    string message,
    bool isGroup = false,
    bool isTemp = false
)

参数

username
类型：SystemUInt32
发送至
message
类型：SystemString
发送的内容
isGroup (Optional)
类型：SystemBoolean
是否群消息
isTemp (Optional)
类型：SystemBoolean
临时会话?

返回值

类型：Task Boolean
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.SendTempMessage 方法

QQBaseSendTempMessage 方法

重载列表
 | 名称 | 说明
公共方法 | SendTempMessage(UInt32, String) | 发送临时消息
公共方法 | SendTempMessage(UInt32, String, Byte) | 发送临时消息
Top
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQBase.SendTempMessage 方法 (UInt32, String)

QQBaseSendTempMessage 方法 (UInt32, String)

发送临时消息

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendTempMessage(
    uint QQ,
    string Message
)

参数

QQ
类型：SystemUInt32
QQ
Message
类型：SystemString
发送的消息
参见

引用

QQBase 类
SendTempMessage 重载
Chat.Framework.QQSdk 命名空间


QQBase.SendTempMessage 方法 (UInt32, String, Byte[])

QQBaseSendTempMessage 方法 (UInt32, String, Byte)

发送临时消息

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendTempMessage(
    uint QQ,
    string Message,
    byte[] Token
)

参数

QQ
类型：SystemUInt32
QQ
Message
类型：SystemString
发送的消息
Token
类型：SystemByte
Token
参见

引用

QQBase 类
SendTempMessage 重载
Chat.Framework.QQSdk 命名空间


QQBase.ToString 方法

QQBaseToString 方法

[缺少 "M:Chat.Framework.QQSdk.QQBase.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

QQBase 类
Chat.Framework.QQSdk 命名空间


QQEventManage 类

QQ事件管理
继承层次
SystemObject
Chat.Framework.QQSdkQQEventManage

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQEventManage

QQEventManage 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQEventManage | 初始化 QQEventManage 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | OnEvent(QQLoginChangeEvents) | QQ登录状态发生改变调用
公共方法 | OnEvent(QQRefreshUser) | QQ信息发生改变调用
公共方法 | ToString | (继承自 Object。)
Top
事件
 | 名称 | 说明
公共事件 | LoginChangeEvent | QQ登陆状态发生改变事件
公共事件 | QQAddMeNeedAuthEvents | QQ有人添加我为好友,需要审核事件
公共事件 | QQAddToClusterNeedAuthEvents | QQ有人进群,需要审核事件
公共事件 | QQLogEvents | 日志消息事件
公共事件 | QQNewFriendEvents | QQ有人添加我为好友事件
公共事件 | QQNewGroupMemberEvents | QQ群新增成员事件
公共事件 | QQReceiveFriendMsgEvents | QQ收到好友消息事件
公共事件 | QQReceiveGroupMsgEvents | QQ收到群消息事件
公共事件 | QQRefreshUserEvent | QQ信息发生改变事件
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk 命名空间


QQEventManage 构造函数

初始化 QQEventManage 类的一个新实例

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQEventManage()
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage 方法

QQEventManage 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | OnEvent(QQLoginChangeEvents) | QQ登录状态发生改变调用
公共方法 | OnEvent(QQRefreshUser) | QQ信息发生改变调用
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.OnEvent 方法

QQEventManageOnEvent 方法

重载列表
 | 名称 | 说明
公共方法 | OnEvent(QQLoginChangeEvents) | QQ登录状态发生改变调用
公共方法 | OnEvent(QQRefreshUser) | QQ信息发生改变调用
Top
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.OnEvent 方法 (QQLoginChangeEvents)

QQEventManageOnEvent 方法 (QQLoginChangeEvents)

QQ登录状态发生改变调用

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void OnEvent(
    QQLoginChangeEvents e
)

参数

e
类型：Chat.Framework.QQSdk.EventsQQLoginChangeEvents

[缺少 "M:Chat.Framework.QQSdk.QQEventManage.OnEvent(Chat.Framework.QQSdk.Events.QQLoginChangeEvents)" 的 <param name="e"/> 文档]

参见

引用

QQEventManage 类
OnEvent 重载
Chat.Framework.QQSdk 命名空间


QQEventManage.OnEvent 方法 (QQRefreshUser)

QQEventManageOnEvent 方法 (QQRefreshUser)

QQ信息发生改变调用

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void OnEvent(
    QQRefreshUser e
)

参数

e
类型：Chat.Framework.QQSdk.EventsQQRefreshUser

[缺少 "M:Chat.Framework.QQSdk.QQEventManage.OnEvent(Chat.Framework.QQSdk.Events.QQRefreshUser)" 的 <param name="e"/> 文档]

参见

引用

QQEventManage 类
OnEvent 重载
Chat.Framework.QQSdk 命名空间


QQEventManage 事件

QQEventManage 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | LoginChangeEvent | QQ登陆状态发生改变事件
公共事件 | QQAddMeNeedAuthEvents | QQ有人添加我为好友,需要审核事件
公共事件 | QQAddToClusterNeedAuthEvents | QQ有人进群,需要审核事件
公共事件 | QQLogEvents | 日志消息事件
公共事件 | QQNewFriendEvents | QQ有人添加我为好友事件
公共事件 | QQNewGroupMemberEvents | QQ群新增成员事件
公共事件 | QQReceiveFriendMsgEvents | QQ收到好友消息事件
公共事件 | QQReceiveGroupMsgEvents | QQ收到群消息事件
公共事件 | QQRefreshUserEvent | QQ信息发生改变事件
Top
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.LoginChangeEvent 事件

QQEventManageLoginChangeEvent 事件

QQ登陆状态发生改变事件

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQLoginChangeEvents> LoginChangeEvent

值

类型：SystemEventHandler QQLoginChangeEvents
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.QQAddMeNeedAuthEvents 事件

QQEventManageQQAddMeNeedAuthEvents 事件

QQ有人添加我为好友,需要审核事件

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQAddMeNeedAuthEvents> QQAddMeNeedAuthEvents

值

类型：SystemEventHandler QQAddMeNeedAuthEvents
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.QQAddToClusterNeedAuthEvents 事件

QQEventManageQQAddToClusterNeedAuthEvents 事件

QQ有人进群,需要审核事件

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQAddToClusterNeedAuthEvents> QQAddToClusterNeedAuthEvents

值

类型：SystemEventHandler QQAddToClusterNeedAuthEvents
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.QQLogEvents 事件

QQEventManageQQLogEvents 事件

日志消息事件

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQLogEvents> QQLogEvents

值

类型：SystemEventHandler QQLogEvents
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.QQNewFriendEvents 事件

QQEventManageQQNewFriendEvents 事件

QQ有人添加我为好友事件

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQNewFriendEvents> QQNewFriendEvents

值

类型：SystemEventHandler QQNewFriendEvents
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.QQNewGroupMemberEvents 事件

QQEventManageQQNewGroupMemberEvents 事件

QQ群新增成员事件

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQNewGroupMemberEvents> QQNewGroupMemberEvents

值

类型：SystemEventHandler QQNewGroupMemberEvents
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.QQReceiveFriendMsgEvents 事件

QQEventManageQQReceiveFriendMsgEvents 事件

QQ收到好友消息事件

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQReceiveFriendMsgEvents> QQReceiveFriendMsgEvents

值

类型：SystemEventHandler QQReceiveFriendMsgEvents
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.QQReceiveGroupMsgEvents 事件

QQEventManageQQReceiveGroupMsgEvents 事件

QQ收到群消息事件

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQReceiveGroupMsgEvents> QQReceiveGroupMsgEvents

值

类型：SystemEventHandler QQReceiveGroupMsgEvents
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


QQEventManage.QQRefreshUserEvent 事件

QQEventManageQQRefreshUserEvent 事件

QQ信息发生改变事件

命名空间： Chat.Framework.QQSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<QQRefreshUser> QQRefreshUserEvent

值

类型：SystemEventHandler QQRefreshUser
参见

引用

QQEventManage 类
Chat.Framework.QQSdk 命名空间


Chat.Framework.QQSdk.Events 命名空间

[缺少 "N:Chat.Framework.QQSdk.Events" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | QQAddMeNeedAuthEvents | QQ收到好友申请事件
公共类 | QQAddToClusterNeedAuthEvents | QQ新人申请加好友事件
公共类 | QQEvents | QQ事件基类
公共类 | QQLogEvents | QQ日志事件
公共类 | QQLoginChangeEvents | QQ登录状态改变事件
公共类 | QQLostConnectionEvents | QQ失去连接事件
公共类 | QQNewFriendEvents | QQ增加新好友事件
公共类 | QQNewGroupMemberEvents | QQ群新增加群成员事件
公共类 | QQReceiveFriendMsgEvents | QQ收到私人消息事件
公共类 | QQReceiveGroupMsgEvents | QQ收到群消息事件
公共类 | QQRefreshUser | QQ更新信息事件


QQAddMeNeedAuthEvents 类

QQ收到好友申请事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQAddMeNeedAuthEvents

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQAddMeNeedAuthEvents : QQEvents

QQAddMeNeedAuthEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQAddMeNeedAuthEvents | 初始化 QQAddMeNeedAuthEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 用户的申请提示
公共属性 | Nickname | 申请用户昵称
公共属性 | QQ | 申请用户QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQAddMeNeedAuthEvents 构造函数

初始化 QQAddMeNeedAuthEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQAddMeNeedAuthEvents(
    QQBase QQBase
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQAddMeNeedAuthEvents.#ctor(Chat.Framework.QQSdk.QQBase)" 的 <param name="QQBase"/> 文档]

参见

引用

QQAddMeNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddMeNeedAuthEvents 属性

QQAddMeNeedAuthEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 用户的申请提示
公共属性 | Nickname | 申请用户昵称
公共属性 | QQ | 申请用户QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQAddMeNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddMeNeedAuthEvents.Message 属性

QQAddMeNeedAuthEventsMessage 属性

用户的申请提示

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

QQAddMeNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddMeNeedAuthEvents.Nickname 属性

QQAddMeNeedAuthEventsNickname 属性

申请用户昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Nickname { get; }

属性值

类型：String
参见

引用

QQAddMeNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddMeNeedAuthEvents.QQ 属性

QQAddMeNeedAuthEventsQQ 属性

申请用户QQ

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint QQ { get; set; }

属性值

类型：UInt32
参见

引用

QQAddMeNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddMeNeedAuthEvents 方法

QQAddMeNeedAuthEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQAddMeNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddMeNeedAuthEvents.ToString 方法

QQAddMeNeedAuthEventsToString 方法

[缺少 "M:Chat.Framework.QQSdk.Events.QQAddMeNeedAuthEvents.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

QQAddMeNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents 类

QQ新人申请加好友事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQAddToClusterNeedAuthEvents

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQAddToClusterNeedAuthEvents : QQEvents

QQAddToClusterNeedAuthEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQAddToClusterNeedAuthEvents | 初始化 QQAddToClusterNeedAuthEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | ClusterId | 群ID
公共属性 | Creator | 群创建者QQ
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | GroupId | 群账号
公共属性 | GroupName | 群昵称
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 用户的申请提示
公共属性 | Nickname | 申请用户昵称
公共属性 | QQ | 申请用户QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents 构造函数

初始化 QQAddToClusterNeedAuthEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQAddToClusterNeedAuthEvents(
    QQBase QQBase
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQAddToClusterNeedAuthEvents.#ctor(Chat.Framework.QQSdk.QQBase)" 的 <param name="QQBase"/> 文档]

参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents 属性

QQAddToClusterNeedAuthEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | ClusterId | 群ID
公共属性 | Creator | 群创建者QQ
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | GroupId | 群账号
公共属性 | GroupName | 群昵称
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 用户的申请提示
公共属性 | Nickname | 申请用户昵称
公共属性 | QQ | 申请用户QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents.ClusterId 属性

QQAddToClusterNeedAuthEventsClusterId 属性

群ID

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint ClusterId { get; set; }

属性值

类型：UInt32
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents.Creator 属性

QQAddToClusterNeedAuthEventsCreator 属性

群创建者QQ

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint Creator { get; }

属性值

类型：UInt32
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents.GroupId 属性

QQAddToClusterNeedAuthEventsGroupId 属性

群账号

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint GroupId { get; }

属性值

类型：UInt32
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents.GroupName 属性

QQAddToClusterNeedAuthEventsGroupName 属性

群昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GroupName { get; }

属性值

类型：String
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents.Message 属性

QQAddToClusterNeedAuthEventsMessage 属性

用户的申请提示

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents.Nickname 属性

QQAddToClusterNeedAuthEventsNickname 属性

申请用户昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Nickname { get; }

属性值

类型：String
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents.QQ 属性

QQAddToClusterNeedAuthEventsQQ 属性

申请用户QQ

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint QQ { get; set; }

属性值

类型：UInt32
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents 方法

QQAddToClusterNeedAuthEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQAddToClusterNeedAuthEvents.ToString 方法

QQAddToClusterNeedAuthEventsToString 方法

[缺少 "M:Chat.Framework.QQSdk.Events.QQAddToClusterNeedAuthEvents.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

QQAddToClusterNeedAuthEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQEvents 类

QQ事件基类
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
更多...

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQEvents : ChatEvent

QQEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQEvents | 初始化 QQEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | QQBase | QQ基类
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQAddMeNeedAuthEvents
Chat.Framework.QQSdk.EventsQQAddToClusterNeedAuthEvents
Chat.Framework.QQSdk.EventsQQLogEvents
Chat.Framework.QQSdk.EventsQQLoginChangeEvents
Chat.Framework.QQSdk.EventsQQLostConnectionEvents
Chat.Framework.QQSdk.EventsQQNewFriendEvents
Chat.Framework.QQSdk.EventsQQNewGroupMemberEvents
Chat.Framework.QQSdk.EventsQQReceiveFriendMsgEvents
Chat.Framework.QQSdk.EventsQQReceiveGroupMsgEvents
Chat.Framework.QQSdk.EventsQQRefreshUser


QQEvents 构造函数

初始化 QQEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQEvents(
    QQBase QQBase
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQEvents.#ctor(Chat.Framework.QQSdk.QQBase)" 的 <param name="QQBase"/> 文档]

参见

引用

QQEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQEvents 属性

QQEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | QQBase | QQ基类
Top
参见

引用

QQEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQEvents.QQBase 属性

QQEventsQQBase 属性

QQ基类

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQBase QQBase { get; }

属性值

类型：QQBase
参见

引用

QQEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQEvents 方法

QQEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLogEvents 类

QQ日志事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQLogEvents

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQLogEvents : QQEvents

QQLogEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQLogEvents | 初始化 QQLogEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 日志内容
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQLogEvents 构造函数

初始化 QQLogEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQLogEvents(
    QQBase client
)

参数

client
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQLogEvents.#ctor(Chat.Framework.QQSdk.QQBase)" 的 <param name="client"/> 文档]

参见

引用

QQLogEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLogEvents 属性

QQLogEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 日志内容
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQLogEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLogEvents.Message 属性

QQLogEventsMessage 属性

日志内容

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

QQLogEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLogEvents 方法

QQLogEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQLogEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLoginChangeEvents 类

QQ登录状态改变事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQLoginChangeEvents

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQLoginChangeEvents : QQEvents

QQLoginChangeEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQLoginChangeEvents | 初始化 QQLoginChangeEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsLogin | 是否已经登录
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 登录附带信息
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQLoginChangeEvents 构造函数

初始化 QQLoginChangeEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQLoginChangeEvents(
    QQBase QQBase,
    bool IsLogin,
    string Message
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQLoginChangeEvents.#ctor(Chat.Framework.QQSdk.QQBase,System.Boolean,System.String)" 的 <param name="QQBase"/> 文档]

IsLogin
类型：SystemBoolean

[缺少 "M:Chat.Framework.QQSdk.Events.QQLoginChangeEvents.#ctor(Chat.Framework.QQSdk.QQBase,System.Boolean,System.String)" 的 <param name="IsLogin"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.Events.QQLoginChangeEvents.#ctor(Chat.Framework.QQSdk.QQBase,System.Boolean,System.String)" 的 <param name="Message"/> 文档]

参见

引用

QQLoginChangeEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLoginChangeEvents 属性

QQLoginChangeEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsLogin | 是否已经登录
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 登录附带信息
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQLoginChangeEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLoginChangeEvents.IsLogin 属性

QQLoginChangeEventsIsLogin 属性

是否已经登录

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsLogin { get; }

属性值

类型：Boolean
参见

引用

QQLoginChangeEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLoginChangeEvents.Message 属性

QQLoginChangeEventsMessage 属性

登录附带信息

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

QQLoginChangeEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLoginChangeEvents 方法

QQLoginChangeEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQLoginChangeEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLoginChangeEvents.ToString 方法

QQLoginChangeEventsToString 方法

[缺少 "M:Chat.Framework.QQSdk.Events.QQLoginChangeEvents.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

QQLoginChangeEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLostConnectionEvents 类

QQ失去连接事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQLostConnectionEvents

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQLostConnectionEvents : QQEvents

QQLostConnectionEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQLostConnectionEvents | 初始化 QQLostConnectionEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQLostConnectionEvents 构造函数

初始化 QQLostConnectionEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQLostConnectionEvents(
    QQBase QQBase,
    string message
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQLostConnectionEvents.#ctor(Chat.Framework.QQSdk.QQBase,System.String)" 的 <param name="QQBase"/> 文档]

message
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.Events.QQLostConnectionEvents.#ctor(Chat.Framework.QQSdk.QQBase,System.String)" 的 <param name="message"/> 文档]

参见

引用

QQLostConnectionEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLostConnectionEvents 属性

QQLostConnectionEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQLostConnectionEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLostConnectionEvents.Message 属性

QQLostConnectionEventsMessage 属性

消息

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; set; }

属性值

类型：String
参见

引用

QQLostConnectionEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQLostConnectionEvents 方法

QQLostConnectionEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQLostConnectionEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewFriendEvents 类

QQ增加新好友事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQNewFriendEvents

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQNewFriendEvents : QQEvents

QQNewFriendEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQNewFriendEvents | 初始化 QQNewFriendEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Nickname | 昵称
公共属性 | QQ | QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQNewFriendEvents 构造函数

初始化 QQNewFriendEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQNewFriendEvents(
    QQBase QQBase
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQNewFriendEvents.#ctor(Chat.Framework.QQSdk.QQBase)" 的 <param name="QQBase"/> 文档]

参见

引用

QQNewFriendEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewFriendEvents 属性

QQNewFriendEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Nickname | 昵称
公共属性 | QQ | QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQNewFriendEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewFriendEvents.Nickname 属性

QQNewFriendEventsNickname 属性

昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Nickname { get; }

属性值

类型：String
参见

引用

QQNewFriendEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewFriendEvents.QQ 属性

QQNewFriendEventsQQ 属性

QQ

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint QQ { get; }

属性值

类型：UInt32
参见

引用

QQNewFriendEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewFriendEvents 方法

QQNewFriendEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQNewFriendEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents 类

QQ群新增加群成员事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQNewGroupMemberEvents

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQNewGroupMemberEvents : QQEvents

QQNewGroupMemberEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQNewGroupMemberEvents | 初始化 QQNewGroupMemberEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Creator | 群创建者QQ
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | GroupId | 群账号
公共属性 | GroupName | 群昵称
公共属性 | InviteNick | 推荐者昵称
公共属性 | InviteQQ | 推荐者QQ
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | NewFriendNick | 新用户昵称
公共属性 | NewFriendQQ | 新用户QQ
公共属性 | Operator | 操作员
公共属性 | OperatorName | 操作员昵称
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents 构造函数

初始化 QQNewGroupMemberEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQNewGroupMemberEvents(
    QQBase QQBase
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQNewGroupMemberEvents.#ctor(Chat.Framework.QQSdk.QQBase)" 的 <param name="QQBase"/> 文档]

参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents 属性

QQNewGroupMemberEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Creator | 群创建者QQ
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | GroupId | 群账号
公共属性 | GroupName | 群昵称
公共属性 | InviteNick | 推荐者昵称
公共属性 | InviteQQ | 推荐者QQ
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | NewFriendNick | 新用户昵称
公共属性 | NewFriendQQ | 新用户QQ
公共属性 | Operator | 操作员
公共属性 | OperatorName | 操作员昵称
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.Creator 属性

QQNewGroupMemberEventsCreator 属性

群创建者QQ

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint Creator { get; }

属性值

类型：UInt32
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.GroupId 属性

QQNewGroupMemberEventsGroupId 属性

群账号

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint GroupId { get; }

属性值

类型：UInt32
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.GroupName 属性

QQNewGroupMemberEventsGroupName 属性

群昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GroupName { get; }

属性值

类型：String
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.InviteNick 属性

QQNewGroupMemberEventsInviteNick 属性

推荐者昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string InviteNick { get; }

属性值

类型：String
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.InviteQQ 属性

QQNewGroupMemberEventsInviteQQ 属性

推荐者QQ

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint InviteQQ { get; }

属性值

类型：UInt32
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.NewFriendNick 属性

QQNewGroupMemberEventsNewFriendNick 属性

新用户昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string NewFriendNick { get; }

属性值

类型：String
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.NewFriendQQ 属性

QQNewGroupMemberEventsNewFriendQQ 属性

新用户QQ

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint NewFriendQQ { get; }

属性值

类型：UInt32
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.Operator 属性

QQNewGroupMemberEventsOperator 属性

操作员

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint Operator { get; }

属性值

类型：UInt32
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.OperatorName 属性

QQNewGroupMemberEventsOperatorName 属性

操作员昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string OperatorName { get; }

属性值

类型：String
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents 方法

QQNewGroupMemberEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQNewGroupMemberEvents.ToString 方法

QQNewGroupMemberEventsToString 方法

[缺少 "M:Chat.Framework.QQSdk.Events.QQNewGroupMemberEvents.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

QQNewGroupMemberEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveFriendMsgEvents 类

QQ收到私人消息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQReceiveFriendMsgEvents

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQReceiveFriendMsgEvents : QQEvents

QQReceiveFriendMsgEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQReceiveFriendMsgEvents | 初始化 QQReceiveFriendMsgEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsTemp | 是否是临时消息
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 收到消息内容
公共属性 | Nickname | 发送消息的用户昵称
公共属性 | QQ | 发送消息的用户QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQReceiveFriendMsgEvents 构造函数

初始化 QQReceiveFriendMsgEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQReceiveFriendMsgEvents(
    QQBase QQBase
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQReceiveFriendMsgEvents.#ctor(Chat.Framework.QQSdk.QQBase)" 的 <param name="QQBase"/> 文档]

参见

引用

QQReceiveFriendMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveFriendMsgEvents 属性

QQReceiveFriendMsgEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsTemp | 是否是临时消息
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 收到消息内容
公共属性 | Nickname | 发送消息的用户昵称
公共属性 | QQ | 发送消息的用户QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQReceiveFriendMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveFriendMsgEvents.IsTemp 属性

QQReceiveFriendMsgEventsIsTemp 属性

是否是临时消息

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsTemp { get; }

属性值

类型：Boolean
参见

引用

QQReceiveFriendMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveFriendMsgEvents.Message 属性

QQReceiveFriendMsgEventsMessage 属性

收到消息内容

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

QQReceiveFriendMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveFriendMsgEvents.Nickname 属性

QQReceiveFriendMsgEventsNickname 属性

发送消息的用户昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Nickname { get; }

属性值

类型：String
参见

引用

QQReceiveFriendMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveFriendMsgEvents.QQ 属性

QQReceiveFriendMsgEventsQQ 属性

发送消息的用户QQ

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint QQ { get; }

属性值

类型：UInt32
参见

引用

QQReceiveFriendMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveFriendMsgEvents 方法

QQReceiveFriendMsgEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQReceiveFriendMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveFriendMsgEvents.ToString 方法

QQReceiveFriendMsgEventsToString 方法

[缺少 "M:Chat.Framework.QQSdk.Events.QQReceiveFriendMsgEvents.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

QQReceiveFriendMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents 类

QQ收到群消息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQReceiveGroupMsgEvents

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQReceiveGroupMsgEvents : QQEvents

QQReceiveGroupMsgEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQReceiveGroupMsgEvents | 初始化 QQReceiveGroupMsgEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | GroupId | 群账号
公共属性 | GroupName | 群昵称
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息
公共属性 | Nickname | 昵称
公共属性 | QQ | QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents 构造函数

初始化 QQReceiveGroupMsgEvents 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQReceiveGroupMsgEvents(
    QQBase QQBase
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQReceiveGroupMsgEvents.#ctor(Chat.Framework.QQSdk.QQBase)" 的 <param name="QQBase"/> 文档]

参见

引用

QQReceiveGroupMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents 属性

QQReceiveGroupMsgEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | GroupId | 群账号
公共属性 | GroupName | 群昵称
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息
公共属性 | Nickname | 昵称
公共属性 | QQ | QQ
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQReceiveGroupMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents.GroupId 属性

QQReceiveGroupMsgEventsGroupId 属性

群账号

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint GroupId { get; }

属性值

类型：UInt32
参见

引用

QQReceiveGroupMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents.GroupName 属性

QQReceiveGroupMsgEventsGroupName 属性

群昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GroupName { get; }

属性值

类型：String
参见

引用

QQReceiveGroupMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents.Message 属性

QQReceiveGroupMsgEventsMessage 属性

消息

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

QQReceiveGroupMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents.Nickname 属性

QQReceiveGroupMsgEventsNickname 属性

昵称

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Nickname { get; }

属性值

类型：String
参见

引用

QQReceiveGroupMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents.QQ 属性

QQReceiveGroupMsgEventsQQ 属性

QQ

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public uint QQ { get; }

属性值

类型：UInt32
参见

引用

QQReceiveGroupMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents 方法

QQReceiveGroupMsgEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQReceiveGroupMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQReceiveGroupMsgEvents.ToString 方法

QQReceiveGroupMsgEventsToString 方法

[缺少 "M:Chat.Framework.QQSdk.Events.QQReceiveGroupMsgEvents.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

QQReceiveGroupMsgEvents 类
Chat.Framework.QQSdk.Events 命名空间


QQRefreshUser 类

QQ更新信息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.QQSdk.EventsQQEvents
Chat.Framework.QQSdk.EventsQQRefreshUser

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQRefreshUser : QQEvents

QQRefreshUser 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | QQRefreshUser | 初始化 QQRefreshUser 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.Events 命名空间


QQRefreshUser 构造函数

初始化 QQRefreshUser 类的一个新实例

命名空间： Chat.Framework.QQSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQRefreshUser(
    QQBase QQBase
)

参数

QQBase
类型：Chat.Framework.QQSdkQQBase

[缺少 "M:Chat.Framework.QQSdk.Events.QQRefreshUser.#ctor(Chat.Framework.QQSdk.QQBase)" 的 <param name="QQBase"/> 文档]

参见

引用

QQRefreshUser 类
Chat.Framework.QQSdk.Events 命名空间


QQRefreshUser 属性

QQRefreshUser 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | QQBase | QQ基类 (继承自 QQEvents。)
Top
参见

引用

QQRefreshUser 类
Chat.Framework.QQSdk.Events 命名空间


QQRefreshUser 方法

QQRefreshUser 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQRefreshUser 类
Chat.Framework.QQSdk.Events 命名空间


Chat.Framework.QQSdk.QPlus 命名空间

[缺少 "N:Chat.Framework.QQSdk.QPlus" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | FormSlide | QQ滑动验证码窗体
公共类 | QQClientImpl_QQPlus | QQ客户端管理
公共类 | QQLoginForm | QQ登录窗体


FormSlide 类

QQ滑动验证码窗体
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Chat.Framework.QQSdk.QPlusFormSlide

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class FormSlide : Form

FormSlide 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FormSlide | 初始化 FormSlide 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 Form。)
公共属性 | BackgroundImage | (继承自 Control。)
公共属性 | BackgroundImageLayout | (继承自 Control。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 Form。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 Control。)
受保护的属性 | FontHeight | (继承自 Control。)
公共属性 | ForeColor | (继承自 Control。)
公共属性 | FormBorderStyle | (继承自 Form。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | Icon | (继承自 Form。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 Form。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 Form。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 Control。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 Form。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
公共方法 | Close | (继承自 Form。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 Form。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 Form。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 FormDispose(Boolean).)
公共方法 | DoDragDrop | (继承自 Control。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
公共方法 | GetContainerControl | (继承自 Control。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 Form。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 Control。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 Form。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 Form。)
受保护的方法 | OnHandleDestroyed | (继承自 Form。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 Form。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 Form。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumSizeChanged | (继承自 Form。)
受保护的方法 | OnMdiChildActivate | (继承自 Form。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumSizeChanged | (继承自 Form。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 ScrollableControl。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 Form。)
受保护的方法 | OnPaintBackground | (继承自 ScrollableControl。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 ContainerControl。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShown | (继承自 Form。)
受保护的方法 | OnSizeChanged | (继承自 Control。)
受保护的方法 | OnStyleChanged | (继承自 Form。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 Form。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 Control。)
公共方法 | ResumeLayout(Boolean) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 Form。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 Form。)
受保护的方法 | SetClientSizeCore | (继承自 Form。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 Form。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 Form。)
受保护的方法 | SizeFromClientSize | (继承自 Control。)
公共方法 | SuspendLayout | (继承自 Control。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 Form。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.QPlus 命名空间


FormSlide 构造函数

初始化 FormSlide 类的一个新实例

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public FormSlide()
参见

引用

FormSlide 类
Chat.Framework.QQSdk.QPlus 命名空间


FormSlide 属性

FormSlide 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 Form。)
公共属性 | BackgroundImage | (继承自 Control。)
公共属性 | BackgroundImageLayout | (继承自 Control。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 Form。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 Control。)
受保护的属性 | FontHeight | (继承自 Control。)
公共属性 | ForeColor | (继承自 Control。)
公共属性 | FormBorderStyle | (继承自 Form。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | Icon | (继承自 Form。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 Form。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 Form。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 Control。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 Form。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

FormSlide 类
Chat.Framework.QQSdk.QPlus 命名空间


FormSlide 方法

FormSlide 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
公共方法 | Close | (继承自 Form。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 Form。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 Form。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 FormDispose(Boolean).)
公共方法 | DoDragDrop | (继承自 Control。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
公共方法 | GetContainerControl | (继承自 Control。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 Form。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 Control。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 Form。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 Form。)
受保护的方法 | OnHandleDestroyed | (继承自 Form。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 Form。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 Form。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumSizeChanged | (继承自 Form。)
受保护的方法 | OnMdiChildActivate | (继承自 Form。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumSizeChanged | (继承自 Form。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 ScrollableControl。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 Form。)
受保护的方法 | OnPaintBackground | (继承自 ScrollableControl。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 ContainerControl。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShown | (继承自 Form。)
受保护的方法 | OnSizeChanged | (继承自 Control。)
受保护的方法 | OnStyleChanged | (继承自 Form。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 Form。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 Control。)
公共方法 | ResumeLayout(Boolean) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 Form。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 Form。)
受保护的方法 | SetClientSizeCore | (继承自 Form。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 Form。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 Form。)
受保护的方法 | SizeFromClientSize | (继承自 Control。)
公共方法 | SuspendLayout | (继承自 Control。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 Form。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

FormSlide 类
Chat.Framework.QQSdk.QPlus 命名空间


FormSlide.Dispose 方法

FormSlideDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 FormDispose(Boolean).)
Top
参见

引用

FormSlide 类
Chat.Framework.QQSdk.QPlus 命名空间


FormSlide.Dispose 方法 (Boolean)

FormSlideDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

FormSlide 类
Dispose 重载
Chat.Framework.QQSdk.QPlus 命名空间


FormSlide 事件

FormSlide 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

FormSlide 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus 类

QQ客户端管理
继承层次
SystemObject
Chat.Framework.QQSdkQQBase
Chat.Framework.QQSdk.QPlusQQClientImpl_QQPlus

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQClientImpl_QQPlus : QQBase,
    IDisposable

QQClientImpl_QQPlus 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | EndTime | (继承自 QQBase。)
公共属性 | IsEQQ | 是否企业QQ (继承自 QQBase。)
公共属性 | IsLogin | 是否已经登录 (继承自 QQBase。)
受保护的属性 | IsRegisterEvent | (继承自 QQBase。)
公共属性 | Nickname | 昵称 (继承自 QQBase。)
公共属性 | Password | 密码 (继承自 QQBase。)
公共属性 | QQ | QQ (继承自 QQBase。)
公共属性 | QQClient | QQ客户端
Top
方法
 | 名称 | 说明
公共方法 | AerifyAddGroup | (重写 QQBaseAerifyAddGroup(UInt32, UInt32, Boolean, String).)
公共方法 | AerifyAddMe | (重写 QQBaseAerifyAddMe(UInt32, Byte, String).)
公共方法 | DelayMess | 消息延迟
公共方法 | Dispose | 释放被 QQClientImpl_QQPlus 使用的所有资源
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Login | (重写 QQBaseLogin.)
公共方法 | Logout | (重写 QQBaseLogout.)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnLog | 发送日志 (继承自 QQBase。)
公共方法 | SendFriendImage | (重写 QQBaseSendFriendImage(UInt32, String).)
公共方法 | SendFriendMessage | (重写 QQBaseSendFriendMessage(UInt32, String).)
公共方法 | SendGroupImage | (重写 QQBaseSendGroupImage(UInt32, String).)
公共方法 | SendGroupMessage | (重写 QQBaseSendGroupMessage(UInt32, String).)
公共方法 | SendMessage | (重写 QQBaseSendMessage(UInt32, String, Boolean, Boolean).)
公共方法 | SendTempMessage(UInt32, String) | (重写 QQBaseSendTempMessage(UInt32, String).)
公共方法 | SendTempMessage(UInt32, String, Byte) | (重写 QQBaseSendTempMessage(UInt32, String, Byte).)
公共方法 | ToString | (继承自 QQBase。)
Top
字段
 | 名称 | 说明
公共字段 | count |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus 属性

QQClientImpl_QQPlus 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | EndTime | (继承自 QQBase。)
公共属性 | IsEQQ | 是否企业QQ (继承自 QQBase。)
公共属性 | IsLogin | 是否已经登录 (继承自 QQBase。)
受保护的属性 | IsRegisterEvent | (继承自 QQBase。)
公共属性 | Nickname | 昵称 (继承自 QQBase。)
公共属性 | Password | 密码 (继承自 QQBase。)
公共属性 | QQ | QQ (继承自 QQBase。)
公共属性 | QQClient | QQ客户端
Top
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.QQClient 属性

QQClientImpl_QQPlusQQClient 属性

QQ客户端

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public QQClient QQClient { get; }

属性值

类型：QQClient
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus 方法

QQClientImpl_QQPlus 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AerifyAddGroup | (重写 QQBaseAerifyAddGroup(UInt32, UInt32, Boolean, String).)
公共方法 | AerifyAddMe | (重写 QQBaseAerifyAddMe(UInt32, Byte, String).)
公共方法 | DelayMess | 消息延迟
公共方法 | Dispose |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Login | (重写 QQBaseLogin.)
公共方法 | Logout | (重写 QQBaseLogout.)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnLog | 发送日志 (继承自 QQBase。)
公共方法 | SendFriendImage | (重写 QQBaseSendFriendImage(UInt32, String).)
公共方法 | SendFriendMessage | (重写 QQBaseSendFriendMessage(UInt32, String).)
公共方法 | SendGroupImage | (重写 QQBaseSendGroupImage(UInt32, String).)
公共方法 | SendGroupMessage | (重写 QQBaseSendGroupMessage(UInt32, String).)
公共方法 | SendMessage | (重写 QQBaseSendMessage(UInt32, String, Boolean, Boolean).)
公共方法 | SendTempMessage(UInt32, String) | (重写 QQBaseSendTempMessage(UInt32, String).)
公共方法 | SendTempMessage(UInt32, String, Byte) | (重写 QQBaseSendTempMessage(UInt32, String, Byte).)
公共方法 | ToString | (继承自 QQBase。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.AerifyAddGroup 方法

QQClientImpl_QQPlusAerifyAddGroup 方法

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.AerifyAddGroup(System.UInt32,System.UInt32,System.Boolean,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void AerifyAddGroup(
    uint groupId,
    uint QQ,
    bool Agree = true,
    string Message = ""
)

参数

groupId
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.AerifyAddGroup(System.UInt32,System.UInt32,System.Boolean,System.String)" 的 <param name="groupId"/> 文档]

QQ
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.AerifyAddGroup(System.UInt32,System.UInt32,System.Boolean,System.String)" 的 <param name="QQ"/> 文档]

Agree (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.AerifyAddGroup(System.UInt32,System.UInt32,System.Boolean,System.String)" 的 <param name="Agree"/> 文档]

Message (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.AerifyAddGroup(System.UInt32,System.UInt32,System.Boolean,System.String)" 的 <param name="Message"/> 文档]

参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.AerifyAddMe 方法

QQClientImpl_QQPlusAerifyAddMe 方法

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.AerifyAddMe(System.UInt32,System.Byte,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void AerifyAddMe(
    uint QQ,
    byte Agree = 4,
    string Message = ""
)

参数

QQ
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.AerifyAddMe(System.UInt32,System.Byte,System.String)" 的 <param name="QQ"/> 文档]

Agree (Optional)
类型：SystemByte

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.AerifyAddMe(System.UInt32,System.Byte,System.String)" 的 <param name="Agree"/> 文档]

Message (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.AerifyAddMe(System.UInt32,System.Byte,System.String)" 的 <param name="Message"/> 文档]

参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.DelayMess 方法

QQClientImpl_QQPlusDelayMess 方法

消息延迟

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DelayMess(
    string message
)

参数

message
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.DelayMess(System.String)" 的 <param name="message"/> 文档]

返回值

类型：String
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.Dispose 方法

QQClientImpl_QQPlusDispose 方法

释放被 QQClientImpl_QQPlus 使用的所有资源

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()

实现

IDisposableDispose
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.Login 方法

QQClientImpl_QQPlusLogin 方法

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.Login" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Login()
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.Logout 方法

QQClientImpl_QQPlusLogout 方法

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.Logout" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Logout()
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.SendFriendImage 方法

QQClientImpl_QQPlusSendFriendImage 方法

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendFriendImage(System.UInt32,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendFriendImage(
    uint QQ,
    string ImageSrc
)

参数

QQ
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendFriendImage(System.UInt32,System.String)" 的 <param name="QQ"/> 文档]

ImageSrc
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendFriendImage(System.UInt32,System.String)" 的 <param name="ImageSrc"/> 文档]

参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.SendFriendMessage 方法

QQClientImpl_QQPlusSendFriendMessage 方法

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendFriendMessage(System.UInt32,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendFriendMessage(
    uint QQ,
    string Message
)

参数

QQ
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendFriendMessage(System.UInt32,System.String)" 的 <param name="QQ"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendFriendMessage(System.UInt32,System.String)" 的 <param name="Message"/> 文档]

参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.SendGroupImage 方法

QQClientImpl_QQPlusSendGroupImage 方法

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendGroupImage(System.UInt32,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendGroupImage(
    uint GroupId,
    string ImageSrc
)

参数

GroupId
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendGroupImage(System.UInt32,System.String)" 的 <param name="GroupId"/> 文档]

ImageSrc
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendGroupImage(System.UInt32,System.String)" 的 <param name="ImageSrc"/> 文档]

参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.SendGroupMessage 方法

QQClientImpl_QQPlusSendGroupMessage 方法

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendGroupMessage(System.UInt32,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendGroupMessage(
    uint GroupId,
    string Message
)

参数

GroupId
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendGroupMessage(System.UInt32,System.String)" 的 <param name="GroupId"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendGroupMessage(System.UInt32,System.String)" 的 <param name="Message"/> 文档]

参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.SendMessage 方法

QQClientImpl_QQPlusSendMessage 方法

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendMessage(System.UInt32,System.String,System.Boolean,System.Boolean)" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Task<bool> SendMessage(
    uint _username,
    string _content,
    bool _isGroup = false,
    bool _isTemp = false
)

参数

_username
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendMessage(System.UInt32,System.String,System.Boolean,System.Boolean)" 的 <param name="_username"/> 文档]

_content
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendMessage(System.UInt32,System.String,System.Boolean,System.Boolean)" 的 <param name="_content"/> 文档]

_isGroup (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendMessage(System.UInt32,System.String,System.Boolean,System.Boolean)" 的 <param name="_isGroup"/> 文档]

_isTemp (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendMessage(System.UInt32,System.String,System.Boolean,System.Boolean)" 的 <param name="_isTemp"/> 文档]

返回值

类型：Task Boolean
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.SendTempMessage 方法

QQClientImpl_QQPlusSendTempMessage 方法

重载列表
 | 名称 | 说明
公共方法 | SendTempMessage(UInt32, String) | (重写 QQBaseSendTempMessage(UInt32, String).)
公共方法 | SendTempMessage(UInt32, String, Byte) | (重写 QQBaseSendTempMessage(UInt32, String, Byte).)
Top
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.SendTempMessage 方法 (UInt32, String)

QQClientImpl_QQPlusSendTempMessage 方法 (UInt32, String)

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendTempMessage(System.UInt32,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendTempMessage(
    uint QQ,
    string Message
)

参数

QQ
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendTempMessage(System.UInt32,System.String)" 的 <param name="QQ"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendTempMessage(System.UInt32,System.String)" 的 <param name="Message"/> 文档]

参见

引用

QQClientImpl_QQPlus 类
SendTempMessage 重载
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.SendTempMessage 方法 (UInt32, String, Byte[])

QQClientImpl_QQPlusSendTempMessage 方法 (UInt32, String, Byte)

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendTempMessage(System.UInt32,System.String,System.Byte[])" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendTempMessage(
    uint QQ,
    string Message,
    byte[] Token
)

参数

QQ
类型：SystemUInt32

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendTempMessage(System.UInt32,System.String,System.Byte[])" 的 <param name="QQ"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendTempMessage(System.UInt32,System.String,System.Byte[])" 的 <param name="Message"/> 文档]

Token
类型：SystemByte

[缺少 "M:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.SendTempMessage(System.UInt32,System.String,System.Byte[])" 的 <param name="Token"/> 文档]

参见

引用

QQClientImpl_QQPlus 类
SendTempMessage 重载
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus 字段

QQClientImpl_QQPlus 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | count |
Top
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQClientImpl_QQPlus.count 字段

QQClientImpl_QQPluscount 字段

[缺少 "F:Chat.Framework.QQSdk.QPlus.QQClientImpl_QQPlus.count" 的 <summary> 文档]

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int count

字段值

类型：Int32
参见

引用

QQClientImpl_QQPlus 类
Chat.Framework.QQSdk.QPlus 命名空间


QQLoginForm 类

QQ登录窗体
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
Chat.Framework.QQSdk.QPlusQQLoginForm

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class QQLoginForm : BaseForm

QQLoginForm 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.QQSdk.QPlus 命名空间


QQLoginForm 属性

QQLoginForm 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

QQLoginForm 类
Chat.Framework.QQSdk.QPlus 命名空间


QQLoginForm 方法

QQLoginForm 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

QQLoginForm 类
Chat.Framework.QQSdk.QPlus 命名空间


QQLoginForm.Dispose 方法

QQLoginFormDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
Top
参见

引用

QQLoginForm 类
Chat.Framework.QQSdk.QPlus 命名空间


QQLoginForm.Dispose 方法 (Boolean)

QQLoginFormDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Chat.Framework.QQSdk.QPlus
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

QQLoginForm 类
Dispose 重载
Chat.Framework.QQSdk.QPlus 命名空间


QQLoginForm 事件

QQLoginForm 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

QQLoginForm 类
Chat.Framework.QQSdk.QPlus 命名空间


QQLoginForm 字段

QQLoginForm 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
参见

引用

QQLoginForm 类
Chat.Framework.QQSdk.QPlus 命名空间


Chat.Framework.Utils 命名空间

[缺少 "N:Chat.Framework.Utils" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | Common | 常用的操作类
枚举
 | 枚举 | 说明
公共枚举 | CommonCircleType | 朋友圈类型


Common 类

常用的操作类
继承层次
SystemObject
Chat.Framework.UtilsCommon

命名空间： Chat.Framework.Utils
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class Common

Common 类型公开以下成员。

方法
名称 | 说明
ConvertBase64ToImage | Base64转图片
ConvertImageToBase64 | 图片转Base64
RandomMess | 变量分隔,随机返回
Top
参见

引用

Chat.Framework.Utils 命名空间


Common 方法

Common 类型公开以下成员。

方法
名称 | 说明
ConvertBase64ToImage | Base64转图片
ConvertImageToBase64 | 图片转Base64
RandomMess | 变量分隔,随机返回
Top
参见

引用

Common 类
Chat.Framework.Utils 命名空间


Common.ConvertBase64ToImage 方法

CommonConvertBase64ToImage 方法

Base64转图片

命名空间： Chat.Framework.Utils
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static Image ConvertBase64ToImage(
    string base64String
)

参数

base64String
类型：SystemString
base64

返回值

类型：Image
参见

引用

Common 类
Chat.Framework.Utils 命名空间


Common.ConvertImageToBase64 方法

CommonConvertImageToBase64 方法

图片转Base64

命名空间： Chat.Framework.Utils
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string ConvertImageToBase64(
    Image file
)

参数

file
类型：System.DrawingImage
图片

返回值

类型：String
参见

引用

Common 类
Chat.Framework.Utils 命名空间


Common.RandomMess 方法

CommonRandomMess 方法

变量分隔,随机返回

命名空间： Chat.Framework.Utils
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string RandomMess(
    this string mess,
    string separator = "[随机]"
)

参数

mess
类型：SystemString
消息
separator (Optional)
类型：SystemString
分隔标识

返回值

类型：String

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 String 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

Common 类
Chat.Framework.Utils 命名空间


Common.CircleType 枚举

CommonCircleType 枚举

朋友圈类型

命名空间： Chat.Framework.Utils
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum CircleType
成员
成员名称 | 值 | 说明
文字朋友圈 | 0 |
视频朋友圈 | 1 |
链接朋友圈 | 2 |
图文朋友圈 | 3 |
参见

引用

Chat.Framework.Utils 命名空间


Chat.Framework.WXSdk 命名空间

[缺少 "N:Chat.Framework.WXSdk" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | BankCar | 银行信息类
公共类 | CDNImageMsgInfo | cdn图片
公共类 | Friend | 好友实体类
公共类 | GroupMember | 群用户
公共类 | WXSdkConfig |
枚举
 | 枚举 | 说明
公共枚举 | WxStatus | 微信状态


BankCar 类

银行信息类
继承层次
SystemObject
Chat.Framework.WXSdkBankCar

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class BankCar

BankCar 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BankCar | 初始化 BankCar 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | bank_name | 银行名称
公共属性 | bank_type | 银行类型
公共属性 | bind_serial | 绑定编号
公共属性 | bind_tail | 绑定尾号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | 重写ToString方法显示为银行名称和卡号 (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk 命名空间


BankCar 构造函数

初始化 BankCar 类的一个新实例

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BankCar()
参见

引用

BankCar 类
Chat.Framework.WXSdk 命名空间


BankCar 属性

BankCar 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | bank_name | 银行名称
公共属性 | bank_type | 银行类型
公共属性 | bind_serial | 绑定编号
公共属性 | bind_tail | 绑定尾号
Top
参见

引用

BankCar 类
Chat.Framework.WXSdk 命名空间


BankCar.bank_name 属性

BankCarbank_name 属性

银行名称

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string bank_name { get; set; }

属性值

类型：String
参见

引用

BankCar 类
Chat.Framework.WXSdk 命名空间


BankCar.bank_type 属性

BankCarbank_type 属性

银行类型

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string bank_type { get; set; }

属性值

类型：String
参见

引用

BankCar 类
Chat.Framework.WXSdk 命名空间


BankCar.bind_serial 属性

BankCarbind_serial 属性

绑定编号

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string bind_serial { get; set; }

属性值

类型：String
参见

引用

BankCar 类
Chat.Framework.WXSdk 命名空间


BankCar.bind_tail 属性

BankCarbind_tail 属性

绑定尾号

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string bind_tail { get; set; }

属性值

类型：String
参见

引用

BankCar 类
Chat.Framework.WXSdk 命名空间


BankCar 方法

BankCar 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | 重写ToString方法显示为银行名称和卡号 (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

BankCar 类
Chat.Framework.WXSdk 命名空间


BankCar.ToString 方法

BankCarToString 方法

重写ToString方法显示为银行名称和卡号

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

BankCar 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo 类

cdn图片
继承层次
SystemObject
Chat.Framework.WXSdkCDNImageMsgInfo

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CDNImageMsgInfo

CDNImageMsgInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CDNImageMsgInfo | 初始化 CDNImageMsgInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AESKey |
公共属性 | CDNBigImgSize |
公共属性 | CDNBigImgUrl |
公共属性 | CDNMidImgSize |
公共属性 | CDNMidImgUrl |
公共属性 | CDNThumbImgHeight |
公共属性 | CDNThumbImgSize |
公共属性 | CDNThumbImgWidth |
公共属性 | DataLen |
公共属性 | TotalLen |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
字段
 | 名称 | 说明
公共字段 | StartPos |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo 构造函数

初始化 CDNImageMsgInfo 类的一个新实例

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CDNImageMsgInfo()
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo 属性

CDNImageMsgInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AESKey |
公共属性 | CDNBigImgSize |
公共属性 | CDNBigImgUrl |
公共属性 | CDNMidImgSize |
公共属性 | CDNMidImgUrl |
公共属性 | CDNThumbImgHeight |
公共属性 | CDNThumbImgSize |
公共属性 | CDNThumbImgWidth |
公共属性 | DataLen |
公共属性 | TotalLen |
Top
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.AESKey 属性

CDNImageMsgInfoAESKey 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.AESKey" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string AESKey { get; set; }

属性值

类型：String
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.CDNBigImgSize 属性

CDNImageMsgInfoCDNBigImgSize 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.CDNBigImgSize" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long CDNBigImgSize { get; set; }

属性值

类型：Int64
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.CDNBigImgUrl 属性

CDNImageMsgInfoCDNBigImgUrl 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.CDNBigImgUrl" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string CDNBigImgUrl { get; set; }

属性值

类型：String
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.CDNMidImgSize 属性

CDNImageMsgInfoCDNMidImgSize 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.CDNMidImgSize" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long CDNMidImgSize { get; set; }

属性值

类型：Int64
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.CDNMidImgUrl 属性

CDNImageMsgInfoCDNMidImgUrl 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.CDNMidImgUrl" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string CDNMidImgUrl { get; set; }

属性值

类型：String
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.CDNThumbImgHeight 属性

CDNImageMsgInfoCDNThumbImgHeight 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.CDNThumbImgHeight" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long CDNThumbImgHeight { get; set; }

属性值

类型：Int64
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.CDNThumbImgSize 属性

CDNImageMsgInfoCDNThumbImgSize 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.CDNThumbImgSize" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long CDNThumbImgSize { get; set; }

属性值

类型：Int64
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.CDNThumbImgWidth 属性

CDNImageMsgInfoCDNThumbImgWidth 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.CDNThumbImgWidth" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long CDNThumbImgWidth { get; set; }

属性值

类型：Int64
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.DataLen 属性

CDNImageMsgInfoDataLen 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.DataLen" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long DataLen { get; set; }

属性值

类型：Int64
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.TotalLen 属性

CDNImageMsgInfoTotalLen 属性

[缺少 "P:Chat.Framework.WXSdk.CDNImageMsgInfo.TotalLen" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long TotalLen { get; set; }

属性值

类型：Int64
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo 方法

CDNImageMsgInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo 字段

CDNImageMsgInfo 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | StartPos |
Top
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


CDNImageMsgInfo.StartPos 字段

CDNImageMsgInfoStartPos 字段

[缺少 "F:Chat.Framework.WXSdk.CDNImageMsgInfo.StartPos" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long StartPos

字段值

类型：Int64
参见

引用

CDNImageMsgInfo 类
Chat.Framework.WXSdk 命名空间


Friend 类

好友实体类
继承层次
SystemObject
Chat.Framework.WXSdkFriend

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Friend

Friend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Friend | 初始化 Friend 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Alias | 微信号
公共属性 | BigHeadImgUrl | 大头像
公共属性 | ChatRoomOwner | 聊天室主人
公共属性 | ChatroomVersion | 版本
公共属性 | City | 城市
公共属性 | ContactType | 连接类型
公共属性 | ExtInfo | 群用户微信ID字符串
公共属性 | id | id
公共属性 | MsgType | 消息类型
公共属性 | NickName | 昵称
公共属性 | Province | 省份
公共属性 | Remark | 备注
公共属性 | Sex | 性别
公共属性 | Signature | 签名
公共属性 | SmallHeadImgUrl | 小头像
公共属性 | Ticket | 是否为相互好友,值为空时为好友 (ipad协议) 等于-1为没有检测,等于0为正常用户,1,2为拉黑用户(Hook协议)
公共属性 | update_time | 更新时间
公共属性 | UserName | 账号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetName |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk 命名空间


Friend 构造函数

初始化 Friend 类的一个新实例

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Friend()
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend 属性

Friend 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Alias | 微信号
公共属性 | BigHeadImgUrl | 大头像
公共属性 | ChatRoomOwner | 聊天室主人
公共属性 | ChatroomVersion | 版本
公共属性 | City | 城市
公共属性 | ContactType | 连接类型
公共属性 | ExtInfo | 群用户微信ID字符串
公共属性 | id | id
公共属性 | MsgType | 消息类型
公共属性 | NickName | 昵称
公共属性 | Province | 省份
公共属性 | Remark | 备注
公共属性 | Sex | 性别
公共属性 | Signature | 签名
公共属性 | SmallHeadImgUrl | 小头像
公共属性 | Ticket | 是否为相互好友,值为空时为好友 (ipad协议) 等于-1为没有检测,等于0为正常用户,1,2为拉黑用户(Hook协议)
公共属性 | update_time | 更新时间
公共属性 | UserName | 账号
Top
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.Alias 属性

FriendAlias 属性

微信号

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Alias { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.BigHeadImgUrl 属性

FriendBigHeadImgUrl 属性

大头像

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string BigHeadImgUrl { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.ChatRoomOwner 属性

FriendChatRoomOwner 属性

聊天室主人

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ChatRoomOwner { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.ChatroomVersion 属性

FriendChatroomVersion 属性

版本

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ChatroomVersion { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.City 属性

FriendCity 属性

城市

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string City { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.ContactType 属性

FriendContactType 属性

连接类型

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int ContactType { get; set; }

属性值

类型：Int32
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.ExtInfo 属性

FriendExtInfo 属性

群用户微信ID字符串

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ExtInfo { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.id 属性

Friendid 属性

id

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int id { get; set; }

属性值

类型：Int32
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.MsgType 属性

FriendMsgType 属性

消息类型

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int MsgType { get; set; }

属性值

类型：Int32
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.NickName 属性

FriendNickName 属性

昵称

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string NickName { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.Province 属性

FriendProvince 属性

省份

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Province { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.Remark 属性

FriendRemark 属性

备注

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Remark { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.Sex 属性

FriendSex 属性

性别

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Sex { get; set; }

属性值

类型：Int32
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.Signature 属性

FriendSignature 属性

签名

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Signature { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.SmallHeadImgUrl 属性

FriendSmallHeadImgUrl 属性

小头像

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SmallHeadImgUrl { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.Ticket 属性

FriendTicket 属性

是否为相互好友,值为空时为好友 (ipad协议) 等于-1为没有检测,等于0为正常用户,1,2为拉黑用户(Hook协议)

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Ticket { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.update_time 属性

Friendupdate_time 属性

更新时间

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime update_time { get; set; }

属性值

类型：DateTime
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.UserName 属性

FriendUserName 属性

账号

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string UserName { get; set; }

属性值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend 方法

Friend 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetName |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


Friend.GetName 方法

FriendGetName 方法

[缺少 "M:Chat.Framework.WXSdk.Friend.GetName" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetName()

返回值

类型：String
参见

引用

Friend 类
Chat.Framework.WXSdk 命名空间


GroupMember 类

群用户
继承层次
SystemObject
Chat.Framework.WXSdkGroupMember

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class GroupMember

GroupMember 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GroupMember | 初始化 GroupMember 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | BigHeadImgUrl | 大头像
公共属性 | ChatroomMemberFlag |
公共属性 | DisplayName | 显示的群昵称
公共属性 | Groupid | 群ID
公共属性 | id | id
公共属性 | InviterUserName | 邀请者微信
公共属性 | NickName | 群昵称
公共属性 | SmallHeadImgUrl | 小头像
公共属性 | update_time | 更新时间
公共属性 | Username | 微信ID
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetName | 显示的群昵称
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk 命名空间


GroupMember 构造函数

初始化 GroupMember 类的一个新实例

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public GroupMember()
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember 属性

GroupMember 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BigHeadImgUrl | 大头像
公共属性 | ChatroomMemberFlag |
公共属性 | DisplayName | 显示的群昵称
公共属性 | Groupid | 群ID
公共属性 | id | id
公共属性 | InviterUserName | 邀请者微信
公共属性 | NickName | 群昵称
公共属性 | SmallHeadImgUrl | 小头像
公共属性 | update_time | 更新时间
公共属性 | Username | 微信ID
Top
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.BigHeadImgUrl 属性

GroupMemberBigHeadImgUrl 属性

大头像

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string BigHeadImgUrl { get; set; }

属性值

类型：String
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.ChatroomMemberFlag 属性

GroupMemberChatroomMemberFlag 属性

[缺少 "P:Chat.Framework.WXSdk.GroupMember.ChatroomMemberFlag" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int ChatroomMemberFlag { get; set; }

属性值

类型：Int32
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.DisplayName 属性

GroupMemberDisplayName 属性

显示的群昵称

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DisplayName { get; set; }

属性值

类型：String
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.Groupid 属性

GroupMemberGroupid 属性

群ID

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Groupid { get; set; }

属性值

类型：String
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.id 属性

GroupMemberid 属性

id

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int id { get; set; }

属性值

类型：Int32
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.InviterUserName 属性

GroupMemberInviterUserName 属性

邀请者微信

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string InviterUserName { get; set; }

属性值

类型：String
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.NickName 属性

GroupMemberNickName 属性

群昵称

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string NickName { get; set; }

属性值

类型：String
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.SmallHeadImgUrl 属性

GroupMemberSmallHeadImgUrl 属性

小头像

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SmallHeadImgUrl { get; set; }

属性值

类型：String
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.update_time 属性

GroupMemberupdate_time 属性

更新时间

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime update_time { get; set; }

属性值

类型：DateTime
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.Username 属性

GroupMemberUsername 属性

微信ID

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Username { get; set; }

属性值

类型：String
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember 方法

GroupMember 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetName | 显示的群昵称
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


GroupMember.GetName 方法

GroupMemberGetName 方法

显示的群昵称

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetName()

返回值

类型：String
参见

引用

GroupMember 类
Chat.Framework.WXSdk 命名空间


WXSdkConfig 类

[缺少 "T:Chat.Framework.WXSdk.WXSdkConfig" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdkWXSdkConfig

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXSdkConfig

WXSdkConfig 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXSdkConfig | 初始化 WXSdkConfig 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsDebug |
公共属性 | MsgConvertToFriend | 消息是否转换为好友消息
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk 命名空间


WXSdkConfig 构造函数

初始化 WXSdkConfig 类的一个新实例

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXSdkConfig()
参见

引用

WXSdkConfig 类
Chat.Framework.WXSdk 命名空间


WXSdkConfig 属性

WXSdkConfig 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsDebug |
公共属性 | MsgConvertToFriend | 消息是否转换为好友消息
Top
参见

引用

WXSdkConfig 类
Chat.Framework.WXSdk 命名空间


WXSdkConfig.IsDebug 属性

WXSdkConfigIsDebug 属性

[缺少 "P:Chat.Framework.WXSdk.WXSdkConfig.IsDebug" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsDebug { get; set; }

属性值

类型：Boolean
参见

引用

WXSdkConfig 类
Chat.Framework.WXSdk 命名空间


WXSdkConfig.MsgConvertToFriend 属性

WXSdkConfigMsgConvertToFriend 属性

消息是否转换为好友消息

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool MsgConvertToFriend { get; set; }

属性值

类型：Boolean
参见

引用

WXSdkConfig 类
Chat.Framework.WXSdk 命名空间


WXSdkConfig 方法

WXSdkConfig 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXSdkConfig 类
Chat.Framework.WXSdk 命名空间


WxStatus 枚举

微信状态

命名空间： Chat.Framework.WXSdk
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WxStatus
成员
成员名称 | 值 | 说明
未登录 | 1 |
登录中 | 2 |
扫码中 | 3 |
扫码成功 | 4 |
登录失败 | 5 |
在线 | 6 |
已退出 | 7 |
已掉线 | 8 |
取消扫码 | 9 |
获取头像成功 | 10 |
参见

引用

Chat.Framework.WXSdk 命名空间


Chat.Framework.WXSdk.Events 命名空间

[缺少 "N:Chat.Framework.WXSdk.Events" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | WXApplyFriend | 微信新人申请加好友事件
公共类 | WXApplyGroup | 收到微信用户进群申请事件
公共类 | WXApplyGroupApplyGroupMember | 申请入群用户基础信息
公共类 | WXChangeStatus | 微信状态改变事件
公共类 | WXEvent | 微信基础事件
公共类 | WXGetDevice | 设备信息
公共类 | WXNewFriend | 微信新增好友事件
公共类 | WXNewMemer | 微信新人进群事件
公共类 | WXOpenWindow | 协议用户聊天窗口被打开后触发的事件
公共类 | WXReceiveGroupMsg | 微信收到群消息事件
公共类 | WXRefreshContactSuccess | 更新联系人成功
公共类 | WXRefreshUser | 微信更新信息事件
公共类 | WXReiceveFriendMsg | 私聊消息事件
公共类 | WXReicevePay | 微信收到转账
公共类 | WXScavengEvents | 微信获取二维码事件
公共类 | WXSendMessage | 微信消息发送
公共类 | WXWriteLog | 微信日志事件
枚举
 | 枚举 | 说明
公共枚举 | ChatMemberType | 聊天用户信息类型


ChatMemberType 枚举

聊天用户信息类型

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum ChatMemberType
成员
成员名称 | 值 | 说明
群信息 | 0 |
用户信息 | 1 |
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend 类

微信新人申请加好友事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXApplyFriend

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXApplyFriend : WXEvent

WXApplyFriend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXApplyFriend(WXClientImpl_HOOK, String, String, String, String, String, String) | 初始化 WXApplyFriend 类的一个新实例
公共方法 | WXApplyFriend(WXClientImpl_IPAD, String, String, String, String, String, String) | 初始化 WXApplyFriend 类的一个新实例
公共方法 | WXApplyFriend(WXClientImpl_QYHOOK, String, String, String, String, String, String) | 初始化 WXApplyFriend 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 附加消息
公共属性 | NewFriendNick | 新朋友昵称
公共属性 | NewFriendWxid | 新朋友Id
公共属性 | OldFriendNick | 推荐人昵称 可能为空
公共属性 | OldFriendWxid | 推荐人wxid 可能为空
公共属性 | Token | 原始信息,自己解析
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend 构造函数

重载列表
 | 名称 | 说明
公共方法 | WXApplyFriend(WXClientImpl_HOOK, String, String, String, String, String, String) | 初始化 WXApplyFriend 类的一个新实例
公共方法 | WXApplyFriend(WXClientImpl_IPAD, String, String, String, String, String, String) | 初始化 WXApplyFriend 类的一个新实例
公共方法 | WXApplyFriend(WXClientImpl_QYHOOK, String, String, String, String, String, String) | 初始化 WXApplyFriend 类的一个新实例
Top
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend 构造函数 (WXClientImpl_HOOK, String, String, String, String, String, String)

初始化 WXApplyFriend 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXApplyFriend(
    WXClientImpl_HOOK client,
    string NewFriendWxid,
    string NewFriendNick,
    string Message,
    string FriendWxid,
    string FriendNick,
    string token
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_HOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="client"/> 文档]

NewFriendWxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="NewFriendWxid"/> 文档]

NewFriendNick
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="NewFriendNick"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="Message"/> 文档]

FriendWxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="FriendWxid"/> 文档]

FriendNick
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="FriendNick"/> 文档]

token
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="token"/> 文档]

参见

引用

WXApplyFriend 类
WXApplyFriend 重载
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend 构造函数 (WXClientImpl_IPAD, String, String, String, String, String, String)

初始化 WXApplyFriend 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXApplyFriend(
    WXClientImpl_IPAD client,
    string NewFriendWxid,
    string NewFriendNick,
    string Message,
    string FriendWxid,
    string FriendNick,
    string token
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="client"/> 文档]

NewFriendWxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="NewFriendWxid"/> 文档]

NewFriendNick
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="NewFriendNick"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="Message"/> 文档]

FriendWxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="FriendWxid"/> 文档]

FriendNick
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="FriendNick"/> 文档]

token
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="token"/> 文档]

参见

引用

WXApplyFriend 类
WXApplyFriend 重载
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend 构造函数 (WXClientImpl_QYHOOK, String, String, String, String, String, String)

初始化 WXApplyFriend 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXApplyFriend(
    WXClientImpl_QYHOOK client,
    string NewFriendWxid,
    string NewFriendNick,
    string Message,
    string FriendWxid,
    string FriendNick,
    string token
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_QYHOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="client"/> 文档]

NewFriendWxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="NewFriendWxid"/> 文档]

NewFriendNick
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="NewFriendNick"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="Message"/> 文档]

FriendWxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="FriendWxid"/> 文档]

FriendNick
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="FriendNick"/> 文档]

token
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="token"/> 文档]

参见

引用

WXApplyFriend 类
WXApplyFriend 重载
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend 属性

WXApplyFriend 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 附加消息
公共属性 | NewFriendNick | 新朋友昵称
公共属性 | NewFriendWxid | 新朋友Id
公共属性 | OldFriendNick | 推荐人昵称 可能为空
公共属性 | OldFriendWxid | 推荐人wxid 可能为空
公共属性 | Token | 原始信息,自己解析
Top
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend.Message 属性

WXApplyFriendMessage 属性

附加消息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend.NewFriendNick 属性

WXApplyFriendNewFriendNick 属性

新朋友昵称

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string NewFriendNick { get; }

属性值

类型：String
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend.NewFriendWxid 属性

WXApplyFriendNewFriendWxid 属性

新朋友Id

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string NewFriendWxid { get; }

属性值

类型：String
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend.OldFriendNick 属性

WXApplyFriendOldFriendNick 属性

推荐人昵称 可能为空

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string OldFriendNick { get; }

属性值

类型：String
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend.OldFriendWxid 属性

WXApplyFriendOldFriendWxid 属性

推荐人wxid 可能为空

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string OldFriendWxid { get; }

属性值

类型：String
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend.Token 属性

WXApplyFriendToken 属性

原始信息,自己解析

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Token { get; }

属性值

类型：String
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend 方法

WXApplyFriend 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyFriend.ToString 方法

WXApplyFriendToString 方法

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyFriend.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WXApplyFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup 类

收到微信用户进群申请事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXApplyGroup

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXApplyGroup : WXEvent

WXApplyGroup 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXApplyGroup | 初始化 WXApplyGroup 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | GroupId | 申请群账号
公共属性 | GroupName | 申请群昵称
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Members | 申请进群的用户集合
公共属性 | Reason | 申请理由
公共属性 | Usernick | 申请入群昵称
公共属性 | Wxid | 申请入群账号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup 构造函数

初始化 WXApplyGroup 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXApplyGroup(
    WXClientImpl_IPAD client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyGroup.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD)" 的 <param name="client"/> 文档]

参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup 属性

WXApplyGroup 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | GroupId | 申请群账号
公共属性 | GroupName | 申请群昵称
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Members | 申请进群的用户集合
公共属性 | Reason | 申请理由
公共属性 | Usernick | 申请入群昵称
公共属性 | Wxid | 申请入群账号
Top
参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.GroupId 属性

WXApplyGroupGroupId 属性

申请群账号

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GroupId { get; }

属性值

类型：String
参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.GroupName 属性

WXApplyGroupGroupName 属性

申请群昵称

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GroupName { get; }

属性值

类型：String
参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.Members 属性

WXApplyGroupMembers 属性

申请进群的用户集合

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<WXApplyGroupApplyGroupMember> Members { get; }

属性值

类型：List WXApplyGroupApplyGroupMember
参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.Reason 属性

WXApplyGroupReason 属性

申请理由

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Reason { get; }

属性值

类型：String
参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.Usernick 属性

WXApplyGroupUsernick 属性

申请入群昵称

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Usernick { get; }

属性值

类型：String
参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.Wxid 属性

WXApplyGroupWxid 属性

申请入群账号

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Wxid { get; }

属性值

类型：String
参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup 方法

WXApplyGroup 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.ToString 方法

WXApplyGroupToString 方法

[缺少 "M:Chat.Framework.WXSdk.Events.WXApplyGroup.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WXApplyGroup 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.ApplyGroupMember 类

WXApplyGroupApplyGroupMember 类

申请入群用户基础信息
继承层次
SystemObject
Chat.Framework.WXSdk.EventsWXApplyGroupApplyGroupMember

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ApplyGroupMember

WXApplyGroupApplyGroupMember 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXApplyGroupApplyGroupMember | 初始化 WXApplyGroupApplyGroupMember 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | headimgurl | 新人头像
公共属性 | nickname | 新人昵称
公共属性 | quitchatroominfo |
公共属性 | wxid | 新人账号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.ApplyGroupMember 构造函数

WXApplyGroupApplyGroupMember 构造函数

初始化 WXApplyGroupApplyGroupMember 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ApplyGroupMember()
参见

引用

WXApplyGroupApplyGroupMember 类
Chat.Framework.WXSdk.Events 命名空间


ApplyGroupMember 属性

WXApplyGroupApplyGroupMember 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | headimgurl | 新人头像
公共属性 | nickname | 新人昵称
公共属性 | quitchatroominfo |
公共属性 | wxid | 新人账号
Top
参见

引用

WXApplyGroupApplyGroupMember 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.ApplyGroupMember.headimgurl 属性

WXApplyGroupApplyGroupMemberheadimgurl 属性

新人头像

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string headimgurl { get; set; }

属性值

类型：String
参见

引用

WXApplyGroupApplyGroupMember 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.ApplyGroupMember.nickname 属性

WXApplyGroupApplyGroupMembernickname 属性

新人昵称

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string nickname { get; set; }

属性值

类型：String
参见

引用

WXApplyGroupApplyGroupMember 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.ApplyGroupMember.quitchatroominfo 属性

WXApplyGroupApplyGroupMemberquitchatroominfo 属性

[缺少 "P:Chat.Framework.WXSdk.Events.WXApplyGroup.ApplyGroupMember.quitchatroominfo" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string quitchatroominfo { get; set; }

属性值

类型：String
参见

引用

WXApplyGroupApplyGroupMember 类
Chat.Framework.WXSdk.Events 命名空间


WXApplyGroup.ApplyGroupMember.wxid 属性

WXApplyGroupApplyGroupMemberwxid 属性

新人账号

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string wxid { get; set; }

属性值

类型：String
参见

引用

WXApplyGroupApplyGroupMember 类
Chat.Framework.WXSdk.Events 命名空间


ApplyGroupMember 方法

WXApplyGroupApplyGroupMember 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXApplyGroupApplyGroupMember 类
Chat.Framework.WXSdk.Events 命名空间


WXChangeStatus 类

微信状态改变事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXChangeStatus

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXChangeStatus : WXEvent

WXChangeStatus 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXChangeStatus | 初始化 WXChangeStatus 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Image | 登录二维码
公共属性 | ImageByte | 登录二维码byte[]
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 改变附带的内容
公共属性 | Status | 微信状态
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXChangeStatus 构造函数

初始化 WXChangeStatus 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXChangeStatus(
    WeixinBase client,
    string message = ""
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXChangeStatus.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase,System.String)" 的 <param name="client"/> 文档]

message (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXChangeStatus.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase,System.String)" 的 <param name="message"/> 文档]

参见

引用

WXChangeStatus 类
Chat.Framework.WXSdk.Events 命名空间


WXChangeStatus 属性

WXChangeStatus 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Image | 登录二维码
公共属性 | ImageByte | 登录二维码byte[]
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 改变附带的内容
公共属性 | Status | 微信状态
Top
参见

引用

WXChangeStatus 类
Chat.Framework.WXSdk.Events 命名空间


WXChangeStatus.Image 属性

WXChangeStatusImage 属性

登录二维码

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Image Image { get; }

属性值

类型：Image
参见

引用

WXChangeStatus 类
Chat.Framework.WXSdk.Events 命名空间


WXChangeStatus.ImageByte 属性

WXChangeStatusImageByte 属性

登录二维码byte[]

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] ImageByte { get; }

属性值

类型：Byte
参见

引用

WXChangeStatus 类
Chat.Framework.WXSdk.Events 命名空间


WXChangeStatus.Message 属性

WXChangeStatusMessage 属性

改变附带的内容

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

WXChangeStatus 类
Chat.Framework.WXSdk.Events 命名空间


WXChangeStatus.Status 属性

WXChangeStatusStatus 属性

微信状态

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WxStatus Status { get; }

属性值

类型：WxStatus
参见

引用

WXChangeStatus 类
Chat.Framework.WXSdk.Events 命名空间


WXChangeStatus 方法

WXChangeStatus 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXChangeStatus 类
Chat.Framework.WXSdk.Events 命名空间


WXChangeStatus.ToString 方法

WXChangeStatusToString 方法

[缺少 "M:Chat.Framework.WXSdk.Events.WXChangeStatus.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WXChangeStatus 类
Chat.Framework.WXSdk.Events 命名空间


WXEvent 类

微信基础事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
更多...

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXEvent : ChatEvent

WXEvent 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXEvent | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXApplyFriend
Chat.Framework.WXSdk.EventsWXApplyGroup
Chat.Framework.WXSdk.EventsWXChangeStatus
Chat.Framework.WXSdk.EventsWXGetDevice
Chat.Framework.WXSdk.EventsWXNewFriend
Chat.Framework.WXSdk.EventsWXNewMemer
Chat.Framework.WXSdk.EventsWXOpenWindow
Chat.Framework.WXSdk.EventsWXReceiveGroupMsg
Chat.Framework.WXSdk.EventsWXRefreshContactSuccess
Chat.Framework.WXSdk.EventsWXRefreshUser
Chat.Framework.WXSdk.EventsWXReiceveFriendMsg
Chat.Framework.WXSdk.EventsWXReicevePay
Chat.Framework.WXSdk.EventsWXScavengEvents
Chat.Framework.WXSdk.EventsWXSendMessage
Chat.Framework.WXSdk.EventsWXWriteLog


WXEvent 构造函数

构造方法

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXEvent(
    WeixinBase client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXEvent.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase)" 的 <param name="client"/> 文档]

参见

引用

WXEvent 类
Chat.Framework.WXSdk.Events 命名空间


WXEvent 属性

WXEvent 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WXEvent 类
Chat.Framework.WXSdk.Events 命名空间


WXEvent.Client 属性

WXEventClient 属性

微信基类

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinBase Client { get; }

属性值

类型：WeixinBase
参见

引用

WXEvent 类
Chat.Framework.WXSdk.Events 命名空间


WXEvent 方法

WXEvent 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXEvent 类
Chat.Framework.WXSdk.Events 命名空间


WXGetDevice 类

设备信息
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXGetDevice

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXGetDevice : WXEvent

WXGetDevice 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXGetDevice | 初始化 WXGetDevice 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | DeviceInfo | 微信设备ID
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXGetDevice 构造函数

初始化 WXGetDevice 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXGetDevice(
    WeixinBase client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXGetDevice.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase)" 的 <param name="client"/> 文档]

参见

引用

WXGetDevice 类
Chat.Framework.WXSdk.Events 命名空间


WXGetDevice 属性

WXGetDevice 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | DeviceInfo | 微信设备ID
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WXGetDevice 类
Chat.Framework.WXSdk.Events 命名空间


WXGetDevice.DeviceInfo 属性

WXGetDeviceDeviceInfo 属性

微信设备ID

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DeviceInfo { get; set; }

属性值

类型：String
参见

引用

WXGetDevice 类
Chat.Framework.WXSdk.Events 命名空间


WXGetDevice 方法

WXGetDevice 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXGetDevice 类
Chat.Framework.WXSdk.Events 命名空间


WXNewFriend 类

微信新增好友事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXNewFriend

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXNewFriend : WXEvent

WXNewFriend 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXNewFriend | 构造方法
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Friend | 新好友信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | 重写ToString方法 (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXNewFriend 构造函数

构造方法

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXNewFriend(
    WeixinBase client,
    Friend Friend
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXNewFriend.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase,Chat.Framework.WXSdk.Friend)" 的 <param name="client"/> 文档]

Friend
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXNewFriend.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase,Chat.Framework.WXSdk.Friend)" 的 <param name="Friend"/> 文档]

参见

引用

WXNewFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXNewFriend 属性

WXNewFriend 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Friend | 新好友信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WXNewFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXNewFriend.Friend 属性

WXNewFriendFriend 属性

新好友信息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Friend Friend { get; }

属性值

类型：Friend
参见

引用

WXNewFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXNewFriend 方法

WXNewFriend 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | 重写ToString方法 (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXNewFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXNewFriend.ToString 方法

WXNewFriendToString 方法

重写ToString方法

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WXNewFriend 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer 类

微信新人进群事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXNewMemer

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXNewMemer : WXEvent

WXNewMemer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXNewMemer(WXClientImpl_HOOK) | 初始化 WXNewMemer 类的一个新实例
公共方法 | WXNewMemer(WXClientImpl_IPAD) | 初始化 WXNewMemer 类的一个新实例
公共方法 | WXNewMemer(WXClientImpl_QYHOOK) | 初始化 WXNewMemer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Group | 群信息
公共属性 | GroupId | 群账号
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | MemberName | 新用户账号
公共属性 | MemberNicks | 新用户昵称
公共属性 | SourceName | 邀请人账号
公共属性 | SourceNick | 邀请人昵称
公共属性 | TotalMember | 群成员数量
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXNewMemer 构造函数

重载列表
 | 名称 | 说明
公共方法 | WXNewMemer(WXClientImpl_HOOK) | 初始化 WXNewMemer 类的一个新实例
公共方法 | WXNewMemer(WXClientImpl_IPAD) | 初始化 WXNewMemer 类的一个新实例
公共方法 | WXNewMemer(WXClientImpl_QYHOOK) | 初始化 WXNewMemer 类的一个新实例
Top
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer 构造函数 (WXClientImpl_HOOK)

初始化 WXNewMemer 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXNewMemer(
    WXClientImpl_HOOK client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_HOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXNewMemer.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK)" 的 <param name="client"/> 文档]

参见

引用

WXNewMemer 类
WXNewMemer 重载
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer 构造函数 (WXClientImpl_IPAD)

初始化 WXNewMemer 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXNewMemer(
    WXClientImpl_IPAD client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.Events.WXNewMemer.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD)" 的 <param name="client"/> 文档]

参见

引用

WXNewMemer 类
WXNewMemer 重载
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer 构造函数 (WXClientImpl_QYHOOK)

初始化 WXNewMemer 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXNewMemer(
    WXClientImpl_QYHOOK client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_QYHOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXNewMemer.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK)" 的 <param name="client"/> 文档]

参见

引用

WXNewMemer 类
WXNewMemer 重载
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer 属性

WXNewMemer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Group | 群信息
公共属性 | GroupId | 群账号
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | MemberName | 新用户账号
公共属性 | MemberNicks | 新用户昵称
公共属性 | SourceName | 邀请人账号
公共属性 | SourceNick | 邀请人昵称
公共属性 | TotalMember | 群成员数量
Top
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer.Group 属性

WXNewMemerGroup 属性

群信息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Friend Group { get; }

属性值

类型：Friend
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer.GroupId 属性

WXNewMemerGroupId 属性

群账号

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GroupId { get; }

属性值

类型：String
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer.MemberName 属性

WXNewMemerMemberName 属性

新用户账号

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string MemberName { get; }

属性值

类型：String
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer.MemberNicks 属性

WXNewMemerMemberNicks 属性

新用户昵称

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string MemberNicks { get; }

属性值

类型：String
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer.SourceName 属性

WXNewMemerSourceName 属性

邀请人账号

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SourceName { get; }

属性值

类型：String
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer.SourceNick 属性

WXNewMemerSourceNick 属性

邀请人昵称

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string SourceNick { get; }

属性值

类型：String
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer.TotalMember 属性

WXNewMemerTotalMember 属性

群成员数量

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int TotalMember { get; }

属性值

类型：Int32
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer 方法

WXNewMemer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXNewMemer.ToString 方法

WXNewMemerToString 方法

[缺少 "M:Chat.Framework.WXSdk.Events.WXNewMemer.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WXNewMemer 类
Chat.Framework.WXSdk.Events 命名空间


WXOpenWindow 类

协议用户聊天窗口被打开后触发的事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXOpenWindow

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXOpenWindow : WXEvent

WXOpenWindow 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXOpenWindow | 初始化 WXOpenWindow 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Friend | 被打开的用户信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXOpenWindow 构造函数

初始化 WXOpenWindow 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXOpenWindow(
    WeixinBase client,
    Friend friend
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXOpenWindow.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase,Chat.Framework.WXSdk.Friend)" 的 <param name="client"/> 文档]

friend
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXOpenWindow.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase,Chat.Framework.WXSdk.Friend)" 的 <param name="friend"/> 文档]

参见

引用

WXOpenWindow 类
Chat.Framework.WXSdk.Events 命名空间


WXOpenWindow 属性

WXOpenWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Friend | 被打开的用户信息
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WXOpenWindow 类
Chat.Framework.WXSdk.Events 命名空间


WXOpenWindow.Friend 属性

WXOpenWindowFriend 属性

被打开的用户信息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Friend Friend { get; }

属性值

类型：Friend
参见

引用

WXOpenWindow 类
Chat.Framework.WXSdk.Events 命名空间


WXOpenWindow 方法

WXOpenWindow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXOpenWindow 类
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg 类

微信收到群消息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXReceiveGroupMsg

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXReceiveGroupMsg : WXEvent

WXReceiveGroupMsg 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXReceiveGroupMsg(WXClientImpl_HOOK, GroupMember, Friend, String) | 初始化 WXReceiveGroupMsg 类的一个新实例
公共方法 | WXReceiveGroupMsg(WXClientImpl_IPAD, GroupMember, Friend, String) | 初始化 WXReceiveGroupMsg 类的一个新实例
公共方法 | WXReceiveGroupMsg(WXClientImpl_QYHOOK, GroupMember, Friend, String) | 初始化 WXReceiveGroupMsg 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Group | 群信息
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Member | 用户信息
公共属性 | Message | 收到的消息内容
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg 构造函数

重载列表
 | 名称 | 说明
公共方法 | WXReceiveGroupMsg(WXClientImpl_HOOK, GroupMember, Friend, String) | 初始化 WXReceiveGroupMsg 类的一个新实例
公共方法 | WXReceiveGroupMsg(WXClientImpl_IPAD, GroupMember, Friend, String) | 初始化 WXReceiveGroupMsg 类的一个新实例
公共方法 | WXReceiveGroupMsg(WXClientImpl_QYHOOK, GroupMember, Friend, String) | 初始化 WXReceiveGroupMsg 类的一个新实例
Top
参见

引用

WXReceiveGroupMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg 构造函数 (WXClientImpl_HOOK, GroupMember, Friend, String)

初始化 WXReceiveGroupMsg 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXReceiveGroupMsg(
    WXClientImpl_HOOK client,
    GroupMember member,
    Friend Group,
    string Message
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_HOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="client"/> 文档]

member
类型：Chat.Framework.WXSdkGroupMember

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="member"/> 文档]

Group
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="Group"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="Message"/> 文档]

参见

引用

WXReceiveGroupMsg 类
WXReceiveGroupMsg 重载
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg 构造函数 (WXClientImpl_IPAD, GroupMember, Friend, String)

初始化 WXReceiveGroupMsg 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXReceiveGroupMsg(
    WXClientImpl_IPAD client,
    GroupMember member,
    Friend Group,
    string Message
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="client"/> 文档]

member
类型：Chat.Framework.WXSdkGroupMember

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="member"/> 文档]

Group
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="Group"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="Message"/> 文档]

参见

引用

WXReceiveGroupMsg 类
WXReceiveGroupMsg 重载
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg 构造函数 (WXClientImpl_QYHOOK, GroupMember, Friend, String)

初始化 WXReceiveGroupMsg 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXReceiveGroupMsg(
    WXClientImpl_QYHOOK client,
    GroupMember member,
    Friend Group,
    string Message
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_QYHOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="client"/> 文档]

member
类型：Chat.Framework.WXSdkGroupMember

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="member"/> 文档]

Group
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="Group"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.GroupMember,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="Message"/> 文档]

参见

引用

WXReceiveGroupMsg 类
WXReceiveGroupMsg 重载
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg 属性

WXReceiveGroupMsg 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Group | 群信息
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Member | 用户信息
公共属性 | Message | 收到的消息内容
Top
参见

引用

WXReceiveGroupMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg.Group 属性

WXReceiveGroupMsgGroup 属性

群信息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Friend Group { get; }

属性值

类型：Friend
参见

引用

WXReceiveGroupMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg.Member 属性

WXReceiveGroupMsgMember 属性

用户信息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public GroupMember Member { get; }

属性值

类型：GroupMember
参见

引用

WXReceiveGroupMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg.Message 属性

WXReceiveGroupMsgMessage 属性

收到的消息内容

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

WXReceiveGroupMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg 方法

WXReceiveGroupMsg 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXReceiveGroupMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReceiveGroupMsg.ToString 方法

WXReceiveGroupMsgToString 方法

[缺少 "M:Chat.Framework.WXSdk.Events.WXReceiveGroupMsg.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WXReceiveGroupMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXRefreshContactSuccess 类

更新联系人成功
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXRefreshContactSuccess

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXRefreshContactSuccess : WXEvent

WXRefreshContactSuccess 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXRefreshContactSuccess | 初始化 WXRefreshContactSuccess 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXRefreshContactSuccess 构造函数

初始化 WXRefreshContactSuccess 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXRefreshContactSuccess(
    WeixinBase client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXRefreshContactSuccess.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase)" 的 <param name="client"/> 文档]

参见

引用

WXRefreshContactSuccess 类
Chat.Framework.WXSdk.Events 命名空间


WXRefreshContactSuccess 属性

WXRefreshContactSuccess 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WXRefreshContactSuccess 类
Chat.Framework.WXSdk.Events 命名空间


WXRefreshContactSuccess 方法

WXRefreshContactSuccess 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXRefreshContactSuccess 类
Chat.Framework.WXSdk.Events 命名空间


WXRefreshUser 类

微信更新信息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXRefreshUser

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXRefreshUser : WXEvent

WXRefreshUser 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXRefreshUser | 初始化 WXRefreshUser 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXRefreshUser 构造函数

初始化 WXRefreshUser 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXRefreshUser(
    WeixinBase wxclient
)

参数

wxclient
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXRefreshUser.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase)" 的 <param name="wxclient"/> 文档]

参见

引用

WXRefreshUser 类
Chat.Framework.WXSdk.Events 命名空间


WXRefreshUser 属性

WXRefreshUser 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
Top
参见

引用

WXRefreshUser 类
Chat.Framework.WXSdk.Events 命名空间


WXRefreshUser 方法

WXRefreshUser 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXRefreshUser 类
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg 类

私聊消息事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXReiceveFriendMsg

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXReiceveFriendMsg : WXEvent

WXReiceveFriendMsg 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXReiceveFriendMsg(WXClientImpl_HOOK, Friend, String) | 初始化 WXReiceveFriendMsg 类的一个新实例
公共方法 | WXReiceveFriendMsg(WXClientImpl_IPAD, Friend, String) | 初始化 WXReiceveFriendMsg 类的一个新实例
公共方法 | WXReiceveFriendMsg(WXClientImpl_QYHOOK, Friend, String) | 初始化 WXReiceveFriendMsg 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Friend | 发送者信息
公共属性 | IsRobot | 是否为机器人自己的消息true是自己的消息
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg 构造函数

重载列表
 | 名称 | 说明
公共方法 | WXReiceveFriendMsg(WXClientImpl_HOOK, Friend, String) | 初始化 WXReiceveFriendMsg 类的一个新实例
公共方法 | WXReiceveFriendMsg(WXClientImpl_IPAD, Friend, String) | 初始化 WXReiceveFriendMsg 类的一个新实例
公共方法 | WXReiceveFriendMsg(WXClientImpl_QYHOOK, Friend, String) | 初始化 WXReiceveFriendMsg 类的一个新实例
Top
参见

引用

WXReiceveFriendMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg 构造函数 (WXClientImpl_HOOK, Friend, String)

初始化 WXReiceveFriendMsg 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXReiceveFriendMsg(
    WXClientImpl_HOOK client,
    Friend friend,
    string message
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_HOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="client"/> 文档]

friend
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="friend"/> 文档]

message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="message"/> 文档]

参见

引用

WXReiceveFriendMsg 类
WXReiceveFriendMsg 重载
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg 构造函数 (WXClientImpl_IPAD, Friend, String)

初始化 WXReiceveFriendMsg 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXReiceveFriendMsg(
    WXClientImpl_IPAD client,
    Friend friend,
    string message
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="client"/> 文档]

friend
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="friend"/> 文档]

message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="message"/> 文档]

参见

引用

WXReiceveFriendMsg 类
WXReiceveFriendMsg 重载
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg 构造函数 (WXClientImpl_QYHOOK, Friend, String)

初始化 WXReiceveFriendMsg 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXReiceveFriendMsg(
    WXClientImpl_QYHOOK client,
    Friend friend,
    string message
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_QYHOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="client"/> 文档]

friend
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="friend"/> 文档]

message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.Friend,System.String)" 的 <param name="message"/> 文档]

参见

引用

WXReiceveFriendMsg 类
WXReiceveFriendMsg 重载
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg 属性

WXReiceveFriendMsg 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Friend | 发送者信息
公共属性 | IsRobot | 是否为机器人自己的消息true是自己的消息
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息
Top
参见

引用

WXReiceveFriendMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg.Friend 属性

WXReiceveFriendMsgFriend 属性

发送者信息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Friend Friend { get; }

属性值

类型：Friend
参见

引用

WXReiceveFriendMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg.IsRobot 属性

WXReiceveFriendMsgIsRobot 属性

是否为机器人自己的消息true是自己的消息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsRobot { get; }

属性值

类型：Boolean
参见

引用

WXReiceveFriendMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg.Message 属性

WXReiceveFriendMsgMessage 属性

消息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

WXReiceveFriendMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg 方法

WXReiceveFriendMsg 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXReiceveFriendMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReiceveFriendMsg.ToString 方法

WXReiceveFriendMsgToString 方法

[缺少 "M:Chat.Framework.WXSdk.Events.WXReiceveFriendMsg.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WXReiceveFriendMsg 类
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay 类

微信收到转账
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXReicevePay

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXReicevePay : WXEvent

WXReicevePay 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXReicevePay(WXClientImpl_HOOK, Friend, String, String, Double) | 初始化 WXReicevePay 类的一个新实例
公共方法 | WXReicevePay(WXClientImpl_IPAD, Friend, String, String, Double) | 初始化 WXReicevePay 类的一个新实例
公共方法 | WXReicevePay(WXClientImpl_QYHOOK, Friend, String, String, Double) | 初始化 WXReicevePay 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Friend | 转账用户信息
公共属性 | Invalidtime | 无效的时间
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Money | 金额
公共属性 | Transferid | 领取时需要的id
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXReicevePay 构造函数

重载列表
 | 名称 | 说明
公共方法 | WXReicevePay(WXClientImpl_HOOK, Friend, String, String, Double) | 初始化 WXReicevePay 类的一个新实例
公共方法 | WXReicevePay(WXClientImpl_IPAD, Friend, String, String, Double) | 初始化 WXReicevePay 类的一个新实例
公共方法 | WXReicevePay(WXClientImpl_QYHOOK, Friend, String, String, Double) | 初始化 WXReicevePay 类的一个新实例
Top
参见

引用

WXReicevePay 类
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay 构造函数 (WXClientImpl_HOOK, Friend, String, String, Double)

初始化 WXReicevePay 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXReicevePay(
    WXClientImpl_HOOK client,
    Friend Friend,
    string Invalidtime,
    string Transferid,
    double Money
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_HOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="client"/> 文档]

Friend
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Friend"/> 文档]

Invalidtime
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Invalidtime"/> 文档]

Transferid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Transferid"/> 文档]

Money
类型：SystemDouble

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Money"/> 文档]

参见

引用

WXReicevePay 类
WXReicevePay 重载
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay 构造函数 (WXClientImpl_IPAD, Friend, String, String, Double)

初始化 WXReicevePay 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXReicevePay(
    WXClientImpl_IPAD client,
    Friend Friend,
    string Invalidtime,
    string Transferid,
    double Money
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="client"/> 文档]

Friend
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Friend"/> 文档]

Invalidtime
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Invalidtime"/> 文档]

Transferid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Transferid"/> 文档]

Money
类型：SystemDouble

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Money"/> 文档]

参见

引用

WXReicevePay 类
WXReicevePay 重载
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay 构造函数 (WXClientImpl_QYHOOK, Friend, String, String, Double)

初始化 WXReicevePay 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXReicevePay(
    WXClientImpl_QYHOOK client,
    Friend Friend,
    string Invalidtime,
    string Transferid,
    double Money
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_QYHOOK

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="client"/> 文档]

Friend
类型：Chat.Framework.WXSdkFriend

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Friend"/> 文档]

Invalidtime
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Invalidtime"/> 文档]

Transferid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Transferid"/> 文档]

Money
类型：SystemDouble

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK,Chat.Framework.WXSdk.Friend,System.String,System.String,System.Double)" 的 <param name="Money"/> 文档]

参见

引用

WXReicevePay 类
WXReicevePay 重载
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay 属性

WXReicevePay 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | Friend | 转账用户信息
公共属性 | Invalidtime | 无效的时间
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Money | 金额
公共属性 | Transferid | 领取时需要的id
Top
参见

引用

WXReicevePay 类
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay.Friend 属性

WXReicevePayFriend 属性

转账用户信息

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Friend Friend { get; }

属性值

类型：Friend
参见

引用

WXReicevePay 类
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay.Invalidtime 属性

WXReicevePayInvalidtime 属性

无效的时间

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Invalidtime { get; }

属性值

类型：String
参见

引用

WXReicevePay 类
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay.Money 属性

WXReicevePayMoney 属性

金额

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double Money { get; }

属性值

类型：Double
参见

引用

WXReicevePay 类
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay.Transferid 属性

WXReicevePayTransferid 属性

领取时需要的id

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Transferid { get; }

属性值

类型：String
参见

引用

WXReicevePay 类
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay 方法

WXReicevePay 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (重写 ObjectToString.)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXReicevePay 类
Chat.Framework.WXSdk.Events 命名空间


WXReicevePay.ToString 方法

WXReicevePayToString 方法

[缺少 "M:Chat.Framework.WXSdk.Events.WXReicevePay.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WXReicevePay 类
Chat.Framework.WXSdk.Events 命名空间


WXScavengEvents 类

微信获取二维码事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXScavengEvents

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXScavengEvents : WXEvent

WXScavengEvents 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXScavengEvents | 初始化 WXScavengEvents 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Status | 二维码状态
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXScavengEvents 构造函数

初始化 WXScavengEvents 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXScavengEvents(
    WeixinBase client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXScavengEvents.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase)" 的 <param name="client"/> 文档]

参见

引用

WXScavengEvents 类
Chat.Framework.WXSdk.Events 命名空间


WXScavengEvents 属性

WXScavengEvents 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Status | 二维码状态
Top
参见

引用

WXScavengEvents 类
Chat.Framework.WXSdk.Events 命名空间


WXScavengEvents.Status 属性

WXScavengEventsStatus 属性

二维码状态

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Status { get; set; }

属性值

类型：Int32
参见

引用

WXScavengEvents 类
Chat.Framework.WXSdk.Events 命名空间


WXScavengEvents 方法

WXScavengEvents 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXScavengEvents 类
Chat.Framework.WXSdk.Events 命名空间


WXSendMessage 类

微信消息发送
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXSendMessage

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXSendMessage : WXEvent

WXSendMessage 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXSendMessage | 初始化 WXSendMessage 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息内容
公共属性 | ToUsername | 接收者账号
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXSendMessage 构造函数

初始化 WXSendMessage 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXSendMessage(
    WeixinBase client,
    string Message,
    string ToUsername
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXSendMessage.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase,System.String,System.String)" 的 <param name="client"/> 文档]

Message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXSendMessage.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase,System.String,System.String)" 的 <param name="Message"/> 文档]

ToUsername
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Events.WXSendMessage.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase,System.String,System.String)" 的 <param name="ToUsername"/> 文档]

参见

引用

WXSendMessage 类
Chat.Framework.WXSdk.Events 命名空间


WXSendMessage 属性

WXSendMessage 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息内容
公共属性 | ToUsername | 接收者账号
Top
参见

引用

WXSendMessage 类
Chat.Framework.WXSdk.Events 命名空间


WXSendMessage.Message 属性

WXSendMessageMessage 属性

消息内容

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

WXSendMessage 类
Chat.Framework.WXSdk.Events 命名空间


WXSendMessage.ToUsername 属性

WXSendMessageToUsername 属性

接收者账号

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ToUsername { get; }

属性值

类型：String
参见

引用

WXSendMessage 类
Chat.Framework.WXSdk.Events 命名空间


WXSendMessage 方法

WXSendMessage 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXSendMessage 类
Chat.Framework.WXSdk.Events 命名空间


WXWriteLog 类

微信日志事件
继承层次
SystemObject
Chat.FrameworkChatEvent
Chat.Framework.WXSdk.EventsWXEvent
Chat.Framework.WXSdk.EventsWXWriteLog

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXWriteLog : WXEvent

WXWriteLog 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXWriteLog | 初始化 WXWriteLog 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsDebug | 是否为debug
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息内容
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Events 命名空间


WXWriteLog 构造函数

初始化 WXWriteLog 类的一个新实例

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXWriteLog(
    WeixinBase wxclient
)

参数

wxclient
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.Events.WXWriteLog.#ctor(Chat.Framework.WXSdk.Implement.WeixinBase)" 的 <param name="wxclient"/> 文档]

参见

引用

WXWriteLog 类
Chat.Framework.WXSdk.Events 命名空间


WXWriteLog 属性

WXWriteLog 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cancel | 是否取消传递 (继承自 ChatEvent。)
公共属性 | Client | 微信基类 (继承自 WXEvent。)
公共属性 | CrtTime | 创建时间 (继承自 ChatEvent。)
公共属性 | IsDebug | 是否为debug
公共属性 | IsToString | (继承自 ChatEvent。)
公共属性 | Message | 消息内容
Top
参见

引用

WXWriteLog 类
Chat.Framework.WXSdk.Events 命名空间


WXWriteLog.IsDebug 属性

WXWriteLogIsDebug 属性

是否为debug

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsDebug { get; }

属性值

类型：Boolean
参见

引用

WXWriteLog 类
Chat.Framework.WXSdk.Events 命名空间


WXWriteLog.Message 属性

WXWriteLogMessage 属性

消息内容

命名空间： Chat.Framework.WXSdk.Events
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Message { get; }

属性值

类型：String
参见

引用

WXWriteLog 类
Chat.Framework.WXSdk.Events 命名空间


WXWriteLog 方法

WXWriteLog 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXWriteLog 类
Chat.Framework.WXSdk.Events 命名空间


Chat.Framework.WXSdk.Implement 命名空间

[缺少 "N:Chat.Framework.WXSdk.Implement" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | EventManage | 底层事件管理
公共类 | Lable | 标签
公共类 | ThreadExcutor |
公共类 | WeixinBase | 微信基类
公共类 | WeixinBaseUser | 微信基础用户
公共类 | WeixinClientImpl_TCPServer |
公共类 | WXClientImpl_HOOK | 普通PC机器人
公共类 | WXClientImpl_HOOKCirCleInfoOri |
公共类 | WXClientImpl_HOOKCommentUserListOri |
公共类 | WXClientImpl_HOOKLikeUserListOri |
公共类 | WXClientImpl_HOOKObjectDesc |
公共类 | WXClientImpl_HOOKObjectOperations |
公共类 | WXClientImpl_HOOKPreDownloadInfo |
公共类 | WXClientImpl_HOOKSnsRedEnvelops |
公共类 | WXClientImpl_HOOKWeAppInfo |
公共类 | WXClientImpl_IPAD | 协议微信
公共类 | WXClientImpl_QYHOOK | 企业PC机器人
接口
 | 接口 | 说明
公共接口 | ICallable |
公共接口 | IRunable |
枚举
 | 枚举 | 说明
公共枚举 | CircleCommentType | 朋友圈评论类型
公共枚举 | EditContactsType | 协议操作类型
公共枚举 | LoginDeviceType | 协议类型
公共枚举 | WeixinType | 微信类型


CircleCommentType 枚举

朋友圈评论类型

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum CircleCommentType
成员
成员名称 | 值 | 说明
评论 | 2 |
点赞 | 1 |
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


EditContactsType 枚举

协议操作类型

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum EditContactsType
成员
成员名称 | 值 | 说明
保存通讯录 | 2051 |
取消保存通讯录 | 2 |
星标 | 71 |
取消星标 | 7 |
备注 | 7 |
拉黑 | 15 |
取消拉黑 | 7 |
置顶 | 2055 |
取消置顶 | 7 |
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


EventManage 类

底层事件管理
继承层次
SystemObject
Chat.Framework.WXSdk.ImplementEventManage

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class EventManage

EventManage 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | EventManage | 初始化 EventManage 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
事件
 | 名称 | 说明
公共事件 | WXApplyFriendEvent | 申请添加好友
公共事件 | WXApplyGroupEvent | 成员申请加入群
公共事件 | WXChangeStatusEvent | 登录状态发生改变
公共事件 | WXGetDeviceEvent | 获取设置信息事件
公共事件 | WXNewFriendEvent | 新增微信好友
公共事件 | WXNewMemerEvent | 新增群成员
公共事件 | WXOpenWindowEvent |
公共事件 | WXReceiveGroupMsgEvent | 收到群消息
公共事件 | WXRefreshContactSuccessEvent | 刷新通讯录完成
公共事件 | WXRefreshUserEvent | 用户信息发生改变
公共事件 | WXReiceveFriendMsgEvent | 收到好友消息
公共事件 | WXScavengEvent |
公共事件 | WXSendMessageEvent |
公共事件 | WXWriteLogEvent | 日志输出事件
公共事件 | WXWXReicevePayEvent |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


EventManage 构造函数

初始化 EventManage 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public EventManage()
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage 方法

EventManage 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage 事件

EventManage 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | WXApplyFriendEvent | 申请添加好友
公共事件 | WXApplyGroupEvent | 成员申请加入群
公共事件 | WXChangeStatusEvent | 登录状态发生改变
公共事件 | WXGetDeviceEvent | 获取设置信息事件
公共事件 | WXNewFriendEvent | 新增微信好友
公共事件 | WXNewMemerEvent | 新增群成员
公共事件 | WXOpenWindowEvent |
公共事件 | WXReceiveGroupMsgEvent | 收到群消息
公共事件 | WXRefreshContactSuccessEvent | 刷新通讯录完成
公共事件 | WXRefreshUserEvent | 用户信息发生改变
公共事件 | WXReiceveFriendMsgEvent | 收到好友消息
公共事件 | WXScavengEvent |
公共事件 | WXSendMessageEvent |
公共事件 | WXWriteLogEvent | 日志输出事件
公共事件 | WXWXReicevePayEvent |
Top
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXApplyFriendEvent 事件

EventManageWXApplyFriendEvent 事件

申请添加好友

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXApplyFriend> WXApplyFriendEvent

值

类型：SystemEventHandler WXApplyFriend
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXApplyGroupEvent 事件

EventManageWXApplyGroupEvent 事件

成员申请加入群

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXApplyGroup> WXApplyGroupEvent

值

类型：SystemEventHandler WXApplyGroup
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXChangeStatusEvent 事件

EventManageWXChangeStatusEvent 事件

登录状态发生改变

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXChangeStatus> WXChangeStatusEvent

值

类型：SystemEventHandler WXChangeStatus
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXGetDeviceEvent 事件

EventManageWXGetDeviceEvent 事件

获取设置信息事件

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXGetDevice> WXGetDeviceEvent

值

类型：SystemEventHandler WXGetDevice
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXNewFriendEvent 事件

EventManageWXNewFriendEvent 事件

新增微信好友

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXNewFriend> WXNewFriendEvent

值

类型：SystemEventHandler WXNewFriend
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXNewMemerEvent 事件

EventManageWXNewMemerEvent 事件

新增群成员

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXNewMemer> WXNewMemerEvent

值

类型：SystemEventHandler WXNewMemer
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXOpenWindowEvent 事件

EventManageWXOpenWindowEvent 事件

[缺少 "E:Chat.Framework.WXSdk.Implement.EventManage.WXOpenWindowEvent" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXOpenWindow> WXOpenWindowEvent

值

类型：SystemEventHandler WXOpenWindow
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXReceiveGroupMsgEvent 事件

EventManageWXReceiveGroupMsgEvent 事件

收到群消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXReceiveGroupMsg> WXReceiveGroupMsgEvent

值

类型：SystemEventHandler WXReceiveGroupMsg
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXRefreshContactSuccessEvent 事件

EventManageWXRefreshContactSuccessEvent 事件

刷新通讯录完成

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXRefreshContactSuccess> WXRefreshContactSuccessEvent

值

类型：SystemEventHandler WXRefreshContactSuccess
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXRefreshUserEvent 事件

EventManageWXRefreshUserEvent 事件

用户信息发生改变

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXRefreshUser> WXRefreshUserEvent

值

类型：SystemEventHandler WXRefreshUser
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXReiceveFriendMsgEvent 事件

EventManageWXReiceveFriendMsgEvent 事件

收到好友消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXReiceveFriendMsg> WXReiceveFriendMsgEvent

值

类型：SystemEventHandler WXReiceveFriendMsg
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXScavengEvent 事件

EventManageWXScavengEvent 事件

[缺少 "E:Chat.Framework.WXSdk.Implement.EventManage.WXScavengEvent" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXScavengEvents> WXScavengEvent

值

类型：SystemEventHandler WXScavengEvents
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXSendMessageEvent 事件

EventManageWXSendMessageEvent 事件

[缺少 "E:Chat.Framework.WXSdk.Implement.EventManage.WXSendMessageEvent" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXSendMessage> WXSendMessageEvent

值

类型：SystemEventHandler WXSendMessage
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXWriteLogEvent 事件

EventManageWXWriteLogEvent 事件

日志输出事件

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXWriteLog> WXWriteLogEvent

值

类型：SystemEventHandler WXWriteLog
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


EventManage.WXWXReicevePayEvent 事件

EventManageWXWXReicevePayEvent 事件

[缺少 "E:Chat.Framework.WXSdk.Implement.EventManage.WXWXReicevePayEvent" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<WXReicevePay> WXWXReicevePayEvent

值

类型：SystemEventHandler WXReicevePay
参见

引用

EventManage 类
Chat.Framework.WXSdk.Implement 命名空间


ICallable 接口

[缺少 "T:Chat.Framework.WXSdk.Implement.ICallable" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public interface ICallable

ICallable 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning |
Top
方法
 | 名称 | 说明
公共方法 | Call |
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


ICallable 属性

ICallable 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning |
Top
参见

引用

ICallable 接口
Chat.Framework.WXSdk.Implement 命名空间


ICallable.IsRunning 属性

ICallableIsRunning 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.ICallable.IsRunning" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
bool IsRunning { get; }

属性值

类型：Boolean
参见

引用

ICallable 接口
Chat.Framework.WXSdk.Implement 命名空间


ICallable 方法

ICallable 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Call |
Top
参见

引用

ICallable 接口
Chat.Framework.WXSdk.Implement 命名空间


ICallable.Call 方法

ICallableCall 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.ICallable.Call(System.Object)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
void Call(
    Object state
)

参数

state
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.Implement.ICallable.Call(System.Object)" 的 <param name="state"/> 文档]

参见

引用

ICallable 接口
Chat.Framework.WXSdk.Implement 命名空间


IRunable 接口

[缺少 "T:Chat.Framework.WXSdk.Implement.IRunable" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public interface IRunable : IDisposable

IRunable 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning |
公共属性 | RegisterdHandler |
公共属性 | WaitHandler |
Top
方法
 | 名称 | 说明
公共方法 | Dispose | (继承自 IDisposable。)
公共方法 | Run |
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


IRunable 属性

IRunable 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsRunning |
公共属性 | RegisterdHandler |
公共属性 | WaitHandler |
Top
参见

引用

IRunable 接口
Chat.Framework.WXSdk.Implement 命名空间


IRunable.IsRunning 属性

IRunableIsRunning 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.IRunable.IsRunning" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
bool IsRunning { get; }

属性值

类型：Boolean
参见

引用

IRunable 接口
Chat.Framework.WXSdk.Implement 命名空间


IRunable.RegisterdHandler 属性

IRunableRegisterdHandler 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.IRunable.RegisterdHandler" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
RegisteredWaitHandle RegisterdHandler { get; set; }

属性值

类型：RegisteredWaitHandle
参见

引用

IRunable 接口
Chat.Framework.WXSdk.Implement 命名空间


IRunable.WaitHandler 属性

IRunableWaitHandler 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.IRunable.WaitHandler" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
WaitHandle WaitHandler { get; set; }

属性值

类型：WaitHandle
参见

引用

IRunable 接口
Chat.Framework.WXSdk.Implement 命名空间


IRunable 方法

IRunable 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose | (继承自 IDisposable。)
公共方法 | Run |
Top
参见

引用

IRunable 接口
Chat.Framework.WXSdk.Implement 命名空间


IRunable.Run 方法

IRunableRun 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.IRunable.Run(System.Object,System.Boolean)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
void Run(
    Object state,
    bool timedOut
)

参数

state
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.Implement.IRunable.Run(System.Object,System.Boolean)" 的 <param name="state"/> 文档]

timedOut
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.IRunable.Run(System.Object,System.Boolean)" 的 <param name="timedOut"/> 文档]

参见

引用

IRunable 接口
Chat.Framework.WXSdk.Implement 命名空间


Lable 类

标签
继承层次
SystemObject
Chat.Framework.WXSdk.ImplementLable

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Lable

Lable 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Lable | 初始化 Lable 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | LabelID | 标签ID
公共属性 | LabelName | 标签名称
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


Lable 构造函数

初始化 Lable 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Lable()
参见

引用

Lable 类
Chat.Framework.WXSdk.Implement 命名空间


Lable 属性

Lable 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | LabelID | 标签ID
公共属性 | LabelName | 标签名称
Top
参见

引用

Lable 类
Chat.Framework.WXSdk.Implement 命名空间


Lable.LabelID 属性

LableLabelID 属性

标签ID

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string LabelID { get; set; }

属性值

类型：String
参见

引用

Lable 类
Chat.Framework.WXSdk.Implement 命名空间


Lable.LabelName 属性

LableLabelName 属性

标签名称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string LabelName { get; set; }

属性值

类型：String
参见

引用

Lable 类
Chat.Framework.WXSdk.Implement 命名空间


Lable 方法

Lable 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Lable 类
Chat.Framework.WXSdk.Implement 命名空间


LoginDeviceType 枚举

协议类型

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum LoginDeviceType
成员
成员名称 | 值 | 说明
未知 | 0 |
Ipad | 1 |
Mac | 3 |
Windows | 5 |
QQBrowser | 7 |
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


ThreadExcutor 类

[缺少 "T:Chat.Framework.WXSdk.Implement.ThreadExcutor" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementThreadExcutor

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ThreadExcutor

ThreadExcutor 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ThreadExcutor | 初始化 ThreadExcutor 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | RegisterIntervalObject |
 | Submit |
公共方法 | ToString | (继承自 Object。)
 | UnRegisterIntervaluObject |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


ThreadExcutor 构造函数

初始化 ThreadExcutor 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ThreadExcutor()
参见

引用

ThreadExcutor 类
Chat.Framework.WXSdk.Implement 命名空间


ThreadExcutor 方法

ThreadExcutor 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | RegisterIntervalObject |
 | Submit |
公共方法 | ToString | (继承自 Object。)
 | UnRegisterIntervaluObject |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ThreadExcutor 类
Chat.Framework.WXSdk.Implement 命名空间


ThreadExcutor.RegisterIntervalObject 方法

ThreadExcutorRegisterIntervalObject 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.RegisterIntervalObject(Chat.Framework.WXSdk.Implement.IRunable,System.Object,System.Int64,System.Boolean)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void RegisterIntervalObject(
    IRunable runnable,
    Object state,
    long interval,
    bool onlyOnce
)

参数

runnable
类型：Chat.Framework.WXSdk.ImplementIRunable

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.RegisterIntervalObject(Chat.Framework.WXSdk.Implement.IRunable,System.Object,System.Int64,System.Boolean)" 的 <param name="runnable"/> 文档]

state
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.RegisterIntervalObject(Chat.Framework.WXSdk.Implement.IRunable,System.Object,System.Int64,System.Boolean)" 的 <param name="state"/> 文档]

interval
类型：SystemInt64

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.RegisterIntervalObject(Chat.Framework.WXSdk.Implement.IRunable,System.Object,System.Int64,System.Boolean)" 的 <param name="interval"/> 文档]

onlyOnce
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.RegisterIntervalObject(Chat.Framework.WXSdk.Implement.IRunable,System.Object,System.Int64,System.Boolean)" 的 <param name="onlyOnce"/> 文档]

参见

引用

ThreadExcutor 类
Chat.Framework.WXSdk.Implement 命名空间


ThreadExcutor.Submit 方法

ThreadExcutorSubmit 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.Submit(Chat.Framework.WXSdk.Implement.ICallable,System.Object)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Submit(
    ICallable callable,
    Object state
)

参数

callable
类型：Chat.Framework.WXSdk.ImplementICallable

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.Submit(Chat.Framework.WXSdk.Implement.ICallable,System.Object)" 的 <param name="callable"/> 文档]

state
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.Submit(Chat.Framework.WXSdk.Implement.ICallable,System.Object)" 的 <param name="state"/> 文档]

参见

引用

ThreadExcutor 类
Chat.Framework.WXSdk.Implement 命名空间


ThreadExcutor.UnRegisterIntervaluObject 方法

ThreadExcutorUnRegisterIntervaluObject 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.UnRegisterIntervaluObject(Chat.Framework.WXSdk.Implement.IRunable)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void UnRegisterIntervaluObject(
    IRunable runnable
)

参数

runnable
类型：Chat.Framework.WXSdk.ImplementIRunable

[缺少 "M:Chat.Framework.WXSdk.Implement.ThreadExcutor.UnRegisterIntervaluObject(Chat.Framework.WXSdk.Implement.IRunable)" 的 <param name="runnable"/> 文档]

参见

引用

ThreadExcutor 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase 类

微信基类
继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWeixinBase
Chat.Framework.WXSdk.ImplementWeixinClientImpl_TCPServer
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOK
Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD
Chat.Framework.WXSdk.ImplementWXClientImpl_QYHOOK

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WeixinBase : IDisposable

WeixinBase 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WeixinBase | 初始化 WeixinBase 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Status | 微信状态
公共属性 | User | 用户
公共属性 | WeixinHao | 微信号
公共属性 | WeixinType | 微信类型
Top
方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | 添加群用户
公共方法 | AddChatRoomMember_40Down | 添加群用户_40人以下
公共方法 | AddLabel | 添加标签
公共方法 | AddPublicUser | 关注公众号
公共方法 | AgreeAddMe | 同意添加我为好友
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序
公共方法 | ChangeStatus | 微信状态改变
公共方法 | CheckUrl | 检测URL在微信中是否有效
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录
公共方法 | CreateChatRoom(String) | 创建群聊
公共方法 | CreateChatRoom(String) | 创建群
公共方法 | DeleteFriend | 删除朋友
公共方法 | DeleteGroupMember | 删除群用户
公共方法 | Dispose | 释放被 WeixinBase 使用的所有资源
公共方法 | DownlowdImage | 下载图片
公共方法 | EditContacts | 编辑用户信息
公共方法 | EditUserLabel | 批量修改标签
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindCircle | 获取朋友圈
公共方法 | FindCircles | 获取朋友圈
公共方法 | FindFriendsT | 获得好友列表
公共方法 | FocusWechat | 关注公众号
公共方法 | GetBalance |
公共方法 | GetContact | 获得联系人信息
公共方法 | GetGroupsNotInMember | 获取群列表(不包含群成员)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签组
公共方法 | GetMember(String, String) | 获取群用户信息
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息带刷新
公共方法 | GetMembers | 获取群成员,不支持pc
公共方法 | GetRobotQRcode | 获得机器人二维码
公共方法 | GetType | (继承自 Object。)
公共方法 | InviteIntoGroup | 邀请入群
公共方法 | LoginOut | 退出微信
公共方法 | LoginOut(String) | 退出微信
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称
公共方法 | ModRoomName | 修改群聊名称
公共方法 | OpenUrl | 打开内置浏览器
公共方法 | Receive | 分析事件
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表)
公共方法 | ResetConnection | 重新连接微信
公共方法 | SendCard | 发送卡片消息
公共方法 | SendCDNImage | 发送CDN图片
公共方法 | SendCDNInfo | 秒发CDN消息
公共方法 | SendCDNVideo | 发送CDN视频
公共方法 | SendCircle | 发表朋友圈
公共方法 | SendCircleComment | 发表评论
公共方法 | SendCirclePraise | 点赞
公共方法 | SendImage(Byte, String) | 发送图片
公共方法 | SendImage(String, String) | 发送图片
公共方法 | SendMessage | 发送消息
公共方法 | SendPay | 发送红包
公共方法 | SendProgramMessage | 发送小程序
公共方法 | SendVoice | 发送语音
公共方法 | SerchKeyword | 搜索关键词
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能
公共方法 | SetRecvNotify | 是否消息免打扰
公共方法 | SetRoomName | 修改群聊名称
公共方法 | SetRoomNotice | 修改群公告(可用于@全体)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称
公共方法 | SetSessionReadedMsg | 设置会话已读
公共方法 | ShowLogin | 启动微信
公共方法 | SnsVerify | 验证支付
公共方法 | TenPayTransferConfirm | 领取转账
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteLog | 写出日志
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WeixinBase 构造函数

初始化 WeixinBase 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinBase()
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase 属性

WeixinBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Status | 微信状态
公共属性 | User | 用户
公共属性 | WeixinHao | 微信号
公共属性 | WeixinType | 微信类型
Top
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.Status 属性

WeixinBaseStatus 属性

微信状态

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WxStatus Status { get; set; }

属性值

类型：WxStatus
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.User 属性

WeixinBaseUser 属性

用户

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinBaseUser User { get; set; }

属性值

类型：WeixinBaseUser
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.WeixinHao 属性

WeixinBaseWeixinHao 属性

微信号

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string WeixinHao { get; }

属性值

类型：String
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.WeixinType 属性

WeixinBaseWeixinType 属性

微信类型

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinType WeixinType { get; set; }

属性值

类型：WeixinType
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase 方法

WeixinBase 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | 添加群用户
公共方法 | AddChatRoomMember_40Down | 添加群用户_40人以下
公共方法 | AddLabel | 添加标签
公共方法 | AddPublicUser | 关注公众号
公共方法 | AgreeAddMe | 同意添加我为好友
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序
公共方法 | ChangeStatus | 微信状态改变
公共方法 | CheckUrl | 检测URL在微信中是否有效
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录
公共方法 | CreateChatRoom(String) | 创建群聊
公共方法 | CreateChatRoom(String) | 创建群
公共方法 | DeleteFriend | 删除朋友
公共方法 | DeleteGroupMember | 删除群用户
公共方法 | Dispose |
公共方法 | DownlowdImage | 下载图片
公共方法 | EditContacts | 编辑用户信息
公共方法 | EditUserLabel | 批量修改标签
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindCircle | 获取朋友圈
公共方法 | FindCircles | 获取朋友圈
公共方法 | FindFriendsT | 获得好友列表
公共方法 | FocusWechat | 关注公众号
公共方法 | GetBalance |
公共方法 | GetContact | 获得联系人信息
公共方法 | GetGroupsNotInMember | 获取群列表(不包含群成员)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签组
公共方法 | GetMember(String, String) | 获取群用户信息
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息带刷新
公共方法 | GetMembers | 获取群成员,不支持pc
公共方法 | GetRobotQRcode | 获得机器人二维码
公共方法 | GetType | (继承自 Object。)
公共方法 | InviteIntoGroup | 邀请入群
公共方法 | LoginOut | 退出微信
公共方法 | LoginOut(String) | 退出微信
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称
公共方法 | ModRoomName | 修改群聊名称
公共方法 | OpenUrl | 打开内置浏览器
公共方法 | Receive | 分析事件
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表)
公共方法 | ResetConnection | 重新连接微信
公共方法 | SendCard | 发送卡片消息
公共方法 | SendCDNImage | 发送CDN图片
公共方法 | SendCDNInfo | 秒发CDN消息
公共方法 | SendCDNVideo | 发送CDN视频
公共方法 | SendCircle | 发表朋友圈
公共方法 | SendCircleComment | 发表评论
公共方法 | SendCirclePraise | 点赞
公共方法 | SendImage(Byte, String) | 发送图片
公共方法 | SendImage(String, String) | 发送图片
公共方法 | SendMessage | 发送消息
公共方法 | SendPay | 发送红包
公共方法 | SendProgramMessage | 发送小程序
公共方法 | SendVoice | 发送语音
公共方法 | SerchKeyword | 搜索关键词
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能
公共方法 | SetRecvNotify | 是否消息免打扰
公共方法 | SetRoomName | 修改群聊名称
公共方法 | SetRoomNotice | 修改群公告(可用于@全体)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称
公共方法 | SetSessionReadedMsg | 设置会话已读
公共方法 | ShowLogin | 启动微信
公共方法 | SnsVerify | 验证支付
公共方法 | TenPayTransferConfirm | 领取转账
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteLog | 写出日志
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.AddChatRoomMember 方法

WeixinBaseAddChatRoomMember 方法

添加群用户

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void AddChatRoomMember(
    string groupid,
    string members
)

参数

groupid
类型：SystemString
群号
members
类型：SystemString
用户wxid多个用户逗号分隔
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.AddChatRoomMember_40Down 方法

WeixinBaseAddChatRoomMember_40Down 方法

添加群用户_40人以下

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void AddChatRoomMember_40Down(
    string groupid,
    string members
)

参数

groupid
类型：SystemString
群id
members
类型：SystemString
用户账号多个用英文逗号分隔
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.AddLabel 方法

WeixinBaseAddLabel 方法

添加标签

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual bool AddLabel(
    string TagName
)

参数

TagName
类型：SystemString
标签名称

返回值

类型：Boolean
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.AddPublicUser 方法

WeixinBaseAddPublicUser 方法

关注公众号

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void AddPublicUser(
    string wxid
)

参数

wxid
类型：SystemString
公众号wxid
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.AgreeAddMe 方法

WeixinBaseAgreeAddMe 方法

同意添加我为好友

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string AgreeAddMe(
    string token
)

参数

token
类型：SystemString
收到添加好友信息token信息

返回值

类型：String
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.AutoAuthMiniAPPLogin 方法

WeixinBaseAutoAuthMiniAPPLogin 方法

自动授权登录小程序

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string AutoAuthMiniAPPLogin(
    string appid
)

参数

appid
类型：SystemString
appid

返回值

类型：String
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.ChangeStatus 方法

WeixinBaseChangeStatus 方法

微信状态改变

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void ChangeStatus(
    WxStatus status,
    WXChangeStatus e = null,
    bool is_next = true
)

参数

status
类型：Chat.Framework.WXSdkWxStatus
状态
e (Optional)
类型：Chat.Framework.WXSdk.EventsWXChangeStatus
微信修改状态事件,可为空
is_next (Optional)
类型：SystemBoolean
无用
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.CheckUrl 方法

WeixinBaseCheckUrl 方法

检测URL在微信中是否有效

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual bool CheckUrl(
    string url
)

参数

url
类型：SystemString
url

返回值

类型：Boolean
0可以访问， -x 负值代表不能访问
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.ClearChatHistoryMsg 方法

WeixinBaseClearChatHistoryMsg 方法

清理历史聊天记录

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void ClearChatHistoryMsg()

返回值

类型：
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.CreateChatRoom 方法

WeixinBaseCreateChatRoom 方法

重载列表
 | 名称 | 说明
公共方法 | CreateChatRoom(String) | 创建群聊
公共方法 | CreateChatRoom(String) | 创建群
Top
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.CreateChatRoom 方法 (String)

WeixinBaseCreateChatRoom 方法 (String)

创建群聊

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string CreateChatRoom(
    string members
)

参数

members
类型：SystemString
用户账号用英文逗号分隔

返回值

类型：String
参见

引用

WeixinBase 类
CreateChatRoom 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.CreateChatRoom 方法 (String[])

WeixinBaseCreateChatRoom 方法 (String)

创建群

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string CreateChatRoom(
    string[] wxids
)

参数

wxids
类型：SystemString
用户账号3个或者以上

返回值

类型：String
参见

引用

WeixinBase 类
CreateChatRoom 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.DeleteFriend 方法

WeixinBaseDeleteFriend 方法

删除朋友

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string DeleteFriend(
    string username
)

参数

username
类型：SystemString
用户wxid

返回值

类型：String
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.DeleteGroupMember 方法

WeixinBaseDeleteGroupMember 方法

删除群用户

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string DeleteGroupMember(
    string username,
    string groupId
)

参数

username
类型：SystemString
用户账号
groupId
类型：SystemString
群id

返回值

类型：String
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.Dispose 方法

WeixinBaseDispose 方法

释放被 WeixinBase 使用的所有资源

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()

实现

IDisposableDispose
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.DownlowdImage 方法

WeixinBaseDownlowdImage 方法

下载图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string DownlowdImage(
    int msgid,
    string fromUsername,
    int datatotalength
)

参数

msgid
类型：SystemInt32
消息id
fromUsername
类型：SystemString
账号
datatotalength
类型：SystemInt32
长度

返回值

类型：String
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.EditContacts 方法

WeixinBaseEditContacts 方法

编辑用户信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void EditContacts(
    string username,
    EditContactsType type,
    string remark = ""
)

参数

username
类型：SystemString
操作用户
type
类型：Chat.Framework.WXSdk.ImplementEditContactsType
操作类型
remark (Optional)
类型：SystemString
如果Type=备注,为空表示取消备注,不为空表示备注所填写内容
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.EditUserLabel 方法

WeixinBaseEditUserLabel 方法

批量修改标签

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual bool EditUserLabel(
    string[] Users,
    List<Lable> Lable
)

参数

Users
类型：SystemString
用户信息
Lable
类型：System.Collections.GenericList Lable
标签组

返回值

类型：Boolean
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.FindCircle 方法

WeixinBaseFindCircle 方法

获取朋友圈

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual List<Dictionary<string, Object>> FindCircle(
    string username,
    string firstPageMd5 = "",
    int MaxId = 0
)

参数

username
类型：SystemString
微信ID
firstPageMd5 (Optional)
类型：SystemString
页码
MaxId (Optional)
类型：SystemInt32
页码ID

返回值

类型：List Dictionary String, Object
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.FindCircles 方法

WeixinBaseFindCircles 方法

获取朋友圈

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual List<Dictionary<string, Object>> FindCircles()

返回值

类型：List Dictionary String, Object
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.FindFriends(T) 方法

WeixinBaseFindFriendsT 方法

获得好友列表

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual List<T> FindFriends<T>()

类型参数

T

返回值

类型：List T
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.FocusWechat 方法

WeixinBaseFocusWechat 方法

关注公众号

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual bool FocusWechat(
    string username
)

参数

username
类型：SystemString
公众号账号

返回值

类型：Boolean
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.GetBalance 方法

WeixinBaseGetBalance 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBase.GetBalance" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual Dictionary<string, Object> GetBalance()

返回值

类型：Dictionary String, Object
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.GetContact 方法

WeixinBaseGetContact 方法

获得联系人信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual Friend GetContact(
    string wxid,
    bool refresh = false
)

参数

wxid
类型：SystemString
用户账号
refresh (Optional)
类型：SystemBoolean
时候刷新

返回值

类型：Friend
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.GetGroupsNotInMember 方法

WeixinBaseGetGroupsNotInMember 方法

获取群列表(不包含群成员)

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual List<Friend> GetGroupsNotInMember()

返回值

类型：List Friend
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.GetLabelList 方法

WeixinBaseGetLabelList 方法

获取标签组

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual List<Lable> GetLabelList(
    bool refresh = false
)

参数

refresh (Optional)
类型：SystemBoolean
是否刷新标签组

返回值

类型：List Lable
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.GetMember 方法

WeixinBaseGetMember 方法

重载列表
 | 名称 | 说明
公共方法 | GetMember(String, String) | 获取群用户信息
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息带刷新
Top
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.GetMember 方法 (String, String)

WeixinBaseGetMember 方法 (String, String)

获取群用户信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual GroupMember GetMember(
    string groupid,
    string wxid
)

参数

groupid
类型：SystemString
群
wxid
类型：SystemString
用户账号

返回值

类型：GroupMember
参见

引用

WeixinBase 类
GetMember 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.GetMember 方法 (String, String, Boolean)

WeixinBaseGetMember 方法 (String, String, Boolean)

获取群用户信息带刷新

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual GroupMember GetMember(
    string groupid,
    string wxid,
    bool flush = false
)

参数

groupid
类型：SystemString
群
wxid
类型：SystemString
用户账号
flush (Optional)
类型：SystemBoolean
刷新

返回值

类型：GroupMember
参见

引用

WeixinBase 类
GetMember 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.GetMembers 方法

WeixinBaseGetMembers 方法

获取群成员,不支持pc

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual GroupMember[] GetMembers(
    string groupid,
    bool flag = false
)

参数

groupid
类型：SystemString
群id
flag (Optional)
类型：SystemBoolean
是否刷新

返回值

类型：GroupMember
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.GetRobotQRcode 方法

WeixinBaseGetRobotQRcode 方法

获得机器人二维码

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual Bitmap GetRobotQRcode(
    bool Refresh = false
)

参数

Refresh (Optional)
类型：SystemBoolean
刷新

返回值

类型：Bitmap
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.InviteIntoGroup 方法

WeixinBaseInviteIntoGroup 方法

邀请入群

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string InviteIntoGroup(
    string username,
    string groupId
)

参数

username
类型：SystemString
用户wxid
groupId
类型：SystemString
群id

返回值

类型：String
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.LoginOut 方法

WeixinBaseLoginOut 方法

重载列表
 | 名称 | 说明
公共方法 | LoginOut | 退出微信
公共方法 | LoginOut(String) | 退出微信
Top
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.LoginOut 方法

WeixinBaseLoginOut 方法

退出微信

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void LoginOut()
参见

引用

WeixinBase 类
LoginOut 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.LoginOut 方法 (String)

WeixinBaseLoginOut 方法 (String)

退出微信

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void LoginOut(
    string message
)

参数

message
类型：SystemString
退出说明
参见

引用

WeixinBase 类
LoginOut 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.ModRoomMyName 方法

WeixinBaseModRoomMyName 方法

设置自己在群中昵称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void ModRoomMyName(
    string nickname,
    string groupId
)

参数

nickname
类型：SystemString
要设置的昵称
groupId
类型：SystemString
需要设置的群id
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.ModRoomName 方法

WeixinBaseModRoomName 方法

修改群聊名称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void ModRoomName(
    string newnick,
    string groupId
)

参数

newnick
类型：SystemString
新名称
groupId
类型：SystemString
群号
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.OpenUrl 方法

WeixinBaseOpenUrl 方法

打开内置浏览器

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void OpenUrl(
    string url
)

参数

url
类型：SystemString
url

返回值

类型：
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.Receive 方法

WeixinBaseReceive 方法

分析事件

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void Receive(
    Object obj
)

参数

obj
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBase.Receive(System.Object)" 的 <param name="obj"/> 文档]

参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.RefreshContact 方法

WeixinBaseRefreshContact 方法

刷新通讯录信息(获取好友列表)

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void RefreshContact(
    Action<WXClientImpl_IPAD> method = null
)

参数

method (Optional)
类型：SystemAction WXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBase.RefreshContact(System.Action{Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD})" 的 <param name="method"/> 文档]

参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.ResetConnection 方法

WeixinBaseResetConnection 方法

重新连接微信

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void ResetConnection(
    int next = 3
)

参数

next (Optional)
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBase.ResetConnection(System.Int32)" 的 <param name="next"/> 文档]

参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendCard 方法

WeixinBaseSendCard 方法

发送卡片消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendCard(
    string username,
    string friendwxid
)

参数

username
类型：SystemString
接收者账号
friendwxid
类型：SystemString
卡片用户账号
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendCDNImage 方法

WeixinBaseSendCDNImage 方法

发送CDN图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendCDNImage(
    string tousername,
    string data
)

参数

tousername
类型：SystemString
接收者账号
data
类型：SystemString
图片cdn
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendCDNInfo 方法

WeixinBaseSendCDNInfo 方法

秒发CDN消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendCDNInfo(
    string tousername,
    string cdnurl,
    string aeskey,
    CDNType type
)

参数

tousername
类型：SystemString
接收者账号
cdnurl
类型：SystemString
cdnurl
aeskey
类型：SystemString
aeskey
type
类型：Chat.Framework.WXSdk.IPADCDNType
type
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendCDNVideo 方法

WeixinBaseSendCDNVideo 方法

发送CDN视频

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendCDNVideo(
    string tousername,
    string cdnurl,
    string aeskey
)

参数

tousername
类型：SystemString
接收者账号
cdnurl
类型：SystemString
cdnurl
aeskey
类型：SystemString
aeskey
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendCircle 方法

WeixinBaseSendCircle 方法

发表朋友圈

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string SendCircle(
    string msg
)

参数

msg
类型：SystemString
内容-需要携带至少一张图片,例如:[图片=路径]

返回值

类型：String
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendCircleComment 方法

WeixinBaseSendCircleComment 方法

发表评论

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendCircleComment(
    string username,
    string circleId,
    string content
)

参数

username
类型：SystemString
发送的微信ID
circleId
类型：SystemString
朋友圈的ID
content
类型：SystemString
发送的内容

返回值

类型：
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendCirclePraise 方法

WeixinBaseSendCirclePraise 方法

点赞

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendCirclePraise(
    string username,
    string circleId
)

参数

username
类型：SystemString
账号
circleId
类型：SystemString
朋友圈id
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendImage 方法

WeixinBaseSendImage 方法

重载列表
 | 名称 | 说明
公共方法 | SendImage(Byte, String) | 发送图片
公共方法 | SendImage(String, String) | 发送图片
Top
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendImage 方法 (Byte[], String)

WeixinBaseSendImage 方法 (Byte, String)

发送图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendImage(
    byte[] img,
    string username
)

参数

img
类型：SystemByte
图片byte[]
username
类型：SystemString
接收者账号
参见

引用

WeixinBase 类
SendImage 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendImage 方法 (String, String)

WeixinBaseSendImage 方法 (String, String)

发送图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendImage(
    string username,
    string address
)

参数

username
类型：SystemString
接收者账号
address
类型：SystemString
图片地址
参见

引用

WeixinBase 类
SendImage 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendMessage 方法

WeixinBaseSendMessage 方法

发送消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual Task<bool> SendMessage(
    string username,
    string message,
    string atUsername = ""
)

参数

username
类型：SystemString
接收者账号
message
类型：SystemString
发送的消息
atUsername (Optional)
类型：SystemString
艾特用户

返回值

类型：Task Boolean
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendPay 方法

WeixinBaseSendPay 方法

发送红包

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual string SendPay(
    string toUsername,
    string content,
    int TotalAmount,
    string password,
    int count,
    PayType type,
    BankCar bank = null,
    Dictionary<string, Object> param = null
)

参数

toUsername
类型：SystemString
接收者账号
content
类型：SystemString
content
TotalAmount
类型：SystemInt32
TotalAmount
password
类型：SystemString
password
count
类型：SystemInt32
count
type
类型：Chat.Framework.WXSdk.IPADPayType
type
bank (Optional)
类型：Chat.Framework.WXSdkBankCar
bank
param (Optional)
类型：System.Collections.GenericDictionary String, Object
param

返回值

类型：String
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendProgramMessage 方法

WeixinBaseSendProgramMessage 方法

发送小程序

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendProgramMessage(
    string username,
    string ghid,
    string wxid,
    string name,
    string title,
    string enterpoint,
    string headimg,
    string image_key1,
    string image_key2,
    string image_key3,
    string image_size
)

参数

username
类型：SystemString
发送给谁
ghid
类型：SystemString
小程序ID
wxid
类型：SystemString
所有者wxid
name
类型：SystemString
小程序名称
title
类型：SystemString
小程序分享的标题
enterpoint
类型：SystemString
入口点
headimg
类型：SystemString
小程序图标
image_key1
类型：SystemString
缩略图key1
image_key2
类型：SystemString
缩略图key2
image_key3
类型：SystemString
缩略图key3
image_size
类型：SystemString
缩略图大小
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SendVoice 方法

WeixinBaseSendVoice 方法

发送语音

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SendVoice(
    string username,
    string url
)

参数

username
类型：SystemString
接收者账号
url
类型：SystemString
连接
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SerchKeyword 方法

WeixinBaseSerchKeyword 方法

搜索关键词

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual Dictionary<string, Object> SerchKeyword(
    string keyword
)

参数

keyword
类型：SystemString
关键词

返回值

类型：Dictionary String, Object
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SetDisableRevoke 方法

WeixinBaseSetDisableRevoke 方法

开启/关闭防撤回功能

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SetDisableRevoke(
    bool status
)

参数

status
类型：SystemBoolean
1是开启防撤回，0是关闭
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SetRecvNotify 方法

WeixinBaseSetRecvNotify 方法

是否消息免打扰

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SetRecvNotify(
    bool status,
    string wxid
)

参数

status
类型：SystemBoolean
true为开启
wxid
类型：SystemString
wxid
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SetRoomName 方法

WeixinBaseSetRoomName 方法

修改群聊名称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SetRoomName(
    string new_name,
    string groupId
)

参数

new_name
类型：SystemString
新的群名
groupId
类型：SystemString
群id
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SetRoomNotice 方法

WeixinBaseSetRoomNotice 方法

修改群公告(可用于@全体)

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SetRoomNotice(
    string notice,
    string groupId
)

参数

notice
类型：SystemString
新公告
groupId
类型：SystemString
群聊wxid
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SetRoomShowMemeberName 方法

WeixinBaseSetRoomShowMemeberName 方法

设置是否显示群成员昵称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SetRoomShowMemeberName(
    bool status,
    string groupId
)

参数

status
类型：SystemBoolean
true为开启
groupId
类型：SystemString
要显示得到群
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SetSessionReadedMsg 方法

WeixinBaseSetSessionReadedMsg 方法

设置会话已读

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SetSessionReadedMsg(
    string wxid
)

参数

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBase.SetSessionReadedMsg(System.String)" 的 <param name="wxid"/> 文档]

参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.ShowLogin 方法

WeixinBaseShowLogin 方法

启动微信

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void ShowLogin()
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.SnsVerify 方法

WeixinBaseSnsVerify 方法

验证支付

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual void SnsVerify(
    string code,
    bool isHongbao,
    string reqKey,
    BankCar bank,
    string token,
    string pass
)

参数

code
类型：SystemString
code
isHongbao
类型：SystemBoolean
isHongbao
reqKey
类型：SystemString
reqKey
bank
类型：Chat.Framework.WXSdkBankCar
bank
token
类型：SystemString
token
pass
类型：SystemString
pass

返回值

类型：
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.TenPayTransferConfirm 方法

WeixinBaseTenPayTransferConfirm 方法

领取转账

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual int TenPayTransferConfirm(
    string Invalidtime,
    string Transferid,
    string FromUsername
)

参数

Invalidtime
类型：SystemString
收到转账中的Invalidtime
Transferid
类型：SystemString
收到转账中的Transferid
FromUsername
类型：SystemString
收到转账中的FromUsername

返回值

类型：Int32
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBase.WriteLog 方法

WeixinBaseWriteLog 方法

写出日志

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void WriteLog(
    string msg,
    bool debug = false
)

参数

msg
类型：SystemString
内容
debug (Optional)
类型：SystemBoolean
是否为debug
参见

引用

WeixinBase 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser 类

微信基础用户
继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWeixinBaseUser

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WeixinBaseUser

WeixinBaseUser 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WeixinBaseUser | 初始化 WeixinBaseUser 类的一个新实例
公共方法 | WeixinBaseUser(String) | 初始化 WeixinBaseUser 类的一个新实例
公共方法 | WeixinBaseUser(User) | 初始化 WeixinBaseUser 类的一个新实例
公共方法 | WeixinBaseUser(String, String, Int64) | 初始化 WeixinBaseUser 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Data |
公共属性 | LoginTime | 机器人登录时间
公共属性 | Nick | 机器人昵称
公共属性 | Uin | Uin
公共属性 | Username | 机器人微信id
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser 构造函数

重载列表
 | 名称 | 说明
公共方法 | WeixinBaseUser | 初始化 WeixinBaseUser 类的一个新实例
公共方法 | WeixinBaseUser(String) | 初始化 WeixinBaseUser 类的一个新实例
公共方法 | WeixinBaseUser(User) | 初始化 WeixinBaseUser 类的一个新实例
公共方法 | WeixinBaseUser(String, String, Int64) | 初始化 WeixinBaseUser 类的一个新实例
Top
参见

引用

WeixinBaseUser 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser 构造函数

初始化 WeixinBaseUser 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinBaseUser()
参见

引用

WeixinBaseUser 类
WeixinBaseUser 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser 构造函数 (String)

初始化 WeixinBaseUser 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinBaseUser(
    string data
)

参数

data
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBaseUser.#ctor(System.String)" 的 <param name="data"/> 文档]

参见

引用

WeixinBaseUser 类
WeixinBaseUser 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser 构造函数 (User)

初始化 WeixinBaseUser 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinBaseUser(
    User user
)

参数

user
类型：WechatProtoUser

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBaseUser.#ctor(WechatProto.User)" 的 <param name="user"/> 文档]

参见

引用

WeixinBaseUser 类
WeixinBaseUser 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser 构造函数 (String, String, Int64)

初始化 WeixinBaseUser 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinBaseUser(
    string username,
    string nick,
    long uin = -1
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBaseUser.#ctor(System.String,System.String,System.Int64)" 的 <param name="username"/> 文档]

nick
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBaseUser.#ctor(System.String,System.String,System.Int64)" 的 <param name="nick"/> 文档]

uin (Optional)
类型：SystemInt64

[缺少 "M:Chat.Framework.WXSdk.Implement.WeixinBaseUser.#ctor(System.String,System.String,System.Int64)" 的 <param name="uin"/> 文档]

参见

引用

WeixinBaseUser 类
WeixinBaseUser 重载
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser 属性

WeixinBaseUser 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Data |
公共属性 | LoginTime | 机器人登录时间
公共属性 | Nick | 机器人昵称
公共属性 | Uin | Uin
公共属性 | Username | 机器人微信id
Top
参见

引用

WeixinBaseUser 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser.Data 属性

WeixinBaseUserData 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WeixinBaseUser.Data" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Data { get; }

属性值

类型：String
参见

引用

WeixinBaseUser 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser.LoginTime 属性

WeixinBaseUserLoginTime 属性

机器人登录时间

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime LoginTime { get; }

属性值

类型：DateTime
参见

引用

WeixinBaseUser 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser.Nick 属性

WeixinBaseUserNick 属性

机器人昵称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Nick { get; }

属性值

类型：String
参见

引用

WeixinBaseUser 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser.Uin 属性

WeixinBaseUserUin 属性

Uin

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long Uin { get; }

属性值

类型：Int64
参见

引用

WeixinBaseUser 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser.Username 属性

WeixinBaseUserUsername 属性

机器人微信id

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Username { get; }

属性值

类型：String
参见

引用

WeixinBaseUser 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinBaseUser 方法

WeixinBaseUser 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WeixinBaseUser 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinClientImpl_TCPServer 类

[缺少 "T:Chat.Framework.WXSdk.Implement.WeixinClientImpl_TCPServer" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWeixinBase
Chat.Framework.WXSdk.ImplementWeixinClientImpl_TCPServer

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WeixinClientImpl_TCPServer : WeixinBase

WeixinClientImpl_TCPServer 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WeixinClientImpl_TCPServer | 初始化 WeixinClientImpl_TCPServer 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Status | 微信状态 (继承自 WeixinBase。)
公共属性 | User | 用户 (继承自 WeixinBase。)
公共属性 | WeixinHao | 微信号 (继承自 WeixinBase。)
公共属性 | WeixinType | 微信类型 (继承自 WeixinBase。)
Top
方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | 添加群用户 (继承自 WeixinBase。)
公共方法 | AddChatRoomMember_40Down | 添加群用户_40人以下 (继承自 WeixinBase。)
公共方法 | AddLabel | 添加标签 (继承自 WeixinBase。)
公共方法 | AddPublicUser | 关注公众号 (继承自 WeixinBase。)
公共方法 | AgreeAddMe | 同意添加我为好友 (继承自 WeixinBase。)
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序 (继承自 WeixinBase。)
公共方法 | ChangeStatus | 微信状态改变 (继承自 WeixinBase。)
公共方法 | CheckUrl | 检测URL在微信中是否有效 (继承自 WeixinBase。)
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录 (继承自 WeixinBase。)
公共方法 | CreateChatRoom(String) | 创建群聊 (继承自 WeixinBase。)
公共方法 | CreateChatRoom(String) | 创建群 (继承自 WeixinBase。)
公共方法 | DeleteFriend | 删除朋友 (继承自 WeixinBase。)
公共方法 | DeleteGroupMember | 删除群用户 (继承自 WeixinBase。)
公共方法 | Dispose | (继承自 WeixinBase。)
公共方法 | DownlowdImage | 下载图片 (继承自 WeixinBase。)
公共方法 | EditContacts | 编辑用户信息 (继承自 WeixinBase。)
公共方法 | EditUserLabel | 批量修改标签 (继承自 WeixinBase。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindCircle | 获取朋友圈 (继承自 WeixinBase。)
公共方法 | FindCircles | 获取朋友圈 (继承自 WeixinBase。)
公共方法 | FindFriendsT | 获得好友列表 (继承自 WeixinBase。)
公共方法 | FocusWechat | 关注公众号 (继承自 WeixinBase。)
公共方法 | GetBalance | (继承自 WeixinBase。)
公共方法 | GetContact | 获得联系人信息 (继承自 WeixinBase。)
公共方法 | GetGroupsNotInMember | 获取群列表(不包含群成员) (继承自 WeixinBase。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签组 (继承自 WeixinBase。)
公共方法 | GetMember(String, String) | 获取群用户信息 (继承自 WeixinBase。)
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息带刷新 (继承自 WeixinBase。)
公共方法 | GetMembers | 获取群成员,不支持pc (继承自 WeixinBase。)
公共方法 | GetRobotQRcode | 获得机器人二维码 (继承自 WeixinBase。)
公共方法 | GetType | (继承自 Object。)
公共方法 | InviteIntoGroup | 邀请入群 (继承自 WeixinBase。)
公共方法 | LoginOut | 退出微信 (继承自 WeixinBase。)
公共方法 | LoginOut(String) | 退出微信 (继承自 WeixinBase。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称 (继承自 WeixinBase。)
公共方法 | ModRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | OpenUrl | 打开内置浏览器 (继承自 WeixinBase。)
公共方法 | Receive | 分析事件 (继承自 WeixinBase。)
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表) (继承自 WeixinBase。)
公共方法 | ResetConnection | 重新连接微信 (继承自 WeixinBase。)
公共方法 | SendCard | 发送卡片消息 (继承自 WeixinBase。)
公共方法 | SendCDNImage | 发送CDN图片 (继承自 WeixinBase。)
公共方法 | SendCDNInfo | 秒发CDN消息 (继承自 WeixinBase。)
公共方法 | SendCDNVideo | 发送CDN视频 (继承自 WeixinBase。)
公共方法 | SendCircle | 发表朋友圈 (继承自 WeixinBase。)
公共方法 | SendCircleComment | 发表评论 (继承自 WeixinBase。)
公共方法 | SendCirclePraise | 点赞 (继承自 WeixinBase。)
公共方法 | SendImage(Byte, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendImage(String, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendMessage | 发送消息 (继承自 WeixinBase。)
公共方法 | SendPay | 发送红包 (继承自 WeixinBase。)
公共方法 | SendProgramMessage | 发送小程序 (继承自 WeixinBase。)
公共方法 | SendVoice | 发送语音 (继承自 WeixinBase。)
公共方法 | SerchKeyword | 搜索关键词 (继承自 WeixinBase。)
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能 (继承自 WeixinBase。)
公共方法 | SetRecvNotify | 是否消息免打扰 (继承自 WeixinBase。)
公共方法 | SetRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | SetRoomNotice | 修改群公告(可用于@全体) (继承自 WeixinBase。)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称 (继承自 WeixinBase。)
公共方法 | SetSessionReadedMsg | 设置会话已读 (继承自 WeixinBase。)
公共方法 | ShowLogin | 启动微信 (继承自 WeixinBase。)
公共方法 | SnsVerify | 验证支付 (继承自 WeixinBase。)
公共方法 | TenPayTransferConfirm | 领取转账 (继承自 WeixinBase。)
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteLog | 写出日志 (继承自 WeixinBase。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WeixinClientImpl_TCPServer 构造函数

初始化 WeixinClientImpl_TCPServer 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinClientImpl_TCPServer()
参见

引用

WeixinClientImpl_TCPServer 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinClientImpl_TCPServer 属性

WeixinClientImpl_TCPServer 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Status | 微信状态 (继承自 WeixinBase。)
公共属性 | User | 用户 (继承自 WeixinBase。)
公共属性 | WeixinHao | 微信号 (继承自 WeixinBase。)
公共属性 | WeixinType | 微信类型 (继承自 WeixinBase。)
Top
参见

引用

WeixinClientImpl_TCPServer 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinClientImpl_TCPServer 方法

WeixinClientImpl_TCPServer 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | 添加群用户 (继承自 WeixinBase。)
公共方法 | AddChatRoomMember_40Down | 添加群用户_40人以下 (继承自 WeixinBase。)
公共方法 | AddLabel | 添加标签 (继承自 WeixinBase。)
公共方法 | AddPublicUser | 关注公众号 (继承自 WeixinBase。)
公共方法 | AgreeAddMe | 同意添加我为好友 (继承自 WeixinBase。)
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序 (继承自 WeixinBase。)
公共方法 | ChangeStatus | 微信状态改变 (继承自 WeixinBase。)
公共方法 | CheckUrl | 检测URL在微信中是否有效 (继承自 WeixinBase。)
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录 (继承自 WeixinBase。)
公共方法 | CreateChatRoom(String) | 创建群聊 (继承自 WeixinBase。)
公共方法 | CreateChatRoom(String) | 创建群 (继承自 WeixinBase。)
公共方法 | DeleteFriend | 删除朋友 (继承自 WeixinBase。)
公共方法 | DeleteGroupMember | 删除群用户 (继承自 WeixinBase。)
公共方法 | Dispose | (继承自 WeixinBase。)
公共方法 | DownlowdImage | 下载图片 (继承自 WeixinBase。)
公共方法 | EditContacts | 编辑用户信息 (继承自 WeixinBase。)
公共方法 | EditUserLabel | 批量修改标签 (继承自 WeixinBase。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindCircle | 获取朋友圈 (继承自 WeixinBase。)
公共方法 | FindCircles | 获取朋友圈 (继承自 WeixinBase。)
公共方法 | FindFriendsT | 获得好友列表 (继承自 WeixinBase。)
公共方法 | FocusWechat | 关注公众号 (继承自 WeixinBase。)
公共方法 | GetBalance | (继承自 WeixinBase。)
公共方法 | GetContact | 获得联系人信息 (继承自 WeixinBase。)
公共方法 | GetGroupsNotInMember | 获取群列表(不包含群成员) (继承自 WeixinBase。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签组 (继承自 WeixinBase。)
公共方法 | GetMember(String, String) | 获取群用户信息 (继承自 WeixinBase。)
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息带刷新 (继承自 WeixinBase。)
公共方法 | GetMembers | 获取群成员,不支持pc (继承自 WeixinBase。)
公共方法 | GetRobotQRcode | 获得机器人二维码 (继承自 WeixinBase。)
公共方法 | GetType | (继承自 Object。)
公共方法 | InviteIntoGroup | 邀请入群 (继承自 WeixinBase。)
公共方法 | LoginOut | 退出微信 (继承自 WeixinBase。)
公共方法 | LoginOut(String) | 退出微信 (继承自 WeixinBase。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称 (继承自 WeixinBase。)
公共方法 | ModRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | OpenUrl | 打开内置浏览器 (继承自 WeixinBase。)
公共方法 | Receive | 分析事件 (继承自 WeixinBase。)
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表) (继承自 WeixinBase。)
公共方法 | ResetConnection | 重新连接微信 (继承自 WeixinBase。)
公共方法 | SendCard | 发送卡片消息 (继承自 WeixinBase。)
公共方法 | SendCDNImage | 发送CDN图片 (继承自 WeixinBase。)
公共方法 | SendCDNInfo | 秒发CDN消息 (继承自 WeixinBase。)
公共方法 | SendCDNVideo | 发送CDN视频 (继承自 WeixinBase。)
公共方法 | SendCircle | 发表朋友圈 (继承自 WeixinBase。)
公共方法 | SendCircleComment | 发表评论 (继承自 WeixinBase。)
公共方法 | SendCirclePraise | 点赞 (继承自 WeixinBase。)
公共方法 | SendImage(Byte, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendImage(String, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendMessage | 发送消息 (继承自 WeixinBase。)
公共方法 | SendPay | 发送红包 (继承自 WeixinBase。)
公共方法 | SendProgramMessage | 发送小程序 (继承自 WeixinBase。)
公共方法 | SendVoice | 发送语音 (继承自 WeixinBase。)
公共方法 | SerchKeyword | 搜索关键词 (继承自 WeixinBase。)
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能 (继承自 WeixinBase。)
公共方法 | SetRecvNotify | 是否消息免打扰 (继承自 WeixinBase。)
公共方法 | SetRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | SetRoomNotice | 修改群公告(可用于@全体) (继承自 WeixinBase。)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称 (继承自 WeixinBase。)
公共方法 | SetSessionReadedMsg | 设置会话已读 (继承自 WeixinBase。)
公共方法 | ShowLogin | 启动微信 (继承自 WeixinBase。)
公共方法 | SnsVerify | 验证支付 (继承自 WeixinBase。)
公共方法 | TenPayTransferConfirm | 领取转账 (继承自 WeixinBase。)
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteLog | 写出日志 (继承自 WeixinBase。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WeixinClientImpl_TCPServer 类
Chat.Framework.WXSdk.Implement 命名空间


WeixinType 枚举

微信类型

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WeixinType
成员
成员名称 | 值 | 说明
Grpc微信 | 1 |
Hook微信 | 2 |
QYHook微信 | 3 |
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK 类

普通PC机器人
继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWeixinBase
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOK

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXClientImpl_HOOK : WeixinBase

WXClientImpl_HOOK 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_HOOK | 初始化 WXClientImpl_HOOK 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Friends | 好友列表
公共属性 | GroupMembers | 群-群成员缓存
公共属性 | HeartBreakTime | 上次心跳时间
公共属性 | Process |
公共属性 | Status | 微信状态 (继承自 WeixinBase。)
公共属性 | User | 用户 (继承自 WeixinBase。)
公共属性 | WeixinHao | 微信号 (继承自 WeixinBase。)
公共属性 | WeixinType | 微信类型 (继承自 WeixinBase。)
Top
方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | (重写 WeixinBaseAddChatRoomMember(String, String).)
公共方法 | AddChatRoomMember_40Down | (重写 WeixinBaseAddChatRoomMember_40Down(String, String).)
公共方法 | AddLabel | 添加标签 (继承自 WeixinBase。)
公共方法 | AddPublicUser | 关注公众号 (重写 WeixinBaseAddPublicUser(String).)
公共方法 | AgreeAddMe | 同意添加我为好友 (重写 WeixinBaseAgreeAddMe(String).)
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序 (重写 WeixinBaseAutoAuthMiniAPPLogin(String).)
公共方法 | ChangeStatus | pc普通微信状态改变 (重写 WeixinBaseChangeStatus(WxStatus, WXChangeStatus, Boolean).)
公共方法 | CheckUrl | 检测URL在微信中是否有效 (重写 WeixinBaseCheckUrl(String).)
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录 (重写 WeixinBaseClearChatHistoryMsg.)
公共方法 | CreateChatRoom(String) | 创建群 (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | CreateChatRoom(String) | 创建群 (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | DelayMess | 消息延迟
公共方法 | DeleteFriend | 删除好友 (重写 WeixinBaseDeleteFriend(String).)
公共方法 | DeleteGroupMember | 删除群用户 (重写 WeixinBaseDeleteGroupMember(String, String).)
公共方法 | Dispose | 释放被 WXClientImpl_HOOK 使用的所有资源
公共方法 | DownlowdImage | 下载图片 (继承自 WeixinBase。)
公共方法 | EditContacts | 修改用户信息 (重写 WeixinBaseEditContacts(String, EditContactsType, String).)
公共方法 | EditUserLabel | 批量修改标签 (继承自 WeixinBase。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindCircle | (重写 WeixinBaseFindCircle(String, String, Int32).)
公共方法 | FindCircles | (重写 WeixinBaseFindCircles.)
公共方法 | FindFriendsT | 获得好友列表 (继承自 WeixinBase。)
公共方法 | FocusWechat | 关注公众号 (继承自 WeixinBase。)
公共方法 | GetBalance | (继承自 WeixinBase。)
公共方法 | GetContact | 获得好友或群组信息 (重写 WeixinBaseGetContact(String, Boolean).)
公共方法 | GetGroupsNotInMember | 获取群基本消息(不包含群成员) (重写 WeixinBaseGetGroupsNotInMember.)
公共方法 | GetGroupWxidInfo(String, String) | 获取指定的群和用户
公共方法 | GetGroupWxidInfo(String, String, Boolean) |
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签组 (继承自 WeixinBase。)
公共方法 | GetMember(String, String) | 获取群用户信息 (重写 WeixinBaseGetMember(String, String).)
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息 (重写 WeixinBaseGetMember(String, String, Boolean).)
公共方法 | GetMembers | 获取群成员,不支持pc (继承自 WeixinBase。)
公共方法 | GetRobotQRcode | 获得机器人二维码 (继承自 WeixinBase。)
公共方法 | GetType | (继承自 Object。)
公共方法 | GetWxidInfo | 获取指定的用户
公共方法 | GetZombie | 检测僵尸（最后获取Friends集合，判断里面的Ticket的值不为空为僵尸）
公共方法 | InviteIntoGroup | 邀请入群 (重写 WeixinBaseInviteIntoGroup(String, String).)
公共方法 | LoginOut | 退出登录 (重写 WeixinBaseLoginOut.)
公共方法 | LoginOut(String) | 退出消息 (重写 WeixinBaseLoginOut(String).)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称 (重写 WeixinBaseModRoomMyName(String, String).)
公共方法 | ModRoomName | 修改群聊名称 (重写 WeixinBaseModRoomName(String, String).)
公共方法 | OpenUrl | (重写 WeixinBaseOpenUrl(String).)
公共方法 | Receive | 分析hook服务器过来的事件 (重写 WeixinBaseReceive(Object).)
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表) (继承自 WeixinBase。)
公共方法 | RequestContact | 请求获取联系人
公共方法 | ResetConnection | 重新连接微信 (继承自 WeixinBase。)
公共方法 | SendCard | 发送卡片 (重写 WeixinBaseSendCard(String, String).)
公共方法 | SendCDNImage | 发送CDN图片 (继承自 WeixinBase。)
公共方法 | SendCDNInfo | 秒发CDN消息 (继承自 WeixinBase。)
公共方法 | SendCDNVideo | 发送CDN视频 (继承自 WeixinBase。)
公共方法 | SendCircle | (重写 WeixinBaseSendCircle(String).)
公共方法 | SendCircleComment | (重写 WeixinBaseSendCircleComment(String, String, String).)
公共方法 | SendCirclePraise | 朋友圈点赞 (重写 WeixinBaseSendCirclePraise(String, String).)
公共方法 | SendImage(Byte, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendImage(String, String) | 发送图片 (重写 WeixinBaseSendImage(String, String).)
公共方法 | SendMessage | 发送消息 (重写 WeixinBaseSendMessage(String, String, String).)
公共方法 | SendPay | 发送红包 (继承自 WeixinBase。)
公共方法 | SendProgramMessage | 发送小程序 (继承自 WeixinBase。)
公共方法 | SendVoice | 发送语音 (继承自 WeixinBase。)
公共方法 | SerchKeyword | 搜索关键词 (继承自 WeixinBase。)
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能 (重写 WeixinBaseSetDisableRevoke(Boolean).)
公共方法 | SetRecvNotify | 是否消息免打扰 (重写 WeixinBaseSetRecvNotify(Boolean, String).)
公共方法 | SetRoomName | 修改群聊名称 (重写 WeixinBaseSetRoomName(String, String).)
公共方法 | SetRoomNotice | 修改群公告(可用于@全体) (重写 WeixinBaseSetRoomNotice(String, String).)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称 (重写 WeixinBaseSetRoomShowMemeberName(Boolean, String).)
公共方法 | SetSessionReadedMsg | 设置会话已读 (重写 WeixinBaseSetSessionReadedMsg(String).)
公共方法 | ShowLogin | (重写 WeixinBaseShowLogin.)
公共方法 | SnsVerify | 验证支付 (继承自 WeixinBase。)
公共方法 | TenPayTransferConfirm | (重写 WeixinBaseTenPayTransferConfirm(String, String, String).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UplodCircleImage | 开始上传图片
公共方法 | WriteLog | 写出日志 (继承自 WeixinBase。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK 构造函数

初始化 WXClientImpl_HOOK 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_HOOK(
    string weixinhao,
    string usernick,
    long uin = -1
)

参数

weixinhao
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.#ctor(System.String,System.String,System.Int64)" 的 <param name="weixinhao"/> 文档]

usernick
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.#ctor(System.String,System.String,System.Int64)" 的 <param name="usernick"/> 文档]

uin (Optional)
类型：SystemInt64

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.#ctor(System.String,System.String,System.Int64)" 的 <param name="uin"/> 文档]

参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK 属性

WXClientImpl_HOOK 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Friends | 好友列表
公共属性 | GroupMembers | 群-群成员缓存
公共属性 | HeartBreakTime | 上次心跳时间
公共属性 | Process |
公共属性 | Status | 微信状态 (继承自 WeixinBase。)
公共属性 | User | 用户 (继承自 WeixinBase。)
公共属性 | WeixinHao | 微信号 (继承自 WeixinBase。)
公共属性 | WeixinType | 微信类型 (继承自 WeixinBase。)
Top
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.Friends 属性

WXClientImpl_HOOKFriends 属性

好友列表

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Friend> Friends { get; }

属性值

类型：Dictionary String, Friend
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GroupMembers 属性

WXClientImpl_HOOKGroupMembers 属性

群-群成员缓存

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, GroupMember[]> GroupMembers { get; }

属性值

类型：Dictionary String, GroupMember
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.HeartBreakTime 属性

WXClientImpl_HOOKHeartBreakTime 属性

上次心跳时间

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime HeartBreakTime { get; }

属性值

类型：DateTime
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.Process 属性

WXClientImpl_HOOKProcess 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.Process" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Process Process { get; }

属性值

类型：Process
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK 方法

WXClientImpl_HOOK 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | (重写 WeixinBaseAddChatRoomMember(String, String).)
公共方法 | AddChatRoomMember_40Down | (重写 WeixinBaseAddChatRoomMember_40Down(String, String).)
公共方法 | AddLabel | 添加标签 (继承自 WeixinBase。)
公共方法 | AddPublicUser | 关注公众号 (重写 WeixinBaseAddPublicUser(String).)
公共方法 | AgreeAddMe | 同意添加我为好友 (重写 WeixinBaseAgreeAddMe(String).)
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序 (重写 WeixinBaseAutoAuthMiniAPPLogin(String).)
公共方法 | ChangeStatus | pc普通微信状态改变 (重写 WeixinBaseChangeStatus(WxStatus, WXChangeStatus, Boolean).)
公共方法 | CheckUrl | 检测URL在微信中是否有效 (重写 WeixinBaseCheckUrl(String).)
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录 (重写 WeixinBaseClearChatHistoryMsg.)
公共方法 | CreateChatRoom(String) | 创建群 (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | CreateChatRoom(String) | 创建群 (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | DelayMess | 消息延迟
公共方法 | DeleteFriend | 删除好友 (重写 WeixinBaseDeleteFriend(String).)
公共方法 | DeleteGroupMember | 删除群用户 (重写 WeixinBaseDeleteGroupMember(String, String).)
公共方法 | Dispose |
公共方法 | DownlowdImage | 下载图片 (继承自 WeixinBase。)
公共方法 | EditContacts | 修改用户信息 (重写 WeixinBaseEditContacts(String, EditContactsType, String).)
公共方法 | EditUserLabel | 批量修改标签 (继承自 WeixinBase。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindCircle | (重写 WeixinBaseFindCircle(String, String, Int32).)
公共方法 | FindCircles | (重写 WeixinBaseFindCircles.)
公共方法 | FindFriendsT | 获得好友列表 (继承自 WeixinBase。)
公共方法 | FocusWechat | 关注公众号 (继承自 WeixinBase。)
公共方法 | GetBalance | (继承自 WeixinBase。)
公共方法 | GetContact | 获得好友或群组信息 (重写 WeixinBaseGetContact(String, Boolean).)
公共方法 | GetGroupsNotInMember | 获取群基本消息(不包含群成员) (重写 WeixinBaseGetGroupsNotInMember.)
公共方法 | GetGroupWxidInfo(String, String) | 获取指定的群和用户
公共方法 | GetGroupWxidInfo(String, String, Boolean) |
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签组 (继承自 WeixinBase。)
公共方法 | GetMember(String, String) | 获取群用户信息 (重写 WeixinBaseGetMember(String, String).)
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息 (重写 WeixinBaseGetMember(String, String, Boolean).)
公共方法 | GetMembers | 获取群成员,不支持pc (继承自 WeixinBase。)
公共方法 | GetRobotQRcode | 获得机器人二维码 (继承自 WeixinBase。)
公共方法 | GetType | (继承自 Object。)
公共方法 | GetWxidInfo | 获取指定的用户
公共方法 | GetZombie | 检测僵尸（最后获取Friends集合，判断里面的Ticket的值不为空为僵尸）
公共方法 | InviteIntoGroup | 邀请入群 (重写 WeixinBaseInviteIntoGroup(String, String).)
公共方法 | LoginOut | 退出登录 (重写 WeixinBaseLoginOut.)
公共方法 | LoginOut(String) | 退出消息 (重写 WeixinBaseLoginOut(String).)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称 (重写 WeixinBaseModRoomMyName(String, String).)
公共方法 | ModRoomName | 修改群聊名称 (重写 WeixinBaseModRoomName(String, String).)
公共方法 | OpenUrl | (重写 WeixinBaseOpenUrl(String).)
公共方法 | Receive | 分析hook服务器过来的事件 (重写 WeixinBaseReceive(Object).)
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表) (继承自 WeixinBase。)
公共方法 | RequestContact | 请求获取联系人
公共方法 | ResetConnection | 重新连接微信 (继承自 WeixinBase。)
公共方法 | SendCard | 发送卡片 (重写 WeixinBaseSendCard(String, String).)
公共方法 | SendCDNImage | 发送CDN图片 (继承自 WeixinBase。)
公共方法 | SendCDNInfo | 秒发CDN消息 (继承自 WeixinBase。)
公共方法 | SendCDNVideo | 发送CDN视频 (继承自 WeixinBase。)
公共方法 | SendCircle | (重写 WeixinBaseSendCircle(String).)
公共方法 | SendCircleComment | (重写 WeixinBaseSendCircleComment(String, String, String).)
公共方法 | SendCirclePraise | 朋友圈点赞 (重写 WeixinBaseSendCirclePraise(String, String).)
公共方法 | SendImage(Byte, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendImage(String, String) | 发送图片 (重写 WeixinBaseSendImage(String, String).)
公共方法 | SendMessage | 发送消息 (重写 WeixinBaseSendMessage(String, String, String).)
公共方法 | SendPay | 发送红包 (继承自 WeixinBase。)
公共方法 | SendProgramMessage | 发送小程序 (继承自 WeixinBase。)
公共方法 | SendVoice | 发送语音 (继承自 WeixinBase。)
公共方法 | SerchKeyword | 搜索关键词 (继承自 WeixinBase。)
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能 (重写 WeixinBaseSetDisableRevoke(Boolean).)
公共方法 | SetRecvNotify | 是否消息免打扰 (重写 WeixinBaseSetRecvNotify(Boolean, String).)
公共方法 | SetRoomName | 修改群聊名称 (重写 WeixinBaseSetRoomName(String, String).)
公共方法 | SetRoomNotice | 修改群公告(可用于@全体) (重写 WeixinBaseSetRoomNotice(String, String).)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称 (重写 WeixinBaseSetRoomShowMemeberName(Boolean, String).)
公共方法 | SetSessionReadedMsg | 设置会话已读 (重写 WeixinBaseSetSessionReadedMsg(String).)
公共方法 | ShowLogin | (重写 WeixinBaseShowLogin.)
公共方法 | SnsVerify | 验证支付 (继承自 WeixinBase。)
公共方法 | TenPayTransferConfirm | (重写 WeixinBaseTenPayTransferConfirm(String, String, String).)
公共方法 | ToString | (继承自 Object。)
公共方法 | UplodCircleImage | 开始上传图片
公共方法 | WriteLog | 写出日志 (继承自 WeixinBase。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.AddChatRoomMember 方法

WXClientImpl_HOOKAddChatRoomMember 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.AddChatRoomMember(System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void AddChatRoomMember(
    string groupid,
    string members
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.AddChatRoomMember(System.String,System.String)" 的 <param name="groupid"/> 文档]

members
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.AddChatRoomMember(System.String,System.String)" 的 <param name="members"/> 文档]

参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.AddChatRoomMember_40Down 方法

WXClientImpl_HOOKAddChatRoomMember_40Down 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.AddChatRoomMember_40Down(System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void AddChatRoomMember_40Down(
    string groupid,
    string members
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.AddChatRoomMember_40Down(System.String,System.String)" 的 <param name="groupid"/> 文档]

members
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.AddChatRoomMember_40Down(System.String,System.String)" 的 <param name="members"/> 文档]

参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.AddPublicUser 方法

WXClientImpl_HOOKAddPublicUser 方法

关注公众号

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void AddPublicUser(
    string wxid
)

参数

wxid
类型：SystemString
公众号wxid
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.AgreeAddMe 方法

WXClientImpl_HOOKAgreeAddMe 方法

同意添加我为好友

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string AgreeAddMe(
    string token
)

参数

token
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.AgreeAddMe(System.String)" 的 <param name="token"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.AutoAuthMiniAPPLogin 方法

WXClientImpl_HOOKAutoAuthMiniAPPLogin 方法

自动授权登录小程序

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string AutoAuthMiniAPPLogin(
    string appid
)

参数

appid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.AutoAuthMiniAPPLogin(System.String)" 的 <param name="appid"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ChangeStatus 方法

WXClientImpl_HOOKChangeStatus 方法

pc普通微信状态改变

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ChangeStatus(
    WxStatus status,
    WXChangeStatus e = null,
    bool is_next = true
)

参数

status
类型：Chat.Framework.WXSdkWxStatus
状态
e (Optional)
类型：Chat.Framework.WXSdk.EventsWXChangeStatus
事件
is_next (Optional)
类型：SystemBoolean
没用
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CheckUrl 方法

WXClientImpl_HOOKCheckUrl 方法

检测URL在微信中是否有效

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override bool CheckUrl(
    string url
)

参数

url
类型：SystemString
要检查的链接

返回值

类型：Boolean
返回true为连接没有屏蔽
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ClearChatHistoryMsg 方法

WXClientImpl_HOOKClearChatHistoryMsg 方法

清理历史聊天记录

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ClearChatHistoryMsg()
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CreateChatRoom 方法

WXClientImpl_HOOKCreateChatRoom 方法

重载列表
 | 名称 | 说明
公共方法 | CreateChatRoom(String) | 创建群 (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | CreateChatRoom(String) | 创建群 (重写 WeixinBaseCreateChatRoom(String).)
Top
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CreateChatRoom 方法 (String)

WXClientImpl_HOOKCreateChatRoom 方法 (String)

创建群

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string CreateChatRoom(
    string wxids
)

参数

wxids
类型：SystemString
用户账号用,分隔

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
CreateChatRoom 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CreateChatRoom 方法 (String[])

WXClientImpl_HOOKCreateChatRoom 方法 (String)

创建群

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string CreateChatRoom(
    string[] wxids
)

参数

wxids
类型：SystemString
用户账号需要3个或者以上

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
CreateChatRoom 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.DelayMess 方法

WXClientImpl_HOOKDelayMess 方法

消息延迟

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DelayMess(
    string message
)

参数

message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.DelayMess(System.String)" 的 <param name="message"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.DeleteFriend 方法

WXClientImpl_HOOKDeleteFriend 方法

删除好友

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string DeleteFriend(
    string username
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.DeleteFriend(System.String)" 的 <param name="username"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.DeleteGroupMember 方法

WXClientImpl_HOOKDeleteGroupMember 方法

删除群用户

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string DeleteGroupMember(
    string username,
    string groupId
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.DeleteGroupMember(System.String,System.String)" 的 <param name="username"/> 文档]

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.DeleteGroupMember(System.String,System.String)" 的 <param name="groupId"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.Dispose 方法

WXClientImpl_HOOKDispose 方法

释放被 WXClientImpl_HOOK 使用的所有资源

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.EditContacts 方法

WXClientImpl_HOOKEditContacts 方法

修改用户信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void EditContacts(
    string username,
    EditContactsType type,
    string remark = ""
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.EditContacts(System.String,Chat.Framework.WXSdk.Implement.EditContactsType,System.String)" 的 <param name="username"/> 文档]

type
类型：Chat.Framework.WXSdk.ImplementEditContactsType

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.EditContacts(System.String,Chat.Framework.WXSdk.Implement.EditContactsType,System.String)" 的 <param name="type"/> 文档]

remark (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.EditContacts(System.String,Chat.Framework.WXSdk.Implement.EditContactsType,System.String)" 的 <param name="remark"/> 文档]

参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.FindCircle 方法

WXClientImpl_HOOKFindCircle 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.FindCircle(System.String,System.String,System.Int32)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override List<Dictionary<string, Object>> FindCircle(
    string username,
    string firstPageMd5 = "",
    int MaxId = 0
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.FindCircle(System.String,System.String,System.Int32)" 的 <param name="username"/> 文档]

firstPageMd5 (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.FindCircle(System.String,System.String,System.Int32)" 的 <param name="firstPageMd5"/> 文档]

MaxId (Optional)
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.FindCircle(System.String,System.String,System.Int32)" 的 <param name="MaxId"/> 文档]

返回值

类型：List Dictionary String, Object
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.FindCircles 方法

WXClientImpl_HOOKFindCircles 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.FindCircles" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override List<Dictionary<string, Object>> FindCircles()

返回值

类型：List Dictionary String, Object
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetContact 方法

WXClientImpl_HOOKGetContact 方法

获得好友或群组信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Friend GetContact(
    string wxid,
    bool refresh = false
)

参数

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetContact(System.String,System.Boolean)" 的 <param name="wxid"/> 文档]

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetContact(System.String,System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：Friend
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetGroupsNotInMember 方法

WXClientImpl_HOOKGetGroupsNotInMember 方法

获取群基本消息(不包含群成员)

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override List<Friend> GetGroupsNotInMember()

返回值

类型：List Friend
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetGroupWxidInfo 方法

WXClientImpl_HOOKGetGroupWxidInfo 方法

重载列表
 | 名称 | 说明
公共方法 | GetGroupWxidInfo(String, String) | 获取指定的群和用户
公共方法 | GetGroupWxidInfo(String, String, Boolean) |
Top
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetGroupWxidInfo 方法 (String, String)

WXClientImpl_HOOKGetGroupWxidInfo 方法 (String, String)

获取指定的群和用户

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetGroupWxidInfo(
    string groupId,
    string wxid
)

参数

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetGroupWxidInfo(System.String,System.String)" 的 <param name="groupId"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetGroupWxidInfo(System.String,System.String)" 的 <param name="wxid"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
GetGroupWxidInfo 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetGroupWxidInfo 方法 (String, String, Boolean)

WXClientImpl_HOOKGetGroupWxidInfo 方法 (String, String, Boolean)

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetGroupWxidInfo(System.String,System.String,System.Boolean)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetGroupWxidInfo(
    string groupId,
    string wxid,
    bool flush
)

参数

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetGroupWxidInfo(System.String,System.String,System.Boolean)" 的 <param name="groupId"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetGroupWxidInfo(System.String,System.String,System.Boolean)" 的 <param name="wxid"/> 文档]

flush
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetGroupWxidInfo(System.String,System.String,System.Boolean)" 的 <param name="flush"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
GetGroupWxidInfo 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetMember 方法

WXClientImpl_HOOKGetMember 方法

重载列表
 | 名称 | 说明
公共方法 | GetMember(String, String) | 获取群用户信息 (重写 WeixinBaseGetMember(String, String).)
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息 (重写 WeixinBaseGetMember(String, String, Boolean).)
Top
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetMember 方法 (String, String)

WXClientImpl_HOOKGetMember 方法 (String, String)

获取群用户信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override GroupMember GetMember(
    string groupid,
    string wxid
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetMember(System.String,System.String)" 的 <param name="groupid"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetMember(System.String,System.String)" 的 <param name="wxid"/> 文档]

返回值

类型：GroupMember
参见

引用

WXClientImpl_HOOK 类
GetMember 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetMember 方法 (String, String, Boolean)

WXClientImpl_HOOKGetMember 方法 (String, String, Boolean)

获取群用户信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override GroupMember GetMember(
    string groupid,
    string wxid,
    bool flush = false
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetMember(System.String,System.String,System.Boolean)" 的 <param name="groupid"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetMember(System.String,System.String,System.Boolean)" 的 <param name="wxid"/> 文档]

flush (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetMember(System.String,System.String,System.Boolean)" 的 <param name="flush"/> 文档]

返回值

类型：GroupMember
参见

引用

WXClientImpl_HOOK 类
GetMember 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetWxidInfo 方法

WXClientImpl_HOOKGetWxidInfo 方法

获取指定的用户

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetWxidInfo(
    string wxid
)

参数

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.GetWxidInfo(System.String)" 的 <param name="wxid"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.GetZombie 方法

WXClientImpl_HOOKGetZombie 方法

检测僵尸（最后获取Friends集合，判断里面的Ticket的值不为空为僵尸）

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void GetZombie()
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.InviteIntoGroup 方法

WXClientImpl_HOOKInviteIntoGroup 方法

邀请入群

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string InviteIntoGroup(
    string username,
    string groupId
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.InviteIntoGroup(System.String,System.String)" 的 <param name="username"/> 文档]

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.InviteIntoGroup(System.String,System.String)" 的 <param name="groupId"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LoginOut 方法

WXClientImpl_HOOKLoginOut 方法

重载列表
 | 名称 | 说明
公共方法 | LoginOut | 退出登录 (重写 WeixinBaseLoginOut.)
公共方法 | LoginOut(String) | 退出消息 (重写 WeixinBaseLoginOut(String).)
Top
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LoginOut 方法

WXClientImpl_HOOKLoginOut 方法

退出登录

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void LoginOut()
参见

引用

WXClientImpl_HOOK 类
LoginOut 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LoginOut 方法 (String)

WXClientImpl_HOOKLoginOut 方法 (String)

退出消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void LoginOut(
    string message
)

参数

message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LoginOut(System.String)" 的 <param name="message"/> 文档]

参见

引用

WXClientImpl_HOOK 类
LoginOut 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ModRoomMyName 方法

WXClientImpl_HOOKModRoomMyName 方法

设置自己在群中昵称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ModRoomMyName(
    string nickname,
    string groupId
)

参数

nickname
类型：SystemString
要设置的昵称
groupId
类型：SystemString
需要设置的群id
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ModRoomName 方法

WXClientImpl_HOOKModRoomName 方法

修改群聊名称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ModRoomName(
    string newnick,
    string groupId
)

参数

newnick
类型：SystemString
新名称
groupId
类型：SystemString
群号
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.OpenUrl 方法

WXClientImpl_HOOKOpenUrl 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.OpenUrl(System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void OpenUrl(
    string url
)

参数

url
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.OpenUrl(System.String)" 的 <param name="url"/> 文档]

参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.Receive 方法

WXClientImpl_HOOKReceive 方法

分析hook服务器过来的事件

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Receive(
    Object obj
)

参数

obj
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.Receive(System.Object)" 的 <param name="obj"/> 文档]

参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.RequestContact 方法

WXClientImpl_HOOKRequestContact 方法

请求获取联系人

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void RequestContact()
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SendCard 方法

WXClientImpl_HOOKSendCard 方法

发送卡片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendCard(
    string username,
    string friendwxid
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendCard(System.String,System.String)" 的 <param name="username"/> 文档]

friendwxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendCard(System.String,System.String)" 的 <param name="friendwxid"/> 文档]

参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SendCircle 方法

WXClientImpl_HOOKSendCircle 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendCircle(System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string SendCircle(
    string msg
)

参数

msg
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendCircle(System.String)" 的 <param name="msg"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SendCircleComment 方法

WXClientImpl_HOOKSendCircleComment 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendCircleComment(System.String,System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendCircleComment(
    string username,
    string circleId,
    string content
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendCircleComment(System.String,System.String,System.String)" 的 <param name="username"/> 文档]

circleId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendCircleComment(System.String,System.String,System.String)" 的 <param name="circleId"/> 文档]

content
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendCircleComment(System.String,System.String,System.String)" 的 <param name="content"/> 文档]

参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SendCirclePraise 方法

WXClientImpl_HOOKSendCirclePraise 方法

朋友圈点赞

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendCirclePraise(
    string username,
    string circleId
)

参数

username
类型：SystemString
无用
circleId
类型：SystemString
朋友圈id
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SendImage 方法

WXClientImpl_HOOKSendImage 方法

重载列表
 | 名称 | 说明
公共方法 | SendImage(Byte, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendImage(String, String) | 发送图片 (重写 WeixinBaseSendImage(String, String).)
Top
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SendImage 方法 (String, String)

WXClientImpl_HOOKSendImage 方法 (String, String)

发送图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendImage(
    string username,
    string address
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendImage(System.String,System.String)" 的 <param name="username"/> 文档]

address
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendImage(System.String,System.String)" 的 <param name="address"/> 文档]

参见

引用

WXClientImpl_HOOK 类
SendImage 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SendMessage 方法

WXClientImpl_HOOKSendMessage 方法

发送消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Task<bool> SendMessage(
    string _username,
    string _message,
    string _atUsername = ""
)

参数

_username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendMessage(System.String,System.String,System.String)" 的 <param name="_username"/> 文档]

_message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendMessage(System.String,System.String,System.String)" 的 <param name="_message"/> 文档]

_atUsername (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SendMessage(System.String,System.String,System.String)" 的 <param name="_atUsername"/> 文档]

返回值

类型：Task Boolean
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SetDisableRevoke 方法

WXClientImpl_HOOKSetDisableRevoke 方法

开启/关闭防撤回功能

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SetDisableRevoke(
    bool status
)

参数

status
类型：SystemBoolean
1是开启防撤回，0是关闭
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SetRecvNotify 方法

WXClientImpl_HOOKSetRecvNotify 方法

是否消息免打扰

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SetRecvNotify(
    bool status,
    string wxid
)

参数

status
类型：SystemBoolean
true为开启
wxid
类型：SystemString
wxid
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SetRoomName 方法

WXClientImpl_HOOKSetRoomName 方法

修改群聊名称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SetRoomName(
    string new_name,
    string groupId
)

参数

new_name
类型：SystemString
新的群名
groupId
类型：SystemString
群id
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SetRoomNotice 方法

WXClientImpl_HOOKSetRoomNotice 方法

修改群公告(可用于@全体)

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SetRoomNotice(
    string notice,
    string groupId
)

参数

notice
类型：SystemString
新公告
groupId
类型：SystemString
群聊wxid
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SetRoomShowMemeberName 方法

WXClientImpl_HOOKSetRoomShowMemeberName 方法

设置是否显示群成员昵称

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SetRoomShowMemeberName(
    bool status,
    string groupId
)

参数

status
类型：SystemBoolean
true为开启
groupId
类型：SystemString
要显示得到群
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SetSessionReadedMsg 方法

WXClientImpl_HOOKSetSessionReadedMsg 方法

设置会话已读

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SetSessionReadedMsg(
    string wxid
)

参数

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SetSessionReadedMsg(System.String)" 的 <param name="wxid"/> 文档]

参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ShowLogin 方法

WXClientImpl_HOOKShowLogin 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.ShowLogin" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ShowLogin()
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.TenPayTransferConfirm 方法

WXClientImpl_HOOKTenPayTransferConfirm 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override int TenPayTransferConfirm(
    string Invalidtime,
    string Transferid,
    string FromUsername
)

参数

Invalidtime
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <param name="Invalidtime"/> 文档]

Transferid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <param name="Transferid"/> 文档]

FromUsername
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <param name="FromUsername"/> 文档]

返回值

类型：Int32
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.UplodCircleImage 方法

WXClientImpl_HOOKUplodCircleImage 方法

开始上传图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string UplodCircleImage(
    string url
)

参数

url
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.UplodCircleImage(System.String)" 的 <param name="url"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_HOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri 类

WXClientImpl_HOOKCirCleInfoOri 类

[缺少 "T:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOKCirCleInfoOri

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CirCleInfoOri

WXClientImpl_HOOKCirCleInfoOri 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_HOOKCirCleInfoOri | 初始化 WXClientImpl_HOOKCirCleInfoOri 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | blackListCount |
公共属性 | commentCount |
公共属性 | commentUserList |
公共属性 | commentUserListCount |
公共属性 | createTime |
公共属性 | deleteFlag |
公共属性 | extFlag |
公共属性 | groupCount |
公共属性 | groupUserCount |
公共属性 | id |
公共属性 | isNotRichText |
公共属性 | likeCount |
公共属性 | likeFlag |
公共属性 | likeUserList |
公共属性 | likeUserListCount |
公共属性 | nickname |
公共属性 | noChange |
公共属性 | objectDesc |
公共属性 | objectOperations |
公共属性 | preDownloadInfo |
公共属性 | referId |
公共属性 | referUsername |
公共属性 | snsRedEnvelops |
公共属性 | username |
公共属性 | weAppInfo |
公共属性 | withUserCount |
公共属性 | withUserListCount |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri 构造函数

WXClientImpl_HOOKCirCleInfoOri 构造函数

初始化 WXClientImpl_HOOKCirCleInfoOri 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CirCleInfoOri()
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


CirCleInfoOri 属性

WXClientImpl_HOOKCirCleInfoOri 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | blackListCount |
公共属性 | commentCount |
公共属性 | commentUserList |
公共属性 | commentUserListCount |
公共属性 | createTime |
公共属性 | deleteFlag |
公共属性 | extFlag |
公共属性 | groupCount |
公共属性 | groupUserCount |
公共属性 | id |
公共属性 | isNotRichText |
公共属性 | likeCount |
公共属性 | likeFlag |
公共属性 | likeUserList |
公共属性 | likeUserListCount |
公共属性 | nickname |
公共属性 | noChange |
公共属性 | objectDesc |
公共属性 | objectOperations |
公共属性 | preDownloadInfo |
公共属性 | referId |
公共属性 | referUsername |
公共属性 | snsRedEnvelops |
公共属性 | username |
公共属性 | weAppInfo |
公共属性 | withUserCount |
公共属性 | withUserListCount |
Top
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.blackListCount 属性

WXClientImpl_HOOKCirCleInfoOriblackListCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.blackListCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int blackListCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.commentCount 属性

WXClientImpl_HOOKCirCleInfoOricommentCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.commentCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int commentCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.commentUserList 属性

WXClientImpl_HOOKCirCleInfoOricommentUserList 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.commentUserList" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<WXClientImpl_HOOKCommentUserListOri> commentUserList { get; set; }

属性值

类型：List WXClientImpl_HOOKCommentUserListOri
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.commentUserListCount 属性

WXClientImpl_HOOKCirCleInfoOricommentUserListCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.commentUserListCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int commentUserListCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.createTime 属性

WXClientImpl_HOOKCirCleInfoOricreateTime 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.createTime" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int createTime { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.deleteFlag 属性

WXClientImpl_HOOKCirCleInfoOrideleteFlag 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.deleteFlag" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int deleteFlag { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.extFlag 属性

WXClientImpl_HOOKCirCleInfoOriextFlag 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.extFlag" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int extFlag { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.groupCount 属性

WXClientImpl_HOOKCirCleInfoOrigroupCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.groupCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int groupCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.groupUserCount 属性

WXClientImpl_HOOKCirCleInfoOrigroupUserCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.groupUserCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int groupUserCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.id 属性

WXClientImpl_HOOKCirCleInfoOriid 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.id" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public double id { get; set; }

属性值

类型：Double
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.isNotRichText 属性

WXClientImpl_HOOKCirCleInfoOriisNotRichText 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.isNotRichText" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int isNotRichText { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.likeCount 属性

WXClientImpl_HOOKCirCleInfoOrilikeCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.likeCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int likeCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.likeFlag 属性

WXClientImpl_HOOKCirCleInfoOrilikeFlag 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.likeFlag" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int likeFlag { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.likeUserList 属性

WXClientImpl_HOOKCirCleInfoOrilikeUserList 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.likeUserList" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<WXClientImpl_HOOKLikeUserListOri> likeUserList { get; set; }

属性值

类型：List WXClientImpl_HOOKLikeUserListOri
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.likeUserListCount 属性

WXClientImpl_HOOKCirCleInfoOrilikeUserListCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.likeUserListCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int likeUserListCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.nickname 属性

WXClientImpl_HOOKCirCleInfoOrinickname 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.nickname" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string nickname { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.noChange 属性

WXClientImpl_HOOKCirCleInfoOrinoChange 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.noChange" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int noChange { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.objectDesc 属性

WXClientImpl_HOOKCirCleInfoOriobjectDesc 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.objectDesc" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_HOOKObjectDesc objectDesc { get; set; }

属性值

类型：WXClientImpl_HOOKObjectDesc
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.objectOperations 属性

WXClientImpl_HOOKCirCleInfoOriobjectOperations 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.objectOperations" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_HOOKObjectOperations objectOperations { get; set; }

属性值

类型：WXClientImpl_HOOKObjectOperations
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.preDownloadInfo 属性

WXClientImpl_HOOKCirCleInfoOripreDownloadInfo 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.preDownloadInfo" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_HOOKPreDownloadInfo preDownloadInfo { get; set; }

属性值

类型：WXClientImpl_HOOKPreDownloadInfo
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.referId 属性

WXClientImpl_HOOKCirCleInfoOrireferId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.referId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int referId { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.referUsername 属性

WXClientImpl_HOOKCirCleInfoOrireferUsername 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.referUsername" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string referUsername { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.snsRedEnvelops 属性

WXClientImpl_HOOKCirCleInfoOrisnsRedEnvelops 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.snsRedEnvelops" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_HOOKSnsRedEnvelops snsRedEnvelops { get; set; }

属性值

类型：WXClientImpl_HOOKSnsRedEnvelops
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.username 属性

WXClientImpl_HOOKCirCleInfoOriusername 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.username" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string username { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.weAppInfo 属性

WXClientImpl_HOOKCirCleInfoOriweAppInfo 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.weAppInfo" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_HOOKWeAppInfo weAppInfo { get; set; }

属性值

类型：WXClientImpl_HOOKWeAppInfo
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.withUserCount 属性

WXClientImpl_HOOKCirCleInfoOriwithUserCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.withUserCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int withUserCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CirCleInfoOri.withUserListCount 属性

WXClientImpl_HOOKCirCleInfoOriwithUserListCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CirCleInfoOri.withUserListCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int withUserListCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


CirCleInfoOri 方法

WXClientImpl_HOOKCirCleInfoOri 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_HOOKCirCleInfoOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri 类

WXClientImpl_HOOKCommentUserListOri 类

[缺少 "T:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOKCommentUserListOri

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class CommentUserListOri

WXClientImpl_HOOKCommentUserListOri 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_HOOKCommentUserListOri | 初始化 WXClientImpl_HOOKCommentUserListOri 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | commentFlag |
公共属性 | commentId |
公共属性 | commentId2 |
公共属性 | content |
公共属性 | createTime |
公共属性 | deleteFlag |
公共属性 | isNotRichText |
公共属性 | nickname | 先森吳
公共属性 | replyCommentId |
公共属性 | replyCommentId2 |
公共属性 | replyUsername |
公共属性 | source |
公共属性 | type |
公共属性 | username |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri 构造函数

WXClientImpl_HOOKCommentUserListOri 构造函数

初始化 WXClientImpl_HOOKCommentUserListOri 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public CommentUserListOri()
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


CommentUserListOri 属性

WXClientImpl_HOOKCommentUserListOri 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | commentFlag |
公共属性 | commentId |
公共属性 | commentId2 |
公共属性 | content |
公共属性 | createTime |
公共属性 | deleteFlag |
公共属性 | isNotRichText |
公共属性 | nickname | 先森吳
公共属性 | replyCommentId |
公共属性 | replyCommentId2 |
公共属性 | replyUsername |
公共属性 | source |
公共属性 | type |
公共属性 | username |
Top
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.commentFlag 属性

WXClientImpl_HOOKCommentUserListOricommentFlag 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.commentFlag" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int commentFlag { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.commentId 属性

WXClientImpl_HOOKCommentUserListOricommentId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.commentId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int commentId { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.commentId2 属性

WXClientImpl_HOOKCommentUserListOricommentId2 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.commentId2" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int commentId2 { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.content 属性

WXClientImpl_HOOKCommentUserListOricontent 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.content" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string content { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.createTime 属性

WXClientImpl_HOOKCommentUserListOricreateTime 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.createTime" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int createTime { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.deleteFlag 属性

WXClientImpl_HOOKCommentUserListOrideleteFlag 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.deleteFlag" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int deleteFlag { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.isNotRichText 属性

WXClientImpl_HOOKCommentUserListOriisNotRichText 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.isNotRichText" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int isNotRichText { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.nickname 属性

WXClientImpl_HOOKCommentUserListOrinickname 属性

先森吳

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string nickname { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.replyCommentId 属性

WXClientImpl_HOOKCommentUserListOrireplyCommentId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.replyCommentId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int replyCommentId { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.replyCommentId2 属性

WXClientImpl_HOOKCommentUserListOrireplyCommentId2 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.replyCommentId2" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int replyCommentId2 { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.replyUsername 属性

WXClientImpl_HOOKCommentUserListOrireplyUsername 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.replyUsername" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string replyUsername { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.source 属性

WXClientImpl_HOOKCommentUserListOrisource 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.source" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int source { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.type 属性

WXClientImpl_HOOKCommentUserListOritype 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.type" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int type { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.CommentUserListOri.username 属性

WXClientImpl_HOOKCommentUserListOriusername 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.CommentUserListOri.username" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string username { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


CommentUserListOri 方法

WXClientImpl_HOOKCommentUserListOri 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_HOOKCommentUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri 类

WXClientImpl_HOOKLikeUserListOri 类

[缺少 "T:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOKLikeUserListOri

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class LikeUserListOri

WXClientImpl_HOOKLikeUserListOri 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_HOOKLikeUserListOri | 初始化 WXClientImpl_HOOKLikeUserListOri 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | commentFlag |
公共属性 | commentId |
公共属性 | commentId2 |
公共属性 | content |
公共属性 | createTime |
公共属性 | deleteFlag |
公共属性 | isNotRichText |
公共属性 | nickname |
公共属性 | replyCommentId |
公共属性 | replyCommentId2 |
公共属性 | replyUsername |
公共属性 | source |
公共属性 | type |
公共属性 | username |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri 构造函数

WXClientImpl_HOOKLikeUserListOri 构造函数

初始化 WXClientImpl_HOOKLikeUserListOri 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public LikeUserListOri()
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


LikeUserListOri 属性

WXClientImpl_HOOKLikeUserListOri 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | commentFlag |
公共属性 | commentId |
公共属性 | commentId2 |
公共属性 | content |
公共属性 | createTime |
公共属性 | deleteFlag |
公共属性 | isNotRichText |
公共属性 | nickname |
公共属性 | replyCommentId |
公共属性 | replyCommentId2 |
公共属性 | replyUsername |
公共属性 | source |
公共属性 | type |
公共属性 | username |
Top
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.commentFlag 属性

WXClientImpl_HOOKLikeUserListOricommentFlag 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.commentFlag" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int commentFlag { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.commentId 属性

WXClientImpl_HOOKLikeUserListOricommentId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.commentId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int commentId { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.commentId2 属性

WXClientImpl_HOOKLikeUserListOricommentId2 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.commentId2" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int commentId2 { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.content 属性

WXClientImpl_HOOKLikeUserListOricontent 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.content" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string content { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.createTime 属性

WXClientImpl_HOOKLikeUserListOricreateTime 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.createTime" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int createTime { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.deleteFlag 属性

WXClientImpl_HOOKLikeUserListOrideleteFlag 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.deleteFlag" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int deleteFlag { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.isNotRichText 属性

WXClientImpl_HOOKLikeUserListOriisNotRichText 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.isNotRichText" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int isNotRichText { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.nickname 属性

WXClientImpl_HOOKLikeUserListOrinickname 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.nickname" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string nickname { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.replyCommentId 属性

WXClientImpl_HOOKLikeUserListOrireplyCommentId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.replyCommentId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int replyCommentId { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.replyCommentId2 属性

WXClientImpl_HOOKLikeUserListOrireplyCommentId2 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.replyCommentId2" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int replyCommentId2 { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.replyUsername 属性

WXClientImpl_HOOKLikeUserListOrireplyUsername 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.replyUsername" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string replyUsername { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.source 属性

WXClientImpl_HOOKLikeUserListOrisource 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.source" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int source { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.type 属性

WXClientImpl_HOOKLikeUserListOritype 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.type" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int type { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.LikeUserListOri.username 属性

WXClientImpl_HOOKLikeUserListOriusername 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.LikeUserListOri.username" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string username { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


LikeUserListOri 方法

WXClientImpl_HOOKLikeUserListOri 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_HOOKLikeUserListOri 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ObjectDesc 类

WXClientImpl_HOOKObjectDesc 类

[缺少 "T:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.ObjectDesc" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOKObjectDesc

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ObjectDesc

WXClientImpl_HOOKObjectDesc 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_HOOKObjectDesc | 初始化 WXClientImpl_HOOKObjectDesc 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | buffer |
公共属性 | iLen |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ObjectDesc 构造函数

WXClientImpl_HOOKObjectDesc 构造函数

初始化 WXClientImpl_HOOKObjectDesc 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ObjectDesc()
参见

引用

WXClientImpl_HOOKObjectDesc 类
Chat.Framework.WXSdk.Implement 命名空间


ObjectDesc 属性

WXClientImpl_HOOKObjectDesc 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | buffer |
公共属性 | iLen |
Top
参见

引用

WXClientImpl_HOOKObjectDesc 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ObjectDesc.buffer 属性

WXClientImpl_HOOKObjectDescbuffer 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.ObjectDesc.buffer" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string buffer { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKObjectDesc 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ObjectDesc.iLen 属性

WXClientImpl_HOOKObjectDesciLen 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.ObjectDesc.iLen" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int iLen { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKObjectDesc 类
Chat.Framework.WXSdk.Implement 命名空间


ObjectDesc 方法

WXClientImpl_HOOKObjectDesc 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_HOOKObjectDesc 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ObjectOperations 类

WXClientImpl_HOOKObjectOperations 类

[缺少 "T:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.ObjectOperations" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOKObjectOperations

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ObjectOperations

WXClientImpl_HOOKObjectOperations 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_HOOKObjectOperations | 初始化 WXClientImpl_HOOKObjectOperations 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | buffer |
公共属性 | iLen |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ObjectOperations 构造函数

WXClientImpl_HOOKObjectOperations 构造函数

初始化 WXClientImpl_HOOKObjectOperations 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ObjectOperations()
参见

引用

WXClientImpl_HOOKObjectOperations 类
Chat.Framework.WXSdk.Implement 命名空间


ObjectOperations 属性

WXClientImpl_HOOKObjectOperations 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | buffer |
公共属性 | iLen |
Top
参见

引用

WXClientImpl_HOOKObjectOperations 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ObjectOperations.buffer 属性

WXClientImpl_HOOKObjectOperationsbuffer 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.ObjectOperations.buffer" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string buffer { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKObjectOperations 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.ObjectOperations.iLen 属性

WXClientImpl_HOOKObjectOperationsiLen 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.ObjectOperations.iLen" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int iLen { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKObjectOperations 类
Chat.Framework.WXSdk.Implement 命名空间


ObjectOperations 方法

WXClientImpl_HOOKObjectOperations 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_HOOKObjectOperations 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.PreDownloadInfo 类

WXClientImpl_HOOKPreDownloadInfo 类

[缺少 "T:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.PreDownloadInfo" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOKPreDownloadInfo

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PreDownloadInfo

WXClientImpl_HOOKPreDownloadInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_HOOKPreDownloadInfo | 初始化 WXClientImpl_HOOKPreDownloadInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | noPreDownloadRange |
公共属性 | preDownloadNetType |
公共属性 | preDownloadPercent |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.PreDownloadInfo 构造函数

WXClientImpl_HOOKPreDownloadInfo 构造函数

初始化 WXClientImpl_HOOKPreDownloadInfo 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PreDownloadInfo()
参见

引用

WXClientImpl_HOOKPreDownloadInfo 类
Chat.Framework.WXSdk.Implement 命名空间


PreDownloadInfo 属性

WXClientImpl_HOOKPreDownloadInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | noPreDownloadRange |
公共属性 | preDownloadNetType |
公共属性 | preDownloadPercent |
Top
参见

引用

WXClientImpl_HOOKPreDownloadInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.PreDownloadInfo.noPreDownloadRange 属性

WXClientImpl_HOOKPreDownloadInfonoPreDownloadRange 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.PreDownloadInfo.noPreDownloadRange" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string noPreDownloadRange { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKPreDownloadInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.PreDownloadInfo.preDownloadNetType 属性

WXClientImpl_HOOKPreDownloadInfopreDownloadNetType 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.PreDownloadInfo.preDownloadNetType" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int preDownloadNetType { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKPreDownloadInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.PreDownloadInfo.preDownloadPercent 属性

WXClientImpl_HOOKPreDownloadInfopreDownloadPercent 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.PreDownloadInfo.preDownloadPercent" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int preDownloadPercent { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKPreDownloadInfo 类
Chat.Framework.WXSdk.Implement 命名空间


PreDownloadInfo 方法

WXClientImpl_HOOKPreDownloadInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_HOOKPreDownloadInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SnsRedEnvelops 类

WXClientImpl_HOOKSnsRedEnvelops 类

[缺少 "T:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SnsRedEnvelops" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOKSnsRedEnvelops

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SnsRedEnvelops

WXClientImpl_HOOKSnsRedEnvelops 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_HOOKSnsRedEnvelops | 初始化 WXClientImpl_HOOKSnsRedEnvelops 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | reportId |
公共属性 | reportKey |
公共属性 | resourceId |
公共属性 | rewardCount |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SnsRedEnvelops 构造函数

WXClientImpl_HOOKSnsRedEnvelops 构造函数

初始化 WXClientImpl_HOOKSnsRedEnvelops 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SnsRedEnvelops()
参见

引用

WXClientImpl_HOOKSnsRedEnvelops 类
Chat.Framework.WXSdk.Implement 命名空间


SnsRedEnvelops 属性

WXClientImpl_HOOKSnsRedEnvelops 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | reportId |
公共属性 | reportKey |
公共属性 | resourceId |
公共属性 | rewardCount |
Top
参见

引用

WXClientImpl_HOOKSnsRedEnvelops 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SnsRedEnvelops.reportId 属性

WXClientImpl_HOOKSnsRedEnvelopsreportId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SnsRedEnvelops.reportId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int reportId { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKSnsRedEnvelops 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SnsRedEnvelops.reportKey 属性

WXClientImpl_HOOKSnsRedEnvelopsreportKey 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SnsRedEnvelops.reportKey" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int reportKey { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKSnsRedEnvelops 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SnsRedEnvelops.resourceId 属性

WXClientImpl_HOOKSnsRedEnvelopsresourceId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SnsRedEnvelops.resourceId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int resourceId { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKSnsRedEnvelops 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.SnsRedEnvelops.rewardCount 属性

WXClientImpl_HOOKSnsRedEnvelopsrewardCount 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.SnsRedEnvelops.rewardCount" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int rewardCount { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKSnsRedEnvelops 类
Chat.Framework.WXSdk.Implement 命名空间


SnsRedEnvelops 方法

WXClientImpl_HOOKSnsRedEnvelops 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_HOOKSnsRedEnvelops 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.WeAppInfo 类

WXClientImpl_HOOKWeAppInfo 类

[缺少 "T:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.WeAppInfo" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWXClientImpl_HOOKWeAppInfo

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WeAppInfo

WXClientImpl_HOOKWeAppInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_HOOKWeAppInfo | 初始化 WXClientImpl_HOOKWeAppInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | appId |
公共属性 | mapPoiId |
公共属性 | redirectUrl |
公共属性 | score |
公共属性 | showType |
公共属性 | userName |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.WeAppInfo 构造函数

WXClientImpl_HOOKWeAppInfo 构造函数

初始化 WXClientImpl_HOOKWeAppInfo 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeAppInfo()
参见

引用

WXClientImpl_HOOKWeAppInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WeAppInfo 属性

WXClientImpl_HOOKWeAppInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | appId |
公共属性 | mapPoiId |
公共属性 | redirectUrl |
公共属性 | score |
公共属性 | showType |
公共属性 | userName |
Top
参见

引用

WXClientImpl_HOOKWeAppInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.WeAppInfo.appId 属性

WXClientImpl_HOOKWeAppInfoappId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.WeAppInfo.appId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int appId { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKWeAppInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.WeAppInfo.mapPoiId 属性

WXClientImpl_HOOKWeAppInfomapPoiId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.WeAppInfo.mapPoiId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string mapPoiId { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKWeAppInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.WeAppInfo.redirectUrl 属性

WXClientImpl_HOOKWeAppInforedirectUrl 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.WeAppInfo.redirectUrl" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string redirectUrl { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKWeAppInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.WeAppInfo.score 属性

WXClientImpl_HOOKWeAppInfoscore 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.WeAppInfo.score" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int score { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKWeAppInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.WeAppInfo.showType 属性

WXClientImpl_HOOKWeAppInfoshowType 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.WeAppInfo.showType" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int showType { get; set; }

属性值

类型：Int32
参见

引用

WXClientImpl_HOOKWeAppInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_HOOK.WeAppInfo.userName 属性

WXClientImpl_HOOKWeAppInfouserName 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_HOOK.WeAppInfo.userName" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string userName { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_HOOKWeAppInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WeAppInfo 方法

WXClientImpl_HOOKWeAppInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_HOOKWeAppInfo 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD 类

协议微信
继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWeixinBase
Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXClientImpl_IPAD : WeixinBase

WXClientImpl_IPAD 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_IPAD | 初始化 WXClientImpl_IPAD 类的一个新实例
公共方法 | WXClientImpl_IPAD(String) | 初始化 WXClientImpl_IPAD 类的一个新实例
公共方法 | WXClientImpl_IPAD(String, String) | 初始化 WXClientImpl_IPAD 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DeviceId |
公共属性 | Friends | 好友列表
公共属性 | GroupMembers |
公共属性 | Host |
公共属性 | IsRefreshContact | 刷新通讯录信息(获取好友列表),刷新状态[true为更新中]
公共属性 | IsResetConnection |
公共属性 | IsRunning |
公共属性 | LoginErrorMessage |
公共属性 | Password | 登录密码
公共属性 | RegisterdHandler |
公共属性 | Socket |
公共属性 | Status | 微信状态 (继承自 WeixinBase。)
公共属性 | User | 用户 (继承自 WeixinBase。)
公共属性 | WaitHandler |
公共属性 | WeixinHao | 微信号 (继承自 WeixinBase。)
公共属性 | WeixinType | 微信类型 (继承自 WeixinBase。)
Top
方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | (重写 WeixinBaseAddChatRoomMember(String, String).)
公共方法 | AddChatRoomMember_40Down | 添加群用户_40人以下 (继承自 WeixinBase。)
公共方法 | AddLabel | 添加标签 (重写 WeixinBaseAddLabel(String).)
公共方法 | AddPublicUser | 关注公众号 (继承自 WeixinBase。)
公共方法 | AgreeAddMe | 同意添加我为好友 (重写 WeixinBaseAgreeAddMe(String).)
公共方法 | AsyncSyncMessage | 强制拉取消息
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序 (继承自 WeixinBase。)
公共方法 | ChangeStatus | (重写 WeixinBaseChangeStatus(WxStatus, WXChangeStatus, Boolean).)
公共方法 | CheckUrl | 检测URL在微信中是否有效 (继承自 WeixinBase。)
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录 (继承自 WeixinBase。)
公共方法 | CloseGRPC |
公共方法 | CreateChatRoom(String) | (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | CreateChatRoom(String) | (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | DelayMess | 消息延迟
公共方法 | DeleteFriend | 删除好友(可以用户清理僵尸粉用) (重写 WeixinBaseDeleteFriend(String).)
公共方法 | DeleteGroupMember | (重写 WeixinBaseDeleteGroupMember(String, String).)
公共方法 | Dispose | 释放被 WXClientImpl_IPAD 使用的所有资源
公共方法 | DownlowdImage | (重写 WeixinBaseDownlowdImage(Int32, String, Int32).)
公共方法 | EditContacts | 编辑用户信息 (重写 WeixinBaseEditContacts(String, EditContactsType, String).)
公共方法 | EditUserLabel | 修改标签 (重写 WeixinBaseEditUserLabel(String, ListLable).)
公共方法 | Equals | (继承自 Object。)
公共方法 | FastLogin | 执行二次登录
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindBankCar | 获得银行卡
公共方法 | FindCircle | 获取朋友圈 (重写 WeixinBaseFindCircle(String, String, Int32).)
公共方法 | FindCircles | 获取朋友圈内容 (重写 WeixinBaseFindCircles.)
公共方法 | FindFriendsT | 获得好友列表 (继承自 WeixinBase。)
公共方法 | FindLoginImage | 获得登录图片
公共方法 | FindLoginStatus | 登录状态检测
 | FindRandomExpression |
公共方法 | FocusWechat | 关注公众号 (重写 WeixinBaseFocusWechat(String).)
公共方法 | GetBalance | (重写 WeixinBaseGetBalance.)
公共方法 | GetContact | 获得好友或群组信息 (重写 WeixinBaseGetContact(String, Boolean).)
公共方法 | GetGroupsNotInMember | 获取群列表(不包含群成员) (继承自 WeixinBase。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签 (重写 WeixinBaseGetLabelList(Boolean).)
公共方法 | GetMember(String, String) | (重写 WeixinBaseGetMember(String, String).)
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息带刷新 (继承自 WeixinBase。)
公共方法 | GetMembers | (重写 WeixinBaseGetMembers(String, Boolean).)
公共方法 | GetRobotQRcode | 获取联系人二维码 (重写 WeixinBaseGetRobotQRcode(Boolean).)
公共方法 | GetType | (继承自 Object。)
公共方法 | Initialization | 快速初始化通讯录列表
公共方法 | InviteIntoGroup | 邀请入群 (重写 WeixinBaseInviteIntoGroup(String, String).)
公共方法 | LoginOut | 退出登录 (重写 WeixinBaseLoginOut.)
公共方法 | LoginOut(String) | 退出微信 (继承自 WeixinBase。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称 (继承自 WeixinBase。)
公共方法 | ModRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | OpenUrl | 打开内置浏览器 (继承自 WeixinBase。)
公共方法 | ReadURL | 阅读文章
公共方法 | Receive | 分析事件 (继承自 WeixinBase。)
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表) (重写 WeixinBaseRefreshContact(ActionWXClientImpl_IPAD).)
公共方法 | ResetConnection | 重新连接 (重写 WeixinBaseResetConnection(Int32).)
公共方法 | SendCard | 发送卡片消息 (重写 WeixinBaseSendCard(String, String).)
公共方法 | SendCDNImage | (重写 WeixinBaseSendCDNImage(String, String).)
公共方法 | SendCDNInfo | 已过时。 (重写 WeixinBaseSendCDNInfo(String, String, String, CDNType).)
公共方法 | SendCDNVideo | 发送CDN视频 (重写 WeixinBaseSendCDNVideo(String, String, String).)
公共方法 | SendCircle | 发送朋友圈 (重写 WeixinBaseSendCircle(String).)
公共方法 | SendCircleComment | 发表评论 (重写 WeixinBaseSendCircleComment(String, String, String).)
公共方法 | SendCirclePraise | 点赞 (重写 WeixinBaseSendCirclePraise(String, String).)
公共方法 | SendImage(Byte, String) | 发送图片 (重写 WeixinBaseSendImage(Byte, String).)
公共方法 | SendImage(String, String) | 发送图片 (重写 WeixinBaseSendImage(String, String).)
公共方法 | SendMessage | 发送文本消息 (重写 WeixinBaseSendMessage(String, String, String).)
公共方法 | SendPay | 实现发红包 (重写 WeixinBaseSendPay(String, String, Int32, String, Int32, PayType, BankCar, DictionaryString, Object).)
公共方法 | SendProgramMessage | 发送小程序 (继承自 WeixinBase。)
公共方法 | SendVoice | 发送语音文件 (重写 WeixinBaseSendVoice(String, String).)
公共方法 | SerchKeyword | (重写 WeixinBaseSerchKeyword(String).)
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能 (继承自 WeixinBase。)
公共方法 | SetRecvNotify | 是否消息免打扰 (继承自 WeixinBase。)
公共方法 | SetRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | SetRoomNotice | 设置公告 (重写 WeixinBaseSetRoomNotice(String, String).)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称 (继承自 WeixinBase。)
公共方法 | SetSessionReadedMsg | 设置会话已读 (继承自 WeixinBase。)
公共方法 | ShowLogin | 显示登录窗口 (重写 WeixinBaseShowLogin.)
公共方法 | SnsVerify |
公共方法 | TenPayTransferConfirm | 自动确认收款接口 (重写 WeixinBaseTenPayTransferConfirm(String, String, String).)
公共方法 | ToString | (重写 ObjectToString.)
公共方法 | WriteLog | 写出日志 (继承自 WeixinBase。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD 构造函数

重载列表
 | 名称 | 说明
公共方法 | WXClientImpl_IPAD | 初始化 WXClientImpl_IPAD 类的一个新实例
公共方法 | WXClientImpl_IPAD(String) | 初始化 WXClientImpl_IPAD 类的一个新实例
公共方法 | WXClientImpl_IPAD(String, String) | 初始化 WXClientImpl_IPAD 类的一个新实例
Top
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD 构造函数

初始化 WXClientImpl_IPAD 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_IPAD()
参见

引用

WXClientImpl_IPAD 类
WXClientImpl_IPAD 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD 构造函数 (String)

初始化 WXClientImpl_IPAD 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_IPAD(
    string wei_xin_hao
)

参数

wei_xin_hao
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.#ctor(System.String)" 的 <param name="wei_xin_hao"/> 文档]

参见

引用

WXClientImpl_IPAD 类
WXClientImpl_IPAD 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD 构造函数 (String, String)

初始化 WXClientImpl_IPAD 类的一个新实例

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_IPAD(
    string WeixinHao,
    string data
)

参数

WeixinHao
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.#ctor(System.String,System.String)" 的 <param name="WeixinHao"/> 文档]

data
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.#ctor(System.String,System.String)" 的 <param name="data"/> 文档]

参见

引用

WXClientImpl_IPAD 类
WXClientImpl_IPAD 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD 属性

WXClientImpl_IPAD 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DeviceId |
公共属性 | Friends | 好友列表
公共属性 | GroupMembers |
公共属性 | Host |
公共属性 | IsRefreshContact | 刷新通讯录信息(获取好友列表),刷新状态[true为更新中]
公共属性 | IsResetConnection |
公共属性 | IsRunning |
公共属性 | LoginErrorMessage |
公共属性 | Password | 登录密码
公共属性 | RegisterdHandler |
公共属性 | Socket |
公共属性 | Status | 微信状态 (继承自 WeixinBase。)
公共属性 | User | 用户 (继承自 WeixinBase。)
公共属性 | WaitHandler |
公共属性 | WeixinHao | 微信号 (继承自 WeixinBase。)
公共属性 | WeixinType | 微信类型 (继承自 WeixinBase。)
Top
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.DeviceId 属性

WXClientImpl_IPADDeviceId 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.DeviceId" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DeviceId { get; }

属性值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.Friends 属性

WXClientImpl_IPADFriends 属性

好友列表

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Friend> Friends { get; }

属性值

类型：Dictionary String, Friend
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.GroupMembers 属性

WXClientImpl_IPADGroupMembers 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GroupMembers" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, GroupMember[]> GroupMembers { get; }

属性值

类型：Dictionary String, GroupMember
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.Host 属性

WXClientImpl_IPADHost 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.Host" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatHost Host { get; }

属性值

类型：WechatHost
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.IsRefreshContact 属性

WXClientImpl_IPADIsRefreshContact 属性

刷新通讯录信息(获取好友列表),刷新状态[true为更新中]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsRefreshContact { get; }

属性值

类型：Boolean
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.IsResetConnection 属性

WXClientImpl_IPADIsResetConnection 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.IsResetConnection" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsResetConnection { get; }

属性值

类型：Boolean
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.IsRunning 属性

WXClientImpl_IPADIsRunning 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.IsRunning" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsRunning { get; }

属性值

类型：Boolean
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.LoginErrorMessage 属性

WXClientImpl_IPADLoginErrorMessage 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.LoginErrorMessage" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string LoginErrorMessage { get; }

属性值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.Password 属性

WXClientImpl_IPADPassword 属性

登录密码

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Password { get; set; }

属性值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.RegisterdHandler 属性

WXClientImpl_IPADRegisterdHandler 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.RegisterdHandler" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public RegisteredWaitHandle RegisterdHandler { get; set; }

属性值

类型：RegisteredWaitHandle
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.Socket 属性

WXClientImpl_IPADSocket 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.Socket" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatSocket Socket { get; }

属性值

类型：WechatSocket
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.WaitHandler 属性

WXClientImpl_IPADWaitHandler 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.WaitHandler" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WaitHandle WaitHandler { get; set; }

属性值

类型：WaitHandle
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD 方法

WXClientImpl_IPAD 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | (重写 WeixinBaseAddChatRoomMember(String, String).)
公共方法 | AddChatRoomMember_40Down | 添加群用户_40人以下 (继承自 WeixinBase。)
公共方法 | AddLabel | 添加标签 (重写 WeixinBaseAddLabel(String).)
公共方法 | AddPublicUser | 关注公众号 (继承自 WeixinBase。)
公共方法 | AgreeAddMe | 同意添加我为好友 (重写 WeixinBaseAgreeAddMe(String).)
公共方法 | AsyncSyncMessage | 强制拉取消息
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序 (继承自 WeixinBase。)
公共方法 | ChangeStatus | (重写 WeixinBaseChangeStatus(WxStatus, WXChangeStatus, Boolean).)
公共方法 | CheckUrl | 检测URL在微信中是否有效 (继承自 WeixinBase。)
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录 (继承自 WeixinBase。)
公共方法 | CloseGRPC |
公共方法 | CreateChatRoom(String) | (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | CreateChatRoom(String) | (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | DelayMess | 消息延迟
公共方法 | DeleteFriend | 删除好友(可以用户清理僵尸粉用) (重写 WeixinBaseDeleteFriend(String).)
公共方法 | DeleteGroupMember | (重写 WeixinBaseDeleteGroupMember(String, String).)
公共方法 | Dispose |
公共方法 | DownlowdImage | (重写 WeixinBaseDownlowdImage(Int32, String, Int32).)
公共方法 | EditContacts | 编辑用户信息 (重写 WeixinBaseEditContacts(String, EditContactsType, String).)
公共方法 | EditUserLabel | 修改标签 (重写 WeixinBaseEditUserLabel(String, ListLable).)
公共方法 | Equals | (继承自 Object。)
公共方法 | FastLogin | 执行二次登录
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindBankCar | 获得银行卡
公共方法 | FindCircle | 获取朋友圈 (重写 WeixinBaseFindCircle(String, String, Int32).)
公共方法 | FindCircles | 获取朋友圈内容 (重写 WeixinBaseFindCircles.)
公共方法 | FindFriendsT | 获得好友列表 (继承自 WeixinBase。)
公共方法 | FindLoginImage | 获得登录图片
公共方法 | FindLoginStatus | 登录状态检测
 | FindRandomExpression |
公共方法 | FocusWechat | 关注公众号 (重写 WeixinBaseFocusWechat(String).)
公共方法 | GetBalance | (重写 WeixinBaseGetBalance.)
公共方法 | GetContact | 获得好友或群组信息 (重写 WeixinBaseGetContact(String, Boolean).)
公共方法 | GetGroupsNotInMember | 获取群列表(不包含群成员) (继承自 WeixinBase。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签 (重写 WeixinBaseGetLabelList(Boolean).)
公共方法 | GetMember(String, String) | (重写 WeixinBaseGetMember(String, String).)
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息带刷新 (继承自 WeixinBase。)
公共方法 | GetMembers | (重写 WeixinBaseGetMembers(String, Boolean).)
公共方法 | GetRobotQRcode | 获取联系人二维码 (重写 WeixinBaseGetRobotQRcode(Boolean).)
公共方法 | GetType | (继承自 Object。)
公共方法 | Initialization | 快速初始化通讯录列表
公共方法 | InviteIntoGroup | 邀请入群 (重写 WeixinBaseInviteIntoGroup(String, String).)
公共方法 | LoginOut | 退出登录 (重写 WeixinBaseLoginOut.)
公共方法 | LoginOut(String) | 退出微信 (继承自 WeixinBase。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称 (继承自 WeixinBase。)
公共方法 | ModRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | OpenUrl | 打开内置浏览器 (继承自 WeixinBase。)
公共方法 | ReadURL | 阅读文章
公共方法 | Receive | 分析事件 (继承自 WeixinBase。)
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表) (重写 WeixinBaseRefreshContact(ActionWXClientImpl_IPAD).)
公共方法 | ResetConnection | 重新连接 (重写 WeixinBaseResetConnection(Int32).)
公共方法 | SendCard | 发送卡片消息 (重写 WeixinBaseSendCard(String, String).)
公共方法 | SendCDNImage | (重写 WeixinBaseSendCDNImage(String, String).)
公共方法 | SendCDNInfo | 已过时。 (重写 WeixinBaseSendCDNInfo(String, String, String, CDNType).)
公共方法 | SendCDNVideo | 发送CDN视频 (重写 WeixinBaseSendCDNVideo(String, String, String).)
公共方法 | SendCircle | 发送朋友圈 (重写 WeixinBaseSendCircle(String).)
公共方法 | SendCircleComment | 发表评论 (重写 WeixinBaseSendCircleComment(String, String, String).)
公共方法 | SendCirclePraise | 点赞 (重写 WeixinBaseSendCirclePraise(String, String).)
公共方法 | SendImage(Byte, String) | 发送图片 (重写 WeixinBaseSendImage(Byte, String).)
公共方法 | SendImage(String, String) | 发送图片 (重写 WeixinBaseSendImage(String, String).)
公共方法 | SendMessage | 发送文本消息 (重写 WeixinBaseSendMessage(String, String, String).)
公共方法 | SendPay | 实现发红包 (重写 WeixinBaseSendPay(String, String, Int32, String, Int32, PayType, BankCar, DictionaryString, Object).)
公共方法 | SendProgramMessage | 发送小程序 (继承自 WeixinBase。)
公共方法 | SendVoice | 发送语音文件 (重写 WeixinBaseSendVoice(String, String).)
公共方法 | SerchKeyword | (重写 WeixinBaseSerchKeyword(String).)
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能 (继承自 WeixinBase。)
公共方法 | SetRecvNotify | 是否消息免打扰 (继承自 WeixinBase。)
公共方法 | SetRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | SetRoomNotice | 设置公告 (重写 WeixinBaseSetRoomNotice(String, String).)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称 (继承自 WeixinBase。)
公共方法 | SetSessionReadedMsg | 设置会话已读 (继承自 WeixinBase。)
公共方法 | ShowLogin | 显示登录窗口 (重写 WeixinBaseShowLogin.)
公共方法 | SnsVerify |
公共方法 | TenPayTransferConfirm | 自动确认收款接口 (重写 WeixinBaseTenPayTransferConfirm(String, String, String).)
公共方法 | ToString | (重写 ObjectToString.)
公共方法 | WriteLog | 写出日志 (继承自 WeixinBase。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.AddChatRoomMember 方法

WXClientImpl_IPADAddChatRoomMember 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.AddChatRoomMember(System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void AddChatRoomMember(
    string groupid,
    string members
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.AddChatRoomMember(System.String,System.String)" 的 <param name="groupid"/> 文档]

members
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.AddChatRoomMember(System.String,System.String)" 的 <param name="members"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.AddLabel 方法

WXClientImpl_IPADAddLabel 方法

添加标签

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override bool AddLabel(
    string TagName
)

参数

TagName
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.AddLabel(System.String)" 的 <param name="TagName"/> 文档]

返回值

类型：Boolean
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.AgreeAddMe 方法

WXClientImpl_IPADAgreeAddMe 方法

同意添加我为好友

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string AgreeAddMe(
    string token
)

参数

token
类型：SystemString
收到的Token完整数据

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.AsyncSyncMessage 方法

WXClientImpl_IPADAsyncSyncMessage 方法

强制拉取消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool AsyncSyncMessage()

返回值

类型：Boolean
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.ChangeStatus 方法

WXClientImpl_IPADChangeStatus 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.ChangeStatus(Chat.Framework.WXSdk.WxStatus,Chat.Framework.WXSdk.Events.WXChangeStatus,System.Boolean)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ChangeStatus(
    WxStatus status,
    WXChangeStatus e = null,
    bool is_next = true
)

参数

status
类型：Chat.Framework.WXSdkWxStatus

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.ChangeStatus(Chat.Framework.WXSdk.WxStatus,Chat.Framework.WXSdk.Events.WXChangeStatus,System.Boolean)" 的 <param name="status"/> 文档]

e (Optional)
类型：Chat.Framework.WXSdk.EventsWXChangeStatus

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.ChangeStatus(Chat.Framework.WXSdk.WxStatus,Chat.Framework.WXSdk.Events.WXChangeStatus,System.Boolean)" 的 <param name="e"/> 文档]

is_next (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.ChangeStatus(Chat.Framework.WXSdk.WxStatus,Chat.Framework.WXSdk.Events.WXChangeStatus,System.Boolean)" 的 <param name="is_next"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.CloseGRPC 方法

WXClientImpl_IPADCloseGRPC 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.CloseGRPC(System.Boolean)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void CloseGRPC(
    bool timeout
)

参数

timeout
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.CloseGRPC(System.Boolean)" 的 <param name="timeout"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.CreateChatRoom 方法

WXClientImpl_IPADCreateChatRoom 方法

重载列表
 | 名称 | 说明
公共方法 | CreateChatRoom(String) | (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | CreateChatRoom(String) | (重写 WeixinBaseCreateChatRoom(String).)
Top
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.CreateChatRoom 方法 (String)

WXClientImpl_IPADCreateChatRoom 方法 (String)

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.CreateChatRoom(System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string CreateChatRoom(
    string members
)

参数

members
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.CreateChatRoom(System.String)" 的 <param name="members"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
CreateChatRoom 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.CreateChatRoom 方法 (String[])

WXClientImpl_IPADCreateChatRoom 方法 (String)

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.CreateChatRoom(System.String[])" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string CreateChatRoom(
    string[] wxids
)

参数

wxids
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.CreateChatRoom(System.String[])" 的 <param name="wxids"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
CreateChatRoom 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.DelayMess 方法

WXClientImpl_IPADDelayMess 方法

消息延迟

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DelayMess(
    string message
)

参数

message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.DelayMess(System.String)" 的 <param name="message"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.DeleteFriend 方法

WXClientImpl_IPADDeleteFriend 方法

删除好友(可以用户清理僵尸粉用)

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string DeleteFriend(
    string username
)

参数

username
类型：SystemString
微信id

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.DeleteGroupMember 方法

WXClientImpl_IPADDeleteGroupMember 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.DeleteGroupMember(System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string DeleteGroupMember(
    string username,
    string groupId
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.DeleteGroupMember(System.String,System.String)" 的 <param name="username"/> 文档]

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.DeleteGroupMember(System.String,System.String)" 的 <param name="groupId"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.Dispose 方法

WXClientImpl_IPADDispose 方法

释放被 WXClientImpl_IPAD 使用的所有资源

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.DownlowdImage 方法

WXClientImpl_IPADDownlowdImage 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.DownlowdImage(System.Int32,System.String,System.Int32)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string DownlowdImage(
    int msgid,
    string fromUsername,
    int datatotalength
)

参数

msgid
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.DownlowdImage(System.Int32,System.String,System.Int32)" 的 <param name="msgid"/> 文档]

fromUsername
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.DownlowdImage(System.Int32,System.String,System.Int32)" 的 <param name="fromUsername"/> 文档]

datatotalength
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.DownlowdImage(System.Int32,System.String,System.Int32)" 的 <param name="datatotalength"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.EditContacts 方法

WXClientImpl_IPADEditContacts 方法

编辑用户信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void EditContacts(
    string username,
    EditContactsType type,
    string remark = ""
)

参数

username
类型：SystemString
操作用户
type
类型：Chat.Framework.WXSdk.ImplementEditContactsType
操作类型
remark (Optional)
类型：SystemString
如果Type=备注,为空表示取消备注,不为空表示备注所填写内容
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.EditUserLabel 方法

WXClientImpl_IPADEditUserLabel 方法

修改标签

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override bool EditUserLabel(
    string[] Users,
    List<Lable> Lable
)

参数

Users
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.EditUserLabel(System.String[],System.Collections.Generic.List{Chat.Framework.WXSdk.Implement.Lable})" 的 <param name="Users"/> 文档]

Lable
类型：System.Collections.GenericList Lable

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.EditUserLabel(System.String[],System.Collections.Generic.List{Chat.Framework.WXSdk.Implement.Lable})" 的 <param name="Lable"/> 文档]

返回值

类型：Boolean
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.FastLogin 方法

WXClientImpl_IPADFastLogin 方法

执行二次登录

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string FastLogin()

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.FindBankCar 方法

WXClientImpl_IPADFindBankCar 方法

获得银行卡

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<BankCar> FindBankCar()

返回值

类型：List BankCar
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.FindCircle 方法

WXClientImpl_IPADFindCircle 方法

获取朋友圈

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override List<Dictionary<string, Object>> FindCircle(
    string username,
    string firstPageMd5 = "",
    int MaxId = 0
)

参数

username
类型：SystemString
微信ID
firstPageMd5 (Optional)
类型：SystemString
页码
MaxId (Optional)
类型：SystemInt32
页码ID

返回值

类型：List Dictionary String, Object
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.FindCircles 方法

WXClientImpl_IPADFindCircles 方法

获取朋友圈内容

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override List<Dictionary<string, Object>> FindCircles()

返回值

类型：List Dictionary String, Object
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.FindLoginImage 方法

WXClientImpl_IPADFindLoginImage 方法

获得登录图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void FindLoginImage(
    LoginDeviceType type
)

参数

type
类型：Chat.Framework.WXSdk.ImplementLoginDeviceType

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.FindLoginImage(Chat.Framework.WXSdk.Implement.LoginDeviceType)" 的 <param name="type"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.FindLoginStatus 方法

WXClientImpl_IPADFindLoginStatus 方法

登录状态检测

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void FindLoginStatus()
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.FindRandomExpression 方法

WXClientImpl_IPADFindRandomExpression 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.FindRandomExpression" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string FindRandomExpression()

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.FocusWechat 方法

WXClientImpl_IPADFocusWechat 方法

关注公众号

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override bool FocusWechat(
    string username
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.FocusWechat(System.String)" 的 <param name="username"/> 文档]

返回值

类型：Boolean
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.GetBalance 方法

WXClientImpl_IPADGetBalance 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetBalance" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Dictionary<string, Object> GetBalance()

返回值

类型：Dictionary String, Object
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.GetContact 方法

WXClientImpl_IPADGetContact 方法

获得好友或群组信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Friend GetContact(
    string wxid,
    bool refresh = false
)

参数

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetContact(System.String,System.Boolean)" 的 <param name="wxid"/> 文档]

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetContact(System.String,System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：Friend
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.GetLabelList 方法

WXClientImpl_IPADGetLabelList 方法

获取标签

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override List<Lable> GetLabelList(
    bool refresh = false
)

参数

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetLabelList(System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：List Lable
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.GetMember 方法

WXClientImpl_IPADGetMember 方法

重载列表
 | 名称 | 说明
公共方法 | GetMember(String, String) | (重写 WeixinBaseGetMember(String, String).)
公共方法 | GetMember(String, String, Boolean) | 获取群用户信息带刷新 (继承自 WeixinBase。)
Top
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.GetMember 方法 (String, String)

WXClientImpl_IPADGetMember 方法 (String, String)

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetMember(System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override GroupMember GetMember(
    string groupid,
    string wxid
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetMember(System.String,System.String)" 的 <param name="groupid"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetMember(System.String,System.String)" 的 <param name="wxid"/> 文档]

返回值

类型：GroupMember
参见

引用

WXClientImpl_IPAD 类
GetMember 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.GetMembers 方法

WXClientImpl_IPADGetMembers 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetMembers(System.String,System.Boolean)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override GroupMember[] GetMembers(
    string groupid,
    bool flag = false
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetMembers(System.String,System.Boolean)" 的 <param name="groupid"/> 文档]

flag (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetMembers(System.String,System.Boolean)" 的 <param name="flag"/> 文档]

返回值

类型：GroupMember
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.GetRobotQRcode 方法

WXClientImpl_IPADGetRobotQRcode 方法

获取联系人二维码

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Bitmap GetRobotQRcode(
    bool Refresh = false
)

参数

Refresh (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.GetRobotQRcode(System.Boolean)" 的 <param name="Refresh"/> 文档]

返回值

类型：Bitmap
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.Initialization 方法

WXClientImpl_IPADInitialization 方法

快速初始化通讯录列表

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Initialization()

返回值

类型：Boolean
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.InviteIntoGroup 方法

WXClientImpl_IPADInviteIntoGroup 方法

邀请入群

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string InviteIntoGroup(
    string username,
    string groupId
)

参数

username
类型：SystemString
用户wxid
groupId
类型：SystemString
群id

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.LoginOut 方法

WXClientImpl_IPADLoginOut 方法

重载列表
 | 名称 | 说明
公共方法 | LoginOut | 退出登录 (重写 WeixinBaseLoginOut.)
公共方法 | LoginOut(String) | 退出微信 (继承自 WeixinBase。)
Top
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.LoginOut 方法

WXClientImpl_IPADLoginOut 方法

退出登录

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void LoginOut()
参见

引用

WXClientImpl_IPAD 类
LoginOut 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.ReadURL 方法

WXClientImpl_IPADReadURL 方法

阅读文章

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void ReadURL(
    string requrl
)

参数

requrl
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.ReadURL(System.String)" 的 <param name="requrl"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.RefreshContact 方法

WXClientImpl_IPADRefreshContact 方法

刷新通讯录信息(获取好友列表)

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void RefreshContact(
    Action<WXClientImpl_IPAD> method = null
)

参数

method (Optional)
类型：SystemAction WXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.RefreshContact(System.Action{Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD})" 的 <param name="method"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.ResetConnection 方法

WXClientImpl_IPADResetConnection 方法

重新连接

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ResetConnection(
    int next = 3
)

参数

next (Optional)
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.ResetConnection(System.Int32)" 的 <param name="next"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendCard 方法

WXClientImpl_IPADSendCard 方法

发送卡片消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendCard(
    string username,
    string friendwxid
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCard(System.String,System.String)" 的 <param name="username"/> 文档]

friendwxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCard(System.String,System.String)" 的 <param name="friendwxid"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendCDNImage 方法

WXClientImpl_IPADSendCDNImage 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNImage(System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendCDNImage(
    string tousername,
    string data
)

参数

tousername
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNImage(System.String,System.String)" 的 <param name="tousername"/> 文档]

data
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNImage(System.String,System.String)" 的 <param name="data"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendCDNInfo 方法

WXClientImpl_IPADSendCDNInfo 方法

注意：此 API 现在已过时。

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNInfo(System.String,System.String,System.String,Chat.Framework.WXSdk.IPAD.CDNType)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
[ObsoleteAttribute("该方法过时,发视频使用:SendCDNVideo,发图片使用:SendCDNImage")]
public override void SendCDNInfo(
    string tousername,
    string cdnurl,
    string aeskey,
    CDNType type
)

参数

tousername
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNInfo(System.String,System.String,System.String,Chat.Framework.WXSdk.IPAD.CDNType)" 的 <param name="tousername"/> 文档]

cdnurl
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNInfo(System.String,System.String,System.String,Chat.Framework.WXSdk.IPAD.CDNType)" 的 <param name="cdnurl"/> 文档]

aeskey
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNInfo(System.String,System.String,System.String,Chat.Framework.WXSdk.IPAD.CDNType)" 的 <param name="aeskey"/> 文档]

type
类型：Chat.Framework.WXSdk.IPADCDNType

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNInfo(System.String,System.String,System.String,Chat.Framework.WXSdk.IPAD.CDNType)" 的 <param name="type"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendCDNVideo 方法

WXClientImpl_IPADSendCDNVideo 方法

发送CDN视频

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendCDNVideo(
    string tousername,
    string cdnurl,
    string aeskey
)

参数

tousername
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNVideo(System.String,System.String,System.String)" 的 <param name="tousername"/> 文档]

cdnurl
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNVideo(System.String,System.String,System.String)" 的 <param name="cdnurl"/> 文档]

aeskey
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCDNVideo(System.String,System.String,System.String)" 的 <param name="aeskey"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendCircle 方法

WXClientImpl_IPADSendCircle 方法

发送朋友圈

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string SendCircle(
    string msg
)

参数

msg
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCircle(System.String)" 的 <param name="msg"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendCircleComment 方法

WXClientImpl_IPADSendCircleComment 方法

发表评论

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendCircleComment(
    string username,
    string circleId,
    string content
)

参数

username
类型：SystemString
发送的微信ID
circleId
类型：SystemString
朋友圈的ID
content
类型：SystemString
发送的内容

返回值

类型：
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendCirclePraise 方法

WXClientImpl_IPADSendCirclePraise 方法

点赞

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendCirclePraise(
    string username,
    string circleId
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCirclePraise(System.String,System.String)" 的 <param name="username"/> 文档]

circleId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendCirclePraise(System.String,System.String)" 的 <param name="circleId"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendImage 方法

WXClientImpl_IPADSendImage 方法

重载列表
 | 名称 | 说明
公共方法 | SendImage(Byte, String) | 发送图片 (重写 WeixinBaseSendImage(Byte, String).)
公共方法 | SendImage(String, String) | 发送图片 (重写 WeixinBaseSendImage(String, String).)
Top
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendImage 方法 (Byte[], String)

WXClientImpl_IPADSendImage 方法 (Byte, String)

发送图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendImage(
    byte[] img,
    string username
)

参数

img
类型：SystemByte
图片字节
username
类型：SystemString
要发送给谁
参见

引用

WXClientImpl_IPAD 类
SendImage 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendImage 方法 (String, String)

WXClientImpl_IPADSendImage 方法 (String, String)

发送图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendImage(
    string username,
    string address
)

参数

username
类型：SystemString
要发送给谁
address
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendImage(System.String,System.String)" 的 <param name="address"/> 文档]

参见

引用

WXClientImpl_IPAD 类
SendImage 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendMessage 方法

WXClientImpl_IPADSendMessage 方法

发送文本消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Task<bool> SendMessage(
    string _username,
    string _content,
    string _atUsername = ""
)

参数

_username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendMessage(System.String,System.String,System.String)" 的 <param name="_username"/> 文档]

_content
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendMessage(System.String,System.String,System.String)" 的 <param name="_content"/> 文档]

_atUsername (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendMessage(System.String,System.String,System.String)" 的 <param name="_atUsername"/> 文档]

返回值

类型：Task Boolean
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendPay 方法

WXClientImpl_IPADSendPay 方法

实现发红包

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string SendPay(
    string toUsername,
    string content,
    int TotalAmount,
    string password,
    int count,
    PayType type,
    BankCar bank = null,
    Dictionary<string, Object> param = null
)

参数

toUsername
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendPay(System.String,System.String,System.Int32,System.String,System.Int32,Chat.Framework.WXSdk.IPAD.PayType,Chat.Framework.WXSdk.BankCar,System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="toUsername"/> 文档]

content
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendPay(System.String,System.String,System.Int32,System.String,System.Int32,Chat.Framework.WXSdk.IPAD.PayType,Chat.Framework.WXSdk.BankCar,System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="content"/> 文档]

TotalAmount
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendPay(System.String,System.String,System.Int32,System.String,System.Int32,Chat.Framework.WXSdk.IPAD.PayType,Chat.Framework.WXSdk.BankCar,System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="TotalAmount"/> 文档]

password
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendPay(System.String,System.String,System.Int32,System.String,System.Int32,Chat.Framework.WXSdk.IPAD.PayType,Chat.Framework.WXSdk.BankCar,System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="password"/> 文档]

count
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendPay(System.String,System.String,System.Int32,System.String,System.Int32,Chat.Framework.WXSdk.IPAD.PayType,Chat.Framework.WXSdk.BankCar,System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="count"/> 文档]

type
类型：Chat.Framework.WXSdk.IPADPayType

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendPay(System.String,System.String,System.Int32,System.String,System.Int32,Chat.Framework.WXSdk.IPAD.PayType,Chat.Framework.WXSdk.BankCar,System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="type"/> 文档]

bank (Optional)
类型：Chat.Framework.WXSdkBankCar

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendPay(System.String,System.String,System.Int32,System.String,System.Int32,Chat.Framework.WXSdk.IPAD.PayType,Chat.Framework.WXSdk.BankCar,System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="bank"/> 文档]

param (Optional)
类型：System.Collections.GenericDictionary String, Object

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendPay(System.String,System.String,System.Int32,System.String,System.Int32,Chat.Framework.WXSdk.IPAD.PayType,Chat.Framework.WXSdk.BankCar,System.Collections.Generic.Dictionary{System.String,System.Object})" 的 <param name="param"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SendVoice 方法

WXClientImpl_IPADSendVoice 方法

发送语音文件

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendVoice(
    string username,
    string url
)

参数

username
类型：SystemString
名称
url
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SendVoice(System.String,System.String)" 的 <param name="url"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SerchKeyword 方法

WXClientImpl_IPADSerchKeyword 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SerchKeyword(System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Dictionary<string, Object> SerchKeyword(
    string keyword
)

参数

keyword
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SerchKeyword(System.String)" 的 <param name="keyword"/> 文档]

返回值

类型：Dictionary String, Object
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SetRoomNotice 方法

WXClientImpl_IPADSetRoomNotice 方法

设置公告

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SetRoomNotice(
    string notice,
    string groupId
)

参数

notice
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SetRoomNotice(System.String,System.String)" 的 <param name="notice"/> 文档]

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SetRoomNotice(System.String,System.String)" 的 <param name="groupId"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.ShowLogin 方法

WXClientImpl_IPADShowLogin 方法

显示登录窗口

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ShowLogin()
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.SnsVerify 方法

WXClientImpl_IPADSnsVerify 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SnsVerify(System.String,System.Boolean,System.String,Chat.Framework.WXSdk.BankCar,System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SnsVerify(
    string code,
    bool isHongbao,
    string reqKey,
    BankCar bank,
    string token,
    string pass
)

参数

code
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SnsVerify(System.String,System.Boolean,System.String,Chat.Framework.WXSdk.BankCar,System.String,System.String)" 的 <param name="code"/> 文档]

isHongbao
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SnsVerify(System.String,System.Boolean,System.String,Chat.Framework.WXSdk.BankCar,System.String,System.String)" 的 <param name="isHongbao"/> 文档]

reqKey
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SnsVerify(System.String,System.Boolean,System.String,Chat.Framework.WXSdk.BankCar,System.String,System.String)" 的 <param name="reqKey"/> 文档]

bank
类型：Chat.Framework.WXSdkBankCar

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SnsVerify(System.String,System.Boolean,System.String,Chat.Framework.WXSdk.BankCar,System.String,System.String)" 的 <param name="bank"/> 文档]

token
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SnsVerify(System.String,System.Boolean,System.String,Chat.Framework.WXSdk.BankCar,System.String,System.String)" 的 <param name="token"/> 文档]

pass
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.SnsVerify(System.String,System.Boolean,System.String,Chat.Framework.WXSdk.BankCar,System.String,System.String)" 的 <param name="pass"/> 文档]

参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.TenPayTransferConfirm 方法

WXClientImpl_IPADTenPayTransferConfirm 方法

自动确认收款接口

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override int TenPayTransferConfirm(
    string Invalidtime,
    string Transferid,
    string FromUsername
)

参数

Invalidtime
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <param name="Invalidtime"/> 文档]

Transferid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <param name="Transferid"/> 文档]

FromUsername
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <param name="FromUsername"/> 文档]

返回值

类型：Int32
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_IPAD.ToString 方法

WXClientImpl_IPADToString 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD.ToString" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WXClientImpl_IPAD 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK 类

企业PC机器人
继承层次
SystemObject
Chat.Framework.WXSdk.ImplementWeixinBase
Chat.Framework.WXSdk.ImplementWXClientImpl_QYHOOK

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WXClientImpl_QYHOOK : WeixinBase

WXClientImpl_QYHOOK 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WXClientImpl_QYHOOK | 企业机器人
Top
属性
 | 名称 | 说明
公共属性 | Friends | 好友列表
公共属性 | GroupMembers |
公共属性 | HeartBreakTime | 上次心跳时间
公共属性 | Status | 微信状态 (继承自 WeixinBase。)
公共属性 | User | 用户 (继承自 WeixinBase。)
公共属性 | WeixinHao | 微信号 (继承自 WeixinBase。)
公共属性 | WeixinType | 微信类型 (继承自 WeixinBase。)
Top
方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | 邀请入群发送名片 和 AddChatRoomMember_40Down 功能一样 (重写 WeixinBaseAddChatRoomMember(String, String).)
公共方法 | AddChatRoomMember_40Down | 邀请入群发送名片 和 AddChatRoomMember 功能一样 (重写 WeixinBaseAddChatRoomMember_40Down(String, String).)
公共方法 | AddLabel | 添加标签 (继承自 WeixinBase。)
公共方法 | AddPublicUser | 关注公众号 (继承自 WeixinBase。)
公共方法 | AgreeAddMe | 同意添加我为好友 (重写 WeixinBaseAgreeAddMe(String).)
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序 (继承自 WeixinBase。)
公共方法 | ChangeStatus | (重写 WeixinBaseChangeStatus(WxStatus, WXChangeStatus, Boolean).)
公共方法 | CheckUrl | 检测URL在微信中是否有效 (继承自 WeixinBase。)
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录 (继承自 WeixinBase。)
公共方法 | CreateChatRoom(String) | 创建群聊 (继承自 WeixinBase。)
公共方法 | CreateChatRoom(String) | 创建群 (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | DelayMess | 消息延迟
公共方法 | DeleteFriend | 删除好友 (重写 WeixinBaseDeleteFriend(String).)
公共方法 | DeleteGroupMember | 删除群用户 (重写 WeixinBaseDeleteGroupMember(String, String).)
公共方法 | Dispose | 释放被 WXClientImpl_QYHOOK 使用的所有资源
公共方法 | DownlowdImage | 下载图片 (继承自 WeixinBase。)
公共方法 | EditContacts | 修改用户信息 (重写 WeixinBaseEditContacts(String, EditContactsType, String).)
公共方法 | EditUserLabel | 批量修改标签 (继承自 WeixinBase。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindCircle | 获取朋友圈 (继承自 WeixinBase。)
公共方法 | FindCircles | 获取朋友圈 (继承自 WeixinBase。)
公共方法 | FindFriendsT | 获得好友列表 (继承自 WeixinBase。)
公共方法 | FocusWechat | 关注公众号 (继承自 WeixinBase。)
公共方法 | GetBalance | (继承自 WeixinBase。)
公共方法 | GetContact | 获得好友或群组信息 (重写 WeixinBaseGetContact(String, Boolean).)
公共方法 | GetGroupsNotInMember | 获取群列表(不包含群成员) (继承自 WeixinBase。)
公共方法 | GetGroupWxidInfo(String, String) | 获取指定的用户或群的信息
公共方法 | GetGroupWxidInfo(String, String, Boolean) | 获取指定的用户或群的信息
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签组 (继承自 WeixinBase。)
公共方法 | GetMember(String, String) | 获取群成员信息 (重写 WeixinBaseGetMember(String, String).)
公共方法 | GetMember(String, String, Boolean) | 获取群成员信息 (重写 WeixinBaseGetMember(String, String, Boolean).)
公共方法 | GetMembers | 获取群成员,不支持pc (继承自 WeixinBase。)
公共方法 | GetRobotQRcode | 获得机器人二维码 (继承自 WeixinBase。)
公共方法 | GetType | (继承自 Object。)
公共方法 | GetWxidInfo | 获取指定的用户
公共方法 | InviteIntoGroup | 邀请入群发送名片 和 AddChatRoomMember 功能一样 (重写 WeixinBaseInviteIntoGroup(String, String).)
公共方法 | LoginOut | 退出登录 (重写 WeixinBaseLoginOut.)
公共方法 | LoginOut(String) | 退出消息 (重写 WeixinBaseLoginOut(String).)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称 (继承自 WeixinBase。)
公共方法 | ModRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | OpenUrl | 打开内置浏览器 (继承自 WeixinBase。)
公共方法 | Receive | 分析hook服务器过来的事件 (重写 WeixinBaseReceive(Object).)
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表) (继承自 WeixinBase。)
公共方法 | RequestContact | 请求获取联系人
公共方法 | ResetConnection | 重新连接微信 (继承自 WeixinBase。)
公共方法 | SendCard | 发送卡片 (重写 WeixinBaseSendCard(String, String).)
公共方法 | SendCDNImage | 发送CDN图片 (继承自 WeixinBase。)
公共方法 | SendCDNInfo | 秒发CDN消息 (继承自 WeixinBase。)
公共方法 | SendCDNVideo | 发送CDN视频 (继承自 WeixinBase。)
公共方法 | SendCircle | 发表朋友圈 (继承自 WeixinBase。)
公共方法 | SendCircleComment | 发表评论 (继承自 WeixinBase。)
公共方法 | SendCirclePraise | 点赞 (继承自 WeixinBase。)
公共方法 | SendImage(Byte, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendImage(String, String) | 发送图片 (重写 WeixinBaseSendImage(String, String).)
公共方法 | SendMessage | 发送消息 (重写 WeixinBaseSendMessage(String, String, String).)
公共方法 | SendPay | 发送红包 (继承自 WeixinBase。)
公共方法 | SendProgramMessage | (重写 WeixinBaseSendProgramMessage(String, String, String, String, String, String, String, String, String, String, String).)
公共方法 | SendVoice | 发送语音 (继承自 WeixinBase。)
公共方法 | SerchKeyword | 搜索关键词 (继承自 WeixinBase。)
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能 (继承自 WeixinBase。)
公共方法 | SetRecvNotify | 是否消息免打扰 (继承自 WeixinBase。)
公共方法 | SetRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | SetRoomNotice | 修改群公告(可用于@全体) (继承自 WeixinBase。)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称 (继承自 WeixinBase。)
公共方法 | SetSessionReadedMsg | 设置会话已读 (继承自 WeixinBase。)
公共方法 | ShowLogin | (重写 WeixinBaseShowLogin.)
公共方法 | SnsVerify | 验证支付 (继承自 WeixinBase。)
公共方法 | TenPayTransferConfirm | 领取转账 (重写 WeixinBaseTenPayTransferConfirm(String, String, String).)
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteLog | 写出日志 (继承自 WeixinBase。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK 构造函数

企业机器人

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WXClientImpl_QYHOOK(
    string weixinhao,
    string usernick,
    long uin = -1
)

参数

weixinhao
类型：SystemString
企业账号
usernick
类型：SystemString
企业昵称
uin (Optional)
类型：SystemInt64
企业账号
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK 属性

WXClientImpl_QYHOOK 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Friends | 好友列表
公共属性 | GroupMembers |
公共属性 | HeartBreakTime | 上次心跳时间
公共属性 | Status | 微信状态 (继承自 WeixinBase。)
公共属性 | User | 用户 (继承自 WeixinBase。)
公共属性 | WeixinHao | 微信号 (继承自 WeixinBase。)
公共属性 | WeixinType | 微信类型 (继承自 WeixinBase。)
Top
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.Friends 属性

WXClientImpl_QYHOOKFriends 属性

好友列表

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, Friend> Friends { get; }

属性值

类型：Dictionary String, Friend
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.GroupMembers 属性

WXClientImpl_QYHOOKGroupMembers 属性

[缺少 "P:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GroupMembers" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Dictionary<string, GroupMember[]> GroupMembers { get; }

属性值

类型：Dictionary String, GroupMember
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.HeartBreakTime 属性

WXClientImpl_QYHOOKHeartBreakTime 属性

上次心跳时间

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DateTime HeartBreakTime { get; }

属性值

类型：DateTime
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK 方法

WXClientImpl_QYHOOK 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddChatRoomMember | 邀请入群发送名片 和 AddChatRoomMember_40Down 功能一样 (重写 WeixinBaseAddChatRoomMember(String, String).)
公共方法 | AddChatRoomMember_40Down | 邀请入群发送名片 和 AddChatRoomMember 功能一样 (重写 WeixinBaseAddChatRoomMember_40Down(String, String).)
公共方法 | AddLabel | 添加标签 (继承自 WeixinBase。)
公共方法 | AddPublicUser | 关注公众号 (继承自 WeixinBase。)
公共方法 | AgreeAddMe | 同意添加我为好友 (重写 WeixinBaseAgreeAddMe(String).)
公共方法 | AutoAuthMiniAPPLogin | 自动授权登录小程序 (继承自 WeixinBase。)
公共方法 | ChangeStatus | (重写 WeixinBaseChangeStatus(WxStatus, WXChangeStatus, Boolean).)
公共方法 | CheckUrl | 检测URL在微信中是否有效 (继承自 WeixinBase。)
公共方法 | ClearChatHistoryMsg | 清理历史聊天记录 (继承自 WeixinBase。)
公共方法 | CreateChatRoom(String) | 创建群聊 (继承自 WeixinBase。)
公共方法 | CreateChatRoom(String) | 创建群 (重写 WeixinBaseCreateChatRoom(String).)
公共方法 | DelayMess | 消息延迟
公共方法 | DeleteFriend | 删除好友 (重写 WeixinBaseDeleteFriend(String).)
公共方法 | DeleteGroupMember | 删除群用户 (重写 WeixinBaseDeleteGroupMember(String, String).)
公共方法 | Dispose |
公共方法 | DownlowdImage | 下载图片 (继承自 WeixinBase。)
公共方法 | EditContacts | 修改用户信息 (重写 WeixinBaseEditContacts(String, EditContactsType, String).)
公共方法 | EditUserLabel | 批量修改标签 (继承自 WeixinBase。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | FindCircle | 获取朋友圈 (继承自 WeixinBase。)
公共方法 | FindCircles | 获取朋友圈 (继承自 WeixinBase。)
公共方法 | FindFriendsT | 获得好友列表 (继承自 WeixinBase。)
公共方法 | FocusWechat | 关注公众号 (继承自 WeixinBase。)
公共方法 | GetBalance | (继承自 WeixinBase。)
公共方法 | GetContact | 获得好友或群组信息 (重写 WeixinBaseGetContact(String, Boolean).)
公共方法 | GetGroupsNotInMember | 获取群列表(不包含群成员) (继承自 WeixinBase。)
公共方法 | GetGroupWxidInfo(String, String) | 获取指定的用户或群的信息
公共方法 | GetGroupWxidInfo(String, String, Boolean) | 获取指定的用户或群的信息
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLabelList | 获取标签组 (继承自 WeixinBase。)
公共方法 | GetMember(String, String) | 获取群成员信息 (重写 WeixinBaseGetMember(String, String).)
公共方法 | GetMember(String, String, Boolean) | 获取群成员信息 (重写 WeixinBaseGetMember(String, String, Boolean).)
公共方法 | GetMembers | 获取群成员,不支持pc (继承自 WeixinBase。)
公共方法 | GetRobotQRcode | 获得机器人二维码 (继承自 WeixinBase。)
公共方法 | GetType | (继承自 Object。)
公共方法 | GetWxidInfo | 获取指定的用户
公共方法 | InviteIntoGroup | 邀请入群发送名片 和 AddChatRoomMember 功能一样 (重写 WeixinBaseInviteIntoGroup(String, String).)
公共方法 | LoginOut | 退出登录 (重写 WeixinBaseLoginOut.)
公共方法 | LoginOut(String) | 退出消息 (重写 WeixinBaseLoginOut(String).)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ModRoomMyName | 设置自己在群中昵称 (继承自 WeixinBase。)
公共方法 | ModRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | OpenUrl | 打开内置浏览器 (继承自 WeixinBase。)
公共方法 | Receive | 分析hook服务器过来的事件 (重写 WeixinBaseReceive(Object).)
公共方法 | RefreshContact | 刷新通讯录信息(获取好友列表) (继承自 WeixinBase。)
公共方法 | RequestContact | 请求获取联系人
公共方法 | ResetConnection | 重新连接微信 (继承自 WeixinBase。)
公共方法 | SendCard | 发送卡片 (重写 WeixinBaseSendCard(String, String).)
公共方法 | SendCDNImage | 发送CDN图片 (继承自 WeixinBase。)
公共方法 | SendCDNInfo | 秒发CDN消息 (继承自 WeixinBase。)
公共方法 | SendCDNVideo | 发送CDN视频 (继承自 WeixinBase。)
公共方法 | SendCircle | 发表朋友圈 (继承自 WeixinBase。)
公共方法 | SendCircleComment | 发表评论 (继承自 WeixinBase。)
公共方法 | SendCirclePraise | 点赞 (继承自 WeixinBase。)
公共方法 | SendImage(Byte, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendImage(String, String) | 发送图片 (重写 WeixinBaseSendImage(String, String).)
公共方法 | SendMessage | 发送消息 (重写 WeixinBaseSendMessage(String, String, String).)
公共方法 | SendPay | 发送红包 (继承自 WeixinBase。)
公共方法 | SendProgramMessage | (重写 WeixinBaseSendProgramMessage(String, String, String, String, String, String, String, String, String, String, String).)
公共方法 | SendVoice | 发送语音 (继承自 WeixinBase。)
公共方法 | SerchKeyword | 搜索关键词 (继承自 WeixinBase。)
公共方法 | SetDisableRevoke | 开启/关闭防撤回功能 (继承自 WeixinBase。)
公共方法 | SetRecvNotify | 是否消息免打扰 (继承自 WeixinBase。)
公共方法 | SetRoomName | 修改群聊名称 (继承自 WeixinBase。)
公共方法 | SetRoomNotice | 修改群公告(可用于@全体) (继承自 WeixinBase。)
公共方法 | SetRoomShowMemeberName | 设置是否显示群成员昵称 (继承自 WeixinBase。)
公共方法 | SetSessionReadedMsg | 设置会话已读 (继承自 WeixinBase。)
公共方法 | ShowLogin | (重写 WeixinBaseShowLogin.)
公共方法 | SnsVerify | 验证支付 (继承自 WeixinBase。)
公共方法 | TenPayTransferConfirm | 领取转账 (重写 WeixinBaseTenPayTransferConfirm(String, String, String).)
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteLog | 写出日志 (继承自 WeixinBase。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.AddChatRoomMember 方法

WXClientImpl_QYHOOKAddChatRoomMember 方法

邀请入群发送名片 和 AddChatRoomMember_40Down 功能一样

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void AddChatRoomMember(
    string groupid,
    string members
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.AddChatRoomMember(System.String,System.String)" 的 <param name="groupid"/> 文档]

members
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.AddChatRoomMember(System.String,System.String)" 的 <param name="members"/> 文档]

参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.AddChatRoomMember_40Down 方法

WXClientImpl_QYHOOKAddChatRoomMember_40Down 方法

邀请入群发送名片 和 AddChatRoomMember 功能一样

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void AddChatRoomMember_40Down(
    string groupid,
    string members
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.AddChatRoomMember_40Down(System.String,System.String)" 的 <param name="groupid"/> 文档]

members
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.AddChatRoomMember_40Down(System.String,System.String)" 的 <param name="members"/> 文档]

参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.AgreeAddMe 方法

WXClientImpl_QYHOOKAgreeAddMe 方法

同意添加我为好友

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string AgreeAddMe(
    string token
)

参数

token
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.AgreeAddMe(System.String)" 的 <param name="token"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.ChangeStatus 方法

WXClientImpl_QYHOOKChangeStatus 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.ChangeStatus(Chat.Framework.WXSdk.WxStatus,Chat.Framework.WXSdk.Events.WXChangeStatus,System.Boolean)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ChangeStatus(
    WxStatus status,
    WXChangeStatus e = null,
    bool is_next = true
)

参数

status
类型：Chat.Framework.WXSdkWxStatus

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.ChangeStatus(Chat.Framework.WXSdk.WxStatus,Chat.Framework.WXSdk.Events.WXChangeStatus,System.Boolean)" 的 <param name="status"/> 文档]

e (Optional)
类型：Chat.Framework.WXSdk.EventsWXChangeStatus

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.ChangeStatus(Chat.Framework.WXSdk.WxStatus,Chat.Framework.WXSdk.Events.WXChangeStatus,System.Boolean)" 的 <param name="e"/> 文档]

is_next (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.ChangeStatus(Chat.Framework.WXSdk.WxStatus,Chat.Framework.WXSdk.Events.WXChangeStatus,System.Boolean)" 的 <param name="is_next"/> 文档]

参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.CreateChatRoom 方法

WXClientImpl_QYHOOKCreateChatRoom 方法

重载列表
 | 名称 | 说明
公共方法 | CreateChatRoom(String) | 创建群聊 (继承自 WeixinBase。)
公共方法 | CreateChatRoom(String) | 创建群 (重写 WeixinBaseCreateChatRoom(String).)
Top
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.CreateChatRoom 方法 (String[])

WXClientImpl_QYHOOKCreateChatRoom 方法 (String)

创建群

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string CreateChatRoom(
    string[] wxids
)

参数

wxids
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.CreateChatRoom(System.String[])" 的 <param name="wxids"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_QYHOOK 类
CreateChatRoom 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.DelayMess 方法

WXClientImpl_QYHOOKDelayMess 方法

消息延迟

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DelayMess(
    string message
)

参数

message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.DelayMess(System.String)" 的 <param name="message"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.DeleteFriend 方法

WXClientImpl_QYHOOKDeleteFriend 方法

删除好友

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string DeleteFriend(
    string username
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.DeleteFriend(System.String)" 的 <param name="username"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.DeleteGroupMember 方法

WXClientImpl_QYHOOKDeleteGroupMember 方法

删除群用户

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string DeleteGroupMember(
    string username,
    string groupId
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.DeleteGroupMember(System.String,System.String)" 的 <param name="username"/> 文档]

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.DeleteGroupMember(System.String,System.String)" 的 <param name="groupId"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.Dispose 方法

WXClientImpl_QYHOOKDispose 方法

释放被 WXClientImpl_QYHOOK 使用的所有资源

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.EditContacts 方法

WXClientImpl_QYHOOKEditContacts 方法

修改用户信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void EditContacts(
    string username,
    EditContactsType type,
    string remark = ""
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.EditContacts(System.String,Chat.Framework.WXSdk.Implement.EditContactsType,System.String)" 的 <param name="username"/> 文档]

type
类型：Chat.Framework.WXSdk.ImplementEditContactsType

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.EditContacts(System.String,Chat.Framework.WXSdk.Implement.EditContactsType,System.String)" 的 <param name="type"/> 文档]

remark (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.EditContacts(System.String,Chat.Framework.WXSdk.Implement.EditContactsType,System.String)" 的 <param name="remark"/> 文档]

参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.GetContact 方法

WXClientImpl_QYHOOKGetContact 方法

获得好友或群组信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Friend GetContact(
    string wxid,
    bool refresh = false
)

参数

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetContact(System.String,System.Boolean)" 的 <param name="wxid"/> 文档]

refresh (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetContact(System.String,System.Boolean)" 的 <param name="refresh"/> 文档]

返回值

类型：Friend
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.GetGroupWxidInfo 方法

WXClientImpl_QYHOOKGetGroupWxidInfo 方法

重载列表
 | 名称 | 说明
公共方法 | GetGroupWxidInfo(String, String) | 获取指定的用户或群的信息
公共方法 | GetGroupWxidInfo(String, String, Boolean) | 获取指定的用户或群的信息
Top
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.GetGroupWxidInfo 方法 (String, String)

WXClientImpl_QYHOOKGetGroupWxidInfo 方法 (String, String)

获取指定的用户或群的信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetGroupWxidInfo(
    string groupId,
    string wxid
)

参数

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetGroupWxidInfo(System.String,System.String)" 的 <param name="groupId"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetGroupWxidInfo(System.String,System.String)" 的 <param name="wxid"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_QYHOOK 类
GetGroupWxidInfo 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.GetGroupWxidInfo 方法 (String, String, Boolean)

WXClientImpl_QYHOOKGetGroupWxidInfo 方法 (String, String, Boolean)

获取指定的用户或群的信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetGroupWxidInfo(
    string groupId,
    string wxid,
    bool flush
)

参数

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetGroupWxidInfo(System.String,System.String,System.Boolean)" 的 <param name="groupId"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetGroupWxidInfo(System.String,System.String,System.Boolean)" 的 <param name="wxid"/> 文档]

flush
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetGroupWxidInfo(System.String,System.String,System.Boolean)" 的 <param name="flush"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_QYHOOK 类
GetGroupWxidInfo 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.GetMember 方法

WXClientImpl_QYHOOKGetMember 方法

重载列表
 | 名称 | 说明
公共方法 | GetMember(String, String) | 获取群成员信息 (重写 WeixinBaseGetMember(String, String).)
公共方法 | GetMember(String, String, Boolean) | 获取群成员信息 (重写 WeixinBaseGetMember(String, String, Boolean).)
Top
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.GetMember 方法 (String, String)

WXClientImpl_QYHOOKGetMember 方法 (String, String)

获取群成员信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override GroupMember GetMember(
    string groupid,
    string wxid
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetMember(System.String,System.String)" 的 <param name="groupid"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetMember(System.String,System.String)" 的 <param name="wxid"/> 文档]

返回值

类型：GroupMember
参见

引用

WXClientImpl_QYHOOK 类
GetMember 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.GetMember 方法 (String, String, Boolean)

WXClientImpl_QYHOOKGetMember 方法 (String, String, Boolean)

获取群成员信息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override GroupMember GetMember(
    string groupid,
    string wxid,
    bool flush = false
)

参数

groupid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetMember(System.String,System.String,System.Boolean)" 的 <param name="groupid"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetMember(System.String,System.String,System.Boolean)" 的 <param name="wxid"/> 文档]

flush (Optional)
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetMember(System.String,System.String,System.Boolean)" 的 <param name="flush"/> 文档]

返回值

类型：GroupMember
参见

引用

WXClientImpl_QYHOOK 类
GetMember 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.GetWxidInfo 方法

WXClientImpl_QYHOOKGetWxidInfo 方法

获取指定的用户

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetWxidInfo(
    string wxid
)

参数

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.GetWxidInfo(System.String)" 的 <param name="wxid"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.InviteIntoGroup 方法

WXClientImpl_QYHOOKInviteIntoGroup 方法

邀请入群发送名片 和 AddChatRoomMember 功能一样

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string InviteIntoGroup(
    string username,
    string groupId
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.InviteIntoGroup(System.String,System.String)" 的 <param name="username"/> 文档]

groupId
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.InviteIntoGroup(System.String,System.String)" 的 <param name="groupId"/> 文档]

返回值

类型：String
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.LoginOut 方法

WXClientImpl_QYHOOKLoginOut 方法

重载列表
 | 名称 | 说明
公共方法 | LoginOut | 退出登录 (重写 WeixinBaseLoginOut.)
公共方法 | LoginOut(String) | 退出消息 (重写 WeixinBaseLoginOut(String).)
Top
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.LoginOut 方法

WXClientImpl_QYHOOKLoginOut 方法

退出登录

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void LoginOut()
参见

引用

WXClientImpl_QYHOOK 类
LoginOut 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.LoginOut 方法 (String)

WXClientImpl_QYHOOKLoginOut 方法 (String)

退出消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void LoginOut(
    string message
)

参数

message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.LoginOut(System.String)" 的 <param name="message"/> 文档]

参见

引用

WXClientImpl_QYHOOK 类
LoginOut 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.Receive 方法

WXClientImpl_QYHOOKReceive 方法

分析hook服务器过来的事件

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void Receive(
    Object obj
)

参数

obj
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.Receive(System.Object)" 的 <param name="obj"/> 文档]

参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.RequestContact 方法

WXClientImpl_QYHOOKRequestContact 方法

请求获取联系人

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void RequestContact()
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.SendCard 方法

WXClientImpl_QYHOOKSendCard 方法

发送卡片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendCard(
    string username,
    string friendwxid
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendCard(System.String,System.String)" 的 <param name="username"/> 文档]

friendwxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendCard(System.String,System.String)" 的 <param name="friendwxid"/> 文档]

参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.SendImage 方法

WXClientImpl_QYHOOKSendImage 方法

重载列表
 | 名称 | 说明
公共方法 | SendImage(Byte, String) | 发送图片 (继承自 WeixinBase。)
公共方法 | SendImage(String, String) | 发送图片 (重写 WeixinBaseSendImage(String, String).)
Top
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.SendImage 方法 (String, String)

WXClientImpl_QYHOOKSendImage 方法 (String, String)

发送图片

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendImage(
    string username,
    string address
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendImage(System.String,System.String)" 的 <param name="username"/> 文档]

address
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendImage(System.String,System.String)" 的 <param name="address"/> 文档]

参见

引用

WXClientImpl_QYHOOK 类
SendImage 重载
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.SendMessage 方法

WXClientImpl_QYHOOKSendMessage 方法

发送消息

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override Task<bool> SendMessage(
    string _username,
    string _message,
    string _atUsername = ""
)

参数

_username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendMessage(System.String,System.String,System.String)" 的 <param name="_username"/> 文档]

_message
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendMessage(System.String,System.String,System.String)" 的 <param name="_message"/> 文档]

_atUsername (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendMessage(System.String,System.String,System.String)" 的 <param name="_atUsername"/> 文档]

返回值

类型：Task Boolean
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.SendProgramMessage 方法

WXClientImpl_QYHOOKSendProgramMessage 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void SendProgramMessage(
    string username,
    string ghid,
    string wxid,
    string name,
    string title,
    string enterpoint,
    string headimg,
    string image_key1,
    string image_key2,
    string image_key3,
    string image_size
)

参数

username
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="username"/> 文档]

ghid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="ghid"/> 文档]

wxid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="wxid"/> 文档]

name
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="name"/> 文档]

title
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="title"/> 文档]

enterpoint
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="enterpoint"/> 文档]

headimg
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="headimg"/> 文档]

image_key1
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="image_key1"/> 文档]

image_key2
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="image_key2"/> 文档]

image_key3
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="image_key3"/> 文档]

image_size
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.SendProgramMessage(System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.String)" 的 <param name="image_size"/> 文档]

参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.ShowLogin 方法

WXClientImpl_QYHOOKShowLogin 方法

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.ShowLogin" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override void ShowLogin()
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


WXClientImpl_QYHOOK.TenPayTransferConfirm 方法

WXClientImpl_QYHOOKTenPayTransferConfirm 方法

领取转账

命名空间： Chat.Framework.WXSdk.Implement
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override int TenPayTransferConfirm(
    string Invalidtime,
    string Transferid,
    string FromUsername
)

参数

Invalidtime
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <param name="Invalidtime"/> 文档]

Transferid
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <param name="Transferid"/> 文档]

FromUsername
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.Implement.WXClientImpl_QYHOOK.TenPayTransferConfirm(System.String,System.String,System.String)" 的 <param name="FromUsername"/> 文档]

返回值

类型：Int32
参见

引用

WXClientImpl_QYHOOK 类
Chat.Framework.WXSdk.Implement 命名空间


Chat.Framework.WXSdk.IPAD 命名空间

[缺少 "N:Chat.Framework.WXSdk.IPAD" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | SocketClient | Socket管理
公共类 | WechatHost | 协议微信 Host
公共类 | WechatPack | 协议发送包
公共类 | WechatPackPackMsg |
公共类 | WechatSocket | 微信Socket
枚举
 | 枚举 | 说明
公共枚举 | ApplyType | 申请订单状态
公共枚举 | CDNType |
公共枚举 | GrpcType |
公共枚举 | PayType | 红包来源类型
公共枚举 | SocketClientWXSocketClientError |
公共枚举 | WechatCmd | 协议基础操作类型


ApplyType 枚举

申请订单状态

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum ApplyType
成员
成员名称 | 值 | 说明
未审核 | 1 |
已审核 | 2 |
退回兑换 | 3 |
没收兑换 | 4 |
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


CDNType 枚举

[缺少 "T:Chat.Framework.WXSdk.IPAD.CDNType" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum CDNType
成员
成员名称 | 值 | 说明
发送图片 | 1 |
发送视频 | 2 |
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


GrpcType 枚举

[缺少 "T:Chat.Framework.WXSdk.IPAD.GrpcType" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum GrpcType
成员
成员名称 | 值 | 说明
Awei | 0 |
Laoyao | 1 |
Huangfan | 2 |
未知 | -1 |
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


PayType 枚举

红包来源类型

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum PayType
成员
成员名称 | 值 | 说明
红包 | 1 |
转账 | 2 |
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


SocketClient 类

Socket管理
继承层次
SystemObject
Chat.Framework.WXSdk.IPADSocketClient

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public sealed class SocketClient

SocketClient 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SocketClient | 初始化 SocketClient 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | connected |
公共属性 | NotifyCallback |
公共属性 | SocketExceptionCallback |
Top
方法
 | 名称 | 说明
公共方法 | AsynSend | 发送vx socket消息
公共方法 | BeginConnection |
公共方法 | ClearPack |
公共方法 | Connect |
公共方法 | CreateSocket |
公共方法 | DePack |
公共方法 | Disconnect |
公共方法 | Equals | (继承自 Object。)
公共方法 | GetBuffBySeq | 通过seq取微信服务器返回的socket包数据
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | HandlePackage |
公共方法 | SaveBufferToPackDic |
公共方法 | ToString | (继承自 Object。)
Top
字段
 | 名称 | 说明
公共字段 | allDone |
公共字段 | weixin |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


SocketClient 构造函数

初始化 SocketClient 类的一个新实例

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SocketClient(
    DnsEndPoint hostEndPoint,
    WeixinBase weixin
)

参数

hostEndPoint
类型：System.NetDnsEndPoint

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.#ctor(System.Net.DnsEndPoint,Chat.Framework.WXSdk.Implement.WeixinBase)" 的 <param name="hostEndPoint"/> 文档]

weixin
类型：Chat.Framework.WXSdk.ImplementWeixinBase

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.#ctor(System.Net.DnsEndPoint,Chat.Framework.WXSdk.Implement.WeixinBase)" 的 <param name="weixin"/> 文档]

参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient 属性

SocketClient 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | connected |
公共属性 | NotifyCallback |
公共属性 | SocketExceptionCallback |
Top
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.connected 属性

SocketClientconnected 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.SocketClient.connected" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool connected { get; }

属性值

类型：Boolean
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.NotifyCallback 属性

SocketClientNotifyCallback 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.SocketClient.NotifyCallback" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Func<byte[], bool> NotifyCallback { get; set; }

属性值

类型：Func Byte , Boolean
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.SocketExceptionCallback 属性

SocketClientSocketExceptionCallback 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.SocketClient.SocketExceptionCallback" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Func<SocketClientWXSocketClientError, SocketClient, bool> SocketExceptionCallback { get; set; }

属性值

类型：Func SocketClientWXSocketClientError, SocketClient, Boolean
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient 方法

SocketClient 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AsynSend | 发送vx socket消息
公共方法 | BeginConnection |
公共方法 | ClearPack |
公共方法 | Connect |
公共方法 | CreateSocket |
公共方法 | DePack |
公共方法 | Disconnect |
公共方法 | Equals | (继承自 Object。)
公共方法 | GetBuffBySeq | 通过seq取微信服务器返回的socket包数据
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | HandlePackage |
公共方法 | SaveBufferToPackDic |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.AsynSend 方法

SocketClientAsynSend 方法

发送vx socket消息

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void AsynSend(
    byte[] _SendBuff
)

参数

_SendBuff
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.AsynSend(System.Byte[])" 的 <param name="_SendBuff"/> 文档]

参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.BeginConnection 方法

SocketClientBeginConnection 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.BeginConnection" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void BeginConnection()
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.ClearPack 方法

SocketClientClearPack 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.ClearPack" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void ClearPack()
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.Connect 方法

SocketClientConnect 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.Connect" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Connect()

返回值

类型：Boolean
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.CreateSocket 方法

SocketClientCreateSocket 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.CreateSocket" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool CreateSocket()

返回值

类型：Boolean
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.DePack 方法

SocketClientDePack 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.DePack(System.Byte[])" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool DePack(
    byte[] bys
)

参数

bys
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.DePack(System.Byte[])" 的 <param name="bys"/> 文档]

返回值

类型：Boolean
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.Disconnect 方法

SocketClientDisconnect 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.Disconnect" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Disconnect()
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.GetBuffBySeq 方法

SocketClientGetBuffBySeq 方法

通过seq取微信服务器返回的socket包数据

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] GetBuffBySeq(
    int Seq
)

参数

Seq
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.GetBuffBySeq(System.Int32)" 的 <param name="Seq"/> 文档]

返回值

类型：Byte
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.HandlePackage 方法

SocketClientHandlePackage 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.HandlePackage(System.Byte[])" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void HandlePackage(
    byte[] bys
)

参数

bys
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.HandlePackage(System.Byte[])" 的 <param name="bys"/> 文档]

参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.SaveBufferToPackDic 方法

SocketClientSaveBufferToPackDic 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.SaveBufferToPackDic(System.Byte[])" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SaveBufferToPackDic(
    byte[] bys
)

参数

bys
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.SocketClient.SaveBufferToPackDic(System.Byte[])" 的 <param name="bys"/> 文档]

参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient 字段

SocketClient 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | allDone |
公共字段 | weixin |
Top
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.allDone 字段

SocketClientallDone 字段

[缺少 "F:Chat.Framework.WXSdk.IPAD.SocketClient.allDone" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ManualResetEvent allDone

字段值

类型：ManualResetEvent
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.weixin 字段

SocketClientweixin 字段

[缺少 "F:Chat.Framework.WXSdk.IPAD.SocketClient.weixin" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WeixinBase weixin

字段值

类型：WeixinBase
参见

引用

SocketClient 类
Chat.Framework.WXSdk.IPAD 命名空间


SocketClient.WXSocketClientError 枚举

SocketClientWXSocketClientError 枚举

[缺少 "T:Chat.Framework.WXSdk.IPAD.SocketClient.WXSocketClientError" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WXSocketClientError
成员
成员名称 | 值 | 说明
connetedErr | 0 |
sendErr | 1 |
receiveErr | 2 |
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


WechatCmd 枚举

协议基础操作类型

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum WechatCmd
成员
成员名称 | 值 | 说明
删除好友 | 681 |
修改标签 | 638 |
获取标签 | 639 |
添加标签 | 635 |
邀请入群 | 610 |
获取群信息 | 551 |
发送文本消息 | 522 |
发送语音文件 | 127 |
搜索关键词 | 719 |
发送图片文件 | -110 |
发送XML消息 | 222 |
同意添加好友 | 137 |
获取联系人信息 | 182 |
获取登录二维码 | 502 |
获取二维码状态 | 503 |
初始化用户信息 | 1002 |
读取通信录 | 851 |
发送消息 | 522 |
获取SYNC消息 | 138 |
noping | 205 |
GetA8Key | 233 |
密码登陆 | 2222 |
退出登录 | 281 |
执行二次登陆 | 702 |
心跳验证包 | 205 |
获取联系人二维码 | 168 |
浏览器加密登录 | 380 |
获得银行卡 | 385 |
发送CDN数据 | 149 |
获取登录短信 | 145 |
下载图片 | 109 |
上传朋友圈图片 | 207 |
发送朋友圈 | 209 |
获取朋友圈 | 212 |
评论或点赞 | 213 |
获取朋友圈首页 | 211 |
编辑联系人信息 | 681 |
删除群用户 | 179 |
群公告 | 993 |
创建群 | 119 |
添加群用户 | 120 |
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


WechatHost 类

协议微信 Host
继承层次
SystemObject
Chat.Framework.WXSdk.IPADWechatHost

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatHost

WechatHost 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatHost | 初始化 WechatHost 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | LongServerList |
公共属性 | ShortServerList |
Top
方法
 | 名称 | 说明
公共方法 | BindLongip |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLong |
公共方法 | GetSort |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


WechatHost 构造函数

初始化 WechatHost 类的一个新实例

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatHost()
参见

引用

WechatHost 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatHost 属性

WechatHost 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | LongServerList |
公共属性 | ShortServerList |
Top
参见

引用

WechatHost 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatHost.LongServerList 属性

WechatHostLongServerList 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.WechatHost.LongServerList" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> LongServerList { get; set; }

属性值

类型：List String
参见

引用

WechatHost 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatHost.ShortServerList 属性

WechatHostShortServerList 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.WechatHost.ShortServerList" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public List<string> ShortServerList { get; set; }

属性值

类型：List String
参见

引用

WechatHost 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatHost 方法

WechatHost 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | BindLongip |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLong |
公共方法 | GetSort |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatHost 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatHost.BindLongip 方法

WechatHostBindLongip 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatHost.BindLongip(System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void BindLongip(
    string ip
)

参数

ip
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatHost.BindLongip(System.String)" 的 <param name="ip"/> 文档]

参见

引用

WechatHost 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatHost.GetLong 方法

WechatHostGetLong 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatHost.GetLong" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetLong()

返回值

类型：String
参见

引用

WechatHost 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatHost.GetSort 方法

WechatHostGetSort 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatHost.GetSort" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetSort()

返回值

类型：String
参见

引用

WechatHost 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack 类

协议发送包
继承层次
SystemObject
Chat.Framework.WXSdk.IPADWechatPack

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatPack

WechatPack 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatPack | 初始化 WechatPack 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Req |
Top
方法
 | 名称 | 说明
公共方法 | Analysis(Byte) |
公共方法 | Analysis(Int32, Byte) |
公共方法 | Analysis(WechatCmd, Object) |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResult |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Send(WechatMsg) |
公共方法 | Send(Int32, Object, ByteString) |
公共方法 | Send(WechatCmd, Byte, ByteString) |
公共方法 | Send(WechatCmd, Object, ByteString) |
公共方法 | SendAll | 发送完整包，并解析微信返回信息
公共方法 | SendNextData |
公共方法 | SendWx |
公共方法 | SetNextData |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


WechatPack 构造函数

初始化 WechatPack 类的一个新实例

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatPack(
    WXClientImpl_IPAD client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD)" 的 <param name="client"/> 文档]

参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack 属性

WechatPack 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Req |
Top
参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Req 属性

WechatPackReq 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.WechatPack.Req" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatMsg Req { get; }

属性值

类型：WechatMsg
参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack 方法

WechatPack 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Analysis(Byte) |
公共方法 | Analysis(Int32, Byte) |
公共方法 | Analysis(WechatCmd, Object) |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResult |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | Send(WechatMsg) |
公共方法 | Send(Int32, Object, ByteString) |
公共方法 | Send(WechatCmd, Byte, ByteString) |
公共方法 | Send(WechatCmd, Object, ByteString) |
公共方法 | SendAll | 发送完整包，并解析微信返回信息
公共方法 | SendNextData |
公共方法 | SendWx |
公共方法 | SetNextData |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Analysis 方法

WechatPackAnalysis 方法

重载列表
 | 名称 | 说明
公共方法 | Analysis(Byte) |
公共方法 | Analysis(Int32, Byte) |
公共方法 | Analysis(WechatCmd, Object) |
Top
参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Analysis 方法 (Byte[])

WechatPackAnalysis 方法 (Byte)

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Analysis(System.Byte[])" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] Analysis(
    byte[] data
)

参数

data
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Analysis(System.Byte[])" 的 <param name="data"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Analysis 重载
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Analysis 方法 (Int32, Byte[])

WechatPackAnalysis 方法 (Int32, Byte)

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Analysis(System.Int32,System.Byte[])" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] Analysis(
    int cmd,
    byte[] data
)

参数

cmd
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Analysis(System.Int32,System.Byte[])" 的 <param name="cmd"/> 文档]

data
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Analysis(System.Int32,System.Byte[])" 的 <param name="data"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Analysis 重载
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Analysis 方法 (WechatCmd, Object)

WechatPackAnalysis 方法 (WechatCmd, Object)

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Analysis(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Object)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] Analysis(
    WechatCmd cmd,
    Object data
)

参数

cmd
类型：Chat.Framework.WXSdk.IPADWechatCmd

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Analysis(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Object)" 的 <param name="cmd"/> 文档]

data
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Analysis(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Object)" 的 <param name="data"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Analysis 重载
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.GetResult 方法

WechatPackGetResult 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.GetResult(System.Int32)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] GetResult(
    int seq
)

参数

seq
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.GetResult(System.Int32)" 的 <param name="seq"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Send 方法

WechatPackSend 方法

重载列表
 | 名称 | 说明
公共方法 | Send(WechatMsg) |
公共方法 | Send(Int32, Object, ByteString) |
公共方法 | Send(WechatCmd, Byte, ByteString) |
公共方法 | Send(WechatCmd, Object, ByteString) |
Top
参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Send 方法 (WechatMsg)

WechatPackSend 方法 (WechatMsg)

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(WechatProto.WechatMsg)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] Send(
    WechatMsg req
)

参数

req
类型：WechatProtoWechatMsg

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(WechatProto.WechatMsg)" 的 <param name="req"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Send 重载
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Send 方法 (Int32, Object, ByteString)

WechatPackSend 方法 (Int32, Object, ByteString)

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(System.Int32,System.Object,Google.Protobuf.ByteString)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] Send(
    int cmd,
    Object data,
    ByteString longHead = null
)

参数

cmd
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(System.Int32,System.Object,Google.Protobuf.ByteString)" 的 <param name="cmd"/> 文档]

data
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(System.Int32,System.Object,Google.Protobuf.ByteString)" 的 <param name="data"/> 文档]

longHead (Optional)
类型：ByteString

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(System.Int32,System.Object,Google.Protobuf.ByteString)" 的 <param name="longHead"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Send 重载
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Send 方法 (WechatCmd, Byte[], ByteString)

WechatPackSend 方法 (WechatCmd, Byte, ByteString)

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Byte[],Google.Protobuf.ByteString)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] Send(
    WechatCmd cmd,
    byte[] data,
    ByteString longHead = null
)

参数

cmd
类型：Chat.Framework.WXSdk.IPADWechatCmd

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Byte[],Google.Protobuf.ByteString)" 的 <param name="cmd"/> 文档]

data
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Byte[],Google.Protobuf.ByteString)" 的 <param name="data"/> 文档]

longHead (Optional)
类型：ByteString

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Byte[],Google.Protobuf.ByteString)" 的 <param name="longHead"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Send 重载
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.Send 方法 (WechatCmd, Object, ByteString)

WechatPackSend 方法 (WechatCmd, Object, ByteString)

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Object,Google.Protobuf.ByteString)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] Send(
    WechatCmd cmd,
    Object data = null,
    ByteString longHead = null
)

参数

cmd
类型：Chat.Framework.WXSdk.IPADWechatCmd

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Object,Google.Protobuf.ByteString)" 的 <param name="cmd"/> 文档]

data (Optional)
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Object,Google.Protobuf.ByteString)" 的 <param name="data"/> 文档]

longHead (Optional)
类型：ByteString

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.Send(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Object,Google.Protobuf.ByteString)" 的 <param name="longHead"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Send 重载
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.SendAll 方法

WechatPackSendAll 方法

发送完整包，并解析微信返回信息

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] SendAll(
    WechatCmd cmd,
    bool isAnalysis,
    Object data = null,
    ByteString longHead = null,
    string text = ""
)

参数

cmd
类型：Chat.Framework.WXSdk.IPADWechatCmd

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendAll(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Boolean,System.Object,Google.Protobuf.ByteString,System.String)" 的 <param name="cmd"/> 文档]

isAnalysis
类型：SystemBoolean

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendAll(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Boolean,System.Object,Google.Protobuf.ByteString,System.String)" 的 <param name="isAnalysis"/> 文档]

data (Optional)
类型：SystemObject

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendAll(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Boolean,System.Object,Google.Protobuf.ByteString,System.String)" 的 <param name="data"/> 文档]

longHead (Optional)
类型：ByteString

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendAll(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Boolean,System.Object,Google.Protobuf.ByteString,System.String)" 的 <param name="longHead"/> 文档]

text (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendAll(Chat.Framework.WXSdk.IPAD.WechatCmd,System.Boolean,System.Object,Google.Protobuf.ByteString,System.String)" 的 <param name="text"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.SendNextData 方法

WechatPackSendNextData 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendNextData" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SendNextData()
参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.SendWx 方法

WechatPackSendWx 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendWx(System.Byte[],System.Int32,System.Int32,System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] SendWx(
    byte[] Data,
    int Seq = 0,
    int retry_number = 1,
    string text = ""
)

参数

Data
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendWx(System.Byte[],System.Int32,System.Int32,System.String)" 的 <param name="Data"/> 文档]

Seq (Optional)
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendWx(System.Byte[],System.Int32,System.Int32,System.String)" 的 <param name="Seq"/> 文档]

retry_number (Optional)
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendWx(System.Byte[],System.Int32,System.Int32,System.String)" 的 <param name="retry_number"/> 文档]

text (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SendWx(System.Byte[],System.Int32,System.Int32,System.String)" 的 <param name="text"/> 文档]

返回值

类型：Byte
参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.SetNextData 方法

WechatPackSetNextData 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SetNextData(Chat.Framework.WXSdk.IPAD.WechatPack.PackMsg)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SetNextData(
    WechatPackPackMsg nextData
)

参数

nextData
类型：Chat.Framework.WXSdk.IPADWechatPackPackMsg

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatPack.SetNextData(Chat.Framework.WXSdk.IPAD.WechatPack.PackMsg)" 的 <param name="nextData"/> 文档]

参见

引用

WechatPack 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.PackMsg 类

WechatPackPackMsg 类

[缺少 "T:Chat.Framework.WXSdk.IPAD.WechatPack.PackMsg" 的 <summary> 文档]

继承层次
SystemObject
Chat.Framework.WXSdk.IPADWechatPackPackMsg

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class PackMsg

WechatPackPackMsg 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatPackPackMsg | 初始化 WechatPackPackMsg 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | cmd |
公共属性 | data |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.PackMsg 构造函数

WechatPackPackMsg 构造函数

初始化 WechatPackPackMsg 类的一个新实例

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public PackMsg()
参见

引用

WechatPackPackMsg 类
Chat.Framework.WXSdk.IPAD 命名空间


PackMsg 属性

WechatPackPackMsg 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | cmd |
公共属性 | data |
Top
参见

引用

WechatPackPackMsg 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.PackMsg.cmd 属性

WechatPackPackMsgcmd 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.WechatPack.PackMsg.cmd" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatCmd cmd { get; set; }

属性值

类型：WechatCmd
参见

引用

WechatPackPackMsg 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatPack.PackMsg.data 属性

WechatPackPackMsgdata 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.WechatPack.PackMsg.data" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Object data { get; set; }

属性值

类型：Object
参见

引用

WechatPackPackMsg 类
Chat.Framework.WXSdk.IPAD 命名空间


PackMsg 方法

WechatPackPackMsg 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatPackPackMsg 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket 类

微信Socket
继承层次
SystemObject
Chat.Framework.WXSdk.IPADWechatSocket

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatSocket

WechatSocket 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatSocket | 初始化 WechatSocket 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IsStop |
公共属性 | ServerIp |
Top
方法
 | 名称 | 说明
公共方法 | ClearPack |
公共方法 | Connect | 连接腾讯服务器
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResult |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnReceivedOnConnected | 连接成功
受保护的方法 | OnReceivedOnDisconnected | 连接断开
公共方法 | SendToWechat |
公共方法 | SendToWeChat | 发包到腾讯
公共方法 | SendWeChatPost(WechatMsg) | 短链发送包
公共方法 | SendWeChatPost(Byte, String, Int32) | 短链发送包
公共方法 | Stop | 停止
公共方法 | TestError |
公共方法 | ToString | (继承自 Object。)
Top
事件
 | 名称 | 说明
公共事件 | ReceivedOnConnected | 连接成功
公共事件 | ReceivedOnDisconnected | 连接断开
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket 构造函数

初始化 WechatSocket 类的一个新实例

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatSocket(
    WXClientImpl_IPAD client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD)" 的 <param name="client"/> 文档]

参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket 属性

WechatSocket 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsStop |
公共属性 | ServerIp |
Top
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.IsStop 属性

WechatSocketIsStop 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.WechatSocket.IsStop" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsStop { get; }

属性值

类型：Boolean
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.ServerIp 属性

WechatSocketServerIp 属性

[缺少 "P:Chat.Framework.WXSdk.IPAD.WechatSocket.ServerIp" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ServerIp { get; set; }

属性值

类型：String
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket 方法

WechatSocket 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ClearPack |
公共方法 | Connect | 连接腾讯服务器
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetResult |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | OnReceivedOnConnected | 连接成功
受保护的方法 | OnReceivedOnDisconnected | 连接断开
公共方法 | SendToWechat |
公共方法 | SendToWeChat | 发包到腾讯
公共方法 | SendWeChatPost(WechatMsg) | 短链发送包
公共方法 | SendWeChatPost(Byte, String, Int32) | 短链发送包
公共方法 | Stop | 停止
公共方法 | TestError |
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.ClearPack 方法

WechatSocketClearPack 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.ClearPack" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void ClearPack()
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.Connect 方法

WechatSocketConnect 方法

连接腾讯服务器

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Connect()

返回值

类型：Boolean
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.GetResult 方法

WechatSocketGetResult 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.GetResult(System.Int32)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] GetResult(
    int seq
)

参数

seq
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.GetResult(System.Int32)" 的 <param name="seq"/> 文档]

返回值

类型：Byte
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.OnReceivedOnConnected 方法

WechatSocketOnReceivedOnConnected 方法

连接成功

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected virtual void OnReceivedOnConnected(
    IPAddress e
)

参数

e
类型：System.NetIPAddress

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.OnReceivedOnConnected(System.Net.IPAddress)" 的 <param name="e"/> 文档]

参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.OnReceivedOnDisconnected 方法

WechatSocketOnReceivedOnDisconnected 方法

连接断开

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected virtual void OnReceivedOnDisconnected(
    IPAddress e
)

参数

e
类型：System.NetIPAddress

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.OnReceivedOnDisconnected(System.Net.IPAddress)" 的 <param name="e"/> 文档]

参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.SendToWechat 方法

WechatSocketSendToWechat 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.SendToWechat(System.Byte[],System.String)" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void SendToWechat(
    byte[] buffers,
    string text = ""
)

参数

buffers
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.SendToWechat(System.Byte[],System.String)" 的 <param name="buffers"/> 文档]

text (Optional)
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.SendToWechat(System.Byte[],System.String)" 的 <param name="text"/> 文档]

参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.SendToWeChat 方法

WechatSocketSendToWeChat 方法

发包到腾讯

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Task<byte[]> SendToWeChat(
    int cmd,
    byte[] buffers
)

参数

cmd
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.SendToWeChat(System.Int32,System.Byte[])" 的 <param name="cmd"/> 文档]

buffers
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.SendToWeChat(System.Int32,System.Byte[])" 的 <param name="buffers"/> 文档]

返回值

类型：Task Byte
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.SendWeChatPost 方法

WechatSocketSendWeChatPost 方法

重载列表
 | 名称 | 说明
公共方法 | SendWeChatPost(WechatMsg) | 短链发送包
公共方法 | SendWeChatPost(Byte, String, Int32) | 短链发送包
Top
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.SendWeChatPost 方法 (WechatMsg)

WechatSocketSendWeChatPost 方法 (WechatMsg)

短链发送包

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] SendWeChatPost(
    WechatMsg pack
)

参数

pack
类型：WechatProtoWechatMsg

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.SendWeChatPost(WechatProto.WechatMsg)" 的 <param name="pack"/> 文档]

返回值

类型：Byte
参见

引用

WechatSocket 类
SendWeChatPost 重载
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.SendWeChatPost 方法 (Byte[], String, Int32)

WechatSocketSendWeChatPost 方法 (Byte, String, Int32)

短链发送包

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public byte[] SendWeChatPost(
    byte[] body,
    string cmdUrl,
    int retry_number = 2
)

参数

body
类型：SystemByte

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.SendWeChatPost(System.Byte[],System.String,System.Int32)" 的 <param name="body"/> 文档]

cmdUrl
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.SendWeChatPost(System.Byte[],System.String,System.Int32)" 的 <param name="cmdUrl"/> 文档]

retry_number (Optional)
类型：SystemInt32

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.SendWeChatPost(System.Byte[],System.String,System.Int32)" 的 <param name="retry_number"/> 文档]

返回值

类型：Byte
参见

引用

WechatSocket 类
SendWeChatPost 重载
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.Stop 方法

WechatSocketStop 方法

停止

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Stop()
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.TestError 方法

WechatSocketTestError 方法

[缺少 "M:Chat.Framework.WXSdk.IPAD.WechatSocket.TestError" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void TestError()
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket 事件

WechatSocket 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | ReceivedOnConnected | 连接成功
公共事件 | ReceivedOnDisconnected | 连接断开
Top
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.ReceivedOnConnected 事件

WechatSocketReceivedOnConnected 事件

连接成功

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<IPAddress> ReceivedOnConnected

值

类型：SystemEventHandler IPAddress
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


WechatSocket.ReceivedOnDisconnected 事件

WechatSocketReceivedOnDisconnected 事件

连接断开

命名空间： Chat.Framework.WXSdk.IPAD
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public event EventHandler<IPAddress> ReceivedOnDisconnected

值

类型：SystemEventHandler IPAddress
参见

引用

WechatSocket 类
Chat.Framework.WXSdk.IPAD 命名空间


Chat.Framework.WXSdk.UIForm 命名空间

[缺少 "N:Chat.Framework.WXSdk.UIForm" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | BrowserForm |
公共类 | LoginForm |
公共类 | LoginwxPassForm |
公共类 | SetwxhForm |


BrowserForm 类

[缺少 "T:Chat.Framework.WXSdk.UIForm.BrowserForm" 的 <summary> 文档]

继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Chat.Framework.WXSdk.UIFormBrowserForm

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class BrowserForm : Form

BrowserForm 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BrowserForm | 初始化 BrowserForm 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 Form。)
公共属性 | BackgroundImage | (继承自 Control。)
公共属性 | BackgroundImageLayout | (继承自 Control。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 Form。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 Control。)
受保护的属性 | FontHeight | (继承自 Control。)
公共属性 | ForeColor | (继承自 Control。)
公共属性 | FormBorderStyle | (继承自 Form。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | Icon | (继承自 Form。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 Form。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 Form。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 Control。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 Form。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
公共方法 | Close | (继承自 Form。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 Form。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 Form。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 FormDispose(Boolean).)
公共方法 | DoDragDrop | (继承自 Control。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
公共方法 | GetContainerControl | (继承自 Control。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 Form。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 Control。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 Form。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 Form。)
受保护的方法 | OnHandleDestroyed | (继承自 Form。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 Form。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 Form。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumSizeChanged | (继承自 Form。)
受保护的方法 | OnMdiChildActivate | (继承自 Form。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumSizeChanged | (继承自 Form。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 ScrollableControl。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 Form。)
受保护的方法 | OnPaintBackground | (继承自 ScrollableControl。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 ContainerControl。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShown | (继承自 Form。)
受保护的方法 | OnSizeChanged | (继承自 Control。)
受保护的方法 | OnStyleChanged | (继承自 Form。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 Form。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 Control。)
公共方法 | ResumeLayout(Boolean) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 Form。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 Form。)
受保护的方法 | SetClientSizeCore | (继承自 Form。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 Form。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 Form。)
受保护的方法 | SizeFromClientSize | (继承自 Control。)
公共方法 | SuspendLayout | (继承自 Control。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 Form。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.UIForm 命名空间


BrowserForm 构造函数

初始化 BrowserForm 类的一个新实例

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BrowserForm(
    string url
)

参数

url
类型：SystemString

[缺少 "M:Chat.Framework.WXSdk.UIForm.BrowserForm.#ctor(System.String)" 的 <param name="url"/> 文档]

参见

引用

BrowserForm 类
Chat.Framework.WXSdk.UIForm 命名空间


BrowserForm 属性

BrowserForm 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 Form。)
公共属性 | BackgroundImage | (继承自 Control。)
公共属性 | BackgroundImageLayout | (继承自 Control。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 Form。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 Control。)
受保护的属性 | FontHeight | (继承自 Control。)
公共属性 | ForeColor | (继承自 Control。)
公共属性 | FormBorderStyle | (继承自 Form。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | Icon | (继承自 Form。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 Form。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 Form。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 Control。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 Form。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

BrowserForm 类
Chat.Framework.WXSdk.UIForm 命名空间


BrowserForm 方法

BrowserForm 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
公共方法 | Close | (继承自 Form。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 Form。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 Form。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 FormDispose(Boolean).)
公共方法 | DoDragDrop | (继承自 Control。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
公共方法 | GetContainerControl | (继承自 Control。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 Form。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 Control。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 Form。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 Form。)
受保护的方法 | OnHandleDestroyed | (继承自 Form。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 Form。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 Form。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumSizeChanged | (继承自 Form。)
受保护的方法 | OnMdiChildActivate | (继承自 Form。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumSizeChanged | (继承自 Form。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 ScrollableControl。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 Form。)
受保护的方法 | OnPaintBackground | (继承自 ScrollableControl。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 ContainerControl。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShown | (继承自 Form。)
受保护的方法 | OnSizeChanged | (继承自 Control。)
受保护的方法 | OnStyleChanged | (继承自 Form。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 Form。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 Control。)
公共方法 | ResumeLayout(Boolean) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 Form。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 Form。)
受保护的方法 | SetClientSizeCore | (继承自 Form。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 Form。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 Form。)
受保护的方法 | SizeFromClientSize | (继承自 Control。)
公共方法 | SuspendLayout | (继承自 Control。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 Form。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

BrowserForm 类
Chat.Framework.WXSdk.UIForm 命名空间


BrowserForm.Dispose 方法

BrowserFormDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 FormDispose(Boolean).)
Top
参见

引用

BrowserForm 类
Chat.Framework.WXSdk.UIForm 命名空间


BrowserForm.Dispose 方法 (Boolean)

BrowserFormDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

BrowserForm 类
Dispose 重载
Chat.Framework.WXSdk.UIForm 命名空间


BrowserForm 事件

BrowserForm 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

BrowserForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginForm 类

[缺少 "T:Chat.Framework.WXSdk.UIForm.LoginForm" 的 <summary> 文档]

继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
Chat.Framework.WXSdk.UIFormLoginForm

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class LoginForm : BaseForm

LoginForm 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | LoginForm | 初始化 LoginForm 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.UIForm 命名空间


LoginForm 构造函数

初始化 LoginForm 类的一个新实例

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public LoginForm(
    WXClientImpl_IPAD wx
)

参数

wx
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.UIForm.LoginForm.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD)" 的 <param name="wx"/> 文档]

参见

引用

LoginForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginForm 属性

LoginForm 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

LoginForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginForm 方法

LoginForm 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

LoginForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginForm.Dispose 方法

LoginFormDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
Top
参见

引用

LoginForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginForm.Dispose 方法 (Boolean)

LoginFormDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

LoginForm 类
Dispose 重载
Chat.Framework.WXSdk.UIForm 命名空间


LoginForm 事件

LoginForm 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

LoginForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginForm 字段

LoginForm 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
参见

引用

LoginForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginwxPassForm 类

[缺少 "T:Chat.Framework.WXSdk.UIForm.LoginwxPassForm" 的 <summary> 文档]

继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
Chat.Framework.WXSdk.UIFormLoginwxPassForm

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class LoginwxPassForm : BaseForm

LoginwxPassForm 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | LoginwxPassForm | 初始化 LoginwxPassForm 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.UIForm 命名空间


LoginwxPassForm 构造函数

初始化 LoginwxPassForm 类的一个新实例

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public LoginwxPassForm(
    WXClientImpl_IPAD client
)

参数

client
类型：Chat.Framework.WXSdk.ImplementWXClientImpl_IPAD

[缺少 "M:Chat.Framework.WXSdk.UIForm.LoginwxPassForm.#ctor(Chat.Framework.WXSdk.Implement.WXClientImpl_IPAD)" 的 <param name="client"/> 文档]

参见

引用

LoginwxPassForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginwxPassForm 属性

LoginwxPassForm 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

LoginwxPassForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginwxPassForm 方法

LoginwxPassForm 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

LoginwxPassForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginwxPassForm.Dispose 方法

LoginwxPassFormDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
Top
参见

引用

LoginwxPassForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginwxPassForm.Dispose 方法 (Boolean)

LoginwxPassFormDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

LoginwxPassForm 类
Dispose 重载
Chat.Framework.WXSdk.UIForm 命名空间


LoginwxPassForm 事件

LoginwxPassForm 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

LoginwxPassForm 类
Chat.Framework.WXSdk.UIForm 命名空间


LoginwxPassForm 字段

LoginwxPassForm 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
参见

引用

LoginwxPassForm 类
Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm 类

[缺少 "T:Chat.Framework.WXSdk.UIForm.SetwxhForm" 的 <summary> 文档]

继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
Chat.Framework.WXSdk.UIFormSetwxhForm

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class SetwxhForm : BaseForm

SetwxhForm 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SetwxhForm | 初始化 SetwxhForm 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | deviceid |
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
公共属性 | wxh |
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm 构造函数

初始化 SetwxhForm 类的一个新实例

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public SetwxhForm()
参见

引用

SetwxhForm 类
Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm 属性

SetwxhForm 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveGlowColor | (继承自 XtraForm。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowFormSkin | (继承自 XtraForm。)
公共属性 | AllowMdiBar | (继承自 XtraForm。)
受保护的属性 | AllowSkinForEmptyText | (继承自 XtraForm。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | Appearance | (继承自 XtraForm。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 XtraForm。)
公共属性 | BackgroundImage | (继承自 XtraForm。)
公共属性 | BackgroundImageLayout | (继承自 XtraForm。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanDrawClientBackground | (继承自 XtraForm。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
受保护的属性 | ClientBackgroundTop | (继承自 XtraForm。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CloseBox | (继承自 XtraForm。)
受保护的属性 | ColorizeInactiveIcon | (继承自 XtraForm。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 XtraForm。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultAppearance | (继承自 XtraForm。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
受保护的属性 | DesignModeCore | (继承自 XtraForm。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | deviceid |
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | EnableAcrylicAccent | (继承自 XtraForm。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 XtraForm。)
受保护的属性 | FontHeight | (继承自 Control。)
受保护的属性 | ForceShowThickBorder | (继承自 XtraForm。)
公共属性 | ForeColor | (继承自 XtraForm。)
公共属性 | FormBorderEffect | (继承自 XtraForm。)
公共属性 | FormBorderStyle | (继承自 Form。)
受保护的属性 | FormPainter | (继承自 XtraForm。)
受保护的属性 | FormShadow | (继承自 XtraForm。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
受保护的属性 | Helper | (继承自 XtraForm。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | HtmlImages | (继承自 XtraForm。)
公共属性 | HtmlText | (继承自 XtraForm。)
公共属性 | Icon | (继承自 Form。)
公共属性 | IconOptions | (继承自 XtraForm。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InactiveGlowColor | (继承自 XtraForm。)
受保护的属性 | InMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的属性 | InvisibleDueShowingStrategy | (继承自 XtraForm。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
受保护的属性 | IsActive | (继承自 XtraForm。)
受保护的属性 | IsApplyingLocalizableResourcesInDesignTime | (继承自 XtraForm。)
受保护的属性 | IsCustomPainter | (继承自 XtraForm。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
受保护的属性 | IsInitializing | (继承自 XtraForm。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
受保护的属性 | IsOnePixelBorder | (继承自 XtraForm。)
受保护的属性 | IsRegionPainted | (继承自 XtraForm。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
受保护的属性 | IsRibbonForm | (继承自 XtraForm。)
受保护的属性 | IsRightToLeftCaption | (继承自 XtraForm。)
受保护的属性 | IsSizableWindow | (继承自 XtraForm。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
受保护的属性 | LayoutSuspendCountCore | (继承自 XtraForm。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | LookAndFeel | (继承自 XtraForm。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 XtraForm。)
公共属性 | MdiChildCaptionFormatString | (继承自 XtraForm。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 XtraForm。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
受保护的属性 | NeedActivateForm | (继承自 XtraForm。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ScaleDPI | (继承自 XtraForm。)
受保护的属性 | ScaleHelper | (继承自 XtraForm。)
受保护的属性 | ShouldShowMdiBar | (继承自 XtraForm。)
受保护的属性 | ShouldShowShadowInDesignMode | (继承自 XtraForm。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
受保护的属性 | ShowingStrategy | (继承自 XtraForm。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | ShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的属性 | ShowMode | (继承自 XtraForm。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 XtraForm。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 XtraForm。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
公共属性 | wxh |
Top
参见

引用

SetwxhForm 类
Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm.deviceid 属性

SetwxhFormdeviceid 属性

[缺少 "P:Chat.Framework.WXSdk.UIForm.SetwxhForm.deviceid" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string deviceid { get; }

属性值

类型：String
参见

引用

SetwxhForm 类
Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm.wxh 属性

SetwxhFormwxh 属性

[缺少 "P:Chat.Framework.WXSdk.UIForm.SetwxhForm.wxh" 的 <summary> 文档]

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string wxh { get; }

属性值

类型：String
参见

引用

SetwxhForm 类
Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm 方法

SetwxhForm 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
受保护的方法 | ActivateWindow | (继承自 XtraForm。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | ApplyAcrylicAccent | (继承自 XtraForm。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CalcClippedRegion | (继承自 XtraForm。)
受保护的方法 | CalcFormBounds | (继承自 XtraForm。)
受保护的方法 | CalcPreferredSizeCore | (继承自 XtraForm。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
受保护的方法 | CheckCustomDrawNonClientArea | (继承自 XtraForm。)
受保护的方法 | CheckFormAppearanceAsMdiTabPage | (继承自 XtraForm。)
受保护的方法 | CheckGlassForm | (继承自 XtraForm。)
受保护的方法 | CheckRightToLeft | (继承自 XtraForm。)
受保护的方法 | CheckUpdateSkinPainter | (继承自 XtraForm。)
公共方法 | ClearAcrylicAccent | (继承自 XtraForm。)
受保护的方法 | ClientSizeFromSize | (继承自 XtraForm。)
公共方法 | Close | (继承自 Form。)
受保护的方法 | ConstrainMinimumClientSize | (继承自 XtraForm。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 XtraForm。)
受保护的方法 | CreateDefaultAppearance | (继承自 XtraForm。)
受保护的方法 | CreateFormBorderPainter | (继承自 XtraForm。)
受保护的方法 | CreateFormShadow | (继承自 XtraForm。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 XtraForm。)
受保护的方法 | CreateHelper | (继承自 XtraForm。)
受保护的方法 | CreateIconOptions | (继承自 XtraForm。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | CreateShowingStrategy | (继承自 XtraForm。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
受保护的方法 | DoDpiChange | (继承自 XtraForm。)
受保护的方法 | DoDpiChangeAfterBase | (继承自 XtraForm。)
公共方法 | DoDragDrop | (继承自 Control。)
受保护的方法 | DrawClientBackground | (继承自 XtraForm。)
受保护的方法 | DrawClientBackgroundCore | (继承自 XtraForm。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | ForceActivateWindow | (继承自 XtraForm。)
受保护的方法 | ForceRefresh | (继承自 XtraForm。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetActiveLookAndFeel | (继承自 XtraForm。)
受保护的方法 | GetAllowMdiFormSkins | (继承自 XtraForm。)
受保护的方法 | GetAllowSkin | (继承自 XtraForm。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
受保护的方法 | GetBaseFont | (继承自 XtraForm。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
受保护的方法 | GetConstrainSize | (继承自 XtraForm。)
公共方法 | GetContainerControl | (继承自 Control。)
受保护的方法 | GetCreateParams | (继承自 XtraForm。)
受保护的方法 | GetFormBorderEffect | (继承自 XtraForm。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 XtraForm。)
受保护的方法 | GetScaleFactor | (继承自 XtraForm。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetSkinBackgroundImage | (继承自 XtraForm。)
受保护的方法 | GetSkinBackgroundImageStretch | (继承自 XtraForm。)
受保护的方法 | GetSkinPainterType | (继承自 XtraForm。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | IsMdiTab | (继承自 XtraForm。)
受保护的方法 | IsMinimizedState | (继承自 XtraForm。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnActiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnAppearance_Changed | (继承自 XtraForm。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 XtraForm。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 XtraForm。)
受保护的方法 | OnHandleDestroyed | (继承自 XtraForm。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInactiveGlowColorChanged | (继承自 XtraForm。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 XtraForm。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 XtraForm。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLookAndFeelChangedCore | (继承自 XtraForm。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMaximumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMdiChildActivate | (继承自 XtraForm。)
受保护的方法 | OnMdiChildTextChanged | (继承自 XtraForm。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumClientSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMinimumSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseHWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 MouseWheelContainerForm。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 XtraForm。)
受保护的方法 | OnPaintBackground | (继承自 XtraForm。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 XtraForm。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScaleControl | (继承自 XtraForm。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShowMdiChildCaptionInParentTitle | (继承自 XtraForm。)
受保护的方法 | OnShown | (继承自 XtraForm。)
受保护的方法 | OnSizeChanged | (继承自 XtraForm。)
受保护的方法 | OnSkinPainterChanged | (继承自 XtraForm。)
受保护的方法 | OnStyleChanged | (继承自 XtraForm。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 XtraForm。)
受保护的方法 | OnTextMdiTabChanged | (继承自 XtraForm。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
受保护的方法 | PatchFormSizeInRestoreWindowBoundsIfNecessary | (继承自 XtraForm。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseFormLayoutChanged | (继承自 XtraForm。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
公共方法 | ResetBackColor | (继承自 XtraForm。)
公共方法 | ResetForeColor | (继承自 XtraForm。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 XtraForm。)
公共方法 | ResumeLayout(Boolean) | (继承自 XtraForm。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 XtraForm。)
受保护的方法 | ScaleCore | (继承自 XtraForm。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 XtraForm。)
受保护的方法 | SetClientSizeCore | (继承自 XtraForm。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetLayoutDeferred | (继承自 XtraForm。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 XtraForm。)
受保护的方法 | ShouldDrawClientBackground | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageLayoutStore | (继承自 XtraForm。)
受保护的方法 | ShouldSerializeBackgroundImageStore | (继承自 XtraForm。)
受保护的方法 | ShouldUpdateFrame | (继承自 XtraForm。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 XtraForm。)
受保护的方法 | SizeFromClientSize | (继承自 XtraForm。)
受保护的方法 | SuppressFormShadowShowing | (继承自 XtraForm。)
公共方法 | SuspendLayout | (继承自 XtraForm。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateClientBackgroundBounds | (继承自 XtraForm。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateSkinPainter | (继承自 XtraForm。)
受保护的方法 | UpdateSkinPainter(Boolean) | (继承自 XtraForm。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateUI | (继承自 BaseForm。)
受保护的方法 | UpdateWindowThemeCore | (继承自 XtraForm。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 XtraForm。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

SetwxhForm 类
Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm.Dispose 方法

SetwxhFormDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 BaseForm.Dispose(Boolean).)
Top
参见

引用

SetwxhForm 类
Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm.Dispose 方法 (Boolean)

SetwxhFormDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： Chat.Framework.WXSdk.UIForm
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

SetwxhForm 类
Dispose 重载
Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm 事件

SetwxhForm 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

SetwxhForm 类
Chat.Framework.WXSdk.UIForm 命名空间


SetwxhForm 字段

SetwxhForm 类型公开以下成员。

字段
 | 名称 | 说明
受保护的字段 | boundsUpdated | (继承自 XtraForm。)
受保护的字段 | formBounds | (继承自 XtraForm。)
受保护的字段 | isFormPainted | (继承自 XtraForm。)
受保护的字段 | lockDrawingClientBackground | (继承自 XtraForm。)
受保护的字段 | Loding | (继承自 BaseForm。)
受保护的字段 | prevFormBounds | (继承自 XtraForm。)
Top
参见

引用

SetwxhForm 类
Chat.Framework.WXSdk.UIForm 命名空间


Eson.Utils 命名空间

[缺少 "N:Eson.Utils" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | Assistant | 文件操作帮助类
公共类 | ExtensiveHelper | 反射帮助类
公共类 | FileUpLoadMsgInfo | 文件上传操作结果返回类


Assistant 类

文件操作帮助类
继承层次
SystemObject
Eson.UtilsAssistant

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class Assistant

Assistant 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | Assistant | 初始化 Assistant 类的一个新实例
Top
属性
名称 | 说明
SiteRoot | 获取虚拟目录根目录
Top
方法
 | 名称 | 说明
 | CreateLog | 根据路径创建文件
 | DeleteFile | 检查是否存在某文件，存在则删除
 | DeleteFileOfImport | 在执行完导入操作后，删除导入过程中临时存放的导入文件
 | Deletes | 删除指定目录下的所有文件
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetRandomCode | 从字符串里随机得到，规定个数的字符串.
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | SaveFile | 上传文件
公共方法 | ToString | (继承自 Object。)
 | UpLoadFile | 上传文件
 | WriteLog | 向文件写入数据
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Eson.Utils 命名空间


Assistant 构造函数

初始化 Assistant 类的一个新实例

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public Assistant()
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant 属性

Assistant 类型公开以下成员。

属性
名称 | 说明
SiteRoot | 获取虚拟目录根目录
Top
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant.SiteRoot 属性

AssistantSiteRoot 属性

获取虚拟目录根目录

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string SiteRoot { get; }

属性值

类型：String
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant 方法

Assistant 类型公开以下成员。

方法
 | 名称 | 说明
 | CreateLog | 根据路径创建文件
 | DeleteFile | 检查是否存在某文件，存在则删除
 | DeleteFileOfImport | 在执行完导入操作后，删除导入过程中临时存放的导入文件
 | Deletes | 删除指定目录下的所有文件
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetRandomCode | 从字符串里随机得到，规定个数的字符串.
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | SaveFile | 上传文件
公共方法 | ToString | (继承自 Object。)
 | UpLoadFile | 上传文件
 | WriteLog | 向文件写入数据
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant.CreateLog 方法

AssistantCreateLog 方法

根据路径创建文件

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void CreateLog(
    string realPath
)

参数

realPath
类型：SystemString
文件路径
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant.DeleteFile 方法

AssistantDeleteFile 方法

检查是否存在某文件，存在则删除

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void DeleteFile(
    string strFilePath
)

参数

strFilePath
类型：SystemString
文件路径
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant.DeleteFileOfImport 方法

AssistantDeleteFileOfImport 方法

在执行完导入操作后，删除导入过程中临时存放的导入文件

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void DeleteFileOfImport(
    string importFilePath
)

参数

importFilePath
类型：SystemString

[缺少 "M:Eson.Utils.Assistant.DeleteFileOfImport(System.String)" 的 <param name="importFilePath"/> 文档]

参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant.Deletes 方法

AssistantDeletes 方法

删除指定目录下的所有文件

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void Deletes(
    string srcPath
)

参数

srcPath
类型：SystemString
目录
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant.GetRandomCode 方法

AssistantGetRandomCode 方法

从字符串里随机得到，规定个数的字符串.

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetRandomCode(
    int CodeCount
)

参数

CodeCount
类型：SystemInt32

[缺少 "M:Eson.Utils.Assistant.GetRandomCode(System.Int32)" 的 <param name="CodeCount"/> 文档]

返回值

类型：String
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant.SaveFile 方法

AssistantSaveFile 方法

上传文件

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void SaveFile(
    FileUpload fuXls,
    out string strFilePath,
    string strPath
)

参数

fuXls
类型：System.Web.UI.WebControlsFileUpload
上传控件
strFilePath
类型：SystemString
文件路径
strPath
类型：SystemString
文件上层文件夹路径
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant.UpLoadFile 方法

AssistantUpLoadFile 方法

上传文件

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string UpLoadFile(
    FileUpload fuXls,
    string strPath,
    string saveName = ""
)

参数

fuXls
类型：System.Web.UI.WebControlsFileUpload
上传控件
strPath
类型：SystemString
文件上层文件夹路径
saveName (Optional)
类型：SystemString
文件名称（默认为空）

返回值

类型：String
参见

引用

Assistant 类
Eson.Utils 命名空间


Assistant.WriteLog 方法

AssistantWriteLog 方法

向文件写入数据

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static void WriteLog(
    string content,
    string realPath
)

参数

content
类型：SystemString
内容
realPath
类型：SystemString
文件路径
参见

引用

Assistant 类
Eson.Utils 命名空间


ExtensiveHelper 类

反射帮助类
继承层次
SystemObject
Eson.UtilsExtensiveHelper

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ExtensiveHelper

ExtensiveHelper 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExtensiveHelper | 初始化 ExtensiveHelper 类的一个新实例
Top
方法
 | 名称 | 说明
 | ConvertDictionaryToTableD, S | 将T类型的Dictionary字典列表转换为DataTable
 | ConvertListToTableT(ListT) | 将T类型的List列表转换为DataTable
 | ConvertListToTableT(ListT, DictionaryString, String) | 将T类型的List列表转换为DataTable
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | MapTSource, TDest(ListTSource) | 将TSource类型的实体类泛型List对象转换为TDest类型的泛型List对象
 | MapTSource, TDest(DataTable) | 将DataTable数据转换为TDest类型的泛型List对象
 | MapTSource, TDest(TSource) | 将TSource类型的实体类对象转换为TDest类型的实体类对象
 | MapTSource, TDest(DataRow, DataColumnCollection) | 将DataTable的行转换成TDest类型的泛型List对象
 | MapITSource, TDest | 将TSource类型的实体类泛型List对象转换为TDest类型的泛型List对象
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Eson.Utils 命名空间


ExtensiveHelper 构造函数

初始化 ExtensiveHelper 类的一个新实例

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExtensiveHelper()
参见

引用

ExtensiveHelper 类
Eson.Utils 命名空间


ExtensiveHelper 方法

ExtensiveHelper 类型公开以下成员。

方法
 | 名称 | 说明
 | ConvertDictionaryToTableD, S | 将T类型的Dictionary字典列表转换为DataTable
 | ConvertListToTableT(ListT) | 将T类型的List列表转换为DataTable
 | ConvertListToTableT(ListT, DictionaryString, String) | 将T类型的List列表转换为DataTable
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | MapTSource, TDest(ListTSource) | 将TSource类型的实体类泛型List对象转换为TDest类型的泛型List对象
 | MapTSource, TDest(DataTable) | 将DataTable数据转换为TDest类型的泛型List对象
 | MapTSource, TDest(TSource) | 将TSource类型的实体类对象转换为TDest类型的实体类对象
 | MapTSource, TDest(DataRow, DataColumnCollection) | 将DataTable的行转换成TDest类型的泛型List对象
 | MapITSource, TDest | 将TSource类型的实体类泛型List对象转换为TDest类型的泛型List对象
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ExtensiveHelper 类
Eson.Utils 命名空间


ExtensiveHelper.ConvertDictionaryToTable(D, S) 方法

ExtensiveHelperConvertDictionaryToTableD, S 方法

将T类型的Dictionary字典列表转换为DataTable

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static DataTable ConvertDictionaryToTable<D, S>(
    Dictionary<D, S> dic,
    List<string> list
)

参数

dic
类型：System.Collections.GenericDictionary D, S
字典列表
list
类型：System.Collections.GenericList String
列名列表

类型参数

D
D类型
S
S类型

返回值

类型：DataTable
返回DataTable
参见

引用

ExtensiveHelper 类
Eson.Utils 命名空间


ExtensiveHelper.ConvertListToTable 方法

ExtensiveHelperConvertListToTable 方法

重载列表
名称 | 说明
ConvertListToTableT(ListT) | 将T类型的List列表转换为DataTable
ConvertListToTableT(ListT, DictionaryString, String) | 将T类型的List列表转换为DataTable
Top
参见

引用

ExtensiveHelper 类
Eson.Utils 命名空间


ExtensiveHelper.ConvertListToTable(T) 方法 (List(T))

ExtensiveHelperConvertListToTableT 方法 (ListT)

将T类型的List列表转换为DataTable

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static DataTable ConvertListToTable<T>(
    List<T> list
)
where T : class

参数

list
类型：System.Collections.GenericList T
列表

类型参数

T
T类型

返回值

类型：DataTable
返回DataTable
参见

引用

ExtensiveHelper 类
ConvertListToTable 重载
Eson.Utils 命名空间


ExtensiveHelper.ConvertListToTable(T) 方法 (List(T), Dictionary(String, String))

ExtensiveHelperConvertListToTableT 方法 (ListT, DictionaryString, String)

将T类型的List列表转换为DataTable

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static DataTable ConvertListToTable<T>(
    List<T> list,
    Dictionary<string, string> properties
)
where T : class

参数

list
类型：System.Collections.GenericList T
列表
properties
类型：System.Collections.GenericDictionary String, String
想要转换的属性名称列表[key值对应Model属性,value值对应Excel显示的列名]

类型参数

T
T类型

返回值

类型：DataTable
返回DataTable
参见

引用

ExtensiveHelper 类
ConvertListToTable 重载
Eson.Utils 命名空间


ExtensiveHelper.Map 方法

ExtensiveHelperMap 方法

重载列表
名称 | 说明
MapTSource, TDest(ListTSource) | 将TSource类型的实体类泛型List对象转换为TDest类型的泛型List对象
MapTSource, TDest(DataTable) | 将DataTable数据转换为TDest类型的泛型List对象
MapTSource, TDest(TSource) | 将TSource类型的实体类对象转换为TDest类型的实体类对象
MapTSource, TDest(DataRow, DataColumnCollection) | 将DataTable的行转换成TDest类型的泛型List对象
Top
参见

引用

ExtensiveHelper 类
Eson.Utils 命名空间


ExtensiveHelper.Map(TSource, TDest) 方法 (List(TSource))

ExtensiveHelperMapTSource, TDest 方法 (ListTSource)

将TSource类型的实体类泛型List对象转换为TDest类型的泛型List对象

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<TDest> Map<TSource, TDest>(
    List<TSource> sList
)
where TSource : class, new()
where TDest : class, new()

参数

sList
类型：System.Collections.GenericList TSource
要转换的泛型List对象

类型参数

TSource
要转换的实体类对象T类型
TDest
目标实体类对象T类型

返回值

类型：List TDest
TDest目标泛型List对象
参见

引用

ExtensiveHelper 类
Map 重载
Eson.Utils 命名空间


ExtensiveHelper.Map(TSource, TDest) 方法 (DataTable)

ExtensiveHelperMapTSource, TDest 方法 (DataTable)

将DataTable数据转换为TDest类型的泛型List对象

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static List<TDest> Map<TSource, TDest>(
    DataTable tb
)
where TSource : DataTable
where TDest : class, new()

参数

tb
类型：System.DataDataTable
DataTabe数据对象

类型参数

TSource
约束DataTabe的行类型T类型
TDest
目标实体类对象T类型

返回值

类型：List TDest
TDest目标泛型List对象
参见

引用

ExtensiveHelper 类
Map 重载
Eson.Utils 命名空间


ExtensiveHelper.Map(TSource, TDest) 方法 (TSource)

ExtensiveHelperMapTSource, TDest 方法 (TSource)

将TSource类型的实体类对象转换为TDest类型的实体类对象

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static TDest Map<TSource, TDest>(
    TSource s
)
where TSource : class, new()
where TDest : class, new()

参数

s
类型：TSource
要转换的实体类对象

类型参数

TSource
要转换的实体类对象T类型
TDest
目标实体类对象T类型

返回值

类型：TDest
TDest目标实体类对象
参见

引用

ExtensiveHelper 类
Map 重载
Eson.Utils 命名空间


ExtensiveHelper.Map(TSource, TDest) 方法 (DataRow, DataColumnCollection)

ExtensiveHelperMapTSource, TDest 方法 (DataRow, DataColumnCollection)

将DataTable的行转换成TDest类型的泛型List对象

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static TDest Map<TSource, TDest>(
    DataRow row,
    DataColumnCollection columns
)
where TSource : DataRow
where TDest : class, new()

参数

row
类型：System.DataDataRow
DataTabe的行对象
columns
类型：System.DataDataColumnCollection
DataTabe的所有列数据

类型参数

TSource
约束DataTabe的行类型
TDest
目标实体类对象T类型

返回值

类型：TDest
TDest目标泛型List对象
参见

引用

ExtensiveHelper 类
Map 重载
Eson.Utils 命名空间


ExtensiveHelper.MapI(TSource, TDest) 方法

ExtensiveHelperMapITSource, TDest 方法

将TSource类型的实体类泛型List对象转换为TDest类型的泛型List对象

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static IList<TDest> MapI<TSource, TDest>(
    IList<TSource> ISList
)
where TSource : class, new()
where TDest : class, new()

参数

ISList
类型：System.Collections.GenericIList TSource
要转换的泛型List对象

类型参数

TSource
要转换的实体类对象T类型
TDest
目标实体类对象T类型

返回值

类型：IList TDest
TDest目标泛型List对象
参见

引用

ExtensiveHelper 类
Eson.Utils 命名空间


FileUpLoadMsgInfo 类

文件上传操作结果返回类
继承层次
SystemObject
Eson.UtilsFileUpLoadMsgInfo

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class FileUpLoadMsgInfo

FileUpLoadMsgInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FileUpLoadMsgInfo | 初始化 FileUpLoadMsgInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | FilePath | 上传好的文件路径
公共属性 | IsSuccess | 是否上传成功
公共属性 | Msg | 消息
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Eson.Utils 命名空间


FileUpLoadMsgInfo 构造函数

初始化 FileUpLoadMsgInfo 类的一个新实例

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public FileUpLoadMsgInfo()
参见

引用

FileUpLoadMsgInfo 类
Eson.Utils 命名空间


FileUpLoadMsgInfo 属性

FileUpLoadMsgInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | FilePath | 上传好的文件路径
公共属性 | IsSuccess | 是否上传成功
公共属性 | Msg | 消息
Top
参见

引用

FileUpLoadMsgInfo 类
Eson.Utils 命名空间


FileUpLoadMsgInfo.FilePath 属性

FileUpLoadMsgInfoFilePath 属性

上传好的文件路径

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string FilePath { get; set; }

属性值

类型：String
参见

引用

FileUpLoadMsgInfo 类
Eson.Utils 命名空间


FileUpLoadMsgInfo.IsSuccess 属性

FileUpLoadMsgInfoIsSuccess 属性

是否上传成功

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool IsSuccess { get; set; }

属性值

类型：Boolean
参见

引用

FileUpLoadMsgInfo 类
Eson.Utils 命名空间


FileUpLoadMsgInfo.Msg 属性

FileUpLoadMsgInfoMsg 属性

消息

命名空间： Eson.Utils
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Msg { get; set; }

属性值

类型：String
参见

引用

FileUpLoadMsgInfo 类
Eson.Utils 命名空间


FileUpLoadMsgInfo 方法

FileUpLoadMsgInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

FileUpLoadMsgInfo 类
Eson.Utils 命名空间


Eson.Utils.ExcelHelper 命名空间

[缺少 "N:Eson.Utils.ExcelHelper" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | ExcelFileExport | 导出Excel帮助类(文件模板形式，特殊样式时，可自己设置模板)
公共类 | ExcelHelper | Excel导出帮助类
公共类 | ExcelStream |
公共类 | ExcelStreamExport | 导出Excel帮助类(内存流形式)


ExcelFileExport 类

导出Excel帮助类(文件模板形式，特殊样式时，可自己设置模板)
继承层次
SystemObject
Eson.Utils.ExcelHelperExcelFileExport

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ExcelFileExport

ExcelFileExport 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExcelFileExport | 初始化 ExcelFileExport 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetColumValue | 通过提供的列名和具体行，返回DataTable中具体的某一列的值
公共方法 | GetHashCode | (继承自 Object。)
 | GetInstance | 实例化导出Excel帮助类
公共方法 | GetSheetByIndex | 按序号打开工作表(Sheet)
公共方法 | GetSheetByName | 按名称打开工作表(Sheet)
公共方法 | GetSheetFromExcel | 初始化工作簿，自动打开第intSheetIndex个Sheet（intSheetIndex默认为0）
公共方法 | GetType | (继承自 Object。)
公共方法 | InitializeWorkbook | 初始化工作簿(Book)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteToFile | 将工作簿写入文件 如果目标文件已经存在，先删除
Top
字段
 | 名称 | 说明
公共字段 | workBook |
公共字段 | workSheet |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Eson.Utils.ExcelHelper 命名空间


ExcelFileExport 构造函数

初始化 ExcelFileExport 类的一个新实例

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExcelFileExport()
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport 方法

ExcelFileExport 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetColumValue | 通过提供的列名和具体行，返回DataTable中具体的某一列的值
公共方法 | GetHashCode | (继承自 Object。)
 | GetInstance | 实例化导出Excel帮助类
公共方法 | GetSheetByIndex | 按序号打开工作表(Sheet)
公共方法 | GetSheetByName | 按名称打开工作表(Sheet)
公共方法 | GetSheetFromExcel | 初始化工作簿，自动打开第intSheetIndex个Sheet（intSheetIndex默认为0）
公共方法 | GetType | (继承自 Object。)
公共方法 | InitializeWorkbook | 初始化工作簿(Book)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteToFile | 将工作簿写入文件 如果目标文件已经存在，先删除
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport.GetColumValue 方法

ExcelFileExportGetColumValue 方法

通过提供的列名和具体行，返回DataTable中具体的某一列的值

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetColumValue(
    DataTable dtbl,
    DataRow rowInfo,
    string columName
)

参数

dtbl
类型：System.DataDataTable
内存表
rowInfo
类型：System.DataDataRow
具体行
columName
类型：SystemString
列名

返回值

类型：String
具体某列的值
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport.GetInstance 方法

ExcelFileExportGetInstance 方法

实例化导出Excel帮助类

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ExcelFileExport GetInstance()

返回值

类型：ExcelFileExport
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport.GetSheetByIndex 方法

ExcelFileExportGetSheetByIndex 方法

按序号打开工作表(Sheet)

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void GetSheetByIndex(
    int? intSheetIndex
)

参数

intSheetIndex
类型：SystemNullable Int32
工作表序号，为空时默认第一个工作表
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport.GetSheetByName 方法

ExcelFileExportGetSheetByName 方法

按名称打开工作表(Sheet)

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void GetSheetByName(
    string strSheetName
)

参数

strSheetName
类型：SystemString
工作表名称
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport.GetSheetFromExcel 方法

ExcelFileExportGetSheetFromExcel 方法

初始化工作簿，自动打开第intSheetIndex个Sheet（intSheetIndex默认为0）

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void GetSheetFromExcel(
    string strExcelFilePath,
    int? intSheetIndex,
    bool is07Excel
)

参数

strExcelFilePath
类型：SystemString
原Excel文件路径
intSheetIndex
类型：SystemNullable Int32
第几个Sheet，默认为0
is07Excel
类型：SystemBoolean
是否导出2007以上版本的Excel
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport.InitializeWorkbook 方法

ExcelFileExportInitializeWorkbook 方法

初始化工作簿(Book)

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void InitializeWorkbook(
    string strSaveName,
    bool is07Excel
)

参数

strSaveName
类型：SystemString
文件名称，也作为工作簿名称
is07Excel
类型：SystemBoolean
是否导出2007以上版本的Excel
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport.WriteToFile 方法

ExcelFileExportWriteToFile 方法

将工作簿写入文件 如果目标文件已经存在，先删除

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void WriteToFile(
    string strSaveFilePath
)

参数

strSaveFilePath
类型：SystemString
要保存的文件地址
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport 字段

ExcelFileExport 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | workBook |
公共字段 | workSheet |
Top
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport.workBook 字段

ExcelFileExportworkBook 字段

[缺少 "F:Eson.Utils.ExcelHelper.ExcelFileExport.workBook" 的 <summary> 文档]

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public IWorkbook workBook

字段值

类型：IWorkbook
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelFileExport.workSheet 字段

ExcelFileExportworkSheet 字段

[缺少 "F:Eson.Utils.ExcelHelper.ExcelFileExport.workSheet" 的 <summary> 文档]

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ISheet workSheet

字段值

类型：ISheet
参见

引用

ExcelFileExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelHelper 类

Excel导出帮助类
继承层次
SystemObject
Eson.Utils.ExcelHelperExcelHelper

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ExcelHelper

ExcelHelper 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExcelHelper | 初始化 ExcelHelper 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
公共方法 | ExportWithFile | 调用Excel模板形式导出Excel（在需要特殊样式时可使用自己设置好样式的模板导出Excel，通常情况下建议使用内存流形式导出）
公共方法 | ExportWithStream | 调用内存流形式导出Excel
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetInstance | 实例化导出Excel帮助类
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Eson.Utils.ExcelHelper 命名空间


ExcelHelper 构造函数

初始化 ExcelHelper 类的一个新实例

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExcelHelper()
参见

引用

ExcelHelper 类
Eson.Utils.ExcelHelper 命名空间


ExcelHelper 方法

ExcelHelper 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
公共方法 | ExportWithFile | 调用Excel模板形式导出Excel（在需要特殊样式时可使用自己设置好样式的模板导出Excel，通常情况下建议使用内存流形式导出）
公共方法 | ExportWithStream | 调用内存流形式导出Excel
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
 | GetInstance | 实例化导出Excel帮助类
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ExcelHelper 类
Eson.Utils.ExcelHelper 命名空间


ExcelHelper.ExportWithFile 方法

ExcelHelperExportWithFile 方法

调用Excel模板形式导出Excel（在需要特殊样式时可使用自己设置好样式的模板导出Excel，通常情况下建议使用内存流形式导出）

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExcelFileExport ExportWithFile()

返回值

类型：ExcelFileExport
参见

引用

ExcelHelper 类
Eson.Utils.ExcelHelper 命名空间


ExcelHelper.ExportWithStream 方法

ExcelHelperExportWithStream 方法

调用内存流形式导出Excel

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExcelStreamExport ExportWithStream()

返回值

类型：ExcelStreamExport
参见

引用

ExcelHelper 类
Eson.Utils.ExcelHelper 命名空间


ExcelHelper.GetInstance 方法

ExcelHelperGetInstance 方法

实例化导出Excel帮助类

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ExcelHelper GetInstance()

返回值

类型：ExcelHelper
参见

引用

ExcelHelper 类
Eson.Utils.ExcelHelper 命名空间


ExcelStream 类

[缺少 "T:Eson.Utils.ExcelHelper.ExcelStream" 的 <summary> 文档]

继承层次
SystemObject
Eson.Utils.ExcelHelperExcelStream

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public sealed class ExcelStream : IDisposable

ExcelStream 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExcelStream | 初始化 ExcelStream 类的一个新实例
公共方法 | ExcelStream(String, Boolean) | 初始化 ExcelStream 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Dispose | 释放被 ExcelStream 使用的所有资源
公共方法 | Equals | (继承自 Object。)
公共方法 | GetColumValue | 通过提供的列名和具体行，返回DataTable中具体的某一列的值
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
字段
 | 名称 | 说明
公共字段 | workBook |
公共字段 | workSheet |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Eson.Utils.ExcelHelper 命名空间


ExcelStream 构造函数

重载列表
 | 名称 | 说明
公共方法 | ExcelStream | 初始化 ExcelStream 类的一个新实例
公共方法 | ExcelStream(String, Boolean) | 初始化 ExcelStream 类的一个新实例
Top
参见

引用

ExcelStream 类
Eson.Utils.ExcelHelper 命名空间


ExcelStream 构造函数

初始化 ExcelStream 类的一个新实例

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExcelStream()
参见

引用

ExcelStream 类
ExcelStream 重载
Eson.Utils.ExcelHelper 命名空间


ExcelStream 构造函数 (String, Boolean)

初始化 ExcelStream 类的一个新实例

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExcelStream(
    string sheetname,
    bool is07Excel
)

参数

sheetname
类型：SystemString

[缺少 "M:Eson.Utils.ExcelHelper.ExcelStream.#ctor(System.String,System.Boolean)" 的 <param name="sheetname"/> 文档]

is07Excel
类型：SystemBoolean

[缺少 "M:Eson.Utils.ExcelHelper.ExcelStream.#ctor(System.String,System.Boolean)" 的 <param name="is07Excel"/> 文档]

参见

引用

ExcelStream 类
ExcelStream 重载
Eson.Utils.ExcelHelper 命名空间


ExcelStream 方法

ExcelStream 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Dispose |
公共方法 | Equals | (继承自 Object。)
公共方法 | GetColumValue | 通过提供的列名和具体行，返回DataTable中具体的某一列的值
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ExcelStream 类
Eson.Utils.ExcelHelper 命名空间


ExcelStream.Dispose 方法

ExcelStreamDispose 方法

释放被 ExcelStream 使用的所有资源

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Dispose()

实现

IDisposableDispose
参见

引用

ExcelStream 类
Eson.Utils.ExcelHelper 命名空间


ExcelStream.GetColumValue 方法

ExcelStreamGetColumValue 方法

通过提供的列名和具体行，返回DataTable中具体的某一列的值

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetColumValue(
    DataTable dtbl,
    DataRow rowInfo,
    string columName
)

参数

dtbl
类型：System.DataDataTable
内存表
rowInfo
类型：System.DataDataRow
具体行
columName
类型：SystemString
列名

返回值

类型：String
具体某列的值
参见

引用

ExcelStream 类
Eson.Utils.ExcelHelper 命名空间


ExcelStream 字段

ExcelStream 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | workBook |
公共字段 | workSheet |
Top
参见

引用

ExcelStream 类
Eson.Utils.ExcelHelper 命名空间


ExcelStream.workBook 字段

ExcelStreamworkBook 字段

[缺少 "F:Eson.Utils.ExcelHelper.ExcelStream.workBook" 的 <summary> 文档]

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public IWorkbook workBook

字段值

类型：IWorkbook
参见

引用

ExcelStream 类
Eson.Utils.ExcelHelper 命名空间


ExcelStream.workSheet 字段

ExcelStreamworkSheet 字段

[缺少 "F:Eson.Utils.ExcelHelper.ExcelStream.workSheet" 的 <summary> 文档]

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ISheet workSheet

字段值

类型：ISheet
参见

引用

ExcelStream 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport 类

导出Excel帮助类(内存流形式)
继承层次
SystemObject
Eson.Utils.ExcelHelperExcelStreamExport

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class ExcelStreamExport

ExcelStreamExport 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExcelStreamExport | 初始化 ExcelStreamExport 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | ConvertExcelToTable | 将Excel2007以上版本文件中的数据读出到DataTable中(xlsx)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetColumValue | 通过提供的列名和具体行，返回DataTable中具体的某一列的值
公共方法 | GetHashCode | (继承自 Object。)
 | GetInstance | 实例化导出Excel帮助类
公共方法 | GetSheetByIndex | 按序号打开工作表(Sheet)
公共方法 | GetSheetByName | 按名称打开工作表(Sheet)
公共方法 | GetSheetFromExcel | 初始化工作簿，自动打开第intSheetIndex个Sheet（intSheetIndex默认为0）
公共方法 | GetType | (继承自 Object。)
公共方法 | InitializeWorkbook | 初始化工作簿(Book)
公共方法 | InitializeWorkSheet | 初始化工作簿(Book)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteToFile | 将工作簿写入文件 如果目标文件已经存在，先删除
Top
字段
 | 名称 | 说明
公共字段 | ms |
公共字段 | workBook |
公共字段 | workSheet |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport 构造函数

初始化 ExcelStreamExport 类的一个新实例

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ExcelStreamExport()
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport 方法

ExcelStreamExport 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ConvertExcelToTable | 将Excel2007以上版本文件中的数据读出到DataTable中(xlsx)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetColumValue | 通过提供的列名和具体行，返回DataTable中具体的某一列的值
公共方法 | GetHashCode | (继承自 Object。)
 | GetInstance | 实例化导出Excel帮助类
公共方法 | GetSheetByIndex | 按序号打开工作表(Sheet)
公共方法 | GetSheetByName | 按名称打开工作表(Sheet)
公共方法 | GetSheetFromExcel | 初始化工作簿，自动打开第intSheetIndex个Sheet（intSheetIndex默认为0）
公共方法 | GetType | (继承自 Object。)
公共方法 | InitializeWorkbook | 初始化工作簿(Book)
公共方法 | InitializeWorkSheet | 初始化工作簿(Book)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | WriteToFile | 将工作簿写入文件 如果目标文件已经存在，先删除
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.ConvertExcelToTable 方法

ExcelStreamExportConvertExcelToTable 方法

将Excel2007以上版本文件中的数据读出到DataTable中(xlsx)

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public DataTable ConvertExcelToTable(
    string filePath,
    int sheetIndex = 0
)

参数

filePath
类型：SystemString
Excel2007版本以上文件地址
sheetIndex (Optional)
类型：SystemInt32
需读取Sheet的Index，Sheet1的index是0，默认0

返回值

类型：DataTable
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.GetColumValue 方法

ExcelStreamExportGetColumValue 方法

通过提供的列名和具体行，返回DataTable中具体的某一列的值

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string GetColumValue(
    DataTable dtbl,
    DataRow rowInfo,
    string columName
)

参数

dtbl
类型：System.DataDataTable
内存表
rowInfo
类型：System.DataDataRow
具体行
columName
类型：SystemString
列名

返回值

类型：String
具体某列的值
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.GetInstance 方法

ExcelStreamExportGetInstance 方法

实例化导出Excel帮助类

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ExcelStreamExport GetInstance()

返回值

类型：ExcelStreamExport
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.GetSheetByIndex 方法

ExcelStreamExportGetSheetByIndex 方法

按序号打开工作表(Sheet)

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void GetSheetByIndex(
    int? intSheetIndex
)

参数

intSheetIndex
类型：SystemNullable Int32
工作表序号，为空时默认第一个工作表
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.GetSheetByName 方法

ExcelStreamExportGetSheetByName 方法

按名称打开工作表(Sheet)

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void GetSheetByName(
    string strSheetName
)

参数

strSheetName
类型：SystemString
工作表名称
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.GetSheetFromExcel 方法

ExcelStreamExportGetSheetFromExcel 方法

初始化工作簿，自动打开第intSheetIndex个Sheet（intSheetIndex默认为0）

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void GetSheetFromExcel(
    string strExcelFilePath,
    int? intSheetIndex,
    bool is07Excel
)

参数

strExcelFilePath
类型：SystemString
原Excel文件路径
intSheetIndex
类型：SystemNullable Int32
第几个Sheet，默认为0
is07Excel
类型：SystemBoolean
是否导出2007以上版本的Excel
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.InitializeWorkbook 方法

ExcelStreamExportInitializeWorkbook 方法

初始化工作簿(Book)

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void InitializeWorkbook(
    string strSaveName,
    bool is07Excel
)

参数

strSaveName
类型：SystemString
文件名称，也作为工作簿名称
is07Excel
类型：SystemBoolean
是否导出2007以上版本的Excel
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.InitializeWorkSheet 方法

ExcelStreamExportInitializeWorkSheet 方法

初始化工作簿(Book)

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void InitializeWorkSheet(
    string strSaveName,
    bool is07Excel = true,
    bool isFirstCreateSheet = true
)

参数

strSaveName
类型：SystemString
文件名称，也作为工作簿名称
is07Excel (Optional)
类型：SystemBoolean
是否导出2007以上版本的Excel(默认是)
isFirstCreateSheet (Optional)
类型：SystemBoolean
是否第一次创建Excel的Sheet页（默认是）
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.WriteToFile 方法

ExcelStreamExportWriteToFile 方法

将工作簿写入文件 如果目标文件已经存在，先删除

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void WriteToFile(
    string strSaveFilePath
)

参数

strSaveFilePath
类型：SystemString
要保存的文件地址
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport 字段

ExcelStreamExport 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | ms |
公共字段 | workBook |
公共字段 | workSheet |
Top
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.ms 字段

ExcelStreamExportms 字段

[缺少 "F:Eson.Utils.ExcelHelper.ExcelStreamExport.ms" 的 <summary> 文档]

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public MemoryStream ms

字段值

类型：MemoryStream
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.workBook 字段

ExcelStreamExportworkBook 字段

[缺少 "F:Eson.Utils.ExcelHelper.ExcelStreamExport.workBook" 的 <summary> 文档]

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public IWorkbook workBook

字段值

类型：IWorkbook
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


ExcelStreamExport.workSheet 字段

ExcelStreamExportworkSheet 字段

[缺少 "F:Eson.Utils.ExcelHelper.ExcelStreamExport.workSheet" 的 <summary> 文档]

命名空间： Eson.Utils.ExcelHelper
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ISheet workSheet

字段值

类型：ISheet
参见

引用

ExcelStreamExport 类
Eson.Utils.ExcelHelper 命名空间


PcLogger 命名空间

[缺少 "N:PcLogger" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | smsCode | 阿里妈妈扫码协议登录验证码


smsCode 类

阿里妈妈扫码协议登录验证码
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
PcLoggersmsCode

命名空间： PcLogger
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class smsCode : Form

smsCode 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | smsCode | 初始化 smsCode 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 Form。)
公共属性 | BackgroundImage | (继承自 Control。)
公共属性 | BackgroundImageLayout | (继承自 Control。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 Form。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 Control。)
受保护的属性 | FontHeight | (继承自 Control。)
公共属性 | ForeColor | (继承自 Control。)
公共属性 | FormBorderStyle | (继承自 Form。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | Icon | (继承自 Form。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 Form。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 Form。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 Control。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | sms |
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 Form。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
公共方法 | Close | (继承自 Form。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 Form。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 Form。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 FormDispose(Boolean).)
公共方法 | DoDragDrop | (继承自 Control。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
公共方法 | GetContainerControl | (继承自 Control。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 Form。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 Control。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 Form。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 Form。)
受保护的方法 | OnHandleDestroyed | (继承自 Form。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 Form。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 Form。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumSizeChanged | (继承自 Form。)
受保护的方法 | OnMdiChildActivate | (继承自 Form。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumSizeChanged | (继承自 Form。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 ScrollableControl。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 Form。)
受保护的方法 | OnPaintBackground | (继承自 ScrollableControl。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 ContainerControl。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShown | (继承自 Form。)
受保护的方法 | OnSizeChanged | (继承自 Control。)
受保护的方法 | OnStyleChanged | (继承自 Form。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 Form。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 Control。)
公共方法 | ResumeLayout(Boolean) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 Form。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 Form。)
受保护的方法 | SetClientSizeCore | (继承自 Form。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 Form。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 Form。)
受保护的方法 | SizeFromClientSize | (继承自 Control。)
公共方法 | SuspendLayout | (继承自 Control。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 Form。)
Top
事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

PcLogger 命名空间


smsCode 构造函数

初始化 smsCode 类的一个新实例

命名空间： PcLogger
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public smsCode()
参见

引用

smsCode 类
PcLogger 命名空间


smsCode 属性

smsCode 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptButton | (继承自 Form。)
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | ActiveMdiChild | (继承自 Form。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | AllowTransparency | (继承自 Form。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 Form。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 Form。)
公共属性 | AutoSizeMode | (继承自 Form。)
公共属性 | AutoValidate | (继承自 Form。)
公共属性 | BackColor | (继承自 Form。)
公共属性 | BackgroundImage | (继承自 Control。)
公共属性 | BackgroundImageLayout | (继承自 Control。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
公共属性 | CancelButton | (继承自 Form。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Form。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | ControlBox | (继承自 Form。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 Form。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Form。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 Form。)
受保护的属性 | DesignMode | (继承自 Component。)
公共属性 | DesktopBounds | (继承自 Form。)
公共属性 | DesktopLocation | (继承自 Form。)
公共属性 | DialogResult | (继承自 Form。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 Control。)
受保护的属性 | FontHeight | (继承自 Control。)
公共属性 | ForeColor | (继承自 Control。)
公共属性 | FormBorderStyle | (继承自 Form。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HelpButton | (继承自 Form。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | Icon | (继承自 Form。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
公共属性 | IsMdiChild | (继承自 Form。)
公共属性 | IsMdiContainer | (继承自 Form。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | IsRestrictedWindow | (继承自 Form。)
公共属性 | KeyPreview | (继承自 Form。)
公共属性 | LayoutEngine | (继承自 Control。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Form。)
公共属性 | MainMenuStrip | (继承自 Form。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximizeBox | (继承自 Form。)
受保护的属性 | MaximizedBounds | (继承自 Form。)
公共属性 | MaximumSize | (继承自 Form。)
公共属性 | MdiChildren | (继承自 Form。)
公共属性 | MdiParent | (继承自 Form。)
公共属性 | Menu | (继承自 Form。)
公共属性 | MergedMenu | (继承自 Form。)
公共属性 | MinimizeBox | (继承自 Form。)
公共属性 | MinimumSize | (继承自 Form。)
公共属性 | Modal | (继承自 Form。)
公共属性 | Name | (继承自 Control。)
公共属性 | Opacity | (继承自 Form。)
公共属性 | OwnedForms | (继承自 Form。)
公共属性 | Owner | (继承自 Form。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | RestoreBounds | (继承自 Form。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
公共属性 | RightToLeftLayout | (继承自 Form。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
公共属性 | ShowIcon | (继承自 Form。)
公共属性 | ShowInTaskbar | (继承自 Form。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
受保护的属性 | ShowWithoutActivation | (继承自 Form。)
公共属性 | Site | (继承自 Control。)
公共属性 | Size | (继承自 Form。)
公共属性 | SizeGripStyle | (继承自 Form。)
公共属性 | sms |
公共属性 | StartPosition | (继承自 Form。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Text | (继承自 Form。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevel | (继承自 Form。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | TopMost | (继承自 Form。)
公共属性 | TransparencyKey | (继承自 Form。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
公共属性 | WindowState | (继承自 Form。)
Top
参见

引用

smsCode 类
PcLogger 命名空间


smsCode.sms 属性

smsCodesms 属性

[缺少 "P:PcLogger.smsCode.sms" 的 <summary> 文档]

命名空间： PcLogger
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string sms { get; set; }

属性值

类型：String
参见

引用

smsCode 类
PcLogger 命名空间


smsCode 方法

smsCode 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
公共方法 | Activate | (继承自 Form。)
受保护的方法 | ActivateMdiChild | (继承自 Form。)
公共方法 | AddOwnedForm | (继承自 Form。)
受保护的方法 | AdjustFormScrollbars | (继承自 Form。)
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
受保护的方法 | CenterToParent | (继承自 Form。)
受保护的方法 | CenterToScreen | (继承自 Form。)
公共方法 | Close | (继承自 Form。)
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 Form。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 Form。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | DefWndProc | (继承自 Form。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 FormDispose(Boolean).)
公共方法 | DoDragDrop | (继承自 Control。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
公共方法 | GetContainerControl | (继承自 Control。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 Form。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetStyle | (继承自 Control。)
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
公共方法 | LayoutMdi | (继承自 Form。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnActivated | (继承自 Form。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Form。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Form。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 Control。)
受保护的方法 | OnClosed | (继承自 Form。)
受保护的方法 | OnClosing | (继承自 Form。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 Form。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDeactivate | (继承自 Form。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Form。)
受保护的方法 | OnEnter | (继承自 Form。)
受保护的方法 | OnFontChanged | (继承自 Form。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnFormClosed | (继承自 Form。)
受保护的方法 | OnFormClosing | (继承自 Form。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 Form。)
受保护的方法 | OnHandleDestroyed | (继承自 Form。)
受保护的方法 | OnHelpButtonClicked | (继承自 Form。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInputLanguageChanged | (继承自 Form。)
受保护的方法 | OnInputLanguageChanging | (继承自 Form。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 Form。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 Form。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMaximizedBoundsChanged | (继承自 Form。)
受保护的方法 | OnMaximumSizeChanged | (继承自 Form。)
受保护的方法 | OnMdiChildActivate | (继承自 Form。)
受保护的方法 | OnMenuComplete | (继承自 Form。)
受保护的方法 | OnMenuStart | (继承自 Form。)
受保护的方法 | OnMinimumSizeChanged | (继承自 Form。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 Control。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 ScrollableControl。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 Form。)
受保护的方法 | OnPaintBackground | (继承自 ScrollableControl。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 ContainerControl。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 Form。)
受保护的方法 | OnResizeBegin | (继承自 Form。)
受保护的方法 | OnResizeEnd | (继承自 Form。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnRightToLeftLayoutChanged | (继承自 Form。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnShown | (继承自 Form。)
受保护的方法 | OnSizeChanged | (继承自 Control。)
受保护的方法 | OnStyleChanged | (继承自 Form。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 Form。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 Form。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 Form。)
受保护的方法 | ProcessDialogChar | (继承自 Form。)
受保护的方法 | ProcessDialogKey | (继承自 Form。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Form。)
受保护的方法 | ProcessMnemonic | (继承自 Form。)
受保护的方法 | ProcessTabKey | (继承自 Form。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
公共方法 | RemoveOwnedForm | (继承自 Form。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 Control。)
公共方法 | ResumeLayout(Boolean) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 Form。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 Form。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 Form。)
受保护的方法 | SetClientSizeCore | (继承自 Form。)
公共方法 | SetDesktopBounds | (继承自 Form。)
公共方法 | SetDesktopLocation | (继承自 Form。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 Form。)
公共方法 | Show | (继承自 Control。)
公共方法 | Show(IWin32Window) | (继承自 Form。)
公共方法 | ShowDialog | (继承自 Form。)
公共方法 | ShowDialog(IWin32Window) | (继承自 Form。)
受保护的方法 | SizeFromClientSize | (继承自 Control。)
公共方法 | SuspendLayout | (继承自 Control。)
公共方法 | ToString | (继承自 Form。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateDefaultButton | (继承自 Form。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 Form。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 Form。)
受保护的方法 | WndProc | (继承自 Form。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

smsCode 类
PcLogger 命名空间


smsCode.Dispose 方法

smsCodeDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | Clean up any resources being used. (重写 FormDispose(Boolean).)
Top
参见

引用

smsCode 类
PcLogger 命名空间


smsCode.Dispose 方法 (Boolean)

smsCodeDispose 方法 (Boolean)

Clean up any resources being used.

命名空间： PcLogger
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
true if managed resources should be disposed; otherwise, false.
参见

引用

smsCode 类
Dispose 重载
PcLogger 命名空间


smsCode 事件

smsCode 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Activated | (继承自 Form。)
公共事件 | AutoSizeChanged | (继承自 Form。)
公共事件 | AutoValidateChanged | (继承自 Form。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Deactivate | (继承自 Form。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | FormClosed | (继承自 Form。)
公共事件 | FormClosing | (继承自 Form。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpButtonClicked | (继承自 Form。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | InputLanguageChanged | (继承自 Form。)
公共事件 | InputLanguageChanging | (继承自 Form。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 Form。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MaximizedBoundsChanged | (继承自 Form。)
公共事件 | MaximumSizeChanged | (继承自 Form。)
公共事件 | MdiChildActivate | (继承自 Form。)
公共事件 | MenuComplete | (继承自 Form。)
公共事件 | MenuStart | (继承自 Form。)
公共事件 | MinimumSizeChanged | (继承自 Form。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | ResizeBegin | (继承自 Form。)
公共事件 | ResizeEnd | (继承自 Form。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | RightToLeftLayoutChanged | (继承自 Form。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | Shown | (继承自 Form。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

smsCode 类
PcLogger 命名空间


WechatProto 命名空间

[缺少 "N:WechatProto" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | BaseMsg |
公共类 | User |
公共类 | Wechat |
公共类 | WechatWechatBase | Base class for server-side implementations of Wechat
公共类 | WechatWechatClient | Client for Wechat
公共类 | WechatMsg |
公共类 | WechatProtoReflection | Holder for reflection information generated from WechatProto.proto


BaseMsg 类

[缺少 "T:WechatProto.BaseMsg" 的 <summary> 文档]

继承层次
SystemObject
WechatProtoBaseMsg

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public sealed class BaseMsg : IMessage<BaseMsg>,
    IMessage, IEquatable<BaseMsg>, IDeepCloneable<BaseMsg>

BaseMsg 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BaseMsg | 初始化 BaseMsg 类的一个新实例
公共方法 | BaseMsg(BaseMsg) | 初始化 BaseMsg 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Cmd |
公共属性 | CmdUrl |
 | Descriptor |
公共属性 | LongHead |
公共属性 | LongHost |
 | Parser |
公共属性 | Payloads |
公共属性 | Playloadextend |
公共属性 | Ret |
公共属性 | ShortHost |
公共属性 | User |
Top
方法
 | 名称 | 说明
公共方法 | CalculateSize |
公共方法 | Clone |
公共方法 | Equals(Object) | (重写 ObjectEquals(Object).)
公共方法 | Equals(BaseMsg) |
公共方法 | GetHashCode | (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
公共方法 | MergeFrom(CodedInputStream) |
公共方法 | MergeFrom(BaseMsg) |
公共方法 | ToString | (重写 ObjectToString.)
公共方法 | WriteTo |
Top
字段
名称 | 说明
CmdFieldNumber | Field number for the "cmd" field.
CmdUrlFieldNumber | Field number for the "cmdUrl" field.
LongHeadFieldNumber | Field number for the "longHead" field.
LongHostFieldNumber | Field number for the "longHost" field.
PayloadsFieldNumber | Field number for the "payloads" field.
PlayloadextendFieldNumber | Field number for the "playloadextend" field.
RetFieldNumber | Field number for the "ret" field.
ShortHostFieldNumber | Field number for the "shortHost" field.
UserFieldNumber | Field number for the "user" field.
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatProto 命名空间


BaseMsg 构造函数

重载列表
 | 名称 | 说明
公共方法 | BaseMsg | 初始化 BaseMsg 类的一个新实例
公共方法 | BaseMsg(BaseMsg) | 初始化 BaseMsg 类的一个新实例
Top
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg 构造函数

初始化 BaseMsg 类的一个新实例

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BaseMsg()
参见

引用

BaseMsg 类
BaseMsg 重载
WechatProto 命名空间


BaseMsg 构造函数 (BaseMsg)

初始化 BaseMsg 类的一个新实例

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BaseMsg(
    BaseMsg other
)

参数

other
类型：WechatProtoBaseMsg

[缺少 "M:WechatProto.BaseMsg.#ctor(WechatProto.BaseMsg)" 的 <param name="other"/> 文档]

参见

引用

BaseMsg 类
BaseMsg 重载
WechatProto 命名空间


BaseMsg 属性

BaseMsg 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Cmd |
公共属性 | CmdUrl |
 | Descriptor |
公共属性 | LongHead |
公共属性 | LongHost |
 | Parser |
公共属性 | Payloads |
公共属性 | Playloadextend |
公共属性 | Ret |
公共属性 | ShortHost |
公共属性 | User |
Top
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.Cmd 属性

BaseMsgCmd 属性

[缺少 "P:WechatProto.BaseMsg.Cmd" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Cmd { get; set; }

属性值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.CmdUrl 属性

BaseMsgCmdUrl 属性

[缺少 "P:WechatProto.BaseMsg.CmdUrl" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string CmdUrl { get; set; }

属性值

类型：String
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.Descriptor 属性

BaseMsgDescriptor 属性

[缺少 "P:WechatProto.BaseMsg.Descriptor" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static MessageDescriptor Descriptor { get; }

属性值

类型：MessageDescriptor
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.LongHead 属性

BaseMsgLongHead 属性

[缺少 "P:WechatProto.BaseMsg.LongHead" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString LongHead { get; set; }

属性值

类型：ByteString
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.LongHost 属性

BaseMsgLongHost 属性

[缺少 "P:WechatProto.BaseMsg.LongHost" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string LongHost { get; set; }

属性值

类型：String
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.Parser 属性

BaseMsgParser 属性

[缺少 "P:WechatProto.BaseMsg.Parser" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static MessageParser<BaseMsg> Parser { get; }

属性值

类型：MessageParserBaseMsg
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.Payloads 属性

BaseMsgPayloads 属性

[缺少 "P:WechatProto.BaseMsg.Payloads" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString Payloads { get; set; }

属性值

类型：ByteString
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.Playloadextend 属性

BaseMsgPlayloadextend 属性

[缺少 "P:WechatProto.BaseMsg.Playloadextend" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString Playloadextend { get; set; }

属性值

类型：ByteString
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.Ret 属性

BaseMsgRet 属性

[缺少 "P:WechatProto.BaseMsg.Ret" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int Ret { get; set; }

属性值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.ShortHost 属性

BaseMsgShortHost 属性

[缺少 "P:WechatProto.BaseMsg.ShortHost" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string ShortHost { get; set; }

属性值

类型：String
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.User 属性

BaseMsgUser 属性

[缺少 "P:WechatProto.BaseMsg.User" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public User User { get; set; }

属性值

类型：User
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg 方法

BaseMsg 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CalculateSize |
公共方法 | Clone |
公共方法 | Equals(Object) | (重写 ObjectEquals(Object).)
公共方法 | Equals(BaseMsg) |
公共方法 | GetHashCode | (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
公共方法 | MergeFrom(CodedInputStream) |
公共方法 | MergeFrom(BaseMsg) |
公共方法 | ToString | (重写 ObjectToString.)
公共方法 | WriteTo |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.CalculateSize 方法

BaseMsgCalculateSize 方法

[缺少 "M:WechatProto.BaseMsg.CalculateSize" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int CalculateSize()

返回值

类型：Int32

实现

IMessage.CalculateSize
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.Clone 方法

BaseMsgClone 方法

[缺少 "M:WechatProto.BaseMsg.Clone" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BaseMsg Clone()

返回值

类型：BaseMsg

实现

IDeepCloneable.Clone
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.Equals 方法

BaseMsgEquals 方法

重载列表
 | 名称 | 说明
公共方法 | Equals(Object) | (重写 ObjectEquals(Object).)
公共方法 | Equals(BaseMsg) |
Top
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.Equals 方法 (Object)

BaseMsgEquals 方法 (Object)

[缺少 "M:WechatProto.BaseMsg.Equals(System.Object)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override bool Equals(
    Object other
)

参数

other
类型：SystemObject

[缺少 "M:WechatProto.BaseMsg.Equals(System.Object)" 的 <param name="other"/> 文档]

返回值

类型：Boolean
参见

引用

BaseMsg 类
Equals 重载
WechatProto 命名空间


BaseMsg.Equals 方法 (BaseMsg)

BaseMsgEquals 方法 (BaseMsg)

[缺少 "M:WechatProto.BaseMsg.Equals(WechatProto.BaseMsg)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Equals(
    BaseMsg other
)

参数

other
类型：WechatProtoBaseMsg

[缺少 "M:WechatProto.BaseMsg.Equals(WechatProto.BaseMsg)" 的 <param name="other"/> 文档]

返回值

类型：Boolean

实现

IEquatableTEquals(T)
参见

引用

BaseMsg 类
Equals 重载
WechatProto 命名空间


BaseMsg.GetHashCode 方法

BaseMsgGetHashCode 方法

[缺少 "M:WechatProto.BaseMsg.GetHashCode" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override int GetHashCode()

返回值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.MergeFrom 方法

BaseMsgMergeFrom 方法

重载列表
 | 名称 | 说明
公共方法 | MergeFrom(CodedInputStream) |
公共方法 | MergeFrom(BaseMsg) |
Top
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.MergeFrom 方法 (CodedInputStream)

BaseMsgMergeFrom 方法 (CodedInputStream)

[缺少 "M:WechatProto.BaseMsg.MergeFrom(Google.Protobuf.CodedInputStream)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void MergeFrom(
    CodedInputStream input
)

参数

input
类型：CodedInputStream

[缺少 "M:WechatProto.BaseMsg.MergeFrom(Google.Protobuf.CodedInputStream)" 的 <param name="input"/> 文档]

实现

IMessage.MergeFrom(CodedInputStream)
参见

引用

BaseMsg 类
MergeFrom 重载
WechatProto 命名空间


BaseMsg.MergeFrom 方法 (BaseMsg)

BaseMsgMergeFrom 方法 (BaseMsg)

[缺少 "M:WechatProto.BaseMsg.MergeFrom(WechatProto.BaseMsg)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void MergeFrom(
    BaseMsg other
)

参数

other
类型：WechatProtoBaseMsg

[缺少 "M:WechatProto.BaseMsg.MergeFrom(WechatProto.BaseMsg)" 的 <param name="other"/> 文档]

实现

IMessage.MergeFrom(UTP)
参见

引用

BaseMsg 类
MergeFrom 重载
WechatProto 命名空间


BaseMsg.ToString 方法

BaseMsgToString 方法

[缺少 "M:WechatProto.BaseMsg.ToString" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.WriteTo 方法

BaseMsgWriteTo 方法

[缺少 "M:WechatProto.BaseMsg.WriteTo(Google.Protobuf.CodedOutputStream)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void WriteTo(
    CodedOutputStream output
)

参数

output
类型：CodedOutputStream

[缺少 "M:WechatProto.BaseMsg.WriteTo(Google.Protobuf.CodedOutputStream)" 的 <param name="output"/> 文档]

实现

IMessage.WriteTo(CodedOutputStream)
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg 字段

BaseMsg 类型公开以下成员。

字段
名称 | 说明
CmdFieldNumber | Field number for the "cmd" field.
CmdUrlFieldNumber | Field number for the "cmdUrl" field.
LongHeadFieldNumber | Field number for the "longHead" field.
LongHostFieldNumber | Field number for the "longHost" field.
PayloadsFieldNumber | Field number for the "payloads" field.
PlayloadextendFieldNumber | Field number for the "playloadextend" field.
RetFieldNumber | Field number for the "ret" field.
ShortHostFieldNumber | Field number for the "shortHost" field.
UserFieldNumber | Field number for the "user" field.
Top
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.CmdFieldNumber 字段

BaseMsgCmdFieldNumber 字段

Field number for the "cmd" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int CmdFieldNumber = 2

字段值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.CmdUrlFieldNumber 字段

BaseMsgCmdUrlFieldNumber 字段

Field number for the "cmdUrl" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int CmdUrlFieldNumber = 3

字段值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.LongHeadFieldNumber 字段

BaseMsgLongHeadFieldNumber 字段

Field number for the "longHead" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int LongHeadFieldNumber = 7

字段值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.LongHostFieldNumber 字段

BaseMsgLongHostFieldNumber 字段

Field number for the "longHost" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int LongHostFieldNumber = 5

字段值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.PayloadsFieldNumber 字段

BaseMsgPayloadsFieldNumber 字段

Field number for the "payloads" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int PayloadsFieldNumber = 8

字段值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.PlayloadextendFieldNumber 字段

BaseMsgPlayloadextendFieldNumber 字段

Field number for the "playloadextend" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int PlayloadextendFieldNumber = 9

字段值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.RetFieldNumber 字段

BaseMsgRetFieldNumber 字段

Field number for the "ret" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int RetFieldNumber = 1

字段值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.ShortHostFieldNumber 字段

BaseMsgShortHostFieldNumber 字段

Field number for the "shortHost" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int ShortHostFieldNumber = 4

字段值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


BaseMsg.UserFieldNumber 字段

BaseMsgUserFieldNumber 字段

Field number for the "user" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int UserFieldNumber = 6

字段值

类型：Int32
参见

引用

BaseMsg 类
WechatProto 命名空间


User 类

[缺少 "T:WechatProto.User" 的 <summary> 文档]

继承层次
SystemObject
WechatProtoUser

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
[SerializableAttribute]
public sealed class User : IMessage<User>,
    IMessage, IEquatable<User>, IDeepCloneable<User>

User 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | User | 初始化 User 类的一个新实例
公共方法 | User(User) | 初始化 User 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AutoAuthKey |
公共属性 | Cookies |
公共属性 | CurrentsyncKey |
 | Descriptor |
公共属性 | DeviceId |
公共属性 | DeviceName |
公共属性 | DeviceType |
公共属性 | MaxSyncKey |
公共属性 | Nickname |
 | Parser |
公共属性 | SessionKey |
公共属性 | Uin |
公共属性 | Userame |
公共属性 | UserExt |
Top
方法
 | 名称 | 说明
公共方法 | CalculateSize |
公共方法 | Clone |
公共方法 | Equals(Object) | (重写 ObjectEquals(Object).)
公共方法 | Equals(User) |
公共方法 | GetHashCode | (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
公共方法 | MergeFrom(CodedInputStream) |
公共方法 | MergeFrom(User) |
公共方法 | ToString | (重写 ObjectToString.)
公共方法 | WriteTo |
Top
字段
名称 | 说明
AutoAuthKeyFieldNumber | Field number for the "autoAuthKey" field.
CookiesFieldNumber | Field number for the "cookies" field.
CurrentsyncKeyFieldNumber | Field number for the "currentsyncKey" field.
DeviceIdFieldNumber | Field number for the "deviceId" field.
DeviceNameFieldNumber | Field number for the "deviceName" field.
DeviceTypeFieldNumber | Field number for the "deviceType" field.
MaxSyncKeyFieldNumber | Field number for the "maxSyncKey" field.
NicknameFieldNumber | Field number for the "nickname" field.
SessionKeyFieldNumber | Field number for the "sessionKey" field.
UinFieldNumber | Field number for the "uin" field.
UserameFieldNumber | Field number for the "userame" field.
UserExtFieldNumber | Field number for the "userExt" field.
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatProto 命名空间


User 构造函数

重载列表
 | 名称 | 说明
公共方法 | User | 初始化 User 类的一个新实例
公共方法 | User(User) | 初始化 User 类的一个新实例
Top
参见

引用

User 类
WechatProto 命名空间


User 构造函数

初始化 User 类的一个新实例

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public User()
参见

引用

User 类
User 重载
WechatProto 命名空间


User 构造函数 (User)

初始化 User 类的一个新实例

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public User(
    User other
)

参数

other
类型：WechatProtoUser

[缺少 "M:WechatProto.User.#ctor(WechatProto.User)" 的 <param name="other"/> 文档]

参见

引用

User 类
User 重载
WechatProto 命名空间


User 属性

User 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AutoAuthKey |
公共属性 | Cookies |
公共属性 | CurrentsyncKey |
 | Descriptor |
公共属性 | DeviceId |
公共属性 | DeviceName |
公共属性 | DeviceType |
公共属性 | MaxSyncKey |
公共属性 | Nickname |
 | Parser |
公共属性 | SessionKey |
公共属性 | Uin |
公共属性 | Userame |
公共属性 | UserExt |
Top
参见

引用

User 类
WechatProto 命名空间


User.AutoAuthKey 属性

UserAutoAuthKey 属性

[缺少 "P:WechatProto.User.AutoAuthKey" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString AutoAuthKey { get; set; }

属性值

类型：ByteString
参见

引用

User 类
WechatProto 命名空间


User.Cookies 属性

UserCookies 属性

[缺少 "P:WechatProto.User.Cookies" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString Cookies { get; set; }

属性值

类型：ByteString
参见

引用

User 类
WechatProto 命名空间


User.CurrentsyncKey 属性

UserCurrentsyncKey 属性

[缺少 "P:WechatProto.User.CurrentsyncKey" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString CurrentsyncKey { get; set; }

属性值

类型：ByteString
参见

引用

User 类
WechatProto 命名空间


User.Descriptor 属性

UserDescriptor 属性

[缺少 "P:WechatProto.User.Descriptor" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static MessageDescriptor Descriptor { get; }

属性值

类型：MessageDescriptor
参见

引用

User 类
WechatProto 命名空间


User.DeviceId 属性

UserDeviceId 属性

[缺少 "P:WechatProto.User.DeviceId" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DeviceId { get; set; }

属性值

类型：String
参见

引用

User 类
WechatProto 命名空间


User.DeviceName 属性

UserDeviceName 属性

[缺少 "P:WechatProto.User.DeviceName" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DeviceName { get; set; }

属性值

类型：String
参见

引用

User 类
WechatProto 命名空间


User.DeviceType 属性

UserDeviceType 属性

[缺少 "P:WechatProto.User.DeviceType" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string DeviceType { get; set; }

属性值

类型：String
参见

引用

User 类
WechatProto 命名空间


User.MaxSyncKey 属性

UserMaxSyncKey 属性

[缺少 "P:WechatProto.User.MaxSyncKey" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString MaxSyncKey { get; set; }

属性值

类型：ByteString
参见

引用

User 类
WechatProto 命名空间


User.Nickname 属性

UserNickname 属性

[缺少 "P:WechatProto.User.Nickname" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString Nickname { get; set; }

属性值

类型：ByteString
参见

引用

User 类
WechatProto 命名空间


User.Parser 属性

UserParser 属性

[缺少 "P:WechatProto.User.Parser" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static MessageParser<User> Parser { get; }

属性值

类型：MessageParserUser
参见

引用

User 类
WechatProto 命名空间


User.SessionKey 属性

UserSessionKey 属性

[缺少 "P:WechatProto.User.SessionKey" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString SessionKey { get; set; }

属性值

类型：ByteString
参见

引用

User 类
WechatProto 命名空间


User.Uin 属性

UserUin 属性

[缺少 "P:WechatProto.User.Uin" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long Uin { get; set; }

属性值

类型：Int64
参见

引用

User 类
WechatProto 命名空间


User.Userame 属性

UserUserame 属性

[缺少 "P:WechatProto.User.Userame" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Userame { get; set; }

属性值

类型：String
参见

引用

User 类
WechatProto 命名空间


User.UserExt 属性

UserUserExt 属性

[缺少 "P:WechatProto.User.UserExt" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public ByteString UserExt { get; set; }

属性值

类型：ByteString
参见

引用

User 类
WechatProto 命名空间


User 方法

User 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CalculateSize |
公共方法 | Clone |
公共方法 | Equals(Object) | (重写 ObjectEquals(Object).)
公共方法 | Equals(User) |
公共方法 | GetHashCode | (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
公共方法 | MergeFrom(CodedInputStream) |
公共方法 | MergeFrom(User) |
公共方法 | ToString | (重写 ObjectToString.)
公共方法 | WriteTo |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

User 类
WechatProto 命名空间


User.CalculateSize 方法

UserCalculateSize 方法

[缺少 "M:WechatProto.User.CalculateSize" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int CalculateSize()

返回值

类型：Int32

实现

IMessage.CalculateSize
参见

引用

User 类
WechatProto 命名空间


User.Clone 方法

UserClone 方法

[缺少 "M:WechatProto.User.Clone" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public User Clone()

返回值

类型：User

实现

IDeepCloneable.Clone
参见

引用

User 类
WechatProto 命名空间


User.Equals 方法

UserEquals 方法

重载列表
 | 名称 | 说明
公共方法 | Equals(Object) | (重写 ObjectEquals(Object).)
公共方法 | Equals(User) |
Top
参见

引用

User 类
WechatProto 命名空间


User.Equals 方法 (Object)

UserEquals 方法 (Object)

[缺少 "M:WechatProto.User.Equals(System.Object)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override bool Equals(
    Object other
)

参数

other
类型：SystemObject

[缺少 "M:WechatProto.User.Equals(System.Object)" 的 <param name="other"/> 文档]

返回值

类型：Boolean
参见

引用

User 类
Equals 重载
WechatProto 命名空间


User.Equals 方法 (User)

UserEquals 方法 (User)

[缺少 "M:WechatProto.User.Equals(WechatProto.User)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Equals(
    User other
)

参数

other
类型：WechatProtoUser

[缺少 "M:WechatProto.User.Equals(WechatProto.User)" 的 <param name="other"/> 文档]

返回值

类型：Boolean

实现

IEquatableTEquals(T)
参见

引用

User 类
Equals 重载
WechatProto 命名空间


User.GetHashCode 方法

UserGetHashCode 方法

[缺少 "M:WechatProto.User.GetHashCode" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override int GetHashCode()

返回值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.MergeFrom 方法

UserMergeFrom 方法

重载列表
 | 名称 | 说明
公共方法 | MergeFrom(CodedInputStream) |
公共方法 | MergeFrom(User) |
Top
参见

引用

User 类
WechatProto 命名空间


User.MergeFrom 方法 (CodedInputStream)

UserMergeFrom 方法 (CodedInputStream)

[缺少 "M:WechatProto.User.MergeFrom(Google.Protobuf.CodedInputStream)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void MergeFrom(
    CodedInputStream input
)

参数

input
类型：CodedInputStream

[缺少 "M:WechatProto.User.MergeFrom(Google.Protobuf.CodedInputStream)" 的 <param name="input"/> 文档]

实现

IMessage.MergeFrom(CodedInputStream)
参见

引用

User 类
MergeFrom 重载
WechatProto 命名空间


User.MergeFrom 方法 (User)

UserMergeFrom 方法 (User)

[缺少 "M:WechatProto.User.MergeFrom(WechatProto.User)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void MergeFrom(
    User other
)

参数

other
类型：WechatProtoUser

[缺少 "M:WechatProto.User.MergeFrom(WechatProto.User)" 的 <param name="other"/> 文档]

实现

IMessage.MergeFrom(UTP)
参见

引用

User 类
MergeFrom 重载
WechatProto 命名空间


User.ToString 方法

UserToString 方法

[缺少 "M:WechatProto.User.ToString" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

User 类
WechatProto 命名空间


User.WriteTo 方法

UserWriteTo 方法

[缺少 "M:WechatProto.User.WriteTo(Google.Protobuf.CodedOutputStream)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void WriteTo(
    CodedOutputStream output
)

参数

output
类型：CodedOutputStream

[缺少 "M:WechatProto.User.WriteTo(Google.Protobuf.CodedOutputStream)" 的 <param name="output"/> 文档]

实现

IMessage.WriteTo(CodedOutputStream)
参见

引用

User 类
WechatProto 命名空间


User 字段

User 类型公开以下成员。

字段
名称 | 说明
AutoAuthKeyFieldNumber | Field number for the "autoAuthKey" field.
CookiesFieldNumber | Field number for the "cookies" field.
CurrentsyncKeyFieldNumber | Field number for the "currentsyncKey" field.
DeviceIdFieldNumber | Field number for the "deviceId" field.
DeviceNameFieldNumber | Field number for the "deviceName" field.
DeviceTypeFieldNumber | Field number for the "deviceType" field.
MaxSyncKeyFieldNumber | Field number for the "maxSyncKey" field.
NicknameFieldNumber | Field number for the "nickname" field.
SessionKeyFieldNumber | Field number for the "sessionKey" field.
UinFieldNumber | Field number for the "uin" field.
UserameFieldNumber | Field number for the "userame" field.
UserExtFieldNumber | Field number for the "userExt" field.
Top
参见

引用

User 类
WechatProto 命名空间


User.AutoAuthKeyFieldNumber 字段

UserAutoAuthKeyFieldNumber 字段

Field number for the "autoAuthKey" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int AutoAuthKeyFieldNumber = 9

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.CookiesFieldNumber 字段

UserCookiesFieldNumber 字段

Field number for the "cookies" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int CookiesFieldNumber = 2

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.CurrentsyncKeyFieldNumber 字段

UserCurrentsyncKeyFieldNumber 字段

Field number for the "currentsyncKey" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int CurrentsyncKeyFieldNumber = 7

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.DeviceIdFieldNumber 字段

UserDeviceIdFieldNumber 字段

Field number for the "deviceId" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int DeviceIdFieldNumber = 4

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.DeviceNameFieldNumber 字段

UserDeviceNameFieldNumber 字段

Field number for the "deviceName" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int DeviceNameFieldNumber = 6

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.DeviceTypeFieldNumber 字段

UserDeviceTypeFieldNumber 字段

Field number for the "deviceType" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int DeviceTypeFieldNumber = 5

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.MaxSyncKeyFieldNumber 字段

UserMaxSyncKeyFieldNumber 字段

Field number for the "maxSyncKey" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int MaxSyncKeyFieldNumber = 8

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.NicknameFieldNumber 字段

UserNicknameFieldNumber 字段

Field number for the "nickname" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int NicknameFieldNumber = 11

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.SessionKeyFieldNumber 字段

UserSessionKeyFieldNumber 字段

Field number for the "sessionKey" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int SessionKeyFieldNumber = 3

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.UinFieldNumber 字段

UserUinFieldNumber 字段

Field number for the "uin" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int UinFieldNumber = 1

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.UserameFieldNumber 字段

UserUserameFieldNumber 字段

Field number for the "userame" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int UserameFieldNumber = 10

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


User.UserExtFieldNumber 字段

UserUserExtFieldNumber 字段

Field number for the "userExt" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int UserExtFieldNumber = 12

字段值

类型：Int32
参见

引用

User 类
WechatProto 命名空间


Wechat 类

[缺少 "T:WechatProto.Wechat" 的 <summary> 文档]

继承层次
SystemObject
WechatProtoWechat

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class Wechat

Wechat 类型公开以下成员。

属性
名称 | 说明
Descriptor | Service descriptor
Top
方法
名称 | 说明
BindService | Creates service definition that can be registered with a server
Top
参见

引用

WechatProto 命名空间


Wechat 属性

Wechat 类型公开以下成员。

属性
名称 | 说明
Descriptor | Service descriptor
Top
参见

引用

Wechat 类
WechatProto 命名空间


Wechat.Descriptor 属性

WechatDescriptor 属性

Service descriptor

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ServiceDescriptor Descriptor { get; }

属性值

类型：ServiceDescriptor
参见

引用

Wechat 类
WechatProto 命名空间


Wechat 方法

Wechat 类型公开以下成员。

方法
名称 | 说明
BindService | Creates service definition that can be registered with a server
Top
参见

引用

Wechat 类
WechatProto 命名空间


Wechat.BindService 方法

WechatBindService 方法

Creates service definition that can be registered with a server

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static ServerServiceDefinition BindService(
    WechatWechatBase serviceImpl
)

参数

serviceImpl
类型：WechatProtoWechatWechatBase
An object implementing the server-side handling logic.

返回值

类型：ServerServiceDefinition
参见

引用

Wechat 类
WechatProto 命名空间


Wechat.WechatBase 类

WechatWechatBase 类

Base class for server-side implementations of Wechat
继承层次
SystemObject
WechatProtoWechatWechatBase

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public abstract class WechatBase

WechatWechatBase 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | WechatWechatBase | 初始化 WechatWechatBase 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | HelloWechat |
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatProto 命名空间


Wechat.WechatBase 构造函数

WechatWechatBase 构造函数

初始化 WechatWechatBase 类的一个新实例

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected WechatBase()
参见

引用

WechatWechatBase 类
WechatProto 命名空间


WechatBase 方法

WechatWechatBase 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | HelloWechat |
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatWechatBase 类
WechatProto 命名空间


Wechat.WechatBase.HelloWechat 方法

WechatWechatBaseHelloWechat 方法

[缺少 "M:WechatProto.Wechat.WechatBase.HelloWechat(WechatProto.WechatMsg,Grpc.Core.ServerCallContext)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual Task<WechatMsg> HelloWechat(
    WechatMsg request,
    ServerCallContext context
)

参数

request
类型：WechatProtoWechatMsg

[缺少 "M:WechatProto.Wechat.WechatBase.HelloWechat(WechatProto.WechatMsg,Grpc.Core.ServerCallContext)" 的 <param name="request"/> 文档]

context
类型：ServerCallContext

[缺少 "M:WechatProto.Wechat.WechatBase.HelloWechat(WechatProto.WechatMsg,Grpc.Core.ServerCallContext)" 的 <param name="context"/> 文档]

返回值

类型：Task WechatMsg
参见

引用

WechatWechatBase 类
WechatProto 命名空间


Wechat.WechatClient 类

WechatWechatClient 类

Client for Wechat
继承层次
SystemObject
ClientBase
ClientBaseWechatWechatClient
WechatProtoWechatWechatClient

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class WechatClient : ClientBase<WechatWechatClient>

WechatWechatClient 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | WechatWechatClient | Protected parameterless constructor to allow creation of test doubles.
公共方法 | WechatWechatClient(CallInvoker) | Creates a new client for Wechat that uses a custom CallInvoker.
公共方法 | WechatWechatClient(Channel) | Creates a new client for Wechat
受保护的方法 | WechatWechatClient(ClientBaseConfiguration) | Protected constructor to allow creation of configured clients.
Top
属性
 | 名称 | 说明
受保护的属性 | CallInvoker | (继承自 ClientBase。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | HelloWechat(WechatMsg, CallOptions) |
公共方法 | HelloWechat(WechatMsg, Metadata, NullableDateTime, CancellationToken) |
公共方法 | HelloWechatAsync(WechatMsg, CallOptions) |
公共方法 | HelloWechatAsync(WechatMsg, Metadata, NullableDateTime, CancellationToken) |
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | NewInstance | Creates a new instance of client from given ClientBaseConfiguration. (重写 ClientBase.NewInstance(ClientBaseConfiguration).)
公共方法 | ToString | (继承自 Object。)
公共方法 | WithHost | (继承自 ClientBaseWechatWechatClient。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatProto 命名空间


WechatClient 构造函数

重载列表
 | 名称 | 说明
受保护的方法 | WechatWechatClient | Protected parameterless constructor to allow creation of test doubles.
公共方法 | WechatWechatClient(CallInvoker) | Creates a new client for Wechat that uses a custom CallInvoker.
公共方法 | WechatWechatClient(Channel) | Creates a new client for Wechat
受保护的方法 | WechatWechatClient(ClientBaseConfiguration) | Protected constructor to allow creation of configured clients.
Top
参见

引用

WechatWechatClient 类
WechatProto 命名空间


Wechat.WechatClient 构造函数

WechatWechatClient 构造函数

Protected parameterless constructor to allow creation of test doubles.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected WechatClient()
参见

引用

WechatWechatClient 类
WechatWechatClient 重载
WechatProto 命名空间


Wechat.WechatClient 构造函数 (CallInvoker)

WechatWechatClient 构造函数 (CallInvoker)

Creates a new client for Wechat that uses a custom CallInvoker.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatClient(
    CallInvoker callInvoker
)

参数

callInvoker
类型：CallInvoker
The callInvoker to use to make remote calls.
参见

引用

WechatWechatClient 类
WechatWechatClient 重载
WechatProto 命名空间


Wechat.WechatClient 构造函数 (Channel)

WechatWechatClient 构造函数 (Channel)

Creates a new client for Wechat

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatClient(
    Channel channel
)

参数

channel
类型：Channel
The channel to use to make remote calls.
参见

引用

WechatWechatClient 类
WechatWechatClient 重载
WechatProto 命名空间


Wechat.WechatClient 构造函数 (ClientBase.ClientBaseConfiguration)

WechatWechatClient 构造函数 (ClientBaseClientBaseConfiguration)

Protected constructor to allow creation of configured clients.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected WechatClient(
    ClientBaseConfiguration configuration
)

参数

configuration
类型：ClientBaseConfiguration
The client configuration.
参见

引用

WechatWechatClient 类
WechatWechatClient 重载
WechatProto 命名空间


WechatClient 属性

WechatWechatClient 类型公开以下成员。

属性
 | 名称 | 说明
受保护的属性 | CallInvoker | (继承自 ClientBase。)
Top
参见

引用

WechatWechatClient 类
WechatProto 命名空间


WechatClient 方法

WechatWechatClient 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
公共方法 | HelloWechat(WechatMsg, CallOptions) |
公共方法 | HelloWechat(WechatMsg, Metadata, NullableDateTime, CancellationToken) |
公共方法 | HelloWechatAsync(WechatMsg, CallOptions) |
公共方法 | HelloWechatAsync(WechatMsg, Metadata, NullableDateTime, CancellationToken) |
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | NewInstance | Creates a new instance of client from given ClientBaseConfiguration. (重写 ClientBase.NewInstance(ClientBaseConfiguration).)
公共方法 | ToString | (继承自 Object。)
公共方法 | WithHost | (继承自 ClientBaseWechatWechatClient 。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatWechatClient 类
WechatProto 命名空间


WechatClient.HelloWechat 方法

WechatClientHelloWechat 方法

重载列表
 | 名称 | 说明
公共方法 | HelloWechat(WechatMsg, CallOptions) |
公共方法 | HelloWechat(WechatMsg, Metadata, NullableDateTime, CancellationToken) |
Top
参见

引用

WechatWechatClient 类
WechatProto 命名空间


Wechat.WechatClient.HelloWechat 方法 (WechatMsg, CallOptions)

WechatWechatClientHelloWechat 方法 (WechatMsg, CallOptions)

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechat(WechatProto.WechatMsg,Grpc.Core.CallOptions)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual WechatMsg HelloWechat(
    WechatMsg request,
    CallOptions options
)

参数

request
类型：WechatProtoWechatMsg

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechat(WechatProto.WechatMsg,Grpc.Core.CallOptions)" 的 <param name="request"/> 文档]

options
类型：CallOptions

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechat(WechatProto.WechatMsg,Grpc.Core.CallOptions)" 的 <param name="options"/> 文档]

返回值

类型：WechatMsg
参见

引用

WechatWechatClient 类
HelloWechat 重载
WechatProto 命名空间


Wechat.WechatClient.HelloWechat 方法 (WechatMsg, Metadata, Nullable(DateTime), CancellationToken)

WechatWechatClientHelloWechat 方法 (WechatMsg, Metadata, NullableDateTime, CancellationToken)

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechat(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual WechatMsg HelloWechat(
    WechatMsg request,
    Metadata headers = null,
    DateTime? deadline = null,
    CancellationToken cancellationToken = default
)

参数

request
类型：WechatProtoWechatMsg

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechat(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <param name="request"/> 文档]

headers (Optional)
类型：Metadata

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechat(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <param name="headers"/> 文档]

deadline (Optional)
类型：SystemNullable DateTime

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechat(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <param name="deadline"/> 文档]

cancellationToken (Optional)
类型：System.ThreadingCancellationToken

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechat(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <param name="cancellationToken"/> 文档]

返回值

类型：WechatMsg
参见

引用

WechatWechatClient 类
HelloWechat 重载
WechatProto 命名空间


WechatClient.HelloWechatAsync 方法

WechatClientHelloWechatAsync 方法

重载列表
 | 名称 | 说明
公共方法 | HelloWechatAsync(WechatMsg, CallOptions) |
公共方法 | HelloWechatAsync(WechatMsg, Metadata, NullableDateTime, CancellationToken) |
Top
参见

引用

WechatWechatClient 类
WechatProto 命名空间


Wechat.WechatClient.HelloWechatAsync 方法 (WechatMsg, CallOptions)

WechatWechatClientHelloWechatAsync 方法 (WechatMsg, CallOptions)

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechatAsync(WechatProto.WechatMsg,Grpc.Core.CallOptions)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual AsyncUnaryCall<WechatMsg> HelloWechatAsync(
    WechatMsg request,
    CallOptions options
)

参数

request
类型：WechatProtoWechatMsg

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechatAsync(WechatProto.WechatMsg,Grpc.Core.CallOptions)" 的 <param name="request"/> 文档]

options
类型：CallOptions

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechatAsync(WechatProto.WechatMsg,Grpc.Core.CallOptions)" 的 <param name="options"/> 文档]

返回值

类型：AsyncUnaryCallWechatMsg
参见

引用

WechatWechatClient 类
HelloWechatAsync 重载
WechatProto 命名空间


Wechat.WechatClient.HelloWechatAsync 方法 (WechatMsg, Metadata, Nullable(DateTime), CancellationToken)

WechatWechatClientHelloWechatAsync 方法 (WechatMsg, Metadata, NullableDateTime, CancellationToken)

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechatAsync(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public virtual AsyncUnaryCall<WechatMsg> HelloWechatAsync(
    WechatMsg request,
    Metadata headers = null,
    DateTime? deadline = null,
    CancellationToken cancellationToken = default
)

参数

request
类型：WechatProtoWechatMsg

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechatAsync(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <param name="request"/> 文档]

headers (Optional)
类型：Metadata

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechatAsync(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <param name="headers"/> 文档]

deadline (Optional)
类型：SystemNullable DateTime

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechatAsync(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <param name="deadline"/> 文档]

cancellationToken (Optional)
类型：System.ThreadingCancellationToken

[缺少 "M:WechatProto.Wechat.WechatClient.HelloWechatAsync(WechatProto.WechatMsg,Grpc.Core.Metadata,System.Nullable{System.DateTime},System.Threading.CancellationToken)" 的 <param name="cancellationToken"/> 文档]

返回值

类型：AsyncUnaryCallWechatMsg
参见

引用

WechatWechatClient 类
HelloWechatAsync 重载
WechatProto 命名空间


Wechat.WechatClient.NewInstance 方法

WechatWechatClientNewInstance 方法

Creates a new instance of client from given ClientBaseConfiguration.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override WechatWechatClient NewInstance(
    ClientBaseConfiguration configuration
)

参数

configuration
类型：ClientBaseConfiguration

[缺少 "M:WechatProto.Wechat.WechatClient.NewInstance(Grpc.Core.ClientBase.ClientBaseConfiguration)" 的 <param name="configuration"/> 文档]

返回值

类型：WechatWechatClient
参见

引用

WechatWechatClient 类
WechatProto 命名空间


WechatMsg 类

[缺少 "T:WechatProto.WechatMsg" 的 <summary> 文档]

继承层次
SystemObject
WechatProtoWechatMsg

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public sealed class WechatMsg : IMessage<WechatMsg>,
    IMessage, IEquatable<WechatMsg>, IDeepCloneable<WechatMsg>

WechatMsg 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WechatMsg | 初始化 WechatMsg 类的一个新实例
公共方法 | WechatMsg(WechatMsg) | 初始化 WechatMsg 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | BaseMsg |
 | Descriptor |
公共属性 | IP |
 | Parser |
公共属性 | TimeStamp |
公共属性 | Token |
公共属性 | Version |
Top
方法
 | 名称 | 说明
公共方法 | CalculateSize |
公共方法 | Clone |
公共方法 | Equals(Object) | (重写 ObjectEquals(Object).)
公共方法 | Equals(WechatMsg) |
公共方法 | GetHashCode | (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
公共方法 | MergeFrom(CodedInputStream) |
公共方法 | MergeFrom(WechatMsg) |
公共方法 | ToString | (重写 ObjectToString.)
公共方法 | WriteTo |
Top
字段
名称 | 说明
BaseMsgFieldNumber | Field number for the "baseMsg" field.
IPFieldNumber | Field number for the "iP" field.
TimeStampFieldNumber | Field number for the "timeStamp" field.
TokenFieldNumber | Field number for the "token" field.
VersionFieldNumber | Field number for the "version" field.
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatProto 命名空间


WechatMsg 构造函数

重载列表
 | 名称 | 说明
公共方法 | WechatMsg | 初始化 WechatMsg 类的一个新实例
公共方法 | WechatMsg(WechatMsg) | 初始化 WechatMsg 类的一个新实例
Top
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg 构造函数

初始化 WechatMsg 类的一个新实例

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatMsg()
参见

引用

WechatMsg 类
WechatMsg 重载
WechatProto 命名空间


WechatMsg 构造函数 (WechatMsg)

初始化 WechatMsg 类的一个新实例

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatMsg(
    WechatMsg other
)

参数

other
类型：WechatProtoWechatMsg

[缺少 "M:WechatProto.WechatMsg.#ctor(WechatProto.WechatMsg)" 的 <param name="other"/> 文档]

参见

引用

WechatMsg 类
WechatMsg 重载
WechatProto 命名空间


WechatMsg 属性

WechatMsg 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BaseMsg |
 | Descriptor |
公共属性 | IP |
 | Parser |
公共属性 | TimeStamp |
公共属性 | Token |
公共属性 | Version |
Top
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.BaseMsg 属性

WechatMsgBaseMsg 属性

[缺少 "P:WechatProto.WechatMsg.BaseMsg" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public BaseMsg BaseMsg { get; set; }

属性值

类型：BaseMsg
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.Descriptor 属性

WechatMsgDescriptor 属性

[缺少 "P:WechatProto.WechatMsg.Descriptor" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static MessageDescriptor Descriptor { get; }

属性值

类型：MessageDescriptor
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.IP 属性

WechatMsgIP 属性

[缺少 "P:WechatProto.WechatMsg.IP" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string IP { get; set; }

属性值

类型：String
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.Parser 属性

WechatMsgParser 属性

[缺少 "P:WechatProto.WechatMsg.Parser" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static MessageParser<WechatMsg> Parser { get; }

属性值

类型：MessageParserWechatMsg
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.TimeStamp 属性

WechatMsgTimeStamp 属性

[缺少 "P:WechatProto.WechatMsg.TimeStamp" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int TimeStamp { get; set; }

属性值

类型：Int32
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.Token 属性

WechatMsgToken 属性

[缺少 "P:WechatProto.WechatMsg.Token" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Token { get; set; }

属性值

类型：String
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.Version 属性

WechatMsgVersion 属性

[缺少 "P:WechatProto.WechatMsg.Version" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string Version { get; set; }

属性值

类型：String
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg 方法

WechatMsg 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CalculateSize |
公共方法 | Clone |
公共方法 | Equals(Object) | (重写 ObjectEquals(Object).)
公共方法 | Equals(WechatMsg) |
公共方法 | GetHashCode | (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
公共方法 | MergeFrom(CodedInputStream) |
公共方法 | MergeFrom(WechatMsg) |
公共方法 | ToString | (重写 ObjectToString.)
公共方法 | WriteTo |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.CalculateSize 方法

WechatMsgCalculateSize 方法

[缺少 "M:WechatProto.WechatMsg.CalculateSize" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public int CalculateSize()

返回值

类型：Int32

实现

IMessage.CalculateSize
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.Clone 方法

WechatMsgClone 方法

[缺少 "M:WechatProto.WechatMsg.Clone" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public WechatMsg Clone()

返回值

类型：WechatMsg

实现

IDeepCloneable.Clone
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.Equals 方法

WechatMsgEquals 方法

重载列表
 | 名称 | 说明
公共方法 | Equals(Object) | (重写 ObjectEquals(Object).)
公共方法 | Equals(WechatMsg) |
Top
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.Equals 方法 (Object)

WechatMsgEquals 方法 (Object)

[缺少 "M:WechatProto.WechatMsg.Equals(System.Object)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override bool Equals(
    Object other
)

参数

other
类型：SystemObject

[缺少 "M:WechatProto.WechatMsg.Equals(System.Object)" 的 <param name="other"/> 文档]

返回值

类型：Boolean
参见

引用

WechatMsg 类
Equals 重载
WechatProto 命名空间


WechatMsg.Equals 方法 (WechatMsg)

WechatMsgEquals 方法 (WechatMsg)

[缺少 "M:WechatProto.WechatMsg.Equals(WechatProto.WechatMsg)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public bool Equals(
    WechatMsg other
)

参数

other
类型：WechatProtoWechatMsg

[缺少 "M:WechatProto.WechatMsg.Equals(WechatProto.WechatMsg)" 的 <param name="other"/> 文档]

返回值

类型：Boolean

实现

IEquatableTEquals(T)
参见

引用

WechatMsg 类
Equals 重载
WechatProto 命名空间


WechatMsg.GetHashCode 方法

WechatMsgGetHashCode 方法

[缺少 "M:WechatProto.WechatMsg.GetHashCode" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override int GetHashCode()

返回值

类型：Int32
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.MergeFrom 方法

WechatMsgMergeFrom 方法

重载列表
 | 名称 | 说明
公共方法 | MergeFrom(CodedInputStream) |
公共方法 | MergeFrom(WechatMsg) |
Top
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.MergeFrom 方法 (CodedInputStream)

WechatMsgMergeFrom 方法 (CodedInputStream)

[缺少 "M:WechatProto.WechatMsg.MergeFrom(Google.Protobuf.CodedInputStream)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void MergeFrom(
    CodedInputStream input
)

参数

input
类型：CodedInputStream

[缺少 "M:WechatProto.WechatMsg.MergeFrom(Google.Protobuf.CodedInputStream)" 的 <param name="input"/> 文档]

实现

IMessage.MergeFrom(CodedInputStream)
参见

引用

WechatMsg 类
MergeFrom 重载
WechatProto 命名空间


WechatMsg.MergeFrom 方法 (WechatMsg)

WechatMsgMergeFrom 方法 (WechatMsg)

[缺少 "M:WechatProto.WechatMsg.MergeFrom(WechatProto.WechatMsg)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void MergeFrom(
    WechatMsg other
)

参数

other
类型：WechatProtoWechatMsg

[缺少 "M:WechatProto.WechatMsg.MergeFrom(WechatProto.WechatMsg)" 的 <param name="other"/> 文档]

实现

IMessage.MergeFrom(UTP)
参见

引用

WechatMsg 类
MergeFrom 重载
WechatProto 命名空间


WechatMsg.ToString 方法

WechatMsgToString 方法

[缺少 "M:WechatProto.WechatMsg.ToString" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.WriteTo 方法

WechatMsgWriteTo 方法

[缺少 "M:WechatProto.WechatMsg.WriteTo(Google.Protobuf.CodedOutputStream)" 的 <summary> 文档]

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void WriteTo(
    CodedOutputStream output
)

参数

output
类型：CodedOutputStream

[缺少 "M:WechatProto.WechatMsg.WriteTo(Google.Protobuf.CodedOutputStream)" 的 <param name="output"/> 文档]

实现

IMessage.WriteTo(CodedOutputStream)
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg 字段

WechatMsg 类型公开以下成员。

字段
名称 | 说明
BaseMsgFieldNumber | Field number for the "baseMsg" field.
IPFieldNumber | Field number for the "iP" field.
TimeStampFieldNumber | Field number for the "timeStamp" field.
TokenFieldNumber | Field number for the "token" field.
VersionFieldNumber | Field number for the "version" field.
Top
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.BaseMsgFieldNumber 字段

WechatMsgBaseMsgFieldNumber 字段

Field number for the "baseMsg" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int BaseMsgFieldNumber = 1

字段值

类型：Int32
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.IPFieldNumber 字段

WechatMsgIPFieldNumber 字段

Field number for the "iP" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int IPFieldNumber = 5

字段值

类型：Int32
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.TimeStampFieldNumber 字段

WechatMsgTimeStampFieldNumber 字段

Field number for the "timeStamp" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int TimeStampFieldNumber = 4

字段值

类型：Int32
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.TokenFieldNumber 字段

WechatMsgTokenFieldNumber 字段

Field number for the "token" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int TokenFieldNumber = 2

字段值

类型：Int32
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatMsg.VersionFieldNumber 字段

WechatMsgVersionFieldNumber 字段

Field number for the "version" field.

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public const int VersionFieldNumber = 3

字段值

类型：Int32
参见

引用

WechatMsg 类
WechatProto 命名空间


WechatProtoReflection 类

Holder for reflection information generated from WechatProto.proto
继承层次
SystemObject
WechatProtoWechatProtoReflection

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static class WechatProtoReflection

WechatProtoReflection 类型公开以下成员。

属性
名称 | 说明
Descriptor | File descriptor for WechatProto.proto
Top
参见

引用

WechatProto 命名空间


WechatProtoReflection 属性

WechatProtoReflection 类型公开以下成员。

属性
名称 | 说明
Descriptor | File descriptor for WechatProto.proto
Top
参见

引用

WechatProtoReflection 类
WechatProto 命名空间


WechatProtoReflection.Descriptor 属性

WechatProtoReflectionDescriptor 属性

File descriptor for WechatProto.proto

命名空间： WechatProto
程序集： Chat.Framework (在 Chat.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static FileDescriptor Descriptor { get; }

属性值

类型：FileDescriptor
参见

引用

WechatProtoReflection 类
WechatProto 命名空间


淘宝登录 命名空间

[缺少 "N:淘宝登录" 的 <summary> 文档]

类
 | 类 | 说明
公共类 | AliQrCordControl | 阿里妈妈登录二维码
公共类 | AliQrCordControlverifyStruct |
枚举
 | 枚举 | 说明
公共枚举 | AliQrCordControld |
公共枚举 | AliQrCordControlqrState |


AliQrCordControl 类

阿里妈妈登录二维码
继承层次
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
淘宝登录AliQrCordControl

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class AliQrCordControl : UserControl

AliQrCordControl 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AliQrCordControl | 初始化 AliQrCordControl 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 ScrollableControl。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 UserControl。)
公共属性 | AutoSizeMode | (继承自 UserControl。)
公共属性 | AutoValidate | (继承自 UserControl。)
公共属性 | BackColor | (继承自 Control。)
公共属性 | BackgroundImage | (继承自 Control。)
公共属性 | BackgroundImageLayout | (继承自 Control。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | BorderStyle | (继承自 UserControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Control。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 UserControl。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Control。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 UserControl。)
受保护的属性 | DesignMode | (继承自 Component。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 Control。)
受保护的属性 | FontHeight | (继承自 Control。)
公共属性 | ForeColor | (继承自 Control。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | LayoutEngine | (继承自 Control。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Control。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximumSize | (继承自 Control。)
公共属性 | MinimumSize | (继承自 Control。)
公共属性 | Name | (继承自 Control。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | Site | (继承自 Control。)
公共属性 | Size | (继承自 Control。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
Top
方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
受保护的方法 | AdjustFormScrollbars | (继承自 ContainerControl。)
公共方法 | AutoAgree | 手淘自动同意
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
公共方法 | CheckLogin | 二次验证
公共方法 | CheckStatus |
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 Control。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 Control。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | DefWndProc | (继承自 Control。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | 清理所有正在使用的资源。 (重写 ContainerControlDispose(Boolean).)
公共方法 | DoDragDrop | (继承自 Control。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
公共方法 | GetContainerControl | (继承自 Control。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 Control。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetStyle | (继承自 Control。)
公共方法 | getTarget | 从url中提取对象
公共方法 | getTbToken | 从cookie中获取token
公共方法 | GetTimeSpan | 日期转换成时间戳Timestamp
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
 | GetUserNick | 根据页面获取用户名称
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Control。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 Control。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 UserControl。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Control。)
受保护的方法 | OnEnter | (继承自 Control。)
受保护的方法 | OnFontChanged | (继承自 ContainerControl。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 Control。)
受保护的方法 | OnHandleDestroyed | (继承自 Control。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 ContainerControl。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 UserControl。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 UserControl。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 ScrollableControl。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 Control。)
受保护的方法 | OnPaintBackground | (继承自 ScrollableControl。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 ContainerControl。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 UserControl。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnSizeChanged | (继承自 Control。)
受保护的方法 | OnStyleChanged | (继承自 Control。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 Control。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 ScrollableControl。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 ContainerControl。)
受保护的方法 | ProcessDialogChar | (继承自 ContainerControl。)
受保护的方法 | ProcessDialogKey | (继承自 ContainerControl。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Control。)
受保护的方法 | ProcessMnemonic | (继承自 ContainerControl。)
受保护的方法 | ProcessTabKey | (继承自 ContainerControl。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 Control。)
公共方法 | ResumeLayout(Boolean) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 ScrollableControl。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 ContainerControl。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 Control。)
受保护的方法 | SetClientSizeCore | (继承自 Control。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 Control。)
公共方法 | Shouquan | 授权
公共方法 | Show | (继承自 Control。)
受保护的方法 | SizeFromClientSize | (继承自 Control。)
公共方法 | SuspendLayout | (继承自 Control。)
公共方法 | ToString | (继承自 Component。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateDefaultButton | (继承自 ContainerControl。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 UserControl。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 UserControl。)
公共方法 | verifySmsCode | 提交验证码
公共方法 | View |
受保护的方法 | WndProc | (继承自 UserControl。)
Top
事件
 | 名称 | 说明
公共事件 | AutoSizeChanged | (继承自 UserControl。)
公共事件 | AutoValidateChanged | (继承自 UserControl。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 UserControl。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
字段
 | 名称 | 说明
公共字段 | error |
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

淘宝登录 命名空间


AliQrCordControl 构造函数

初始化 AliQrCordControl 类的一个新实例

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public AliQrCordControl()
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl 属性

AliQrCordControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AccessibilityObject | (继承自 Control。)
公共属性 | AccessibleDefaultActionDescription | (继承自 Control。)
公共属性 | AccessibleDescription | (继承自 Control。)
公共属性 | AccessibleName | (继承自 Control。)
公共属性 | AccessibleRole | (继承自 Control。)
公共属性 | ActiveControl | (继承自 ContainerControl。)
公共属性 | AllowDrop | (继承自 Control。)
公共属性 | Anchor | (继承自 Control。)
公共属性 | AutoScaleDimensions | (继承自 ContainerControl。)
受保护的属性 | AutoScaleFactor | (继承自 ContainerControl。)
公共属性 | AutoScaleMode | (继承自 ContainerControl。)
公共属性 | AutoScroll | (继承自 ScrollableControl。)
公共属性 | AutoScrollMargin | (继承自 ScrollableControl。)
公共属性 | AutoScrollMinSize | (继承自 ScrollableControl。)
公共属性 | AutoScrollOffset | (继承自 Control。)
公共属性 | AutoScrollPosition | (继承自 ScrollableControl。)
公共属性 | AutoSize | (继承自 UserControl。)
公共属性 | AutoSizeMode | (继承自 UserControl。)
公共属性 | AutoValidate | (继承自 UserControl。)
公共属性 | BackColor | (继承自 Control。)
公共属性 | BackgroundImage | (继承自 Control。)
公共属性 | BackgroundImageLayout | (继承自 Control。)
公共属性 | BindingContext | (继承自 ContainerControl。)
公共属性 | BorderStyle | (继承自 UserControl。)
公共属性 | Bottom | (继承自 Control。)
公共属性 | Bounds | (继承自 Control。)
受保护的属性 | CanEnableIme | (继承自 ContainerControl。)
公共属性 | CanFocus | (继承自 Control。)
受保护的属性 | CanRaiseEvents | (继承自 Control。)
公共属性 | CanSelect | (继承自 Control。)
公共属性 | Capture | (继承自 Control。)
公共属性 | CausesValidation | (继承自 Control。)
公共属性 | ClientRectangle | (继承自 Control。)
公共属性 | ClientSize | (继承自 Control。)
公共属性 | CompanyName | (继承自 Control。)
公共属性 | Container | (继承自 Component。)
公共属性 | ContainsFocus | (继承自 Control。)
公共属性 | ContextMenu | (继承自 Control。)
公共属性 | ContextMenuStrip | (继承自 Control。)
公共属性 | Controls | (继承自 Control。)
公共属性 | Created | (继承自 Control。)
受保护的属性 | CreateParams | (继承自 UserControl。)
公共属性 | CurrentAutoScaleDimensions | (继承自 ContainerControl。)
公共属性 | Cursor | (继承自 Control。)
公共属性 | DataBindings | (继承自 Control。)
受保护的属性 | DefaultCursor | (继承自 Control。)
受保护的属性 | DefaultImeMode | (继承自 Control。)
受保护的属性 | DefaultMargin | (继承自 Control。)
受保护的属性 | DefaultMaximumSize | (继承自 Control。)
受保护的属性 | DefaultMinimumSize | (继承自 Control。)
受保护的属性 | DefaultPadding | (继承自 Control。)
受保护的属性 | DefaultSize | (继承自 UserControl。)
受保护的属性 | DesignMode | (继承自 Component。)
公共属性 | DisplayRectangle | (继承自 ScrollableControl。)
公共属性 | Disposing | (继承自 Control。)
公共属性 | Dock | (继承自 Control。)
受保护的属性 | DoubleBuffered | (继承自 Control。)
公共属性 | Enabled | (继承自 Control。)
受保护的属性 | Events | (继承自 Component。)
公共属性 | Focused | (继承自 Control。)
公共属性 | Font | (继承自 Control。)
受保护的属性 | FontHeight | (继承自 Control。)
公共属性 | ForeColor | (继承自 Control。)
公共属性 | Handle | (继承自 Control。)
公共属性 | HasChildren | (继承自 Control。)
公共属性 | Height | (继承自 Control。)
公共属性 | HorizontalScroll | (继承自 ScrollableControl。)
受保护的属性 | HScroll | (继承自 ScrollableControl。)
公共属性 | ImeMode | (继承自 Control。)
受保护的属性 | ImeModeBase | (继承自 Control。)
公共属性 | InvokeRequired | (继承自 Control。)
公共属性 | IsAccessible | (继承自 Control。)
公共属性 | IsDisposed | (继承自 Control。)
公共属性 | IsHandleCreated | (继承自 Control。)
公共属性 | IsMirrored | (继承自 Control。)
公共属性 | LayoutEngine | (继承自 Control。)
公共属性 | Left | (继承自 Control。)
公共属性 | Location | (继承自 Control。)
公共属性 | Margin | (继承自 Control。)
公共属性 | MaximumSize | (继承自 Control。)
公共属性 | MinimumSize | (继承自 Control。)
公共属性 | Name | (继承自 Control。)
公共属性 | Padding | (继承自 Control。)
公共属性 | Parent | (继承自 Control。)
公共属性 | ParentForm | (继承自 ContainerControl。)
公共属性 | PreferredSize | (继承自 Control。)
公共属性 | ProductName | (继承自 Control。)
公共属性 | ProductVersion | (继承自 Control。)
公共属性 | RecreatingHandle | (继承自 Control。)
公共属性 | Region | (继承自 Control。)
受保护的属性 | RenderRightToLeft | 已过时。 (继承自 Control。)
受保护的属性 | ResizeRedraw | (继承自 Control。)
公共属性 | Right | (继承自 Control。)
公共属性 | RightToLeft | (继承自 Control。)
受保护的属性 | ScaleChildren | (继承自 Control。)
受保护的属性 | ShowFocusCues | (继承自 Control。)
受保护的属性 | ShowKeyboardCues | (继承自 Control。)
公共属性 | Site | (继承自 Control。)
公共属性 | Size | (继承自 Control。)
公共属性 | TabIndex | (继承自 Control。)
公共属性 | TabStop | (继承自 Control。)
公共属性 | Tag | (继承自 Control。)
公共属性 | Top | (继承自 Control。)
公共属性 | TopLevelControl | (继承自 Control。)
公共属性 | UseWaitCursor | (继承自 Control。)
公共属性 | VerticalScroll | (继承自 ScrollableControl。)
公共属性 | Visible | (继承自 Control。)
受保护的属性 | VScroll | (继承自 ScrollableControl。)
公共属性 | Width | (继承自 Control。)
Top
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl 方法

AliQrCordControl 类型公开以下成员。

方法
 | 名称 | 说明
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (继承自 Control。)
受保护的方法 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (继承自 Control。)
受保护的方法 | AdjustFormScrollbars | (继承自 ContainerControl。)
公共方法 | AutoAgree | 手淘自动同意
公共方法 | BeginInvoke(Delegate) | (继承自 Control。)
公共方法 | BeginInvoke(Delegate, Object) | (继承自 Control。)
公共方法 | BringToFront | (继承自 Control。)
公共方法 | CheckLogin | 二次验证
公共方法 | CheckStatus |
公共方法 | Contains | (继承自 Control。)
受保护的方法 | CreateAccessibilityInstance | (继承自 Control。)
公共方法 | CreateControl | (继承自 Control。)
受保护的方法 | CreateControlsInstance | (继承自 Control。)
公共方法 | CreateGraphics | (继承自 Control。)
受保护的方法 | CreateHandle | (继承自 Control。)
公共方法 | CreateObjRef | (继承自 MarshalByRefObject。)
受保护的方法 | DefWndProc | (继承自 Control。)
受保护的方法 | DestroyHandle | (继承自 Control。)
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | 清理所有正在使用的资源。 (重写 ContainerControlDispose(Boolean).)
公共方法 | DoDragDrop | (继承自 Control。)
公共方法 | DrawToBitmap | (继承自 Control。)
公共方法 | EndInvoke | (继承自 Control。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Component。)
公共方法 | FindForm | (继承自 Control。)
公共方法 | Focus | (继承自 Control。)
受保护的方法 | GetAccessibilityObjectById | (继承自 Control。)
受保护的方法 | GetAutoSizeMode | (继承自 Control。)
公共方法 | GetChildAtPoint(Point) | (继承自 Control。)
公共方法 | GetChildAtPoint(Point, GetChildAtPointSkip) | (继承自 Control。)
公共方法 | GetContainerControl | (继承自 Control。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetLifetimeService | (继承自 MarshalByRefObject。)
公共方法 | GetNextControl | (继承自 Control。)
公共方法 | GetPreferredSize | (继承自 Control。)
受保护的方法 | GetScaledBounds | (继承自 Control。)
受保护的方法 | GetScrollState | (继承自 ScrollableControl。)
受保护的方法 | GetService | (继承自 Component。)
受保护的方法 | GetStyle | (继承自 Control。)
公共方法 | getTarget | 从url中提取对象
公共方法 | getTbToken | 从cookie中获取token
公共方法 | GetTimeSpan | 日期转换成时间戳Timestamp
受保护的方法 | GetTopLevel | (继承自 Control。)
公共方法 | GetType | (继承自 Object。)
 | GetUserNick | 根据页面获取用户名称
公共方法 | Hide | (继承自 Control。)
公共方法 | InitializeLifetimeService | (继承自 MarshalByRefObject。)
受保护的方法 | InitLayout | (继承自 Control。)
公共方法 | Invalidate | (继承自 Control。)
公共方法 | Invalidate(Region) | (继承自 Control。)
公共方法 | Invalidate(Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle) | (继承自 Control。)
公共方法 | Invalidate(Region, Boolean) | (继承自 Control。)
公共方法 | Invalidate(Rectangle, Boolean) | (继承自 Control。)
公共方法 | Invoke(Delegate) | (继承自 Control。)
公共方法 | Invoke(Delegate, Object) | (继承自 Control。)
受保护的方法 | InvokeGotFocus | (继承自 Control。)
受保护的方法 | InvokeLostFocus | (继承自 Control。)
受保护的方法 | InvokeOnClick | (继承自 Control。)
受保护的方法 | InvokePaint | (继承自 Control。)
受保护的方法 | InvokePaintBackground | (继承自 Control。)
受保护的方法 | IsInputChar | (继承自 Control。)
受保护的方法 | IsInputKey | (继承自 Control。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
受保护的方法 | MemberwiseClone(Boolean) | (继承自 MarshalByRefObject。)
受保护的方法 | NotifyInvalidate | (继承自 Control。)
受保护的方法 | OnAutoSizeChanged | (继承自 Control。)
受保护的方法 | OnAutoValidateChanged | (继承自 ContainerControl。)
受保护的方法 | OnBackColorChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnBackgroundImageLayoutChanged | (继承自 Control。)
受保护的方法 | OnBindingContextChanged | (继承自 Control。)
受保护的方法 | OnCausesValidationChanged | (继承自 Control。)
受保护的方法 | OnChangeUICues | (继承自 Control。)
受保护的方法 | OnClick | (继承自 Control。)
受保护的方法 | OnClientSizeChanged | (继承自 Control。)
受保护的方法 | OnContextMenuChanged | (继承自 Control。)
受保护的方法 | OnContextMenuStripChanged | (继承自 Control。)
受保护的方法 | OnControlAdded | (继承自 Control。)
受保护的方法 | OnControlRemoved | (继承自 Control。)
受保护的方法 | OnCreateControl | (继承自 UserControl。)
受保护的方法 | OnCursorChanged | (继承自 Control。)
受保护的方法 | OnDockChanged | (继承自 Control。)
受保护的方法 | OnDoubleClick | (继承自 Control。)
受保护的方法 | OnDragDrop | (继承自 Control。)
受保护的方法 | OnDragEnter | (继承自 Control。)
受保护的方法 | OnDragLeave | (继承自 Control。)
受保护的方法 | OnDragOver | (继承自 Control。)
受保护的方法 | OnEnabledChanged | (继承自 Control。)
受保护的方法 | OnEnter | (继承自 Control。)
受保护的方法 | OnFontChanged | (继承自 ContainerControl。)
受保护的方法 | OnForeColorChanged | (继承自 Control。)
受保护的方法 | OnGiveFeedback | (继承自 Control。)
受保护的方法 | OnGotFocus | (继承自 Control。)
受保护的方法 | OnHandleCreated | (继承自 Control。)
受保护的方法 | OnHandleDestroyed | (继承自 Control。)
受保护的方法 | OnHelpRequested | (继承自 Control。)
受保护的方法 | OnImeModeChanged | (继承自 Control。)
受保护的方法 | OnInvalidated | (继承自 Control。)
受保护的方法 | OnKeyDown | (继承自 Control。)
受保护的方法 | OnKeyPress | (继承自 Control。)
受保护的方法 | OnKeyUp | (继承自 Control。)
受保护的方法 | OnLayout | (继承自 ContainerControl。)
受保护的方法 | OnLeave | (继承自 Control。)
受保护的方法 | OnLoad | (继承自 UserControl。)
受保护的方法 | OnLocationChanged | (继承自 Control。)
受保护的方法 | OnLostFocus | (继承自 Control。)
受保护的方法 | OnMarginChanged | (继承自 Control。)
受保护的方法 | OnMouseCaptureChanged | (继承自 Control。)
受保护的方法 | OnMouseClick | (继承自 Control。)
受保护的方法 | OnMouseDoubleClick | (继承自 Control。)
受保护的方法 | OnMouseDown | (继承自 UserControl。)
受保护的方法 | OnMouseEnter | (继承自 Control。)
受保护的方法 | OnMouseHover | (继承自 Control。)
受保护的方法 | OnMouseLeave | (继承自 Control。)
受保护的方法 | OnMouseMove | (继承自 Control。)
受保护的方法 | OnMouseUp | (继承自 Control。)
受保护的方法 | OnMouseWheel | (继承自 ScrollableControl。)
受保护的方法 | OnMove | (继承自 Control。)
受保护的方法 | OnNotifyMessage | (继承自 Control。)
受保护的方法 | OnPaddingChanged | (继承自 ScrollableControl。)
受保护的方法 | OnPaint | (继承自 Control。)
受保护的方法 | OnPaintBackground | (继承自 ScrollableControl。)
受保护的方法 | OnParentBackColorChanged | (继承自 Control。)
受保护的方法 | OnParentBackgroundImageChanged | (继承自 Control。)
受保护的方法 | OnParentBindingContextChanged | (继承自 Control。)
受保护的方法 | OnParentChanged | (继承自 ContainerControl。)
受保护的方法 | OnParentCursorChanged | (继承自 Control。)
受保护的方法 | OnParentEnabledChanged | (继承自 Control。)
受保护的方法 | OnParentFontChanged | (继承自 Control。)
受保护的方法 | OnParentForeColorChanged | (继承自 Control。)
受保护的方法 | OnParentRightToLeftChanged | (继承自 Control。)
受保护的方法 | OnParentVisibleChanged | (继承自 Control。)
受保护的方法 | OnPreviewKeyDown | (继承自 Control。)
受保护的方法 | OnPrint | (继承自 Control。)
受保护的方法 | OnQueryContinueDrag | (继承自 Control。)
受保护的方法 | OnRegionChanged | (继承自 Control。)
受保护的方法 | OnResize | (继承自 UserControl。)
受保护的方法 | OnRightToLeftChanged | (继承自 ScrollableControl。)
受保护的方法 | OnScroll | (继承自 ScrollableControl。)
受保护的方法 | OnSizeChanged | (继承自 Control。)
受保护的方法 | OnStyleChanged | (继承自 Control。)
受保护的方法 | OnSystemColorsChanged | (继承自 Control。)
受保护的方法 | OnTabIndexChanged | (继承自 Control。)
受保护的方法 | OnTabStopChanged | (继承自 Control。)
受保护的方法 | OnTextChanged | (继承自 Control。)
受保护的方法 | OnValidated | (继承自 Control。)
受保护的方法 | OnValidating | (继承自 Control。)
受保护的方法 | OnVisibleChanged | (继承自 ScrollableControl。)
公共方法 | PerformAutoScale | (继承自 ContainerControl。)
公共方法 | PerformLayout | (继承自 Control。)
公共方法 | PerformLayout(Control, String) | (继承自 Control。)
公共方法 | PointToClient | (继承自 Control。)
公共方法 | PointToScreen | (继承自 Control。)
公共方法 | PreProcessControlMessage | (继承自 Control。)
公共方法 | PreProcessMessage | (继承自 Control。)
受保护的方法 | ProcessCmdKey | (继承自 ContainerControl。)
受保护的方法 | ProcessDialogChar | (继承自 ContainerControl。)
受保护的方法 | ProcessDialogKey | (继承自 ContainerControl。)
受保护的方法 | ProcessKeyEventArgs | (继承自 Control。)
受保护的方法 | ProcessKeyMessage | (继承自 Control。)
受保护的方法 | ProcessKeyPreview | (继承自 Control。)
受保护的方法 | ProcessMnemonic | (继承自 ContainerControl。)
受保护的方法 | ProcessTabKey | (继承自 ContainerControl。)
受保护的方法 | RaiseDragEvent | (继承自 Control。)
受保护的方法 | RaiseKeyEvent | (继承自 Control。)
受保护的方法 | RaiseMouseEvent | (继承自 Control。)
受保护的方法 | RaisePaintEvent | (继承自 Control。)
受保护的方法 | RecreateHandle | (继承自 Control。)
公共方法 | RectangleToClient | (继承自 Control。)
公共方法 | RectangleToScreen | (继承自 Control。)
公共方法 | Refresh | (继承自 Control。)
受保护的方法 | ResetMouseEventArgs | (继承自 Control。)
公共方法 | ResetText | (继承自 Control。)
公共方法 | ResumeLayout | (继承自 Control。)
公共方法 | ResumeLayout(Boolean) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(HorizontalAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(LeftRightAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateAlignment(ContentAlignment) | (继承自 Control。)
受保护的方法 | RtlTranslateContent | (继承自 Control。)
受保护的方法 | RtlTranslateHorizontal | (继承自 Control。)
受保护的方法 | RtlTranslateLeftRight | (继承自 Control。)
公共方法 | Scale | (继承自 Control。)
受保护的方法 | ScaleControl | (继承自 ScrollableControl。)
公共方法 | ScrollControlIntoView | (继承自 ScrollableControl。)
受保护的方法 | ScrollToControl | (继承自 ScrollableControl。)
公共方法 | Select | (继承自 Control。)
受保护的方法 | Select(Boolean, Boolean) | (继承自 ContainerControl。)
公共方法 | SelectNextControl | (继承自 Control。)
公共方法 | SendToBack | (继承自 Control。)
公共方法 | SetAutoScrollMargin | (继承自 ScrollableControl。)
受保护的方法 | SetAutoSizeMode | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
公共方法 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (继承自 Control。)
受保护的方法 | SetBoundsCore | (继承自 Control。)
受保护的方法 | SetClientSizeCore | (继承自 Control。)
受保护的方法 | SetDisplayRectLocation | (继承自 ScrollableControl。)
受保护的方法 | SetScrollState | (继承自 ScrollableControl。)
受保护的方法 | SetStyle | (继承自 Control。)
受保护的方法 | SetTopLevel | (继承自 Control。)
受保护的方法 | SetVisibleCore | (继承自 Control。)
公共方法 | Shouquan | 授权
公共方法 | Show | (继承自 Control。)
受保护的方法 | SizeFromClientSize | (继承自 Control。)
公共方法 | SuspendLayout | (继承自 Control。)
公共方法 | ToString | (继承自 Component。)
公共方法 | Update | (继承自 Control。)
受保护的方法 | UpdateBounds | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (继承自 Control。)
受保护的方法 | UpdateDefaultButton | (继承自 ContainerControl。)
受保护的方法 | UpdateStyles | (继承自 Control。)
受保护的方法 | UpdateZOrder | (继承自 Control。)
公共方法 | Validate | (继承自 ContainerControl。)
公共方法 | Validate(Boolean) | (继承自 ContainerControl。)
公共方法 | ValidateChildren | (继承自 UserControl。)
公共方法 | ValidateChildren(ValidationConstraints) | (继承自 UserControl。)
公共方法 | verifySmsCode | 提交验证码
公共方法 | View |
受保护的方法 | WndProc | (继承自 UserControl。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.AutoAgree 方法

AliQrCordControlAutoAgree 方法

手淘自动同意

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string AutoAgree(
    string url,
    ref string cookie,
    string refer,
    string refere
)

参数

url
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.AutoAgree(System.String,System.String@,System.String,System.String)" 的 <param name="url"/> 文档]

cookie
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.AutoAgree(System.String,System.String@,System.String,System.String)" 的 <param name="cookie"/> 文档]

refer
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.AutoAgree(System.String,System.String@,System.String,System.String)" 的 <param name="refer"/> 文档]

refere
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.AutoAgree(System.String,System.String@,System.String,System.String)" 的 <param name="refere"/> 文档]

返回值

类型：String
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.CheckLogin 方法

AliQrCordControlCheckLogin 方法

二次验证

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string CheckLogin(
    string url,
    ref string cookie,
    string refer
)

参数

url
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.CheckLogin(System.String,System.String@,System.String)" 的 <param name="url"/> 文档]

cookie
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.CheckLogin(System.String,System.String@,System.String)" 的 <param name="cookie"/> 文档]

refer
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.CheckLogin(System.String,System.String@,System.String)" 的 <param name="refer"/> 文档]

返回值

类型：String
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.CheckStatus 方法

AliQrCordControlCheckStatus 方法

[缺少 "M:淘宝登录.AliQrCordControl.CheckStatus(Newtonsoft.Json.Linq.JObject,System.String,System.String@,System.String,System.String,System.String)" 的 <summary> 文档]

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public AliQrCordControlqrState CheckStatus(
    JObject msg,
    string refer,
    ref string cookie,
    string t,
    string ck,
    string ua
)

参数

msg
类型：JObject

[缺少 "M:淘宝登录.AliQrCordControl.CheckStatus(Newtonsoft.Json.Linq.JObject,System.String,System.String@,System.String,System.String,System.String)" 的 <param name="msg"/> 文档]

refer
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.CheckStatus(Newtonsoft.Json.Linq.JObject,System.String,System.String@,System.String,System.String,System.String)" 的 <param name="refer"/> 文档]

cookie
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.CheckStatus(Newtonsoft.Json.Linq.JObject,System.String,System.String@,System.String,System.String,System.String)" 的 <param name="cookie"/> 文档]

t
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.CheckStatus(Newtonsoft.Json.Linq.JObject,System.String,System.String@,System.String,System.String,System.String)" 的 <param name="t"/> 文档]

ck
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.CheckStatus(Newtonsoft.Json.Linq.JObject,System.String,System.String@,System.String,System.String,System.String)" 的 <param name="ck"/> 文档]

ua
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.CheckStatus(Newtonsoft.Json.Linq.JObject,System.String,System.String@,System.String,System.String,System.String)" 的 <param name="ua"/> 文档]

返回值

类型：AliQrCordControlqrState
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.Dispose 方法

AliQrCordControlDispose 方法

重载列表
 | 名称 | 说明
公共方法 | Dispose | (继承自 Component。)
受保护的方法 | Dispose(Boolean) | 清理所有正在使用的资源。 (重写 ContainerControlDispose(Boolean).)
Top
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.Dispose 方法 (Boolean)

AliQrCordControlDispose 方法 (Boolean)

清理所有正在使用的资源。

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
protected override void Dispose(
    bool disposing
)

参数

disposing
类型：SystemBoolean
如果应释放托管资源，为 true；否则为 false。
参见

引用

AliQrCordControl 类
Dispose 重载
淘宝登录 命名空间


AliQrCordControl.getTarget 方法

AliQrCordControlgetTarget 方法

从url中提取对象

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string getTarget(
    string url,
    string target
)

参数

url
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.getTarget(System.String,System.String)" 的 <param name="url"/> 文档]

target
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.getTarget(System.String,System.String)" 的 <param name="target"/> 文档]

返回值

类型：String
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.getTbToken 方法

AliQrCordControlgetTbToken 方法

从cookie中获取token

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string getTbToken(
    string cookie
)

参数

cookie
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.getTbToken(System.String)" 的 <param name="cookie"/> 文档]

返回值

类型：String
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.GetTimeSpan 方法

AliQrCordControlGetTimeSpan 方法

日期转换成时间戳Timestamp

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public long GetTimeSpan(
    DateTime time
)

参数

time
类型：SystemDateTime

[缺少 "M:淘宝登录.AliQrCordControl.GetTimeSpan(System.DateTime)" 的 <param name="time"/> 文档]

返回值

类型：Int64
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.GetUserNick 方法

AliQrCordControlGetUserNick 方法

根据页面获取用户名称

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public static string GetUserNick(
    ref string cookie
)

参数

cookie
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.GetUserNick(System.String@)" 的 <param name="cookie"/> 文档]

返回值

类型：String
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.Shouquan 方法

AliQrCordControlShouquan 方法

授权

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void Shouquan(
    string cookie_
)

参数

cookie_
类型：SystemString

[缺少 "M:淘宝登录.AliQrCordControl.Shouquan(System.String)" 的 <param name="cookie_"/> 文档]

参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.verifySmsCode 方法

AliQrCordControlverifySmsCode 方法

提交验证码

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string verifySmsCode(
    AliQrCordControlverifyStruct vs
)

参数

vs
类型：淘宝登录AliQrCordControlverifyStruct

[缺少 "M:淘宝登录.AliQrCordControl.verifySmsCode(淘宝登录.AliQrCordControl.verifyStruct)" 的 <param name="vs"/> 文档]

返回值

类型：String
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.View 方法

AliQrCordControlView 方法

[缺少 "M:淘宝登录.AliQrCordControl.View" 的 <summary> 文档]

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public void View()
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl 事件

AliQrCordControl 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | AutoSizeChanged | (继承自 UserControl。)
公共事件 | AutoValidateChanged | (继承自 UserControl。)
公共事件 | BackColorChanged | (继承自 Control。)
公共事件 | BackgroundImageChanged | (继承自 Control。)
公共事件 | BackgroundImageLayoutChanged | (继承自 Control。)
公共事件 | BindingContextChanged | (继承自 Control。)
公共事件 | CausesValidationChanged | (继承自 Control。)
公共事件 | ChangeUICues | (继承自 Control。)
公共事件 | Click | (继承自 Control。)
公共事件 | ClientSizeChanged | (继承自 Control。)
公共事件 | ContextMenuChanged | (继承自 Control。)
公共事件 | ContextMenuStripChanged | (继承自 Control。)
公共事件 | ControlAdded | (继承自 Control。)
公共事件 | ControlRemoved | (继承自 Control。)
公共事件 | CursorChanged | (继承自 Control。)
公共事件 | Disposed | (继承自 Component。)
公共事件 | DockChanged | (继承自 Control。)
公共事件 | DoubleClick | (继承自 Control。)
公共事件 | DragDrop | (继承自 Control。)
公共事件 | DragEnter | (继承自 Control。)
公共事件 | DragLeave | (继承自 Control。)
公共事件 | DragOver | (继承自 Control。)
公共事件 | EnabledChanged | (继承自 Control。)
公共事件 | Enter | (继承自 Control。)
公共事件 | FontChanged | (继承自 Control。)
公共事件 | ForeColorChanged | (继承自 Control。)
公共事件 | GiveFeedback | (继承自 Control。)
公共事件 | GotFocus | (继承自 Control。)
公共事件 | HandleCreated | (继承自 Control。)
公共事件 | HandleDestroyed | (继承自 Control。)
公共事件 | HelpRequested | (继承自 Control。)
公共事件 | ImeModeChanged | (继承自 Control。)
公共事件 | Invalidated | (继承自 Control。)
公共事件 | KeyDown | (继承自 Control。)
公共事件 | KeyPress | (继承自 Control。)
公共事件 | KeyUp | (继承自 Control。)
公共事件 | Layout | (继承自 Control。)
公共事件 | Leave | (继承自 Control。)
公共事件 | Load | (继承自 UserControl。)
公共事件 | LocationChanged | (继承自 Control。)
公共事件 | LostFocus | (继承自 Control。)
公共事件 | MarginChanged | (继承自 Control。)
公共事件 | MouseCaptureChanged | (继承自 Control。)
公共事件 | MouseClick | (继承自 Control。)
公共事件 | MouseDoubleClick | (继承自 Control。)
公共事件 | MouseDown | (继承自 Control。)
公共事件 | MouseEnter | (继承自 Control。)
公共事件 | MouseHover | (继承自 Control。)
公共事件 | MouseLeave | (继承自 Control。)
公共事件 | MouseMove | (继承自 Control。)
公共事件 | MouseUp | (继承自 Control。)
公共事件 | MouseWheel | (继承自 Control。)
公共事件 | Move | (继承自 Control。)
公共事件 | PaddingChanged | (继承自 Control。)
公共事件 | Paint | (继承自 Control。)
公共事件 | ParentChanged | (继承自 Control。)
公共事件 | PreviewKeyDown | (继承自 Control。)
公共事件 | QueryAccessibilityHelp | (继承自 Control。)
公共事件 | QueryContinueDrag | (继承自 Control。)
公共事件 | RegionChanged | (继承自 Control。)
公共事件 | Resize | (继承自 Control。)
公共事件 | RightToLeftChanged | (继承自 Control。)
公共事件 | Scroll | (继承自 ScrollableControl。)
公共事件 | SizeChanged | (继承自 Control。)
公共事件 | StyleChanged | (继承自 Control。)
公共事件 | SystemColorsChanged | (继承自 Control。)
公共事件 | TabIndexChanged | (继承自 Control。)
公共事件 | TabStopChanged | (继承自 Control。)
公共事件 | TextChanged | (继承自 Control。)
公共事件 | Validated | (继承自 Control。)
公共事件 | Validating | (继承自 Control。)
公共事件 | VisibleChanged | (继承自 Control。)
Top
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl 字段

AliQrCordControl 类型公开以下成员。

字段
 | 名称 | 说明
公共字段 | error |
Top
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.error 字段

AliQrCordControlerror 字段

[缺少 "F:淘宝登录.AliQrCordControl.error" 的 <summary> 文档]

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string error

字段值

类型：String
参见

引用

AliQrCordControl 类
淘宝登录 命名空间


AliQrCordControl.d 枚举

AliQrCordControld 枚举

[缺少 "T:淘宝登录.AliQrCordControl.d" 的 <summary> 文档]

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum d
成员
成员名称 | 值 | 说明
生成二维码 | 0 |
二维码已确认 | 1 |
二维码过期 | 2 |
登录成功 | 3 |
开始执行 | 4 |
验证码已发送 | 5 |
手淘点击确认 | 6 |
发送完毕 | 7 |
确认超时 | 8 |
参见

引用

淘宝登录 命名空间


AliQrCordControl.qrState 枚举

AliQrCordControlqrState 枚举

[缺少 "T:淘宝登录.AliQrCordControl.qrState" 的 <summary> 文档]

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public enum qrState
成员
成员名称 | 值 | 说明
未扫码 | 0 |
已扫码 | 1 |
已确认 | 2 |
已发码 | 3 |
登录成功 | 4 |
二维码超时 | 5 |
确认超时 | 6 |
参见

引用

淘宝登录 命名空间


AliQrCordControl.verifyStruct 类

AliQrCordControlverifyStruct 类

[缺少 "T:淘宝登录.AliQrCordControl.verifyStruct" 的 <summary> 文档]

继承层次
SystemObject
淘宝登录AliQrCordControlverifyStruct

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public class verifyStruct

AliQrCordControlverifyStruct 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | AliQrCordControlverifyStruct | 初始化 AliQrCordControlverifyStruct 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | _tb_token_ | 从cookie中获取
公共属性 | action |
公共属性 | cookie |
公共属性 | event_submit_do_validate |
公共属性 | fma | 地区码
公共属性 | fmc | 来源渠道
公共属性 | fmh | htoken
公共属性 | fmp | 电话号码
公共属性 | fmph | 验证码
公共属性 | fmpho | 固定
公共属性 | fmt | 来源渠道
公共属性 | refer |
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

淘宝登录 命名空间


AliQrCordControl.verifyStruct 构造函数

AliQrCordControlverifyStruct 构造函数

初始化 AliQrCordControlverifyStruct 类的一个新实例

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public verifyStruct()
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


verifyStruct 属性

AliQrCordControlverifyStruct 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | _tb_token_ | 从cookie中获取
公共属性 | action |
公共属性 | cookie |
公共属性 | event_submit_do_validate |
公共属性 | fma | 地区码
公共属性 | fmc | 来源渠道
公共属性 | fmh | htoken
公共属性 | fmp | 电话号码
公共属性 | fmph | 验证码
公共属性 | fmpho | 固定
公共属性 | fmt | 来源渠道
公共属性 | refer |
Top
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct._tb_token_ 属性

AliQrCordControlverifyStruct_tb_token_ 属性

从cookie中获取

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string _tb_token_ { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.action 属性

AliQrCordControlverifyStructaction 属性

[缺少 "P:淘宝登录.AliQrCordControl.verifyStruct.action" 的 <summary> 文档]

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string action { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.cookie 属性

AliQrCordControlverifyStructcookie 属性

[缺少 "P:淘宝登录.AliQrCordControl.verifyStruct.cookie" 的 <summary> 文档]

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string cookie { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.event_submit_do_validate 属性

AliQrCordControlverifyStructevent_submit_do_validate 属性

[缺少 "P:淘宝登录.AliQrCordControl.verifyStruct.event_submit_do_validate" 的 <summary> 文档]

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string event_submit_do_validate { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.fma 属性

AliQrCordControlverifyStructfma 属性

地区码

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fma { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.fmc 属性

AliQrCordControlverifyStructfmc 属性

来源渠道

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fmc { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.fmh 属性

AliQrCordControlverifyStructfmh 属性

htoken

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fmh { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.fmp 属性

AliQrCordControlverifyStructfmp 属性

电话号码

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fmp { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.fmph 属性

AliQrCordControlverifyStructfmph 属性

验证码

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fmph { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.fmpho 属性

AliQrCordControlverifyStructfmpho 属性

固定

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fmpho { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.fmt 属性

AliQrCordControlverifyStructfmt 属性

来源渠道

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string fmt { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


AliQrCordControl.verifyStruct.refer 属性

AliQrCordControlverifyStructrefer 属性

[缺少 "P:淘宝登录.AliQrCordControl.verifyStruct.refer" 的 <summary> 文档]

命名空间： 淘宝登录
程序集： Api.Framework (在 Api.Framework.dll 中) 版本：1.0.0.0 (1.0.0.0)
语法
C#
复制
public string refer { get; set; }

属性值

类型：String
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间


verifyStruct 方法

AliQrCordControlverifyStruct 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | FindPropertyInfo | 反射获取某个对象属性信息 (由 PluginExtend 定义。)
公共扩展器方法 | FindPropertyValue | 反射获取某个对象属性的值 (由 PluginExtend 定义。)
公共扩展器方法 | Sleep | 不卡界面休眠 (由 TaskExtend 定义。)
Top
参见

引用

AliQrCordControlverifyStruct 类
淘宝登录 命名空间